保存窗体

您完成窗体的修改后,就需要保存窗体。

默认情况下,窗体保存在 ClientFileDirectory 文件夹下。也可以把窗体保存到用户指定的文件目录下 - 有关详情,请参阅“工具” > “选项”。

注意: 您会发现,某些窗体的“另存为”性能不可用。这是因为[窗体设计器]对某些类型的 SunSystems 窗体的修改作了限制。

如要保存窗体:

  1. 从“文件”菜单,选择“保存”或单击“标准”工具栏上的“保存”按钮。现在您可以开始本地编译或检入该窗体了。
  2. 如您要用其他名称来保存窗体,请从“文件”菜单选择“另存为”。屏幕上出现“另存为”对话框。
    窗体类型
    选择一个窗体类型。如果是在完整模式状态下运行[窗体设计器],您能创建“用户”,“系统”或“SASI”窗体。
    窗体代码
    输入一个窗体代码来标识您的窗体。代码必须采用大写字母,长度不能超过八个字符。窗体代码会在窗体的窗口标题栏上显示。
    描述
    输入由字母数字组成的描述,最长为 100 个字符。系统会自动输入原窗体的描述。
  3. 单击“确定”。使用“另存为”可更改一个只读窗体的名称。