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Contacting Infor

If you have questions about Infor products, go to Infor Concierge at https://concierge.infor.com/ and select
Infor Customer Portal to create a case.

For the latest documentation, go to Documentation Central at docs.infor.com. We recommend that you check
this website periodically for updated documentation. If you have comments about Infor documentation,
contact documentation@infor.com.
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Chapter 1: Overview

Order-Based Production Management (OBPM) provides you with access to all the information required to
view, control, and manage your manufacturing orders.

You can immediately respond to problems on the shop floor without wasting time, steps, materials, and labor.
You can view details about the availability of components before releasing orders. Then, you can respond to
Material Resource Planning (MRP) recommendations for purchase and manufacturing orders to ensure smooth
production work-flow.

You can create, maintain, report activity on, complete and close orders directly from a variety of sources.
Besides creating or copying manufacturing orders, you can generate reorder recommendations by warehouse
and create manufacturing orders during generation. Using several objects in OBPM, you can view component
availability and adjust those components to fill manufacturing orders. You can use order and item shortage
reports to help you define the need for manufactured items. In several objects in OBPM,you can create
manufacturing orders to meet those shortages. With Customer Order Management (COM) installed, you can
review customer demand records and create manufacturing orders for customer order line item releases.
With MRP installed, you can create manufacturing orders using recommendations generated through an MRP
planning run.

After creating manufacturing orders, you can link them to customer orders or add bills of material and routings.
For manufacturing operations, you can add or delete milestones. You can print on demand shop packets,
work lists, and manufacturing order close transaction registers.

You can use OBPM to track manufacturing order labor and material processes associated with each order.
OBPM ensures each process is performed in sequence. For example, you can close a manufacturing order
only when the labor complete, receipt of material, and material complete operations are completed for the
order. Use Inventory Management (IM) and Production Control and Costing (PC&C) to perform the order
closeout and purge processes. Labor reporting must be performed in PC&C or Production Monitoring and
Control (PMC).

In addition to creating and maintaining manufacturing orders, you can use objects in OBPM to view and
maintain information related to purchasing and inventory. For example, in Reorder Recommendations, you
can create requisitions, purchase orders, and intersite orders.

OBPM does not split manufacturing orders but does support other functions on split orders. OBPM does not
create or release manufacturing orders for Knowledge Based Configurator (KBC) items but does support other
functions on an order for a KBC item.
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Chapter 2: Attendance reasons

You can create additional attendance reasons for the employee in addition to those shipped with the system.

For example, you can create an attendance reason for out sick (OS). Attendance reasons specify whether the
employee is in or out.

This table shows the attendance reasons that are shipped with the system.

SubtypeDescriptionReason

InEnd BreakEB

InEnd LunchEL

InEnd ShiftES

OutStart BreakSB

OutStart ShiftSS

OutStart WorkSW

Attendance reasons are used by attendance and labor to track and monitor the In and Out times of employees
on the shop floor. The employee’s first attendance and labor record is counted as an In record and begins a
attendance and labor elapsed time pair. The next attendance and labor record is counted as an Out record
and provides the ending time for the previous elapsed time record. Subsequent attendance and labor records
are paired in the same way until all records have been matched to create elapsed time pairs with In and Out
times.

Creating attendance reasons
1 Select Production > Monitoring > Administration > Attendance Reasons > Maintain > Create.
2 Complete the fields including this information:

Subtype
Select In or Out.

Reason
Specify a two character abbreviation for the attendance reason description.

3 Click Create.

Infor XA Order-Based Production Management | 14

 

Attendance reasons



Chapter 3: Component availability

Component shortages are calculated by comparing the total quantity of components required for all the
selected potential manufacturing orders against available components

If MRP is installed, you can consider future allocations of components as available when calculating shortages.
Future allocations are those that are required beyond the item's time phased allocation fence established in
MRP.

You can use the Component Availability object to perform these tasks:

• Substitute items for potential orders
• Add, change, or remove potential orders from the list
• Recheck component availability

Use the Check Component Availability option to view an analysis of all the potential manufacturing orders
and the required components in a selected subset from that object. This option is available from the Maintain
menu on from these objects:

• Item Warehouses
• Customer Demand
• MRP Recommendations
• Item Warehouses Reorder Recommendations

The Create Component Availability page contains these cards:

• Potential Orders
• Components
• Errors

From each card, you can view information for all orders and components or only orders and components for
which a shortage exists.

A potential order and its component items can have ties to information in other objects. Within the Component
Availability object, you can use Display menu options or toolbar buttons to see information in other objects
that is related to a selected potential order and its components.
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Checking component availability
Use the Check component availability option to analyze component availability for potential orders from
sources. Sources may be MRP recommendations, reorder recommendations, or customer demand. You can
check component availability for potential orders created from item warehouses.

1 Select orders or items for which to check component availability.
2 Select Maintain > Check Component Availability.
3 Complete the fields including this information:

Subset
Select a value from the list. This value is used by the source object to restrict the list of potential orders.
Note that the more records selected, the longer the process may take.

Consider future allocations as available
Select the check box to consider these components when availability is checked. This option is only
available if MRP is installed.

4 Click Create.
5 To create a list of all potential orders, click Create on the Create Component Availability page.

Checking component availability from Item Warehouses
Use the Check Component Availability task to search for available components related to a selected order.
The ability to check for available components enables you to consider alternatives if a specific component
is not available. Use this task to analyze interactively the availability of required components for one order
or a group of potential manufacturing orders. A group can be a subset of records or a group of selected orders.
You can view lists of all orders and components or only those orders and components that are short. You can
view what if component substitutions and order quantity changes.

1 Select an item warehouse record.
2 Select Maintain > Check Component Availability.
3 Complete the fields including this information:

Consider future allocations as available
Select the Consider future allocations as available check box for time phased allocations or
manufacturing allocations requiring time past the item lead time or the allocation horizon set in MRP.

4 Click Create.
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Add potential orders
You can add a single potential order or multiple potential orders to your list from other source objects. If
EPDM is installed, you have the option to choose the item revision and an associated item process when
adding an order.

When adding multiple orders, you can select potential orders from MRP Recommendations, Reorder
Recommendation, or Customer Demand. You can restrict the number and type of potential orders to add by
applying a subset to list.

Adding a single potential order
1 Select Maintain > Add Potential Order.

Optionally, you can click the + (Add Potential Order) icon on the Short or All tab on the Potential card.

2 Complete the fields including this information on the Single tab:

Warehouse
Specify the ID for the warehouse. This attribute is required.

Item
Specify the ID for the item. This attribute is required.

Item revision
Select an item revision, or click Find Item Revision to search for an item revision. This attribute is only
available if EPDM is installed. The default value is the current effective revision on the order start date.

Process
Click Find Process to search for an item process. This attribute is only available if EPDM is installed.

Order quantity
Specify the total number of components required for the order.

Scheduled start date
Select the order start date.

Due date
Select the order due date. If you do not specify a start date or due date, then the order start date and
the due date are calculated using the item, warehouse, required quantity, and start date.

3 Click Add.

Adding multiple potential orders
1 Select Maintain > Add Potential Order.

Optionally, you can click the + (Add Potential Order) icon on the Short or All tab on the Potential card.
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2 Click the Multiple tab.
3 Click the Multiple button.
4 Select one of these sources for the potential orders:

• Customer Demand

• Mrp Recommendation

• Reorder Recommendation

5 Select a subset from the Subset list or click Customize Subsets to create a new subset.
6 Click Add.

Changing component availability information for a
potential order
Use the Change option to change order quantity, warehouse, item revision, or process for a potential order.
1 Select an item line from the Short or All tab on the Potential Orders card.
2 Click the Change icon on the tab.
3 Change the necessary fields.
4 Click Update.

Substitute items for component availability orders
Use the Substitute item option when you want to substitute one component for another in your components
list for a potential order. For a planning activity, you can substitute available components for those in short
supply and recheck component availability before creating a manufacturing order.

You can use this option to substitute a component for a single order when working with components on the
Components card.

You can substitute components for all orders when viewing summarized components.

Substituting a single item for a component availability
1 Click the Components card tab on the Create Component Availability page.
2 Click one of these tabs:

• Short: View the component availability information for the records which show a shortage of
components for the potential orders
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• All: View component availability information for all the records you selected from the order source
object. The top level line represents summarized component information. Components for particular
orders are indented below the summarized component line.

3 Double-click the line with the component to substitute.
4 Select Maintain > Substitute item.
5 Specify this information:

Item
Specify the new item number or click Find Enterprise Item to search for the item.

Item revision
The default value is (current). Click Find Substitute Item Revision to search for a new item revision.

6 Click Substitute.

Substituting a component for all orders
1 Click the Components card tab on the Create Component Availability page.
2 Click one of these tabs:

• Short: View the component availability information for the records which show a shortage of
components for the potential orders

• All: View component availability information for all the records you selected from the order source
object. The top level line represents summarized component information. Components for particular
orders are indented below the summarized component line.

3 Select the line with the summarized component in the overview list.
4 Click the Substitute item icon on the current tab.
5 Specify this information:

Item
Specify the new item number or click Find Enterprise Item to search for the item.

Item revision
The default value is (current). Click Find Substitute Item Revision to search for a new item revision.

6 Click Substitute.

Rechecking component availability
Use the Recheck Component Availability option to recalculate available components for the potential orders
in your list after you perform these tasks:
• Add potential orders
• Remove orders
• Change orders
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• Substitute items

Select Maintain > Recheck Component Availability.

Deleting potential orders
When you remove an order from your list, use the Recheck Component Availability option to recalculate
component availability for the potential orders in the list.

1 Select the line from the potential orders list on the Short or All tab.
2 Click the Delete icon, then click Yes.
3 Select Maintain > Recheck Component Availability.

Creating manufacturing orders for a component
availability potential order
Use the Create Manufacturing Order(s) button to create manufacturing orders from the list of potential
orders. After you create a manufacturing order, you can view and make changes to the order in the
Manufacturing Orders object.

You can create manufacturing orders (M.O.s) in these ways:

• Create an M.O. from the individual orders selected in the potential orders list
• Create M.O.s for all orders in the list

1 Click one of these tabs:
• Short: View potential manufacturing orders for the selected records from the order source object

that have a shortage of components
• All: View all potential manufacturing orders for the selected records from the order source object

2 If creating an M.O. for an individual order, select the line in the Potential Orders card for which to create
the M.O..

3 Click the Create Manufacturing Orders icon on the current tab.
4 Click Yes.
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Chapter 4: Customer demand

The Customer Demand object contains information about the item releases associated with customer orders.

This information includes the dates requested and promised for delivery, quantities of the item on-hand,
available, on-order, and allocated from the specified warehouse, and release information.

A customer demand record can have ties to information in other objects. For example, the customer demand
record has a direct relationship with a customer order line item release and an item warehouse issuing the
line item. You can use the Display menu options to see more information in other objects that is related to
a selected customer demand.

This table shows Customer Demand related objects:

Viewable informationObject

A list of the kit components that must be available
to ship the item to the customer.

Kit Components

A list of the shipped items for the releases.Shipped Items

A list of the holds that have been placed against the
releases.

Customer Order Holds

A list of the allocations made for the release. If the
item is a kit, the allocations are for the component
items.

Discrete Allocations

A list of the manufacturing orders that respond to
demand created by a customer order line item.

Sources of Demand

A list of the closed and purged manufacturing orders
used to produce the item.

Manufacturing Order History

A list of the item locations associated with the line
item.

Item Locations
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Checking component availability
Use the Check component availability option to analyze component availability for potential orders from
sources. Sources may be MRP recommendations, reorder recommendations, or customer demand. You can
check component availability for potential orders created from item warehouses.

1 Select orders or items for which to check component availability.
2 Select Maintain > Check Component Availability.
3 Complete the fields including this information:

Subset
Select a value from the list. This value is used by the source object to restrict the list of potential orders.
Note that the more records selected, the longer the process may take.

Consider future allocations as available
Select the check box to consider these components when availability is checked. This option is only
available if MRP is installed.

4 Click Create.
5 To create a list of all potential orders, click Create on the Create Component Availability page.

Creating a manufacturing order from a customer demand
1 Select a customer demand record that has an item.

The record cannot already have a manufacturing order.

2 Select Maintain > Create M.O..
3 Complete the fields including this information:

Item revision
Specify the revision for the order. This attribute is available if EPDM is installed and active.

Total order quantity
Specify the order quantity. The order quantity must be greater than zero.

Scheduled start date
Select the scheduled start date. The due date is calculated from this date if a date is not specified.

Due date
Select the due date. The scheduled start date is calculated from this date if a date is not specified.

Create M.O.s for configured components
Select the check box to create M.O.s for configured components that belong to a configured parent item.
This option is valid only if Advanced Planning Configurator (APC) is installed and the customer order
line item is associated with an APC item.

4 Click Create.
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Mass creating manufacturing orders from customer
demands
1 Select the customer demand records.
2 Select Maintain > Mass Create M.O..
3 Specify a reason code if reason code tracking is required.
4 Complete the fields including this information:

Subset
Select a value from the list to narrow the list.

Create M.O.s for configured components
Select the check box to create M.O.s for configured components that belong to a configured parent item.
This option is valid only if Advanced Planning Configurator (APC) is installed and the customer order
line item is associated with an APC item.

5 Click Create, then click OK.

Generating a pick list for a customer demand host job
Pick lists are documents that reflect the picking process. You generate pick lists to identify the items that
warehouse personnel need to remove from stock and ship-to customers. Warehouse personnel use the pick
list as an authorization to pick material. The shipment or packaging personnel use the pick list as a statement
of what was picked. The pick list can be used to confirm shipments. Depending on the needs of your company,
inventory counters can use the pick list as a turnaround document to report actual picks for inventory control.

You can generate a pick list using customer orders, customer demand records, quotes, standing orders, and
credit memos. When you generate a pick list for customer orders, you can use any customer order, customer
order line item, or customer order line item release that is not on hold. However, a pick list may not be
processed for items on credit memos that are credited to the customers account but not returned to stock.

1 Select the customer demand records.
2 Select File > Host jobs.
3 Select the Execute check box.
4 Complete the fields under Content.
5 Specify this information on the Options - General tab::

Pick Consolidation
Select a value from the list. These values are valid:
• Default to company: Use this value to default the preferences defined in the Companies object to

determine how the pick list is consolidated
• One order, one ship-to: Use this value to create a pick list for an order to one ship-to address
• One order, all ship-tos: Use this value to create a pick list for an order to all the ship-to addresses

specified on the order
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• All orders, one ship-to: Use this value to create a pick list for all orders that are to be sent to one
ship-to address

• All orders, one customer: Use this value to create a pick list for all orders for one customer
• All orders, all customers: Use this value to create a pick list for all orders that require shipping

Pick short stock quantity
Select a value from the list. If the item quantity on the pick list is more than the quantity of the item you
have in stock, you can print the pick list the quantity you have in stock or print both the quantity required
and the quantity in-stock. These values are valid:
• Ignore short stock: Use this value to generate a regular pick list. When you select this value you

cannot use the Automatic pick confirm attribute.
• Short stock, on-hand quantity: Use this value to generate a pick list that shows the quantity of the

item that is in stock when the quantity in stock is less than the quantity the customer ordered. When
you select this value, the Discrete allocation attribute defaults to Yes and is not maintainable.

• Short stock, next pick quantity: Use this value to generate a pick list that shows the quantity of
the item that is in stock when the quantity in stock is less than the quantity the customer ordered.
The pick list shows the quantity the customer ordered. When you select this value, the Discrete
allocation attribute defaults to Yes and is not maintainable.

Automatic pick confirm
Select this check box to have the transactions to move the items to the staging location generated.
Select the check box when you select the Short stock, on-hand quantity or Short stock, next pick
quantity value.

Discrete allocation
Select this check box to allocate the items to the order to prevent the items from being used elsewhere.
Select the check box when you select the Ignore short stock value.

6 Click the Options - Print tab, then specify this information:

Print pick list
Select the check box to automatically print a pick list when you generate the pick list. If you print a pick
list, you can specify what prints on the list and in what format.

Item barcodes
Select the check box to print item numbers as bar codes on the pick list.

Location barcodes
Select the check box to print item locations as bar codes on the pick list.

Print kit components
Select the check box to include component items on the documents printed for any order that contains
a kit item.

Space for serial numbers
Select the check box to leave space on the pick list to enter serial numbers for the items picked.

Sequence
Select the value that specifies the sequence in which available items for picking should be printed.
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Location options
Select the value that specifies how to select locations to print on the pick list. You can only use these
options with a controlled warehouse. These values are valid:
• Number to fill order: Use this value to print locations with stock until enough is located to fill the

order
• Number plus additional: Use this value to print locations with stock until enough is located to fill

the order and print the number of additional locations specified
• All: Use this value to print locations with stock until enough is located to fill the order and print the

number of additional locations specified
• Number plus low quantity: Use this value to print locations with stock until enough is located to fill

the order and print all locations with a quantity of ten percent or less of the order amount

Additional locations
If you select Number plus addition, specify the default value for this attribute to specify the number of
extra locations with stock. This value is in addition to the locations needed to pick the order. Additional
locations are searched in the same sequence, by location or FIFO, as the other locations.

Print pro forma packing list
Select the check box to print a pro forma packing list when the pick list is generated.

7 Click the E-mail tab, then specify the information.
8 Click Submit.
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Chapter 5: Departments

The Departments object contains information about the departments associated with employees.

Any department assigned in the Employee object must exist in the Department object.

Creating departments
1 Select Production > Monitoring > Departments > Maintain > Create.
2 Complete the fields.
3 Click Create.

If you select Preview before create, you can specify additional information on the General card tab.
Additionally, you can create employees on the Employees Activateand Terminated tab.
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Chapter 6: Discrete allocations

The Discrete Allocations object contains information for all locations where a specific quantity of an item has
been allocated to a specific order.

For each item in a warehouse that has discrete allocations, this information is displayed:

• Location
• Inventory qualifiers such as batch/lot number or FIFO date
• Quantity allocated
• Order that owns the allocations
• Total on-hand quantity of the item

An item can be allocated if the Discrete allocations attribute in the Items or Item Revisions object has a value
of Yes. With discrete allocations, items from a specific location or particular batch/lot or FIFO date can be
reserved for a specific customer or manufacturing order. A C.O. line item can have a discrete allocation if the
line item is not a blanket item. Discrete allocations for blanket items can only be created at the C.O. line item
release level.

These allocations types are supported by XA applications:

• None: No allocation
• Item balance: Updates the quantity in the Pick List Requirements attribute (PKREQ) in the Item Balance

file but does not create a detailed allocation
• Discrete allocation: Updates the quantity in the Pick List Requirements (PKREQ) attribute in the Item

Balance file and creates records in the Allocation Quantity file (SLALLO) and the Location Quantity file
(SLQNTY)

• Auto discrete: Updates the Pick List Requirements attribute (PKREQ) in the Item Balance file and creates
records in the Allocation Quantity file (SLALLO) and the Location Quantity file (SLQNTY)

You can only allocate inventory manually for items that have an allocation type of discrete allocation.

A discrete allocation record can have ties to information in other objects. For example, an allocation can have
an order in the Customer Orders object. You can use the Display menu options to see more information in
other objects that is related to a selected discrete allocation.

This table shows discrete allocations related objects:

Viewable informationObject

A list of the items associated with the discrete allo-
cation

Item
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Viewable informationObject

A list of the item warehouses associated with the
discrete allocation

Item Warehouse

A list of the item locations associated with the dis-
crete allocation

Item Location

A list of the customer orders or quotes associated
with the discrete allocation

Customer Order or Quote

A list of the customer order line items associated
with the discrete allocation

C.O. Line Item

A list of the customer order blanket releases associ-
ated with the discrete allocation

C.O. Line Item Release

A list of the manufacturing orders associated with
the discrete allocation

Manufacturing Order

A list of the manufacturing order component items
associated with the discrete allocation

M.O. Component

A list of the schedules associated with the discrete
allocation

Schedule

A list of the schedule component items associated
with the discrete allocation

Schedule Component

A list of the warehouses from which the item has
been allocated

Warehouse

A list of the locations in the warehouse from which
the item has been allocated

Warehouse Location

Running the Publish Discrete Allocations job
The Publish Discrete Allocations host job sends current information, for selected discrete allocations, from
XA to specified destinations using System-Link. You can choose to publish a single discrete allocation, manually
selected discrete allocations, or discrete allocations in a subset. For more information, contact your System-Link
administrator.

1 Select File > Host Jobs.
2 Select the Execute check box if not selected.
3 Complete the fields including this information:

Replication
Specify the System-Link destination to which to send the discrete allocation information. If you leave
the replication destination blank, the replication destination specified for the individual discrete
allocations is used.
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4 Click the E-mail tab, then specify the information.
5 Click Submit.
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Chapter 7: Employee absence

Absence records can be created for all employees by employee ID in the Employee Absence object.

After an employee absence request is created, management can review and reject or approve the request.
Absence requests cannot overlap times and dates for any given employee.

A valid employee ID is required to create, approve, or reject an absence request. When an employee absence
request is maintained a lock is placed on the employee absence file for that employee. This lock prevents
others from maintaining the same employee absence request.

Creating employee absences
1 Select Production > Monitoring > Administration > Employee Absence > Maintain > Create.
2 Complete the fields including this information:

Employee id
Specify the employee ID or click Find Employee to search for an employee.

Reason
Select a reason for the absence. These values are valid:
• Vacation

• Absent

• Late

Type
Specify the one-character code assigned by your company for the type of absence requested.

3 Click Create.

Approving an employee absence
You can only approve an employee absence request with a status of R or X.

1 Select the employee absence request.
2 Select Maintain > Approve.
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3 Click Employee Absence Approve.
The status of the employee absence request is changed to A.

Rejecting an employee absence
You can only approve an employee absence request with a status of R or A.

1 Select the employee absence request.
2 Select Maintain > Reject.
3 Click Employee Absence Reject.

The status of the employee absence request is changed to X.
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Chapter 8: Employee activity

The Employee Activity object shows all the transactions collected for an employee.

The transaction activity that is shown for employees can come from any of these applications:

• Materials Management (MM) - Inventory Management (IM)
• Customer Service Management (CSM) - Customer Order Management (COM)
• Order-Based Production Management (OBPM), includes shop floor activity

Transactions from Production Monitoring and Control (PMC) when shop floor is not activated are not included
in OBPM. Therefore, these transactions cannot be viewed in the Employee Activity object. Transactions from
Repetitive Production Management (REP) are also not included.

The employee badge ID or user ID from a transaction is used to create employee activity records. The user ID
must be linked to an employee.

Employee activity records are linked to the Inventory Transaction History records and the Labor Activity
records. Note that no option to turn off employee activity is available.
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Chapter 9: Employees

The Employee object contains the business relationship type, business role assignment for shop floor workers,
employee ID, badge number, and other employee information. The Employee object does not contain any
employee payroll information.

Shop floor supervisors may add employees who report attendance and labor activity. While shop floor and
materials management supervisors may add employees who report materials and inventory activity. Though,
any user can add an employee.

The Employee Master object in IBM i Production Monitoring and Control (PMC) application has been split into
these parts: Payroll Employee maintenance located in PMC and Employee object located in IDF.

All employee information that pertains to payroll continues to be created in Payroll Employee maintenance.
Employees that are created in the Payroll Employee object are automatically created in the Employee object.
The Payroll attribute on the Employees page shows as Enrolled.

The Employee object is used by these applications:

• Production Monitoring and Control (PMC)
• Contract Accounting (CA)
• Executive Information System (EIS)
• Order Based Production Management (OBPM)
• Inventory Management (IM)
• Materials Management (MM)
• Procurement Management (PM)
• Production Control and Costing (PCC)

The Employee object contains these unique keys:

• Employee ID is the primary key. The employee ID can be manually added or auto-generated when an
employee is created.

• Shop Floor ID is a 5-digit badge number. The Shop Floor ID is required if reporting activity in Production
Monitoring and Control (PMC). This ID can be used if specifying a badge in MM and PCC. The Shop Floor
ID can have an associated shop floor temporary ID, badge containing five numbers, which is also unique.

Therefore, if an employee ID is not deleted when an employee is terminated, then the badge number can be
reused.

You can specify an employee as a shop floor employee, which enables you to specify work schedule information
for the employee.
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Creating employees
If the employee is paid through XA payroll, use the XA Payroll employee maintenance application accessed
through the emulator. After the employee information is entered, an IDF employee record is auto generated.

1 Select Production > Order Based > Employees > Maintain > Create.
2 Complete the fields including this information:

Template
Select a template to show only the attributes relevant to the purpose of the template. If you are creating
a shop floor employee, select Shop floor.

Employee ID
The employee ID is auto generated but can be changed.

Relationship type
Select the relationship of the employee to the company. These values are valid:
• Employee
• Partner
• Sub-contractor
• Other

Company
Specify the code that identifies the company for which the employee works, or click Find Company and
select a company from the list.

Department
Specify the department where the employee works, or click Find Departmentand select a department
from the list. The department must be defined in the Department object.

Work schedule
Specify a code for the work schedule, or click Find Work Schedule and select a work schedule from the
list. This attribute is displayed when you select the Shop floor template.

Multi-job flag
Select this check box to indicate that the employee is authorized to work more than one job at a time.
This attribute is displayed when you select the Shop floor template.

3 Click Create.
If you select Preview before create, you can specify additional information on the General card tab.

Changing employee information
If the employee is enrolled in payroll, then most of the attributes are display only and cannot be changed
except through the Payroll Employee maintenance.

1 Select the employee record from the Employee list.
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2 Select Maintain > Change.
3 Change the necessary fields.
4 Click Update.

Viewing employee activity
1 Select the employee record from the Employees list.
2 Select Display > Employee details.
3 Click the Activity card tab.
4 Optionally, you can view employee activity by selecting Production > Activity > Employee Activity.

Use the filter row to sort the list by Name, Order, and so on. For example, you can sort by Source to view
activity by transaction source such as by OBPM shop floor or by Status such as by I = In process.

Deleting employees
Before deleting an employee record, ensure that the employee does not have any employee absence requests.
If employee absence requests exist for the employee, delete the requests, then delete the employee.

Note: If the employee is enrolled in XA payroll, then you cannot delete the employee from the Employee
object. They can only be deleted from the Payroll Employee maintenance.

1 Select the employee record from the Employee list.
2 Select Maintain > Delete.
3 Click Yes.

Terminating employees
To terminate an employee, the employee must have a relationship type of Employee and not be enrolled in
XA payroll. If the employee is enrolled in XA payroll, then the employee must be terminated using the Payroll
Employee Termination/Activation maintenance.

1 Select the employee in the Employees list.
2 Select Maintain > Terminate.
3 Specify the termination date.
4 Click Continue.
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Rehiring employees
Note that employees enrolled in XA payroll cannot be re-hired through the Employees object. Instead, you
must use XA Payroll Employee Termination/Activation maintenance to rehire them.

1 Select an employee in the Employees list.
2 Select Maintain > Re-Hire.
3 Specify the rehire date.
4 Click Continue.

Suspending employees
You can only suspend employees with these relationship types:

• Partner
• Subcontractor
• Other

1 Select the employee in the Employees list.
2 Select Maintain > Suspend.
3 Click Yes.

Activating employees
You can only activate employees with these relationship types that have a Status of Inactive:

• Partner
• Subcontractor
• Other

1 Select the suspended, or inactive, employee in the Employees list.
2 Select Maintain > Activate.
3 Click Yes.

Reporting M.O. operation activity for employees or labor
activities
This task is for reporting M.O. operation activity from the Employees or Labor Activity object.

Infor XA Order-Based Production Management | 36

 

Employees



Use the Report M.O. Operation Activity transaction for reporting quantities, scrap, machine, and labor times
for an M.O. Operation.

This transaction is only available if Shop Floor is active in OBPM application settings.
1 Select one of these options:

• Select Order Based > Employees. Then, select the employee in the list.
• Select Activity > Labor Activity. Then, select the labor activity in list.

2 Select Maintain > Report M.O. Operation Activity.
3 Complete the fields including this information:

Template
Select a template to show only the attributes relevant to the purpose of the template. For example,
select the Milestone template to report the activity as a milestone operation.

Order
Specify the order number of the operation on which the employee is working. If you selected a labor
activity, this attribute is automatically populated.

Operation
Specify the operation of the operation on which the employee is working. If a labor activity transaction
is selected, this attribute is may be automatically populated.

Run type
Select the type of run for the activity. These values are valid:
• Setup
• Run
• Milestone group: This value can only be used with a milestone operation
This attribute is displayed when you select the Default or Scrap quantity template.

Completion code
These values are valid:
• 0=Open: Not complete. Quantity can be reported.
• 1=Complete with entered quantity: You must specify quantity with this completion code.
• 2=Complete with defaulted: You do not specify quantity with this completion code. The quantity is

assumed to be the quantity still open for the operation.
• 3=Milestone: Closes all milestone sub-operations and set the operation status to complete. This

completion code can only be used with a Run code of M.

Complete
Specify the quantity that is complete. This attribute is displayed when you select the Default, Milestone,
and Setup template.

Scrap
Specify the scrap quantity. This attribute is displayed when you select the Default, Scrap quantity, and
Setup template.

Reason
Select a reason for the scrap. If reason codes are specified in the Transaction Reasons object, you must
select a reason for the scrap. If your company does not require reason codes, blank is a valid entry.
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Labor
Specify the amount of labor time in hours or minutes. If the Time basis code for M.O. Operation is not
M (minutes), then the labor time is assumed to be hours. If the Time basis code is M (minutes), then the
labor time is assumed to be minutes. For an operation in a milestone group type F (flow shop
environment), labor time entry is not accepted.

Machine
Specify the amount of machine time in hours or minutes. If the Time basis code for M.O. Operation is
not M (minutes), then the machine time is assumed to be hours. If the Time basis code is M (minutes),
then the machine time is assumed to be minutes. This attribute is not valid for a milestone group
sub-operation. This attribute is displayed when you select the Default or Setup template.

Reference
Specify information for reference purposes.

Transaction cost
Optionally, specify the cost for the transaction. If using standard rates as actual costs, this cost overrides
that cost. If using actual employee costs, this cost overrides that cost as well. This attribute is displayed
when you select the Default or Setup template.

Actual work center
Specify the work center being used for the operation. You can specify an override work center only for
the first transaction for an operation. This attribute is displayed when you select the Default or Setup
template.

Badge
Specify the employe badge number. This attribute is mandatory. If an employee record is selected, this
attribute is automatically populated.

Rate override
This attribute is displayed when you select the Default or Setup template.

Shift override
Specify 1, 2,or 3 for the shift override. This attribute is displayed when you select the Default or Setup
template.

Turnaround
Specify the turnaround number of the operation on which the employee is working.

4 Click Continue.

Attendance and labor
Use the Attendance and Labor menu to select these transactions:

• Start Labor (ON)
• Stop Labor (OF)
• Start Work (SW)
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• End Work (EW)

Attendance and labor review and approval is required if Review attendance and labor before approval is
set to Manual in the OBPM - Shop Floor application setting.

You can only approve attendance and labor transactions when Review attendance and labor before approval
is Automatic.

Starting labor for an employee
Use the Start Labor (ON) transaction to show that an employee is clocking onto a job and to specify the kind
of labor required for the job. Start Labor (ON) cannot be created for Flow-shop milestone.

1 Select Order Based > Employees.
2 Select the employee in the list.
3 Select Maintain > Attendance and Labor > Start Labor (ON).
4 Complete the fields including this information:

Order
Specify the order number of the operation on which the employee is working. If you selected a labor
activity, this attribute is automatically populated.

Operation
Specify the operation of the operation on which the employee is working. If a labor activity transaction
is selected, this attribute is may be automatically populated.

Run type
Select the run type for this transaction. The value indicates the kind of labor required for the job associated
with this transaction. These values are valid:
• Setup: Code used to report work spent in preparing an M.O. operation. Time can include changing

dies and tools, moving material to the facility, or performing testing.
• Run: Code used to report actual work on an operation. Time can include welding, assembly. packaging,

etc.
• Indirect: Code used to report work that is not against an M.O. operation. Time can include sweeping,

cleaning, and attending meetings.
• Milestone: Code used to report activity or work against the final operation in a milestone group.

Crew
Select the check box to indicate that the employee is part of a work crew.

Badge
Specify the employe badge number. This attribute is mandatory. If an employee record is selected, this
attribute is automatically populated.

Turnaround
Specify the turnaround number of the operation on which the employee is working.

5 Click Continue.
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Stopping labor for an employee
Use the Stop Labor (OF) transaction to show that an employee is clocking off a job and to specify the kind of
labor required for the job. A corresponding Start Labor (ON) transaction is required unless you are tailored
for OF only processing, reporting scrap against a milestone operation, or reporting against a flow-shop
milestone.
1 Select Order Based > Employees.
2 Select the employee in the list.
3 Select Maintain > Attendance and Labor > Stop Labor (OF).
4 Complete the fields including this information:

Order
Specify the order number of the operation on which the employee is working. If you selected a labor
activity, this attribute is automatically populated.

Operation
Specify the operation of the operation on which the employee is working. If a labor activity transaction
is selected, this attribute is may be automatically populated.

Run type
Select the run type for this transaction. The value indicates the kind of labor required for the job associated
with this transaction. These values are valid:
• Setup: Code used to report work spent in preparing an M.O. operation. Time can include changing

dies and tools, moving material to the facility, or performing testing.
• Run: Code used to report actual work on an operation. Time can include welding, assembly. packaging,

etc.
• Indirect: Code used to report work that is not against an M.O. operation. Time can include sweeping,

cleaning, and attending meetings.
• Milestone: Code used to report activity or work against the final operation in a milestone group.

Completion code
Select a completion code. These values are valid:
• 0=Open: Not complete. Quantity can be reported.
• 1=Complete with entered quantity: Specify quantity with this completion code.
• 2=Complete with defaulted: Do not specify quantity with this completion code. The quantity is

assumed to be the quantity still open for the operation.
• 3 = Milestone: Closes all milestone sub-operations and sets the operation status to complete. Can

only be used with Run code of M.

Reason
Select a reason for the scrap. If reason codes are specified in the Transaction Reasons object, you must
select a reason for scrapping. If your company does not require reason codes, blank is a valid entry.

Reference
Specify information for reference purposes.
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Crew
Select the check box to indicate that the employee clocked off the job as part of a work crew. Machine
time is calculated only if the Crew check box is not selected for both a Start Labor (ON) transaction and
the matching OF transaction.
Crew clock transactions can be used with multiple employees to clock on or off the same job without
reentering the transaction detail information. The first employee clocks on or off using the normal ON
or OF transaction. The other employees then specify a Crew Clock (CC) transaction that PM&C converts
to an ON or OF transaction with the same time, order, and operation information as the original
transaction.

Badge
Specify the employe badge number. This attribute is mandatory. If an employee record is selected, this
attribute is automatically populated.

Turnaround
Specify the turnaround number of the operation on which the employee is working.

5 Click Continue.

Starting work
Use the Start Work (SW) transaction to specify when an employee starts a shift, starts work, ends a break, or
ends lunch.

1 Select one of these options:
• Select Order Based > Employees.
• Select Activity > Shop Floor Activity.

2 Select the employee in the list.
3 Select Maintain > Attendance and Labor > Start Work (SW).
4 Complete the fields including this information:

Transaction date
The value for this attribute is automatically populated but you can change the value. Click the Select a
Date icon to change the date.

Transaction time
The value for this attribute is automatically populated but you can change the value.

Reason
Select the reason for starting work. These values are valid:
• EB = End Break
• EL = End Lunch
• SS = Start Shift
• SW = Start Work

5 Click Continue.
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Ending work
Use the End Work (SW) transaction to specify when an employee ends a shift, ends work, starts a break, or
starts lunch.

1 Select one of these options:
• Select Order Based > Employees.
• Select Activity > Shop Floor Activity.

2 Select the employee in list.
3 Select Maintain > Attendance and Labor > End Work (EW).
4 Complete the fields including this information:

Transaction date
The value for this attribute is automatically populated but you can change the value. Click the Select a
Date icon to change the date.

Transaction time
The value for this attribute is automatically populated but you can change the value.

Reason
Select the reason for starting work. These values are valid:
• SB = Start Break
• SL = Start Lunch
• ES = End Shift
• EW = End Work

5 Click Continue.

Printing employee badges
Use the Badges report to print badges for one or more employees.

• Is active
• Is terminated and the termination date is greater than or equal to current dateEmployee badges are only

printed for employees that have shop floor roles assigned and match one of these conditions:

1 Select Production > Order Based > Employees > File > Host Print.
2 Select the Print check box on the Badges tab.
3 Specify this information:

Subset
Select a value from the list. These values are valid:
• (all records): Select to print badges for all records
• Active employee: Select to print badges for all active employees
• Badge: Select to print badges by badge numbers
• Name contains: Select to be able to specify a name.
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• Payroll employee: Select to print badges for all payroll employees
• Shop floor: Select to print badges for all shop floor employees
• Terminated employee: Select to print badges for all terminated employees

Sort
Select a value from the list. These values are valid:
• (none)
• (default)
• Display name
• First name
• Last name

4 Select the E-mail tab, then specify the information.
5 Optionally, select the Attachments tab to add attachments.
6 Click Submit, then click OK to confirm.
7 If you selected Name contains for the Subset, specify the name or initial, then click Continue.

Running the Publish Employees job
The Publish host job creates one record for the employee and one for the shop floor role assigned to the
employee, if one is assigned. For more information, contact your System-Link administrator.

1 Select Production > Order Based > Employees > File > Host Jobs
2 Select the Publish tab.
3 Select the Execute check box.
4 Complete the fields including this information:

Replication destination
In the Options section, specify the System-Link destination to which to send the employee information.
If you leave the replication destination blank, the replication destination specified for the individual
employee is used.

5 Select the E-mail tab, then specify the information.
6 Click Submit.

You can track the progress of the Publish host job in the Transaction Status object. Troubleshooting logs
may display in the Transaction Status when logging is configured in System-Link by your administrator.
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Chapter 10: Facilities

A facility is a group of machines with similar characteristics that are used to perform a manufacturing process.

For example, an assembly area or milling machine center. A facility, often called a production facility, can be
a work center, production line, or work station.

How you use these terms depends on the needs of your company though some restrictions exist. For example,
routings can contain work stations or work centers but not production lines. Production lines can be made
up of a combination of work stations and work centers.

Work stations are usually designated work areas along a production line located relatively close to each other.
They may be linked together by material handling devices such as transport belts or robotics material handlers.
Work centers can perform stand-alone operations and generally are not a part of a production line.

A facility can have ties to information in other objects. For example, if a facility is used to create a manufactured
order, that facility will have an order in the Manufacturing Order Operations Where-Used object. You can use
the Display menu options to see more information in other objects that is related to a selected facility.

This table shows facility related objects:

Viewable informationObject

A list of facility capacities with start and end times
sorted by site

Facility Capacity Overrides

A list of where the facility is usedRouting Operations Where-Used

A list of the manufacturing order operations which
exist for a production facility sorted by manufactur-
ing order

M.O. Operations Where-Used

A list of the manufacturing order history operations
which exist for a production facility sorted by manu-
facturing order

M.O. Operation History Where-Used

A list of the production line items for a production
facility sorted by item

Production Line Items

A list of the scheduled items that exist for a produc-
tion facility sorted by dates due and item

Schedules

A list of schedule operations which exist for a produc-
tion facility sorted by schedule and operation

Schedule Operations Where-Used
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Viewable informationObject

A list of the schedules associated with the discrete
allocation

Schedule

A list of the schedule component items associated
with the discrete allocation

Schedule Component

A list of the warehouses from which the item has
been allocated

Warehouse

A list of the locations in the warehouse from which
the item has been allocated

Warehouse Location

Facility where used

Facilities where-used shows the routing operations where the facility is used. The manufacturing routing for
an item is a sequence of operations that provide a connection between the item and the appropriate facility
for each operation in the routing. Thus, options under the Display and Maintain menus show a Routings list
page or card file.

Creating facilities
1 Select Production > Oder Based > Facilities > Maintain > Create.
2 Complete the fields including this information:

Site
Specify the number of the site.

Facility
Specify the name of the facility.

3 Click Create.
If you select Preview before create, you can specify additional information on the General card tab.

Printing a Facility Master Report
You use the Facility Master Report host print option to show information about the facility.

1 Select Production > Order Based > Facilities > File > Host Print.
2 Select the Print check box on the Facility Master Report tab.
3 Complete the fields on the Content tab.
4 Click the E-mail tab, then specify the information.
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5 Optionally, click the Attachments tab to add attachments.
6 Click Submit.

Printing a Facility Where-Used report
Use the Facility Where-Used report host print to show information about the routings where the facility is
used.

1 Select Production > Order Based > Facilities > File > Host Prints.
2 Click the Facility Where-Used tab.
3 Select the Print check box.
4 Complete the fields on the Content tab.
5 Click the E-mail tab, then specify the information.
6 Optionally, click the Attachments tab to add attachments.
7 Click Submit.

Running the Publish Facilities job
Use the Publish Facilities host job to send current information, for selected facilities, from XA to specified
destinations using System-Link. You can choose to publish a single facility, manually selected facilities, or
facilities in a subset. For more information, contact your System-Link administrator.

1 Select Production > Facilities > File > Host Jobs.
2 Select the Execute check box.
3 Complete the fields including this information:

Replication destination
In the Options section, specify the System-Link destination to which to send the facility information. If
you leave the replication destination blank, the replication destination specified for the individual facility
is used.

4 Click the E-mail tab, then specify the information.
5 Click Submit.

Facility capacity override
The Facility Capacity Override object contains information related to production capacity for each shift in a
production facility.
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You see the start and end dates when the variable capacity is available, the source description, the available
shift hours, and the available capacity (resources) for each shift.

Facility Capacity Override contains information that relates the facility to other XA objects. For example, you
can view the daily capacity overrides available for production lines. Use the option under the Display menu
to see information in other objects related to a selected production facility. You also can use the option under
the Maintain menu to work with information in other objects related to a selected production facility.

Facility capacity daily override
The Facility Capacity Daily Override object contains information related to production capacity for each shift
on a production line.

The object shows overrides to the base hours specified in the Production Facility object, if PDM is installed,
or the Facility object, if EPDM is installed. You see the availability date when the variable capacity is available,
the available shift hours, and the available capacity (resources) for each shift.

Facility Capacity Daily Override contains information that relates the override to the Production Facility or
Facility object. Within the Facility Capacity Daily Override object, you can use the option under the Display
menu to see information in the Production Facility or Facility object. You can use the option under the Maintain
menu to work with information in the Production Facility or Facility object.
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Chapter 11: Items

Items are components, materials, purchased parts, finished goods, and any other type of object your company
manufactures or sells to customers.

Items are those things that you use, produce, cost, and stock. Items are identified by unique item numbers.
To define an item, you must add a record to the Items object and specify this information:

• Unique item number
• Item description
• Item type
• Unit of measure for the item

This information depends on the type of item and the type of information required by your company. You
can select from these item types:

• Phantom
• Assembly or subassembly
• Fabricated item
• Raw material
• Purchased item
• User option
• Feature
• Kit

Typically, you start by defining your end items, then define the purchased parts and raw materials that you
use to build the end items.

Item records are related to other records. For manufactured items, items are the basis for engineering records
such as bills of material and routings. Purchase orders and customer orders reference item records in the
details of the orders.

When you use an item on a customer order, manufacturing order, or purchase order, you must have a record
in the Items object. Any item on an open customer order, manufacturing order, or purchase order cannot be
deleted from the Items object.

You can use the Pricing task on the Items object to calculate a selling price for an item without specifying the
item on an order or quote.
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Pricing an item
Use the Pricing task to calculate a selling price for an item without specifying the item on an order or quote.
The price is calculated using the values you specify in the Price Inquiry page. The price is displayed on Price
Inquiry cards with details of how the price was calculated. Information is not saved when the Price Inquiry
cards are closed.

1 Select Materials > Inventory > Items.
2 Optionally, select an item in the Items list page.
3 Select Maintain > Enterprise Item options > Pricing
4 Complete the fields including this information:

Contract
Specify the ID of the contract that is associated with the customer. The negotiated customer contract
price for that item takes precedence over the calculated selling prices.

Price book
Specify the code defined by your company to identify the price book for this item. Each price book can
have multiple versions based on the effective date.

Price group
Specify the code used to group items into categories for pricing.

Total price class quantity
Specify the total quantity of items in the item price class that must be ordered for the target group
discount percent to be applied.

Unit price discount %
Specify the discount or markup percent applied to the unit price when calculating the selling price. A
negative value indicates a markup percent.

5 Click Continue.

Item base prices
The Item Base Price object shows information about a selected base price defined for an item.

An item can have multiple base prices. However, only one base price is in effect at a time. The effective date
for the base price shows the date on which the price becomes effective.

A base price can be created when creating or changing an item in the Items object. Use the Item Base Price
object to view information about a base price. You cannot create or change a base price in the Item Base Price
object.

You can use the Item Price List report to view all possible base prices, or a subset of base prices, for an item
based on the effective date, currency ID, and price book ID.
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Viewing an item base price
Item base prices are maintained in the Items object. You cannot change a price directly in the Item Base Price
object. You can view information about the price and effective date.

1 Select the item in the Items list page.
2 Select Display > Item details.
3 Select the Sales card tab, then select the base price to use as the base, or starting point, for the comparison.
4 Click the Item Base Price details button under Base Prices, or double-click the selected base price.
5 Click Continue to return to the Item card file.

Printing the Item Price List report
Use this report to view all possible base prices, or a subset of base prices, for items based on the effective
date, currency ID, and price book ID. The Item Base Prices object is not included on any shipped application
cards but you can add it.

1 Select File > Host Print in the Item Base Prices list page.
2 Select the Print check box if not already selected.
3 Complete the fields including this information:

Effective date
Specify the date that the base prices are effective.

Currency ID
Specify the currency identifier (ID) for the item base prices.

Price book ID
Specify the ID of the price book used to calculate the selling price of the item.

4 Select the E-mail tab, then specify the information.
5 Optionally, select the Attachments tab to add attachments.
6 Click Submit, then click OK to confirm.

Copying a bill of material
Note: This task is only available when PDM Plus is installed and running.

Copying a bill of material copies all of the product structure records for the component items from the source
items bill of material to a new bill of materials for the target item.

1 Select the item.
2 Select Maintain > Copy Bill of Material.
3 Specify the number of the item.
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This item is the target item.

4 Click Continue.
To see the copied bill of material, go to the target item, open the Default card file, then select the Single
Level Bill of Material card.
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Chapter 12: Item revisions

The Item Revision Master file is created when the PDM Item Master file is migrated to Enterprise Product Data
Management (EPDM).

Defining items and revisions

Item records are maintained in the PDM Item Master file. Each record is stored in three files: ITMRVA, ITMRVB,
and ITMRVC. File A stores general item information and attributes that are used by Customer Order Management
(COM). File B contains product costing information, and File C stores purchasing information.

Each item revision is identified by a combination of three key attributes:

• Site
• Item
• Revision

Each site-item-revision can have a different routing and can be costed separately.

The items in the Item Revision Master file can have different revisions. Each revision has an effective from
and effective to date range. Since a revision is part of the site item key, you can create product costs by revision
within a site. Master Production Schedule Planning (MPSP) and Material Requirements Planning (MRP) plan
orders by revision based on these things:

• The start date of an order
• The planning warehouse
• The site to which the warehouse is assigned

Each item revision must be assigned an implementation status. The implementation status controls the
processing of item information through the design, production, manufacturing, and sales cycle. The status
code values contained in an implementation status determine how interfacing Infor XA applications process
information for item revisions assigned to that implementation status. For example, one implementation
status might be created for all item revisions that are manufactured, while another implementation status
might be created for all item revisions that are purchased items.

Understanding item revisions and enterprise items

During migration from Product Data Management (PDM), EPDM also creates the Enterprise Item Master file.
Each item from the Item Revision Master file is stored in the Enterprise Item Master file. Many sites can copy
an item an item definition from the Enterprise Item Master file when in a multi-site environment. Therefore,
each site uses the same item definitions.
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When you create an item for the first time, the item number in EPDM is added to the Enterprise Item Master
file. If someone creates the same item in another site, a message is sent from EPDM that the item already
exists. You can then copy the item description from the Enterprise Item Master file to the item you are creating
at a different site. You can give the item a unique revision but it is not necessary.

Additional features

Items have a status that identifies them for release to PDM and release of an order. These statuses are used
as edits during the functions discussed .

You can attach file objects such as bitmaps, word processing documents, or spreadsheets to the item revision
record. You can use a card in the card file for the object to view these files in EPDM. You can define these
statuses through file maintenance for individual item revisions or for a group of items related to a project.

Controlling item revisions

These essential properties of an item answer the questions of how and why items acquire revisions:

• Form: Form is the configuration of an item such as shape, size, density, weight, or other physical properties
that identify the item.

• Fit: Fit is the characteristic that is used by an item to connect to or become an integral part of another
item.

• Function: Function is the use or performance of an item.

Engineering changes drive the creation of revisions for an item. When an engineering change affects the form,
fit, or function of an item, you cannot have a revision. A new item must be created. All other changes can
result in a revision usually identified as a letter of the alphabet A through Z. Since all revisions of an item are
assumed to be interchangeable, form, fit, and function, you cannot track inventory by revision.

When you do not know an item revision number but need to enter the number, you can use EPDM to display
a list of all revisions for an item in a site.

Extending the item master record

Revisions, in effect, extend the item master record to let you define appropriate manufacturing processes
and run costs by site, item, and revision. Manufacturing orders can be released to build a revision.

These revisions are used by interfacing programs. Consider these rules when selecting a revision:

• A blank revision is valid
• Selection of a revision is done by effective date and revisions

If effective dates overlap for an item, orders in MPSP and MRP are planned by using the item revision with
the latest start date. In IM, component revisions are assigned based on the oldest start date; so you should
use the oldest revision.

Maintaining items and item revisions

Use the Maintain menu in Item Revisions to create, change, delete and copy item revision records. From this
menu you can open list windows for Enterprise Item, Site, Buyer, and Vendor.

Infor XA Order-Based Production Management | 53

 

Item revisions



Creating item revisions
You can create item revisions when EPDM is installed.

1 Select Production > Item Revisions > Maintain > Create.
2 Complete the fields including this information:

Site
Specify the identification (ID) for the group of records.

Item
Specify the ID for the group of records.

Revision
Specify a number for the revision or click Find Item Revision to select a revision. If you select an existing
item revision, the Site and Item attributes for the item revision are used.

Initial release
Select Yes to automatically release the item revision to PDM. The default is No. You can only change this
attribute when you are creating an item revision, and only if you have Item Release task security authority.

3 Click Create.
If you select Preview before create, you can specify additional information on the General card tab.
Click Create when finished.

Copying item revisions
Use the Copy option to copy a single item and its engineering records to another site, or to create a new item
using the same engineering records. You have the option to copy the item revision and an associated item
process. The single level bill of material and routing are copied for the item process. All item and facility
records must exist at the target site.

1 Select the item revision.
2 Select Maintain > Copy.
3 Complete the fields including this information:

Site
Specify the ID for the new group of records.

Item
Specify a new ID if you are creating a new item revision.

Revision
Specify a new ID if you are creating a new item revision.

Copy of Bill of Material
Select the check box to copy. This option is only available if bills of material (BOM) already exist for the
item or item revision.
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Copy Bill of Material Components
This option is only available if BOM already exist for the item or item revision. The check box is
automatically selected when you select the Copy of Bill of Material check box. Clear the check box to
not copy the BOM components.

Copy Routings
Select the check box to copy. This option is only available if routings already exist for the item or item
revision being copied.

Copy Routing Operations
This option is only available if routings already exist for the item or item revision being copied. The check
box is automatically selected when you select the Copy Routings check. Clear the check box to not copy
the routing operations.

Copy Routing Additional Descriptions
This option is only available if routings already exist for the item or item revision being copied. The check
box is automatically selected when you select the Copy Routings check. Clear the check box to not copy
the routing additional descriptions.

Copy Item Process
This option is only available if the Copy Bill of Material or Copy Routings option is selected, or if the
item or item revision being copied has a generic routing. When selected, the Copy Item Process
Comments check box is automatically selected and cannot be cleared.

Copy Item Process Descriptions
Select the check box to copy. This option is only available if the Copy Bill of Material or Copy Routings
option is selected, or if the item or item revision being copied has a generic routing.

Copy Item Revision Base Prices
Select the check box to copy. This option is only available if base prices already exist for the item or item
revision being copied.

Copy Item Foreign Prices
Select the check box to copy. This option is only available if foreign prices already exist for the item or
item revision being copied.

Copy Item Revisions Foreign Language Descriptions
Select the check box to copy. This option is only available if foreign language descriptions already exist
for the item or item revision being copied.

4 Click Copy.
5 Click OK to confirm the creation of Enterprise Item records.
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Deleting item revisions
Deleting an item revision removes the item revision immediately. If the item revision is used on another object,
then you cannot delete the item revision. For example, if the item revision is used on a purchase order or
requisition.

1 Select the item revision.
2 Select Maintain > Delete.
3 Click Yes to confirm. If the item revision is associated with another item, a message is displayed in the

Delete Item Revision dialog box. Click No to return to the Item Revision page without deleting the item
revision.

Releasing item revisions
Use the Release option to update PDM with the item revision record and the associated item process
information. Included in the release information is the bill of material, routing, and any facilities associated
with the routing operations.

When releasing item revisions for a single engineering change, ensure that each item revision has the
engineering change number specified in the Implementation Status attribute or in a user attribute. You can
use the Implementation Status attribute or the user attribute to subset item revisions by the engineering
change number. If you need to ensure that engineering change numbers are valid before processing the
release to PDM, use the Implementation Status attribute.

1 Select the item revision.
2 Select Maintain > Release.
3 Select the Auto sync check box to keep the Item Master data automatically synchronized with the current

item revision for the released item and site. The Auto sync option updates item data when current item
revisions change.

4 Click Continue.
You can check the status of this request by looking in the Transaction Status object. The Description
attribute identifies the release transaction.

Mass indented copying of item revisions
Use the Mass Indented Copy option to copy one or more products from one site to another. You can copy
all engineering records for the products to a target site, as long as none of the item revisions or objects already
exist at the target site. If an item revision does exist, the engineering records for that object will not be copied.
This ensures that the data in both the source and target site are the same at the end of the mass indented
copy.
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Using this option, you can copy engineering records for all the item revision records identified on a subsetted
Item Revision list page. Based on their primary item processes, the indented bills of material and routings
are copied. All items associated with the indented bills of material and all facilities associated with the
operation records are copied. If an item revision already exists at the target site, the item process for that
item revision is bypassed, and an error message can be created optionally.

1 Select Maintain > Mass Indented Copy.
2 Complete the fields including this information:

Target site
Specify the site to which to copy the item revision records, or click Find Site to search for a particular
site.

Retrieval date
Specify of select a retrieval date to be used for including or excluding engineering records based on their
effective dates.

Include Routings
Clear the check box to not copy all routings and associated facilities; otherwise, all routings and associated
facilities are copied. The check box is selected by default.

Suppress duplicate record errors
This option is used to not generate error messages for any duplicate item revision and the bill of material,
routing header, and facility records for the item revision found in the target site. The mass indented
copy continues, by passing the item process for the duplicate item revision. The check box is selected
by default.
Clear the check box to generate error messages for the duplicate record errors.

Reason
Optionally, specify a maintenance reason or click Find Maintenance Reason to select a reason code.

3 Click Continue, then click OK to confirm.

Mass releasing item revisions
Use the Mass Release option to update PDM with the item revision and the associated item process information.
Included in the release information is the bill of material, routing, and any facilities associated with the routing
operations.

1 Select Maintain > Mass Release.
2 Complete the fields including this information:

Auto sync
Select the check box to keep the Item Master data automatically synchronized with the current item
revision for the released item and site. The Auto sync option updates item data when current item
revisions change.

3 Click Continue, then click OK to confirm.
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Printing the Cost Variations - Current to Standard report
Use the Cost Variations - Current to Standard report option to view lines of current or standard costing
information for each item revision. This report shows the costs from the last costing run.

1 Select Production > Facilities > File > Host Print.
2 Select Print on the Cost Variations - Current to Standard tab.
3 Complete the fields on the Content tab.
4 Click the E-mail tab, then specify the information.
5 Optionally, click the Attachments tab to add attachments.
6 Click Submit.

Printing the End-Item Where-Used report
Use the End-Item Where-Used report option to view the end-items when a selected item revision is used as
a component.

1 Select File > Host Print.
2 Click the End-Item Where-Used tab.
3 Select the Print check box.
4 Complete the fields including this information:

Retrieval date
Specify or select the date to use to select components that are in effect. The Retrieval date is not used
to compare to item revision effective dates.

5 Click the E-mail tab, then specify the information.
6 Optionally, click the Attachments tab to add attachments.
7 Click Submit.

Printing the Feature/Option report
Use the Feature/Options Report option to view the features and all of the associated options for item revision
end items. Item revisions may have features and options when the Activate Feature/Options application
setting in Enterprise Product Data Management is Yes.

1 Select File > Host Print.
2 Click the Feature/Option Report tab.
3 Select the Print check box.
4 Complete the fields on the Content tab.
5 Click the E-mail tab, then specify the information.
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6 Optionally, click the Attachments tab to add attachments.
7 Click Submit.

Printing the Indented Bill report
Use the Indented Bill report option to show the entire bill of material (BOM), including structural relationship,
in an indented format. The indented bill can be for an item at any level in the structure. Any item that you
select for the report is an end-item for this report. An assembly or sub-assembly can have a structure, BOM,
and can be used as a component in other BOMs.

1 Select File > Host Print.
2 Click the Indented Bill tab.
3 Select the Print check box.
4 Complete the fields including this information:

Quantity
Specify a quantity for the amount of components. The value can be up to 99,999,999. Component
quantities are specified as units instead of standard batch quantities. For example, if the standard batch
quantity is 100 and there are 900 units, then specify 900.
If you select multiple item revisions, the quantity that is specified is used for all item revisions on the
report.

Retrieval date
Specify or select the date to use to select components that are in effect. The Retrieval date is not used
to compare to item revision effective dates.

S-number
Specify an S-number if the item is an end-item that has features. Use the S-number to select which
features and options are reported. Use this attribute to view the cost for a particular configuration,
option selection, of an end item. If you do not specify the S-number and the features and options that
are present, then all features and options are reported with the component cost. For a specific feature,
if you specify an asterisk, then all options for that feature are printed on the report.

5 Click the E-mail tab, then specify the information.
6 Optionally, click the Attachments tab to add attachments.
7 Click Submit.

Printing the Indented Cost Sheet report
Use the Indented Cost Sheet report option to view cost information about an item, bill of material, in indented
format. This report shows the cost for the components and end-item. Any item you select is an end-item for
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this report. An assembly or sub-assembly can have a bill of material, and can also be used as a component
in other bills. The Indented Cost Sheet report shows the costs as of the last costing run.

1 Select File > Host Print.
2 Click the Indented Cost Sheet tab.
3 Select the Print check box.
4 Complete the fields including this information:

Cost Content
Select Current orStandard.

Retrieval date
Specify or select the date to use to select components that are in effect. The Retrieval date is not used
to compare to item revision effective dates.

5 Click the E-mail tab, then specify the information.
6 Optionally, click the Attachments tab to add attachments.
7 Click Submit.

Printing the Item Process Report
An item process is a link between the bill of material and the routing. A bill of material is a list of component
items. The routing is a list of manufacturing processes.

Use the Item Process Reportoption to show the associated bill of material and the routing for each selected
manufactured item that is in effect as of the date that the report is run. The report shows whether the selected
item has an alternate bill of material or routing. When you run this report from Item Revisions, only the current
primary process is displayed. When you run this report from Item Processes, you can select which records
are printed.

1 Select Production > Facilities > File > Host Print.
2 Click the Item Process Report tab.
3 Select the Print check box.
4 Complete the fields on the Content tab.
5 Click the E-mail tab, then specify the information.
6 Optionally, click the Attachments tab to add attachments.
7 Click Submit.
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Printing the Item Revision Audit Report
Certain attributes in the item revision record must be identical for all item revisions that have the same item
number within a site. Use the Item Revision Audit Report option to compare item revision records to
corresponding item site records to show which common attributes are not synchronized.

1 Select Production > Facilities > File > Host Print.
2 Click the Item Revision Audit Report tab.
3 Select the Print check box.
4 Complete the fields on the Content tab.
5 Click the E-mail tab, then specify the information.
6 Optionally, click the Attachments tab to add attachments.
7 Click Submit.

Printing the Item Revision Costs report
Use the Item Revision Costs report to show current or standard costs for the item revision. This report shows
the cost for each selected item and the summary cost of lower-level components. This report does not show
the cost for each component. Use theSingle Level Cost Sheet Report or Indented Cost Sheet report to see
the cost of the individual components. This report shows the costs as of the last costing run.

1 Select Production > Facilities > File > Host Print.
2 Click the Item Revision Costs tab.
3 Select the Print check box.
4 Complete the fields on the Content tab.
5 Click the E-mail tab, then specify the information.
6 Optionally, click the Attachments tab to add attachments.
7 Click Submit.

Printing the Management Cost Summary report
Use the Management Cost Summary report option to view a summary of item revision cost elements such
as labor, material, overhead, and other information such as price and gross margin.

The Management Cost Summary report shows the lower-level component costs in summary. The report does
not show the cost for each component. Use the Single Level Cost Sheet Report or Indented Cost Sheet
report to see the cost of the individual components.

This report shows the costs as of the last costing run.

1 Select Production > Facilities > File > Host Print.
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2 Click the Management Cost Summary tab.
3 Select the Print check box.
4 Complete the fields on the Content tab.
5 Click the E-mail tab, then specify the information.
6 Optionally, click the Attachments tab to add attachments.
7 Click Submit.

Printing the Operations Cost Sheet report
Use the Operations Cost Sheet report option to show the cost of producing a particular batch quantity for
the item revisions that are selected for this report. Labor and machine setup cost is calculated for each unit
based on the specified batch quantity. In contrast, for standard costing runs, the labor and machine setup
costs is apportioned to the expected production run size by dividing by lot size. You can use this to project
an expected cost of manufacture.

This report shows costs as of the last costing run.

1 Select Production > Facilities > File > Host Print.
2 Click the Operations Cost Sheet tab.
3 Select the Print check box.
4 Complete the fields including this information:

Quantity
Specify a quantity for the amount of components. The value can be up to 99,999,999. Component
quantities are specified as units instead of standard batch quantities. For example, if the standard batch
quantity is 100 and there are 900 units, then specify 900.
If you select multiple item revisions, the quantity that is specified is used for all item revisions on the
report.

Retrieval date
Specify or select the date to use to select components that are in effect. The Retrieval date is not used
to compare to item revision effective dates.

S-number
Specify an S-number if the item is an end-item that has features. Use the S-number to select which
features and options are reported. Use this attribute to view the cost for a particular configuration,
option selection, of an end item. If you do not specify the S-number and the features and options that
are present, then all features and options are reported with the component cost. For a specific feature,
if you specify an asterisk, then all options for that feature are printed on the report.

5 Click the E-mail tab, then specify the information.
6 Optionally, click the Attachments tab to add attachments.
7 Click Submit.
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Printing the Routing List report
Use the Routing List report option to show the sequence of operations that an item revision is expected to
pass through on the shop floor.

1 Select Production > Facilities > File > Host Print.
2 Click the Routing List tab.
3 Select the Print check box.
4 Complete the fields on the Content tab.
5 Click the E-mail tab, then specify the information.
6 Optionally, click the Attachments tab to add attachments.
7 Click Submit.

Printing the Routing and Single Level Bill with blow thru
report
Use the Routing and Single Level Bill with blow thru report option to show the standard sequence of
operations that are required to perform the selected item revisions. This report shows the options of the
features. The Routing and Single Level Bill with blow thru job report is similar to single level except that
phantom item structures are exploded, blown-thru.

1 Select Production > Facilities > File > Host Print.
2 Click the Routing and Single Level Bill with blow thru tab.
3 Select the Print check box.
4 Complete the fields including this information:

Quantity
Specify a quantity for the amount of components. The value can be up to 99,999,999. Component
quantities are specified as units instead of standard batch quantities. For example, if the standard batch
quantity is 100 and there are 900 units, then specify 900.
If you select multiple item revisions, the quantity that is specified is used for all item revisions on the
report.

Retrieval date
Specify or select the date to use to select components that are in effect. The Retrieval date is not used
to compare to item revision effective dates.

S-number
Specify an S-number if the item is an end-item that has features. Use the S-number to select which
features and options are reported. Use this attribute to view the cost for a particular configuration,
option selection, of an end item. If you do not specify the S-number and the features and options that
are present, then all features and options are reported with the component cost. For a specific feature,
if you specify an asterisk, then all options for that feature are printed on the report.

5 Click the E-mail tab, then specify the information.
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6 Optionally, click the Attachments tab to add attachments.
7 Click Submit.

Printing the Single Level Bill with blow thru report
For end items, use the Single Level Bill with blow thru report option to show the option items for each
feature as specified by the S-number and the component items for each phantom. This report provides a
single-level picking list for end items that have features or any item with phantoms.

1 Select File > Host Print.
2 Click the Single Level Bill with blow thru tab.
3 Select the Print check box.
4 Complete the fields including this information:

Quantity
Specify a quantity for the amount of components. The value can be up to 99,999,999. Component
quantities are specified as units instead of standard batch quantities. For example, if the standard batch
quantity is 100 and there are 900 units, then specify 900.
If you select multiple item revisions, the quantity that is specified is used for all item revisions on the
report.

Retrieval date
Specify or select the date to use to select components that are in effect. The Retrieval date is not used
to compare to item revision effective dates.

S-number
Specify an S-number if the item is an end-item that has features. Use the S-number to select which
features and options are reported. Use this attribute to view the cost for a particular configuration,
option selection, of an end item. If you do not specify the S-number and the features and options that
are present, then all features and options are reported with the component cost. For a specific feature,
if you specify an asterisk, then all options for that feature are printed on the report.

5 Click the E-mail tab, then specify the information.
6 Optionally, click the Attachments tab to add attachments.
7 Click Submit.

Printing the Single Level Cost Sheet report
Use the Single Level Cost Sheet report option to view cost information about an item, bill of material, in
indented format. The Single level cost sheet report is a cost summary of the indented cost report, summarizing
costs at level 1 of the structure. A blow-thru option is available to explode the structure of phantoms. Use
this report when the full detail of a structure is not required.
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This report shows the costs as of the last costing run.

1 Select Production > Facilities > File > Host Print.
2 Click the Single Level Cost Sheet tab.
3 Select the Print check box.
4 Complete the fields including this information:

Quantity
Specify a quantity for the amount of components. The value can be up to 99,999,999. Component
quantities are specified as units instead of standard batch quantities. For example, if the standard batch
quantity is 100 and there are 900 units, then specify 900.
If you select multiple item revisions, the quantity that is specified is used for all item revisions on the
report.

Retrieval date
Specify or select the date to use to select components that are in effect. The Retrieval date is not used
to compare to item revision effective dates.

S-number
Specify an S-number if the item is an end-item that has features. Use the S-number to select which
features and options are reported. Use this attribute to view the cost for a particular configuration,
option selection, of an end item. If you do not specify the S-number and the features and options that
are present, then all features and options are reported with the component cost. For a specific feature,
if you specify an asterisk, then all options for that feature are printed on the report.

Blow through
By default, Yes is selected. The Yes option specifies that the option items for each feature as specified
by the S-number and the component items for each phantom are to be displayed. Select No to not show
this information.

5 Click the E-mail tab, then specify the information.
6 Optionally, click the Attachments tab to add attachments.
7 Click Submit.

Printing the Single Level Where-Used report
Use the Single Level Where-Used report option to show the parent items, one level up, directly using an item
revision.

1 Select File > Host Print.
2 Click the Single Level Where-Used tab.
3 Select the Print check box.
4 Complete the fields including this information:

Retrieval date
Specify or select the date to use to select components that are in effect. The Retrieval date is not used
to compare to item revision effective dates.
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5 Click the E-mail tab, then specify the information.
6 Optionally, click the Attachments tab to add attachments.
7 Click Submit.

Printing the Summarized Bill report
Use the Summarized Bill report option to show the entire bill of material, single list, for an item summarized
as a parts list.

1 Select File > Host Print.
2 Click the Summarized Bill tab.
3 Select the Print check box.
4 Complete the fields including this information:

Quantity
Specify a quantity for the amount of components. The value can be up to 99,999,999. Component
quantities are specified as units instead of standard batch quantities. For example, if the standard batch
quantity is 100 and there are 900 units, then specify 900.
If you select multiple item revisions, the quantity that is specified is used for all item revisions on the
report.

Retrieval date
Specify or select the date to use to select components that are in effect. The Retrieval date is not used
to compare to item revision effective dates.

5 Click the E-mail tab, then specify the information.
6 Optionally, click the Attachments tab to add attachments.
7 Click Submit.

Printing the Work-in-process Cost Worksheet report
Use the Work-in-process Cost Worksheet report option to print a worksheet for selected item revisions using
standard, current, or average costs. This report shows the cost buildup for a quantity of an item in terms of
material, outside costs, labor, machine, and overhead costs that are added at each active operation. This
report shows components in the ascending sequence of the component within the operation in which they
are used.

You can use this report to determine the unit cost of making a quantity of the item. For example, if you specify
a standard lot size of the quantity, then the unit cost is matched to the unit cost that is calculated in product
costing. The unit cost of the item varies when you specify more or less of the standard lot size.

This report shows the costs as of the last costing run.
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1 Select Production > Facilities > File > Host Print.
2 Click the Work-in-process Cost Worksheet tab.
3 Select the Print check box.
4 Complete the fields including this information:

Cost Content
Select a cost type. These values are valid:
• Current
• Standard
• Average

Quantity
Specify a quantity for the amount of components. The value can be up to 99,999,999. Component
quantities are specified as units instead of standard batch quantities. For example, if the standard batch
quantity is 100 and there are 900 units, then specify 900.
If you select multiple item revisions, the quantity that is specified is used for all item revisions on the
report.

Retrieval date
Specify or select the date to use to select components that are in effect. The Retrieval date is not used
to compare to item revision effective dates.

S-number
Specify an S-number if the item is an end-item that has features. Use the S-number to select which
features and options are reported. Use this attribute to view the cost for a particular configuration,
option selection, of an end item. If you do not specify the S-number and the features and options that
are present, then all features and options are reported with the component cost. For a specific feature,
if you specify an asterisk, then all options for that feature are printed on the report.

5 Click the E-mail tab, then specify the information.
6 Optionally, click the Attachments tab to add attachments.
7 Click Submit.

Running the Product Costing - Both job
To run product costing, you decide whether you want to perform current costing, standard costing, or both.

Use the Product Costing - Both host job option to send current and standard costing information for the
products from XA to specified destinations using System-Link.

1 Select Production > Item Revisions > File > Host Jobs.
2 Select Execute on the Product Costing - Both tab.
3 Complete the fields including this information:

Costing effective date
Specify an effective date for the costing run.
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Include affected assemblies
Select this check box to include any affected subassemblies in the costing run.

Suppress warning messages
Select this check box to prevent warning messages from printing on the reports generated by the costing
run.

4 Click the E-mail tab, then specify the information.
5 Click Submit.

Running the Product Costing - Current job
To run product costing, you need to decide whether you want to perform current costing, standard costing,
or both.

Use the Product Costing - Current host job option to send current costing information for the products from
XA to specified destinations using System-Link.

1 Select Production > Item Revisions > File > Host Jobs.
2 Click the Product Costing - Current tab.
3 Select the Execute check box.
4 Complete the fields including this information:

Costing effective date
Specify an effective date for the costing run.

Include affected assemblies
Select this check box to include any affected subassemblies in the costing run.

Suppress warning messages
Select this check box to prevent warning messages from printing on the reports generated by the costing
run.

5 Click the E-mail tab, then specify the information.
6 Click Submit.

Running the Product Costing - Standard job
To run product costing, you need to decide whether you want to perform current costing, standard costing,
or both.

Use the Product Costing - Current host job option to send standard costing information for the products
from XA to specified destinations using System-Link.
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1 Select Production > Item Revisions > File > Host Jobs.
2 Click the Product Costing - Standard tab.
3 Select the Execute check box.
4 Complete the fields including this information:

Costing effective date
Specify an effective date for the costing run.

Include affected assemblies
Select this check box to include any affected subassemblies in the costing run.

Suppress warning messages
Select this check box to prevent warning messages from printing on the reports generated by the costing
run.

5 Click the E-mail tab, then specify the information.
6 Click Submit.

Running the Publish Item Revisions job
The Publish host job sends current information, for selected item revisions, from XA to specified destinations
using System-Link. You can choose to publish a single item revision, manually selected item revisions, or item
revisions in a subset. For more information, contact your System-Link administrator.

1 Select Production > Rate Based > Item Revisions > File > Host Jobs.
2 Click the Publish tab.
3 Select the Execute check box.
4 Complete the fields including this information:

Replication destination
In the Options section, specify the System-Link destination to which to send the item revision information.
If you leave the replication destination blank, the replication destination specified for the individual
item revision is used.

5 Click the E-mail tab, then specify the information.
6 Click Submit.

Item revision base prices
Use the Item Revision Base Prices object to specify and maintain base prices for items by revision.

The definition includes the base price, the pricing unit of measure, the item price class, and an effective date
that determines the base price to be used at any given time.
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Each base price is identified by its site, item, item revision, and effective date. An item revision can have many
base prices. However, only one base price can be effective at a given time.

If you maintain current base price attributes on the item revision, the currently effective base price is updated
with the new value. If no currently effective base price exists, one is created using the system date as the
effective date.

You can use the Item Revision Price List report to view all possible base prices, or a subset of base prices, for
an item revision based on these things:

• Effective date
• Currency ID
• Price book ID

Creating item revision base prices
You need to know the site, item, item revision, and item revision base price before creating the base price
record.

1 Select the item revision.
2 Select Display > Item Revision Base Prices.
3 Select Maintain > Create.
4 Complete these fields including this information:

Price effective date
Select or specify the date that the base price is effective. This date compared to the actual date determines
whether the base price is the current one. The current base price is displayed in blue in the Base Prices
list. This attribute is used by the Customer Order Management (COM) application.

Pricing unit of measure
Select the unit of measure assigned to the base price class. This user-assigned code identifies the
measurement basis for item revisions in the base price class. Examples include EA (each), KG (kilogram),
or CM (centimeter).

Item price class
Select a user-defined code to group items into categories for pricing. Items assigned the same item price
class must have the same pricing unit of measure.

5 Click Create.
If you select Preview before create, you can specify additional information on the General card tab. If
you do not select Preview before create, the base price is created and added to the Item Revision Base
Prices list page. Depending on the price effective date, these values may also qualify as Current and
shows in the list of Sales attributes.
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Changing item revision base prices
To perform this change, you need to know the item revision and item revision base price you want to change.
1 Select the item revision in the Item Revisions list page that contains the item revision base price.
2 Select Display > Item Revision Base Prices.
3 Select the item revision base price.
4 Select Maintain > Change.
5 Update maintainable attributes on the Change Item Revision Base Price card file.
6 Click Update.

Copying item revision base prices
Use the Copy option when you want to copy an item revision base price to create another base price for its
item revision or another item revision.

1 Select the item revision that contains the item revision base price in the Item Revisions list page.
2 Select Display > Item Revision Base Prices.
3 Select the item revision base price.
4 Select Maintain > Copy.
5 Complete the fields including this information:

Site
Specify the ID for the new group of records.

Item
Specify the ID for the item for which you are creating the base price.

6 Click Copy.
If you selected Preview before copy, the detailed item revision base price information is displayed on
the Copy Item Revision Base Price card file. You can maintain this information. Click Copy after you
have finished.

Deleting item revision base prices
Deleting a item revision base price removes the item revision base price immediately.

1 Select the item revision in the Item Revisions list page that contains the item revision base price.
2 Select Display > Item Revision Base Prices.
3 Select the item revision base price.
4 Select Maintain > Delete.
5 Click Yes to confirm.
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Printing the Item Revision Price List report
Use the Item Revision Price List report option to

1 Select the item revision in the Item Revisions list page that contains the item revision base price. report
option to

2 Select Display > Item Revision Base Prices.
3 Select the item revision base price.
4 Select File > Host Print.
5 Select the Print check box if not already selected.
6 Complete the fields including this information:

Effective date
Specify the date that the base prices are effective.

Currency ID
Specify the currency identifier for the item revision base prices.

Price book ID
Specify the ID of the price book used to calculate the selling price of the item revision.

7 Click the E-mail tab, then specify the information.
8 Optionally, click the Attachments tab to add attachments.
9 Click Submit.

Running the Generate Item Revision Base Price Changes job
Use this host job to change item revision base prices to a new price based on the percent of the original base
price. For example, you could select a subset of item revision base prices and increase the base price for each
record by 10%.

1 Select the item revision in the Item Revisions list page that contains the item revision base price. report
option to

2 Select Display > Item Revision Base Prices.
3 Select the item revision base price.
4 Select File > Host Jobs.
5 Select the Execute check box if not already selected.
6 Complete the fields including this information:

Effective date
Specify the date that the base prices are effective.

Variance percent
Specify the percent of the original base price that is added to the item revision base price.

7 Click the E-mail tab, then specify the information.
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8 Click Submit.

Item revision foreign language descriptions
Use Item Revision Foreign Language Descriptions object to specify and maintain text descriptions in multiple
languages for items by revision.

The definition includes a translated description and up to two longer descriptions.

Creating item revision foreign language descriptions
You need to know the site, item, item revision, and foreign language of the set of descriptions before creating
the foreign language description..

1 Select the item revision.
2 Select Display > Foreign Language Descriptions.
3 Select Maintain > Create.
4 Complete the fields including this information:

Language
Select the language for the item revision.

Translated description
Specify a 30-character foreign language description of the item revision.

Translated truncated description (20 positions)
Specify a translated description of this item revision for 20 positions.

Translated truncated description (10 positions)
Specify a translated description of this item revision for 10 positions.

Translated extended description 1
Specify a 40-character foreign language description of the item revision.

Translated extended description 2
Specify a second 40-character foreign language description of the item revision.

5 Click Create.

Changing item revision foreign language descriptions
To perform this change, you need to know the item revision, language, and translated description of the set
to change.
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1 Select the item revision in the Item Revisions list page that contains the foreign language description.
2 Select Display > Foreign Language Descriptions.
3 Select the foreign language description.
4 Select Maintain > Change.
5 Update maintainable attributes on the Change Foreign Language Descriptions card file.
6 Click Update.

Copying item revision foreign language descriptions
Use the Copy option when you want to copy a foreign language description to create another foreign language
description for its item revision or another item revision.

1 Select the item revision that contains the foreign language description in the Item Revisions list page.
2 Select Display > Foreign Language Descriptions.
3 Select the foreign language description.
4 Select Maintain > Copy.
5 Complete the fields including this information.

Site
Specify the ID for the new group of records.

Item
Specify the ID for the item for the new foreign language description.

Item revision
Specify the ID for the item revision for the new foreign language description.

6 Click Copy.
If you selected Preview before copy, the detailed foreign language description information is displayed
on the Copy Foreign Language Description card file. You can maintain this information. Click Copy after
you have finished.

Deleting item revision foreign language descriptions
Deleting a foreign language description removes the foreign language description immediately.

1 Select the item revision in the Item Revisions list page that contains the foreign language description.
2 Select Display > Foreign Language Description.
3 Select the foreign language description.
4 Select Maintain > Delete.
5 Click Yes to confirm.
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Item revision foreign prices
The Item Revision Foreign Prices object contains prices for item revisions in currencies other than the local
currency.

An item revision can have multiple prices in multiple foreign currencies. If you add a foreign currency price
for an item revision without specifying a price amount, the nominal price is calculated in the specified currency
using the current exchange rate for that currency.

The effective date for the foreign price determines which one of multiple prices in the specified currency
applies to the item revision. Only one price per currency applies at a time. Additionally, only foreign currency
prices specified for the current item revision can be in effect.

Because of fluctuations in exchange rates, changes to the pricing unit of measure, and other factors can
require changes to prices in foreign currency. The Item Revision Foreign Prices object provides several options
for updating foreign currency prices for an item revision. Use the Assign nominal price button to replace the
current price with a recalculated version of the price. Use Mass Replace Foreign Price with Nominal Price
option to perform these task: recalculate the nominal price for all selected foreign currency prices. The
recalculated price replaces the existing foreign currency price with the nominal price.

Creating item revision foreign prices
Before you begin, you need to know the site, item, revision, currency, and pricing unit of measure for the
foreign price. You can create more than one foreign price in a specified currency but only one price can be
current. The current price is determined by the effective date you assign to the foreign price.

1 Select the item revision.
2 Select Display > Item Revision Foreign Prices.
3 Select Maintain > Create.
4 Complete the fields including this information:

Company
Specify the company to which the site and item revision combination belongs, or click the Find Company
button to select a company. This information cannot be changed after you create the foreign price.

Currency
Select the foreign currency for the price. The currency must be a valid currency defined for the specified
company. If you select a currency for a company other than the one you specified, the company changes
to the company associated with the selected currency. You cannot change the currency after you create
the foreign price.

Price effective date
Select the date that the foreign price is effective. This date compared to the actual date determines
whether the foreign price is the current one. The current foreign price shows in blue on the Item Revision
Foreign Prices list. You cannot change the effective date after you create the foreign price.

Foreign currency price
Specify the foreign price amount for this item revision in this currency. If you do not specify an amount,
a nominal foreign price can be calculated in EPDM based on these things:
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• Base price of the item revision
• Current exchange rate for the specified currency
• Pricing unit of measure
• Any adjustment factor that applies to the currency

5 Click Create.
If you select Preview before create, you can make changes or additions to the item revision foreign price
information. When finished, click Create.
If you do not select Preview before create, the foreign price is created and added to theItem Revision
Foreign Prices list page. Depending on the price effective date, this price may qualify as the current price
in this currency.

Changing item revision foreign prices
The price and the pricing unit of measure are the only values that can be changed for an item revision foreign
price.

1 Select the item revision in the Item Revisions list page that contains the item revision foreign price.
2 Select Display > Item Revision Foreign Prices.
3 Select the item revision foreign price.
4 Select Maintain > Change.
5 Update maintainable attributes.
6 Click Update.

Copying item revision foreign prices
Before you begin, you need to know the site, item, revision, currency, and pricing unit of measure for the new
foreign price. You can create more than one foreign price in a specified currency but only one price can be
current. The current price is determined by the effective date you assign to the foreign price.

1 Select the item revision that contains the item revision foreign price in the Item Revisions list page.
2 Select Display > Item Revision Foreign Prices.
3 Select the item revision foreign price.
4 Select Maintain > Copy.
5 Complete the fields including this information:

Site
Specify the site that contains the item revision for which you are creating the foreign price.

Item
Specify the identifier for the enterprise item to which the item revision belongs.
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Company
Specify the company to which the site and item revision combination belongs, or click the Find Company
button to select a company. This information cannot be changed after you create the foreign price.

Currency
Select the foreign currency for the price. The currency must be a valid currency defined for the specified
company. If you select a currency for a company other than the one you specified, the company changes
to the company associated with the selected currency. You cannot change the currency after you create
the foreign price.

Price effective date
Select the date that the foreign price is effective. This date compared to the actual date determines
whether the foreign price is the current one. The current foreign price shows in blue on the Item Revision
Foreign Prices list. You cannot change the effective date after you create the foreign price.

6 Click Copy.
If you select Preview before create, you can make changes or additions to the item revision foreign price
information. When finished, click Create.
If you do not select Preview before create, the foreign price is created and added to theItem Revision
Foreign Prices list page. Depending on the price effective date, this price may qualify as the current price
in this currency.

Deleting item revision foreign prices
The item revision foreign price is deleted automatically if the item revision is deleted.

1 Select the item revision in the Item Revisions list page that contains the item revision foreign price.
2 Select Display > Item Revision Foreign Prices.
3 Select the item revision foreign price.
4 Select Maintain > Delete.
5 Click Yes to confirm.

Mass replace foreign price with nominal price
Use the Mass Replace Foreign Price with Nominal Price option to do these things:

• Recalculate the nominal price for all selected foreign currency prices
• Replace the existing foreign currency price with the nominal price

For example, since the last time the prices were recalculated, the exchange rate between a local currency
and another currency has increased by 10 percent. You can use the Mass Replace Foreign Price with Nominal
Price option to recalculate and replace the prices in that currency across all item revisions automatically.

This calculation is used for the nominal price:
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[base price (local currency) x exchange rate for specified currency] x any currency adjustment factor /foreign
pricing UM if different from base price UM

For example, an item revision has a foreign price of 3.35 euros and the foreign pricing UM is each. The base
price in dollars is $24 and the pricing UM is dozen. The exchange rate from dollars to francs is 1.5. The price
adjustment factor for the euro currency is 0.90. The calculation for the nominal price is [(24 x 1.5)] x 0.90/12
= nominal price of 2.70 euros for each item.

To narrow the foreign currency prices for recalculation and replacement, you can apply one a subset or select
specific item revision foreign prices from the Item Revision Foreign Prices list page. Note that if the list of
item revision foreign prices does not have a subset, then all item revision foreign prices are recalculated and
replaced when you use this option. This table shows the subsets you can use and describes when to use them.

Use toSubset

Recalculate and replace only item revision foreign
prices calculated in the specified currency

Currency ID

Recalculate and replace only the item revision for-
eign prices that are currently effective

Current price

Recalculate and replace only item revision foreign
prices for the specified item

Item

Recalculate item revision foreign prices and only
replace those prices that differ from the nominal
prices by a percentage greater than or equal to the
specified variance percent

Variance percent

For any item revision foreign price included in the subset, the Mass Replace Foreign Price with Nominal
Price option recalculates the nominal price and replaces the existing price with the nominal price based on
these things:

• Base price
• Pricing unit of measure
• Current exchange rate for the currency
• Any currency adjustment factor that applies to that currency

Mass replacing foreign price with nominal price
1 Select the item revision foreign prices to replace with the recalculated nominal price. Or, select the subset

to use to restrict the list of item revision foreign prices to be replaced.
2 Select Maintain > Mass Replace Foreign Price with Nominal Price.
3 Specify this information:

Description
Specify a reason for the mass replacement of the selected foreign prices. This description shows with
the transaction in the Transaction Status and Transaction History objects.
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Subset
Select the subset to use to restrict the list of item revision foreign prices. The default value is any subset
that already applies to the list of item revision foreign prices.

4 Click Continue.
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Chapter 13: Item warehouses

The Item Warehouses object contains one record for each unique item number assigned to a warehouse.

Each record includes data for managing inventory, such as quantity on hand, quantity on order, historical
usage, and lead time.

When an item is assigned to more than one warehouse, the item has a different record for each warehouse
in the Item Warehouses object. You determine how many item warehouse records need to be created for an
item by identifying where the items are stocked. Then, you create an item warehouse record for each warehouse
where an item is stocked.

The Item Warehouses object contains the same records as the Item Balance file. For example, maintenance
activities you perform in the Item Warehouses object have the same result as performing those activities
using the Inventory Management (IM) Item Balance file maintenance options.

The Item Warehouses object has two security levels for maintenance. The highest level of security (09) is
required if maintenance is performed for on-hand quantities, or period-to-date and year-to-date figures.
These attributes are normally updated by the application. The remaining attributes are maintained through
regular security.

Item warehouse records can be suspended or reactivated. When you suspend an item warehouse, you should
change the effective dates for that item in the Bills of Material object.

You cannot delete a record from the Item Warehouses object if there are open orders or allocations for the
item in that record. If the warehouse in an item warehouse record is controlled, you cannot maintain that
record if an MRP Planning run is in process.

A specific item can have ties to information in other objects. For example, if an item is in a controlled warehouse,
a location is defined in the Warehouse Locations object. Within the Item Warehouses object, you can use
Display menu options or toolbar buttons to see information in other objects that is related to a selected item.

By default, the Item Warehouses object shows you all item warehouse records, regardless of item or warehouse.
If you want to see only warehouses that stock a particular item, you can select an item in the Items object,
then select the Item Warehouses option on the Display menu. If you want to see only items stocked in a
particular warehouse, select the warehouse in the Warehouses object, then select the Warehouse Items
option on the Display menu.

When Materials Planning is installed, you use the Item Warehouse (Planning) object to view your planning
information, identify exceptions, and release orders. You can manage the requirements for master level items
in the Item Warehouse (Planning) object. The Item Warehouse (Planning) object provides several subsets to
assist you in limiting your list window view to specific planning details. For example, if you wanted to limit
your view to only those items that had planning exceptions in the last planning run or only those items that
were active in the last planning run, you would select the Has planning exceptions or In last planning run
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subset. The Planning list page includes an indicator that shows a red exclamation for each item with one or
more planning exceptions. You can double-click a line in the Planning view on the Item Warehouses list
page shows the Item Warehouse details page with the Planning card file active.

Activating an item warehouse
You can only activate an item warehouse that has been suspended.

1 Select a suspended item warehouse record.
2 Select Maintain > Activate.
3 Click Yes.

Creating item warehouses
1 Select one of these options:

• Select Engineering > PDM Plus > Item Warehouses
• Select Materials > Inventory > Item Warehouses
• Select Material Logistics > Enterprise > Item Warehouses
• Select Production > Order Based > Item Warehouses
• Select Planning > Item Warehouses (Planning)

2 Select Maintain > Create.
3 Specify this information:

Item
Specify the code that defines the item.

Warehouse
Specify the code that defines the warehouse.

4 Click Create.
If you select Preview before create, you can specify additional information on the General card tab.

Creating a purchase order from an item warehouse
You can create a purchase order item from a selected item warehouse record. To create a new purchase order,
you specify only basic item information. The purchase order header is automatically created from default
values. The buyer comes from your user preference in the item master record or from your selection. The
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vendor comes from the vendor in the item warehouse record or from the primary vendor in the item master
record.

1 Select an item warehouse record.
2 Select Maintain > Create Purchase Order.
3 Specify a vendor or buyer depending on the item warehouse record selected.

The buyer comes from your user preference in the item master record or from your selection. The vendor
comes from the vendor in the item warehouse record or from the primary vendor in the item master
record.

4 Click Continue.
5 Complete the fields including this information:

Order
Specify the number to assign to the new purchase order. If you are adding an item to an existing purchase
order, specify that number. If you are using system-assigned purchase order numbers, the next available
purchase order number is displayed.

Warehouse
Optionally, specify the warehouse associated with this item if different from the one provided. The
warehouse information is automatically pulled from the selected item warehouse record.

Requisition
Click the Assign requisition button to specify the number of the requisition that is fulfilled by this item
on the purchase order.

Item
Specify the item for this purchase order if not the default. This attribute is displayed when you select
the Default or Miscellaneous template.

Service
Specify the enterprise item for the purchase order item. This attribute is displayed when you select the
Service template.

Extended description
Specify a description for this miscellaneous item. This attribute is displayed when you select the
Miscellaneous or Service template.

Contract
Specify the number of the contract associated with the item for the purchase order.

Unit price
Specify the price at which the item is being ordered. Leave this attribute blank if you are using contract
pricing.

Blanket item
Select the Blanket item check box if the item has more than one delivery date.

Include Item Receiving operations
Select the Include Item Receiving operations check box to include item receiving operations on the
purchase order. This attribute is displayed when you select the Default or Miscellaneous template.
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6 Click Create.

Adding an item warehouse to a purchase order
You can add an item warehouse to a purchase order.

1 Select an item warehouse record.
2 Select Maintain > Add to Purchase Order.
3 Specify the order number, then click Continue.
4 Specify a vendor, then click Continue.
5 Complete the fields.
6 Click Create.

Creating a requisition order
1 Select an item warehouse record.
2 Select Maintain > Create Requisition.
3 Complete the fields including this information:

Requisition
The next available requisition number is automatically supplied. You can override this number. The
number must start with R.

Requisitioner
Specify the requisition vendor.

4 Click Create.

Deleting an item warehouse
You cannot delete a record from the Item Warehouses object if there are open orders or allocations for the
item in that record.

1 Select an item warehouse record.
2 Select Maintain > Delete.

Any related objects that are related to the item warehouse are listed on the Delete Item Warehouse
prompt.

3 Click Delete.
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Deleting multiple item warehouses
You cannot delete records from the Item Warehouses object if there are open orders or allocations for the
items in that record.

1 Select the item warehouses to delete by creating a subset or by selecting multiple item warehouses from
the list.

2 Select Maintain > Mass Delete.
Any related objects that are related to the item warehouse are listed on the Delete Item Warehouse
prompt.

3 Click Delete.

Marking a planning schedule as reviewed
This task is only available when the Materials Planning application is installed.

1 Select Materials > Inventory > Item Warehouses.
2 Select Planning from the Views list.
3 Select Master level items not reviewed from the Subsets list.
4 Select an item warehouse record.
5 Select Maintain > Mark/Unmark Reviewed Planning Schedule.
6 Click Yes.

Marking a planning order as reviewed
This task is only available when the Materials Planning application is installed.

1 Select Planning from the Views list.
2 Select Master level items not reviewed from the Subsets list.
3 Select an item warehouse record.
4 Select Maintain > Mark/Unmark Reviewed Planning Order.
5 Click Yes.

Suspending an item warehouse
When you suspend an item warehouse, information in that item warehouse record cannot be changed.

1 Select the item warehouse.
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2 Select Maintain > Suspend.
3 Click Yes.

Audit Allocation Quantities host job
Use the Audit Allocation Quantities host job to validate the allocation quantities, or pick requirements,
between the Item Balance file and the Manufacturing Order Detail file. The Audit Allocation Quantities host
job updates the Item Balance file to correct discrepancies found between these two files and prints any
differences found.

If COM is installed and interfacing, this host job accumulates the customer order allocation quantities in the
Item Balance file. Any item or warehouse that is out of balance is listed, and the Item Balance record is updated
to agree with the Customer Order Detail records for that item or warehouse.

This host job should be scheduled for a time when these files are not being used by another task:

• Item Balance
• Customer Order detail
• Manufacturing Order detail
• Customer Order Master
• Manufacturing Order Master
• Order Release Data Entry

Running an Audit Allocation Quantities host job
1 Select Materials > Inventory > Item Warehouses > File > Host Jobs.
2 Click the Audit Allocation Quantities tab if not selected.
3 Select the Execute check box.
4 Complete the fields.
5 Select the Confirmation tab, then specify the information.
6 Click Submit.

Running an Audit Allocation Quantities host job
1 Select Materials > Inventory > Item Warehouses > File > Host Jobs.
2 Click the Audit Allocation Quantities tab if not selected.
3 Select the Execute check box.
4 Complete the fields.
5 Select the Confirmation tab, then specify the information.

Infor XA Order-Based Production Management | 85

 

Item warehouses



6 Click Submit.

Audit On-order Quantities host job
The Audit On-order Quantities host job validates quantities on-order between these files:

• Item Balance
• Purchase Order Item Detail
• Manufacturing Order Master

The host job updates the Item Balance file to correct discrepancies between these three files and prints any
differences found.

If a task is selected when the Audit On-order Quantity host job is active, the error message SYS-1172 FILE
(file label) IS CURRENTLY NOT AVAILABLE is displayed. You can select the available options for this message
without endangering data integrity.

Running an Audit On-order Quantities host job
These attributes print out on the Purchase/Mfg On-Order Audit Exception List:

• Item Number
• Warehouse
• Description
• Manufacturing On-order Quantity Before
• Manufacturing On-order Quantity After
• Purchase On-order Quantity Before
• Purchase On-order Quantity After

1 Select Materials > Inventory > Item Warehouses > Files > Host Jobs.
2 Click the Audit On-order Quantities tab.
3 Complete the fields.
4 Select the Confirmation tab, then specify the information.
5 Click Submit.

Running the Copy Indented Item Warehouse job
Use the Copy Indented Item Warehouse host job to copy a manufactured item with a bill of materials to
another warehouse. This host job to copies the end item and all of its components to the new warehouse and
creates Item Warehouse records. The direct, first level, components that are used to produce the end item is
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copied but the components of components, lower levels, are not copied. Similar to the Single Level Bill with
blow thru report, the Copy Indented Item Warehouse host job copies both the phantom items and their
direct components.

1 Select Materials > Inventory > Item Warehouses > File > Host Jobs.
2 Click the Copy Indented Item Warehouse tab.
3 Select the Execute check box.
4 Complete the fields including this field.

Structure level
Specify the item warehouse levels that are copied.

5 Select the Confirmation tab, then specify the information.
6 Click Submit.
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Chapter 14: Labor activity

The Labor Activity object contains information about the labor transactions associated with a manufacturing
order.

The Labor Activity Transactions list page includes information such as operation sequence, item and production
facility information, employee information, and transaction times.

Reporting M.O. operation activity for employees or labor
activities
This task is for reporting M.O. operation activity from the Employees or Labor Activity object.

Use the Report M.O. Operation Activity transaction for reporting quantities, scrap, machine, and labor times
for an M.O. Operation.

This transaction is only available if Shop Floor is active in OBPM application settings.
1 Select one of these options:

• Select Order Based > Employees. Then, select the employee in the list.
• Select Activity > Labor Activity. Then, select the labor activity in list.

2 Select Maintain > Report M.O. Operation Activity.
3 Complete the fields including this information:

Template
Select a template to show only the attributes relevant to the purpose of the template. For example,
select the Milestone template to report the activity as a milestone operation.

Order
Specify the order number of the operation on which the employee is working. If you selected a labor
activity, this attribute is automatically populated.

Operation
Specify the operation of the operation on which the employee is working. If a labor activity transaction
is selected, this attribute is may be automatically populated.

Run type
Select the type of run for the activity. These values are valid:
• Setup
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• Run
• Milestone group: This value can only be used with a milestone operation
This attribute is displayed when you select the Default or Scrap quantity template.

Completion code
These values are valid:
• 0=Open: Not complete. Quantity can be reported.
• 1=Complete with entered quantity: You must specify quantity with this completion code.
• 2=Complete with defaulted: You do not specify quantity with this completion code. The quantity is

assumed to be the quantity still open for the operation.
• 3=Milestone: Closes all milestone sub-operations and set the operation status to complete. This

completion code can only be used with a Run code of M.

Complete
Specify the quantity that is complete. This attribute is displayed when you select the Default, Milestone,
and Setup template.

Scrap
Specify the scrap quantity. This attribute is displayed when you select the Default, Scrap quantity, and
Setup template.

Reason
Select a reason for the scrap. If reason codes are specified in the Transaction Reasons object, you must
select a reason for the scrap. If your company does not require reason codes, blank is a valid entry.

Labor
Specify the amount of labor time in hours or minutes. If the Time basis code for M.O. Operation is not
M (minutes), then the labor time is assumed to be hours. If the Time basis code is M (minutes), then the
labor time is assumed to be minutes. For an operation in a milestone group type F (flow shop
environment), labor time entry is not accepted.

Machine
Specify the amount of machine time in hours or minutes. If the Time basis code for M.O. Operation is
not M (minutes), then the machine time is assumed to be hours. If the Time basis code is M (minutes),
then the machine time is assumed to be minutes. This attribute is not valid for a milestone group
sub-operation. This attribute is displayed when you select the Default or Setup template.

Reference
Specify information for reference purposes.

Transaction cost
Optionally, specify the cost for the transaction. If using standard rates as actual costs, this cost overrides
that cost. If using actual employee costs, this cost overrides that cost as well. This attribute is displayed
when you select the Default or Setup template.

Actual work center
Specify the work center being used for the operation. You can specify an override work center only for
the first transaction for an operation. This attribute is displayed when you select the Default or Setup
template.
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Badge
Specify the employe badge number. This attribute is mandatory. If an employee record is selected, this
attribute is automatically populated.

Rate override
This attribute is displayed when you select the Default or Setup template.

Shift override
Specify 1, 2,or 3 for the shift override. This attribute is displayed when you select the Default or Setup
template.

Turnaround
Specify the turnaround number of the operation on which the employee is working.

4 Click Continue.

Starting labor in a labor activity
Use the Start Labor (ON) transaction to show that an employee is clocking onto a job and to specify the kind
of labor required for the job. Start Labor (ON) cannot be created for Flow-shop milestone.

1 Select Activity > Labor Activity.
2 Select the activity in list.
3 Select Maintain > Start Labor (ON).
4 Complete the fields including this information:

Order
Specify the order number of the operation on which the employee is working. If you selected a labor
activity, this attribute is automatically populated.

Operation
Specify the operation of the operation on which the employee is working. If a labor activity transaction
is selected, this attribute is may be automatically populated.

Run type
Select the run type for this transaction. The value indicates the kind of labor required for the job associated
with this transaction. These values are valid:
• Setup: Code used to report work spent in preparing an M.O. operation. Time can include changing

dies and tools, moving material to the facility, or performing testing.
• Run: Code used to report actual work on an operation. Time can include welding, assembly. packaging,

etc.
• Indirect: Code used to report work that is not against an M.O. operation. Time can include sweeping,

cleaning, and attending meetings.
• Milestone: Code used to report activity or work against the final operation in a milestone group.

Crew
Select the check box to indicate that the employee is part of a work crew.
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Badge
Specify the employe badge number. This attribute is mandatory. If an employee record is selected, this
attribute is automatically populated.

Turnaround
Specify the turnaround number of the operation on which the employee is working.

5 Click Continue.

Stopping labor in labor activity
Use the Stop Labor (OF) transaction to show that an employee is clocking off a job and to specify the kind of
labor required for the job. A corresponding Start Labor (ON) transaction is required unless you are tailored
for OF only processing, reporting scrap against a milestone operation, or reporting against a flow-shop
milestone.
1 Select Activity > Labor Activity.
2 Select the activity in list.
3 Select Maintain > Stop Labor (OF).
4 Complete the fields including this information:

Order
Specify the order number of the operation on which the employee is working. If you selected a labor
activity, this attribute is automatically populated.

Operation
Specify the operation of the operation on which the employee is working. If a labor activity transaction
is selected, this attribute is may be automatically populated.

Run type
Select the run type for this transaction. The value indicates the kind of labor required for the job associated
with this transaction. These values are valid:
• Setup: Code used to report work spent in preparing an M.O. operation. Time can include changing

dies and tools, moving material to the facility, or performing testing.
• Run: Code used to report actual work on an operation. Time can include welding, assembly. packaging,

etc.
• Indirect: Code used to report work that is not against an M.O. operation. Time can include sweeping,

cleaning, and attending meetings.
• Milestone: Code used to report activity or work against the final operation in a milestone group.

Completion code
Select a completion code. These values are valid:
• 0=Open: Not complete. Quantity can be reported.
• 1=Complete with entered quantity: Specify quantity with this completion code.
• 2=Complete with defaulted: Do not specify quantity with this completion code. The quantity is

assumed to be the quantity still open for the operation.
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• 3 = Milestone: Closes all milestone sub-operations and sets the operation status to complete. Can
only be used with Run code of M.

Reason
Select a reason for the scrap. If reason codes are specified in the Transaction Reasons object, you must
select a reason for scrapping. If your company does not require reason codes, blank is a valid entry.

Reference
Specify information for reference purposes.

Crew
Select the check box to indicate that the employee clocked off the job as part of a work crew. Machine
time is calculated only if the Crew check box is not selected for both a Start Labor (ON) transaction and
the matching OF transaction.
Crew clock transactions can be used with multiple employees to clock on or off the same job without
reentering the transaction detail information. The first employee clocks on or off using the normal ON
or OF transaction. The other employees then specify a Crew Clock (CC) transaction that PM&C converts
to an ON or OF transaction with the same time, order, and operation information as the original
transaction.

Badge
Specify the employe badge number. This attribute is mandatory. If an employee record is selected, this
attribute is automatically populated.

Turnaround
Specify the turnaround number of the operation on which the employee is working.

5 Click Continue.
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Chapter 15: Labor activity history

The Labor Activity History object contains information about the labor transactions associated with closed
and purged manufacturing orders.

This information includes operation sequence, item and production facility information, employee information,
and transaction times.

Infor XA Order-Based Production Management | 93

 

Labor activity history



Chapter 16: Manufacturing orders

The Manufacturing Orders object contains information related to released manufacturing orders.

This list shows some of the related information:

• Item and description
• Warehouse
• Item
• Job number
• Status
• Order quantity
• Stocking unit of measure
• Date due
• Planner responsible for the order

A specific manufacturing order can have ties to information in other objects. You can use the Display menu
options or toolbar buttons to see information in other objects that is related to a selected manufacturing
order. Depending on what applications are installed, you can use the Maintain menu options to work with
related information in other objects.

This table shows manufacturing orders related objects:

Viewable informationObject

A list of the components used to manufacture the
item associated with the order

M. O. Components

A list of the operations used to manufacture the item
associated with the order

M. O. Operations

A list of the miscellaneous charges associated with
the order

M. O. Miscellaneous Charges

A list of the discrete allocations associated with the
order

Discrete Allocations

A list of the specific inventory transactions associat-
ed with the order

Inventory Transaction History

A list of the top-level requirement that generated
the need for the component associated with the or-
der

Sources of Demand
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Viewable informationObject

A list of the specific labor activity transactions asso-
ciated with the order

Labor Activity Transactions

A list of the manufacturing orders associated with
the component in the order

Component M.O.s

A list of all splits associated with the orderSplits

Creating manufacturing orders
1 Select Production > Order Based > Manufacturing Orders > Maintain > Create.
2 Complete the fields including this information:

Order
The next manufacturing order number is automatically supplied but you can override this number. The
number must start with M. You can set a user preference for using system-assigned or manually assigned
manufacturing order numbers.

Item Revision
This attribute is available only if EPDM is installed and defaults to the current setting.

Standard in quantity
Specify a value. Click the Set Standard in quantity default button to calculate the standard in quantity
value based on the value of the order quantity.

Total order quantity
Specify a value. If this attribute is inactive, order quantity is calculated based on the Standard in quantity
value.

Scheduled start date
Specify a start date. If this attribute is inactive, the scheduled start date is calculated based on the Due
date value.

Due date
Specify a start date. If this attribute is inactive, the due date is calculated based on the Scheduled start
date value.

Include primary BOM
This attribute is only available if EPDM or PDM is installed. Select the Include primary BOM check box
to include the primary bill of material. The bill of material (BOM) is based on these attributes:
• If PDM is installed: Warehouse, Item, and Start Date
• If EPDM is installed: Warehouse, Item, Start Date, and Revision

Include primary routing
This attribute is only available if EPDM or PDM is installed. Select the Include primary routing check
box to include primary routing. Primary routing is based on these attributes:
• If PDM is installed: Warehouse, Item, and Start Date

Infor XA Order-Based Production Management | 95

 

Manufacturing orders



• If EPDM is installed: Warehouse, Item, Start Date, and Revision
You can import bills of material and routings from the Create Manufacturing Order card file.

3 Click Create.

Importing a bill of material for a manufacturing order
When creating a manufacturing order, you can import an existing bill of material or routing.

1 Select the Components card tab in the Manufacturing Orders card file.
2 Click the Import Bill of Material icon.
3 Select one of these sources in the Import option attribute:

• Item Process (EPDM only)
• Bill of Material (EPDM only)
• Item(PDM+ only)
• Manufacturing order

• Manufacturing order history

For Item Process and Bill of Material, you can specify an item and query the EPDM sites, revisions,
and processes associated with the item. The Find buttons launch a search for these objects. Only the
sites, revisions, and processes associated with or belonging to the item and site are displayed. You can
import bill of material data from existing manufacturing orders or manufacturing order history by selecting
these import options.

4 Specify additional information.
5 Optionally, select Yes for the Import routing also attribute to import the routing with the bill of material.
6 Click Import Bill of Material.

Importing a routing for a manufacturing order
1 Select the Operations card tab in the When creating a manufacturing order, you can import an existing

routing or bill of material.Manufacturing Orders card file.
2 Click the Import Routing icon.
3 Select one of these sources in the When creating a manufacturing order, you can import an existing

routing or bill ofImport option attribute:
• Item Process (EPDM only)
• Routing (EPDM only)
• Item(PDM+ only)
• Manufacturing order

• Manufacturing order history
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For Item Process and Routing, you can specify an item and query the EPDM sites, revisions, and processes
associated with the item. The Find buttons launch a search for these objects. Only the sites, revisions,
and processes associated with or belonging to the item and site are displayed. You can import routing
data from existing manufacturing orders or manufacturing order history by selecting these import options.

4 Specify additional information.
5 Optionally, select Yes for the Import bill of material also attribute to import the bill of material with the

routing.
6 Click Import Bill of Material.

Creating an M.O. operation for a manufacturing order
M.O. operations can be created at any time for a manufacturing order

1 Select the Operations tab on the Create or Change Manufacturing Order page.
2 Click Create on the Operations Dates, Operations Quantities, or Operations Hours tab.
3 Complete the fields:

To add an M.O. outside operation to the M.O. operation, ensure that Preview before Createis selected.

4 Click Create.
Note: If you are adding an M.O. outside operation, click the Hours tab and select Cost / piece for the
Time basis code attribute.
See Creating an M.O. outside operation for an M.O. operation.

5 If you selected Preview before Create, complete additional fields and click Create.
6 Click Continue, then click Confirm.

Creating an M.O. outside operation for an M.O. operation
When creating or changing an M.O. operation you can create an M.O. outside operation if the Time basis code
(TBC) is set to Cost / piece.
1 Click the Hours tab on the Create M.O. Operations or Change M.O. Operations page.
2 Ensure that the Time basis code attribute is set to Cost / piece.
3 Click the General tab.
4 Click the Create icon under M.O. Outside Operations.
5 Complete the fields including this information:

Release code
Select a value. These values are valid:
• No

• Requisitions

• Held P.O.

• P.O.
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• Held blanket

• Blanket

• Held blanket-fixed

• Blanket-fixed

Vendor
Specify a vendor or click the Find Vendor icon to select a vendor. Optionally, click the Find Outside
Operation icon next to the Vendor attribute to select an outside operation detail record that corresponds
with the M.O. operation.

Service item
Specify the service item or click Find Item Revision to select an item revision.

Qty/cost update
Select a value for the update. These values are valid:
• Invoice

• Receive P.O.

• Receive P.O./Invoice

Update operation status
Select this box to set Operation status to Complete when cost is reported complete.

6 Click Create, then click Create on the next page.
7 Click Continue until the Confirm dialog box is displayed.
8 Click Confirm.

Releasing an M.O. outside operation
You can release an M.O. outside operation when the purchase order (P.O.) for the M.O. outside operation is
blank and the vendor is an active vendor in the vendor object. You cannot release an M.O. if the purchase
order (P.O.) is assigned to the M.O. outside operation.

1 Select the M.O. outside operation.
2 Select Maintain > Release.
3 Complete the fields including this information:

Vendor
Optionally, select a different vendor from the one shown. You can select a vendor from outside operations
or any active vendor from the Vendor master file.

Release code
Select a code. This attribute is maintainable if Vendor is not blank. These values are valid:
• 0 = No
• 1 = Requisitions
• 2 = Held P.O.
• 4 = Held blanket
• 5 = Blanket
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• 6 = Held blanket-fixed
• 7 = Blanket-fixed
If you select 6 or 7, then a fixed blanket must exist.

Service item
Specify the service item number or click Find Item Revision to select a service item from the Find Item
Revision list.

Qty/cost update
Select where the quantity or cost is to be updated. These values are valid:
• Invoice
• Receive P.O.
• Receive P.O./Invoice

Update operation status
Select the check box to indicate that the operation status is to be updated.

4 Click Continue.
If you select the Return here to create another check box, the next valid M.O. outside operation is
displayed.

Activating a manufacturing order
Use the Activate menu option to reactivate manufacturing orders that have been canceled, Order status is
99. When activated, the Order status changes from 99 = Cancelled to 10 = Released, no activity.

You can use Activate to reset orders that have these order statuses back to a status of 40 = Started:

• 45 = Material complete
• 50 = Labor complete
• 55 = Complete

1 Select the manufacturing order or open the card file for the manufacturing order to activate.
2 Select Maintain > Activate.
3 Click Yes.

Changing manufacturing orders
The Change option is available when OBPM is installed.

1 Select the manufacturing order.
2 Select Maintain > Change.
3 Update the attributes.
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4 Click Update.

Canceling a manufacturing order
Use the Cancel menu option to prevent any transactions from being processed for an order. You can only use
this option for an order with an Order status of 10 = Released, no activity.

The Cancel option is available when OBPM is installed.

1 Select the manufacturing order or open the card file for the manufacturing order to cancel.
2 Select Maintain > Cancel.
3 Click Yes.

The Order status changes from 10 = Released, no activity to 99 = Cancelled. To reverse the cancellation,
use Activate.

Order close transactions in manufacturing orders
You can use these order close transactions to complete the manufacturing order labor and material processes
associated with each order:

• Labor Complete
• Receipt of Material
• Material Complete
• Normal Close
• Force Close

The transactions are sequential in nature. For example, you may only designate a manufacturing order with
a normal close status when the labor complete, receipt of material and material complete operations have
been completed for the order. This table shows you which transactions need to be completed based on the
current status of the order.

Complete these transactionsIf the current status is

• Labor Complete
• Receipt of Material, if needed
• Material Complete
• Normal Close
• Force Close

10
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Complete these transactionsIf the current status is

• Labor Complete
• Receipt of Material, if needed
• Material Complete
• Normal Close
• Force Close

40

• Labor Complete
• Normal Close
• Force Close

45

• Receipt of Material, if needed
• Material Complete
• Normal Close
• Force Close

50

• Normal Close
• Force Close

55

Processing a labor complete transaction
For the line item to be eligible for a labor complete transaction, the original manufacturing order must have
one of these order statuses:

• 10 = Released, no activity
• 40 = Started
• 45 = Material complete

1 Select the manufacturing order line items in the Manufacturing Orders page to designate as labor
complete.

2 Select Maintain > Labor Complete
3 Specify this information:

Reference number
Specify the reference number related to the manufacturing order.

Reason code
Select the reason code related to the manufacturing order. If no codes are displayed in the drop-down
list, specify your own code. Codes are created in the Transaction Reasons object.

4 Click Continue.
The Incomplete Operations card is displayed with these tabs depending on the transaction being
processed:
• General: Shows information provided on the Labor Complete card
• Incomplete operations: Shows a listing of all the incomplete operations associated with the order
• All operations: Shows a list of all the components associated with the order
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5 Click Create.
The Order status is updated to 50 = Labor complete or 55 = Normal close.

Processing a receipt of material transaction
To use the Receipt of Material option on a line item, the manufacturing order must have one of these order
statuses:

• 10 = Released, no activity
• 40 = Started
• 50 = Labor complete

1 Select the manufacturing order line item in the Manufacturing Orders page to process as having receipt
of material to completion.

2 Select Maintain > Receipt of Material.
3 Complete the fields including this information:

Item receipt quantity
Specify the amount of material to be received.

Reason
Select the code that represents the reason for the receipt of material. If no codes are provided, you can
specify a code. Codes are created in the Transaction Reasons object.

Location
Specify the location code that matches the original location of the material.

User sequence
Specify the number indicating the sequence of this component in the bill of material. This attribute is
only displayed if you chose user sequence at application tailoring.

4 Click Continue.
The Backflush/Scrap Candidates card is displayed with these tabs depending on the transaction being
processed:
• General: Shows information provided on the Receipt of Material card
• Backflush candidates: Shows a list of all the backflush components associated with the order
• All components: Shows a list of all the components associated with the order

5 Click Create.

Processing a material complete transaction
For the manufacturing order to be eligible for the Material complete transaction, the original manufacturing
order must have an Order status of 40 = Started or 50 = Labor complete. Additionally, the finished item on
the manufacturing order must be received to completion. If not, the Receipt of Material page is displayed.

Infor XA Order-Based Production Management | 102

 

Manufacturing orders



1 Select the manufacturing order lines in the Manufacturing Orders page to designate as material complete.
2 Select Maintain > Material Complete.
3 Complete the fields including this information:

Reference
Specify the reference number related to the manufacturing order.

Reason
Select the reason code related to the manufacturing order. If no codes are displayed in the drop-down
list, specify your own code. Codes are created in the Transaction Reasons object.

4 Click Continue.
The Backflush/Scrap Candidates card is displayed with these tabs depending on the transaction being
processed:
• General: Shows information provided on the Material Complete card
• Scrap candidates: Shows a list of all the scrap components associated with the order
• All components: Shows a list of all the components associated with the order

5 Click Create.

Processing a normal close transaction
For the manufacturing order to be eligible for the Normal Close transaction, the original manufacturing order
must have an Order status of 55 = Complete.

1 Select the manufacturing order line items in the Manufacturing Orders page to designate as normal
close.

2 Select Maintain > Normal Close.
3 Click Yes.

Processing a force close transaction
You can process a Force Close transaction for all the order statuses except the 99 = Cancelled.

1 Select the manufacturing order line items in the Manufacturing Orders page to designate as force close.
2 Select Maintain > Force Close.
3 Click Yes.
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Approving a manufacturing order item (MQ)
After all operations have produced a manufactured item, the item often needs to be inspected for quality.
The item is inspected to ensure that the item meets the quality parameters set by the organization. The quality
manager is responsible for these checks before sending the item to be stocked. If the item does not match
with parameters, the item needs to be re-furbished or scrapped. Items clearing the quality inspection are
moved to the stocking location and stored or may be shipped to customer.

Use the Approve Manufacturing Order Item (MQ) transactions to report that quality control (QC) inspection
has been completed for manufactured items.
1 Select Production > Order Based > Manufacturing Order, then select a record that has been received

and waiting inspection.
If you select one or more records, some attributes default from the selected record and cannot be changed.

2 Select Maintain > Approve Manufacturing Order Item (MQ).
3 Complete the fields including this information:

Template
Select a template to show only the attributes relevant to the purpose of the template. For example,
select Reject with MO to approve, reject, and scrap an item waiting inspection for a specific manufacturing
order.

Warehouse
If you selected a manufacturing order, this attribute is automatically populated. Otherwise, specify the
warehouse for the manufacturing order.

Item
If you selected a manufacturing order, this attribute is automatically populated. Otherwise, specify the
item for the manufacturing order.

Location
Specify the location of the item. This attribute is required if the warehouse is controlled.

Batch/Lot
Specify the batch or lot number if one is assigned to this item. This attribute is maintainable if batch/lot
control was selected during application tailoring and item revision setup. This attribute is required if
the warehouse is controlled.

To warehouse
Specify the ID of the warehouse to which the quantity is approved . This attribute is displayed when you
select the Default, Complete or Reject with MO template.

To location
Specify the location to which the quantity is approved. This attribute is required if the warehouse is
controlled. This attribute is displayed when you select the Default, Complete or Reject with MO template.

Reject to warehouse
Specify the ID of the warehouse to which the quantity is being rejected. This attribute is displayed when
you select the Complete,Reject with MO, and Reject without MO template.
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Reject to location
Specify the location to which the quantity is being rejected. This attribute is displayed when you select
the Complete,Reject with MO, and Reject without MO template.

Production order
Specify the number of the production order. This attribute is displayed when you select the Default,
Complete, and Reject with MO template.

Reference
Specify information for reference purposes.

Approval reason
Select the reason for the approval. If reason codes are specified in the Transaction Reasons object, you
must select a reason in each of the reason fields shown.

Transfer reason
Select the reason for the transfer. If reason codes are specified by your company in the Transaction
Reasons object, you must select a reason. The Transfer reason attribute is displayed when you select
the Complete, Reject with MO, or Reject without MO template.

Issue transfer reason
Select the reason for issuing the transfer. If reason codes are specified by your company in the Transaction
Reasons object, you must select a reason. The Issue transfer reason attribute is displayed when you
select the Complete template.

Receive transfer reason
Select the reason for the transfer of the quantity to the receiving location. If reason codes are specified
by your company in the Transaction Reasons object, you must select a reason. The Receive transfer
reason attribute is displayed when you select the Complete template.

Rejection reason
Select the reason for the rejection. If reason codes are specified by your company in the Transaction
Reasons object, you must select a reason. The Rejection reason attribute is displayed when you select
the Complete template.

Transfer rejected reason
Select the reason for the rejected transfer. If reason codes are specified by your company in the
Transaction Reasons object, you must select a reason. The Transfer rejected reason attribute is displayed
when you select the Complete template.

Issue rejected transfer reason
Select the reason for issuing the rejected transfer. If reason codes are specified by your company in the
Transaction Reasons object, you must select a reason. The Issue rejected transfer reason attribute is
displayed when you select the Complete template.

Receive rejected transfer reason
Select the reason for the rejected transfer of the quantity to the receiving location. If reason codes are
specified by your company in the Transaction Reasons object, you must select a reason. The Receive
rejected transfer reason attribute is displayed when you select the Complete template.
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Scrap production order reason
Select the reason for scrapping the production order. If reason codes are specified by your company in
the Transaction Reasons object, you must select a reason. This attribute is displayed when you select
the Complete or Reject with MO template.

Stock scrap reason
Select the reason for the scrapping the stock. If reason codes are specified by your company in the
Transaction Reasons object, you must select a reason. The Stock scrap reason attribute is displayed
when you select the Complete, Reject with MO, or Reject without MO template.

Cost adjustment reason
Select the reason for the cost adjustment. If reason codes are specified by your company in the Transaction
Reasons object, you must select a reason. This attribute is displayed when you select the Complete or
Reject with MO template.

Badge
Specify the number that identifies the person entering the transaction. The badge number can be an
employee number or number encoded on an employee badge. This attribute is displayed when you
select the Complete template.

Turnaround
Specify the turnaround number of the item. Turnaround numbers are used with barcode readers and
can be printed on inventory documentation. Specifying the turnaround number, pre-fills other attributes
on this page. This attribute is displayed when you select the Complete template.

4 Click Continue.

Issuing an M.O. unplanned production component (IU)
Use the Issue M.O. Unplanned Production Component (IU) transaction to add a new component to a
manufacturing order (M.O.) and create an issue transaction. You can issue an unplanned quantity to the new
or existing component. For example, you have an M.O. to build a bicycle and the list of components includes
a frame, two wheels, handlebars, and a seat. You need to add training wheels to the M.O.. The training wheels
are an unplanned component, therefore, you use the IU transaction to report this addition.

This task can be used to add new or different components to a rework order for special tooling, or to add
consumable supplies to an order. An unplanned issue has no effect on allocation quantities unless the required
quantity is greater than the issue quantity. The IU transaction is similar to the Issue Item (IS) transaction
except that it applies the issue to a manufacturing order.

1 Optionally, select the records from the Manufacturing Orders list page.
If you select one or more records, some attributes default from the selected record and cannot be changed.

2 Select Maintain > Issue M.O. Unplanned Production Component (IU).
3 Complete the fields including this information:
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Template
Select a template to show only the attributes relevant to the purpose of the template. For example, use
the Uncontrolled template when issuing an unplanned production component from an uncontrolled
warehouse.

Sequence
Specify the user-assigned sequence number of the desired material detail record if the issue is applied
to a specific record in the Manufacturing Order detail page.

Location
Specify the location of the item. This attribute is required if the warehouse is a controlled warehouse.
This attribute is displayed when you select the Default or Complete template.

Standard quantity per
Specify the standard quantity for each component used in each parent item. If left blank, the attribute
is set to equal the adjusted quantity per. This attribute is required for controlled floor stock items with
a Backflush code of 2, backflush at standard. If the Backflush code is 1, adjusted quantity per, the standard
quantity per attribute is not used.
If the Backflush code for the item on this order is 2, standard quantity per, then you can specify a standard
quantity per that is different from the adjusted quantity per. When the component is backflushed, the
standard quantity is used. If you backflush at standard, you must account for material used in excess of
the standard quantity using scrap transactions.

Operation where used
Specify the sequence number of the first operation where this component is used.

Reason
Select the reason for issuing an unplanned production component. If reason codes are specified in the
Transaction Reasons object, you must select a reason.

Badge
Specify the number that identifies the person entering the transaction. The badge number can be an
employee number or number encoded on an employee badge. This attribute is displayed when you
select the Complete template.

Turnaround
Specify the turnaround number of the item. Turnaround numbers are used with barcode readers and
can be printed on inventory documentation. Specifying the turnaround number, pre-fills other attributes
on this page. This attribute is displayed when you select the Complete template.

4 Click Continue.

Rejecting a manufacturing order item (RQ)
Use the Reject Manufacturing Order Item (RQ) transaction to reject waiting inspection inventory with a
status of 19 = QC shelf life item in stock, expired or 90 = Purchased item waiting inspection to perform
these actions:
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• Scrap the inventory through the SS transaction and removes the quantity from the item location records
• Return the inventory through the VR transaction and removes the quantity from the item location records
• Leave the inventory in the item location records and change status to Rejected (80)

The RQ transaction may generate any of these child transactions:

• Scrap Item (SS): scraps the item and reduces the quantity in the item location records
• Scrap Purchase Item (SP): Scrap purchased item from P.O., if a purchased item and if a P.O. is entered
• Scrap Production Item (SM): Scrap manufactured item from M.O., if a manufactured item and if an M.O.

is entered
• Return Purchased Item to Vendor (VR): returns item to vendor and reduces the quantity in the item

location records

1 Optionally, select the records from the Manufacturing Order list page.
If you select one or more records, some attributes default from the selected record and cannot be changed.

2 Select Maintain > Reject Manufacturing Order Item (RQ).
3 Complete the fields including this information:

Template
Select a template to show only the attributes relevant to the purpose of the template. For example, use
the Default with transfer template when you are rejecting and transferring M.O, item quantities.

Warehouse
If you selected a record, this attribute is automatically populated. Otherwise, specify the warehouse for
the manufacturing order.

Item
If you selected a record, this attribute is automatically populated. Otherwise, specify the item for the
manufacturing order.

Rejected quantity
Specify the rejected quantity.

Scrapped quantity
Specify the quantity that is being scrapped. This attribute is displayed when you select the Default with
scrap, Complete, and Production order templates.

Returned quantity
Specify the quantity that is being returned. This attribute is displayed when you select the Complete
template.

Resupply
Select this check box to indicate that the vendor must send replacement inventory for the returned
inventory. Clear this check box to indicate that the vendor does not have to send replacement inventory.
The check box is cleared by default. This attribute is displayed when you select the Complete template.

Location
Specify the location of the item. This attribute is required if the warehouse is controlled.

Infor XA Order-Based Production Management | 108

 

Manufacturing orders



Batch/Lot
Specify the batch or lot number if one is assigned to this item. This attribute is maintainable if batch/lot
control was selected during application tailoring and item revision setup. This attribute is required if
the warehouse is controlled.

To warehouse
Specify the ID of the warehouse to which the quantity is being rejected. This attribute is displayed when
you select the Complete, Default with transfer, and Production order templates.

To location
Specify the location to which the quantity is being rejected. This attribute is required if the warehouse
is controlled. This attribute is displayed when you select the Complete, Default with transfer, and
Production order templates.

Production order
Specify the number of the production order. This attribute is displayed when you select the Complete
and Production order.

Purchase order
Specify the number of the purchase order. This attribute is displayed when you select the Complete
template.

Line
Specify the line item for the purchase order associated with this transaction. This attribute is displayed
when you select the Complete template.

Release
Specify the blanket release number if this is a blanket purchase order. If left blank and this is a blanket
purchase order, the receipt is applied to the oldest open release. Any remaining quantity is applied to
the next oldest release until the quantity is fully applied. This attribute is displayed when you select the
Complete template.

Rejection reason
Select the reason for the rejection. If reason codes are specified in the Transaction Reasons object, you
must select a reason in each of the reason fields shown.

PO scrap reason
Optionally, select the reason for scraping the purchase order (P.O.). If no reason is selected, the reason
from the Rejection reason attribute is used. This attribute is displayed when you select the
Completetemplate.

Stock scrap reason
Optionally, select the reason for scrapping the stock. If no reason is selected, the reason from the
Rejection reason attribute is used. This attribute is displayed when you select the Complete, Default
with scrap, Production order, template.

Scrap production order reason
Optionally, select the reason for scrapping the production order. If no reason is selected, the reason
from the Rejection reason attribute is used. This attribute is displayed when you select the Complete,
Default with scrap, and Production order template.
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Return reason
Optionally, select the reason for the return. If no reason is selected, the reason from the Rejection reason
attribute is used. The Return reason attribute is displayed when you select the Complete template.

Transfer reason
Optionally, select the reason for the transfer. If no reason is selected, the reason from the Rejection
reason attribute is used. The Transfer reason attribute is displayed when you select the Complete,
Default with transfer, and Production order templates.

Issue transfer reason
Optionally, select the reason for issuing the transfer. If no reason is selected, the reason from the Rejection
reason attribute is used. The Issue transfer reason attribute is displayed when you select the Complete
template.

Receive transfer reason
Optionally, select the reason for the transfer of the quantity to the receiving location. If no reason is
selected, the reason from the Rejection reason attribute is used. The Receive transfer reason attribute
is displayed when you select the Complete template.

Badge
Specify the number that identifies the person entering the transaction. The badge number can be an
employee number or number encoded on an employee badge. This attribute is displayed when you
select the Complete template.

Turnaround
Specify the turnaround number of the item. Turnaround numbers are used with barcode readers and
can be printed on inventory documentation. Specifying the turnaround number, pre-fills other attributes
on this page. This attribute is displayed when you select the Complete template.

4 Click Continue.

Assigning a reopen status
Only manufacturing orders with an Order status of 55 = Complete can be reopened.

1 Select the manufacturing order line items in the Manufacturing Orders page to designate as reopened.
2 Select Maintain > Reopen.
3 Click Yes.

Printing an Item Shortage report
Use the Item Shortage report to view the material for an item not available to meet current release demands
at order release.
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1 Select Production > Order Based > Manufacturing Orders > File > Host Print.
2 Select the Print check box on the Item Shortage tab.
3 Complete the fields.
4 Select the E-mail tab, then specify the information.
5 Optionally, select the Attachments tab to add attachments.
6 Click Submit.

Printing an Order Shortage report
Use the Order Shortage report option to view the material not available to meet current release demands
at order release.

1 Select Production > Order Based > Manufacturing Orders > File > Host Print.
2 Select the Order Shortage tab.
3 Select the Print check box.
4 Complete the fields.
5 Select the E-mail tab, then specify the information.
6 Optionally, select the Attachments tab to add attachments.
7 Click Submit.

Printing a Shop Packet report
Use the Shop Packet report option to print worksheets, pick lists, labor tickets and receiving tickets.

1 Select Production > Order Based > Manufacturing Orders > File > Host Print.
2 Select the Shop Packet tab.
3 Select the Print check box.
4 Complete the fields including this information:

Options group box
The Options group box contains a multi-tabbed options pane. You can use these option tabs to select
which shop packets to print and what information to display:
• Worksheet: Select Print to print worksheets to be included as part of the shop packet. If not selected,

all options on both sub-tabs are disabled. When Print is checked, select the options on the General
and Barcode tabs that meet your reporting needs.

• Pick list: Select Print to print pick lists to be included as part of the shop packet. If not selected, all
options on both sub-tabs are disabled. When Print is checked, select the options on the General
and Barcode tabs that meet your reporting needs.

• Labor tickets: Select Print to print labor tickets to be included as part of the shop packet. When
Print is checked, select the options that meet your reporting needs.
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• Receiving tickets: Select Print to print receiving tickets to be included as part of the shop packet.
When Print is checked, select the options that meet your reporting needs.

5 Select the E-mail tab, then specify the information.
6 Optionally, select the Attachments tab to add attachments.
7 Click Submit.

Generating a Work List host job
The Generate Work List host job function provides a work list for the manufacturing orders and is run by site,
not by manufacturing order. This host job updates the priorities of all the manufacturing orders in one or
more sites. Optionally, the host job prints one or more of these reports:

• Work list
• Critical orders
• Work center analysis

Depending on whether EPDM is installed, these default values apply:

• Not installed: Your work list is generated from one site only.
• Installed: All attributes have a choice for a site default. Every site can be created with these default options,

and each site uses their individual site defaults.

1 Select Production > Order Based > Manufacturing Orders > File > Host Jobs
2 Select the Execute check box on the Generate Work List tab.
3 Complete the fields under Content.
4 Under Options, select Use sited default check boxes for the options or specify information for the

attributes to override the site default.
5 Select the E-mail tab, then specify the information.
6 Click Submit.

Running the Publish Manufacturing Orders job
Use the Publish host job to send current information, for selected manufacturing orders, from XA to specified
destinations using System-Link. You can choose to publish a single manufacturing order, manually selected
manufacturing orders, or manufacturing orders in a subset. For more information, contact your System-Link
administrator.

1 Select Production > Order Based > Manufacturing Orders > File > Host Jobs.
2 Click the Publish tab.
3 Select the Execute check box.
4 Complete the fields including this information:
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Replication destination
In the Options section, specify the System-Link destination to which to send the manufacturing order
information. If you leave the replication destination blank, the replication destination specified for the
individual manufacturing orders is used.

5 Click the E-mail tab, then specify the information.
6 Click Submit.

C.O. Link/Unlink option for manufacturing orders
The Link/Unlink option for manufacturing orders is available if APC is installed and only for top-level
manufacturing orders in its hierarchy for a configured item.

By clicking the Link/Unlink C.O. Release button on the Status card, you can connect or disconnect a
manufacturing order to or from a customer order. The correct function is performed based on the current
condition of the manufacturing order. If the manufacturing order is linked to a customer order, selecting the
tool performs the unlink function. If the manufacturing order is unlinked, selecting the tool performs the link
function. The button only shows when the manufacturing order is in create or maintenance mode.

This function is not available for M.O. Components. Only top-level manufacturing orders in a configured item
M.O. hierarchy can be linked to a customer order. This function is not applicable to manufacturing orders for
non-configured items.

Linking a manufacturing order to a customer order
1 Select the manufacturing order on the Manufacturing Orders page to link to a customer order.
2 Select Maintain > Change.
3 Click the Status card tab.
4 Click the Link/Unlink C.O. Release button next to the Customer demand attribute.

The link function searches all potential customer order line item releases that can be linked to this
manufacturing order using the this criteria:
• C.O. Line Item Release item must match the manufacturing order item
• C.O. Line Item Release Configuration ID attribute must match the manufacturing order configuration

ID
• C.O. Line Item Release M.O. status attribute must not be R = Manufacturing order released
• C.O. Line Item Release Release status attribute must be less than 50 = Complete
• C.O. Line Item Release Open to pick/MBO attribute must be less than or equal to the manufacturing

order Remaining quantity
All customer order line item releases that pass the criteria are displayed in the Find C.O. Line Item Release
list.

5 Select an item release, then click Select.
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The selected release is returned to the manufacturing order. The customer order attributes are updated
with the proper values. The Customer demand is updated to reflect the change.

Unlinking a manufacturing order to a customer order
1 Select the manufacturing order on the Manufacturing Orders page to link to a customer order.
2 Select Maintain > Change.
3 Click the Status card tab.
4 Click the Link/Unlink C.O. Release button next to the Customer demand attribute.
5 Click Yes.

If the unlink option is confirmed, the data in the customer order attributes in the Manufacturing Orders
object are removed and passed to the server as part of the update transaction.
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Chapter 17: Manufacturing order history

The Manufacturing Order History object contains information related to closed manufacturing orders and
schedules.

The Manufacturing Order History list page includes information such as the item and description, warehouse
containing the item, job number, status, order quantity, stocking unit of measure, date due, and the planner
responsible for the order.

Manufacturing order history records contain information that relates the orders to other objects. For example,
a manufacturing order history has ties to the Warehouses object. You can use the Display menu options to
see more information in other objects that is related to a selected order or schedule. Depending on what
applications are installed, you can use options under the Maintain menu to work with information in other
objects that is related to a selected order or schedule.

This table shows Manufacturing Order History related objects:

Viewable informationObject

A list of the components used to manufacture the
item associated with the closed order

M.O. History Components

A list of the operations used to manufacture the item
associated with the closed order

M. O. History Operations

A list of the miscellaneous charges associated with
the closed order

M. O. History Miscellaneous Charges

A list of the inventory transaction history associated
with the closed order

Inventory Transaction History

A list of the labor activity transactions associated
with the order

Labor Activity Transaction History

Copying a manufacturing order history record to a
manufacturing order
1 Select Production > Order Based > Manufacturing Order History.
2 Select the manufacturing order history record.

Infor XA Order-Based Production Management | 115

 

Manufacturing order history



3 Select Maintain > Copy to Manufacturing Order.
4 Complete the fields including this information:

Standard in quantity
Specify the recommended starting quantity of the manufacturing order.

Total order quantity
Specify the order quantity of a manufacturing item determined after any changes from deviation quantity
and split order quantity.

5 Click Copy.

M.O. History Components
The M.O. History Components object contains a list of all the components of the parent item on the selected
manufacturing order history record. The information shown contains the component description, the
components warehouse, the standard quantity of the component expected to be issued to this order, and
the actual quantity issued of the component to date, unit of measure, and the date required.

You can use the Display menu options to see more information in other objects that is related to a selected
component. For example, the Inventory Transaction History option shows a list of the inventory transaction
history records associated with the component on the order.

M.O. History Miscellaneous Charges
The M.O. History Miscellaneous Charges object contains a list of all miscellaneous charges related to the item
on the selected manufacturing order.

The information shown contains the charge number and its description, the standard and actual quantities
and costs, and the date of the last transaction associated with the miscellaneous charge.

You can use the Display menu options to see more information in other objects that is related to a selected
miscellaneous charge. For example, the Manufacturing Order History option shows a list of information
related to closed manufacturing orders and schedules.

M.O. History Operations
The M.O. History Operations object contains a list of all operations related to the item on the selected
manufacturing order.

The information displayed contains the operation description, the facility where the operation is performed,
the operation status, the department responsible for the facility, the process sheet ID, and the tool number
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associated with that operation. You can see whether or not additional routing descriptions are defined for
this operation.
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Chapter 18: M.O. components

The M.O. Components object contains a list of all the components of the parent item on the selected
manufacturing order.

The information contains this information:

• Component description
• Component warehouse
• Standard quantity of the component expected to be issued to this order
• Actual quantity issued of the component to date, unit of measure, and the date required

A specific M.O. component record can have ties to information in other objects. You can use the Display menu
options to see more information in other objects that is related to a selected component. Depending on what
applications are installed, you can use the Maintain menu options to work with information in other objects
that is related to a selected component.

This table shows M.O. components related objects:

Viewable informationObject

A list of the discrete allocations associated with the
component on the order

Discrete Allocations

A list of the inventory transactions associated with
this M.O. component.

Inventory Transaction History

A list of the top-level requirement that generated
the need for the component associated with the or-
der

Sources of Demand

A list of the purchase order associated with the
component on the order

M.O. Component P.O.s

A list of the requisition associated with the compo-
nent on the order

M.O. Component Requisitions

Creating an M.O. component
1 Select Production > Order Based > Manufacturing Orders.
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2 Select the manufacturing order for which to create an M.O. component.
3 Select Display > M.O. Components.
4 Select Maintain > Create.
5 Select a manufacturing order.
6 Complete the fields including this information:

Component warehouse
Specify the warehouse in which this component resides.

Component item revision
This attribute is only available if EPDM is installed. Specify the component item revision number.

7 Click Create.

Changing an M.O. component
1 Select the manufacturing order that contains the M.O. component in the Manufacturing Orders list page.
2 Select Display > M.O. Components.
3 Select the M.O. component.
4 Select Maintain > Change.
5 Change the attributes.
6 Click Update.

Copying M.O. components
1 Select the manufacturing order that contains the M.O. component in the Manufacturing Orders list page.
2 Select Display > M.O. Components.
3 Select the M.O. component.
4 Select Maintain > Copy.
5 Complete the fields including this information:

Order
Specify the order number to use for the new component item. If you are using system-generated
component item numbers, the next available component item is shown in the attribute.

User sequence
Specify the user sequence number.

Operation where-used
Specify the operations number.

6 Click Copy.
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Deleting M.O. components
1 Select the manufacturing order that contains the M.O. component in the Manufacturing Orders list page.
2 Select Display > M.O. Components.
3 Select the M.O. component.
4 Select Maintain > Delete.
5 Click Yes to delete.
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Chapter 19: M.O. operations

The M.O. Operations object contains a list of all operations related to the item on the selected manufacturing
order.

The information displayed contains the operation description, the facility where the operation is performed,
the operation status, the department responsible for the facility, the process sheet ID, and the tool number
associated with that operation. You also can see whether or not additional routing descriptions are defined
for this operation.

A specific M.O. operations record can have ties to information in other objects. You can use options under
the Display menu to see more information in other objects that is related to a selected operation. Depending
on what applications are installed, you also can use options under the Maintain menu to work with information
in other objects that is related to a selected operation. Availability of the Maintain menu depends on what
applications you have installed.

This table shows M.O. components related objects:

Viewable informationObject

A list of the components associated with the opera-
tion

Operation Components

A list of the M.O. outside operations associated with
the operation

M.O. Outside Operations

Creating M.O. operations
1 Select Production > Order Based > Manufacturing Orders > Maintain > Create.
2 Select the manufacturing order, then select Display > M.O. Operations.
3 Select Maintain > Create.
4 Complete the fields including this information:

Facility (standard)
Specify the facility code of the M.O. operation.

5 Click Create.
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Changing M.O. operations
1 Select the manufacturing order that contains the M.O. operation on the Manufacturing Orders list page.
2 Select Display > M.O. Operations.
3 Select the M.O. operation.
4 Select Maintain > Change.
5 Change the attributes.
6 Click Update.

Creating an M.O. outside operation for an M.O. operation
When creating or changing an M.O. operation you can create an M.O. outside operation if the Time basis code
(TBC) is set to Cost / piece.
1 Click the Hours tab on the Create M.O. Operations or Change M.O. Operations page.
2 Ensure that the Time basis code attribute is set to Cost / piece.
3 Click the General tab.
4 Click the Create icon under M.O. Outside Operations.
5 Complete the fields including this information:

Release code
Select a value. These values are valid:
• No

• Requisitions

• Held P.O.

• P.O.

• Held blanket

• Blanket

• Held blanket-fixed

• Blanket-fixed

Vendor
Specify a vendor or click the Find Vendor icon to select a vendor. Optionally, click the Find Outside
Operation icon next to the Vendor attribute to select an outside operation detail record that corresponds
with the M.O. operation.

Service item
Specify the service item or click Find Item Revision to select an item revision.

Qty/cost update
Select a value for the update. These values are valid:
• Invoice

• Receive P.O.

• Receive P.O./Invoice
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Update operation status
Select this box to set Operation status to Complete when cost is reported complete.

6 Click Create, then click Create on the next page.
7 Click Continue until the Confirm dialog box is displayed.
8 Click Confirm.

Creating a milestone for an M.O. operation
Use the Create Milestone option to group a collection of operations as a unit for tracking purposes. The range
of the milestone must include all of the sequence numbers that exist between the start sequence number
and the ending operation sequence number.

1 Select the manufacturing order (M.O.) that contains the M.O. operation in the Manufacturing Orders
list page.

2 Select Display > M.O. Operations.
3 Select the M.O. operation that is to be the first M.O. operation in the milestone group.
4 Select Maintain > Create Milestone
5 Complete the fields including this information:

To operation
Specify the To operation.

Milestone type
Select Flow shop or Job shop for the type of milestone group.

6 Click Continue.

Copying M.O. operations
1 Select the manufacturing order that contains the M.O. operation on the Manufacturing Orders list page.
2 Select Display > M.O. Operations.
3 Select the M.O. operation.
4 Select Maintain > Copy.
5 Complete the fields including this information.

Copy M.O. Operation Description
Select this check box to copy the additional description from the source M.O. operation.

6 Click Copy.

Infor XA Order-Based Production Management | 123

 

M.O. operations



Deleting M.O. operations
1 Select the manufacturing order that contains the M.O. operation on the Manufacturing Orders list page.
2 Select Display > M.O. Operations.
3 Select the M.O. operation.
4 Select Maintain > Delete.
5 Click Yes.

Deleting a milestone for a manufacturing order
1 Select the manufacturing order that contains the M.O. operation on the Manufacturing Orders list page.
2 Select Display > M.O. Operations.
3 Select the M.O. operation.
4 Select Maintain > Delete Milestone.
5 Click Yes.

Reporting M.O. operation activities
Use the Report M.O. Operation Activity transaction for reporting quantities, scrap, machine, and labor times
for an M.O. Operation.

This transaction is only available if Shop Floor is active in OBPM application settings.
1 Select Order Based > Manufacturing Orders.
2 Select the manufacturing order from the list.
3 Select Display > M.O. Operations.
4 Select the outside operation.
5 Select Maintain > Report M.O. Operation Activity.
6 Complete the fields including this information:

Template
Select a template to show only the attributes relevant to the purpose of the template. For example,
select the Milestone template to report the activity as a milestone operation.

Order
Specify the order number of the operation on which the employee is working. If you selected a labor
activity, this attribute is automatically populated.

Operation
Specify the operation of the operation on which the employee is working. If a labor activity transaction
is selected, this attribute is may be automatically populated.

Infor XA Order-Based Production Management | 124

 

M.O. operations



Run type
Select the type of run for the activity. These values are valid:
• Setup

• Run

• Milestone group: This value can only be used with a milestone
This attribute is displayed when you select the Default or Scrap quantity template.

Completion code
These values are valid:
• 0=Open: Not complete. Quantity can be reported.
• 1=Complete with entered quantity: You must specify quantity with this completion code.
• 2=Complete with defaulted: You do not specify quantity with this completion code. The quantity is

assumed to be the quantity still open for the operation.
• 3=Milestone: Closes all milestone sub-operations and set the operation status to complete. This

completion code can only be used with a Run code of M.

Complete
Specify the quantity that is complete. This attribute is displayed when you select the Default, Milestone,
and Setup template.

Scrap
Specify the scrap quantity. This attribute is displayed when you select the Default, Scrap quantity, and
Setup template.

Reason
Select a reason for the scrap. If reason codes are specified in the Transaction Reasons object, you must
select a reason for the scrap. If your company does not require reason codes, blank is a valid entry.

Labor
Specify the amount of labor time in hours or minutes. If the Time basis code for M.O. Operation is not
M (minutes), then the labor time is assumed to be hours. If the Time basis code is M (minutes), then the
labor time is assumed to be minutes. For an operation in a milestone group type F (flow shop
environment), labor time entry is not accepted.

Machine
Specify the amount of machine time in hours or minutes. If the Time basis code for M.O. Operation is
not M (minutes), then the machine time is assumed to be hours. If the Time basis code is M (minutes),
then the machine time is assumed to be minutes. This attribute is not valid for a milestone group
sub-operation. This attribute is displayed when you select the Default or Setup template.

Reference
Specify information for reference purposes.

Transaction cost
Optionally, specify the cost for the transaction. This cost is overridden if this cost is true:
• Standard rates are being used as actual costs
• Actual employee costs are being used
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For outside operations, specify the transaction cost if actual costs are not coming from associated
purchase order or invoice. This attribute is not valid for a milestone group sub-operation. This attribute
is displayed when you select the Default or Setup template.

Actual work center
Specify the work center being used for the operation. You can specify an override work center only for
the first transaction for an operation. This attribute is displayed when you select the Default or Setup
template.

Badge
Specify the employe badge number. This attribute is mandatory. If an employee record is selected, this
attribute is automatically populated.

Rate override
This attribute is displayed when you select the Default or Setup template.

Shift override
Specify 1, 2,or 3 for the shift override. This attribute is displayed when you select the Default or Setup
template.

Turnaround
Specify the turnaround number of the operation on which the employee is working.

7 Click Continue.
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Chapter 20: M.O. outside operations

An M.O. outside operation in XA is an operation performed by a vendor that provides outside service.

When an M.O. operation is created with Time Basis Code of C = Cost/piece, an outside service can be performed
on that operation. An M.O. outside operation is then created and linked to this M.O. operation to perform this
outside service.

M.O. outside operations and outside operations are created in IDF when OBPM is installed and EPDM is
activated.

You can use the Display menu to view the related outside operations for a selected M.O. outside operation.

Outside operations
An outside operation in XA is a setup record used when creating an M.O. outside operation.

An outside operation in XA is a setup record that can be used when creating an M.O. outside operation. When
an M.O. operation is created with a Time basis code of C=Cost/piece an M.O. outside operation is created.
The M.O. outside operation details are provided by an outside operation setup record. If multiple outside
operation setup records exists, then you have the option to select an outside operation before the M.O. outside
operation is created.

An outside operation setup record is linked to a routing operation. One or more outside operations can be
linked to a routing operation.

Outside operation setup records can be created in IDF when OBPM is installed and EPDM is activated.

Note: If OBPM is not installed and EPDM is not activated, then outside operations are created and maintained
in PCC.

To create an outside operation you must have these records:

• Item revisions in EPDM defined as a service item
• A vendor as a service provider
• Production facility
• Routing for operation activity

A specific outside operation can have ties to information in other objects. You can use the Display menu
options to see information in other objects that is related to a selected outside operation. Depending on what
applications are installed, you can use the Maintain menu options to work with related information in other
objects.
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This table shows outside operations related objects:

Viewable informationObject

A list of the manufacturing orders (M.O.) associated
with the outside operation

Manufacturing Order

A list of the manufacturing order (M.O.) outside op-
erations associated with the outside operation

Manufacturing Order Outside Operations

Creating outside operations
Outside operations can be created for routing operations with a Time Basis Code (TBC) of C = cost/piece.

1 Double-click the routing operation with a TBC of Cost / piece in the Routing Operations list page.
2 Click the Create icon under Outside Operations.
3 Complete the fields including this information:

Preferred
Select this check box to indicate that the vendor is the preferred vendor. Note that at least one record
with a primary vendor associated with the site, item, revision, or warehouse must exist. If a record does
not exist, then the Preferred check box is automatically selected.

Service item
Specify the item revision or click Find Item Revision to select one.

4 Click Create.

Creating M.O. outside operations
1 Select Production > M.O. Outside Operations > Maintain > Create.
2 Complete the fields including this information:

Create PO / req at MO release
Select this check box to create a purchase order (PO) or requisition when a manufacturing order (M.O.)
is created. This attribute is only applicable when you are creating an M.O.

Release code
Select a value. These values are valid:
• No

• Requisitions

• Held P.O.

• P.O.

• Held blanket

• Blanket
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• Held blanket-fixed

• Blanket-fixed

Operation sequence

Service item
Specify the service item or click Find Item Revision to select an item revision.

Qty/cost update
Select a value for the update. These values are valid:
• Invoice

• Receive P.O.

• Receive P.O./Invoice

Update operation status
Select this check box to update the Operation status attribute on the General tab of the M.O. Operation.

3 Click Create, then click Create again.

Releasing an M.O. outside operation
You can release an M.O. outside operation when the purchase order (P.O.) for the M.O. outside operation is
blank and the vendor is an active vendor in the vendor object. You cannot release an M.O. if the purchase
order (P.O.) is assigned to the M.O. outside operation.

1 Select the M.O. outside operation.
2 Select Maintain > Release.
3 Complete the fields including this information:

Vendor
Optionally, select a different vendor from the one shown. You can select a vendor from outside operations
or any active vendor from the Vendor master file.

Release code
Select a code. This attribute is maintainable if Vendor is not blank. These values are valid:
• 0 = No
• 1 = Requisitions
• 2 = Held P.O.
• 4 = Held blanket
• 5 = Blanket
• 6 = Held blanket-fixed
• 7 = Blanket-fixed
If you select 6 or 7, then a fixed blanket must exist.
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Service item
Specify the service item number or click Find Item Revision to select a service item from the Find Item
Revision list.

Qty/cost update
Select where the quantity or cost is to be updated. These values are valid:
• Invoice
• Receive P.O.
• Receive P.O./Invoice

Update operation status
Select the check box to indicate that the operation status is to be updated.

4 Click Continue.
If you select the Return here to create another check box, the next valid M.O. outside operation is
displayed.
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Chapter 21: MRP Recommendations

The MRP Recommendations object provides you with all of the orders planned by MRP that were created for
a warehouse during an MRP planning run.

The recommended orders include all the released and firmed manufacturing, purchase orders, inter-site
orders, and purchase requisitions; and any planned orders with a start date on or before your MRP Review
Horizon. During planning, MRP defines its recommended actions (recommendations, for example, release,
expedite, defer, cancel) by assigning an exception to an order.

You can view all records or any provided subset of records in the file and take action on the recommendations
as appropriate. You can access the MRP Recommendations object from related objects like Planners and
Buyers, where you can view only the recommendations that pertain to that planner or buyer. You can also
maintain MRP Recommendations for manufacturing schedules and KBC items. In addition, there are several
maintainable options in the MRP Recommendations object. You can perform these options on a single record
or run in Mass mode by predefined set of records or by user-selected records. Included in the seven
maintainable options are these five basic transactions:

• Create order: Creates or releases an order or requisition from a planned or firm planned order. As you
create the order, you can make changes to attributes to fit the current situation. You use the set of cards
based upon the Make/buy new code that exists on the recommended order. You can change the Make/buy
new attribute to create a different order if desired, and the cards that you view will change to reflect the
new Make/buy new code that has been selected. For example, if you select a manufacturing order to
create, the Manufacturing Order card opens. If you decide to change the order into a purchasing order
(by changing the Make/buy new attribute), the Purchase Order card opens. Different attributes may only
apply to certain Make/buy new types. Therefore, applicable attributes will be enabled or disabled based
upon the Make/buy new attribute chosen.

• Change: Changes any kind of order or requisition. Changing a planned order will firm the order.
• Cancel: Cancels any type of order or requisition
• Accept: Accepts or implements the MRP recommendation, for example: creating/releasing an order
• Firm: Firms, without change, a planned order, which prevents MRP from re-planning or changing the

order in the next MRP planning run

Using a user preference you can create transactions either in Immediate or Deferred update mode. The
Immediate mode enables you to complete all of the transactions inline, while the Deferred mode allows you
to record the transaction in the MRP Recommendations order review file without processing the transaction.
With deferred processing, you can use the reset transaction to back out any pending deferred transaction,
or use the process transaction to process the pending transaction. Another user preference allows you to
print shop packets while creating a manufacturing order.
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The MRP Recommendations object also contains the option Check Component Availability that allows you
to view the availability of the components required, evaluate alternatives to the recommendations, and take
the most appropriate action.

A specific MRP recommendation can have ties to information in other objects. Within the MRP
Recommendations object, you can use options under the Display menu to see information in other objects
that is related to a selected MRP recommendation. Depending on what applications are installed, you also
can use options under the Maintain menu to work with information in other objects that is related to a selected
recommendation.

Accepting an MRP recommendation
Using the Accept function you can select an order or recommendation and accept the recommendations that
have been provided by the planning run.

1 In the MRP Recommendations list window, select the order or items to accept the recommendation.
2 Select Maintain > Accept.
3 Specify this information:

Immediate processing of this transaction
Select this option to process this transaction when you click Accept.

Print shop packet at M.O. release
Select this option to print the shop packet when the manufacturing order is released.

4 Click Accept to confirm your request. If you selected Preview before create the Change MRP
Recommendations card file opens. Click Update to accept the recommendation and any changes you
made. Click Cancel to cancel your request to accept the recommendation.

Creating an order for an MRP recommendation
1 Select MRP Recommendations.
2 From the MRP Recommendations list window, select Maintain > Create.
3 Specify any final attribute overrides to create the order.
4 Click Create Order.

Changing an MRP Recommendation
You can change a released, planned, or firm planned order or requisition. Changing a planned order results
in a firmed planned order and preserves the changes made for the next MRP planning run. The change option
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returns you to the original set of cards used in the creation of the order. You can change the maintainable
attributes in those cards.

1 Select MRP Recommendations > Maintain > Change.
2 From the Change MRP Recommendations card file, make final attribute overrides to the recommended

order.
3 Click Update.

Firming orders for MRP recommendations
You can reserve the selected planned order for a future transaction, which prevents MRP from re-planning
or changing the order in the next MRP planning run. To change and firm a planned order, you can use the
Change option on the Maintain menu, which automatically firms the order.

1 In the MRP Recommendations list window, select the order or items to firm.
2 Select Maintain > Firm.
3 Specify this information from the Firm MRP Recommendation prompt:

Immediate processing of this transaction
Select this option to process this transaction when you click Firm.

Preview before firm
Select this option to preview the order before it is firmed.

4 Click Firm to confirm your request. Click Cancel to cancel the order.

Canceling an MRP recommendation
1 In the MRP Recommendations list window, select the recommendation order or items to cancel an

order.
2 Select Maintain > Cancel.
3 Specify this information

Immediate processing of this transaction
Select this option to process this transaction when you click Cancel Order.

4 Click Cancel Order to confirm your request. Click Cancel to cancel your request to cancel the order.
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Resetting an MRP recommended order
You can only reset a recommendation with a deferred transaction status that has not been processed. Resetting
the transaction clears or backs out the pending deferred action, setting the recommendation back to its
status before the deferred action was entered.

1 In the MRP Recommendations list window, select the order or items to resert a recommended order.
2 Select Maintain > Reset.
3 Click Reset to reset the original recommended order.

Processing an MRP recommendation
You can only process a recommendation with a deferred transaction status that has not been processed.
Processing the transaction performs all of the required transaction processing and updates. In addition, to
print any reports from MRP Order Release (other than shop packets for manufacturing orders), you can use
the MRP Order release menu.

1 In the MRP Recommendations list window, select the order or items to process a recommended order.
2 Select Maintain > Process.
3 Click Process to process the original recommended order.

Checking component availability for an MRP
recommendation
Using this option you can search for available components related to a selected order. You can consider
alternatives if a specific component is not available. You can use this option to analyze interactively the
availability of required components for one order or a group (subset of records, or a group of orders you pick)
of potential manufacturing orders. The option provides viewing capabilities by order and by component, and
you can view all or short lists of the orders and components. The object also provides what-if component
substitutions and order quantity changes.

1 Select MRP Recommendations > .
2 In the MRP Recommendations list window, select the recommendation order or items to check component

availability.
3 Select Maintain > Check Component Availability.
4 Specify this information:

Subset
Select an available subset from the drop-down list to search for the related components of your item.
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Consider future allocations as available
Select this option if you want time either phased allocations or manufacturing allocations required
beyond either the item lead time or the allocation horizon set in MRP.

5 Click Create.
The Create Component Availability card file opens. This card file contains these three tabs and related
sub tabs:
• Potential Orders: Provides a listing of potential orders. Select the Short tab to see the subsetted

list of items that are short orders. Select the All tab to view the complete list.
• Components: Provides the list of components and related orders. Select the Short tab to see the

component short list. Select the All tab to view the complete list.
• Errors: Provides any errors that may have occurred based upon the requested component availability

and subset selected.

6 Click Create.

Performing mass accept for an MRP recommendation
Using the mass accept function, you can mass accept the orders that were recommended by the planning
run. Using the Mass Accept option impacts a large range of orders.
1 In the MRP Recommendations list window, select the recommendation order or items to perform mass

accept.
2 Select Maintain > Accept.
3 Specify this information:

Description
Specify a description of the mass accept being performed.

Subset
Select an available subset from the list.

Immediate processing of this transaction
Select this option to process this transaction when you click Continue.

Print shop packet at M.O. release
Select this option to print the shop packet when the manufacturing order is released.

4 Click Continue to mass accept the MRP recommendations.
5 Click Yes to update the MRP recommendation.
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Performing mass create orders for an MRP
recommendation
Using the Mass Create Orders option you can mass create orders. Note that using the mass create orders
option impacts a large range of orders.

1 In the MRP Recommendations list window, select the recommendation order or items to perform mass
create.

2 Select Maintain > Mass Create.
3 Specify this information:

Description
Specify a description of the mass create being performed.

Subset
Select an available subset from the list.

Immediate processing of this transaction
Select this option to process this transaction when you click Continue.

Print shop packet at M.O. release
Select this option to print the shop packet when the manufacturing order is released.

4 Click Continue.
5 Click Yes.

Performing mass change for MRP recommendations
Using the Mass Change option you can perform mass changes on recommended orders. Note that using the
Mass Change option impacts a large range of orders.

1 In the MRP Recommendations list window, select the recommendation order or items to perform mass
change.

2 Select Maintain > Mass Change.
3 Specify this information:

Transaction description
Specify a description of the mass change being performed.

Transaction criteria
Select the subset to be used in selecting the MRP recommendations and the sort to determine the
processing order of the objects included in the subset.

Available attributes
Select an available attribute or attributes from the list. Click the Add button.

4 From the Mass change definition dialog, specify this information:
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Update type
Select either replace value or adjust value. If you select replace value, include the value to be replaced.

5 Click Click Continue.
6 Click Update.
7 Click Yes.

Performing mass firm for an MRP recommendation
Using the Mass Firm option you can mass firm planned orders. Note that using the Mass Firm option will
impact a large range of orders.

1 In the MRP Recommendations list window, select the recommendation order or items to perform mass
firm.

2 Select Maintain > Mass Firm.
3 Specify this information:

Description
Specify a description of the mass firm being performed.

Subset
Select an available subset from the list.

Immediate processing of this transaction
Select this option to process this transaction when you click Continue.

4 Click Continue.
5 Click Yes.

Performing mass cancel for an MRP recommendation
The Mass Cancel option enables the user to mass cancel orders. Note that using this option impacts a large
range of orders.

1 In the MRP Recommendations list window, select the recommendation order or items to perform mass
cancel.

2 Select Maintain > Mass Cancel.
3 Specify this information:

Description
Specify a description of the mass cancel being performed.
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Subset
Select an available subset from the list.

Immediate processing of this transaction
Select this option to process this transaction when you click Continue.

4 Click Continue.
5 Click OK.

Performing Mass Reset for an MRP recommendation
Using the Mass Reset option you can mass reset orders that currently have a deferred status. Note that using
the Mass Reset option impacts a large range of orders.

1 In the MRP Recommendations list window, select the recommendation order or items to perform mass
reset.

2 Select Maintain > Mass Reset.
3 Specify this information:

Description
Specify a description of the mass reset being performed.

Subset
Select an available subset from the list.

Immediate processing of this transaction
Select this option to process this transaction when you click Continue.

4 Click Continue to accept and trigger the mass reset the transaction.
5 Click Yes to update the MRP recommendations.

Performing mass process for an MRP recommendation
Using the Mass Process option you can mass process all of the actions that have a status of deferred update,
thereby changing the status of each of the orders to immediate update status. Note that using the Mass
Process option impacts a large range of orders.

1 In the MRP Recommendations list page, select the recommendation order or items to perform mass
process.

2 Select Maintain > Mass Process.
3 Specify this information:

Description
Specify a description of the mass process being performed.
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Subset
Select an available subset from the list.

Immediate processing of this transaction
Select this option to process this transaction when you click Continue.

Print shop packet at M.O. release
Select this option to print the shop packet when the manufacturing order is released.

4 Click Continue.
5 Click Yes.
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Chapter 22: Planners

A planner is responsible for planning and managing the availability of a set of items.

The Planners object creates a record for each planner number present in item warehouse, manufacturing
order, and purchase order item records. Use the planner to navigate across a variety of records by planner
number.

For instance, view only the MRP recommendations or the open manufacturing orders, assigned to a specific
planner. A planner number is validated against this file in client item warehouse, manufacturing order, and
purchase order entry and maintenance. The planner file is keyed by planner number, and includes planner
name, user ID, department, phone number, user fields, and create and change user, date and time.

A planner can have ties to information in other objects. For example, you can navigate, subset, and edit items
in a warehouse, open manufacturing orders, or purchase orders that are assigned to a specific planner. Within
the Planners object, you can use Display menu options or toolbar buttons to see information in other objects
that is related to a planner.

Creating a planner
When you create a planner, you create a new card file and a new entry in the Planners list window.

1 Select Planner > Maintain > Create.
2 From the Create Planner dialog, specify this information:

Template
Select an existing template from the list or click the Template button to modify a template.

Planner
Specify the planner number for the new planner.

Name
Specify the planner name.

3 Click Create.
If you select Preview before create, the card file for the planner opens. Make any changes or additions
that are necessary to the planner information, then click the Create button. If you do not select Preview
before create, the new planner is created and added to the list of planners.
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Changing a planner
1 Select Planner.
2 Select the planner to change by highlighting the planner in the Planners list page or by opening the

Planner card file.
3 Select Maintain > Change.
4 Make the changes to information.
5 Click Update.

Deleting a planner
You cannot delete a planner if the planner is assigned to an item warehouse, manufacturing order, or purchase
order.

1 Select Planner.
2 Select the planner to delete by highlighting the planner in the Planners window.
3 Select Maintain > Delete.
4 Click Yes.
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Chapter 23: Production GL transactions

The Production GL Transactions object contains Production Control & Costing (PC&C) and Repetitive Production
Management (REP) transaction information created in XA that you want to be available in EGLi.

The Order Based and Rate Based Production GL Transactions objects are installed when you install OBPM or
RBPM.

The General Ledger interface in PC&C creates ledger entries to record costs charged to manufacturing orders
and cost variances when manufacturing orders are closed out. From an accounting viewpoint, work in
manufacturing orders increases when PC&C accumulates material, labor, and overhead costs against an
order. Work in manufacturing orders decreases when users process Receive Production Item (RM) transactions.
When you close out and purge an order, order variances are calculated in PC&C and an order closeout variance
transaction is created to force the work in progress balance to zero.

The General Ledger interface in REP creates ledger entries to record labor, machine, and overhead costs to
manufacturing schedules. Accounting for other REP activities, such as material costs and production receipts,
is handled through the General Ledger interface in Inventory Management (IM).

The production transaction information in the Order Based and Rate Based Production GL Transactions
objects is used by EGLi to create GL journal entries for production in EGLi when all of these conditions exist:

• OBPM or RBPM is installed
• OBPM and RBPM are interfacing with Enterprise General Ledger
• Production ledger entries are created in XA
• General Ledger interface in XA is active
• Generate Production GL Journal Entries host job is run
• Processing in EGLi is successful and no errors are received

EGLi accounts are assigned by EGLi from user-defined rules based on the warehouse, transaction type, item,
and order information. You define the transaction type for general ledger transmission when you set up the
General Ledger interface for order based and rate based production transactions.

To find the production GL transactions that have EGLi errors, use the Error transactions subset in the
Production GL Transactions list page. To display the error messages for a transaction, use the Error Messages
option from theDisplay menu or view from the details card.

Correct the EGLi errors in the EGLi configuration of account segments, charts of accounts, financial calendars,
ledgers, macros, models, event classes, and subsystems. Then, resend the GL transactions that have EGLi
error messages using the Generate Production GL Journal Entries host job.
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Running the Generate Production GL Journal Entries job
Use the Generate Production GL Journal Entries host job to initially send or resend production GL journal
entries to EGLi.

Correct the EGLi errors in the EGLi configuration of account segments, charts of accounts, financial calendars,
ledgers, macros, models, event classes, and subsystems. Then, resend the GL transactions that have EGLi
error messages using this host job.

1 Select one of these options:
• Select Production > Order Based > Order Based Production GL Transactions > File > Host Jobs
• Select Production > Order Based > Rate Based Production GL Transactions > File > Host Jobs

2 Select the Execute check box if not already selected..
3 Complete the fields including this information:

Override journal entry date
Specify or select the override posting date used for the EGL journal entries. This date is used in place of
the date on the transaction.

Summarize IFM journal entries - Charge
Select the option to use for the charge. These values are valid:
• No Summarization
• Unit, naturet, transaction type
• Unit, nature

Summarize IFM journal entries - Offset
Select the option to use for the offset. These values are valid:
• No Summarization
• Unit, naturet, transaction type
• Unit, nature

IFM transaction - Type
Select the code that classifies the transaction type. For example, payable invoices, receivable credit
notes, cash receipts, payable credit for goods returned, receivable invoice for services, or cash receipts
for goods sold. The transaction type determines the type of ledger in which the transaction is entered,
for example, AR, AP, cash book, or general ledger.

IFM transaction - Number
Specify the number to identify the transaction. Based on values in the associated ledger, this number
can be generated automatically and can contain a user-assigned prefix and suffix for identification
purposes.

IFM transaction - Narrative
Specify a brief description of the transaction.

IFM transaction - Financial division
Specify the identifier for the financial division in which the transaction occurred.
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IFM transaction - Originating unit
Specify the organizational unit, cost center, that initiated the transaction. The organizational unit must
be in the same financial division as the transaction. If no unit is specified on transaction lines, the
originating unit is the default unit for posting to the general ledger.

IFM transaction - Period
Specify the accounting period to which the transaction is posted. This period must be open in the
transaction ledger. To use the period that is associated with the journal entry date, leave this attribute
blank.

4 Select the E-mail tab, then specify the information.
5 Click Submit.

You can track the progress of the this host job in the Transaction Status object.

Workspaces
Workspaces are a collection of choices for how you want to display and work with information in the Order
Based/Rate Based Production GL Transactions objects. When you apply a workspace, the choices in the
workspace override your default choices specified in Preferences for this log-on session.

Order Based Production GL Transaction workspace

The Order Based Production GL Transactions workspace shows order based production GL transactions. In
this workspace, you can use the OBPM subset to work with order based production transactions.

Rate Based Production GL Transaction workspace

The Rate Based Production GL Transactions workspace shows rate based production GL transactions. In this
workspace, you can use the RBPM subset to work with rate based production transactions.
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Chapter 24: Reorder recommendations

The Reorder Recommendations object shows a preview of order recommendations for replenishment items.
that are generated at the warehouse level that are eligible for action.

The replenishment items are generated at the warehouse level and are eligible for action. Use this object to
see all the items that need replenishment in a warehouse and the quantity of the replenishment.

Reorder recommendations are created for item warehouses with the quantity available less than the reorder
point. You can create or refresh these recommendations with the Generate Reorder Recommendations host
job option. This host job can also be run by using the Submit Work List Generation (SBMPCCWLG) AS/400
command in OBPM in a user program, which you can set up to run on a scheduled basis using OS/400 scheduled
jobs. Reorder recommendations are always generated for all order point items in a warehouse or a subset of
warehouses.

A specific reorder recommendation can have ties to information in other objects. You can use Display menu
options or toolbar buttons to see information in other objects that is related to a selected recommendation.

Checking component availability
Use the Check component availability option to analyze component availability for potential orders from
sources. Sources may be MRP recommendations, reorder recommendations, or customer demand. You can
check component availability for potential orders created from item warehouses.

1 Select orders or items for which to check component availability.
2 Select Maintain > Check Component Availability.
3 Complete the fields including this information:

Subset
Select a value from the list. This value is used by the source object to restrict the list of potential orders.
Note that the more records selected, the longer the process may take.

Consider future allocations as available
Select the check box to consider these components when availability is checked. This option is only
available if MRP is installed.

4 Click Create.
5 To create a list of all potential orders, click Create on the Create Component Availability page.
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Creating orders for reorder recommendations in mass
1 Select the recommendation orders or items for which to perform a mass create.
2 Select Maintain > Mass Create Orders.
3 Complete the fields.
4 Click Continue, then click Yes.

Creating an order for a reoder recommendation
When you create an order from a reorder recommendation, the item type defaults to the type of item planned
by the order recommendation. You can change the type of item recommended for an order and specify the
required information for the type of item contained in an order.

You can create manufacturing orders, purchase orders, intersite orders, and requisitions from Reorder
Recommendations.

1 Select the recommendation for which to create an order.
2 Select Maintain > Create Order.
3 Change the necessary fields.

If the planned item type contained in the order is a manufactured item, specify information that is required
to create a manufacturing order. If the item type is an intersite item, specify information required for
creating an intersite order.

4 Click Create Order.

Running a Generate Reorder Recommendations host job
Use the Generate Reorder Recommendations host job to create or refresh reorder recommendations.
Reorder recommendations are always generated for all order point items in a warehouse or a subset of
warehouses.

Use this host job to select whether to automatically create or not automatically create replenishment orders
during generation. After you generate a list of reorder recommendations, you can view them and create orders
from the Reorder Recommendations object. You can change order type, quantity, and other information as
you create orders.

1 Select File > Host Jobs.
2 Select the Execute check box.
3 Complete the fields including this information:

Create manufacturing orders
Select the value from the list. These values are valid:
• Create
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• Create, if all components are available
• Create based on auto release code
• Do not create

Shop packet
Select Yes to generate a shop packet.

Consider future allocations
If MRP is installed, select Yes to consider future allocations as available when OBPM checks component
availability for an order. Future allocations are those components required outside the lead time for an
item or after an allocation time fence as designated in MRP.

Create purchase orders
Select a value from the list. These values are valid:
• (Find or create)
• Create based on auto release code
• Do not create

Create requisitions
Select a value from the list. These values are valid:
• Create based on auto release code
• Do not create

Create intersite orders
Select a value from the list. These values are valid:
• Create
• Create based on auto release code
• Do not create

4 Click Submit.
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Chapter 25: Shop floor activity

When Shop Floor Activity is turned on in OBPM application settings, PMC transactions are processed in OBPM
except for physical inventory, repetitive, and user-defined transactions.

The Shop Floor Activity object provides these benefits to IDF users:

• Real-time attendance and labor summary information is presented
• Error identification and correction can be performed in one place
• Review and approval process for attendance and labor is improved
• Persisted data

You can create attendance and labor transactions in the Shop Floor Activity object. The transactions are then
processed and if no errors are found, the status is updated to Processed.

Process flow

This list describes the process flow for transactions created by shop floor employees:

• Attendance and Labor transactions that are processed in shop floor activity can come from PMC, Shop
Floor System-Link, and Shop Floor Activity. Non-labor transactions that are processed in shop floor
activity can come from PMC and Shop Floor System-Link.

• Shop floor activity transactions are processed.
• Shop floor Processing status is set to Error or Processed (no errors).
• If the Processing status is Error, then update these shop floor summary files: Labor status, Other status,

and Error counts.
• If non-labor transactions and no error, then update the XA database and shop floor summary files.
• If an SW or EW attendance transaction or ON or OF labor transaction, then match transactions.
• If the attendance and labor transactions are matched, then calculate the unapproved hours and costs
• Labor unapproved hours and costs update Manufacturing order, M.O. operation, and shop floor summary

files. Attendance unapproved hours and costs update shop floor summary files.

Errors

You can view and correct these error types:

• Transaction errors, for example, an item not found. If badge is in error, you cannot change the badge
number.

• Related object errors, for example, order status is not correct.
• Unmatched errors for attendance and labor, for example, a Stop Labor (OF) record is missing. To correct

a labor that is unmatched, you can create a matching attendance and labor transaction.
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• Employee shift errors, for example, attendance records are missing.

Reprocessing shop floor activity
When a transaction is processed, errors within the transaction prevent the transaction from being processed
successfully. You can view the errors by viewing the transaction details. Use the Reprocess action to correct
a shop floor activity transaction that has processed in error. Only transactions with an Error or Canceled
status can be reprocessed.

1 Select Production > Activity > Shop Floor Activity.
2 Select the transaction with an Error or Cancel status. Or, double-click the transaction to view the details

and reprocess the error.
3 Select Maintain > Reprocess.

You are presented with the IDF transaction page that matches the transaction type such as Receive Item
(RC).

4 Change or correct any maintainable attributes such as Item, Warehouse, or Order.
5 Click Continue.

Reassigning attendance reasons
The Start Work (SW) and End Work (EW) attendance transactions are created or generated. The reasons for
those attendance reasons can vary. For example, these XA supplied reasons are for a Start Work (SW):

• EB=End break
• EL=End lunch
• SS=Start shift
• SW=Start work

Additional user defined reasons can be created and assigned to SW or EW.

You can change the reason for these attendance transactions. Use the Reassign Attendance Reason action
to change the attendance reason. For example, changing the attendance reason from Start break to Start
lunch.

1 Select Production > Activity > Shop Floor Activity.
2 Select the attendance transaction.
3 Select Maintain > Reassign Attendance Reason.
4 Select a reason from the New Reason attribute list.
5 Clear the Auto Advance check box.
6 Click Continue.
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Canceling shop floor activities
The Cancel action is used by a shop floor employee or supervisor to change Processing status of a transaction
in shop floor activity from Error to Canceled. This action can be performed when the initial processing of the
transaction results in an error. If the transaction does not need to be processed successfully, then use Cancel
to set the transaction status to Canceled.

Use this action to signify that the transaction has errors but is not to be corrected. All attendance and labor
transactions for an employee shift must have a Processing status of Processed or Canceled before the
employee shift Labor status can be set to Approved.

1 Select Production > Activity > Shop Floor Activity.
2 Select the Error transaction.
3 Select Maintain > Cancel.
4 Click Yes to confirm.

Reversing a specific shop floor activity
Transactions that are processed in shop floor and have a Processing status of Processed can be reversed.
The transaction being reversed is usually performed by the shop floor employee who created the transaction
or their supervisor. When reversed the status is set to Reversed and updates to database files such as M.O.
operation and summary files are backed out. Reversed non-labor transactions written to inventory transaction
history have a reversing transaction, same transaction but with negative quantity, written to inventory
transaction history. Reversed transactions written to labor activity do not have a reversing transaction. They
are flagged as reversed.

Not all processed transactions can be reversed. Employee shift attendance and labor transactions that have
a Labor status of Approved cannot be reversed. Reversing a shop floor activity transaction backs out what
is updated when the transaction was processed, such as quantity or costs.

These types of transactions cannot be reversed:

• CQ
• LA
• LQ
• RQ
• SM
• SQ

1 Select Production > Activity > Shop Floor Activity.
2 Select a transaction with a status of Processed.
3 Select Maintain > Reverse.
4 Click Yes to confirm.

Infor XA Order-Based Production Management | 150

 

Shop floor activity



Attendance and labor
Use the Attendance and Labor menu to select these transactions:

• Start Labor (ON)
• Stop Labor (OF)
• Start Work (SW)
• End Work (EW)

Attendance and labor review and approval is required if Review attendance and labor before approval is
set to Manual in the OBPM - Shop Floor application setting.

You can only approve attendance and labor transactions when Review attendance and labor before approval
is Automatic.

Starting labor transactions for a shop floor activity
Use the Start Labor (ON) transaction to show that an employee is clocking onto a job and to specify the kind
of labor required for the job.

1 Select Activity > Shop Floor Activity.
2 Select the activity in list.
3 Select Maintain > Attendance and Labor > Start Labor (ON).
4 Complete the fields including this information:

Order
Specify the order number of the operation on which the employee is working. If you selected a labor
activity, this attribute is automatically populated.

Operation
Specify the operation of the operation on which the employee is working. If a labor activity transaction
is selected, this attribute is may be automatically populated.

Run type
Select the run type for this transaction. The value indicates the kind of labor required for the job associated
with this transaction. These values are valid:
• Setup
• Run
• Indirect

Crew
Select the check box to indicate that the employee is part of a work crew.

Badge
Specify the employe badge number. This attribute is mandatory. If an employee record is selected, this
attribute is automatically populated.

Turnaround
Specify the turnaround number of the operation on which the employee is working.
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5 Click Continue.

Stopping labor in shop floor activity
Use the Stop Labor (OF) transaction to show that an employee is clocking off a job and to specify the kind of
labor required for the job. A corresponding Start Labor (ON) transaction is required unless you are tailored
for OF only processing, reporting scrap against a milestone operation, or reporting against a flow-shop
milestone.
1 Select Activity > Labor Activity.
2 Select the activity in list.
3 Select Maintain > Attendance and Labor > Stop Labor (OF).
4 Complete the fields including this information:

Order
Specify the order number of the operation on which the employee is working. If you selected a labor
activity, this attribute is automatically populated.

Operation
Specify the operation of the operation on which the employee is working. If a labor activity transaction
is selected, this attribute is may be automatically populated.

Run type
Select the run type for this transaction. The value indicates the kind of labor required for the job associated
with this transaction. These values are valid:
• Setup: Code used to report work spent in preparing an M.O. operation. Time can include changing

dies and tools, moving material to the facility, or performing testing.
• Run: Code used to report actual work on an operation. Time can include welding, assembly. packaging,

etc.
• Indirect: Code used to report work that is not against an M.O. operation. Time can include sweeping,

cleaning, and attending meetings.
• Milestone: Code used to report activity or work against the final operation in a milestone group.

Completion code
Select a completion code. These values are valid:
• 0=Open: Not complete. Quantity can be reported.
• 1=Complete with entered quantity: Specify quantity with this completion code.
• 2=Complete with defaulted: Do not specify quantity with this completion code. The quantity is

assumed to be the quantity still open for the operation.
• 3 = Milestone: Closes all milestone sub-operations and sets the operation status to complete. Can

only be used with Run code of M.

Reason
Select a reason for the scrap. If reason codes are specified in the Transaction Reasons object, you must
select a reason for scrapping. If your company does not require reason codes, blank is a valid entry.

Reference
Specify information for reference purposes.
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Crew
Select the check box to indicate that the employee clocked off the job as part of a work crew. Machine
time is calculated only if the Crew check box is not selected for both a Start Labor (ON) transaction and
the matching OF transaction.
Crew clock transactions can be used with multiple employees to clock on or off the same job without
reentering the transaction detail information. The first employee clocks on or off using the normal ON
or OF transaction. The other employees then specify a Crew Clock (CC) transaction that PM&C converts
to an ON or OF transaction with the same time, order, and operation information as the original
transaction.

Badge
Specify the employe badge number. This attribute is mandatory. If an employee record is selected, this
attribute is automatically populated.

Turnaround
Specify the turnaround number of the operation on which the employee is working.

5 Click Continue.

Starting work
Use the Start Work (SW) transaction to specify when an employee starts a shift, starts work, ends a break, or
ends lunch.

1 Select one of these options:
• Select Order Based > Employees.
• Select Activity > Shop Floor Activity.

2 Select the employee in the list.
3 Select Maintain > Attendance and Labor > Start Work (SW).
4 Complete the fields including this information:

Transaction date
The value for this attribute is automatically populated but you can change the value. Click the Select a
Date icon to change the date.

Transaction time
The value for this attribute is automatically populated but you can change the value.

Reason
Select the reason for starting work. These values are valid:
• EB = End Break
• EL = End Lunch
• SS = Start Shift
• SW = Start Work

5 Click Continue.
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Ending work
Use the End Work (SW) transaction to specify when an employee ends a shift, ends work, starts a break, or
starts lunch.

1 Select one of these options:
• Select Order Based > Employees.
• Select Activity > Shop Floor Activity.

2 Select the employee in list.
3 Select Maintain > Attendance and Labor > End Work (EW).
4 Complete the fields including this information:

Transaction date
The value for this attribute is automatically populated but you can change the value. Click the Select a
Date icon to change the date.

Transaction time
The value for this attribute is automatically populated but you can change the value.

Reason
Select the reason for starting work. These values are valid:
• SB = Start Break
• SL = Start Lunch
• ES = End Shift
• EW = End Work

5 Click Continue.

Running a Cancel job
Use the shop floor activity Cancel host job to cancel a large number of transactions that have a status of
Error.

1 Select Production > Activity > Shop Floor Activity > File > Host Jobs.
2 Select the Execute check box on the Cancel tab.
3 Complete the fields.
4 Select the E-mail tab, then specify the information.
5 Click Submit.
6 Click Yes to confirm.
7 If you selected Badge, Data collector, Employee name, or Transaction type, specify the information in the

Display attribute and click Continue.
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Running a Reprocess job
Use the Reprocess host job to correct a subset of shop floor activity transactions that have a status of Error
or Canceled.

1 Select Production > Activity > Shop Floor Activity > File > Host Jobs.
2 Select the Reprocess tab.
3 Select the Execute check box .
4 Complete the fields.
5 Select the E-mail tab, then specify the information.
6 Click Submit.
7 Click Yes to confirm.
8 If you selected Badge, Data collector, Employee name, or Transaction type, specify the information in the

Display attribute and click Continue.
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Chapter 26: Shop floor summary objects

As the shop floor activity transactions are processed, shift dates are assigned to the transactions using the
employee and work schedules assigned to the employee.

These shop floor summary objects are located under the Shop Floor Summary card on the Monitoring card
file:

• Employee shop floor summary
The icon is Employee Summary.

• Department shop floor summary
The icon is Department Summary.

• Company shop floor summary
The icon is Company Summary.

Each of these summaries has a shift shop floor summary:

• Employee shift shop floor summary
• Department shift shop floor summary
• Company shift shop floor summary

If the shift summary record does not exist for the summary employee, department, and summary object, then
one is created for the summary object. These shift shop floor summaries are not available on the Shop Floor
Summary card but can be added.

If review and approval is performed by a department supervisor, then select the Department Summary to
view a list of department summary records.

The shop floor summary objects are created as non-labor, attendance, and labor transactions are processed
in the Shop Floor Activity object. These transactions are shown in real-time as they are processed. Attendance
and labor real-time matching and calculations provide visibility to authorized personnel to correct any errors,
review, and approve attendance labor time and costs.

Errors can be identified and corrected from any of the Shop Floor Summary objects. The Labor status and
Other status headings in the summary list identify issues that should be reviewed and corrected.

Real-time updates

This section describes how real-time updates are processed when shop floor summary objects are created
or updated. An Employee shift shop floor summary record is used in this description.
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The Employee Shift Shop Floor Summary page is accessed from the Display menu on the Employee Shop
Floor Summary page.

Understanding the shop floor summary pages
After clicking a summary icon on the Shop Floor Summary card, the shop floor summary list page for that
icon is displayed. From the list page, you can view details for an individual shop floor summary record by
double-clicking the record.

Shop Floor Summary list page

This table shows each column heading on the list page, a description of each, and values if they exist.

ValuesDescriptionColumn heading

• Error
• Unmatched
• Ready to review
• Ready to approve
• Approved
• blank
Labor status is hierarchical. If any
attendance and labor errors exist,
then the value is Error. If no errors
exist, then the values is Un-
matched if unmatched atten-
dance and labor transactions are
not matched.

Summary status for attendance
and labor transactions. Atten-
dance and labor transactions re-
quire approval. Review is required
if the OBPM application setting
Review attendance and labor
before approval is set to Manual.

Labor status

• Error
• blank
The value is Error when these
conditions are true:
• Any non-labor transactions

with status of Error exist
• Other errors count is greater

than 0
Review and approve are not re-
quired for non-labor transactions.

Summary status for non-labor
transactions. You should review
and correct transactions with an
Error status.

Other status

Shows the number of employee
shift shop floor summary records
that are ready to review.

Ready to review
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ValuesDescriptionColumn heading

Shows the number of employee
shift shop floor summary records
that are ready to review.

Ready to approve

Shows the number of individual
attendance and labor transac-
tions for that shop floor summary
record that are in error. If non-ze-
ro, then theLabor status for the
record is Error.

Attendance and labor errors

Shows the number of individual
attendance and labor transac-
tions for that shop floor summary
record that are unmatched. If
non-zero and no transactions or
employee shift records with status
of Errors exist, then the Labor
status for the record is Un-
matched.

Unmatched errors

Shows the number of employee
shift shop floor summary records
that are in error due to employee
shift errors. For example, no atten-
dance records when work sched-
ule requires them.

Employee shift errors

Shows the number of non-labor
transactions that are in error. If
non-zero, then Other status for
the shop floor summary record
should be Error.

Other errors

Shop floor summary details page

The details General view contains these sections:

• Hours and Costs
The Hours and Costs tabs show the hours and costs that are ready and not ready for approval.

• Status
This section shows both counts and activity statuses.

• Shop Floor Activity
This compound card contains these additional tabs of information related to the shop floor activity for
the selected record:
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• Needs review: This card tab contains summary records where the Labor status is not approved or
Other status is not blank for employees.

• Overview: This card tab contains all employee summary records in that summary record. If you
select a department shop floor summary record or company shop floor summary record, expand
the levels to view the employee information.

• All: This card tab contains a list of every shop floor transaction for that record.
• Errors: This card tab contains a list of all the shop floor transactions that are in error.

Understanding elapsed time
Elapsed time is calculated by matching Start Labor (ON) and Stop Labor (OF) transactions for each order.
Elapsed time calculations work the same way for generated ON transactions that may occur with the off-only
method of job activity reporting.

In and out matching

Attendance and labor records are matched from an employee's in and out records. The employee’s first
attendance and labor record is counted as an In record and begins a attendance and labor elapsed time pair.
The next attendance and labor record is counted as an Out record and provides the ending time for the
previous elapsed time record. Subsequent attendance and labor records are paired in the same way until all
records have been matched to create elapsed time pairs with In and Out times. Matched records are linked
by updating each record with the transaction number of the other record.

Job record matching

Job ON and OF record matching is based on these things:

• record type such as production, setup, or indirect
• Job number such as manufacturing order number
• Operation sequence number

Elapsed time pairs are formed by matching ON and OF records. ON and OF records are matched in the same
way even the off-only method of job activity reporting and the system generated the ON transaction.

Time and attendance (SW, EW, TA) transactions

Time and attendance (TA) transactions can only come in from PMC. When processed in shop floor they are
transformed into a Start Work (SW) or End Work (EW) transaction based on whether preceding attendance
transactions exist. The only time TA transactions show up in shop floor is if the TA transaction cannot be
transformed to an SW or EW transaction. This can happen if Badge, Transaction date, or transaction time are
invalid for the TA transaction.

Attendance time is calculated for matching attendance transactions using the work schedule assigned to the
employee. Work schedule clocking windows, lunch, paid and unpaid breaks, and Pay basis code are used in
the calculation. After the attendance time is approved the calculated attendance and job time can be passed
to XA payroll or a third party payroll application for processing.
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Time adjustment

You can adjust employee clock-ins when they fall within a specified range. The time ranges that can be
specified for each work shift:

• Shift start
• Lunch start
• Lunch end
• Shift end

Separate time ranges are specified for time and attendance records. To specify a time range, these times are
required:

• Range start: The earliest time for the time range
• Range end: The latest time for the time range
• Standard time: The time that replaces the actual clocking when the time falls within the time range

Each transaction contains an actual start or stop time. The start time is compared to the shift start early or
shift start late and lunch early and late time ranges. If the actual start time falls within the time range or is
equal to the start or end of the time range, the standard time for shift start or lunch end is used as an adjusted
start time. If the actual start time does not fall within the time range, the actual clocking is used for any time
calculation.

Stop times are compared to the lunch start and shift end time ranges. If the stop time falls within the time
range, then the standard time is used as an adjusted stop time.

Time calculation

Elapsed time for each record is calculated by subtracting the adjusted time from the adjusted end time. The
break and lunch times are then extracted from the job records. Lunch times are extracted from the time and
attendance records. The breaks can be paid or unpaid.

If the job begins or ends during a break, then only the portion of the break spanned by the record is extracted.
If the complete break time is spanned, the complete break is extracted. If more then one break or portion of
a break is spanned, the total of all complete and partial breaks spanned is extracted.

A lunch period can be specified and extracted from both types of records when required. The time is extracted
in the same manner.

Overlap apportionment

An employee can work on several job simultaneously. For example, the employee may perform the setup on
one machine while several other machines are performing operations for different jobs. The overlap
apportionment function checks the employee's records for overlapped jobs and operations. If jobs overlap,
then the amount of overlapped time is apportioned equally between the hobs. Any time for paid or unpaid
breaks is extracted before the apportionment is made.

On the Labor Report, overlapped jobs are shown by an A to the right of the job time to show apportionment
has taken place.

Overlap apportionment is used for labor hours only. Machine hours are not apportioned. Overlap
apportionment works with the off-only method of job activity reporting when you use clocking windows.
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Machine time calculation

Machine time is only calculated if the standard machine time is defined for an operation and the ON transaction
nor the OFF transaction is a Crew Clock (CC) transaction. Machine time is calculated from the adjusted job
start time and adjusted job end time. unlike labor time, machine time is not apportioned. Breaks are extracted
as specified in the production facility record. Lunch is extracted if lunch extract is specified for the work
schedule.

Machine hours are used to update the Manufacturing Order Operation detail file and are included in the
transactions passed to PR.

Employee shop floor summary
The Employee Shop Floor Summary object contains a summary of shop floor activity for all employees for
which shop floor activity has been reported.

The Employee Shop Floor Summary object is accessed from the Shop Floor Summary application card on
the Monitoring tab.

The General view shows several statuses that are relevant to the employee such as labor activity status and
other activity status. These statuses are updated based on the labor and activity status from the employee
shift activity.

The Last reported view shows labor status and last reported order information. Actual work status shows
whether an employee is in or out based on the work schedule assigned to the shop floor employee. The Ready
to approve view shows the number of employee shift summary records that are ready to approve. this view
also shows the total unapproved attendance hours and labor hours for each employee.

A specific employee shop floor summary can have ties to information in other objects. You can use the Display
menu options or toolbar buttons to see information in other objects that is related to a selected employee
shop floor summary.

This table shows employee shop floor summary related objects:

Viewable informationObject

A list of the employee activities associated with the
selected employee shop floor summary

Employee Activity

A list of the employee shift information associated
with the selected employee shop floor summary

Employee Shift Shop Floor Summary

A list of the shop floor activities associated with the
selected employee shop floor summary

Shop Floor Activity
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Employee shop floor summary related object tasks
You can maintain information in other objects that are related to the Employee Shop Floor Summary object.
For example, from the Employee Shop Floor Summary list page or card file, you work with or maintain
information for a related employee from the Maintain menu. You can select tasks for these related objects
from the Maintain menu on the Employee Shop Floor Summary card file:

• Company shop floor summary on page 165
• Department shop floor summary on page 163
• Employees on page 33

Employee shift shop floor summary
The Employee Shift Shop Floor Summary object shows the labor status and other status along with paid,
attendance, labor, and machine hours for the shift dates of a specific employee.

These statuses are updated based on the labor and activity status from the employee shift summary. The
Employee Shift Shop Floor Summary object is the lowest shop floor summary object. You can access this
object from the Display menu on the Employee Shop Floor Summary list page.

Employee Shift Shop Floor Summary can provide the shop floor employee and their supervisor with a summary
by shift date for a given employee. This information can be helpful by a supervisor who upon reviewing their
department finds that an employee shop floor summary with a Labor status of Unmatched. The supervisor
can use the Employee Shift Shop Floor Summary page to find out which employee shift records have
unmatched attendance or labor records. The supervisor can add an attendance and labor transaction to
match up the record or reverse the attendance and labor transaction if the record is a duplicate.

The Employee Shift Shop Floor detail page shows hour and cost information, employee work status, and
shop floor activity information for the shift date.

You can use the Display menu to view the related shop floor activities for a selected employee shift shop
floor summary.

Viewing employee shift shop floor summaries
The Employee Shift Shop Floor Summary object is not displayed on the Shop Floor Summary tab on the
Monitoring card.

1 Select Production > Monitoring > Employee Summary.
2 Select an employee.
3 Select Display > Employee Shift Shop Floor Summary.
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Employee shift shop floor related object tasks
You can maintain information in other objects that are related to the Employee Shift Shop Floor Summary
object. For example, from the Employee Shift Shop Floor Summary list page or card file, you work with or
maintain information for a related employee from the Maintain menu. You can select tasks for these related
objects from the Maintain menu on the Employee Shift Shop Floor Summary card file:

• Company shop floor summary on page 165
• Company Shift Shop Floor Summary on page 166
• Department shop floor summary on page 163
• Department shift shop floor summary on page 164
• Employees on page 33
• Employee shop floor summary on page 161

Department shop floor summary
The Department Shop Floor Summary provides you with a real-time summary by department.

The Department Shop Floor Summary object is accessed from the Shop Floor Summary application card on
the Monitoring tab.

The Department Shop Floor Summary object provides a summary of shop floor activity that can be used by
a department supervisor. The General view contains labor status and other status. A supervisor can look at
these statuses to see if any shop floor employees in their department have errors, are unmatched, need
reviewed, or need approval.

The General view can provide a supervisor with a count of how many employee shift records in that department
are ready to review and ready to approve. Additionally, total counts in that department are displayed for
attendance and labor errors, unmatched, employee shift errors, and other errors. Counts are important in
case a supervisor wants to know how much time they should take for reviewing and fixing the issues. This
time could be minutes or hours depending on the status and counts shown.

A specific department shop floor summary can have ties to information in other objects. You can use the
Display menu options or toolbar buttons to see information in other objects that is related to a selected
department shop floor summary.

This table shows the department shop floor summary related objects:

Viewable informationObject

A list of the employee shop floor summaries associ-
ated with the department shop floor summary

Employee Shop Floor Summary

A list of the department shift shop floor summaries
associated with the department shop floor summary

Department Shift Shop Floor Summary

A list of the employee activities associated with the
department shop floor summary

Employee Activity
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Viewable informationObject

A list of the employee shift shop floor summaries
associated with the department shop floor summary

Employee Shift Shop Floor Summary

A list of the shop floor activities associated with the
department shop floor summary

Shop Floor Activity

Department shop floor summary related object tasks
You can maintain information in other objects that are related to the Department Shop Floor Summary object.
For example, from the Department Shop Floor Summary list page or card file, you work with or maintain
information for a related department from the Maintain menu. You can select tasks for these related objects
from the Maintain menu on the Department Shop Floor Summary card file:

• Company shop floor summary on page 165
• Departments on page 26

Department shift shop floor summary
The Department Shift Shop Floor Summary object shows a list of shift dates within that department.

You can access this object from the Display menu on the Department Shop Floor Summary list page.

The Department Shift Shop Floor Summary object provides a summary of shop floor activity that can be used
by a department supervisor. The General view contains labor status and other status. A supervisor can look
at these statuses to see if any shop floor employees in their department have errors, are unmatched, need
reviewed, or need approval.

The General view can provide a supervisor with a count of how many employee shift records in that department
are ready to review and ready to approve. Additionally, total counts in that department are displayed for
attendance and labor errors, unmatched, employee shift errors, and other errors. Counts are important in
case a supervisor wants to know how much time they should take for reviewing and fixing the issues. This
time could be minutes or hours depending on the status and counts shown.

A specific department shift shop floor summary can have ties to information in other objects. You can use
the Display menu options or toolbar buttons to see information in other objects that is related to a selected
department shift shop floor summary.

This table shows the department shift shop floor summary related objects:

Viewable informationObject

A list of the employee shop floor summaries associ-
ated with the department shift shop floor summary

Employee Shift Shop Floor
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Viewable informationObject

A list of the shop floor transactions associated with
the department shift shop floor summary

Shop Floor Activity

Viewing department shift shop floor summaries
The Department Shift Shop Floor Summary object is not displayed on the Shop Floor Summary tab on the
Monitoring card.

1 Select Production > Monitoring > Department Summary.
2 Select a department.
3 Select Display > Department Shift Shop Floor Summary.

Department shift shop floor summary related object tasks
You can maintain information in other objects that are related to the Department Shift Shop Floor Summary
object. For example, from the Department Shift Shop Floor Summary list page or card file, you work with
or maintain information for a related employee from the Maintain menu. You can select tasks for these related
objects from the Maintain menu on the Department Shift Shop Floor Summary card file:

• Company shop floor summary on page 165
• Company Shift Shop Floor Summary on page 166
• Departments on page 26
• Department shop floor summary on page 163

Company shop floor summary
The Company Shop Floor Summary provides you with a real-time summary by company.

The Company Shop Floor Summary object is accessed from the Shop Floor Summary application card on
the Monitoring tab.

The Company Shop Floor Summary object provides a summary of shop floor activity that can be used by
someone reviewing and approving shop floor summary at the company level. The General view contains
labor status and other status. The person who is reviewing, correcting, and approving shop floor activity at
the company level can look at these statuses to see if any shop floor employees in that company that have
errors, unmatched, need review, or need approval.

The General view can provide a count for how many employee shift records in that company that are ready
to review and ready to approve. Additionally, total counts in that company are displayed for attendance and
labor errors, unmatched, employee shift errors, and other errors. Counts are important in case a supervisor
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wants to know how much time they should take for reviewing and fixing the issues. This time could be minutes
or hours depending on the status and counts shown.

A specific company shop floor summary can have ties to information in other objects. You can use the Display
menu options or toolbar buttons to see information in other objects that is related to a selected company
shop floor summary.

This table shows the company shop floor summary related objects:

Viewable informationObject

A list of the company shift shop floor summaries as-
sociated with the company shop floor summary

Company Shift Shop Floor Summary

A list of the department shop floor summaries asso-
ciated with the company shop floor summary

Department Shop Floor Summary

A list of the employee shift shop floor summaries
associated with the company shop floor summary

Employee Shift Shop Floor Summary

A list of the shop floor transactions associated with
the company shop floor summary

Shop Floor Activity

Company shop floor summary related object tasks
You can maintain information in other objects that are related to the Company Shop Floor Summary object.
For example, from the Company Shop Floor Summary list page or card file, you work with or maintain
information for a related company from the Maintain menu.

Company Shift Shop Floor Summary
The Company Shift Shop Floor Summary object shows a list of shift dates for that company.

You can access this object from the Display menu on the Company Shop Floor Summary list page.

The Company Shift Shop Floor Summary object provides a summary of shop floor activity that can be used
by someone reviewing and approving shop floor summary at the company level. The General view contains
labor status and other status. The person who is reviewing, correcting, and approving shop floor activity at
the company level an look at these statuses to see if any shop floor employees in that company that have
errors, unmatched, need review, or need approval.

The General view can provide a count for how many employee shift records in that company that are ready
to review and ready to approve. Additionally, total counts in that company are displayed for attendance and
labor errors, unmatched, employee shift errors, and other errors. Counts are important in case a supervisor
wants to know how much time they should take for reviewing and fixing the issues. This time could be minutes
or hours depending on the status and counts shown.
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A specific company shift shop floor summary can have ties to information in other objects. You can use the
Display menu options or toolbar buttons to see information in other objects that is related to a selected
company shift shop floor summary.

This table shows the company shift shop floor summary related objects:

Viewable informationObject

A list of the department shift shop floor summaries
associated with the company shift shop floor sum-
mary

Department Shift Shop Floor Summary

A list of the employee shift shop floor summaries
associated with the company shift shop floor sum-
mary

Employee Shift Shop Floor Summary

A list of the shop floor transactions associated with
the company shift shop floor summary

Shop Floor Activity

Company shift shop floor summary related object tasks
You can maintain information in other objects that are related to the Company Shift Shop Floor Summary
object. For example, from the Company Shift Shop Floor Summary list page or card file, you work with or
maintain information for a related company from the Maintain menu. You can select tasks for these related
objects from the Maintain menu on the Company Shift Shop Floor Summary card file:

• Company
• Company shop floor summary

Viewing company shift shop floor summaries
The Company Shift Shop Floor Summary object is not displayed on the Shop Floor Summary tab on the
Monitoring card.

1 Select Production > Monitoring > Company Summary.
2 Select a company.
3 Select Display > Company Shift Shop Floor Summary.

Reprocessing a shop floor activity from a summary
When a transaction is processed, errors within the transaction prevent the transaction from being processed
successfully. You can view the errors by viewing the transaction details. Use the Reprocess action to correct
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a shop floor activity transaction that has processed in error. Only transactions with an Error or Canceled
status can be reprocessed.

1 Click Employee Summary, Department Summary, or Company Summary.
2 Double-click the summary with a Labor status or an Other status of Error.
3 Under Shop Floor Activity, click the Errors tab.

To view the details of the errors, double-click the transaction. From the details page, you can view the
details and click Continue to return to the Errors tab; or, select Maintain > Reprocess to reprocess the
transaction.

4 Click the Reprocess icon on the tab.
You are presented with the IDF transaction page that matches the transaction type such as Receive Item
(RC).

5 Change or correct any maintainable attributes such as Badge, Transaction date, or Transaction time.
6 Click Continue.

Canceling a shop floor activity from a summary
You can cancel a shop floor activity transaction with a Processing status of Error can be canceled. Use this
action to signify that the transaction has errors but is not to be corrected. All attendance and labor transactions
for an employee shift must have a Processing status of Processed or Canceled before the employee shift
Labor status can be set to Approved.

The Cancel action is available in all the shop floor summary detail pages under Shop Floor Activity.

1 Double-click the summary with an status of Error on the shop floor summary page.
2 Under Shop Floor Activity, select theOverview or Needs Review tab, then expand the record to view the

transaction in error.
You can expand the transaction to view the errors.

3 Select the transaction to cancel.
4 Click the Cancel icon on the tab.
5 Click Yes to confirm.

Review, approve, and recalculate attendance and labor
transactions
As attendance and labor shop floor transactions are processed they are matched and attendance time, labor
time and labor costs are calculated real time. Matching attendance and labor calculations results in updates
to these files:

• Manufacturing Order (M.O.)
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• M.O. Operation
• Employee Shop Floor Summary
• Employee Shift Shop Floor Summary
• Department Shop Floor Summary
• Department Shift Shop Floor Summary
• Company Shop Floor Summary
• Company Shift Shop Floor Summary

Attendance and labor review and approval is required if Review attendance and labor before approval is
set to Manual in the OBPM - Shop Floor application setting.

Shop Floor Summary files are updated in real time. The attendance time, labor time, and labor costs can be
reviewed and approved by authorized supervisors and managers without having to run separate attendance
and labor batch jobs. Authorized people have the ability to calculate attendance and labor time and costs
due to changes to employee, production facility, and work schedules. You can back out labor time and costs
from the M.O. operation and M.O. files using the Unapprove Labor action.

Review

You can review shop floor summaries from all the Shop Floor Summary levels. Though, you can only perform
a review on an employee shift shop floor summary with a Labor activity status of C=Ready to review or R
= Ready to review. When performing a review at another shop floor summary level, the Labor activity status
can be any status. Any Employee Shift Shop Floor Summary with a status of C=Ready to review within that
summary group is set to R=Ready to approve when a review is performed.

The Review action updates these areas:

• Reviewed fields in the Shop Floor Transaction file, such as User, Date, Time, and Status.
• Change the Attendance hour, Labor hour, and Cost attributes on the employee shift shop floor summary

record to Ready to approve and set the Labor activity status to R = Ready to approve.
• Update the Attendance hour, Labor hour, and Cost attributes on higher shop floor summary objects,

such as Employee Shop Floor Summary, Department Shop Floor Summary, or Department Shift Shop
Floor Summary. Set theLabor Activity status to Ready to approve based on hierarchy.
Note that the higher shop floor summary files are updated using the Recalculate action.

Approve

You can approve an Employee Shift Shop Floor Summary in any of the shop floor summary levels as long as
the labor activity for the employee record has a status of R=Ready to approve. The Approve action is available
at all shop floor summary levels on theMaintain menu and as host job.

When approving the labor activity from the employee shift shop floor summary record, these actions are
taken:

• Update the hours and costs in these locations:
• Manufacturing order (M.O.)
• M.O. operation
• Item warehouse
• Labor activity
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• Inventory GL Transactions (INVTXN)
• Order Based Production GL Transactions (PCCTXN)

• Update the approved date, time, user and status fields in the shop floor transaction file for attendance
and labor transactions for the employee shift.

• Move employee shift M.O. operation and employee shift M.O. records from a status of Unapproved to
Approved.

• Update the M.O. operation extension and M.O. extension unapproved hours and costs.
• Updates the Employee Shift Shop Floor Summary Labor status from Ready to approve to Approved.
• Attendance and labor transactions in approved employee shift shop floor summary are set to approved

when you click Approve. If no further maintenance is required, you can use these transactions: Cancel
and Reverse.

• All employee shift shop floor summary records in higher level shop floor summary object, such as
department shop floor summary, with Labor status of Ready to approve are set to Approved when you
select Approve for the higher level shop floor summary records.

• For all employee shift shop floor summary records in a higher level shop floor summary record, such as
Employee Shop Floor Summary, then the Labor status is set to Approved for the shop floor summary
record at the higher level.

• Create an Employee Shift Attendance and Labor Summary file to be used by third party payroll systems.

Recalculate

You may find that in situations such as these that you want to recalculate attendance time, labor time, and
labor costs:

• After attendance and labor transactions are matched and time is calculated, changes occur for an
employee, to a work schedule, or at the production facility. If these changes are made before attendance
and labor are approved, a reviewing and approving manager wants to recalculate attendance and labor
based on those changes.

• A power outage or some other failure occurs during the activity matching and elapsed time calculations
causing the attendance and labor calculations to be wrong.

The Recalculate option is available on all shop floor summary and shift shop floor summary pages. Only
Employee Shift Shop Floor Summary records with a Labor activity status of E=Error, U=Unmatched,C=Ready
to review, and R=Ready to approve can be recalculated.

Reviewing shop floor summaries
Use the Review action to change the Labor status from Ready to review to Ready to approve.

The Review action is available in all the shop floor summary objects from the Maintain and Host Job options.
Note that the Review action is available and required if OBPM application setting Review attendance and
labor before approval is Manual.

1 Select one of these options:
• Select a ready to review Employee Shift Shop Floor Summary record, then select Maintain > Review.
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• Select any upper level Shop Floor Summary record (Employee, Department, Department Shift,
Company, Company Shift) and select Maintain > Review. Any Employee Shift Shop Floor Summary
record in that summary group with status Ready to review is set to Ready to Approve.

2 Click Yes.

Approving shop floor summaries
Use the Approve action to change the Labor status from Ready to approve to Approved.

The Approve action is available in all shop floor summary objects from the Maintain menu and Host Job
options.

1 Select any shop floor summary record, then select Maintain > Approve.
Any Employee Shift Shop Floor Summary record with status Ready to approve is approved.

2 Click Yes to confirm.

Recalculating shop floor summaries
Use the Recalculate action when changes occur in the work schedule or related object and the changes affect
the calculation of hours and costs. These examples describe when you may want to recalculate a shop floor
summary:

• A change occurs in the pay basis or breaks of a work schedule that affect the hour and cost calculations
• A production facility reporting method changes in a related object that affects the hour and cost

calculations

Only Employee Shift Shop Floor Summary records with a Labor activity status of E=Error,
U=Unmatched,C=Ready to review, and R=Ready to approve can be recalculated.

1 Click Employee Summary, Department Summary, or Company Summary.
2 Do one of the following:

• To recalculate the list of shop floor summaries, select Maintain > Recalculate
• To recalculate a specific shop floor summary record, double-click the shop floor record in the summary

list, then select Maintain > Recalculate on the shop floor summary detail page.
• To recalculate the shop floor activity record for a specific shop summary record, use these steps:

a Double-click the shop floor record in the summary list.
b Select the shop floor activity record under Shop Floor Activity on the floor summary detail page.
c Click the Recalculate icon.

3 Click Yes to confirm.
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Recalculating shift shop floor summaries
Use the Recalculate action when changes occur in the work schedule or related object and the changes affect
the calculation of hours and costs. These examples describe when you may want to recalculate a shop floor
summary:

• A change occurs in the pay basis or breaks of a work schedule that affect the hour and cost calculations
• A production facility reporting method changes in a related object that affects the hour and cost

calculations

.

1 Click Employee Summary, Department Summary, or Company Summary.
2 Select the transaction, then select Display > (Employee, Department, or Company) Shift Shop Floor

Summary.
3 Select one of these options:

• To recalculate the list of shift shop floor summaries, select Maintain > Recalculate.
• To recalculate a specific shift shop floor summary record, double-click the shift shop floor record in

the summary list, then select Maintain > Recalculate on the shift shop floor summary detail page.
• To recalculate the shop floor activity record for a specific shift shop summary record, use these steps:

a Double-click the shift shop floor record in the summary list.
b Select the shop floor activity record under Shop Floor Activity on the shift floor summary detail

page.
c Click the Recalculate icon.

4 Click Yes to confirm.

Running a Review job
Use the Review host job to select a subset of shop floor summary transactions to review.

Review is available and required for attendance and labor when OBPM application setting Review attendance
and labor before approval is Manual.

The Review host job is available on all the shop floor summary pages.

1 Optionally, select a ready to approve summary record.
2 Select File > Host Jobs
3 Select the Review tab.
4 Select the Execute check box.
5 Complete the fields including this information:

Subset
Select a subset. These values are valid:
• (all records): Select to subset on all records.
• Badge: Select to subset records by badge ID
• Employee name: Select to subset records by employee name
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• Errors: Select to subset by records with errors
• Labor activity status: Select to subset records by a specific labor activity status
• Needs review: Select to subset by records that need reviewed

Sort
Select Name to sort by employee name. Otherwise, leave as (default) or select (none) for no sort.

6 Select the E-mail tab, then specify the information.
7 Click Submit.
8 Click Yes to confirm.
9 If you selected Badge, Employee name, or Labor activity status, specify the information in the Display

attribute and click Continue.
Any Employee Shift Shop Floor Summary with Labor status of Ready to review is set to Ready to
approve.

Running an Approve job
Use the Approve host job to change the Labor status from Ready to approve to Approved by subset.

The Approve host job is available on all the shop floor summary pages.

1 Optionally, select a ready to approve summary record.
2 Select File > Host Jobs
3 Select the Execute check box on the Approve tab.
4 Complete the fields including this information:

Subset
Select a subset. These values are valid:
• (all records): Select to subset on all records.
• Badge: Select to subset records by badge ID
• Employee name: Select to subset records by employee name
• Errors: Select to subset by records with errors
• Labor activity status: Select to subset records by a specific labor activity status
• Needs review: Select to subset by records that need reviewed

Sort
Select Name to sort by employee name. Otherwise, leave as (default) or select (none) for no sort.

5 Select the E-mail tab, then specify the information.
6 Click Submit.
7 Click Yes to confirm.
8 If you selected Badge, Employee name, or Labor activity status, specify the information in the Display

attribute and click Continue.
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Running a Recalculate job
Use the Recalculate host job to recalculate shop floor summary transactions by subset. These examples
describe when you may want to recalculate a shop floor summary:

• A change occurs in the pay basis or breaks of a work schedule that affect the hour and cost calculations
• A production facility reporting method changes in a related object that affects the hour and cost

calculations

Only Employee Shift Shop Floor Summary records with a Labor activity status of E=Error,
U=Unmatched,C=Ready to review, and R=Ready to approve can be recalculated.

The Recalculate host job is available on all the shop floor summary pages.

1 Optionally, select a record.
2 Select File > Host Jobs
3 Click the Recalculate tab.
4 Select the Execute check box.
5 Complete the fields including this information:

Subset
Select a subset. These values are valid:
• (all records): Select to subset on all records.
• Badge: Select to subset records by badge ID
• Employee name: Select to subset records by employee name
• Errors: Select to subset by records with errors
• Labor activity status: Select to subset records by a specific labor activity status
• Needs review: Select to subset by records that need reviewed

Sort
Select Name to sort by employee name. Otherwise, leave as (default) or select (none) for no sort.

6 Select the E-mail tab, then specify the information.
7 Click Submit.
8 Click Yes to confirm.
9 If you selected Badge, Employee name, or Labor activity status, specify the information in the Display

attribute and click Continue.
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Chapter 27: Sources of demand

The Sources of Demand object is an inquiry that shows you all the sources of demand for the selected item
on a requisition, material order, customer order, or purchase order.

The Sources of Demand page shows the top level requirement that generated the request for the purchase
of the item. You can use this information to determine the person or group that is waiting for the ordered
item. The information is used to notify the person or group of changes to the shipment or delivery of the
ordered item.

The Sources of Demand object provides demand information for items specified on requisitions and for items
and item releases on purchase orders.

MRP planning runs generate the sources of demand information. You do not maintain information in this
object.
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Chapter 28: Warehouses

The Warehouses object contains information about the entities where inventory is stored and managed. The
information for each warehouse identifies whether it is controlled or uncontrolled, selling or non-selling, and
planning or demand.

Warehouses are used to group information in other objects. The Item Warehouses object shows the items
stored or managed in each warehouse. The Warehouse Addresses object contains the addresses associated
with each warehouse. You can assign multiple items to a warehouse, and you can define multiple addresses
for a warehouse.

A specific warehouse can have ties to information in other objects. For example, a warehouse has ties to the
Warehouse Locations object. Within the Warehouses object, you can use options under the Display menu to
see information in other objects that are related to a selected warehouse.

Creating warehouses
To create a warehouse you need to know this information:

• Warehouse code
• Warehouse type
• Shipping calendar code

If EPDM is installed, you need to know the site for the new warehouse.

1 Select one of these options:
• Select Engineering > PDM Plus > Warehouses > Maintain > Create
• Select Materials > Inventory > Warehouses > Maintain > Create
• Select Production > Order Based > Warehouses > Maintain > Create
• Select Planning > Warehouses > Maintain > Create

2 Complete the fields.
3 Click Create.
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Changing warehouses
Use these instructions to change information for warehouses.

1 Select the warehouse.
2 Select Maintain > Change.
3 Update the attributes.
4 To change the warehouse to or from a planning warehouse, use these steps:

a Select the General tab if not already selected.
b Click Yes or No for the Planning warehouse attribute.
c Click the Assign planning defaults button. If Yes is selected, planning warehouse values are set

back to their default value when Update is clicked. If No is selected, planning warehouse values are
cleared when Update is clicked.

5 Click Update.

Copying a warehouse
You can create a new warehouse by copying an existing warehouse.

1 Select the warehouse.
2 Select Maintain > Copy.
3 Complete the field including this information:

Warehouse
Specify the target warehouse number.

Shipping calendar
Specify the shipping calendar of the target warehouse.

Site
Specify the site of the target warehouse.

Copy Warehouse Addresses
Select the check box to copy the warehouse address information. If you select a different template from
the one used to create the source warehouse, values copied from the warehouse are overridden with
the values from the selected template.
To make source attributes blank in the target warehouse, make those attributes blank in the template.

4 Click Copy.
If you selected Preview before copy, the
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Deleting warehouses
Deleting a warehouse removes the warehouse immediately.

1 Select the warehouse.
2 Select Maintain > Delete.
3 Click Yes.

Warehouse Planning card
You can use the Planning card to establish planning horizon dates, set date intervals for consolidating
requirements, and establish planning run execution and report options. You initiate the planning run using
the Planning Run host job option. The Planning card is maintainable when Materials Planning (MP) is installed
and the warehouse is a planning warehouse. This card is blank when MP is not installed.

Execution Options

This section includes execution information for the planning run of the selected warehouse. Before setting
up the planning run, consider these execution questions:

• Should customer backlog orders be combined
• Should you allow time phased allocation
• What level will you plan master level items
• How will rescheduling be handled
• Should contracts be required for auto-release

Reporting Options

This section includes these report settings for printing automatically when a planning run is executed:

• Requirements planning
• MLI requirements vs forecast customer orders
• Purchase planning
• Order recommendation by item
• Order recommendation by exception

If the Requirements planning report check box is selected, then you can specify this information:

• Types of items
• Level of details for the items
• Dates intervals for the items on the report
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Horizon Values

This section is used to specify planning horizon values and dates used in the planning run. The planning dates
are the parameters, or horizons, that you establish for the application to perform materials planning. You
should only change these dates immediately before a planning run. Between runs they are used on reports
and displays and should correspond with the data they accompany. Because the data represents the last
planning run, the dates should also represent the last planning run.

You can specify a new current date and displacements, or days. Displacements occur between start, current,
release and review dates. These formulas describe how the start, release, allocation, and review dates are
derived from the current date:

• Current date minus Overdue days equals Start date
• Current date plus Release days equals Release date
• Current date plus Allocation days equals Allocation date
• Current date plus Review days equals Review date

Combine Interval Days

This section is used to specify the number of days for the combine codes. The Combine requirements code,
1-9, identifies which of these codes is used during planning. These codes determine time intervals for combining
requirements for the item for planning orders.

Price Break Literals

This section is used to specify the unit of measure to use as a literal value for price breaks from the vendor
for combine codes 5 through 9. Literals are only used for printing the MRP Purchase Planning Report, which
groups items by combine code associated with the unit of measure in which purchased.

Report Code Period Intervals

This section is used to specify the length of periods on the Requirements Planning Report. You can print the
Requirements Planning Report showing the total quantities of requirements and planned orders within
buckets, or periods, of specified numbers of days. You can choose the length of periods on the report by
selecting the appropriate report code. In the Report Code Period Intervals, you can define the number of days
within each of the twenty periods for each of the 3 report codes. If you specify zero for a period interval, all
remaining interval periods for that report code must be zero. The first period of each report code begins at
the planning start date. Any generated requirement falling before the start date shows individually. Any
generated requirement falling after the 20th period is not printed. Planner requirements are listed individually;
only generated requirements are summarized.

Setting up a warehouse planning run
1 Select the warehouse.
2 Select Maintain > Change.
3 Select the Planning tab.
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4 Complete the fields.
5 Click Update.

Printing a M.O. Transaction Register report
The M.O. Transaction Register report shows all material and labor transactions. Additionally, the report shows
any closeout transactions that are performed during completing and closing orders. Transactions processed
through Inventory Management (IM) are logged to the OBPM Order close transaction file. Production Control
and Costing (PC&C) transactions, such as labor complete and operations, are also written to the OBPM Order
Close transaction file.

1 Select File > Host Jobs.
2 Select the Print check box on the M.O. Transaction Register tab.
3 Complete the fields.
4 Optionally, click the E-mail tab, then specify the information that confirms the printing of this report.
5 Click Submit.

Printing an Order Shortages report
The Order Shortages report shows the material not available to meet current release demands at order
release.

1 Select File > Host Print.
2 Click the Order Shortages tab.
3 Select the Print check box.
4 Complete the fields.
5 Optionally, click the E-mail tab, then specify the information that confirms the printing of this report.
6 Click Submit.

Audit Allocation Quantities host job
Use the Audit Allocation Quantities host job to validate the allocation quantities, or pick requirements,
between the Item Balance file and the Manufacturing Order Detail file. The Audit Allocation Quantities host
job updates the Item Balance file to correct discrepancies found between these two files and prints any
differences found.
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If COM is installed and interfacing, this host job accumulates the customer order allocation quantities in the
Item Balance file. Any item or warehouse that is out of balance is listed, and the Item Balance record is updated
to agree with the Customer Order Detail records for that item or warehouse.

This host job should be scheduled for a time when these files are not being used by another task:

• Item Balance
• Customer Order detail
• Manufacturing Order detail
• Customer Order Master
• Manufacturing Order Master
• Order Release Data Entry

Running an Audit Allocation Quantities host job
1 Select File > Host Jobs.
2 Click the Execute check box on the Audit Allocation Quantities tab.
3 Complete the fields.
4 Optionally, click the E-mail tab, then specify the information for the email that confirms the execution

of this host job.
5 Click Submit.

This table shows the lists and their attributes that are printed when this host job is executed.

Pick Requirements Audit Exception List at-
tributes

Mfg Allocation Audit Exception List attributes

Item numberItem number

WarehouseWarehouse

DescriptionDescription

Pick requirements quantity beforeManufacturing allocated quantity before

Pick requirements quantity afterManufacturing allocated quantity after

Requirements recordsAllocation records

Running an Audit Location Quantities host job
The Audit Location Quantities host job creates the Location Quantity/Item Balance report. This report compares
the item quantities in the Item Balance file with the on hand quantities in the Location Quantity file to identify
any discrepancies. Reject items and items waiting for inspection are not included in the totals.

1 Select File > Host Jobs.
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2 Click the Audit Location Quantities tab.
3 Click Execute check box.
4 Complete the fields.
5 Optionally, click the E-mail tab, then specify the information for the email that confirms the execution

of this host job.
6 Click Submit.

These attributes are displayed on the Location Quantity/Item Balance report:
• Item number
• Warehouse
• On-hand quantity location detail
• On-hand quantity item balance
• Allocated quantity
• Exception

Audit On-order Quantities host job
The Audit On-order Quantities host job validates quantities on-order between these files:

• Item Balance
• Purchase Order Item Detail
• Manufacturing Order Master

The host job updates the Item Balance file to correct discrepancies between these three files and prints any
differences found.

If a task is selected when the Audit On-order Quantity host job is active, the error message SYS-1172 FILE
(file label) IS CURRENTLY NOT AVAILABLE is displayed. You can select the available options for this message
without endangering data integrity.

Running an Audit On-order Quantities host job
This option should be scheduled for a time when these files are not being used by another task:

• Item Balance
• Purchase Order Item Detail
• Manufacturing Order Master

1 Select File > Host Jobs.
2 Click the Audit On-order Quantities tab.
3 Click the Execute check box.
4 Complete the fields.
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5 Optionally, click the E-mail tab, then specify the information for the email that confirms the execution
of this host job.

6 Click Submit.
These attributes are displayed on the Purchase/Mfg On-Order Audit Exception List:
• Item number
• Warehouse
• Manufacturing on-order quantity before
• Manufacturing on-order quantity after
• Purchase on-order quantity before
• Purchase on-order quantity after

Creating an inventory count group for cycle count
You can create a cycle count job from the Item Locations object and from the Warehouse Locations object.

1 Select File > Host Jobs.
2 Click the Cycle Count tab.
3 Select the Execute check box.
4 Complete the fields on the Content tab.
5 Specify this information on the General tab in the Options section:

Compare quantity
Select one of these options for the on-hand quantity to use during the reconciliation process to which
to compare entered counts:
• Entry on-hand quantity to capture the quantity at the time the count is specified
• Cutoff on-hand quantity to capture the quantity at the time the count is activated

Exclude line locations
Select one of these options for excluding line locations from the group:
• Yes: The line locations are not included even if they meet some other cycle count criteria
• No: The line locations are included if they are selected by another criteria

Exclude unapproved items
Select one of these options for excluding unapproved items or locations:
• Yes: The unapproved item or locations are not counted
• No: The unapproved item or locations are counted if they are selected by another criteria

Starting tag number
Specify the first number to use when generating tag numbers or use the default number that is
automatically generated. You can generate tag numbers when you create the count group or maintain
the count group.

Activate next count
Select Yes to set a flag to indicate which count is active. When you activate a new group for cycle count,
the active count is always 1.
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Generate tag numbers
Select one of these options for how to generate tag numbers:
• Yes: The tag numbers are automatically generated using the starting tag number indicated when

the group is created.
• No: To generate tag numbers later or manually specify the tag number later. The tag numbers can

be generated through inventory count group maintenance.

6 Select the Selection Criteria tab and specify this information:

Select all in subset
Select Yes to include every item in the subset in the inventory count group. If you select No to include
only those items that meet one or more of the criteria activated under Select all in subset.

Select by transaction activity
If No is selected for Select all in subset, then select Yes if only items that have exceeded the limit of
transaction activity are selected for this cycle count. The transaction activity is defined at the item
warehouse level.

Transaction tolerance percent
Specify a percent to use when comparing the number of transactions for the item to the transaction
compare number. Items within the tolerance are included even if they do not exceed the limit.

Select by time period
Select Yes to specify that only items due for another count based on their cycle count code are to be
selected. The cycle count code is defined at the item warehouse level.

Select if forced cycle count
Select Yes to specify that if the item or warehouse has the forced cycle count flag on, then the item and
warehouse or item and locations are included.

Select if negative on hand
Select Yes to specify that if the item and warehouse or item and location has a negative on-hand balance
the item is included.

7 Optionally, click the Reports tab to print these reports after the inventory count group is created:
• Inventory Count Entry List: This report is used as a turnaround document for entering the counts as

they are being taken. Select the Print check box and specify the information.
• Inventory Tags: Use the inventory tag forms instead of the Inventory Count Entry List. Each item or

location prints on a separate tag.
a Click the Inventory Tags tab.
b Select the Print check box and specify the information.

8 Optionally, click the E-mail tab and specify the information.
9 Click Submit.
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Running a Generate Reorder Recommendations host job
Use the Generate Reorder Recommendations host job to create or refresh reorder recommendations.
Reorder recommendations are always generated for all order point items in a warehouse or a subset of
warehouses.

Use this host job to select whether to automatically create or not automatically create replenishment orders
during generation. After you generate a list of reorder recommendations, you can view them and create orders
from the Reorder Recommendations object. You can change order type, quantity, and other information as
you create orders.

1 Select File > Host Jobs.
2 Select the Execute check box.
3 Complete the fields including this information:

Create manufacturing orders
Select the value from the list. These values are valid:
• Create
• Create, if all components are available
• Create based on auto release code
• Do not create

Shop packet
Select Yes to generate a shop packet.

Consider future allocations
If MRP is installed, select Yes to consider future allocations as available when OBPM checks component
availability for an order. Future allocations are those components required outside the lead time for an
item or after an allocation time fence as designated in MRP.

Create purchase orders
Select a value from the list. These values are valid:
• (Find or create)
• Create based on auto release code
• Do not create

Create requisitions
Select a value from the list. These values are valid:
• Create based on auto release code
• Do not create

Create intersite orders
Select a value from the list. These values are valid:
• Create
• Create based on auto release code
• Do not create

4 Click Submit.
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Creating an inventory count group for physical inventory
Use the Physical Inventory host job to create an inventory count group and print the Inventory Count Entry
List and Inventory Tag forms. The Inventory Count Entry List report can be used as a turnaround document
for specifying the counts as they are being taken. You can use the inventory tags instead of using the Inventory
Count Entry List. The turnaround number can be converted and printed as a bar code on the tags.

Use this host job to count all items and update the on-hand quantity in the Item Balance and Location Quantity
files.

1 Select File > Host Jobs.
2 Click the Physical Inventory tab.
3 Click Execute check box.
4 Complete the fields on the Content tab.
5 Specify this information on the General tab in the Options section:

Compare quantity
Select one of these options for the on-hand quantity to use during the reconciliation process to which
to compare entered counts:
• Entry on-hand quantity to capture the quantity at the time the count is specified
• Cutoff on-hand quantity to capture the quantity at the time the count is activated

Exclude line locations
Select one of these options for excluding line locations from the group when in a controlled warehouse:
• Yes: The line locations are not included even if they meet some other cycle count criteria
• No: The line locations are included if they are selected by another criteria

Exclude unapproved items
Select one of these options for excluding unapproved items or locations in a controlled warehouse:
• Yes: The unapproved item or locations are not counted
• No: The unapproved item or locations are counted if they are selected by another criteria

Starting tag number
Specify the first number to use when generating tag numbers or use the default number that is
automatically generated. You can generate tag numbers when you create the count group or maintain
the count group.

Activate next count
Select Yes to set a flag to indicate which count is active. When you activate a new group for cycle count,
the active count is always 1.

Generate tag numbers
Select one of these options for how to generate tag numbers:
• Yes: The tag numbers are automatically generated using the starting tag number indicated when

the group is created.
• No: To generate tag numbers later or manually specify the tag number later. The tag numbers can

be generated through inventory count group maintenance.

6 Click the Reports tab to specify what to print after the inventory count group is created.
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7 To print the Inventory Count Entry List, select the Print check box on the tab and complete the fields.
8 To print inventory tags, click the Inventory Tags tab, select the Print check box, and complete the fields.
9 Optionally, click the E-mail tab, then specify the information for the email that confirms the execution

of this host job.
10 Click Submit.

Planning Run host job
Use the Planning Run host job to examine the balance of each inventory item, starting with end-items. On
any date where requirements exceed the projected available on-hand, a planned order is created for the
quantity. The planned orders satisfies the net required quantity and other order sizing requirements for the
item. The start date for the planned order is calculated from the lead times specified for the item in the Item
Warehouses object. All start dates are calculated using actual work days, which are established when you
build the production calendar.

As each planned order is created for an item, the planning run creates a requirement for each component of
that item. These requirements are called generated requirements. A generated requirement is a statement
that a certain quantity of the component is needed on a given date. For a generated requirement, the
component part satisfies internal demand. Whereas, with a master level item (MLI) requirement, the component
part satisfies external demand, such as a sales order. Internal demanded is a planned order for an item higher
in the product structure. Each component item is examined and planned orders are created when needed to
meet these generated requirements. The planning run continues this process through all levels of the bill of
material until all component parts of all items have been examined.

The plan that is created is a collection of the requirements and the resulting planned orders for items that
need to be replenished. The collection of requirements is for both MLI and generated requirements. The
planned orders are a tentative production and purchasing schedule.

The Warehouse Planning card contains information you can use to perform these tasks:

• Establish planning horizon dates
• Set date intervals for consolidating requirements
• Establish planning run execution and report options

You should review these options before you initiate the planning run using this Planning Run host job.

To run the Planning Run host job, Materials Planning (MP) must be installed. You must be authorized to the
proper level of security for the planning run and for the warehouse you select.

If EPDM is activated and the selected warehouse is defined for EPDM, information in the Item Revisions object
is used. Otherwise, information in the Items object is used.
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Running the Planning Run host job
Note: A planning run prevents some MRP activities from running, so you should schedule the planning run
carefully; typically for overnight or over a weekend. Use the Start date and Start time attributes to schedule
the planning run.
1 Select File > Host Jobs.
2 Click the Planning Run tab.
3 Select the Execute check box.
4 Complete the fields including this information in the Options section:

Extract independent demand
Select one of these options:
• Yes: Click to extract customer orders, including released intersite orders and expected customer

orders from the respective data bases for informational and planning purposes
• No: Click to not extract customer orders at this time
This option is available when CSM is interfacing.
If EC is installed, expected customer orders are netted against the actual customer orders and the
remaining quantities are included.

Transfer MPSP orders
Select one of these options:
• Yes: Click to transfer the new master schedule, planned and firm planned orders, from MPSP to MRP
• No: Click to not transfer the schedule at this time
This option is available when MPSP is installed.

Auto-release manufacturing orders
Select one of these options:
• Yes: Click to release manufacturing order items at the end of the planning run
• No: Click to not perform manufacturing order auto release
This option is available when MRP is interfacing to IM.

Auto-release purchase orders
Select one of these options:
• Yes: Click to release purchase order items at the end of the planning run
• No: Click to not perform purchase order auto release
This option is available when Purchasing is installed.

Auto-release intersite orders
Select By auto release code or All to auto-release intersite orders at the end of the planning. This option
is available when ISL and MISL are installed.

Auto-reschedule manufacturing orders
Select one of these options:
• Yes: Click to automatically reschedule manufacturing order items
• No: Click to not reschedule manufacturing orders
This option is available when MRP is interfacing to IM.
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Auto-reschedule purchase orders
Select one of these options:
• Yes: Click to automatically reschedule purchase orders
• No: Click to not reschedule purchase orders
This option is available when Purchasing is installed.

Auto-reschedule schedules
Select one of these options:
• Yes: Click to automatically reschedule REP production schedules
• No: Click to not reschedule REP production schedules
This option is available when REP is installed.

Planning run type
Select one of these values:
• Full planning run - Generation: Select this option to perform a planning run covering all items

planned by MRP. Planned orders are replanned, except for firm planned orders, and dependent
requirements are regenerated.

• Full planning run - Net change: Select this option to perform a planning run covering all items
planned by MRP. Note that the planning run starts with only those items that have had activity since
the last planning run.
If you maintain horizon values, other than release and review days, a status message is issued stating
that this warehouse was not planned because all items have become active.
If your system is not tailored for Net change planning, a status message is issued.

• MLI planning run - Generation: Select this option to perform a planning run covering only the bill
of material levels you requested during planning run execution options.

• MLI planning run - Net change: Select this option to perform a planning run covering only the bill
of material levels for master level items, as described in the MLI planning run - Generation option.
Planned orders are replanned and requirements regenerated, as described in the Full planning
run - Net change option.
If your system is not tailored for Net change planning, an error message is issued.

5 Optionally, click the E-mail tab, then specify the information for the email that confirms the execution
of this host job.

6 Click Submit.

Running the Publish job
Use the Publish host job to send current information, for selected warehouses, from XA to specified destinations
using System-Link. You can choose to publish a single warehouse, manually selected warehouses, or
warehouses in a subset. For more information, see your System-Link administrator.

1 Select File > Host Jobs.
2 Click the Publish tab.
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3 Select the Execute check box.
4 Complete the fields including this information:

Replication destination
Specify the System-Link destination to which to send the warehouse information. If you leave the
replication destination blank, the replication destination specified for the individual warehouses is used.

5 Optionally, click the E-mail tab, then specify the information for the email that confirms the execution
of this host job.

6 Click Submit.
You can track the progress of the Publish host job in the Transaction Status object. Troubleshooting logs
may display in the Transaction Status when logging is configured in System-Link by your administrator.
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Chapter 29: Work schedule

The Work Schedule object contains start, end, break and lunch times for Time and Attendance and job shifts.

These times are used to calculate shift length, variance, and break times that are used in a number of inquiries
and calculations. For example, an employee status found on the Last Reported view of the Employee
Summary list page is considered an inquiry.

Shift date and time from a work schedule is used to determine employee status. Information from the work
schedule is used to calculate elapsed time, match and link labor transactions, and determine ON for OF only
reporting.

The Work Schedule object is active when OBPM and PMC are installed.

Variance time

Variance is the time lost between the end of one job and the beginning of the next. Variance time is the sum
of the unreported or lost time between jobs. The variance time is calculated by subtracting the reported time
from a balancing value.

A balancing value is calculated for each employee and is determined by the payment method specified in the
work schedule for the employee. For pay by time and attendance, the sum of time and attendance elapsed
times is used. For pay by job, the adjusted earliest job-on time is subtracted from the adjusted latest job-off
time to create the balancing value.

Variance time is calculated by taking the balancing value and subtracting the total of these times:

• Job time of the employee
• Total of the paid breaks extracted
• Amount of lunch extracted

Unpaid breaks are not used for balancing time or for variance calculations. The unpaid breaks are used to
reduce the individual job times in the balancing value.

After the variance is calculated, the variance is then compared to the variance limit. If the calculated variance
is less than or equal to the variance limit, the calculated variance is awarded. When pay is by time and
attendance, the entire variance is awarded. When pay is by job, no variance is awarded when the limit is
exceeded.
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Creating work schedules
1 Select Production > Monitoring > Administration > Work Schedule > Maintain > Create
2 Specify this information:

Work schedule
Specify a value between 001 and 999.

Pay basis
Select the option that indicates how pay is calculated for this employee. These values are valid:
• Time and attendance only: Select this option if these conditions are true:

• Employees are paid according to time and attendance records
• You do not want order activity passed to payroll for the Order Distribution Register

• Time attendance with job detail: Select this option if these conditions are true:
• Employees are paid according to time and attendance records
• You do want order activity passed to payroll for the Order Distribution Register

• Job: Select this option if employees are paid by job time records

3 Click Create.
If you select Preview before create, you can specify additional information on the General card tab.

Deleting a work schedule
If a work schedule is associated with employee records, then you cannot delete the work schedule.

1 Select the work schedule.
2 Select Maintain > Delete.
3 Click Yes.

Printing a Work Schedule List report
Use the Work Schedule List report to print a work schedule.

1 Select Production > Order Based > Monitoring > Administration > Work Schedule > File.
2 Optionally, select a work schedule.
3 Select File > Host Print
4 Select the Print check box..
5 Complete the fields on the Content tab.
6 Select the E-mail tab, then specify the information.
7 Optionally, select the Attachments tab to add attachments.
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8 Click Submit.
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