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Style Conventions 

The following is the list of conventions used throughout this document: 

[ ] Square brackets are used around text to indicate optional items, except in 
languages in which brackets are part of the syntax. You should type only 
the information within the brackets, not the brackets. 

Italics Italics are used to specify a variable name or other information the user 
must provide – for example, a path and file name. We also use them to 
denote parameters, placeholders, new terms, emphasis, and book titles. 

Bold Bolded text is used to indicate commands; text that must be entered 
exactly as it appears in this document; and buttons, checkboxes, menu 
commands, tabs, and option buttons that must be clicked. 

 

Intended Readers 

• Technology Managers 

• Systems Engineers  

• Web/Network Administrators 
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Overview 

This document explains the steps involved in deploying Thru-Put 7.0(64 Bit) Advanced 
Planning and Scheduling software in your environment. Thru-Put installation now 
supports installing Planning components without installing the Web components. When 
you uncheck the Web components during installation, IIS prerequisites are not checked. 
However when you do check “Web Components” option then, it is essential to have IIS 
pre-installed on the PC. For securing the Thru-Put application, you will have to modify 
some of the security policy settings of Thru-Put server components using DCOM 
configuration utility. Although policy settings are identical in all flavors of Windows 
machines (Windows XP/ Vista/ Windows Server 2008 etc), the location and screen 
layouts are little bit different in each of those windows environment. This document 
explains how to prepare Microsoft IIS and DCOM configuration in Windows 2008 
Server R2 Operating System.  

With this release, please note that reporting engines are different for planning session and 
for Web deployment. For scheduling, a run time distributable of Crystal 64 Bit is 
provided and is available on the Infor support website. For TPWeb Reports, Crystal 7.0 
Viewer version is no longer provided with Thru-Put installation due to incompatibility. 
As on May, 2012, TPWeb Reports are tested with Crystal 8.5 and Crystal XI (32 Bit) 
version only. It is highly recommended to use Crystal XI or above for your reporting 
needs. Thru-Put 7.0 (64 Bit) is available to work with SQL Server 2008 or above (both 32 
bit and 64 bit) version. Microsoft Access 64 Bit drivers are not available and hence Thru-
Put 7.0 is not available to work with Microsoft Access. 

Prerequisites before Installing Thru-Put 

Thru-Put 7.0 requires following five prerequisites: 

1. 64 Bit VC redistributables (vcredist_x64.exe) 

2. 32 Bit VC redistributables (vcredist_x86.exe) 

3. Crystal Run Time Version 13, 64 Bit (CRRuntime_64bit_13_0_1.msi) 

4. .NET 4.0 Redistributables (dotNetFx40_Full_x86_x64.exe) – required only if 
they are not already installed with the system. To check if you require, try running 
Dbutility from Thru-Put. If you get a crash or a warning message requesting for 
.NET 4.0version, then install. 

5. SQL Server Native Client Driver Version 10.0 (sqlncli_x64.msi) – required only 
if they are not already installed with the system. To check if you require, try 
creating a ODBC data source in DbUtil and see if you find SQL Native Client 
10.0 driver. If you don’t see means you need to install.  
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6. Any version of Crystal among Crystal Reports 8.5 thru Crystal XI R2 versions ( 
You can install this later also. but you need this information to specify which 
version of Crystal you are going to install) 

Run all of them in the above sequence before running Thru-Put Installation. 

Note: Thru-Put has been tested with IBM Client Access Drivers version VR60 and 
VR61 64 Bit only. You can install those components by downloading from IBM 
website. Remaining components are available on ftp.thru-put.com or from Infor 
support web site. 

Before Installing Thru-Put 

If you don’t plan to use TPWeb (TpWeb Reports & Customer Service Workbench), 
you can ignore this section. 

Thru-Put relies on Microsoft IIS as Web Server and assumes you have installed and 
turned on IIS feature.  If you go to Administrative Tools->Server Manager, your screen 
should like similar one below: 

 

 

ftp://ftp.thru-put.com/
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On Windows 2008 Server/Vista, make sure that ASP feature is also enabled as detailed in 
the following link: 

http://learn.iis.net/page.aspx/562/classic-asp-is-not-installed-by-default-on-iis-70-and-iis-
75/ 

Summary: 

1. Click Start, point to Administrative Tools, and then click Server Manager.  

2. In the Server Manager hierarchy pane, expand Roles, and then click Web Server 
(IIS).  

3. In the Web Server (IIS) pane, scroll to the Role Services section, and then click Add 
Role Services.  

4. On the Select Role Services page of the Add Role Services Wizard, select ASP.  

 

 

http://learn.iis.net/page.aspx/562/classic-asp-is-not-installed-by-default-on-iis-70-and-iis-75/
http://learn.iis.net/page.aspx/562/classic-asp-is-not-installed-by-default-on-iis-70-and-iis-75/
http://learn.iis.net/file.axd?i=1525
http://learn.iis.net/file.axd?i=1525


Deploying Thru-Put 7.0 on Windows 2008 R2 Server 

 

Copyright © 2002-2013 Infor IP Holdings C.V. and/or its affiliates or licensors.  All rights reserved. 5 

 

5. if the Add role services required by ASP dialog box appears, click Add Required Role 
Services. (This page appears only if you have not already installed the ISAPI Extensions role 
service on your server.)  

 

1. On the Select Role Services page, click Next.  

2. On the Confirm Installation Selections page, click Install.  

http://learn.iis.net/file.axd?i=1526
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3. On the Results page, click Close.  

 

 

Important note while installing Thru-Put on Windows 
2008/Vista 

If you don’t plan to use TPWeb, then uncheck “Web Components” from the 
installation screen below: 

One of the shortcomings while installing Thru-Put on Windows 2008 is, under certain 
environments Thru-Put install utility can not identify the System Drive on your system 
where IIS is installed. In that scenario, Thru-Put will install the Thru-Put Web 
components (TPWeb) under the current folder where the installation set up 
(SCMSetUp.EXE or SH15535.exe) is running from. This symptom can be easily 
overcome by looking at the installation screen as shown below. 

 

 

 

In the above screen, if you click on Web Components check box,  you might see  Folder 
selected for Currently selected Options as “%SystemDrive%\ inetpub\wwwroot” . If you 
leave this default selection, install utility will create a subfolder named“%SystemDrive%\ 
inetpub\wwwroot\TPWeb” and place all files belonging to Thru-Put Web components 
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inside. If this happens then Thru-Put Web Server will not operate smoothly.  This can be 
avoided by manually specifying the physical path of “inetpub\wwwroot” on your hard 
drive (typically C drive). This can be done by clicking on “Change Folder” which will 
bring up following screen: 

  

Change Directory to C:\inetpub\wwwroot or any other directory where you wish you to 
install the Thru-Put web components as shown below: 

 

If your IIS is installed on a different drive, please change the drive appropriately 
installed. 

 Installing XA configuration files. 
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During install if you check the box Use Infor XA integration as shown below, XA 
configuration files will be installed. (You can also choose configure XA later without this 
step)  

 

Installing Crystal Report run time for the TPWeb 

If you plan to use TPWeb Reports, it is better to install the Crystal software first. If you 
don’t have the Crystal Reports Software installed, choose the version you might install so 
that supporting files can be copied automatically. These components are used in TPWeb 
reports only. For planning purpose, report componenets have been  installed as a part of 
Thru-Put installation pre-requisites. 
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This complete the Thru-Put software components on your system. 

 

 

Creating the SQL Server database  

 

1. Go to Microsoft SQL Server management Studio and Right Click on Databases 
Node as shown below 
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2. Click on New Database… You will get following dialog: 
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Provide the name of the new database. Make sure the initial size is at least 2GB for the 
data and 100MB for log files and “Autogrowth” set to 10%-20%, unrestricted growth as 
shown below: 

 

3. Click on the Options tab and make sure “Recovery Model” is set to Simple. Keep 
remaining at default 
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This finishes creating a new SQL Server database 

 

Creating a New User for Thru-Put  
 

1.  Go to SQL Server Management Studio and Click on Security node as shown 
below 
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2. Click on the New Login. You will see following dialog: 



Deploying Thru-Put 7.0 on Windows 2008 R2 Server 

Copyright © 2002-2013 Infor IP Holdings C.V. and/or its affiliates or licensors. All rights reserved. 14 

 

 

Make sure the authentication is set to SQL Server authentication instead of Windows 
authentication as shown below: 

 

3. Click on the Server Roles as shown below: 
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4. Click on the User Mapping option and choose as shown below: 

 

 



Deploying Thru-Put 7.0 on Windows 2008 R2 Server 

Copyright © 2002-2013 Infor IP Holdings C.V. and/or its affiliates or licensors. All rights reserved. 16 

 

 

 

This finishes setting up SQL server and the SQL server user. 

 

Configuring Thru-Put to connect to SQL Server database 

Thru-Put 7.0 uses “SQL Native Client 10.0” (or above) version of ODBC driver to 
connect to SQL Server Database.  You can set up this connection by using Thru-Put DB 
Utility. With Thru-Put 7.0 Native SQL Server Connection no longer required. Thru-Put 
uses ODBC Native Client Driver for reading and writing to SQL Server database and for 
Crystal Reports. 
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Setting up SQL Server ODBC connection 

Step 1: Open DbUtility from Programs->Thru-Put7.0->Database Utility. Please choose 
“Run as Administrator” option. (else System will not allow you to change any settings 
and ignores your changes) 

Step 2: Go to File->Download Configuration 

In the database Type entry combo box, choose “ODBC”.  Make sure you have created a 
System DSN for the SQL Server ODBC driver with SQL native Client 10.0 or above. 

Changing the Configuration to use SQL Server 

After installing Thru-Put, locate the folder where installation folder and open config.ini 
file in a text editor. Modify the entry UseDAOForDatabase=0 if not already. 

 

Configuring DCOM 

If you don’t plan to use Customer Service Workbench, you can ignore this section. 

 

From Start Menu Run DCOM configuration by typing dcomcnfg as shown below: 
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You will see following screen 
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Go to Console Root->Component Services->Computers->My Computer->DCOM Config 
folder on the left pane and expand the view. You should see the list of components 
registered on the right pane as shown above. You should be to locate two components 
that are part of TPWeb viz. RESLISTENER and ResSession class. If you don’t see both 
components, then DCOM service has not registered your class successfully. In such case, 
please run register.bat from C:\THRU-PUT70 folder and reboot your computer and come 
back again. 

 

Configuring Default settings of DCOM  

If you don’t plan to use Customer Service Workbench, you can ignore this section. 

To configure “Default Access” and “Default Launch” permissions right click on “My 
Computer” on the left hand pane and select properties. A window will appear with a 
number of tabs. Select the tab titled “COM Security” as shown below. 

 

 



Deploying Thru-Put 7.0 on Windows 2008 R2 Server 

Copyright © 2002-2013 Infor IP Holdings C.V. and/or its affiliates or licensors. All rights reserved. 20 

 

 

Click on Edit Default.You need to have System, Interactive, IIS and IIS_USR in this list 
with “Allow” Access permissions. 
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Similarly Click on Default Launch and Activate permission. Make sure the above users 
have “Local Launch” and “Local Activation” permission.   
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Configuring DCOM settings of TPWeb components 

If you don’t plan to use Customer Service Workbench nor TPWeb, you can ignore 
this section. 

These setting are same as in other Windows systems like XP/Vista. 

Right click on Reslistener class and choose Propertes. 
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You should see the dialog below  
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The settings should look as above. 

 

Choose the “Identity” tab as shown below. 
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You can also set to a predetermined administrator user by choosing the “This User” and 
providing the local admin credentials. Click “OK” after done. 

Similarly, from the DCOM Config screen, right click on “ResSession Class” and you 
will see the dialog similar to the earlier dialog shown above. (If you don’t see ResSession 
class, you need to run Register.bat). Click on the “Identity” tab and set to “Launching 
user” as shown below. 
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Or you can set to “This User” and provide the credential of the local administrator as 
shown below: 
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Once done click “OK”. This ends the DCOM configuration. Close the DCOM Config 
application utility.  

Open Internet Explorer, and type in the address http://localhost/tpweb and you should see 
welcome login screen if you are successful : 

 

Registering Crystal 32 Viewer Dlls  

Note: If you don’t plan to use  TPWeb Reports, you can ignore this section. 

 

http://localhost/tpweb
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Run Command Prompt with elevated permission and go to <TPWeb> folder. You should 
see a batch file called WebRegister.bat. Open the file in notepad and modify each line 
where regsvr32 is referred and replace it with c:\windows\syswow64\regsvr32 and 
replace the <ActiveViewer folder> with appropriate folder on your hard drive where 
those files are.  Following is a sample file: 

 

Rem this will Register Crystal Viewer related DLLs on 64 Bit Windows 2008R2 

C:\Windows\SysWow64\regsvr32 /u <ActiveXViewer folder>\crviewer.dll 

C:\Windows\SysWow64\regsvr32 /u <ActiveXViewer folder>\Emfgen.dll 

C:\Windows\SysWow64\regsvr32 /u <ActiveXViewer folder>\swebrs.dll 

C:\Windows\SysWow64\regsvr32 /u <ActiveXViewer folder>\sviewhlp.dll 

C:\Windows\SysWow64\regsvr32 <ActiveXViewer folder>\crviewer.dll 

C:\Windows\SysWow64\regsvr32 <ActiveXViewer folder>\Emfgen.dll 

C:\Windows\SysWow64\regsvr32 <ActiveXViewer folder>\swebrs.dll 

C:\Windows\SysWow64\regsvr32 <ActiveXViewer folder>\sviewhlp.dll 

 

Save the file. Now run this modified batch file from command line. 

 

Configuring SQL Server to use Crystal 32 Bit version 

Note: If you don’t plan to use  TPWeb Reports, you can ignore this section. 

Thru-Put Web Report Engine is different than the Thru-Put Report Engine in Sync 
session. Thru-Put Sync engine uses 64 Bit version of Crystal which is single user license 
and is free and is included along with Thru-Put distributable.  

Thru-Put Web Reports use 32 Bit version of Crystal and can be used for multiuser 
purpose. To make TPWeb 64 bit version compatible with 32 Bit version of Crystal, 
crystal software needs 32 Bit version of ODBC SQL Server driver. Whenever user 
creates a 64 Bit ODBC DSN for connecting to Thru-Put database, user should also create 
another ODBC DSN for 32 with the same name but with 32 suffix. 

For Example, if the 64 Bit DSN name is TPProduction then, DSN name for 32 bit ODBC 
DSN should be TPProduction32.  
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For creating 32 Bit ODBC DSN, you should not use DBUtil /Resonance. Instead, open 
Command Prompt window as an Administrator and then goto c:\Windows\SysWow64 
folder and run ODBCAD32.exe to open the ODBC dialog and make sure you see “SQL 
Server " in the driver list and use it. Even SQL Client 10.0 also OK. 

 

Setting up Thru-Put TPWeb on Windows 2008 R2 

If you don’t plan to use Customer Service Workbench nor TPWeb, you can ignore 
this section. 

Following screenshots apply to Windows 2008 R2 Systems 

 

1. Go to IIS and choose Application Pools 
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2. Add a new Application pool or Modify Default app pool. In case you don’t want to 
disturb the other Web Applications better to have separate app pool for TPWeb.  

 

 

 

3. In the advanced Settings make sure 32 Bit applications are enabled as shown below: 
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4. Now go to TPWeb on the left pane and right mouse click 
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5. Make sure to change the Application Pool to TpWeb32BitPool you created in step 2 
above 
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6. Setting up Permission for all the folder in TPWeb 

On the left pane, click on Default Website. Then on the right pane, click on ASP and then 
click on Open Feature on the Action section (far right) as shown below 
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You will see following page. Choose Enable Parent Paths and set it to True if it is set to 
false as shown below. 
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Also note, the TPWeb icon which is open list with globe behind to indicate IIS has 
registered TPWeb as a web site. If you see a folder icon before TPWeb instead as shown 
below: 
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Right mouse click on TPWeb as shown below and execute “Convert To 
Application”menu option: 
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You will get the following dialog: 
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Leave all the defaults as is and click OK.  

Next from the Features pane, double click on ASP icon.  Change “Enable Parent Path” 
to “Yes” in the combo box. You should see the settings as shown below: 

 

 

Configuring IIS to use Crystal 32 Viewer   

Note: If you don’t plan to use  TPWeb Reports, you can ignore this section. 

From the left pane, make sure Viewer is an application. In higher version of crystal this 
Application may be different. In Crystal 11 viewer for example, you will see the 
application as “crystalreportviewers11”. Make sure that the Viewer is an application( 
Globe icon). Right click on the viewer and choose Manage Application->Advanced 
Settings. You will see the screen as shown below: 
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Change the Application pool to TpWeb32BitPool created earlier. 

At this point, IIS configuration is complete. If you are successful, then you should be able 
to open internet explorer and goto http://localhost/tpweb and able to see TPWeb although 
it may give some error messages regarding DCOM configuration. 

 

http://localhost/tpweb
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One last thing in setting up TPWeb 

Note: If you don’t plan to use Customer Service Workbench, you can ignore this 
section. 

If you are using Thru-Put Customer Service workbench, then you also need to provide 
access to c:\inetpub\wwwroot\TPWeb\tempXML folder using Windows Explorer. 

In Windows Explorer, locate the above folder and right mouse click to get to “Share” 
command and make “everyone” to have “Full Control”. This folder is used for writing 
the “Waterfall Information” during quotation in Thru-Put Customer Service 
workbench. 
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Setting up IBM Client Access ODBC Driver  
This section is applicable only if you are using XA ERP system ( or any other which are hosted on 
I Series platform).  

Thru-Put has been tested with IBM Client VR61  

The driver version is highlighted in the screenshot below:  

 

 

Setting up a new ODBC data source  
 

From   Windows 2008 R2, Start->Programs->IBM System I Access For Windows 

Run ODBC Administration. You will see a dialog as shown below. Click on the System 
DSN tab as shown below: 
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Click on ‘Add’ to add a new data source. From the ODBC Driver Admin, Add a new data 
source and choose the driver ‘iSeries Access ODBC driver’ as shown below.  
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You will see the following dialog: 

 
 

Enter the System pointing to your iSeries environment where XA is hosted. In the above 
example ‘USATLS05.INFOR.COM’ replace with the one you have configured. 

 

For the Data source Name avoid blank, dash (-) or under score (_) in the name. 

 

Click on the server tab as shown below: 

 

Choose System Naming Convention and provide the default library. In the example 
below, it is entered as AMALIBP. Check with your admin the name to be provided in 
your environment. 
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Click tab ‘Packages’ 

 

The screen should like as shown below: 
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Click on Conversions 

 

And make sure the configuration looks like the screen shot shown below; 
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Click on Diagnostic tab 

 

And make sure it matches the screenshot shown below: 
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After setting up the data source 
Please open ISeriesIntegration.ini and modify the file as shown below and save it: 

 

[ODBC] 

ISeriesDataSourceName=XAS0564Bit => change to your data source name 

ISeriesUserId=an1   => Change to your environment 

ISeriesPassword=909a23EE78CDF92412820CF3CDD871a2 => required only for 
TPWeb 

ISeriesEnv=9P => Change to your environment 

ISeriesWarehouse=KCC => Change to your environment 



Deploying Thru-Put 7.0 on Windows 2008 R2 Server 

Copyright © 2002-2013 Infor IP Holdings C.V. and/or its affiliates or licensors. All rights reserved. 48 

ISeriesUnencryptedPassword=nine2five => Change to your environment 

 

Make sure APSActive=1 ( For Thru-Put) 0 for VPi 

DownloadMode=1 ( 0 means test mode and putback will not upload) 

 

Running Download and Scheduling ( DbUtil.exe/ 
Resonance.exe) 

Please remember to run DbUtil and Resonance.exe as Administrator. In Windows 
Explorer, Right mouse click on the executables and choose ‘Run as Administrator’. 
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