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About this guide

Infor Distribution Storefront Catalog (Storefront Catalog) helps you manage your items and item
information, such as images and file attachments, in a central database so that all of your item information
is available for catalog creation. This guide explains how to set up and manage your item catalogs
using Storefront Catalog.

Intended audience
This guide is intended for Storefront Catalog administrators.

Related documents
These documents are in the product documentation section of Infor Xtreme:

• Infor Distribution Storefront Release Notes
• Infor Distribution Storefront Hardware and Software Requirements
• Infor Distribution Storefront Installation Guide
• Infor Distribution Storefront Catalog User Guide
• Infor Distribution Storefront Administration User Guide
• The appropriate ERP installation and integration guides

Online help is available for Storefront Administration, Storefront Catalog, and Storefront Commerce.

Contacting Infor
If you have questions about Infor products, go to the Infor Xtreme Support portal.

If we update this document after the product release, we will post the new version on this website. We
recommend that you check this website periodically for updated documentation.

If you have comments about Infor documentation, contact documentation@infor.com.
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1Storefront Catalog overview

With Infor Distribution Storefront Catalog, you can create and publish online catalogs for the products
you sell. Storefront Catalog uses products from your ERP application as the basis of information for
your catalogs. Presentation of that information is set up and maintained using Storefront Catalog. For
example, you use the Storefront Catalog application to create attributes and attachments for catalog
items, set up page layouts and page layout groups for catalogs, and publish items and catalogs for
use in Storefront Commerce.

Review these topics for more information:

• "Getting started" on page 11
• "Setting up Storefront Catalog" on page 17
• "Translating Storefront Catalog data" on page 31
• "Working with items" on page 33
• "Working with attributes" on page 45
• "Working with attachments" on page 53
• "Working with page layouts" on page 65
• "Working with page layout groups" on page 89
• "Working with item detail tabs" on page 91
• "Working with catalogs" on page 95
• "Scheduling and running jobs" on page 103
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2Getting started

Before you use Storefront Catalog to create and manage online catalogs, review these topics:

• "Logging in and out" on page 11
• "Navigating Storefront Catalog" on page 11
• "Searching for records" on page 14
• "Editing records" on page 15
• "Deleting records" on page 15

Logging in and out
The first time you log into Storefront Catalog, you must use the administrator user ID and password
(admin, admin). The administrator user ID and password are included as part of your installation.

Note: To use Storefront applications, JavaScript must be enabled in your browser. Do not disable this
setting when using Storefront applications.

To log in:

1 Launch the Storefront Catalog application.
2 In the User ID and Password fields, type admin.
3 Click Login or press Enter. The Storefront Catalog home page is displayed.

To log out:
Click the logout X.

Navigating Storefront Catalog
This topic provides a description of the Storefront Catalog user interface and its conventions.
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• Drop-down menus are available from any page in the application. To perform a task, select it from
the menu.

• Tabs identify pages. The tab for the current page is white and in front. Tabs for inactive pages are
blue and behind the active page. Click a tab to access its page.

• Use the links on the page to move to another page in the application. A link indicates an element
of data, such as an item number, that you can click to review the item in detail.

• Select a row by clicking the check box associated with it. You can then perform actions on selected
rows.

• Click a button to perform a specific action on the page. The button action always applies to selected
rows.

• When multiple pages of data exist, use the page links to access the additional pages of results.
Click the number of the page that you want to review to access that page. To go to the next page,
click the forward arrow (>). To go to the previous page, click the back arrow (<). To go to the last
page of results, click the double forward arrow (>>). To go the first page of results, click the double
back arrow (<<).

Menus
The Storefront Catalog menus are described in this table:

12 | Infor Distribution Storefront Catalog User Guide

 

Getting started



PurposeMenu

Select to return to the Storefront Catalog home page.Home

Create and search for catalogs.Catalogs

Search for items, assign attributes and attachments, apply rules, and create
rules for item descriptions.

Items

Create and search for attributes and assign attributes to items.Attributes

Import single and multiple attachments, search for imported attachments, and
assign attachments to items, catalogs, or categories.

Attachments

Import items, classifications, extended item comments, and user accounts from
your ERP application. This menu is also used to publish items and catalogs.

Import

Export your catalogs.Export

Create and search Item Detail page tabs; set the Storefront Catalog user interface
options and options for handling import and export, attachments, and extended
item comments; and schedule and run catalog jobs.

System > Catalog

Create and search for page layouts and page layout groups, and set the Store-
front Commerce user interface option.

System > Com-
merce

Translate user-defined data and imported master data for the supported lan-
guages.

Translation

Shows the online help for Storefront Catalog.Help

Common page types
This table shows the common page types and the purpose of each type of page:

PurposePage

Search pages are displayed when you select a Search task from a menu. Search
pages typically contain a subset of maintenance fields you can use to type
search criteria for limiting search results.

Search

Create pages are displayed when you select a Create task from a menu. Create
pages contain all of the fields used to define the record being created. In some
instances, not all fields are required.

Create

Results pages are displayed when you click Search on a Search page. Results
pages list the results of your search. Typically, the first column in search results

Results

contains links you can click to view the full details of each record. Results pages
also can be used to delete records.

View pages are displayed when you click the link in the first column of a Results
page. Typically, the fields on a View page are the same as those on the Create
page, except that they cannot be changed.

View
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PurposePage

Edit pages are available when a View page is available. You can access an
Edit page by clicking the Edit tab. Use Edit pages to change any of the informa-
tion for a record. Edit pages also can be used to delete a record.

Edit

Searching for records
When searching in Storefront Catalog, be aware of the relationship between the search criteria. Two
types of criteria relationships are possible:

• And
This type of search combines all search criteria in a cumulative way so that all specified criteria
must be met. For example, if you are searching for items and you specify binder in the Description
field, 01 in the Item Class/Subclass field, and then you select Suspended, your search results will
include only those items that match all three conditions: items that have binder in the description,
are assigned to item class 01, and are suspended. Your results will not include all items with binder
in the description, all items assigned item class 01, and all suspended items.

• Or
This type of search does not combine search criteria, but looks for results that match any one of
the search criteria. For example, if you are searching for catalogs and you specify SUM in the
Catalog Name field and Sale in the Catalog Description field, your search results will include
catalogs with SUM in the name or Sale in the description. You r results may include all items with
a Catalog name of Summer or Summer 2024 or all items with a description of End of season sale,
or Top ten percent customer sales.

To search for records:

1 In the menu bar, select the type of record to work with. For example, to find a particular item, select
Items > Search. Or to find an attachment, select Attachments > Search.

2 Perform one of these steps:

• To narrow your search, specify any of the requested search criteria and then click Search. The
and/or relationship is indicated to the right of the field text boxes. The Results page is displayed,
listing records that match your search criteria.

• To find all records, leave search criteria fields empty and click Search. The Results page is
displayed, listing all records.
This common search functionality is provided for finding most records. Search criteria differ for
the various record types and are explained in greater detail in a search topic related to each
record type.
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Editing records
To edit records in Storefront Catalog:

1 Search for the record to edit.
2 On the Results page, select the record to edit. The View page is displayed.
3 Click the Edit tab and make changes as necessary.
4 Click Save.

Deleting records
To delete records in Storefront Catalog:

1 Search for the record to work with.
2 Perform one of these steps:

• Delete multiple records: On the Results page, select the check box of each record to delete and
then click Delete and OK.

• Delete a single record: On the Results page, select the record to edit. Select the Edit page and
then click Delete and OK.
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3Setting up Storefront Catalog

To set up Storefront Catalog, you will specify settings for attachments, extended item comments (EIC),
import and export, and Storefront Catalog and Storefront Commerce user interface options.

Review these topics for more information:

• "Setting Catalog import options" on page 17
• "Setting Catalog export options" on page 18
• "Setting image attachment options" on page 18
• "Setting Catalog user interface options" on page 19
• "Setting Commerce user interface options" on page 20
• "Setting extended item comments options" on page 20
• "Importing user accounts" on page 21

Setting Catalog import options
Import options indicate how item information from your ERP database updates item information in
Storefront Catalog.

To set import options:

1 Select System > Catalog > Import Options.
2 Specify this information:

Update item product description with the back end descriptions if it has not been changed
in Catalog.
Select this option to update item descriptions during the import. A description is updated only if it
has not been changed in Storefront Catalog. For example, assume that the description for item
A100 changed on the ERP from "Arctic Sun Shades" to "Arctic Sunglasses" and the description
has never been changed in Storefront Catalog. The description "Arctic Sun Shades" will be updated
to "Arctic Sunglasses" during the next import, if this check box is selected.
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Update item manufacturer with the back end manufacturer if it has not been changed in
Catalog.
Select this option to update item manufacturers during the import. A manufacturer is updated only
if it has not been changed in Storefront Catalog.

Automatically approve modified items from the staging area during the back end import (not
rejected).
Select this option to approve items with changes during the import. This means items will be moved
from the staging area to the repository as part of the import, unless the item is marked as rejected.
Only existing items with changes are approved automatically. You must review and approve or
reject new items. See "Publishing items" on page 42.
If you select this option, be sure you have rejected any existing items in the staging area that you
do not want moved to the item repository.

3 Click Submit.

Setting Catalog export options
To set export options:

1 Select System > Catalog > Export Options.
2 Specify this information:

Export Directory
Specify the directory where the exported catalog will be saved.

Max File Size to Display
Specify the maximum file size for the exported catalog.

3 Click Submit.

Setting image attachment options
After setting attachment options, you can upload image attachments into Storefront Catalog in one size
and resolution but display those images in different sizes in Storefront Commerce.

You can select a predefined image size or select Custom and define your own width and height for
the image size.

Note: If the custom size entered is greater than the actual image size, Storefront will not adjust the
image size up. The actual size of the image is displayed.

To set attachment options:

1 Select System > Catalog > Attachment Options.
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2 Specify this information:

Thumbnail Size
Specify the size, in pixels, to display thumbnail images in Storefront Commerce. The default value
is 64 x 64. Thumbnail images are displayed on pages where multiple products are listed, such as
the Browse and Specials List pages. When a shopper clicks a thumbnail image, the Item Detail
page for that product is opened.

Primary Image Size
Specify the size, in pixels, to display the primary product image in Storefront Commerce. The default
value is 256 x 256. The primary image is displayed on the Item Detail page for a selected item.
When a shopper clicks a primary image, it is displayed in the full size and resolution that was
uploaded into Storefront Catalog.

Gallery Size
Specify the size, in pixels, to display gallery images in Storefront Commerce. The default value is
128 x 128. Gallery images are displayed on the Item Detail page for a selected item when there
are multiple views to choose from. When a shopper clicks a gallery image, it is displayed in the full
size and resolution that was uploaded into Storefront Catalog.

Category
Specify the size, in pixels, to display category images in Storefront Commerce. The default value
is 128 x 128. Category images are displayed on the Browse all Categories page. When a shopper
clicks a category image, it is displayed in the full size and resolution that was uploaded into Storefront
Catalog.

3 Click Submit.

Setting Catalog user interface options
When you set Catalog user interface options, you specify the number of results to be shown on a page.

To set Catalog user interface options:

1 Select System > Catalog > User Interface Options.
2 Specify this information for all installations of Storefront Catalog:

Number of Results Per Page
Specify the number of search results to display on a Storefront Catalog Results page by default,
and the number of results that can be displayed if the user wants to change the default number.
The first field is for the number of results displayed by default and the second and third fields are
for the user's options.
For example, if you specify 10, 20, 30, then when a Storefront Catalog user performs a search —
such as a catalog, item, attribute, or attachment search — 10 results are displayed on each page
by default, and the options for 20 or 30 results are provided in a drop-down field.
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Number of Items Per Page (Categories page)
Specify the number of items to display on the Storefront Catalog Categories page for a selected
category.

3 Click Submit.

Setting Commerce user interface options
When you set Storefront Commerce user interface options, you specify the number of results to be
displayed for a search in Storefront Commerce.

To set Commerce user interface options:

1 Select System > Commerce > User Interface Options.
2 Specify this information:

Number of Results per Page
Specify how many search results to show by default in Storefront Commerce, and how many can
be shown if the user wants to change this number.
For example, in the three fields provided, you could specify 10, 20, and 30. When Storefront
Commerce users perform a search, they are shown a list of 10 results per page, and they are given
links to change the number of results displayed to 20 or 30.

Number of Items per Row
Specify the number of items per row to show by default in Storefront Commerce. This is only
available for the grid view in Storefront Commerce.

Number of Rows per Page
Specify the number of rows per page to show on the Storefront Commerce. This is only available
for the grid view in Storefront Commerce.

3 Click Submit.

Setting extended item comments options
Note:  Refer to the ERP integration documentation delivered with the Infor Distribution Storefront
Integration components for details regarding support of this feature with your ERP.

Extended item comments (EICs) provide additional information about an item. Before you set extended
item comments (EIC) options, you must import the extended item comments. They can be imported
when you import items. Refer to "Importing items from the ERP" on page 33. They can also be imported
by themselves. Refer to "Importing extended item comments" on page 34.

To set EIC options:

20 | Infor Distribution Storefront Catalog User Guide

 

Setting up Storefront Catalog



1 Select System > Catalog > EIC Options. The EIC groups defined on your ERP application, and
available to be used in Storefront Catalog, are displayed in the Available list box. The EIC groups
set to be used in Storefront Catalog are displayed in the Selected list box.

2 Use the left and right arrow buttons to arrange your groups in the appropriate list box.
3 Click Submit. EICs for selected groups are shown on the Item Detail page if the tab is set up to

show EICs. See "Working with item detail tabs" on page 91.

Importing user accounts
Note:  Refer to the ERP integration documentation delivered with the Infor Distribution Storefront
Integration components for details regarding support of this feature with your ERP.

On the ERP, you have defined a set of users that are authorized to use the ERP application. To minimize
duplication of effort, you can create user accounts for the users that you have defined on your ERP by
importing the data from the ERP.

To import back end user accounts:

1 Select Import > Back End > User Accounts.
2 Click Start Import. When the import is complete, the status of each stage of the import and the

number of records processed for each stage is displayed. If there are errors at a particular stage,
click View Errors.

3 Wait for the import process to complete before you leave the page.
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4Working with the Catalog import utility

With the Infor Distribution Storefront Catalog import utility, you can create files containing catalog data
and import the file data into the Storefront Catalog. You can use the utility as a high speed approach
to creating catalog data and automate repetitive Catalog application data entry tasks.

You can use Storefront Catalog to manage your items and item information, such as images and file
attachments. This information is stored in a central database and is available for catalog creation. You
can use the Catalog import utility to upload file data into the Storefront Catalog.

A set of file formats support the interface to corresponding catalog objects such as catalogs, categories,
attributes, attachments, and the assignment of these objects to items, catalogs, and categories.
Additionally, you can unassign and delete catalog objects. The import utility reads, validates, and loads
the file data into the Storefront Catalog. The Storefront Catalog may be published for use in Storefront
Commerce.

Note: You should perform an SQL backup of the Catalog prior to using the Catalog import utility. Any
data corruption caused by the import utility is not supported. Additionally, you should create a new
catalog.

Understanding the Catalog import utility processing
flow
To use the catalog utility, follow these steps

1 Upload files

• Files are uploaded to the Infor Distribution Storefront AppServer Catalog import utility data input
directory through the Upload Page, FTP, or file copy.

• A set of Storefront Catalog import utility data directories are created when you upload the first
file. If this directory is inadvertently deleted, it is re-created when you upload.

• The data directories are created on the Storefront AppServer in the webapps directory for example,
c:\tomcat\webapps\storefrontAppServerData

• The upload input directory is \webapps\storefrontAppServerData\ciu\in
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• The directory where processed files are moved after processing is \webapps\storefrontApp
ServerData\ciu\processed.

Note: The input files are not deleted.

2 Read the spreadsheet files into a set of corresponding Catalog import utility temp database tables.

• The temp tables correspond to each file format.
• Data validation is performed and messages are available on the Catalog import utility Status

Page or SQL query.
• When you use the Upload Page, the validation process is started after the file upload.
• If you use Ftp/Copy, the validation process is initiated from the Catalog import utility Status Page.
• Optionally, you can write data directly to the temp tables to enable your own automation.

3 Process the Catalog import utility temp table data into the Storefront Catalog staging area tables.

• The Storefront Catalog staging are tables store data for the Storefront Catalog user interface.
• The data is validated before processing data into Catalog staging tables.
• You can view any warning or error messages on the Storefront Catalog import utility Status Page.
• Optionally, you can view the temp table data through SQL to validate data.
• Only valid data is transferred to the Catalog staging tables.
• This process is available via the Storefront Catalog Schedule/Run Jobs Page.
• After this process completes, the Storefront Catalog import utility temp table data associated

with the File(s) processed is deleted.

4 Publish the Storefront Catalog as usual. Storefront Catalog data is processed as usual through the
Catalog publish/indexing process.

Preparing the import utility files
You can use the provided formats for creating data to be imported. The data must be specified as
defined in these file formats.

See the Documentation\sample folder for file format examples.

Using the Catalog import utility
After you create the catalog files, you can upload the files. You can upload one or more files before
you process the data into the Catalog staging area tables.

To access the Catalog import utility and upload a file:
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1 In Storefront Catalog, select Import > File Utility.
2 Select the Upload Files tab.
3 Click Browse to open a file dialog and select a file.
4 Select the file to upload and click Open.
5 Select Run File Validation Only to validate the file without loading the data.
6 Click Upload File. The selected file is uploaded to the input directory and processed into the

corresponding temp tables.

Uploading files using FTP or File/Copy
Optionally, you can copy your files directly to the Catalog import utility input directory.

To copy your files directly to the input directory:

1 Select the files in the source directory and click Copy.
2 Browse to the target input directory: \webapps\storefrontAppServerData\ciu\in and click

Paste.

Checking the upload status
After you upload the files, you can use the Status Search function to check the upload status. The
Search Status function shows the status of the files that have been uploaded but have not been
published to the Storefront Catalog.

To check the status of the files:

1 Select Import > File Utility > Status Search.
2 Optionally, you can specify filter criteria.
3 Click Search to display the Status Results page.

The Status Results page shows the status of files that have not been published into the Storefront
Catalog. Only data for entries with a status of Load Complete and an error count of zero are eligible
for processing into the Storefront Catalog. You must correct and re-upload all data with entries that
have an error count greater than zero.

Understanding the search results
On the Status Results page, you can view the file ID, filename, number of input records processed,
error information, and the status of the upload.

If the Id field is non-numeric and begins with u, for example u001 and the status is UPLOADED:
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• The file was copied directly to the input directory using FTP or File Copy.

• The file has not yet been processed into the TEMP tables

• You can process this file as an UPLOADED file using one of the Process Uploaded Actions.

If the Id field is numeric, the status is LOAD COMPLETE, and the Filename is not a Link:

• This file was processed into the temp tables.
• Because the filename is not a link, and there are no errors, this data can be published to Storefront

Catalog.

If the Id field is numeric, the status is LOAD COMPLETE, and the filename is a link:

• This file was processed into the temp tables.
• Because the filename is a link, there are errors. Click the filename to view the warning and error

messages. The error messages state the row and column that failed the validation process. You
must correct the errors and re-upload the data. These files are not ready to be published to Storefront
Catalog and are ignored by the Processing File Data into the Storefront Catalog process.

This table illustrates the search results columns:

NotesStatus Results Column

Count of input file recordsRecords

Count of input file records processedProcessed

Count of input file records processed that pass
validation and are inserted into SFCIU TEMP ta-
bles

Valid

Count of input file records processed with non-fatal
warnings and are inserted into SFCIU TEMP ta-

Warning

bles. If Warning Count > 0, data will be processed
into Storefront Catalog.

Count of input file records processed that failed
validation and are not inserted into SFCIU TEMP

Error

tables. If Error Count > 0, data is not processed
into Storefront Catalog; this data must be corrected
and re-uploaded.

Count of rows inserted into all corresponding SF-
CIU TEMP tables. It is possible that multiple table

Data

rows will result from one input record; this is true
for the unassign/delete formats that support wild
card processing.

UPLOADED - File is uploaded to the input directo-
ry but not loaded into the TEMP tables.

File Upload Status

LOAD COMPLETE - File is uploaded to the input
directory and loaded into the TEMP tables.
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NotesStatus Results Column
LOADING - File is uploaded to the input directory
and is currently being loaded into the TEMP tables.

NOT PROCESSED - Initial status during file upload
to TEMP tables.
LOAD COMPLETE - TEMP table to SA table pro-
cessing job successful (Scheduled Jobs Page -
Catalog Import Utility Process Temp Data).

Process Data JOB Status

ERROR - An error has occurred during TEMP table
to SA table processing (Scheduled Jobs Page -
Catalog Import Utility Process Temp Data). Click
the Filename to view the error. After you resolve
the issue, you must re-upload the file.

File options on the Status Results
You can perform these options on the Status Results page:

• Refresh
You can click Refresh to update the record counts and statuses.

• Delete
You can delete any file that is displayed. Select one or more files and click Delete to delete the file,
status entries, messages, and the TEMP table data.

• Process Selected Uploaded Files
This operation is allowed on files that have a status of UPLOADED and the files are uploaded by
FTP or File Copy. This action is disabled until one of more files that have the status of UPLOADED
are selected. Select one or more files and click Process Selected Uploaded Files to process this
data into the TEMP tables. You should review the status of these files after processing because
they contains error/warnings.

• Process All Uploaded Files
his operation is allowed on files that have a status of UPLOADED and the files are uploaded by FTP
or File Copy. This action is disabled until one of more files that have the status of UPLOADED are
selected. Click Process All Uploaded Files to process all UPLOADED data into the TEMP tables.
Only files with Status of UPLOADED are processed as a batch of files. You should review the status
of these files after processing because they contains error/warnings.
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Understanding the processed directory
After the input file is uploaded and processed into the temp tables, the files are moved to the processed
directory. The files are not deleted.

The input filename is pre-pended with processing date/time timestamp. All files processed as a batch
will have same timestamp. For example:

Filename in SFCIU processed directoryOriginal Input Filename

20140424153702_SFCIU_account.xlsxSFCIU_account.xlsx

• 20140423121838_SFCIU_01_saitem_sacatego-
ry_unassign_delete_DEL_CATALOG.xlsx

• SFCIU_01_saitem_sacategory_unas-
sign_delete_DEL_CATALOG.xlsx

• SFCIU_02_saitem_sacategory_ADD_CATA-
LOG_CATEGORIES_ITEMS.xlsx

• 20140423121838_SFCIU_02_saitem_sacatego-
ry_ADD_CATALOG_CATEGORIES_ITEMS.xlsx

• 20140423121838_SFCIU_03_saitem_saat-
tribute_unassign_delete_DEL_ATTRIBUTES.xl-
sx

• SFCIU_03_saitem_saattribute_unas-
sign_delete_DEL_ATTRIBUTES.xlsx SF-
CIU_04_saitem_saattribute_ADD_AT-
TRIBUTES.xlsx • 20140423121838_SFCIU_04_saitem_saat-

tribute_ADD_ATTRIBUTES.xlsx• SFCIU_05_saitem_saattachment_unas-
sign_delete_UNASSIGN_ATTACHMENTS.xlsx • 20140423121838_SFCIU_05_saitem_saattach-

ment_unassign_delete_UNASSIGN_ATTACH-
MENTS.xlsx

• SFCIU_06_saitem_saattachment_ASSIGN_AT-
TACHMENTS.xlsx

• 20140423121838_SFCIU_06_saitem_saattach-
ment_ASSIGN_ATTACHMENTS.xlsx

Processing File Data into the Storefront Catalog
After the input files are uploaded, processed into the temp tables, and all errors are resolved, you can
publish the data into Storefront Catalog. Only data with a status of LOAD COMPLETE and zero error
can be processed.

To process your file data into Storefront:

1 To execute the job that moves the data from the temp tables into the Storefront Catalog staging
area tables, click the Go to Scheduled Jobs to process Catalog Import Utility Job from any of
the import utility screens. The Storefront Catalog Scheduled Jobs page is displayed.

2 Select Catalog Import Utility Process Temp Data.
3 Click Run Now.
4 Click Refresh to view the current status of the job.
5 To validate the data after the process completes:

• Validate the data in Storefront Catalog
• Use SQL Query to validate the data

28 | Infor Distribution Storefront Catalog User Guide

 

Working with the Catalog import utility



• Verify that data from the original input files processed appears as expected in the corresponding
Storefront Catalog object(s). If your original input file is misplaced, the original file that you
uploaded remains in the processed directory until it is deleted.

Processing data order
Files are processed in a particular order based on data dependency. This enables a set of files to be
processed as a batch. Data with a particular format can be processed across multiple files. This enables
loading larger sets of data, for example, creating a large catalog that would not otherwise fit into a
single file.

The Catalog Import Utility Process Temp Data JOB executes the program CatalogImportUtilityNativeSQL.
This program processes data in this order:

DescriptionFile FormatProcessing Method

UPDATING Item Product Descrip-
tion, Manufacturer

SFCIU_saitemimportSaitem

DELETING Attributes DELETING
Attribute Name/Values UNAS-

SFCIU_saitem_saattribute_unas-
sign_delete

deleteSaattributes

SIGNING Attribute Name/Values
from Items

ADDING Attributes ADDING At-
tribute Values, Attribute Value

SFCIU_saitem_saattributeimportSaAttributes

Sequence ASSIGNING Attribute
Name/Value Pair(s) to Items

UNASSIGNING Attachment(s)
from Items by Attachment Name
DELETING Attachments

SFCIU_saitem_saattach-
ment_unassign_delete

deleteSaattachments

ASSIGNING Image/Text/File/URL
Attachments to Items by Attach-

SFCIU_saitem_saattachmentimportSaAttachments

ment Name ADDING Text Attach-
ment Content (same as Process
As Text Option) ADDING URL
Attachment Content

DELETING Catalog(s) DELET-
ING Categories and SubCate-

SFCIU_saitem_sacategory_unas-
sign_delete

deleteSaCatalog

gories from a Catalog UNAS-
SIGNING Item(s) from Categories

ADDING Catalog(s) ADDING
Categories and SubCategories

SFCIU_saitem_sacategoryimportSaCatalog

to a Catalog with category se-
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DescriptionFile FormatProcessing Method
quence numbers supported at all
levels ASSIGNING Item (s) to
Categories and set item se-
quence numbers at category lev-
el

UNASSIGNING Attachment(s)
from existing Catalogs/Categories

SFCIU_sacategory_saattach-
ment_unassign

deleteSaCategoryAttachments

ASSIGNING Attachment(s) to
existing Catalogs/Categories

SFCIU_sacategory_saattachmentimportSaCategoryAttachments

WILL NOT ADD Catalog/Catego-
ry WILL NOT ADD Text/URL At-
tachment Content

DELETING Accounts Will NOT
Delete Shopper Accounts (Active
Budget/Approval Accounts)

SFCIU_account_deletedeleteAccounts

ADDING AccountsSFCIU_accountimportAccounts
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5Translating Storefront Catalog data

In Storefront Catalog, you can translate user-defined and imported master data for the supported
languages, which are English, Spanish, French, German, and Italian. The translated text is displayed
in Storefront Commerce based on the language that the user selects on the Home page in Storefront
Commerce.

If you require multiple languages, you can specify translated text in the languages that you support on
these pages:

• Catalog
• Category
• Item
• Attachment
• Text Attachment
• Extended Item Comment
• Attribute
• Attribute Value
• Page Layouts
• Item Detail Tabs

To add or change translated text individually for only a few items, see "Adding or changing translated
text" on page 31. To provide translated text for multiple items, you can download a spreadsheet, make
your changes in Microsoft Excel, and then upload the file. See "Uploading translated text for items" on
page 32.

Adding or changing translated text
To specify translated text:

1 Select Translation and then select one of the translation menu options that you want to specify the
translated text such as Catalog. For the option that you selected, the Translation Summary page
shows the number of untranslated entries and the number of translated entries for each of the
supported languages.
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2 To specify translated text for untranslated entries, click Untranslated Entries next to the language
to translate. To view or change text that has already been translated, click Translated Entries next
to the language to translate. The Translation Details page is displayed.

3 For each field, specify the appropriate translated text.
4 For text that was not translated previously, click Add Translation; otherwise, click Update

Translation.
5 Click Back to Summary.
6 To specify translated text for a different option, select another option from the Translation menu or

click one of the tabs.
7 Repeat steps 1 through 5 until all entries that you require are translated or updated.
8 To publish your changes, select Import > Publish > Catalog.

Uploading translated text for items
To upload translated text for items:

1 Select Translation > Items. The Translation Summary page shows the number of untranslated
entries and the number of translated entries for each of the supported languages.

2 To specify translated text for untranslated entries, click Untranslated Entries next to the language
to translate. To view or change text that has already been translated, click Translated Entries next
to the language to translate. The Translation Details page is displayed.

3 In the Download item entries field for the language that you chose, click the numer of items to
translate, click Download, and save the file. The file that includes the items to translate for the
specified language is saved to the location that you specify.

4 Open the file in Microsoft Excel and add the translated text in each column provided for the translation.
5 Save your changes.
6 In Storefront Catalog, navigate back to the Items Translation Details page. See steps 1 and 2 for

details to do this, if necessary.
7 To upload the file, click Browse next to the Upload item translations field for the language that

you chose. Select the file with your changes.
8 Click Upload File. The translated text is saved.
9 Repeat this process until all items in the language that you require are translated.
10 To publish your changes, select Import > Publish > Catalog.
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6Working with items

Items are the foundation of your catalogs. After you have imported items to Storefront Catalog, you
can begin to work with them. You can edit item information for presentation on your website. You can
also assign attachments to items, such as product specifications, to provide additional information to
prospective buyers. Attributes can be assigned to items to help classify their identifying characteristics
and enhance the search capabilities provided to users.

Review these topics for more information:

• "Importing items from the ERP" on page 33
• "Understanding item information" on page 36
• "Using normalization rules for item descriptions" on page 38
• "Searching for items" on page 40
• "Editing items" on page 41
• "Publishing items" on page 42
• "Deleting records" on page 15

Importing items from the ERP
Note:  Refer to the ERP integration documentation delivered with the Infor Distribution Storefront
Integration components for details regarding support of this feature with your ERP.

Storefront Catalog allows you to import items from your ERP application.

The Storefront Catalog back-end item import process copies item, item classification, and extended
item comment (EIC) data from the ERP. You also can import user accounts from your ERP database
to Storefront Catalog, as explained in "Importing user accounts" on page 21.

Note:  If this is the initial import for a new installation, you must run the Data Retrieve option in Storefront
Administration to retrieve warehouse data first. Then, you can you import items.

To import items:

1 Select Import > Back End > Items.
2 On the Import Items page, click Start Import.
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Your first import may take longer than subsequent imports because the first import must pull all item
data; subsequent imports pull only new items and changed data.
When the import is complete, the status of each stage of the import and the number of records
processed for each stage is displayed on the page. If there are errors at a particular stage, click
View Errors.
With a complete set of item data available in the Storefront Catalog staging area, you must use the
publish function to move data from the staging area to the production area, so items are available
to add to catalogs. See "Publishing items" on page 42.
Also, after EICs are imported, you can set options for them. See "Setting extended item comments
options" on page 20.

Note: When you change an item in the ERP, you should run the import. Item changes on the ERP
do not automatically update Storefront Catalog.

Importing classifications
Item classification data is information that can be used to characterize and classify items, such as item
classes, item subclasses, GL codes, price classes, miscellaneous codes, and user fields. Item
classifications are included in the import data when you import items. However, if you know that changes
have been made to item classification information on the ERP and you want to import only those
changes to Storefront Catalog, you can select to import just classification data.

To import classifications:

1 Select Import > Back End > Classifications.
2 Click Start Import.

When the import is complete, the status of each stage of the import and the number of records
processed for each stage are displayed. If there are errors at a particular stage, click View Errors.

Note: As you make classification data changes on the ERP, you must import classifications again.
Classification changes on the ERP do not automatically update Storefront Catalog.

Importing extended item comments
Note:  Refer to the ERP integration documentation delivered with the Infor Distribution Storefront
Integration components for details regarding support of this feature with your ERP.

On the ERP, you can create extended item comments (EICs) to provide additional information about
an item, such as warranty information, picking/packing instructions, or promotional information. EICs
are included in the import data when you import items. However, if you know that changes have been
made to EIC information on the ERP and you want to import only those changes to Storefront Catalog,
you can select to import only extended item comments.

To import extended item comments:
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1 Select Import > Back End > Extended Item Comments.
2 Click Start Import.

When the import is complete, the status of the import and the number of records processed is
displayed. If there are errors, click View Errors.

Note: As you make EIC data changes on the ERP, you must import EICs again. EIC changes on
the ERP do not automatically update Storefront Catalog.

After EICs are imported, you can set options for them. See "Setting extended item comments options"
on page 20.

Uploading to the Catalog
In Storefront Catalog, you can upload United Nations Standard Products and Services Codes (UNSPSC)
and UOM cross-reference codes.

Uploading UNSPSC codes
In Storefront Catalog, you can upload United Nations Standard Products and Services Codes (UNSPSC).
The upload process uses a Microsoft Excel spreadsheet that has this data:

• UNSPSC
• Item number

To process each line of your Excel spreadsheet, the upload process :

• Searches for the UNSPSC.

• If the UNSPSC is found then it is assigned to the item.
• If a UNSPSC is not found then a UNSPSC is created and assigned to the item.

• Assigns the UNSPSC to all the items with that item number regardless of the company and a status
of stocked or non-stocked.

To upload your UNSPSC codes:

1 Select Items > Upload > Unspsc.
2 Browse to and select the Excel spreadsheet file containing Item UNSPSC.
3 Click Upload file.

Uploading UOM cross-reference codes
In Storefront Catalog, you can upload UOM cross-reference codes. UOM cross-reference codes are
used to map the Storefront item UOM codes with the external UOM codes.
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The upload process uses a Microsoft Excel spreadsheet that has this data:

• Connection name: This is the Punchout connection created in Storefront Administration.
• Item Number
• UOM in Storefront
• UOM cross-reference

To process each line of your excel spreadsheet, the upload process :

• Searches for the UOM.

• If the Storefront UOM is found in the table then update the replacement UOM code with the UOM
cross-reference value.

• If the Storefront UOM is not found then a new entry is created.

• The UOM is moved to production tables after the Item Index Generation job is run. See "Publishing
catalogs" on page 101.

To upload your UOM cross-reference codes:

1 Select Items > Upload > UOM cross-ref.
2 Browse to and select the file containing UOM cross-reference codes.
3 Click Upload file.

Understanding item information
The View page in Storefront Catalog shows detailed information about a selected item. Item information
defined on your ERP application is copied to Storefront Catalog when item data is imported. Only the
product description and manufacturer can be edited in Storefront Catalog. See "Editing items" on page
41 for information about editing item data.

This information is displayed for an item:

Item Number
The item number that is displayed to the shopper.
Product Description
The product description. The product description is assigned using the Edit page in Storefront Catalog.
If a product description has not been assigned through Storefront Catalog, the item description from
the ERP is displayed.
Manufacturer
The item's manufacturer name. The manufacturer is assigned using the Edit page in Storefront Catalog.
If a manufacturer has not been assigned through Storefront Catalog, this field is left blank.
Manuf. Item Number
The number the manufacturer uses to identify the item.
Default UOM
The item's default unit of measure.
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UOM1
The item's first stocking unit of measure.
UOM2
The item's second stocking unit of measure. If this field is blank, a second stocking unit of measure
has not been assigned.
UOM3
The item's third stocking unit of measure. If this field is blank, a third stocking unit of measure has not
been assigned.
UOM Conv 1
The conversion factor that defines the relationship between the first and second units of measure.
UOM Conv 2
The conversion factor that defines the relationship between the first and third units of measure.
Price UOM
The item's pricing unit of measure.
Price UOM Conv
The conversion factor that defines the relationship between the pricing unit of measure and the first
stocking unit of measure.
List Price 1-5
The item's five list prices.
Product Rest. Code
The item's product restriction code. Product restriction codes prevent certain customers from ordering
an item. If this field is blank, a product restriction code has not been assigned.
Configurable
If you are using Infor Product Configurator, this field indicates if the product is configurable.
Description 1
The first line of the item description.
Description 2
The second line of the item description.
Company Number
The number of the company to which the item is assigned.
Item Class/Subclass
The item's class and subclass.
Item GL Code
The item's general ledger (GL) code. This code represents a product class and is not directly related
to the GL chart of accounts.
Item Price Class
The item's price class.
Suspended
This field indicates whether an item is suspended, which means it is not available to order. An item
can be suspended on the ERP through Item Master Maintenance. No means the item is not suspended.
Yes means it is suspended.
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Prevented From Web
This field indicates whether an item is available for online ordering. No means the item is available to
the Web site. Yes means the item is not available to the Web site.
Extended Item Comments
Additional information provided for an item, such as warranty information, picking/packing instructions,
or promotional information.
Vendor Number
The number of the primary vendor from whom the item is purchased.
Vendor Non-stock
Indicates whether the item is a vendor non-stock item.

Using normalization rules for item descriptions
Rules are conditions you can set to help make your item descriptions consistent. When you create
rules, you are defining search and replace text that Storefront Catalog will use to modify your item
descriptions.

For example, if you had item descriptions that use BL, BLK, and BLCK to mean black, use a rule to
modify those descriptions so that all variants are changed to BLACK. In this example, create three
rules, one for each black variant. Then apply them to items. Applying the three rules for the black
variants will make your descriptions consistent so they all use BLACK.

Review these topics for more information:

"Creating rules" on page 38

"Searching for rules" on page 39

"Applying rules to items" on page 39

"Editing records" on page 15

"Deleting records" on page 15

Creating rules
To create a rule:

1 Select Items > Rules.
2 Click the Create tab.
3 Specify this information:

Rule Name
Specify a name for the rule you are creating.
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Rule Description
Specify descriptive text to identify the rule you are creating.

From Text
Specify the text you want Storefront Catalog to change. For example, if you want to change BL to
BLACK, specify BL in this field. Be sure to include any spacing or other special characters when
entering your From Text. For example, to change OR to ORANGE, specify OR in this field with a
space after OR. If you do not include a space and also have ORIOLES in some of your item
descriptions, than ORIOLES will become ORANGEIOLES. Specifying a space does not require a
special character; pressing the space bar on the keyboard includes the space.

To Text
Specify the text that you want to be the result of the rule. For example, if you want to change BL
to BLACK, you would specify BLACK in this field.

4 Click Create.

Searching for rules
You can search for rules to view, edit, or delete.

To search for a rule:

1 Select Items > Rules.
2 Specify any of this search criteria:

Note: To show all rules, leave search criteria fields empty and then click Search.

Rule Name Contains
Specify all or part of a rule name.

Rule Description Contains
Specify all or part of a rule description.

3 Click Search. The Results page is displayed, listing rules that match your search criteria.

Applying rules to items
To apply rules to items, you must first create the rule. For information about creating rules, see "Creating
rules" on page 38.

To apply a rule to items:

1 Select Items > Search
2 Specify search criteria to find the items to which to apply a rule and click Search. The Results page

is displayed.

Note: To display all rules, leave search criteria fields empty and click Search.
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3 Select the check box of each item to which to apply the rule and select Apply Rule. Rule search
fields are displayed.

4 Specify search criteria and click Search. The rules that match your search criteria are displayed.
5 Select the rule to apply. The Rules page shows the items that have the text specified as the "from

text" for the rule, the current item description, and the description as it will be after the rule is applied.

Note: You cannot remove or "undo" a rule once it has been applied. Review the changes carefully
to be certain that the rule you created changes the item description in the way that you intended. If
you do not want to apply the rule at this time, click Back to leave the page.

6 Click Apply.

Searching for items
You can search for item records to view, edit, or delete.

To search for an item:

1 Select Items > Search.
2 Specify any of this search criteria:

Note: To show all items, leave search criteria fields empty and then click Search.

Item Number
Specify all or part of the item number or range of item numbers.

Product Description
Specify all or part of the item description.

Manuf. Item Number
Specify all or part of the manufacturer's item number.

Prevented from Web
Select whether you want the search results to include all items, only items available to the Web
(not prevented from Web), or only items unavailable to the Web (prevented from Web). An item's
availability to the Web is set through Item Master Maintenance on the ERP.

Suspended
Select whether you want the search results to include all items, only suspended items, or only
unsuspended items. Suspended items are those items that have been suspended from availability
to ordering through Item Master Maintenance on the ERP.

Item Class/Subclass
Choose an item class or an item class and subclass combination. Once you choose the item class,
the page refreshes and the drop-down list for the subclasses is displayed.

Item GL Code
To search for items by the item general ledger (GL) code, select an item GL code. This code
represents a product class and is not directly related to the GL chart of accounts.
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Company Number
Specify the company number.

Attachment
Select whether you want the search results to include all items, only items with a primary attachment
assigned to them, or only items with no primary attachment assigned.

Approved Date
To search for items based on the date on which the item was approved in Storefront Catalog, select
the date or range of dates to limit the search results. Click select date to use a calendar.

Attribute
Specify an attribute to search by and specify if the attribute is assigned or not.

Filter items based only on selected attribute
Select this option if you specified NOT Assigned in the Attribute field. You can select this field to
exclude items based on the selected attribute.

Sort By
Specify a value to be used to sort the search results and specify the order in which to list results.
Select Ascending to sort in ascending order. Clear Ascending to sort in descending order.

Stock Type
Specify whether you want the search results to include all items, only non-stock items, or only stock
items.

Product Restriction Code
To search for items by product restriction code, specify the code.

Item Price Class
To search for items by price class, select the price class.

Vendor Number
To search for items based on the vendor assigned to the item, type the vendor number.

3 Click Search. The Results page is displayed, listing items that match your search criteria.

Editing items
You can edit an item imported from the ERP to change the item's description or to provide the name
of the item's manufacturer.

To edit an item:

1 Select Items > Search.
2 Specify search criteria to find the item to edit and click Search. The Results page is displayed.

Note: To show all items, leave search criteria fields empty and click Search.

3 Select the item number of the item to edit. The View page is displayed.
4 Click the Edit tab and make changes as necessary. You can edit this item information:
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Product Description
Specify changes to the item's description. A text editor lets you change the format of the text, add
lists, links, or images. To increase or decrease the size of an image in one or more directions, select
the image and then drag a sizing handle away from or toward the center of the image.
Changing the product description in Storefront Catalog does not change the item description on
the ERP. The default value for this field is the description provided for the item on the ERP.

Manufacturer
Specify the item's manufacturer name.

Alternate Price Message
If an item cannot be priced or no price is available, you can specify a message that is displayed in
Storefront Commerce. For example, you can specify Call for price.
You must publish the items and generate an Item Index to see the new message in Storefront
Commerce.

Note: These items cannot be added to the cart.

5 Click Save.

Publishing items
Publishing items moves them from the staging area to the production area where they are available to
add to catalogs. You must publish items before you publish catalogs. After items are published, you
can publish catalogs that contain those items. Unlike publishing catalogs, publishing items does not
request an index build from the Progress EasyAsk Studio server. You must publish a catalog before
items will be added to the search index. See "Publishing catalogs" on page 101.

Note: You can set import options to automatically publish item changes during an import.

See "Setting Catalog import options" on page 17.

To publish items:

1 Select Import > Publish > Items.
2 Provide any of the following search criteria to limit the list of items to be published. To publish all

items, see "Publishing all items" on page 44.

Item Number
Specify all or part of the item number or a range of item numbers.

Description
Specify all or part of the item description.

Manufacturer Item
Specify all or part of the manufacturer item number.

Status
Select the statuses to be included in your search. The Storefront Catalog item statuses are
determined by comparing records in the staging area to records in the item repository. New items
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are those items that have not been added to the item repository. Modified items are those items
that have changed in the staging area, but the change has not been added to the item repository.
Select New and Modified to include both new and modified items. Select New to include only those
items that have not been added to the item repository. Select Modified to include only those items
with changes in the staging area that have not been approved to the item repository.

Rejected Only
Select this field to include items or item changes that have been rejected in the staging area.

Prevented from Web Only
Select this field to include items that have been set to prevent from the Web on the back end.

Suspended Only
Select this field to include items that have been suspended on the back end.

3 Click Search. Results are displayed on the View page.
4 Select the check boxes of items to accept or reject and click Accept Selected or Reject Selected.

To accept or reject all items, click Accept All or Reject All.
5 Click Submit.
6 To view the changes that have been made to the item, click the item number link on the Results

page. The View page is displayed. Use the pages described in this table to review item changes:

DescriptionPage

Shows the item master information. In the Staging Area Item
column, the values as they were imported from the ERP into the

View Item Changes

staging area are shown. In the Commerce Catalog Item column,
the values as they currently exist in the Storefront Catalog item
repository are shown. Fields with a change are highlighted.

Shows the item balance information changes. In the Staging Area
Item Warehouses section, the values as they were imported from

Item Wh Changes

the ERP into the staging area are shown. In the Commerce Cat-
alog Item Warehouses section, the values as they currently exist
in the item repository are shown. Fields with a change are high-
lighted.

Shows the item classification changes.Item Cls Changes

Lists the name and value for attribute assignment changes. At-
tribute changes are made only when you import items from an

Attributes

XML document. Attributes that were also created by the import
process (not just assigned) are marked with an asterisk.

Lists the name, description, text, or URL, and type for attachment
assignment changes. Attachments that were also created by the
upload process (not just assigned) are marked with an asterisk.

Attachments

7 On the Results page, make your selections and then click Submit. Approved items are moved to
the item repository. Rejected items are marked as rejected and are not moved to the item repository.
A progress bar shows the progress of the publication.
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8 When the publication is complete, three links are displayed on the processing window. Use the links
to perform one of these steps:

• To continue searching for items to approve, click Return to Item Approval Search.
• To publish catalogs, click Publish Catalog.

See "Publishing catalogs" on page 101.

• To work with scheduled jobs, click Go to Scheduled Jobs.
See "Scheduling jobs" on page 104.

Publishing all items
Optionally, you can publish all items.

To publish all items:

1 Select Import > Publish > All.
2 Select Publish all items and click Publish.
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7Working with attributes

Attributes identify specific item qualities or characteristics. You can use attributes to help classify items,
which makes searching for them easier. For example, if you sell light bulbs, you can create an attribute
called WATT to classify bulb wattage. For each attribute you create, you can then assign a number of
values that represent valid entries for the attribute. Using the watt example, you may create entries for
60, 75, 100, and 120.

Review these topics for more information:

• "Creating attributes" on page 45
• "Searching for attributes" on page 47
• "About assigning attributes" on page 47
• "Editing records" on page 15
• "Deleting attributes" on page 51

Creating attributes
You can add as many attributes to Storefront Catalog as you need to help classify your items and
promote successful searches for your customers.

To create an attribute:

1 Select Attributes > Create.
2 Specify this information:

Attribute Name
Specify a name of up to 30 characters for the attribute being created.

Attribute Description
Specify descriptive text of up to 200 characters to identify the attribute being created. Do not use
a vertical bar (|) in your attribute description.

Active
Indicate whether this attribute is active. Select this option to allow this attribute to be assigned to
an item in Storefront Catalog. Clear this option to prevent this attribute from being assigned to an
item in Storefront Catalog.
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Searchable
Indicate whether this attribute can be used in Storefront Commerce to search for items. Searchable
attributes are included in the Progress EasyAsk Studio search index. Select this option to allow this
attribute to be searchable. Clear this option to prevent this attribute from being searchable.

Visible
Indicate whether this attribute will be displayed in the search results of Storefront Commerce. Users
can use visible attributes to refine their search results. Select this option to allow this attribute to
be shown for further limiting search results. Clear this option to prevent this attribute from being
shown for further limiting search results.

3 Click Create. After the attribute record is created, you can add values.

Adding values to attributes
Attributes are assigned values to identify the different valid entries the attribute may possess. For
example, a color attribute could have values of red, blue, green, and yellow.

To add values to an attribute:

1 Select Attributes > Search. If you have just created a new attribute and the record is still open,
start at step 4.

2 Specify search criteria to find the attribute to which to assign values and then click Search. The
Results page is displayed.

Note: To show all attributes, leave the search criteria fields empty and click Search.

3 Select an attribute. The View page is displayed.
4 Click the Values tab.
5 Specify a value to add to the attribute and click Add.
6 Repeat step 5 as needed.

Deleting attribute values
To delete attribute values:

1 Select Attributes > Search. If you have just added values to an attribute and the record is still open,
go to step 5.

2 Specify search criteria to find the attribute from which to delete values and then click Search. The
Results page is displayed.

Note: To show all attributes, leave search criteria fields empty and click Search.

3 Select an attribute. The View page is displayed.
4 Click the Values tab.
5 Select the check box of each value to delete. Click Delete and OK.

46 | Infor Distribution Storefront Catalog User Guide

 

Working with attributes



Searching for attributes
You can search for attribute records to view, edit, or delete.

To search for an attribute:

1 Select Attributes > Search.
2 Specify any of the search criteria:

Note: To show all attributes, leave search criteria fields empty and click Search.

Attribute Name Contains
Specify all or part of the attribute's name.

Attribute Description Contains
Specify all or part of the attribute's description.

Attribute Active
Specify the attribute status to limit results by status. Select active and inactive to search all attributes
regardless of type. Select active only to search for only the active attributes. Select inactive only
to search for only the inactive attributes.

3 Click Search. The Results page is displayed, listing attributes that match your search criteria.

About assigning attributes
In Storefront Catalog, you can assign attributes to catalogs, categories, and items. When you assign
attributes to a catalog or category, you assign only the attribute (for example, Color), not the attribute
values (for example, Red). Attribute values can be assigned to only items.

You can manually add, change, or delete attribute value assignments for a selected item, or you can
assign a value to multiple items at once. When you delete an attribute, its attribute assignments also
are deleted.

Attribute assignment example
Assume you have two categories in your catalog: t-shirts and sunglasses. You create Color, Sleeve,
and Fabric attributes and assign them to the t-shirt category. You also create Lens Color and Brand
attributes and assign them to the sunglasses category.

When the user searches items in Storefront Commerce, if the user has selected the category t-shirts,
three attribute boxes are displayed (Color, Sleeve, Fabric). The user can search the category by the
attributes' values, such as Red, Short-Sleeve, and Cotton. If the user selects the category sunglasses,
two attribute boxes are displayed (Lens Color and Brand), and the user can search by those attributes'
values, such as Yellow and Ray Ban.

Review these topics for more information:

• "Assigning attributes to catalogs" on page 48
• "Assigning attributes to catalog categories" on page 48
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• "Assigning attributes to a single item" on page 49
• "Assigning attributes to an item search result set" on page 49
• "Assigning attribute values to items in a category" on page 50
• "Deleting attribute assignments" on page 50

Assigning attributes to catalogs
To assign attributes to a catalog:

1 Select Catalogs > Search.
2 Specify search criteria to find the catalog to which to assign attributes and click Search. The Results

page is displayed.

Note: To show all catalogs, leave search criteria fields empty and click Search.

3 Select a catalog. The View page is displayed.
4 Click the Categories tab.
5 Click the catalog name at the top level of the tree.
6 Select Category Attributes. Attribute search fields are displayed, and any attributes already assigned

to the catalog are listed.
7 Specify search criteria and click Search. Attributes that match your search criteria are displayed.
8 Select the check box of each attribute to assign to the catalog and click Assign and OK. The page

shows the attributes assigned to the catalog.

Assigning attributes to catalog categories
To assign attributes to a catalog category or subcategory:

1 Select Catalogs > Search.
2 Specify search criteria to find the catalog with categories to which to assign attributes and click

Search. The Results page is displayed.

Note: To show all catalogs, leave search criteria fields empty and click Search.

3 Select a catalog. The View page is displayed.
4 Click the Categories tab.
5 Expand categories and select a category or subcategory.
6 Select Category Attributes. Attribute search fields are displayed, and any attributes already assigned

to the category are listed.
7 Specify search criteria and click Search. Attributes that match your search criteria are displayed.
8 Select the check box of each attribute to assign to the selected category. Click Assign and OK.

The page shows the attributes assigned to the category.
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Assigning attributes to a single item
To assign attributes to items, you must create the attribute and its values. See "Creating attributes" on
page 45.

To assign an attribute to an individual item:

1 Select Items > Search.
2 Specify search criteria to find the item to which to assign an attribute and click Search. The Results

page is displayed.

Note: To show all items, leave search criteria fields empty and click Search.

3 Select an item number. The View page is displayed.
4 Select the Attributes tab. Any attributes already assigned to the item are displayed.
5 Select Assign Attributes. Attribute search fields are displayed.
6 Specify search criteria and click Search. Attributes that match your search criteria are displayed.
7 Select an attribute. Values for the selected attribute are displayed.
8 Select the name of the value. The attribute value is assigned to the item. Also, the assigned attribute

and its value are added to the list on the Attributes page.

Assigning attributes to an item search result set
To assign attributes to items, you must first create the attribute and its values. See "Creating attributes"
on page 45.

To assign an attribute to an item search results set:

1 Select Items > Search.
2 Specify search criteria to find the items to which to assign an attribute and click Search. The Results

page is displayed.

Note: To show all items, leave search criteria fields empty and click Search.

3 Select the check box of each item to assign and select Assign Attributes. Attribute search fields
are displayed.

4 Specify search criteria and click Search. Attributes that match your search criteria are displayed.
5 Select the name of the attribute to assign. Values for the selected attribute are displayed. This option

also is displayed:
Overwrite attribute values that are already assigned
Indicate if this attribute value assignment should override any previous value assignment. For
example, if you are assigning attribute and value Color-Red to an item that was previously assigned
attribute and value Color-Blue, you can select this check box to overwrite existing value assignments.
Clear the check box to keep existing value assignments.

6 Select the name of the value to assign. The attribute is assigned to all of the items in the search
result set and you are returned to the Results page.
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Note: If an attribute value has already been assigned to the item at the item level (not at the
catalog/category level), an asterisk is displayed to the left of the name and it cannot be selected.

Assigning attribute values to items in a category
To assign attribute values to items in a category, you must first create the attribute and its values and
assign the attribute to the catalog or category. See "Assigning attributes to catalogs" on page 48 and
"Assigning attributes to catalog categories" on page 48.

To assign attribute values to items in a catalog category or subcategory:

1 Select Catalogs > Search.
2 Specify search criteria to find the catalog with category items to which to assign attribute values.

Click Search. The Results page is displayed.

Note: To show all catalogs, leave search criteria fields empty and click Search.

3 Select a catalog. The View page is displayed.
4 Click the Categories tab.
5 Select the category or subcategory that contains the items. The list of items is displayed.
6 Select the check box of each item to which to assign the attribute values. In the Assign to Selected

Items field, select Attribute Values. Attributes already assigned to the category are displayed.
7 Click the name of the attribute to which to assign values. Values for the selected attribute are

displayed. This option also is displayed:
Overwrite attribute values that are already assigned
Indicate if this attribute value assignment should override any previous value assignment. For
example, if you are assigning attribute and value Color-Red to an item that was previously assigned
attribute and value Color-Blue, you can select this check box to overwrite existing value assignments.
Clear the check box to keep existing value assignments.

8 Select the value to assign. The attribute value is assigned to selected items.

Note: If an attribute value has already been assigned to the item at the item level (not at the
catalog/category level), an asterisk is displayed to the left of the name and it cannot be selected.

Deleting attribute assignments
To delete an attribute assignment:

1 Select Items > Search.
2 Specify search criteria to find the item and click Search. The Results page is displayed.

Note: To show all items, leave search criteria fields empty and click Search.

3 Select an item. The View page is displayed.
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4 Click the Attributes tab. The Attributes page is displayed with attributes assigned to the item.
5 Select the each attribute to remove and click Delete and OK.

Deleting attributes
When you delete an attribute, it is removed from Storefront Catalog and is no longer available for
assignment to items. It is also removed from the items to which it has already been assigned. See
"Deleting records" on page 15.

You can prevent an attribute from being assigned and still preserve that attribute in the Storefront
Catalog. Change the status of the attribute by clearing the Active check box on the Edit page.
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8Working with attachments

Attachments are text, URL, image, and other MIME media-type files that provide additional product
information to your customers in Storefront Commerce. You can upload or create attachments in
Storefront Catalog and then associate them with your items, catalogs, or categories. For example, you
can attach detailed product specifications or product reviews to help customers make buying decisions,
and you can assign various image files to display pictures of your products.

For a complete listing of the MIME media-type files supported by Infor Distribution Storefront, go to
http://www.iana.org/assignments/media-types/index.html.

Setting up and using attachments
This is an overview of tasks for setting up and using attachments in Storefront Catalog:

1 Save attachment files to a local drive.
2 Optionally, you can change attachment file names for automatic item assignment. The file names

should correspond with specific items from the ERP, so when the attachments are uploaded, they
can be automatically assigned to those items in Storefront Catalog. See "Naming attachments for
automatic item assignment" on page 54.

3 Set image attachment options. Before you upload and assign image attachments, you must specify
sizes for displaying those images in Storefront Commerce. See "Setting image attachment options"
on page 18.

4 Upload attachment files that have been saved to a local drive. See "Uploading a single attachment"
on page 54 and "Uploading an attachment archive" on page 55.

5 Create text and URL attachments. See "Creating text or URL attachments" on page 55.
6 Assign attachments to items, if they were not assigned automatically during the upload process.

See "About assigning attachments" on page 58.
7 Create item detail tabs and assign information types to them. After you know the type of attachments

you have available, you can create tabs for the Item Detail page in Storefront Commerce. This page
shows attachment information assigned to your items, with tabs that organize, group, and show the
information. See "Working with item detail tabs" on page 91.

Review these topics for more information:

• "Searching for attachments" on page 56
• "Previewing attachments" on page 57
• "Editing attachments" on page 62
• "Deleting attachments" on page 64
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Naming attachments for automatic item assignment
When you select Attachments > Upload > Create, the Make Item Assignments upload option allows
attachments to be automatically assigned to items from the ERP system. This option is especially
helpful if you have hundreds or even thousands of attachments to include with items in Storefront
Commerce.

For this option to work, your attachment file names, excluding the extension, must match the item
number of the corresponding item. For example, if your product number is A100, the product can have
an image file named A100.jpg and a text file named A100.txt. When you upload these files into
Storefront Catalog, they are automatically mapped to corresponding items in the ERP system.

For more information about enabling auto assignment of attachments to corresponding items, see
"Uploading a single attachment" on page 54 and "Uploading an attachment archive" on page 55.

Uploading a single attachment
You can upload any attachment file that you have saved to a local drive. If a file for upload has the
same name as a file that was previously uploaded, the existing file is overwritten with the new file.

To upload a single attachment:

1 Select Attachments > Upload.
2 Click Browse.
3 Select the attachment file to upload and click Open.
4 Optionally, you can specify a list of comma-separated keywords or phrases that describe the

attachment. Keywords are used for searching Storefront Catalog for a particular attachment. If you
specify one or more keywords, the Tag Status is set to Tagged.

5 Optionally, you can select Load File Data as Text.
If the attachment file has 4000 characters or less and you want to copy its content to the Storefront
database (instead of attaching the file attachment as a link), select this option. To show the attachment
as a link and to maintain the file outside of Storefront Catalog, clear this option.

6 Optionally, you can select Make Item Assignment.
To use this feature, the attachment file name must match the number of the item to which the
attachment should be assigned. See "Naming attachments for automatic item assignment" on page
54. Select this check box to assign the attachment to the item with which it is associated. Leave the
check box cleared to prevent the attachment from being assigned to the item automatically. You
can also assign attachments to items manually. See "About assigning attachments" on page 58.

7 Click Upload. The attachment is uploaded and the Usage Status is set to Active, which means it
is available to be assigned to items in Storefront Catalog and it can be seen in Storefront Commerce.
A message is displayed to indicate that the process was successful.
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Uploading an attachment archive
You can upload groups of attachment files that are archived in .zip or .tar files, and the attachment files
are saved individually in Storefront Catalog. You must use a .zip utility such as Winzip or WinRar to
create the zip files for upload. If you use a different type of archiver, they may not load and upzip
correctly. If files in the archive have the same names as files that were previously uploaded, the new
files will overwrite existing files.

To upload an attachment archive:

1 Select Attachments > Upload.
2 Click Browse.
3 Select the archive file to upload and then click Open.
4 Optionally, you can specify a list of comma-separated keywords or phrases that describe the

attachments. These keywords are added to each attachment in the archive file. Keywords are used
for searching Storefront Catalog for a particular asset. If you specify one or more keywords, the tag
statuses are automatically set to Tagged.

5 Optionally, you can select Load File Data as Text.
If the attachment archive file contains an attachment file that is a .txt, .htm or .html file with 4000
characters or less and you want to copy the contents of the file to the Storefront database (instead
of attaching the file attachment as a link), select this option. To show the attachment as a link and
to maintain the file outside of Storefront Catalog, clear this option.

6 Optionally, you can select Make Item Assignment.
To use this feature, the attachment file names must match the numbers of the items to which the
attachments should be assigned. See "Naming attachments for automatic item assignment" on page
54. Select this check box to automatically assign the attachments to the items with which they are
associated. Leave the check box cleared to prevent the attachments from being assigned to the
items automatically. You can also assign attachments to items manually. See "About assigning
attachments" on page 58.

7 Click Upload. The attachments in the archive file are uploaded and their usage statuses are set to
Active, which means they are available to be assigned to items in Storefront Catalog and they can
be seen in Storefront Commerce. A message is displayed to indicate that the process was successful.

Creating text or URL attachments
To create a text or URL attachment:

1 Select Attachments > Manage > Create.
2 Specify this information:

Name
Specify a name for the attachment.

Type
Specify the type of attachment:
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• To create a text attachment, leave Text selected. A Text field is included on the page.
• To create a URL attachment, specify URL. A URL Address field is displayed on the page.

Tag Status
If you specify one or more keywords, the attachment tag status is automatically set to Tagged. If
you do not specify one or more keywords, the tag status remains as Untagged.

Creation Date
This is the date the attachment was created.

Usage Status
To make the attachment available to be assigned to items in Storefront Catalog and to be seen in
Storefront Commerce, leave Active selected. To create the attachment but make it unavailable for
use, specify Inactive.

Description
Optionally, you can specify a description for the attachment.

Keywords
Optionally, you can specify a list of comma-separated keywords or phrases that describe the
attachment. Keywords are used for searching Storefront Catalog for a particular asset.

Make Item Assignment
Select this field to automatically assign the attachment to the item with which it is associated. Clear
this field to prevent the attachment from being assigned to the item automatically.
You can also assign attachments to items manually. See "About assigning attachments" on page
58.

Text
This field is displayed for text attachments. Specify the text to display in Storefront Commerce for
the attachment. In Storefront Commerce, this text is displayed on the Item Details tab.

URL Address
This field is displayed for URL attachments. Specify the URL address to display in Storefront
Commerce for the attachment. The correct format for the URL address is http://www.domain.com.

3 Click Submit. The attachment is created. A list of all attachments is displayed on the Results page.

Searching for attachments
You can search for attachment records to view, edit, or delete:

To search for attachments:

1 Select Attachments > Manage > Search.
2 To show all attachments, leave search criteria fields empty and click Search. Otherwise, specify

any search criteria:

Name
Specify all or part of the attachment file name.
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Type
Specify the MIME type of attachment to find. This table provides examples of the text to specify for
various attachment types:

You can specifyTo find

TEXT, HTML, RTFText

EXCELSpreadsheet

VISIODrawing

PNG, JPEG, TIF, GIF, POSTSCRIPTImage

MSWORD, PDFDocument

URLURL

Keywords
Specify keywords that were assigned when attachments were created or uploaded.

Tag Status
Specify a status of Tagged or Untagged. Tagged finds attachments with assigned keywords, and
Untagged find attachments with no assigned keywords.

Usage Status
Specify a status of Active or Inactive. Active finds attachments that are available for use in Storefront
Catalog and viewable in Storefront Commerce. Inactive finds attachments that are not available
for use.

3 Click Search. The Results page is displayed, listing attachments that match your search criteria.

Previewing attachments
To preview an attachment:

1 Select Attachments > Manage > Search.
2 Specify search criteria to find the attachment to preview and click Search. The Results page is

displayed.

Note: To show all attachments, leave search criteria fields empty and click Search.

3 Select the attachment to preview. The attachment is displayed on the Preview tab. All fields on this
page are read-only.

4 To optionally open the attachment, click Open.

• If the attachment is an image file, it is opened in a new browser window. The image is in the
original size and resolution that was uploaded into Storefront Catalog.

• If the attachment is a document file, such as a .doc, .xls, .txt. or .pdf file, it is opened in a new
browser window for viewing.
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• If the attachment is a URL, the corresponding website is opened.

About assigning attachments
In Storefront Catalog, you can assign attachments to a catalog, to catalog categories and subcategories,
and to items. You can make the assignment by first finding the catalog, category, or item to which to
assign the attachment, or by finding the attachment to assign and then finding the catalog, category,
or item to which to assign it.

When you assign more than one image attachment, you must indicate which one is the primary image
to be displayed by default as the digital asset thumbnail image in Storefront Commerce. Also, when
you assign more than one text description attachment, you must indicate which one is the primary
description to be displayed by default in Storefront Commerce. The secondary images that are assigned
to an item are gallery images. These images are displayed on the Item Detail tab in Storefront
Commerce.

When an attachment is deleted, its assignments are also deleted, and the affected catalogs or items
must be published to complete the change. If a deleted attachment was a primary image or description,
then the next image or description file in the list of assigned attachments, if one exists, becomes primary.

You must upload attachments before you can assign them. See "Uploading a single attachment" on
page 54 and "Uploading an attachment archive" on page 55.

Review these topics for more information:

• "Assigning attachments to catalogs by catalog selection" on page 58
• "Assigning attachments to catalogs by attachment selection" on page 59
• "Assigning attachments to categories by catalog selection" on page 59
• "Assigning attachments to categories by attachment selection" on page 60
• "Assigning attachments to items by item selection" on page 61
• "Assigning attachments to items by attachment selection" on page 61
• "Deleting attachment assignments" on page 62

Assigning attachments to catalogs by catalog selection
To assign attachments to a catalog, you must find the catalog and then find the attachments.

1 Select Catalogs > Search.
2 Specify search criteria to find the catalog to which to assign attachments. To display all catalogs,

leave the search criteria fields blank. Click Search. The Results page is displayed.
3 Select a catalog. The View page is displayed.
4 Click the Categories tab.
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5 Right-click the catalog name and select Assign. Attachment search fields are displayed, and any
attachments already assigned to the catalog are listed.

6 Specify search criteria and click Search. Attachments that match your search criteria are displayed.
7 Select each attachment to assign to the catalog. Click Assign and OK. The list of attachments

assigned to the catalog is displayed.
8 If you have assigned more than one image attachment and more than one description attachment,

you must specify which files to show in Storefront Commerce by default. If you do not select a
primary image and description, then the first image file and the first text file in the list of attachments
are used as the primary image. To specify the primary image and description:

• In the list of attachments, select the check box of the image file to show by default and click
Primary Image.

• In the list of attachments, select the check box next to the text file to show by default and click
Primary Description.

Assigning attachments to catalogs by attachment selection
To assign attachments to a catalog, you must find the attachments and then finding the catalogs.

1 Select Attachments > Manage > Search.
2 Specify search criteria to find the attachments to assign to catalogs. To display all attachments,

leave the search criteria fields blank. Click Search. The Results page is displayed.
3 Select the check box next to one or more attachments to assign and click Catalog/Category

Assignment. Select the check box in the Results header to select all attachments on the current
page or click Select All. Catalog search fields are displayed.

4 Specify search criteria and click Search. Catalogs that match your search criteria are displayed.
5 Select the check box of each catalog to which to assign the selected attachments and then click

Assign. The list of attachments assigned to the catalog is displayed.
6 If you have assigned more than one image attachment and more than one description attachment,

you must specify which files to show in Storefront Commerce by default. If you do not select a
primary image and description, then the first image file and the first text file in the list of attachments
are used as the primary image. To specify the primary image and description:

• In the list of attachments, select the check box of the image file to show by default and click
Primary Image.

• In the list of attachments, select the check box next to the text file to show by default and click
Primary Description.

Assigning attachments to categories by catalog selection
This topic explains how to assign attachments to catalog categories by first finding the categories and
then finding the attachments.
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To assign attachments to categories by catalog selection:

1 Select Catalogs > Search.
2 Specify search criteria to find the catalog with categories to which to assign attachments. To display

all catalogs, leave the search criteria fields blank. Click Search. The Results page is displayed.
3 Click the name of the catalog to work with. The View page is displayed.
4 Click the Categories tab.
5 In the tree on the left, expand categories, right-click the category or subcategory to work with, and

then select Assign. Attachment search fields are displayed, and any attachments already assigned
to the catalog category are listed in the lower portion of the page.

6 Specify search criteria and then click Search. Attachments that match your search criteria are
displayed.

7 Select the check box of each attachment to assign to the category and then click Assign and OK.
8 If you have assigned more than one image attachment and more than one description attachment,

you must specify which files to display in Storefront Commerce by default. If you do not select a
primary image and description, then the first image file and the first text file in the list of attachments
are used as the primary image. To specify the primary image and description:

• In the list of attachments, select the check box of the image file to display by default and then
click Primary Image.

• In the list of attachments, select the check box next to the text file to display by default and then
click Primary Description.

Assigning attachments to categories by attachment selection
To assign attachments to catalog categories , you must first find the attachments and then find the
categories.

1 Select Attachments > Manage > Search.
2 Specify search criteria to find the attachments to assign to catalog categories. To show all

attachments, leave the search criteria fields blank. Click Search. The Results page is displayed.
3 Select one or more attachments to assign and click Catalog/Category Assignment. You can click

the check box in the Results header to select all attachments on the current page or click the Select
All. Catalog search fields are displayed.

4 Specify search criteria and click Search. Catalogs that match your search criteria are displayed.
5 Select each catalog and click Assign.
6 If you have assigned more than one image attachment and more than one description attachment,

you must specify which files to display in Storefront Commerce by default. If you do not select a
primary image and description, then the first image file and the first text file in the list of attachments
are used as the primary image. To specify the primary image and description:
In the list of attachments, select the check box of the image file to display by default and then click
Primary Image.

• In the list of attachments, select the check box of the image file to display by default and then
click Primary Image.
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• In the list of attachments, select the check box next to the text file to display by default and then
click Primary Description.

Assigning attachments to items by item selection
To assign attachments to an item, you must first find the item and then assign the attachments.

1 Select Items > Search.
2 Specify search criteria to find the item. To show all items, leave the search criteria fields blank. Click

Search. The Results page is displayed.
3 Select the item. The View page is displayed.
4 Click the Attachments tab.
5 Select Search Attachments. Attachment search fields are displayed.
6 Specify search criteria and click Search. Attachments that match your search criteria are displayed.
7 Select each attachment to assign and click Assign. The assigned attachments are added to the list

on the Attachments page.
8 If you have assigned more than one image attachment and more than one description attachment,

you must specify which files to display in Storefront Commerce by default. If you do not select a
primary image and description, then the first image file and the first text file in the list of attachments
are used as the primary image. To specify the primary image and description:

• In the list of attachments, select the check box of the image file to display by default and then
click Primary Image.

• In the list of attachments, select the check box next to the text file to display by default and then
click Primary Description.

Assigning attachments to items by attachment selection
To assign attachments to items, you must first find the attachments to assign and then find the items.

1 Select Attachments > Manage > Search.
2 Specify search criteria to find the attachments. To display all attachments, leave search criteria

fields blank. Click Search. The Results page is displayed.
3 Select one or more attachments to assign and click Item Assignment. You can click the check box

in the Results header to select all attachments on the current page or click Select All.
4 Specify search criteria and click Search. Items that match your search criteria are displayed.
5 Select each item to which to assign the selected attachments and click Assign .
6 If you have assigned more than one image attachment and more than one description attachment,

you must specify which files to display in Storefront Commerce by default. If you do not select a
primary image and description, then the first image file and the first text file in the list of attachments
are used as the primary image. To specify the primary image and description:
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• In the list of attachments, select the check box of the image file to display by default and then
click Primary Image.

• In the list of attachments, select the check box next to the text file to display by default and then
click Primary Description.

Deleting attachment assignments
To delete an attachment assignment:

1 Select Items > Search.
2 Specify search criteria to find the item from which to delete an attachment assignment. To show all

items, leave the search criteria fields blank. Click Search. The Results page is displayed.
3 Select an item. The View page is displayed.
4 Click the Attachments tab. The Attachments page is displayed with attachments assigned to the

item.
5 Select each attachment to remove and click Delete .
6 Publish the item to complete the change.

Editing attachments
To edit an attachment:

1 Select > Attachments > Manage > Search.
2 Specify search criteria to find the attachment to edit and click Search. The Results page is displayed.

Note: To show all attachments, leave search criteria fields empty and click Search.

3 Select the attachment. The Preview tab is displayed.
4 Click the Edit tab and make changes as necessary. You can edit the name, description, keywords,

or usage status. Keywords are used to define additional search criteria when searching for this item.
5 Click Save. After you save your changes, the tag status is Tagged. If you do not specify a keyword,

the tag status is Untagged.

Viewing items assigned to attachments
You can view all of the items assigned to an attachment. For example, the import process can have
attachments automatically assigned to items from the ERP system. See "Working with attachments"
on page 53.
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To view items assigned to the attachment:

1 Select Attachments > Manage > Search.
2 Specify search criteria to find the attachment to preview and click Search. The Results page is

displayed.

Note: To show all attachments, leave search criteria fields empty and click Search.

3 Select the attachment to view. The Preview tab is displayed.
4 Click the Items tab to view items that have been assigned this attachment.
5 To return to the search results, click the Results tab.

Viewing catalogs and categories assigned to
attachments
You can view all of the catalogs and categories assigned to the attachment. See "Working with
attachments" on page 53.

To view catalogs and categories assigned to the attachment:

1 Select Attachments > Manage > Search.
2 Specify search criteria to find the attachment to preview and click Search. The Results page is

displayed.

Note: To show all attachments, leave search criteria fields empty and click Search.

3 Select the attachment to view. The Preview tab is displayed.
4 Click the Catalogs/Categories tab to view catalogs and categories that have been assigned this

attachment.
5 To return to the search results, click the Results tab.

Changing attachments usage status from active to
inactive
When attachments are uploaded in Storefront Catalog, their usage status is automatically set to Active,
so they are available to be assigned to items. You can change the status to Inactive as necessary. If
an attachment has already been assigned to an item and then its status is changed to Inactive, the
item assignment remains, but the attachment is no longer displayed in Storefront Commerce. If you
change the status of the attachment to Inactive for an attachment that is a primary image and the item
has multiple images assigned, the first secondary image becomes the primary image. If no other images
are assigned, then No Image Available is displayed in Storefront Commerce.
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1 Select Attachment > Manage > Search.
2 Specify any search criteria, including the usage status, Active, and click Search.
3 Select the attachment to update.
4 Change the usage status to Inactive.
5 Click Save.
6 To include this change in Storefront Commerce, republish the catalog.

Deleting attachments
When you delete an attachment, it is removed from Storefront Catalog and is no longer available to
assign to items. It is also removed from any catalogs or items to which it has already been assigned.
The catalogs or items must be published for the attachment change to be complete.

When you delete an attachment that has a primary image or description, the next image or text
attachment for that category becomes the primary one.

See "Deleting records" on page 15.
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9Working with page layouts

With page layouts, you can create the pages that display in Storefront Commerce and you can control
every field and link available on those pages.

The default page layouts for Storefront Catalog are:

• Additional Charges
• Alternate Warehouses
• Alternates
• Assortments
• Browse Results
• Checkout
• Complements
• Invoice Detail
• Item Detail
• Open Invoices
• Order Detail
• Order History
• Order Listing
• Paid Invoices
• Sales Statistics
• Search Results
• Shopping Cart
• Shopping List
• Specials
• Wish List

You can use default page layouts or customize the type of data that is included on a page, such as the
label for each column in search or browse results, the order of the information, and what price and
availability information is shown. You can modify classes in the Storefront cascading style sheet to
define the colors and fonts for your Storefront user interface.

Not only can you fully customize your pages, you can create multiple versions of each type of page to
meet the needs of different user audiences that you have. For example, if you have B2C Anonymous,
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B2C Registered, and B2B Storefront accounts, you have three different audiences that need, or are
authorized to view, different information. To handle multiple versions and audiences using the user
interface, complete these tasks:

1 Create page layouts for each audience.
2 Create a page layout group for each audience.
3 Assign the appropriate page layout group to Storefront accounts. Refer to the  Infor Distribution

Storefront Administration User Guide.

Note: If you choose to modify a default page layout to customize it for your company, we recommend
that you create a copy of the default format and modify the copy.

Review these topics for more information:

• "Planning page layouts" on page 66
• "Page layout fields" on page 66
• "Creating page layouts" on page 85
• "Searching for page layouts" on page 87
• "Copying page layouts" on page 87
• "Viewing a sample of the page layout" on page 88

Planning page layouts
Before you begin creating page layouts, we recommend that you carefully plan the fields you want to
include on your pages, what each field will be named, and the order in which fields will be displayed
on the page. You can review the default layout samples and use them as a guide for creating your own
layouts.

We also recommend that the user who designs and modifies your page layouts has at least a basic
knowledge of HTML and understands how to create and use tables to design pages.

Refer to "Page layout fields" on page 66 for information that will help you plan which fields to include
in your layouts. Also see "Viewing a sample of the page layout" on page 88 for information about
viewing a sample of your layout.

Page layout fields
This topic provides descriptions of the fields available for Storefront Catalog page layouts.
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Search Results, Browse Results, and Item Detail page types

Item
Detail
page

Browse
Results
page

Search
Results
pageDataField

XXShows a link to add the item to the shopping
cart.

Add to Cart Link

XInserts a blank line in the page layout.Blank Line

XXXShows the item availability as obtained by
the Commerce Gateway Price and Availabil-

Calculated Avail-
ability

ity transaction. This availability is retrieved
from the back-end database.

XXXSimilar to Calculated Availability, but this field
shows item availability for only the default
warehouse, not an accumulated quantity.

Calculated Avail-
ability (Default
Whse)

XXXShows an indicator (In stock/Out of Stock)
of the item availability based on the availabil-

Calculated Avail-
ability Flag

ity obtained by the Commerce Gateway Price
and Availability transaction. This availability
is retrieved from the back-end database.

XXXSimilar to Calculated Availability Flag, but
this field shows an indicator (In stock/Out of

Calculated Avail-
ability Flag (De-
fault Whse) Stock) of item availability for only the default

warehouse, not an accumulated quantity.

XXXShows the item's price for the default unit of
measure. This price is retrieved from the

Calculated Price

back-end database by the Commerce Gate-
way Price and Availability transaction.

XXXShows the amount of savings for the item.
The saving is calculated as
Calculated Price - Web Price = Savings

Calculated Sav-
ings

XXXShows the customer's item number.Customer Item
Number

XXXShows the customer's item number as a link
to the Item Detail page.

Customer Item
Number Link to
Item Detail

XShows the price of the item multiplied by the
quantity entered to order. For example, if the

Extended Item
Price

user entered 5 to order five bottles priced at
$3.00/each, the extended item price is
$15.00.
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Item
Detail
page

Browse
Results
page

Search
Results
pageDataField

XXXShows the GTIN code that is imported from
the ERP.

Global Tracking
Identification num-
ber (GTIN)

XShows the class and subclass of the item.Item Class/Sub-
class

XXXShows the item's description. If you have
added product descriptions to your back-end

Item Description

items in Storefront Catalog, the item's product
description is displayed.

XItem Inventory
Status

XXXShows the name of the item's manufacturer.Item Manufacturer

XXXShows the number of the item.Item Number

XXShows the number of the item as a link to
the Item Detail page.

Item Number Link
to Item Detail

XXShows the thumbnail image attachment
which links to the Item Detail page.

Item Thumbnail

XXXShows the item list prices that are set up in
the ERP. The ERP determines which price
is displayed in Storefront Commerce.

List Price

XXXShows the availability of the item in all ware-
houses. This availability value is from the
CMS database, not the back end.

Local Avail (All
Whs)

XXXShows an indicator (In stock/Out of Stock)
for the availability of the item in all warehous-

Local Avail (All
Whs) Flag

es. This availability value is from the CMS
database, not the back end.

XXXShows the availability of the item in the
warehouse assigned to the user who is

Local Avail (Def.
Whs)

logged in. This availability value is from the
CMS database, not the back end.

XXXShows an indicator (In stock/Out of Stock)
for the availability of the item in the ware-

Local Avail (Def.
Whs) Flag

house assigned to the user who is logged in.
This availability value is from the CMS
database, not the back end.
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Item
Detail
page

Browse
Results
page

Search
Results
pageDataField

XXXShows the manufacturer's item number.Manufacturer's
Item

XXXShows the date of the next open requisition
for this item.

Next PO Date

XXXShows the quantity of this item on the next
open requisition.

Next PO Quantity

XShows the quantity that meets the next
quantity break requirements.

Next Quantity
Break

XShows the price of the item at the next
quantity break.

Next Quantity
Break Price

XShows whether the quantity break is a per-
cent or an amount.

Next Quantity
Break Type

XXXShows the item's default unit of measure.Order UOM

XXXShows the item's price for the pricing unit of
measure.

Price UOM Price

XXXShows the unit of measure at which the item
is priced.

Pricing UOM

XXShows an input field for entering order
quantity.

Quantity Input Box

XXShows a drop-down list for selecting the or-
dering unit of measure.
For the Item Detail page and Results pages,
if there is only a single unit of measure, this

Unit of Measure
Drop-Down

field displays the single UOM for the B2C in-
terface.

XXShows user-defined fields based on your
ERP. After you specify your user-defined

User-defined

fields, you can import them to Storefront
Commerce by selecting Import > Backend
> Items.

XXShows the item's list price. For Web users,
the list price to use is based on the customer

Web Price

number of the user who is logged in. For
back-end users, the list price on the Order
Header Screen is used.

XXShows the UPC code that is imported from
the ERP.

UPC
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Shopping List, Shopping Cart, and Wish List page types

Wish List
page

Shopping
Cart page

Shopping
List pageDataField

XXXShows a link to add the item to the
shopping cart.

Add to Cart Link

XXXShows the item availability as obtained
by the Commerce Gateway Price and

Calculated Availability

Availability transaction. This availability
is retrieved from the back-end database.

XXXSimilar to Calculated Availability, but this
field shows item availability for only the

Calculated Availability
(Default Whse)

default warehouse, not an accumulated
quantity.

XXXShows an indicator (In stock/Out of
Stock) of the item availability based on

Calculated Availability
Flag

the availability obtained by the Com-
merce Gateway Price and Availability
transaction. This availability is retrieved
from the back-end database.

XXXSimilar to Calculated Availability Flag,
but this field shows an indicator (In

Calculated Availability
Flag (Default Whse)

stock/Out of Stock) of item availability for
only the default warehouse, not an accu-
mulated quantity.

XXXShows the item's price for the default unit
of measure. This price is retrieved from

Calculated Price

the back-end database by the Commerce
Gateway Price and Availability transac-
tion.

XXXShows the amount of savings for the
item. The saving is calculated as
Calculated Price - Web Price = Savings

Calculated Savings

XShows on the cart where users can
specify a comment for an item. During

Comment Text

checkout, the comment that the user
enters is displayed.

XShows on the cart where users can
specify where to print the comment, for

Comment (Print on)
Type

example, on all documents, on the pick
ticket, or on the invoice. During checkout,
the selection is displayed.
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Wish List
page

Shopping
Cart page

Shopping
List pageDataField

XXXShows the customer's item number.Customer Item Num-
ber

XXXShows the customer's item number as
a link to the Item Detail page.

Customer Item Num-
ber Link to Item Detail

XShows the price of the item multiplied by
the quantity entered to order. For exam-

Extended Item Price

ple, if the user entered 5 to order five
bottles priced at $3.00/each, the extend-
ed item price is $15.00.

XXXShows the GTIN number from the ERP.Global Tracking Identi-
fication Number (GTIN)

XXXShows the item's description. If you have
added product descriptions to your back-

Item Description

end items in Storefront Catalog, the
item's product description is displayed.

XXXShows the name of the item's manufac-
turer.

Item Manufacturer

XXXShows the number of the item.Item Number

XXXShows the number of the item as a link
to the Item Detail page.

Item Number Link to
Item Detail

XXXShows the thumbnail image attachment
which links to the Item Detail page.

Item Thumbnail

XXXShows the item list prices that are set up
in the ERP. The ERP determines which

List Price

price is displayed in Storefront Com-
merce.

XXXShows the availability of the item in all
warehouses. This availability value is

Local Avail (All Whs)

from the CMS database, not the back
end.

XXXShows an indicator (In stock/Out of
Stock) for the availability of the item in

Local Avail (All Whs)
Flag

all warehouses. This availability value is
from the CMS database, not the back
end.

XXXShows the availability of the item in the
warehouse assigned to the user who is

Local Avail (Def. Whs)

logged in. This availability value is from
the CMS database, not the back end.
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Wish List
page

Shopping
Cart page

Shopping
List pageDataField

XXXShows an indicator (In stock/Out of
Stock) for the availability of the item in

Local Avail (Def. Whs)
Flag

the warehouse assigned to the user who
is logged in. This availability value is from
the CMS database, not the back end.

XXXShows the manufacturer's item number.Manufacturer's Item

XXXShows the date of the next open requisi-
tion for this item.

Next PO Date

XXXShows the item's default unit of measure.Order UOM

XXXShows the item's price for the pricing unit
of measure.

Price UOM Price

XXXShows the unit of measure at which the
item is priced.

Pricing UOM

XXXShows an input field for entering order
quantity.

Quantity Input Box

XXXShows a check box to indicate that the
item should be removed from the shop-
ping cart.

Remove Check Box

XShows Remove Item at the line item
level to remove one item from the cart.

Remove Item Link

This new page layout field is only avail-
able for the Cart page layouts.

XXXShows a drop-down list for selecting the
ordering unit of measure.
For the Item Detail page and Results
pages, if there is only a single unit of

Unit of Measure Drop-
Down

measure, this field displays the single
UOM for the B2C interface.

XXShows user-defined fields based on your
ERP. After you specify your user-defined

User-defined

fields, you can import them to Storefront
Commerce by selecting Import > Back-
end > Items.

XShows the warehouse abbreviation.Warehouse Abbrevia-
tion

XXXShows the item's list price. For Web
users, the list price to use is based on

Web Price

the customer number of the user who is
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Wish List
page

Shopping
Cart page

Shopping
List pageDataField

logged in. For back-end users, the list
price on the Order Header Screen is
used.

XXXShows the quantity of this item on the
next open requisition.

Next PO Quantity

XXShows the UPC code that is imported
from the ERP.

UPC

Specials and Checkout page types

Checkout
page

Specials
pageDataField

XShows a link to add the item to the shopping cart.Add to Cart Link

XXShows the item availability as obtained by the
Commerce Gateway Price and Availability trans-

Calculated Availability

action. This availability is retrieved from the back-
end database.

XXSimilar to Calculated Availability, but this field
shows item availability for only the default ware-
house, not an accumulated quantity.

Calculated Availability
(Default Whse)

XXShows an indicator (In stock/Out of Stock) of the
item availability based on the availability obtained

Calculated Availability
Flag

by the Commerce Gateway Price and Availability
transaction. This availability is retrieved from the
back-end database.

XXSimilar to Calculated Availability Flag, but this
field shows an indicator (In stock/Out of Stock) of

Calculated Availability
Flag (Default Whse)

item availability for only the default warehouse,
not an accumulated quantity.

XXShows the item's price for the default unit of
measure. This price is retrieved from the back-

Calculated Price

end database by the Commerce Gateway Price
and Availability transaction.

XXShows the amount of savings for the item. The
saving is calculated as
Calculated Price - Web Price = Savings

Calculated Savings

XShows on the cart where users can specify a
comment for an item. During checkout, the com-
ment that the user enters is displayed.

Comment Text
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Checkout
page

Specials
pageDataField

XShows on the cart where users can specify where
to print the comment, for example, on all docu-

Comment (Print on)
Type

ments, on the pick ticket, or on the invoice. During
checkout, the selection is displayed.

XXShows the customer's item number.Customer Item Number

XXShows the customer's item number as a link to
the Item Detail page.

Customer Item Number
Link to Item Detail

XShows the price of the item multiplied by the
quantity entered to order. For example, if the user

Extended Item Price

entered 5 to order five bottles priced at
$3.00/each, the extended item price is $15.00.

XXShows the GTIN number from the ERP.Global Tracking Identifi-
cation Number (GTIN)

XXShows the item's description. If you have added
product descriptions to your back-end items in

Item Description

Storefront Catalog, the item's product description
is displayed.

XXShows the name of the item's manufacturer.Item Manufacturer

XXShows the number of the item.Item Number

XXShows the number of the item as a link to the Item
Detail page.

Item Number Link to
Item Detail

XXShows the thumbnail image attachment which
links to the Item Detail page.

Item Thumbnail

XXShows the item list prices that are set up in the
ERP. The ERP determines which price is dis-
played in Storefront Commerce.

List Price

XXShows the availability of the item in all warehous-
es. This availability value is from the CMS
database, not the back end.

Local Avail (All Whs)

XXShows an indicator (In stock/Out of Stock) for the
availability of the item in all warehouses. This

Local Avail (All Whs)
Flag

availability value is from the CMS database, not
the back end.

XXShows the availability of the item in the ware-
house assigned to the user who is logged in. This

Local Avail (Def. Whs)

availability value is from the CMS database, not
the back end.
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Checkout
page

Specials
pageDataField

XXShows an indicator (In stock/Out of Stock) for the
availability of the item in the warehouse assigned

Local Avail (Def. Whs)
Flag

to the user who is logged in. This availability value
is from the CMS database, not the back end.

XXShows the manufacturer's item number.Manufacturer's Item

XXShows the date of the next open requisition for
this item.

Next PO Date

XXShows the quantity of this item on the next open
requisition.

Next PO Quantity

XShows the quantity ordered.Order Quantity

XXShows the item's default unit of measure.Order UOM

XXShows the item's price for the pricing unit of
measure.

Price UOM Price

XXShows the unit of measure at which the item is
priced.

Pricing UOM

XShows an input field for entering order quantity.Quantity Input Box

XShows a check box to indicate that the item
should be removed from the shopping cart.

Remove Check Box

XShows a drop-down list for selecting the ordering
unit of measure.
For the Item Detail page and Results pages, if
there is only a single unit of measure, this field
displays the single UOM for the B2C interface.

Unit of Measure Drop-
Down

XXShows user-defined fields based on your ERP.
After you specify your user-defined fields, you can

User-defined

import them to Storefront Commerce by selecting
Import > Backend > Items.

XShows the warehouse abbreviation.Warehouse Abbreviation

XXShows the item's list price. For Web users, the
list price to use is based on the customer number

Web Price

of the user who is logged in. For back-end users,
the list price on the Order Header Screen is used.

XShows the UPC code that is imported from the
ERP.

UPC
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Alternates, Complements, and Assortments page types

Assortments
page

Complements
page

Alternates
pageDataField

XXXShows a link to add the item to the
shopping cart.

Add to Cart Link

XXXShows the item availability as obtained
by the Commerce Gateway Price and

Calculated Avail-
ability

Availability transaction. This availability
is retrieved from the back-end database.

XXXSimilar to Calculated Availability, but this
field shows item availability for only the

Calculated Avail-
ability (Default
Whse) default warehouse, not an accumulated

quantity.

XXXShows an indicator (In stock/Out of
Stock) of the item availability based on

Calculated Avail-
ability Flag

the availability obtained by the Com-
merce Gateway Price and Availability
transaction. This availability is retrieved
from the back-end database.

XXXSimilar to Calculated Availability Flag,
but this field shows an indicator (In

Calculated Avail-
ability Flag (De-
fault Whse) stock/Out of Stock) of item availability

for only the default warehouse, not an
accumulated quantity.

XXXShows the item's price for the default
unit of measure. This price is retrieved

Calculated Price

from the back-end database by the
Commerce Gateway Price and Availabil-
ity transaction.

XXXShows the amount of savings for the
item. The saving is calculated as
Calculated Price - Web Price = Savings

Calculated Sav-
ings

XXXShows the customer's item number.Customer Item
Number

XXXShows the customer's item number as
a link to the Item Detail page.

Customer Item
Number Link to
Item Detail

XXXShows the item's description. If you
have added product descriptions to your

Item Description

back-end items in Storefront Catalog,
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Assortments
page

Complements
page

Alternates
pageDataField

the item's product description is dis-
played.

XXXShows the name of the item's manufac-
turer.

Item Manufacturer

XXXShows the number of the item.Item Number

XXXShows the number of the item as a link
to the Item Detail page.

Item Number Link
to Item Detail

XXXShows the thumbnail image attachment
which links to the Item Detail page.

Item Thumbnail

XXXShows the availability of the item in all
warehouses. This availability value is

Local Avail (All
Whs)

from the CMS database, not the back
end.

XXXShows an indicator (In stock/Out of
Stock) for the availability of the item in

Local Avail (All
Whs) Flag

all warehouses. This availability value
is from the CMS database, not the back
end.

XXXShows the availability of the item in the
warehouse assigned to the user who is

Local Avail (Def.
Whs)

logged in. This availability value is from
the CMS database, not the back end.

XXXShows an indicator (In stock/Out of
Stock) for the availability of the item in

Local Avail (Def.
Whs) Flag

the warehouse assigned to the user who
is logged in. This availability value is
from the CMS database, not the back
end.

XXXShows the manufacturer's item number.Manufacturer's
Item

XXShows if there is a multiplier for this item
that is associated with the compliment

Multiplier

or alternate. For example, if a flashlight
requires two batteries, the compliment
is batteries, and the multiplier is 2. This
is informational only.

XXXShows the date of the next open requi-
sition for this item.

Next PO Date
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Assortments
page

Complements
page

Alternates
pageDataField

XXXShows the quantity of this item on the
next open requisition.

Next PO Quantity

XXXShows the item's default unit of mea-
sure.

Order UOM

XXXShows the item's price for the pricing
unit of measure.

Price UOM Price

XXXShows the unit of measure at which the
item is priced.

Pricing UOM

XXXShows an input field for entering order
quantity.

Quantity Input Box

XXShows a check box to indicate that the
item should be removed from the shop-
ping cart.

Remove Check
Box

XXXShows a drop-down list for selecting the
ordering unit of measure.
For the Item Detail page and Results
pages, if there is only a single unit of

Unit of Measure
Drop-Down

measure, this field displays the single
UOM for the B2C interface.

XXShows user-defined fields based on
your ERP. After you specify your user-

User-defined

defined fields, you can import them to
Storefront Commerce by selecting Im-
port > Backend > Items.

XXXShows the item's list price. For Web
users, the list price to use is based on

Web Price

the customer number of the user who
is logged in. For back-end users, the list
price on the Order Header Screen is
used.

Open Invoices, Paid Invoices, and Invoice Detail page types

Invoice
Detail page

Paid
Invoices
page

Open
Invoice
pageDataField

XShows the amount by which the original
invoice amount was adjusted.

Adjustment
Amount
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Invoice
Detail page

Paid
Invoices
page

Open
Invoice
pageDataField

XShows the adjustment number.Adjustment Num-
ber

XXShows the age date.Age Date

XShows the cash discount amount.Cash Discount
Amount

XShows the check number applied to the
invoice payment.

Check Number

XXXShows the code for the invoice's curren-
cy.

Currency Code

XXShows the number of days the invoice
has been open, based on the invoice
date.

Days Open

XShows an indicator that the open amount
is the result of a finance charge.

Finance Charge

XShows an internal sequence number for
tracking invoices.

History Sequence
Number

XXShows the amount of the invoice when it
was issued.

Invoice Amount

XThe amount yet to be received for the in-
voice.

Invoice Balance

XShows the date on which the invoice was
created.

Invoice Date

XShows the invoice dispute code assigned
to an invoice in dispute.

Invoice Dispute
Code

XXShows the invoice number.Invoice Number

XXShows the type of invoice: invoice, credit
memo, or disputed invoice

Invoice Type

XXShows the date of the last payment
transaction made for the invoice.

Last Transaction
Date

XShows the order generation number as-
sociated with the invoice.

Order Generation
Number

XShows the order number associated with
the invoice.

Order Number

XXShows the amount of the payment that
was received for the invoice.

Payment Amount
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Invoice
Detail page

Paid
Invoices
page

Open
Invoice
pageDataField

XXShows the purchase order number asso-
ciated with the invoice.

Purchase Order
Number

XXShows the invoice amount in the trading
currency.

Trade Invoice
Amount

XShows the adjustment amount in the
trading currency.

Trade Adjustment
Amount

XShows the invoice balance in the trading
currency.

Trade Invoice Bal-
ance

XShows the amount of payment that was
received for the invoice in the trading
currency.

Trade Payment
Amount

XShows the amount applied for a specific
transaction.

Transaction
Amount

XShows the date on which a specific
transaction was processed.

Transaction Date

XShows the type of transaction that was
processed.

Transaction Type

XShows the reference number for an in-
voice document

Reference Number

Sales Statistics page type

DataField

Shows the month in which a product was purchased.Month

Shows the year in which a product was purchased.Year

Shows the quantity of product purchased.Quantity Purchased

Shows the average price paid for the product.Average Purchase Price

Order Listing and Order Detail page types

Order Detail
page

Order Listing
pageDataField

XShows the item number the customer us-
es.

Customer Item Number

XShows the unit of measure the customer
uses to order (which may be different than

Customer Order UOM
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Order Detail
page

Order Listing
pageDataField

the unit of measure used to track the
purchase in your ERP system).

XShows the unit of measure the customer
sees for pricing.

Customer Pricing UOM

XShows the date the order was entered.Entry Date

XShows an internal sequence number for
tracking orders.

Entry Sequence Number

XXShows the date it is expected that the or-
der will ship.

Estimated Ship Date

XShows the sell price multiplied by the
quantity ordered.

Extended

XShows the total value invoiced.Invoice Amount

XShows the date on which the order was
invoiced.

Invoice Date

XShows the invoice number.Invoice Number

XShows the item description.Item Description

XShows the item number.Item Number

XShows the product list price.List Price

XShows the generation number of the or-
der.

Order Generation Num-
ber

XShows the customer's order number.Order Number

XShows the status of the order.Order Status

XShows the order type.Order Type

XShows the total value of the order.Order Value

XShows the item's original item number.Original Item Number

XShows the purchase order number.P.O. Number

XShows the unit of measure at which the
product is priced.

Pricing Unit of Measure

XShows the quantity of product that was
back ordered.

Quantity Back Ordered

XShows the quantity of product the cus-
tomer ordered.

Quantity Ordered
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Order Detail
page

Order Listing
pageDataField

XShows the quantity of product that was
shipped.

Quantity Shipped

XShows the price for which the product was
sold.

Sell Price

XShows the date on which the order was
processed for shipping.

Ship Confirm Date

XShows the order ship-to number.Ship-to Number

XShows the unit of measure in which the
product was purchased.

Unit of Measure

XXShows the warehouse abbreviation.Warehouse Abbreviation

Order History page type

DataField

Shows a link to add the item to the shopping cart.Add to Cart Link

Shows the item availability as obtained by the Commerce Gateway Price
and Availability transaction. This availability is retrieved from the back-
end database.

Calculated Availability

Similar to Calculated Availability, but this field displays item availability
for only the default warehouse, not an accumulated quantity.

Calculated Availability (De-
fault Whse)

Shows an indicator (In stock/Out of Stock) of the item availability based
on the availability obtained by the Commerce Gateway Price and Avail-

Calculated Availability Flag

ability transaction. This availability is retrieved from the back-end
database.

Similar to Calculated Availability Flag, but this field shows an indicator
(In stock/Out of Stock) of item availability for only the default warehouse,
not an accumulated quantity.

Calculated Availability Flag
(Default Whse)

Shows the item's price for the default unit of measure. This price is re-
trieved from the back-end database by the Commerce Gateway Price
and Availability transaction.

Calculated Price

Shows the amount of savings for the item. The saving is calculated as
Calculated Price - Web Price = Savings

Calculated Savings

Shows the customer's item number.Customer Item Number

Shows the customer's item number as a link to the Item Detail page.Customer Item Number Link
to Item Detail
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DataField

Shows the item's description. If you have added product descriptions to
your back-end items in Storefront Catalog, the item's product description
is displayed.

Item Description

Shows the name of the item's manufacturer.Item Manufacturer

Shows the number of the item.Item Number

Shows the number of the item as a link to the Item Detail page.Item Number Link to Item
Detail

Shows the thumbnail image attachment which links to the Item Detail
page.

Item Thumbnail

Shows the item list prices that are set up in the ERP. The ERP deter-
mines which price is displayed in Storefront Commerce.

List Price

Shows the availability of the item in all warehouses. This availability
value is from the CMS database, not the back end.

Local Avail (All Whs)

Shows an indicator (In stock/Out of Stock) for the availability of the item
in all warehouses. This availability value is from the CMS database, not
the back end.

Local Avail (All Whs) Flag

Shows the availability of the item in the warehouse assigned to the user
who is logged in. This availability value is from the CMS database, not
the back end.

Local Avail (Def. Whs)

Shows an indicator (In stock/Out of Stock) for the availability of the item
in the warehouse assigned to the user who is logged in. This availability
value is from the CMS database, not the back end.

Local Avail (Def. Whs) Flag

Shows the manufacturer's item number.Manufacturer's Item

Shows the date of the next open requisition for this item.Next PO Date

Shows the quantity of this item on the next open requisition.Next PO Quantity

Shows the item's default unit of measure.Order UOM

Shows the item's price for the pricing unit of measure.Price UOM Price

Shows the unit of measure at which the item is priced.Pricing UOM

Shows an input field for entering order quantity.Quantity Input Box

Shows a check box to indicate that the item should be removed.Remove Check Box

Shows a drop-down list for selecting the ordering unit of measure.Unit of Measure Drop-Down

Shows the warehouse abbreviation.Warehouse Abbreviation

Shows the item's list price. For Web users, the list price to use is based
on the customer number of the user who is logged in. For back-end
users, the list price on the Order Header Screen is used.

Web Price
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Additional Charges page type

DataField

Shows the amount of the additional charges.Charge Amount

Shows a description of the additional charges.Charge Description

Alternate Warehouses page type

DataField

Shows the item availability as obtained by the Commerce Gateway Price and
Availability transaction. This availability is retrieved from the back-end
database.

Calculated Availability

Shows an indicator (In stock/Out of Stock) of the item availability based on
the availability obtained by the Commerce Gateway Price and Availability
transaction. This availability is retrieved from the back-end database.

Calculated Availability
Flag

Shows the item's price for the default unit of measure. This price is retrieved
from the back-end database by the Commerce Gateway Price and Availabil-
ity transaction.

Calculated Price

Shows the amount of savings for the item. The saving is calculated as
Calculated Price - Web Price = Savings

Calculated Savings

Shows the customer's item number.Customer Item Number

Shows the warehouse abbreviation.Warehouse Abbrevia-
tion

Shows a description of the warehouse.Warehouse Description

Shows the name of the item's manufacturer.Item Manufacturer

Shows the number of the item.Item Number

Shows the thumbnail image attachment which links to the Item Detail page.Item Thumbnail

Shows the availability of the item in all warehouses. This availability value is
from the CMS database, not the back end.

Local Availability

Shows an indicator (In stock/Out of Stock) for the availability of the item in all
warehouses. This availability value is from the CMS database, not the back
end.

Local Availability Flag

Shows the manufacturer's item number.Manufacturer's Item

Shows the date of the next open requisition for this item.Next PO Date

Shows the quantity of this item on the next open requisition.Next PO Quantity

Shows the item's default unit of measure.Order UOM

Shows the item's price for the pricing unit of measure.Price UOM Price
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DataField

Shows the unit of measure at which the item is priced.Pricing UOM

Shows the item's list price. For Web users, the list price to use is based on
the customer number of the user who is logged in. For back-end users, the
list price on the Order Header Screen is used.

Web Price

Creating page layouts
In Storefront Catalog, you can use the default page layouts or create your own. You can create as
many layouts as required. For example, if you have different levels of users who will be using Storefront
Commerce, you can create page layouts for each type of user. This allows you to control what data is
available to different users, such as internal users versus Web site users or account managers versus
a customer service representatives.

To create a page layout:

1 Select System > Commerce > Page Layout > Create.
2 Specify this information:

Page Layout Name
Specify the name of the page layout being created.

Page Layout Description
Specify descriptive text to identify the page layout being created.

Page Layout Type
Specify the type of page for which the layout is being created.

3 Click Create. The View page is displayed with the new page layout. Now you can add fields to the
layout. See "Adding fields to page layouts" on page 85.

Adding fields to page layouts
You can add fields to new or existing page layouts. You can add one field at a time, or add all default
layouts for the page type at one time.

To add one or more fields to a page layout:

1 Select System > Commerce > Page Layout > Search. If you just created a new page layout and
the record is still open, start at step 4.

2 Specify search criteria to find the page layout to which to add fields and click Search. The Results
page is displayed.

3 Select a page layout. The View page is displayed.
4 Click the Page Detail tab.
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5 Perform one of these steps:

• To add all default fields based on the page layout type, click Add All Defaults.
• To add one field, select it from the drop-down list and specify this information:

Display
Specify whether this field should be displayed on the page.

Field Name
Specify the name of the field as it will be shown on the page.

Width
Specify the width of the column, in pixels, for the field.

Align
Specify the alignment of the data in the column.

Line Number
Specify the number of the row in which the field data will be displayed. For example, if you want
the item description to be in the second row, type 2.

Column Span
Specify the number of columns this field will span in the table. Type 0 if the field is contained in
a single column.

Row Span
Specify the number of rows this field will span in the table. Type 0 if this field is contained in a
single row.

Wrap Column
Specify whether the content in this column will wrap when it reaches the maximum width of the
column.

CSS Class
If you modified a class in the cascading style sheet (.css) to format the color and fonts of your
page, type the name of the class that should be used to format this field.

Show in Grid View
This field is displayed if you select Browse Results Page page layout. Select the check box to
display this field in a grid view.

6 Click Add.

Changing field order
You can specify the order in which field data is read and loaded from the database to the page layouts.
After you have added two or more fields to your page layout, you can change the order in which they
are displayed. By default, fields are incremented by ten as they are added.

When you change the field sequence number, you must change the line number for the fields, to
maintain the relationship between the sequence in which data is retrieved and the order in which it
appears on the page.
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To change the order of fields on a page layout:

1 Select System > Commerce > Page Layout > Search. If you just added fields to a page layout
and the record is still open, start at step 5.

2 Specify search criteria to find the page layout and click Search. The Results page is displayed.
3 Select the page layout. The View page is displayed.
4 Click the Page Detail tab.
5 In the drop-down field, select Resequence Detail.
6 In the fields provided, specify new sequence numbers and click Reorder.
7 For the fields whose sequence you changed, you must now change the line number to correspond

with the new sequence position. For example, if the Item Thumbnail field was in the first sequence
position and you moved it to the second position, you must select that field on the Page Detail page
and change Line Number from 1 to 2.

Searching for page layouts
You can use search criteria to limit the list of page layouts that are displayed on the Page Layouts
page.

To search for a page layout:

1 Select System > Commerce > Page Layout > Search.
2 Specify any of this search criteria:

Name Contains
Specify all or part of the page layout name.

Description Contains
Specify all or part of the page layout description.

Type
Specify the type of page or leave **All** selected to search for all page types.

3 Click Search. The page shows page layouts that match your search criteria.

Copying page layouts
To copy a page layout:

1 Select System > Commerce > Page Layout > Search.
2 Specify search criteria to find the page layout to copy and click Search. The Results page is displayed.
3 Select the page layout to copy. In the Copy To field, specify the name of the page layout that you

want to create.
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4 Click Copy and OK. The page shows the new page layout added to the list, in alphabetical order.

Viewing a sample of the page layout
As you create your page layout, you should view a sample of how the page will look.

To view a sample layout:

1 Select System > Commerce > Page Layout > Search.
2 Specify search criteria to find the page layout to view and click Search. The Results page is displayed.
3 Select the page layout. The View page is displayed.
4 Click the Page Detail tab.
5 In the drop-down field, click View Sample. A new browser window opens that shows the page layout

filled with the maximum sample data allowed.
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10Working with page layout groups

After you create page layouts, you can create page layout groups to which page layouts can be assigned.
A page layout group is a container for page layout formats that you have created.

For example, suppose you have created page layouts for Internal Search Results, Internal Browse
Results, and Internal Item Detail. You could create a page layout group called Internal, add these three
layouts to the group, and assign the group to your internal catalog users.

Page layout groups are assigned to Storefront Commerce Web accounts using Storefront Administration.
Refer to the  Infor Distribution Storefront Administration User Guide.

Review these topics for more information:

• "Creating page layout groups" on page 89
• "Assigning page layouts to page layout groups" on page 90
• "Searching for page layout groups" on page 90

Creating page layout groups
To create a page layout group:

1 Select System > Commerce > Page Layout Groups > Create.
2 Specify this information:

Page Layout Group Name
Specify the name of the page layout group.

Page Layout Group Description
Specify descriptive text to help identify the page layout group.

3 Click Create. The View page is displayed, showing the information you entered for the page layout
group record. Now you can assign page layouts to the group.
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Assigning page layouts to page layout groups
To assign page layouts to a page layout group:

1 Select System > Commerce > Page Layout Groups > Search. If you create a new page layout
group and the record is still open, start at step 4.

2 Specify search criteria to find the page layout group to which to assign page layouts and click Search.
The Results page is displayed.

3 Select a group. The View page is displayed.
4 Click the Assignments tab.
5 Use the drop-down field to select the page layout type to assign to the group. The page shows

unassigned page layouts of the type you selected.
6 Select a page layout to assign it to the page layout group. You can assign only one layout of each

type to a group. If a layout of a certain type is already assigned, clicking the name removes the
current assignment and replaces it with the layout selected.

7 Repeat step 5 for each page layout type until the group has all types assigned.

Note: For each page layout group, you must complete page layout assignments for each type of
page layout. If a page layout type remains unassigned, users in that group will not have access to
that type of page. For example, you cannot have a page layout group with only a search results and
browse results page layout assigned.

Searching for page layout groups
You can use search criteria to limit the list of page layout groups that are displayed on the Page Layout
Groups page.

To search for a page layout group:

1 Select System > Commerce > Page Layout Groups > Search.
2 Specify any of the search criteria:

Name Contains
Specify all or part of the group's name.

Description Contains
Specify all or part of the group's description.

3 Click Search. A list of page layout groups that match your search criteria is displayed.
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11Working with item detail tabs

Item detail tabs are used on the Storefront Catalog Item Detail page to provide different types of
information about an item. You can control the number, order, content, and text labels of the tabs
included on the Item Detail page.

The Item Detail page includes all or part of this information:

• Related categories
• Alternate items
• Complementary items
• Extended item comments
• Detailed text descriptions
• Images
• Links to files and/or Web sites
• Additional warehouses where the item is available (this feature is for the Storefront Catalog user

interface only)

You can assign one or more of these information types to a tab and specify the order in which the
information will be shown on the tabbed page. Then, if an item has an attachment for the information
type, the attachment information is displayed.

Unlike page layout groups, which are assigned to accounts, you do not need to assign item detail tabs
to accounts. Each tab you create is automatically displayed on the Item Detail page.

Review these topics for more information:

• "Creating detail tabs" on page 92
• "Searching for detail tabs" on page 92
• "Managing information on detail tabs" on page 93
• "Changing tab order" on page 94
• "Editing records" on page 15
• "Deleting records" on page 15
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Creating detail tabs
To create a tab for the Item Detail page:

1 Select System > Catalog > Item Detail Tabs > Create.
2 Specify this information:

Tab Name
Specify the name of the tab. The name you provide will be the name shown on the tab on the Item
Detail page.

Tab Description
Specify descriptive text to help identify the tab.

Tab Visibility Type
Select Web/Internal if this tab will be available to Storefront Commerce users and internal users.
Select Web if the tab is for Storefront Commerce users only. Select Internal if the tab is for internal
users only.

Tab Default Position
Select Extended if, by default, the tab contents will be expanded on the Item Detail page. Select
Unextended if, by default, the contents will be collapsed on the Item Detail page.

3 Click Create. The View page is displayed with the new tab. Now you can add information to the tab.
See "Managing information on detail tabs" on page 93.

Searching for detail tabs
You can search for detail tab records to view, edit, or delete.

To search for a detail tab:

1 Select System > Catalog > Item Detail Tabs > Search.
2 Specify any search criteria:

Note: To display all detail tabs, leave search criteria fields empty and click Search.

Tab Name Contains
Specify all or part of a tab name.

Tab Description Contains
Specify all or part of a tab description.

Tab Visibility Type
Select the tab visibility type. Leave **All** selected to search for all visibility types.

3 Click Search. The Results page is displayed, listing detail tabs that match your search criteria.
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Managing information on detail tabs
Each detail tab must have at least one information type assigned to it. The information type determines
what type of attachment information is available on the tab. You can add, delete, and reorder tab
information.

Adding information types to a tab
To add information types to a tab:

1 Select System > Catalog > Item Detail Tabs > Search. If you have just created a new tab and the
record is still open, start at step 4.

2 Specify search criteria to find the tab to which to add information and click Search. The Results
page is displayed.

Note: To display all tabs, leave search criteria fields empty and click Search.

3 Select the tab. The View page is displayed.
4 Click the Tab Detail tab.
5 In the Tab Detail Type field, choose the information type to add and click Add.
6 Repeat step 5 as needed.

Deleting information types from a tab
To delete information types from a tab:

1 Search for the tab from which to delete information.
2 On the Results page, select the tab. The View page is displayed.
3 Click the Tab Detail tab.
4 Select the each information type to delete. Click Delete and OK.

Reordering information on a tab
To reorder information on a tab:

1 Search for the tab to organize.
2 On the Results page, select the tab. The View page is displayed.
3 Click the Tab Detail tab.
4 Select Tab Detail Sequence. The page shows only the list of information types and number fields.
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5 Specify a sequence number for each information type and click Reorder. We recommend using
sequence numbers in increments of 10 (10, 20, 30, and so on), so that in the future you can add
information types between existing types without renumbering.

Changing tab order
Sequence numbers control the order in which your item detail tabs are displayed on the Item Detail
page. The system automatically assigns sequence numbers to a tab when you create the tab. Sequence
numbers are incremented by ten (ten being the first sequence number). You can change the sequence
number on the Tab Sequence page.

To change the order of tabs for the Item Detail page:

1 Select System > Catalog > Item Detail Tabs > Search or System > Catalog > Item Detail Tabs
> Create. The Search or Create page is displayed.

2 Click the Tab Sequence tab.
3 In the Tab Visibility Type field, specify the tab visibility to limit the list of tabs based on where they

are shown. The page shows the tabs with the visibility type you selected.
4 Specify sequence numbers for the tabs you want to rearrange.
5 Click Reorder.
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12Working with catalogs

A catalog is a set of all products you intend to market to customers. With Storefront Catalog, you can
create as many different types of catalogs as you require. For example, a catalog can be global, regional,
available to all customers, or specific to a single customer. You also can create seasonal and sales
catalogs.

After you create a catalog, you must publish it and the items in it before it can be assigned to Web
accounts and seen by Storefront Commerce users.

Review these topics for more information:

• "Setting Catalog user interface options" on page 19
• "Creating catalogs" on page 95
• "Searching for catalogs" on page 96
• "Creating catalog categories and subcategories" on page 97
• "Adding and managing catalog items" on page 98
• "Copying catalogs" on page 99
• "Resequencing catalog items, attachments, and attributes" on page 100
• "Publishing catalogs" on page 101
• "Exporting catalogs" on page 102
• "Editing records" on page 15
• "Deleting records" on page 15

Creating catalogs
Use Storefront Catalog to create as many catalogs as you need. When you create a catalog, you can
select to use information from your ERP, such as item class/subclass or GL codes, to create the catalog
categories, or you can create custom catalogs with categories/subcategories designed specifically for
your Storefront.

To create a catalog:

1 Select Catalogs > Create.
2 Specify this information:
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Catalog Name
Specify the name of the catalog.

Catalog Description
Specify descriptive text to identify the catalog.

Create Catalog
Specify how you want your catalog to be created:

• Select Empty Catalog to create the catalog with no categories or subcategories. You will be
able to build all of your categories later. See "Creating catalog categories and subcategories"
on page 97.

• Select Item Class/SubClass to create the catalog with categories and subcategories based on
the item classes and subclass defined in the ERP. You can type a range to limit the
category/subcategory creation to classes in the specified range. Categories and subcategories
are named as the item classes and subclasses, and items in those classes are assigned to the
category or subcategory.

• Select GL class to create the catalog with categories and subcategories based on the GL classes
defined in the ERP. You can type a GL code range to limit the category/subcategory creation
to classes in the specified range. Categories are named as the GL classes, and items in those
classes are assigned to the category or subcategory.

3 Click Create. The View page is displayed, showing the catalog you just created.

Searching for catalogs
You can search for catalog records to view, edit, or delete.

To search for a catalog:

1 Select Catalogs > Search.
2 Specify any of the search criteria:

Note: To display all catalogs, leave search criteria fields empty and click Search.

Catalog Name Contains
Specify all or part of the catalog name.

Catalog Description Contains
Specify all or part of the catalog description.

3 Click Search. The Results page is displayed, listing catalogs that match your search criteria.
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Creating catalog categories and subcategories
If you chose Empty Catalog when creating catalogs, you must create categories and subcategories
using the Categories page. Categories and subcategories allow you to organize your catalog contents
into groups of products. For example, a Toy catalog can have categories for Action Figures, Stuffed
Animals, and Dolls. Action Figures can have subcategories for Sports Heroes and TV Stars.

There is no limit to the number of categories and subcategories you can create, and you can have as
many subcategory levels as you need to organize your items.

You also can use the Categories page to manage existing categories and subcategories for a catalog.
See "Managing catalog categories and subcategories" on page 97.

To create a catalog category or subcategory:

1 Select Catalogs > Search. If you have just created an empty catalog and the record is still open,
start at step 4.

2 Specify search criteria to find the catalog and click Search. The Results page is displayed.

Note: To display all catalogs, leave search criteria fields empty and click Search.

3 Select the catalog. The View page is displayed.
4 Click the Categories tab.
5 Right-click the catalog name and click Add. A new category node is added under the catalog name.
6 Specify a name for the new category. A successful message is displayed.
7 Perform one or more of these tasks:

• Create another main category for your catalog: Right-click the catalog name in the hierarchy tree
and repeat this process at step 5. You can create as many categories as required.

• Create a subcategory under a category: Right-click the category name in the hierarchy tree and
repeat this process at step 5. You can create as many subcategories as required.

• Add items to a category or subcategory.
See "Adding and managing catalog items" on page 98.

Managing catalog categories and subcategories
Whether your catalog categories were created automatically during catalog creation or manually using
the Categories page, you can use the Categories page to manage them.

A search function is provided above the catalog hierarchy tree to help you find categories. To search
for categories:

1 Specify all or part of a category name in the search field and click Search. Categories matching the
search criteria are highlighted in the tree.

2 To clear the search field and start again, click Clear.

Using the right-click menu or the chevron button above the tree, you can display options to add, rename,
delete, cut, copy, and paste categories and subcategories, and to assign attachments. Use the right-click
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menu to expand or collapse categories and subcategories. To manage categories using these options,
select the category to work with and then select the action to perform on that category.

You can move categories and subcategories using multi-select and drag-and-drop functionality.

When you use cut and paste or drag and drop to move a category or subcategory, its items are moved.
However, when you copy a category or subcategory, its items are not copied.

Adding and managing catalog items
You can search for and add items to catalogs using the Categories tab. You can remove items from
catalogs, move items among categories and subcategories, and copy items to multiple categories and
subcategories.

Adding a single item by item number
To add a single item by item number:

1 Navigate to the Categories page for a selected catalog.
2 In the tree, click the category or subcategory to which to add an item.
3 Specify the item number and click Add to Category. To add multiple items from search results:

Adding multiple items from search results
To add multiple items from search results:

1 Navigate to the Categories page for a selected catalog.
2 In the tree, click the category or subcategory to which to add items.
3 Select Add Items. Item search fields are displayed.
4 Specify the search criteria and click Search. To show all items, leave the search criteria fields empty

and click Search. The Results page is displayed.
5 Select a category or subcategory and click Add to Category. The items are added to the end of

the current list of items in the selected category or subcategory. To resequence the items, see
"Resequencing catalog items, attachments, and attributes" on page 100.

Copying items to another category or subcategory
To copy items to another category or subcategory
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1 Navigate to the Categories page for a selected catalog.
2 In the tree, click the category or subcategory from which to copy an item.
3 Select each item to copy and click Copy. A new browser window is displayed that shows the list of

categories to which you can copy the items.
4 Select the parent category for the copied items. You are returned to the Categories page, with your

selected items copied to the new parent category. The items are added to the end of the current list
of items. To resequence the items, see "Resequencing catalog items, attachments, and attributes"
on page 100.

Moving items within the catalog
To move items within the catalog:

1 Navigate to the Categories page for a selected catalog.
2 In the tree, click the category or subcategory from which to move items.
3 Select each item to move and click Move. A new browser window opens that shows the list of

categories to which you can move the items.
4 Select a new parent category for the items. You are returned to the Categories page, with your

selected items in the new parent category. The items are added to the end of the current list of
items. To resequence the items, see "Resequencing catalog items, attachments, and attributes" on
page 100 .

Deleting items from the catalog
To delete items from the catalog

1 Navigate to the Categories page for a selected catalog.
2 In the tree, click the category or subcategory from which to remove items.
3 Select each item to remove. Click Delete and OK.

Copying catalogs
If you have an existing catalog that you want to modify to create a new catalog, you can copy the
existing catalog from the Results page.

To copy a catalog:

1 Select Catalogs > Search.
2 Specify the search criteria to find the catalog to copy and click Search. The Results page is displayed.

Note: To display all catalogs, leave the search criteria fields empty and click Search.
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3 Select the catalog to copy. In the Copy To field, specify the name of the catalog to create as a copy.
4 Click Copy and OK. The catalog you selected is copied and assigned the name you specified. The

new catalog is added to the bottom of the list of catalogs on the Results page. You can edit the
catalog and work with its categories.

Resequencing catalog items, attachments, and
attributes
Sequence numbers determine the order in which items, attachments, or attributes are displayed in
Storefront Commerce when users browse catalog categories.

Note: The search results for Storefront Commerce are always sequenced by relevancy.

When a category or subcategory contains one or more items, or has one or more attachments or
attributes assigned to it, you can change the order in which they are displayed. By default, the sequence
of items, attachments, and attributes is incremented by ten.

Resequencing items in a category or subcategory
To resequence items in a category or subcategory:

1 Navigate to the Categories page for a selected catalog.
2 In the tree, click the category or subcategory with items.
3 Select Resequence Items.
4 Specify new sequence numbers for the items and click Reorder.

Resequencing attachments for a category item
To resequence attachments for a category item:

1 Navigate to the Categories page for a selected catalog.
2 In the tree, click the category or subcategory with which to work.
3 Select the item number of the item with attachments.
4 Select Attachments. Attachment search fields and a list of current attribute assignments are

displayed.
5 Select Attachment Sequence.
6 Specify new sequence numbers for the attachments and click Resequence.
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Resequencing attributes in a category
To resequence attributes in a category:

1 Navigate to the Categories page for a selected catalog.
2 In the tree, click the category or subcategory with attribute assignments to resequence.
3 Select Category Attributes. Attribute search fields and a list of current attribute assignments are

displayed.
4 Click Attribute Sequence.
5 Specify new sequence numbers for the attributes and click Reorder.

Publishing catalogs
When a catalog is ready for browsing in Storefront Commerce, you must publish the catalog to make
it available to Storefront Catalog.

When you publish a catalog, the catalog, its categories, the category item assignments, attribute
assignments, and item attribute value assignments are published from the staging area to the production
area. At the same time, an index build request is sent to the Progress EasyAsk Studio server and a
search index is generated.

You must publish items in the catalog before you can publish the catalog. For help publishing items,
see "Publishing items" on page 42.

To publish a catalog:

1 Select Import > Publish > Catalogs.
2 Specify all or part of the catalog's name or description to find the catalog to import and click Search.

The Results page is displayed. To publish all catalogs, see "Publishing all catalogs" on page 101

Note: To display all catalogs, leave the search criteria fields empty and click Search.

3 Click Publish Catalog next to the catalog to publish. If no errors are present, a message is displayed
saying the catalog publish status is complete and the system is ready for indexing.

4 Click Generate Item Index. The Scheduled Jobs page is displayed.
5 Select the check box for the Item Index Generation job and click Run Now. See "Running a job

manually" on page 105.

Publishing all catalogs
Optionally, you can publish all catalogs.

To publish all catalogs:

1 Select Import > Publish > All.
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2 Select Publish all catalogs and click Publish.

Exporting catalogs
You can export your new Storefront catalogs to an XML document. Exporting to an XML document
provides you with a text format that can be used with certain publishing programs to help create paper
catalogs.

To export a catalog:

1 Make sure export options are set. See "Setting Catalog export options" on page 18.
2 Select Export > Catalogs.
3 Specify all or part of the catalog's name or description to find the catalog to export and click Search.

The Results page is displayed.

Note: To display all catalogs, leave the search criteria fields empty and click Search.

4 Select the catalog to export. The Export Catalog page is displayed with elements for the catalog.
5 Clear the check box for each element you do not want to include in your exported file. By default,

all of the lines are selected. You can rename the element tags. You must change only the opening
tag (the first field in the row). The closing tag (the second field in the row) changes automatically to
match your entry in the opening tag.

6 Select Replace HTML Entity Number with Symbol to include symbols in the export. This field is
used for exporting Manufacturer and Product Descriptions.
Select this field if you are specifying a trademark symbol.

7 Click Submit. The resulting XML output content is displayed in the browser window.
8 To save the file, select File > Save As.
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13Scheduling and running jobs

You can use the Storefront Catalog Schedule/Run Jobs option to run these processes:

• Item Index Generation is used for the Storefront search. You must have imported items before you
can generate the item index. Only items in published catalogs are searchable by Storefront users.
As your item information changes, you must regenerate the item index to reflect the change in items.
It is recommended that you generate the item index after every import of items.

• Import Back End Items is for retrieving item information from the back end.
• Import Back End Item Quantities is for retrieving item quantities from the back end.
• Import Back End Item Classifications and Import Back End Item Extended Comments is for retrieving

classifications, EICs, and users.
• Customer and SHipto Synch to synchronize customer and ship-to information with the ERP. This

process retrieves the current customer and ship-to data from the ERP for B2B Web accounts based
on the Synchronize ship-tos at Login setting in Storefront Administration account options.

Note: When processing corporate group accounts, the Storefront Administration setting is not used.
All corporate group customer and ship-to data is processed.

• Delete Inactive Ship to Data is is for deleting information that is no longer active. The deleted or
inactive shipto data in the ERP is not removed from the Storefront database but is marked as inactive.
You must run this job to delete the inactive information.

• Sitemap Generation is to generate the sitemap for search engines. The URLs generated are search
engine friendly. We recommend that you schedule this job after the item index generation. This will
ensure that any added items and categories are included. A sitemap.xml for each language and
site, if the multisite feature is turned on, will be created in the <EaskAsk install dir>/server/
EasyAsk/sitemaps folder.

• Delete Stale Cart Data is for clearing the tables that contain left over cart data. The B2C-A cart data
is saved in the database. Run this job to clear the data.

Because it is important that your item information is current and available, it is recommended that you
schedule these jobs to run automatically. Jobs can be scheduled to run daily or weekly at the time you
specify or you can set a recurring interval for the job.

Review these topics for more information:

• "Scheduling jobs" on page 104
• "Managing scheduled jobs" on page 104
• "Running a job manually" on page 105
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Scheduling jobs
To schedule a job:

1 Select System > Catalog > Schedule/Run Jobs.
2 A job must be disabled before you can maintain its schedule. To disable a job, select the check box

of the enabled job and then click Enable/Disable.
3 Click the name of the job to schedule. The Job Schedule Options page is displayed.

Note: If you are an SX.enterprise user, do not schedule the Import Back End Item Quantities job.

4 Specify this information:

Repeat
To schedule the job to run on specific days of the week, select the appropriate check boxes. For
example, to run the job weekly on Sundays, select the check box for Sun. To run the job daily,
select the check boxes for Sun, Mon, Tue, Wed, Thu, Fri, and Sat.

at __:__ AM/PM
Use this field to run at a specific hour and minute of the days selected in the Repeat field. Select
the option, specify the hour as a value between 1 through 12, specify the minute as a value between
00 and 59, and select AM or PM. For example, to run the job at midnight, specify 12:00 and select
AM.

every __ Hours __ Minutes
Use this field to run the job periodically, at the interval you specify. Select the option and then specify
the interval in hours and/or minutes. For example, to run the job every 10 minutes, specify 00 for
the Hours and 10 for the Minutes. To run the job every four hours, specify 4 for the Hours and 0
for the Minutes.

5 Click Update.

Note: If you made changes but want to reset the values to those you had before entering changes,
click Reset.

6 Repeat these steps for each job you need to schedule.
7 After a job is scheduled, you must enable it. Select the check box of a disabled job and click

Enable/Disable.

Managing scheduled jobs
To check the status of the jobs you have scheduled or to enable or disable scheduled jobs:

1 Select System > Catalog > Schedule/Run Jobs.
2 Perform one of these steps:

• To disable a job, select the enabled job and click Enable/Disable.
• To review the current status of the job, check the Job Status, Last Run Time, and Job Message

columns.
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Running a job manually
To run a job manually at any time:

1 Select System > Catalog > Schedule/Run Jobs.
2 Select the check box of the job to run and click Run Now.

You can click Refresh to update the job status, or click Enable Auto Refresh to have the job status
updated automatically.
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ACatalog import utility file formats

To access the Catalog Import Utility sample spreadsheets, browse to and select Documentation\
sample\SFCIU_Sample_Spreadsheet_Files.zip.

To access the Catalog Import Utility sample attachment files, browse to and select Documentation\
sample\SFCIU_Sample_Attachment_Files.zip.

This is a summary of the available file formats:

DescriptionSFCIU File Formats

Updates Item Product Description and/or Manufac-
turer

SFCIU_saitem

Deletes Attributes, Deletes Attribute Name/Values,
Unassigns Attribute Name/Values from Items

SFCIU_saitem_saattribute_unassign_delete

Add Attributes, Add Attribute Values, Attribute
Value Sequence and Assigns Attribute
Name/Value Pair(s) to Items

SFCIU_saitem_saattribute

Unassign Attachment(s) from Items by Attachment
Name, Deletes Attachments

SFCIU_saitem_saattachment_unassign_delete

Assign Image/Text/File/URL Attachments to Items
by Attachment Name. Adds Text Attachment

SFCIU_saitem_saattachment

Content (same as Process As Text Option), Adds
URL Attachment Content

Delete Catalog(s), Deletes Categories and SubCat-
egories from a Catalog, Unassign Items from Cat-
egories

SFCIU_saitem_sacategory_unassign_delete

Adds Catalog(s), Adds Categories and SubCate-
gories to a Catalog with category sequence num-

SFCIU_saitem_sacategory

bers supported at all levels, Assigns Item(s) to
Categories and set Item sequence numbers at
category level

Unassigns Attachment(s) from existing Cata-
logs/Categories

SFCIU_sacategory_saattachment_unassign
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DescriptionSFCIU File Formats

Assigns Attachment(s) to existing Catalogs/Cate-
gories. Does Not Add Catalog/Category, and does
not add Text/URL Attachment Content

SFCIU_sacategory_saattachment

Deletes Accounts, Does not Delete Shopper Ac-
counts (Active Budget/Approval Accounts)

SFCIU_account_delete

Adds AccountsSFCIU_account

File size limitations
The technology that processes the spreadsheet files is open source software that reads the entire
fileinto memory. Therefore, file size limitations are imposed. Without these limitations, the process
thatreads files may cause errors in your Web container (TomCat). The limitations specified below
weretested with the following:

• Java version 1.6.0_25 (32bit)
• Apache-tomcat-6.0.29 (32-bit)
• LaunchConfig= -Xmx768M -XX:MaxPermSize=768M

If your system is 64bit and/or has larger memory specifications, you can increase these properties. Itis
recommended that you divide large files in multiple smaller files. If the data is logically correct and does
not overlap, the spreadsheet files are processed as if the data were in a single larger file.

Note: These limitations may be modified, but use caution. Infor Storefront Support will not be responsible
for problems encountered as a result of changing these properties.

Restore the values to the default and restart TomCat if you have file size problems:
maxFileSizeToReadForStatus 1048576 bytes = 1MB.

If an uploaded file is larger than 1M, the Catalog import utility status function does not read the file
because it is not critical that the File Format and Number of Records be extracted just for the status
display. If this limitation is encountered, the File Format is displayed as NOT DETECTED.

The maxFileSizeToProcess 4619566 bytes is approximately 4.5MB or 100,000 records for most File
Formats. If an uploaded file is larger than 4.5M, it is not be processed and the file status displayed is
FILE TOO LARGE. In this case, the file must be broken into smaller files or the file size limitations must
be changed.

These properties are specified in the following file: \webapps\storefrontAppServer\WEB-INF\
StorefrontApplicationContext.xml

<property name="maxFileSizeToReadForStatus" value="1048576" /><property
 name="maxFileSizeToProcess" value="4619566" /> 
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Excel 2010 Limitations
Worksheet size limit is 1,048,576 rows by 16,384 columns. Total number of characters that a cell can
contain is 32,767 characters.

Note: The input file length is checked against corresponding Storefront database columns.

If an uploaded file is larger than 400k, the Catalog import utility status function does not read the file
because it is not critical that the File Format and Number of Records be extracted just for the status
display. If this limitation is encountered, the File Format will display as NOT DETECTED. The
MaxFileSizeToProcess 3072000 = 3000k = 3MB is approximately 50,000 records for most File Formats.
If an uploaded file is larger than 3000k, it is not be processed and the file status displayed is FILE TOO
LARGE. In this case, the file must be broken into smaller files or the file size limitations must be changed.

SFCIU_saitem
You can use this file format to update the item product description and/or the manufacturer. The columns
are:

• Company
• Item Number
• Item Description
• Manufacturer

The processing options are:

• languagecode
• convertsymbolhtml

The required fields are:

• languagecode
• Valid item number or valid item company/item number
• Item Description or Manufacturer

Example:

Example with special characters to convert
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SFCIU_saitem_saattribute
You can use this file format to add attributes, attribute name/values, and assign attribute name/values
to items. The columns are:

• Company
• Item Number
• Name 1
• Value 1
• Seq 1
• Name 2
• Value 2
• Seq 2
• Name 3
• Value 3
• Seq 3
• Name 4
• Value 4
• Seq 4
• Name 5
• Value 5
• Seq 5

The processing options are:

• languagecode
• convertsymbolhtml

The required fields are:

• languagecode
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• At least 1 Name when adding an attribute
• At least 1 Name/value when adding an attribute name/value
• Valid Item number or valid Company/item number when assigning name/value to an item

Note: There is a known limitation in Attribute processing. If there is only one Item assigned to a Attribute
Value, the Attribute may not appear as expected in Storefront Commerce. This could be because the
Item is filtered out by Price and Availability or because the Item was not indexed as expected by
EasyAsk.

Example:

Example continued:

SFCIU_saitem_saattribute_unassign_delete
You can use this file format to delete attributes, attribute name/value, and unassign attribute name/values
from items. The columns are:

• Company
• Item number
• Attribute name
• Attribute value

The processing option is languagecode.

The required fields are:

• languagecode
• At least 1 Attribute Name (or wildcard) when deleting an attribute
• At least 1 Attribute Name/value (or wildcard) when deleting an attribute name/value
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• Valid Item number or valid Company/item number when unassigning name/value to an item. Wildcards
can be used.

Note: To unassign Attributes from Global Items and other items with the same name, specify two Rows:
one with Company and one without Company.

Example:

SFCIU_saitem_saattachment
You can use this file format to assign Image/Text/File/URL attachments to items by Attachment Name
and add Text Attachment Content. Additionally, you can add URL attachment content. The columns
are:

• Company
• Item Number
• ImagePrimary
• ImageSecondary
• Image3
• Text Name1
• Text Desc1
• Text Content1
• Text Name2
• Text Desc2
• Text Content2
• File Name1
• File Name2
• URL Name1
• URL Desc1
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• URL Content1
• URL Name2
• URL Desc2
• URL Content2

The processing options are:

• languagecode
• convertsymbolhtml

The required fields are:

• languagecode
• Required fields for assigning and Image/Text/File/URL attachment to items by attachment name:

• Valid Item Number or Company/Item name
• Image File attachment is valid
• At least one attachment name

• Required fields for adding text and URL attachments

• Text description/content
• URL description/content

• Required fields for assigning text and URL attachments to items

• Valid Item Number or Company/Item name
• Text description/content
• URL description/content

Example:

Example continued:

Example continued:
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SFCIU_saitem_saattachment_unassign_delete
You can use this file format to unassign Attachment(s) from Items by Attachment Name and delete
Attachments (which also UNASSIGNS).

Note: The Catalog Import Utility only supports adding Text/URL Attachments and not Image/Files.
Therefore, if Image/File Attachments are deleted, then the Storefront Catalog application can be used
to Upload/Add Attachments.

The columns are:

• Company
• Item Number
• Image Primary
• Image Secondary
• Image3
• Text Name1
• Text Name2
• File Name1
• File Name2
• URL Name1
• URL Name2

The processing options is languagecode. .

The required fields are:

• languagecode
• At least 1 Attachment Name (wildcard available)
• Valid Item Number or Company/Item Number when unassigning attachments from items.
• Empty Company/Item Number for deleting Image, Text, File, and URL Attachments

Example:
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SFCIU_saitem_sacategory
You can use this file format to add Catalog Categories and Subcategories to a Catalog with category
sequence numbers supported at all levels. You can assign Items to Categories and set item sequence
numbers at the category level. The columns are:

• Catalog
• Level 1
• Seq 1
• Level 2
• Seq 2
• Level 3
• Seq 3
• Level 4
• Seq 4
• Level 5
• Seq 5
• Company
• Item Number
• Item Seq

The processing options are:

• languagecode
• convertsymbolhtml

The required fields are:

• languagecode
• Category
• At least one level consecutive Category Names (no gaps between Levels) when adding a Category
• A valid Item Number or Company/Item Number and at least one level when assigning an Item to a

Category

Example:
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SFCIU_saitem_sacategory_unassign_delete
You can use this file format to delete Catalogs, delete Categories and SubCategories from a Catalog,
and unassign Items from Categories. The columns are:

• Catalog
• Level 1
• Level 2
• Level 3
• Level 4
• Level 5
• Company
• Item Number

The processing option is languagecode.

The required fields are:

• languagecode
• A valid Catalog when deleting a Catalog
• At least one Level or wildcard consecutive Category Names (no gaps between Levels) when deleting

Categories.
• A valid Item Number or Company/Item Number or wildcard, at least one Level or wildcard Consecutive

Category Names (no gaps between Levels) when unassigning items from a Category.

Example:
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SFCIU_sacategory_saattachment
You can use this file format to assign valid Attachments to valid Catalogs and Categories. This file
format does not add Catalogs and Categories and does not add Attachment content. The columns are:

• Catalog
• Level 1
• Level 2
• Level 3
• Level 4
• Level 5
• Image Primary
• Image Secondary
• Image 3
• Text Name 1
• Text Name 2
• File Name 1
• File Name 2
• URL Name 1
• URL Name 2

The processing option is convertsymboltohtml.

The required fields are:

• A valid Catalog
• At least one valid Attachment Name when assigning an Attachment to a Catalog.
• At least one valid level, at least one valid Attachment Name, and consecutive category names (no

gaps between Levels), when assigning an attachment to a Category.

Example:
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Example continued:

SFCIU_sacategory_saattachment_unassign
You can use this file format to unassign Attachments from existing Catalogs and Categories. The
columns are:

• Catalog
• Level 1
• Level 2
• Level 3
• Level 4
• Level 5
• Image Primary
• Image Secondary
• Image 3
• Text Name 1
• Text Name 2
• File Name 1
• File Name 2
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• URL Name 1
• URL Name 2

There are no processing options for this file format.

The required fields are:

• At least one valid Attachment Name or wildcard when you unassign an attachment from a Catalog.
• At least one valid level or wildcard and at least one Attachment Name or wildcard when you unassign

an attachment from a Category.

Example:

Example continued:

SFCIU_account
You can use this file format to add accounts. The columns are:

• Company
• Customer
• UserId
• Password
• Question
• Answer
• Account Profile
• Corporate Group
• Ship To Group
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• Contact Name
• Email Address
• Bcc
• Phone
• Domain

The required fields are:

• Valid UserID
• Valid Password (must be 8 to 32 characters)
• Valid Question and Answer
• Valid Account Profile
• Valid Contact Name
• Valid Email Address

Note: If the Account Profile is for ACCOUNTTYPE_B2B_CORPGROUP, then the Corporate Group
must be specified and must be valid. If the Account Profile is for ACCOUNTTYPE_B2B_SHIPTOGROUP,
then the Ship To Group must be specified and must be valid.
If SystemOption MultiSite is Active and Domain EMPTY, Domain is DEFAULTED to default site domain.
If SystemOption MultiSite is Active and Domain NOT EMPTY, the Domain must be valid.

Example:

Example continued:

SFCIU_account_delete
You can use this file format to delete accounts. This file format does not delete Shopper Accounts
(Active Budget/Approval Accounts). The columns are:

• Company
• Customer
• UserId
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• Domain

The required fields are:

• A valid Company
• A valid UserId

Note: To delete Corporate Group Accounts, you must include a record that has Field Customer=EMPTY.
This will delete a Corporate Group Account with any Customer.

Note: If SystemOption MultiSite is Active, the Domain must be a WildCard or a valid Domain.

Example:

Catalog import utility temporary tables
These are the temp tables associated with each file format.

Associated TempTable(s)SFCIU File Format

ciu_saitemSFCIU_saitem

ciu_saitem_saattribute_unassign_item
ciu_saitem_saattribute_unassign_category

SFCIU_saitem_saattribute_unassign_delete

ciu_saitem_saattribute_value_delete
ciu_saitem_saattribute_delete

ciu_saitem_saattributeSFCIU_saitem_saattribute

ciu_saitem_saattachment_unassign_item
ciu_saitem_saattachment_unassign_category
ciu_saitem_saattachment_delete

SFCIU_saitem_saattachment_unassign_delete

ciu_saitem_saattachmentSFCIU_saitem_saattachment
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Associated TempTable(s)SFCIU File Format

ciu_saitem_sacategory_unassign_item
ciu_saitem_sacategory_unassign_attachment

SFCIU_saitem_sacategory_unassign_delete c

ciu_saitem_sacategory_unassign_attribute
ciu_saitem_sacategory_delete

ciu_saitem_sacategorySFCIU_saitem_sacategory

ciu_sacategory_saattachment_unassignSFCIU_sacategory_saattachment_unassign

ciu_sacategory_saattachmentSFCIU_sacategory_saattachment

ciu_account_deleteSFCIU_account_delete

ciu_accountSFCIU_account

Management of SFCIU files and processing statusciu_dataimport_status

Management of SFCIU files and processing mes-
sages

ciu_dataimport_message
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