Database
This section provides you with solutions to some messages you might receive when you try to access the Lawson database.
Message
“Can't communicate with database. No space left on device.”
Possible cause
The system is running out of semaphores.
Solution
Increase the number of semaphores available in the kernel, then relink the kernel and reboot.
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Message
“Can't communicate with database server, no such file or directory.”
Possible cause
The database server is not running. The server might not have been started, it might have been stopped, or it might have terminated normally or abnormally.
Solution
Access the ladb.log file to see if the database server stopped
or if it was not started. If the database server is not running, perform startlaw
.
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Message
“Data and Index date/timestamps.”
Possible cause
Data or index files, or both, are no longer synchronized with the dictionary due to an incomplete restoration or reorganization.
Solution
Complete the restoration or reorganization, then run setdbstamp.
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Message
“DB Error: Dictionary in administration mode (11).”
Possible cause
A blddbdict or dbreorg is in progress.
Solution
Wait for the blddbdict or dbreorg to complete.
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Message
“Dictionary program timestamp mismatch.”
Possible cause
The database was reorganized and changes were made to the database file that the program uses.
Solution
Recompile all programs that use that database file.
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Message
“Too many open foreign servers.”
Possible cause
The number of foreign servers in $LAWDIR/system/ladb.cfg is not set high enough. Foreign servers include the Lawson remote database server (tcpdbm).
Solution
Increase the FOREIGN
variable in the ladb.cfg
file.