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This document describes the Process Modeler Workbench that is used to graphically create and maintain
the different types of diagrams that make up an enterprise model.

About this guide
This document is assembled from online Help topics.

The functionalities you can use to create and maintain the models, are basically the same for all, and
explained in Functions used in all diagram types and Operations used in all diagram types.

It is assumed that you have a general understanding of Infor LN Infor Enterprise Modeler and understand
these topics:
 ▪ Enterprise Structure Diagram (p. 15)

▪ Business Control Diagram (p. 17)
▪ Business Function Diagram (p. 21)
▪ Business Process Diagram (p. 23)
▪ Entity Relationship Diagram (p. 31)

Underlined terms indicate a link to a glossary definition. If you view this document online and you click
the underlined text, you jump to the glossary definition at the end of this document.

For details, see the Infor LN Infor Enterprise Modeler Online Help.

Comments?
We continually review and improve our documentation. Any remarks/requests for information concerning
this document or topic are appreciated. Please e-mail your comments to documentation@infor.com .

In your e-mail, refer to the document number and title. More specific information will enable us to process
feedback efficiently.

Contacting Infor
If you have questions about Infor products, go to Infor Concierge at https://concierge.infor.com/  and
create a support incident.

If we update this document after the product release, we will post the new version on the Infor Support
Portal. To access documentation, select Search Browse Documentation. We recommend that you
check this portal periodically for updated documentation.

If you have comments about Infor documentation, contact documentation@infor.com .
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Process Modeler Workbench
The Process Modeler Workbench is used to graphically create and maintain the different types of
diagrams that make up an enterprise model. The enterprise model consists of these parts:
 ▪ The highest level is the enterprise-structure model which is represented by the

enterprise-structure diagram that visualizes the multicompany structure of the Company.

▪ The next level is the business model which is a subset of following diagrams that are maintained
in the repository.

▪ Business control diagram; visualizes the primary process that takes place and the business
functions that are used to control that process.

▪ Business-function diagram; visualizes the multilevel relationships between business
functions.

▪ Business-process diagram; visualizes a business objective.

▪ Then there is the data model which is represented by the Entity Relationship Diagram. This
diagram provides information about the physical and/or logical data model of the Infor LN
package combination to which the Enterprise Model applies.

How to use the Process Modeler Workbench
The functionalities you can use to create and maintain the models are basically the same for all and
explained in Functions used in all diagram types and Operations used in all diagram types. The diagram
specific information is explained in:
 ▪ Enterprise Structure Diagram (p. 15)

▪ Business Control Diagram (p. 17)
▪ Business Function Diagram (p. 21)
▪ Business Process Diagram (p. 23)
▪ Entity Relationship Diagram (p. 31)
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The explanation of all buttons, icons and graphical objects that are available in the Process Modeler
Workbench can be found in the Legend.

Functions used in all diagram types
Drop-down menus

DescriptionMenu Options

To undo the last user action.Edit -> Undo

To reverse the last Undo command.Edit -> Redo

To delete the currently selected diagram objects from the diagram and
copy these objects to the diagram clipboard.

Edit -> Cut

To copy the currently selected diagram objects from the diagram and
copy these objects to the diagram clipboard.

Edit -> Copy

To copy the diagram objects from the diagram clipboard into the dia-
gram.

Edit -> Paste

To delete the currently selected diagram objects from the diagram.Edit -> Delete

To select all diagram objects in the diagram.Edit -> Select All

All To deselect all selected objects in the diagram.Edit -> Deselect

To show or hide the diagram header.View -> Show Header

To show or hide the external codes that are setup in the graphical object
properties.

View -> Show External Codes

To increase zoom level.View -> Zoom in

To decrease zoom level.View -> Zoom out

To set the zoom to the default value 100.View -> Actual size

To resize the diagram so it is completely visible.View -> Zoom to fit
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To switch on or off the automatic alignment of objects based on a fixed
grid.

View -> Snap to Grid

The Action drop-down menu contains diagram specific options which
can be found here:

Action drop-down menu

▪ Enterprise Structure Diagram Action drop-down menu

▪ Business Control Diagram Action drop-down menu

▪ Business Function Diagram Action drop-down menu

▪ Business Process Diagram Action drop-down menu

To insert a text block that contains information regarding the diagram
such as diagram code, description, version, creation date and last
modification date.

Insert -> Info Block

To insert a note that is directly readable in the diagram.Insert -> Annotation

The other graphical objects that can be selected in the Insert drop-down
menu differ per diagram type and are explained here:

Insert -> ....

▪ Enterprise Structure Diagram graphical objects
▪ Business Control Diagram graphical objects
▪ Business Function Diagram graphical objects
▪ Business Process Diagram graphical objects

▪ Entity Relationship Diagram graphical objects

To align all selected graphical objects vertically, relative to the top of
the object that is most at the top.

Arrange -> Align -> Top

To align all selected graphical objects vertically, relative to the middle
of all selected objects.

Arrange -> Align -> Middle

To align all selected graphical objects vertically, relative to the bottom
of the object that is most at the bottom.

Arrange -> Align -> Bottom

To align all selected graphical objects horizontally, relative to the left
of the object that is most to the left.

Arrange -> Align -> Left

To align all selected graphical objects horizontally, relative to the middle
of all selected object.

Arrange -> Align -> Center

To align all selected graphical objects horizontally, relative to the right
of the object that is most to the right.

Arrange -> Align -> Right
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To resize the width of all selected graphical objects to the widest of all
selected objects.

Arrange -> Make Same Size ->
Width

To resize the height of all selected graphical objects to the highest of
all selected objects.

Arrange -> Make Same Size ->
Height

To resize the height and width of all selected graphical objects to the
highest and widest of all selected objects.

Arrange -> Make Same Size ->
Both

To align all selected graphical objects with the same horizontal distance
from each other.

Arrange -> Space Evenly ->
Across

To align all selected graphical objects with the same vertical distance
from each other.

Arrange -> Space Evenly ->
Down

Operations used in all diagram types
These operations are generic for all diagram types:

DescriptionOperation

From the Insert drop-down menu or the Diagram Objects toolbar select rela-
tionship or trigger. Click and hold the left mouse key on the first graphical

Insert a relationship/trig-
ger

object that you want to connect, then move the cursor to the destination object
and release the left mouse button.

From the Insert drop-down menu or the Diagram Objects toolbar select the
desired graphical object. Move the cursor to the first a location in the diagram
and click once.

Insert all other graphical
objects

Select one or more graphical objects and drag them to the new location.Move a graphical object

Select the graphical object and drag one of the black squares positioned at
the outline of the object. To change the width of the object by dragging the

Modify the size of a
graphical object

black squares positioned at the left or the right side. To change the height of
the object by dragging the black square positioned at the top or the bottom.
To change both the width and the height, drag the black square at the top or
the bottom. To change both the width and the height, drag the black square
positioned at the corner. Not all diagram objects are resizable!
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Right-click the graphical object. Select Text or Model Text. A text window is
displayed where you can enter your text. In this text window, from the Refer-

Link a text to a graphical
object

ence menu you can select Zoom session. A list of possible options is displayed.
You can add references to other Dynamic Enterprise Modeler content or Infor
LN sessions in the text. To exit the text window click the save changes and
exit button. Once a Text or Model Text is linked to a graphical object, a Text-
or Model Text icon is linked to the diagram object. A double click on this icon
also opens the text window

Right-click a graphical object, select Properties to view/modify the properties
of the graphical object.

View/Modify the proper-
ties a graphical object

Right-click the diagram canvas outside an graphical object and select Proper-
ties to view/modify the properties of the diagram.

View/Modify the proper-
ties of the diagram

Operations used in the specific diagram types:
 ▪ Operations used Enterprise Structure Diagram

▪ Operations used in Business Control Diagram
▪ Operations used in Business Function Diagram
▪ Operations used in Business Process Diagram

▪ Operations used in Entity Relationship Diagram

Toolbars
The available buttons on the toolbars:
 ▪ Top Toolbar (p. 35)

▪ Diagram Objects Toolbar (p. 36)
▪ Align Toolbar (p. 37)
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Enterprise Structure Diagram
On a geographical map Enterprise Units can be located to create a graphical representation of the
organization and its entities such as warehouses, departments or work centers. An enterprise unit can
also represent an external business partner. Insert an Enterprise Unit Relationship between enterprise
units and link a category to the relationship to define if it is for instance a goods or a money flow.

To describe in more detail the operations within the enterprise unit, link a business control diagram to
that unit.
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Enterprise Structure Diagram graphical objects

DescriptionMenu option 

To insert an Enterprise Unit.Insert -> Enterprise Unit

To insert an Enterprise Relationship with a descrip-
tion to identify the relation between two Enterprise
Units.

Insert -> Enterprise Relationship

Enterprise Structure Diagram Action dropdown menu

DescriptionMenu option 

To switch on or off the background map that is set
up in the diagram properties.

Action -> Show Background

Operations used Enterprise Structure Diagram

DescriptionOperation

Right-click the Enterprise Unit and select Properties.
In properties select a business model and a Busi-

Link a business control diagram to an enterprise
unit

ness Control Model. A Linked Business Control Di-
agram icon is linked to the Enterprise Unit.

Right-click the Enterprise Relationship and select
Reverse Direction.

Modify the direction of the Enterprise Relationship

16 | Infor LN | Process Modeler Workbench User Guide
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Business Control Diagram
In a business control diagram, Business Functions are used to describe the operations that take place
in a specific enterprise unit. When those Business Functions fall within the circle of influence of the
enterprise unit, they are grouped together in an Area. External Agents (such as customers, suppliers,
governments) are added to indicate their influence on the operations both located outside the Area.
Arrows are drawn between External Agents and Business Functions to indicate what triggers the
operation. The results from this operation can trigger the next operation in another business function
and arrows are drawn between business functions. The arrows are called Triggers.

Further detail in the operations can be added by linking Business Processes to Business Functions
using Transformation Rules. The transformation rules are created in the repository through the Rules
(tgbrg7500m000) session. For more information on the creation of transformation rules, see the Infor
LN Session Help .

At the bottom of the diagram a flow represents the primary goods or money flow.

The repository is the modeling environment in which the Business Control Diagrams are defined. These
business control diagrams serve as a basis on which you can create a business model(s).
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Business Control Diagram graphical objects

DescriptionMenu option 

To insert a Trigger between the other graphical
objects in the diagram.

Insert -> Trigger

To insert a business function.Insert -> Function

To insert External Agents such as customers,
suppliers and governments that affect the Business
Functions.

Insert -> External Agent

To insert an Area to visualize related business
functions.

Insert -> Area

To insert a Flow to visualize the goods flow, finan-
cial flow or information flow.

Insert -> Flow

To insert a Customer Order Decoupling Point to
be located on the Flow.

Insert -> CODP

To insert a Buffer, representing a queue or a stock
point to be located on the Flow.

Insert -> Buffer

To insert a Primary Activity such as receive goods
or production to be located on the Flow.

Insert -> Primary Activity

Business Control Diagram Action drop-down menu

DescriptionMenu option 

To make parts of the Business Control Diagram
visible or not, based on the categories of the
Business Functions.

Action -> Function Categories

To link child Business Control Diagrams to the
current diagram.

Action -> Children

Operations used in Business Control Diagram
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DescriptionOperation

Right-click the Trigger, point to Type and select one
of one of these options:

Modify the Type of the Trigger

▪ Free (midpoints can be added)
▪ Direct
▪ Z-style
▪ Horizontal-Vertical
▪ Vertical-Horizontal

Right-click the Trigger and select Reverse direction
or Bidirectional

Modify the direction of the Trigger

Right-click the Trigger and select Add Midpoint to
change the route of the Trigger. This is only possible

Add a Midpoint to a Trigger

if the Type of the Trigger is Free. You can add as
many Midpoints as required.

Right-click the Business Function, select Time
Trigger or Normal to switch the time trigger on or
off.

Add or remove a Time Trigger

Right-click the Business Function/external agent,
select Category. The category determines the color

Modify the Category of the Business Function/Ex-
ternal Agent/Buffer/ Primary Activity

of the business function/external agent/Buffer/Pri-
mary Activity.

If a transformation rule exists for a Business Func-
tion, a business process icon is linked to this func-

View/edit the Business Process linked to the Busi-
ness Function

tion. Double-click this icon, a list of linked business
processes is shown. Click "Go to Details" in front
of the appropriate process.

Right-click the Area/CODP and select Properties.
In properties change the background color.

To modify the color of the Area/CODP

Right-click the Flow, point to Type and select one
of these options:

To modify the Flow Type

▪ Goods
▪ Information
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▪ Financial

Right-click the Enterprise Relationship and select
Reverse Direction

Modify the direction of the Enterprise Relationship
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Business Function Diagram
For a Parent Business Function a Business Function Diagram can be created to represent the child
Business Functions. Icons indicate if a Wizard is available to implement the Business Function.

The repository is the modeling environment in which the Business Functions are defined. The Business
Function Diagrams from the Repository serve as a basis on which to create a business model (s). The
Business Function Diagrams in the Business Model is used to indicate the Optimization Relations
between Business Functions. This is to represent either a variant (replacement functionality) or an option
(additional functionality. Phases can be linked to Business Functions to indicate in which phase the
functions are implemented and used. This is represented by colored circles linked to the Business
Functions.
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Business Function Diagram graphical objects

DescriptionMenu option 

To insert a Business Function.Insert -> Function

To insert an Optimization Relationship.Insert -> Optimization Relation-
ship (only available in a Busi-
ness Model)

Business Function Diagram Action drop-down menu

DescriptionMenu option 

To make parts of a selection of optimizations visi-
ble. Optimization phases must be linked to the
Business Functions.

Action -> Phases by Model

Operations used in Business Function Diagram

DescriptionOperation

Right-click the business function, click Phases and
modify the phases that this function is using. The

Link Optimization Phases to a business function

Phases icon is linked to the Business Function. Also
colored circles become visible depending on the
selected phases.

Right-click the Business Function, click Properties
and set up a wizard. The Wizard icon is linked to
the business function.

Link a Wizard to a business function

Double-click the Wizard icon that is linked to the
Business Function. The wizard is started.

Execute a Wizard linked to a business function

22 | Infor LN | Process Modeler Workbench User Guide

Business function diagram



Business Process Diagram
A Business Process Diagram is the lowest level of representation of the business operations. It represents
the flow of activities (manual or application) users have to run from start to finish. Control Activities are
used to represent the choices users have to make in that process.

Sub Business Processes are used to bring sufficient detail but still keep the structure understandable.

Linking Roles to Business Processes or to business process activities authorizes employees linked to
those roles to run the activities.

Business Processes are created and maintained in the repository and serve as a basis on which to
create a business model (s). Changes you make in the repository reflect in the Business Models. In a
Business Model you can modify the authorization that is setup in the Repository, thus creating enterprise
unit specific authorization setup.

The Business Process Diagram is based on the Petri nets modeling conventions.

Business Process Diagram graphical objects

DescriptionMenu option

To insert an Activity that represents work to do in
the form of:

Insert -> Activity

▪ Manual activity; a not (in LN) automated task
▪ Business process; links a sub-process
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▪ Application; starts an application of the select-
ed component

To insert a State that defines a particular point in
time:

Insert -> State

▪ Begin; always the start of a business process
▪ End; always the end of a business process

▪ Normal; all other states in the business pro-
cess

To insert a Control Activity that represents a deci-
sion moment and can be:

Insert -> Control Activity

▪ XOR; only one of the paths must be executed
▪ OR; one or more of the paths can be executed
▪ AND; all paths must be executed

▪ JOIN; to join the paths split by XOR, OR or
AND

To insert a Relationship. Valid relations:Insert -> Relationship

▪ Between State and Activity
▪ Between State and Control Activity

24 | Infor LN | Process Modeler Workbench User Guide

Business process diagram



Business Process Diagram Action dropdown menu

DescriptionMenu option 

Renumbers the external codes used in the dia-
gram.

Action -> Renumber External Codes

Checks the syntax/validity of the business process;
see Business Process Syntax Checks for more
information.

Action -> Syntax Check

Links Roles to the business process.Action -> Roles

Operations used in Business Process Diagram

DescriptionOperation

Right-click the State, point to Type and select one
of these options:

Modify the State Type

▪ Begin; always the start of a business process
▪ End; always the end of a business process

▪ Normal; all other states in the business pro-
cess

Right-click the Activity, select Properties. In the
properties setup a Support Application. A Support

Link a Support Application to an Activity

Applications icon is linked to the Activity. Double-
clicking this icon shows a list with Support Applica-
tions from which you can start the application.

Right-click the Activity, select Properties. In the
properties setup an AO Document. An AO Docu-

Link an AO Document to an Activity

ment icon is linked to the Activity. Double-clicking
this icon opens the AO Document.

Right-click the Activity/Control Activity, select
Properties. In the properties setup an URL. A Linked

Link a URL to an Activity/Control Activity

URL icon is linked to the Activity/Control Activity.
Double-clicking this icon opens the URL.
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Right-click the Activity/Control Activity, select Roles
by Activity. Add or delete Roles, or click "Go to De-

Link a Role to an Activity/Control Activity

tails" in front of the Role to modify the authorization
level to:

▪ No authorization
▪ Display authorization
▪ Display/Print authorization
▪ Modify/Display/Print authorization
▪ Insert/Modify/Display/Print authorization
▪ Full authorization
A Linked Roles on Activity Level icon is linked to
the Activity/Control Activity. Double-clicking this
icon opens the session to modify the Roles by Ac-
tivity.

Right-click the Activity, select Sub Applications.
Double-click ‘All possible subapplications for …’, a

Activate Sub Application Authorization

list unfolds. Highlight a Sub Application and from
the appropriate menu select Add subapplications
as modeled Subapplication. The Sub Applications
icon is linked to the Activity.

Double-click the Sub Applications icon linked to the
Activity. Highlight the Sub Application and from the

Modify Sub Application Authorization

Change authorization menu select one of these
options:

▪ No authorization
▪ Display authorization
▪ Display/Print authorization
▪ Modify/Display/Print authorization
▪ Insert/Modify/Display/Print authorization
▪ Full authorization
Or use one of the appropriate buttons.

Double-click the Sub Applications icon linked to the
activity.

Link Specific Role Authorization to a Sub Application

1. To change the authorization level for a Role
that is already linked to the Activity, highlight
the Role, holding the Ctrl-key, also highlight
the Sub Application and from the Specific
menu select Link Roles to modeled Subappli-
cations. The Role appears underneath the Sub
Application.
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2. To change the authorization level for a Role
that is not yet linked to the Activity, highlight
a sub application and from the Specific menu
select Link unmodeled Roles to modeled
Subapplications. The Role appears under-
neath the Sub Application.

For both 1 and 2, highlight the new line and from
the Change authorization menu select one these
options:

▪ No authorization
▪ Display authorization
▪ Display/Print authorization
▪ Modify/Display/Print authorization
▪ Insert/Modify/Display/Print authorization
▪ Full authorization
Or use one of the appropriate buttons.

Right-click the Control Activity and point to Type,
select one of these options:

Change Control Activity Type

▪ XOR; only one of the paths must be executed
▪ OR; one or more of the paths can be executed
▪ AND; all paths must be executed

▪ JOIN; to join the paths split by XOR, OR or
AND

Right-click the Relationship, point to Type. Select
one of these options:

Modify the Type of the Relationship

▪ Free (midpoints can be added)
▪ Direct
▪ Z-style
▪ Horizontal-Vertical
▪ Vertical-Horizontal

Right-click the Relationship and select Reverse di-
rection.

Modify the direction of the Relationship

Right-click the Relationship and select Add Midpoint
to change the route of the Relationship. This is only

Add a Midpoint to a Relationship

possible if the Type of the Relationship is Free. You
can add as many midpoints as required.
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Business Process Syntax Checks

CheckSyntax Error

Static conditions are only allowed on relationships that flow from an OR,
XOR, AND Control Activity to an Activity or a JOIN Control Activity. So-

Error: [object type] [external
code] [description]: Static

lution: Remove the static conditions from the properties of the relationship
concerned.

condition not allowed on out-
going arrow

Except for the Begin State each other State must at least have one in-
coming arrow. Solution: Add a Relationship between an Activity or a
Control Activity that is missing an outgoing arrow.

Error: state [external code]
[description]: Missing incom-
ing arrow

Except for the End State each other State must have one outgoing arrow.
Solution: Add a Relationship between an Activity or Control Activity that
is missing an incoming arrow.

Error: state [External code]
[description]: Missing outgoing
arrow

All Activities and JOIN type Control Activities must have one outgoing
arrow. Solution: Add a Relationship between the Activity or the JOIN
Control Activity and a state that is missing an incoming arrow.

Error: [object type] [external
code] [description]: Missing
outgoing arrow

A State can only have one outgoing arrow. Solution: Remove all but one
of the outgoing Relationships that are linked to the mentioned State.

Error: state [external code]
[description]: Too many outgo-
ing arrows" Consider using a Control Activity to split the business process in multiple

paths.

Only one arrow can exist between the same State and Activity (or Control
Activity). Solution: Remove the duplicate arrow(s) between the listed
State and (Control) Activity.

Error: state [external code]
[description]: Duplicate incom-
ing arrow

An Activity can only have one outgoing arrow. Solution: Remove all but
one of the outgoing Relationships that are linked to the mentioned Activ-
ity.

Error: activity [external code]
[description]: Too many outgo-
ing arrows

All Control Activities with type OR, XOR, AND must at least have two
outgoing arrows. Solution: Add an outgoing Relationship from the Control
Activity to a state that is missing an incoming.

Error: control [external code]
[description]: Too few outgo-
ing arrows

A JOIN Control Activities must at least have two incoming arrows. Solu-
tion: Add an incoming Relationship from the JOIN Control Activity to a
state that is missing an outgoing arrow.

Error: control [external code]
[description]: Too few incom-
ing arrows
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Each business process must start with only one Begin State. Solution:
Ensure the business process starts with a state and change the State
type to ‘Begin’.

Error: Missing begin state

Each Activity and Control Activity should be reachable from the Begin
State. Solution: Ensure all paths in the business process starts from a
Begin State and all necessary relationships are drawn.

Error: [object type] [external
code] [description]: Not
reachable from begin state

Each business process must start with only one Begin State. Solution:
Ensure the business process starts with only one state of the type ‘Begin’.

Error: Too many begin states

Each business process must start with only one Begin State. This means
that there can be no incoming arrow for a begin state. In case of a loop

Error: state [external code]
[description]: Incoming arrow
not allowed an arrow return to the begin state. Solution: Ensure the business process

starts with a begin state and remove any other begin states.

Each business process must end with one state and this must be of the
‘End’ type. Solution: Ensure the business process ends with one state
and change the State type to ‘End’.

Error: Missing end state

Each business process path should end in an End State. Solution: Ensure
all paths in the business process end in an End State and all necessary
relationships are drawn.

Error: [object type] [external
code] [description]: Cannot
reach end state

Each business process path should end in an End State. Solution: Ensure
all paths in the business process end in an End State and remove any
arrow that flows out of the end state.

Error: state [external code]
[description]: Outgoing arrow
not allowed

Each business process path should end in an End State. A business
process can have more than one end state, but this is not common. Thus

Warning: Too many end
states

a warning is displayed. Solution: Ensure all paths in the business process
end in the correct End State.
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Entity Relationship Diagram
The Entity Relationship Diagram represents Entity Types for which data must be stored in the Infor LN
Application, such as Purchase Orders, Customers and Projects. Entity Types that represent database
tables are placed in the diagram. Relationships are drawn between the Entity Types and their graphical
representation indicates the cardinality of the relationship (one to one, one to many or many to many)
and the relation is optional.

Using Decomposed Diagrams you can link another Entity Relationship Diagram to one of the Entity
Types in a diagram, thus indicating all the other relationships of that Entity Type. For instance in a
diagram created for Purchase Orders, there is an Entity Type for Items. If you would draw all the Entity
Types that are linked to the Item Entity, the diagram becomes unreadably big. By linking an Decomposed
Diagram of the Item Entity, the Purchase Order Diagram is readable.

Entity Relationship Diagram graphical objects

DescriptionMenu option

Inserts an Entity that represents an object for which
you must record information. Select one of the fol-
lowing:

Insert -> Entity Type

▪ Normal; Logical entity type; a meaning to the
real world and is comprised of one or more
physical entity types

▪ Physical entity type; database tables in the
Infor applications.
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▪ Associative; used to link other entity types.

Inserts a relationship between two entity types. The
cardinality of the relationship defines the expected

Insert -> Relationship(1:n)

number of related occurrences for each of the two
entity types

Inserts a subtype relationship between two entity
types (a subtype and a supertype) that is used to

Insert -> Subtype Relationship

indicate that the supertype’s attribute also apply to
(are inherited by) the subtype.

Operations used in Entity Relationship Diagram

DescriptionOperation

Right-click the Entity Type, point to Type. Select
one of these options:

Modify the Type of the Entity Type

▪ Normal

▪ Associative; an octagon is added inside the
graphical object

Right-click the Entity Type, select Properties. Link
the appropriate Decomposed Diagram to the Entity
Type. The Entity Type graphical object is embossed.

Link a Decomposed Diagram to the Entity Type

Right-click the Entity Type, select Edit linked ERD.Edit/view the Decomposed Diagram linked to the
Entity Type

Right-click the Entity Type, select Tables. Link the
appropriate Infor LN tables to the Entity Type. A
Linked Tables icon is attached to the Entity Type.

Link tables to the Entity Type

Right-click the (Subtype) Relationship, point to
Type. Select one of these:

Modify the Type of the (Subtype) Relationship

▪ Free (midpoints can be added)
▪ Direct
▪ Z-style
▪ Horizontal-Vertical
▪ Vertical-Horizontal
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Right-click the Relationship, point to Cardinality.
Select one of these:

Modify the cardinality of the Relationship

▪ One to One (midpoints can be added)
▪ One to Many
▪ Many to Many

Right-click the (Subtype) Relationship and select
Reverse direction.

Modify the direction of the (Subtype) Relationship

Right-click the (Subtype) Relationship and select
Add Midpoint to change the route of the Relation-

Add a Midpoint to a (Subtype) Relationship

ship. This is only possible if the Type of the Rela-
tionship is Free. You can add as many midpoints
as required.

Right-click the Relationship and select one of the
following:

Indicate an optional Relationship between two Entity
Types

▪ Optional From To
▪ Optional To From
A circle is displayed at the end of the Relationship
that is indicated as optional.

Right-click the Entity Type, select Properties. Now
add/modify the description From-To or To-From.

Add/modify the description on one and/or the other
side of the Relationship

The descriptions display in the diagram and can be
moved around.
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Top Toolbar

DescriptionButton 

To save the diagram and close the workbench

To save the diagram

To return to the last saved version of the diagram

To delete the current selected diagram objects
from the diagram

To print the diagram on a local printer

To undo the last user action

To reverse the last Undo command

To increase zoom level

To decrease zoom level

To set the zoom to the default value 100
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To resize the diagram to make it completely visible

Diagram Objects Toolbar
Generic buttons

The Diagram Objects toolbar shows the graphical objects you can insert in the diagram. These buttons
are generic for all diagram types:

DescriptionButton

To turn on or off the automatic creation of a relation-
ship (connector) between an existing (selected) di-
agram object and a newly inserted diagram object

To switch to the ‘select mode’ to be able to select
one or more graphical objects in the diagram

To insert a graphical object that contains information
regarding the diagram like diagram code, descrip-
tion, version, creation date and last modification
date

To insert a note that is directly readable in the dia-
gram

The diagram specific buttons in the Diagram Objects Toolbar are explained here:
 ▪ Diagram Objects Toolbar (p. 36)

▪ Business Control Diagram objects toolbar
▪ Business Function Diagram objects toolbar
▪ Business Process Diagram objects toolbar
▪ Entity Relationship Diagram objects toolbar
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Align Toolbar

DescriptionButton 

To align all selected graphical objects vertically,
relative to the top of the object that is most at the
top

To align all selected graphical objects vertically,
relative to the middle of all selected objects

To align all selected graphical objects vertically,
relative to the bottom of the object that is most at
the bottom

To align all selected graphical objects horizontally,
relative to the left of the object that is most to the
left

To align all selected graphical objects horizontally,
relative to the middle of all selected object

To align all selected graphical objects horizontally,
relative to the right of the object that is most to the
right

To align all selected graphical objects with the
same horizontal distance from each other

To align all selected graphical objects with the
same vertical distance from each other

To resize the width of all selected graphical objects
to the widest of all selected objects

To resize the height of all selected graphical ob-
jects to the highest of all selected objects

To resize the width and height of all selected
graphical objects to the widest and highest of all
selected objects
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Graphical objects used in all diagram types
Info block

The fields are automatically filled. The Diagram Name, Description, Version, Role and Category are
defined in the LN session where you create or modify the diagram properties.

Annotation

Icons used in all diagrams
Icons are graphical decorators linked to the diagram objects to indicate that certain data has been setup
for that object.
 

Text created for a graphical ob-
ject in the repository.

Text icon

Text created for a graphical ob-
ject in a business model.

Model Text icon

Graphical objects used in the Enterprise Structure
Model
Enterprise Unit
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The graphical representation of the enterprise unit, it can be changed by selecting a different category
in the enterprise unit properties. For each enterprise unit category a different image can be setup. The
description is an object that can be moved individually from the image.
 

Indicates that a business control
diagram has been linked to the
Enterprise Unit

Linked Business Control Diagram
icon

Enterprise Relationship

The graphical representation of a relationship between enterprise units. The description is an object that
can be moved individually from the line.

Enterprise Structure Diagram objects toolbar

DescriptionButton 

To insert an Enterprise Unit.

To insert an Enterprise Relationship with a descrip-
tion to identify the relation between two Enterprise
Units

Graphical objects used in the Business Control Model
Trigger

The graphical representation of a relationship between business functions or business functions and
external agents. The description is an object that can be moved individually from the line.
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Function

 
Indicates that business process-
es are linked to the business

Linked Business Process icon

function via a Transformation
Rule

Indicates that a Business function
created in the Business Func-

Linked Business Function icon

tions (tgbrg2500m000) session
have been linked.

Function with Timed Trigger

It indicates that the function either triggers itself completely at a fixed moment in time, for example
monthly. O that after receiving a trigger from anywhere else it waits to also trigger itself before actually
starting.

External Agent
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Represents External Agents such as customers, suppliers and governments that affect the Business
Functions

Area

Visualizes which functions are related and fall within the circle of influence of the enterprise unit. If the
area is moved, all graphical objects within that area are moved with it.

Flow

Shows the primary process controlled in the diagram. It can be represent a goods flow, financial flow or
information flow.

Customer Order Decoupling Point

A customer order decoupling point indicates up to what point in the material flow the product is tied to
a specific customer order.

Buffer

The graphical representation of a queue or a stock point to be located on the Flow
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Primary activity

Represents a primary activity such as receive goods or production to be located on the flow

Business Control Diagram objects toolbar

DescriptionButton

To insert a Trigger between the other graphical
objects in the diagram. An incoming Trigger repre-
sents the cause/origin of the Business Function.
The outgoing Trigger represents the result of an
action

To insert a business function

To insert External Agents such as customers, sup-
pliers and governments that affect the Business
Functions

To insert an Area to visualize related business
functions

To insert a Flow to visualize the goods flow, finan-
cial flow or information flow

To insert a Customer Order Decoupling Point to be
located on the Flow

To insert a Buffer, representing a queue or a stock
point to be located on the Flow

To insert a Primary Activity such as receive goods
or production to be located on the Flow
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Graphical objects used in the Business Function Model

Function

Represents a model item that defines relevant business issues and operations.
 

Indicates that a wizard is linked
to the business function

Wizard icon

Indicates that phases are linked
to the business function, only
available in a business model.

Phases icon

Indicates which phases are linked
to the business function, only
available in a Business Model.

Linked Phases icon

Optimization relationship

Represents the relation between two business functions and can only be used in a Business Model.
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Business Function Diagram objects toolbar

DescriptionButton 

To insert a Business Function

To insert an Optimization Relationship, only avail-
able in a Business Model.

Graphical objects used in the Business Process Model

Activity

An activity represents work to do in the form of:
 ▪ Manual activity; a not (in LN) automated task

▪ Business process; links a sub-process

▪ Application; starts an application of the selected component
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Indicates that an URL is linked to
the activity. Click on the icon to
start the URL

Linked URL icon

Indicates that an AO document
is linked to the activity.

Linked AO Document icon

Indicates that sub application
authorization has been setup for
the activity

Sub Applications icon

Indicates that Roles authorization
is setup for the activity

Linked Roles on Activity Level
icon

Indicates that a support applica-
tion has been linked to the activi-
ty

Support Application icon

State

Represents a particular point in time.

Control activity

A control activity represents a decision moment and can be one of the following:
 ▪ XOR; only one of the paths must be executed

▪ OR; one or more of the paths can be executed
▪ AND; all paths must be executed

▪ JOIN; to join the paths split by XOR, OR or AND
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Indicates that an URL is linked to
the activity. Click on the icon to
start the URL

Linked URL icon

Indicates that Roles authorization
is setup for the activity

Linked Roles on Activity Level
icon

Relationship

Indicates the flow of activities in the business process.

Valid relations:
 ▪ Between State and Activity

▪ Between State and Control Activity
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Business Process Diagram objects toolbar

DescriptionButton 

To insert an Activity to represent work to do

To insert a State that defines a particular point in
time

To insert a Control Activity that represents a deci-
sion moment

To insert a Relationship

Graphical objects used in the Entity Relationship Model

Entity type

Entity that represents an object for which you must record information. It can be one of the following:
 ▪ Normal; to represent a Logical entity (has a meaning to the real world and is comprised of one

or more physical entity types) or a Physical entity (database tables in the Infor LN applications)
▪ Associative; used to link other entity types

An entity in a diagram can have a Decomposed diagram linked to it. The graphical object is represented
embossed.
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Indicates that a database table is
linked to the Entity Type

Linked Tables icon

Relationship (1:n)

Represents the relationship between the entity types. The cardinality of the relationship defines the
expected number of related occurrences for each of the two entity types.

Subtype relationship

An indication that the supertype’s attribute also apply to (are inherited by) the subtype

Entity Relationship Diagram objects toolbar

DescriptionButton 

To insert an Entity that represents an object for
which you must record information

To insert a relationship between two entity types

To insert a subtype relationship between two entity
types
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appropriate menu
Commands are distributed across the Views, References, and Actions menus, or displayed as buttons.
In previous LN and Web UI releases, these commands are located in the Specific menu.

business control diagram
A graphic design that visualizes the primary process that takes place within an organization and shows
the business functions that are used to control that process.

business-function diagram
A graphic design that visualizes the multilevel relationships between business functions.

Note
The lowest level of business functions is used to set the value of static conditions. The level above the
lowest level is used to link business processes to business functions.

business model
A model that represents the organization.

There are two types of business models:
 ▪ Reference models apply to specific industries or business typologies.

▪ Project models apply to a specific organization.

business-process diagram
A graphic design that visualizes the business objective via a process structure in the Petri Net format.

data model
Consists of one or more entity relationship diagrams that together represent the way the information is
stored in a database.
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enterprise-structure diagram
A graphic design that shows the geographic location of enterprise units and the relationships between
these enterprise units in a multisite organization.

You can model various kinds of relationships between enterprise units; this includes goods flows, financial
flows, and information flows.

enterprise-structure model
An enterprise structure diagram that shows the geographic location of enterprise units and the
relationships between these enterprise units in a multisite organization.

repository
A library of model items.

LN distinguishes the following repositories:
 ▪ Business functions

▪ Business processes
▪ Business-control diagrams

In coherence with each other the repository model items can form a business model.

transformation rule
An expression imposing a unilateral dependency of business processes in relation to business functions.
By carrying out the rules, business processes are imported into the business model based on the
business functions that are already present.
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