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About this Guide

Document Summary
This document describes how to use the Infor Ming.le-LN Plug-in.

A number of screenshots in this document may be based on previous Web UI releases. They can differ
slightly from your Infor Ming.le-LN Plug-in screens. However, the described functionality is identical.

Contacting Infor
If you have questions about Infor products, go to the Infor Xtreme Support portal at http://www.infor.
com/inforxtreme.

If we update this document after the product release, we will post the new version on this Web site.
We recommend that you check this Web site periodically for updated documentation.

If you have comments about Infor documentation, contact documentation@infor.com.
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1Overview

Infor Ming.le-LN Plug-in is the web based client user interface for various Infor applications, such as:

• Infor LN
• Infor DEM

Infor Ming.le-LN Plug-in requires Infor LN and Enterprise Server 8.7 or higher.

Infor Ming.le-LN Plug-in runs in a page in Infor Ming.leTM . This page consists of an application area
with an application navigation menu bar.

The Infor Ming.le interface includes a panel with icons at the top of the page. These icons activate the
display of applications. To open the Infor Ming.le-LN Plug-in, click this icon:

To the right of the application area is a collapsible panel, which hosts a series of context applications,
such as LN Navigator, Documentation, Shortcuts, and Maps. Most of these context applications are
not specific to the Infor Ming.le-LN Plug-in. They are available in all applications in Infor Ming.le. See
the  Infor Ming.le User Guide.

The support for the context applications and the corresponding Infor Ming.le technology depends on
the combination of the LN application version and LN Tools version. See the Infor Enterprise Server
Web UI - Installation and Configuration Guide (U8715).

This figure shows the LN page in Infor Ming.le:
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Application area
When you start a session, the session is displayed in the application area. At the top of the application
area, an application navigation menu bar is displayed.

This figure shows an LN session that is started in the application area:
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This figure shows a DEM process that is started in the application area:
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Application navigation menu bar
This table shows the elements in the application navigation menu bar:

LN menu buttons are displayed if the LN menu browser is selected in your LN
user data. Click these buttons to open pull-down menus. These menus are used

LN menu buttons
or

to browse LN folder trees and start sessions. The menu buttons in the menu bar
depend on the start menu in your LN user data.DEM navigation

buttons
When you click a session on the menu, the session is displayed in the application
area and cannot be moved. When you press Ctrl while clicking the session, the
session starts in a separate window that can be moved and resized.
This figure shows the menu bar with LN menu buttons and pull-down menus:
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DEM navigation buttons are displayed if the DEM process browser is selected
in your LN user data.
If there are many menu buttons, a chevron button is displayed at the end of the
menu bar. Click this button to display a pull-down menu with the remaining menu
options.

This is the latest menu in the menu bar, or in the chevron button's pull-down
menu. See "The Options menu" on page 27.

Options menu

Session tabs
If you start multiple sessions, only the last session is displayed in the application area. The other
sessions are still open. For each open session, a tab is displayed below the application navigation
menu bar.

This figure shows an example:
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To switch to another open session, click the corresponding tab.

To close a session, click the  icon in the corresponding tab.

Recently closed sessions
Thumbnails of the recently closed sessions are stored in the application area. To view these thumbnails,
click the Recently Closed tab below the application navigation menu bar.

This figure shows an example:

To restart a session, click the corresponding thumbnail. The session is displayed in the application
area and cannot be moved. When you press Ctrl while clicking the thumbnail, the session starts in a
separate window that can be moved and resized.

To remove a thumbnail from the list of recently closed sessions, right-click the thumbnail and select
Remove.
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LN Navigator
You can use the LN Navigator context application to navigate to Infor LN applications, and find
applications on code or description. To start this context application, in the collapsible panel to the right
of the application area, click this icon:

Dependent on your user profile, the LN Navigator can contain these tabs:

• Processes
This tab contains the DEM Process Browser. Users can navigate to LN applications based on
predefined DEM process flows.

• LN
This tab contains a folder tree to navigate through the LN menu structure, and start sessions.

• Options
Use this tab to perform these actions:

• Specify a session code in the Run Program field, and click Run to start the session.
• Click Change Company to switch to another LN company number.

This figure shows the LN Navigator:

By default, the sessions started from the LN Navigator start in the plug-in’s application area. You can
use these methods to start a session in a separate, floating, window:

• Select the Open in new Window check box in the Options tab.
• Right-click a session in the LN tab and select Open in new Window.
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• Press the Ctrl key while selecting a session in the LN tab.

For details about the installation of the LN Navigator context application, see Infor LN Role Based
Home Pages Administration Guide (U9738)

Menu bar in sessions
The menu bar of a session contains command buttons and menu buttons.

This figure shows the menu bar in an LN session:

In various sessions, records are displayed per group. In those sessions, the buttons to navigate between
groups are displayed at the top of the session. The buttons to navigate between records in the same
group are displayed directly above the grid.

This figure shows a session where the records are displayed per group (Country):

Note: 
In sessions with a grid, a check box with a down arrow button is displayed above the grid. See the
previous figures. Use this check box, and the options in the down arrow button's menu, to select or
unselect all records in the grid.

This table shows the buttons that can be present in a session:

Shortcut keyDescriptionButton

Ctrl+LSave the changes made to the record and close the ses-
sion.Save changes and exit

Ctrl+SSave the changes made to the record.

Save
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Shortcut keyDescriptionButton

Ctrl+EDiscard the changes made to the record.
Revert to saved

Ctrl+NAdd a new record.

New

Ctrl+DCreate a copy of a record.

Duplicate

Ctrl+DeleteDelete the selected record.

Delete

F5Show the current record data.

Update the screen

 Print a report.
Click the down arrow button to display the available print
sessions.

Print

 Export data to, and import data from, MS Excel.
Click the down arrow button to display the available ses-
sions.
See "MS Excel integration" on page 51.

Ctrl+FStarts the Find session, which you can use to specify search
criteria to find a record. You can only specify search criteria
for fields that are currently visible.Find

Ctrl+HomeJump to the first record(s).
First record(s)

Page UpJump to the previous record(s).
Previous record(s)

Page DownJump to the next record(s).
Next record(s)

Ctrl+EndJump to the last record(s).
Last record(s)

Ctrl+VCreate or find a group of records that all have the same
value for one or for a few specific fields. These fields areNew View displayed at the top of the session. You can zoom to the
appropriate session to select the group record. To add new
records to a group, press Ctrl+N or click New ( ).
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Shortcut keyDescriptionButton

 Copy a range of records from the current group to another
group.
After clicking this button, complete these steps:

Copy records from one
view to another

1 Select the first record to be copied.
2 Select the last record to be copied.
3 Specify the group to which the records must be copied.

 Show the records of the first group.

First View

Shift +Page UpShow the records of the previous group.

Previous View

Shift +Page
Down

Show the records of the next group.

Next View

 Show the records of the last group.

Last View

N/aContains standard commands for LN sessions.
See the "Basic Tasks" section in the Infor Web Help.

Views

N/aContains commands that are specific to the current session.
These commands usually start related sessions and special
functions.

References

N/aContains standard commands for LN sessions and com-
mands that are specific to the current session. The session-

Actions

specific commands usually start related sessions and spe-
cial functions.

F1Shows the online help for the current session.
The button's pull-down menu contains this command:Help
• Properties (CTRL+SHIFT+8)

Shows the session properties. See "Viewing session
properties" on page 58.

N/aOpens a menu with commands to personalize the session,
define conditional formatting, define customer defined fields,
etc.
See:

• "Personalizing sessions" on page 44
• "Conditional Formatting" on page 49
• "Customer defined fields" on page 56

Note: 
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The menu bar can contain additional pull-down menus that are specific to the current session.

Signing on and signing out
Signing on
To sign on to the Infor Ming.le-LN Plug-in:

1 Sign on to the Infor Ming.le
Open your internet browser and enter the Web address of the Infor Ming.le. The Infor Ming.le URL
has this format:
https://[hostname]:[port]/SitePages/InforSuite.aspx.
Ask your Infor Ming.le administrator for details.
You are automatically signed on, using your MS Windows user account and password.

2 Open the Infor Ming.le-LN Plug-in
To open LN, click the LN icon.
Depending on user profile settings, one of these situations occurs:

You are prompted to create a user profile.You do not yet have a user pro-
file. Click New to create a profile. See "Creating user profiles" on page

31. After creating a profile, you must select and open the new profile.

The available profiles are displayed.You have one or more user pro-
files, and you did not specify to
always use the default profile.

To sign on:

1 Select a profile in the selection dialog.
2 Select Next time use this User Profile automatically. From

now on, the profile selection will be skipped during sign on.

3 Click Open.

If you want to enable the profile selection again, unselect the Use
default User Profile on next login option in the Options menu in
the Infor Ming.le-LN Plug-in.

You are logged on to the server. During the log on process, the last
login date and time are displayed. This is useful, for example, to

You have a default user profile,
and you specified to always use
this profile check if somebody used your user account during your absence.

Once you are logged on, the last login date and time are displayed
in the status bar below the application area.
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Signing out
To sign out from the Infor Ming.le:

1 In the right-upper area of the Infor Ming.le, click your user name to display a pull-down menu.
2 Select Sign Out. A message is displayed to inform you that you must close your browser.
3 Close your browser to complete the sign out process.
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2Keyboard shortcuts

This section summarizes the common keyboard shortcuts you can use in the Infor Ming.le-LN Plug-in.

Options menu
This table shows keyboard shortcuts for actions that are available in the Options menu in the Infor
Ming.le-LN Plug-in menu bar:

ShortcutActionShortcutAction

Alt+F12System messageAlt+F5Start session

Ctrl+Alt+RRestartAlt+F7Change company

Menu navigation
This table shows keyboard shortcuts that you can use in the menus in the Infor Ming.le-LN Plug-in
menu bar and in the menu bar in sessions:

ShortcutActionShortcutAction

Left Ar-
row

Close submenuAlt+letter
This command is only available in
sessions.

Open menu

Enter
Spacebar

Open selected menu itemLeft Arrow
Right Arrow

Navigate between menus

EscClose menuUp ArrowNavigate within menu
Down Arrow

LetterOpen menu itemRight ArrowOpen submenu
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Sessions
Sessions
This table shows the keyboard shortcuts that you can use in sessions:

ShortcutActionShortcutActionSession
Type

F5RefreshCtrl+QClose sessionGeneral

Ctrl+HomeFirst record(s)Ctrl+NNew

Page UpPrevious record(s)Ctrl+OOpen

Page DownNext record(s)Ctrl+SSave

Ctrl+EndLast record(s)Ctrl+LSave and close

F2CalendarCtrl+ERevert to saved

Ctrl+RRotate currencyCtrl+PPrint

F1Help current sessionCtrl+FFind

Ctrl+TTextsCtrl+DDuplicate

Shift+Page UpPrevious groupCtrl+CCopy to clipboard

Shift+Page DownNext groupCtrl+DeleteDelete

EscClose dialog without resultEnterExecute standard commandPrint session

EnterClose session with resultEscClose session without resultZoom session

Satellite sessions
This table shows keyboard shortcuts that you can use in related sessions (satellites) that are situated
on the lower part of the screen of a Multi Main Table session:

NoteShortcutAction

Ensure the current focus is inside the satellite.Ctrl+WSatellite
texts

See "Multi Main Table sessions" on page 39.

Grids
This table shows the keyboard shortcuts that you can use in grids:

ShortcutActionShortcutAction

SpacebarSelect row line without
opening the item

Ctrl+HomeGo to the beginning of the
selected data sheet
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ShortcutActionShortcutAction

Enter
This shortcut does
not work in Baan
IV.

Start detail session
from selected row

Ctrl+EndGo to the end of the se-
lected data sheet

Ctrl+ASelect all rowsPage UpGo to previous set of data

SpacebarDeselect allPage downGo to next set of data

Ctrl+Alt+Spacebar(De)select multiple rowsUp ArrowGo to previous item (row)

Alt+SpacebarActivate generic jframe
menu

Down ArrowGo to next item (row)

Ctrl+Up ArrowFocus on first displayed
row

Ctrl+SpacebarSelect current row

Ctrl+Down ArrowFocus on last displayed
row

Tab
The row header is skipped.

Go to next editable field

If you press Tab in the last
editable field of the last visible
row, the next row is displayed.
This shortcut does not work in
Baan 5 and Baan IV.

  Shift+Tab
The row header is skipped.

Go to previous editable
field

This shortcut does not work in
Baan 5 and Baan IV.

Session tabs
This table shows the keyboard shortcuts that you can use in tabs in sessions:

ShortcutAction

Left Arrow
Right Arrow

Switching tabs

First press Tab or Shift+Tab to put focus on the tab. Then use the arrow keys.

Fields
This table shows the keyboard shortcuts that you can use in fields in sessions.

ShortcutActionField type

Ctrl+B
F4, Baan IV only

Start a zoom session from
the field

Fields with a browse
button
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ShortcutActionField type

F4
Down Arrow

Open list boxFields with a list box

Alt+Down Arrow

Up Arrow
Down Arrow

Select item in list box

First letter of item

ESC
Enter

Close the list box that is
open

Tab
Shift+Tab

Ctrl+B
F4, Baan IV only

Start a calendar from the
field

Date fields

Up Arrow
Down Arrow

Change day/month/year in-
dependently

First press Right Arrow or Left Arrow to set focus
on day, month, or year.

Up Arrow
Down Arrow

Change hours, minutes,
seconds, and AM/PM inde-
pendently

Time fields

First press Right Arrow or Left Arrow to set focus
on hours, minutes, seconds, or AM/PM.

SpacebarSelect or clear the check-
box

Check boxes

Down ArrowSelect next optionRadio buttons

Up ArrowSelect previous option

Dialogs
This table shows the keyboard shortcuts that you can use in dialogs that you can start in sessions:

Keyboard shortcutActionDialog type

Up Arrow
Down Arrow

Navigate inside the calendarCalendar dialog

Left Arrow
Right Arrow

Up Arrow
Down Arrow

Change the years

EscClose dialog without resultFind dialog

EnterClose dialog with result
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Switching between sessions or DEM processes
This table shows the keyboard shortcuts to switch between running sessions or DEM processes:

NoteShortcutAction

You must hold the Ctrl key.
If the current focus is inside a tab in a session,
the list also displays the available tabs. To switch

Ctrl+TabDisplay a list of open
sessions or DEM pro-
cesses

to another session or tab, select the correspond-
ing item from the list. To close the list, release
the Ctrl key.

You must immediately release the keys.Ctrl+TabNext session
Next tab
Next DEM process

You must immediately release the keys.Ctrl+Shift+TabPrevious session
Previous tab
Previous DEM process

This shortcut does not work in Windows 7.Ctrl+Alt+TabNext session

This shortcut does not work in Windows 7.Ctrl+Alt+Shift+TabPrevious session
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3Working with Web UI

The Options menu
The Options menu contains these options:

Run Program (Alt+F5)
Starts the Run Program dialog, where you can start sessions or Web pages.

To start a session or a web page from this dialog:

1 Enter the desired session code or URL.
2 Select "Infor LN" or "Internet" from the list.
3 Click OK.

• Note
In the Open field, you can select previously started sessions or URLs from the list.

• When you type a session code or URL, Web UI automatically selects the appropriate value, "Infor
LN" or "Internet", from the list.

• If the Open in new Window check box is selected, the session starts in a separate, floating, window.
If this check box is cleared, the session starts in the Infor Ming.le application area.

• Web pages start in separate Internet Browser windows.

Cache Menu
Stores your LN startup menu, which is displayed in the application navigation menu bar, on your
computer. This is useful in a WAN environment. The next time you sign on, the menu is loaded faster.
If the menu is changed on the LN server, you must select Options > Refresh Menu to refresh the
menu on your computer.

Note: 
This setting only applies to the Infor LN menu. The Enterprise Modeler (DEM) menu in the Processes
menu panel is never cached and is automatically refreshed with the latest changes.

Change Company (Alt+F7)
Starts the Change Company session. See "Changing the company number" on page 37.
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Select Activity
Use this option if you want to test software components that are checked out to an Infor LN Studio
activity.

If this option is selected, the Debug and Profile 4GL (ttadv1123m000) session starts. Use this session
to select the activity that contains the component you want to test. See the session help and the LN
Studio documentation.

Change Data Language
This option is only available if Multi Language Fields Support is enabled on your LN server. See "Multi
language application data" in the Enterprise Server Web Help.

If you select Change Data Language the Change Data Language (ttdsk2006m000) session starts.

You can use this session to switch to another data language. In this way, you can view and edit data
in multiple languages in sessions that are multi language enabled.

If you change the data language, the next session you start will run in the new data language. The
sessions that were already opened remain in the old data language.

Note:

• Web UI displays the current data language in the status bar of each session, next to the company
number.

• You can only switch to another data language if the Switch Data Languages check box in your
user data template properties on the LN server ( User Data Template (ttams1110m000) session)
is selected.

System Message (Alt+F12)
Displays the current System Message.

Show Mandatory Indication
If you select Show Mandatory Indication, Web UI displays an asterisk behind the labels of the
mandatory fields in sessions.

Note:

• By default, Show Mandatory Indication is turned off. The option is stored in your Web UI user profile.
• This option is only available in LN.

Non-interrupting Message Mode
Use this option to change the message mode:

• If this option is selected, LN uses the Non-interrupting message mode: Data you enter in a field
automatically validates when you move to a new field. LN displays the messages in a separate
Messages window without interruption to your work.

• If this option is not selected, LN uses the Interactive message mode: Data you enter in a field
automatically validates when you move to a new field. LN displays any messages prompted by a
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field's validation in a message box. You must click OK to close the message box and continue your
work.

Auto Complete Settings
Starts the Auto Complete Settings dialog.

Use this dialog to specify the following settings:

Use this check box to enable/disable the Auto Complete feature. If this
check box is selected, the Auto Complete database will be filled and

Auto Complete Enabled

updated and an Auto Complete list will be shown on fields with zoom
functionality.

The maximum number of possibilities that will be shown in the Auto
Complete list.

Maximum number of entries

See "Auto Complete" on page 42.

Show Mouse Over in Grid
If this option is selected, the background color changes when you hover the mouse pointer over rows
in a grid. This color change may adversely affect the performance.

Open Sessions in New Window (Alt+F9)
If this option is selected, sessions started from the Recently Closed panel or from the navigation menu
are opened in a new window.

This setting is stored in your user profile.

Debug Bshell
Starts the Run time debugging of bshell (ttstpbshdebug) session.

Use this session to set or modify the various bshell debug options on runtime. See the session help.

These bshell debug options can also be set before runtime in the Command field in the Bshell
Environment dialog. To do this, you must modify the configuration settings of the application in your
user profile. See "User Profiles" on page 30.

Restart
Restarts Web UI. In this way you can easily log off and log on again. You are not prompted for your
user name and password. This is useful, for example, after a change in the user data when the bshell
must restart to load new settings.

Note:

• If any programs, such as LN sessions, are running, the system asks you for confirmation.
• Running programs are closed.
• Any unsaved changes will be lost.
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Show Excluded Sub Business Processes
If this option is selected, Web UI displays the following:

• Business Processes that are part of your DEM role.
• Business Processes that are not part of your DEM role.

If this option is not selected, only Business Processes that are part of your DEM role are displayed.

Show Only Main Processes
If this option is selected, Web UI displays only main Business Processes.

If this option is not selected, main Business Processes and sub processes are displayed.

DEM Company always same as ERP company
If this option is selected, the DEM company always follows the LN company. When the LN company
is changed, the DEM company automatically changes as well. See "Changing the DEM Company" on
page 37.

By default, this option is turned off.

Use default User Profile on next login
If this option is selected, your default Web UI user profile is used automatically the next time you log
on. So the User Profiles selection dialog will be skipped during the login.

If this option is not selected, you will be prompted to select a user profile during the next login.

About
Starts a dialog that displays the following:

• Web UI version
• Web UI Server
• User
• User profile
• Bshell environment command(s) of the user profile
• Infor LN environment
• Host name
• And so on

User Profiles
A user profile is a way for Web UI to store personalizations, such as:
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• Skin, language, and font of the Web UI.
• Selected applications, including their configuration.

The system administrator decides whether you can create/modify user profiles.

Creating user profiles
To create a user profile:

1 Unselect the Use default User Profile on next login option in the Options menu in the Infor
Ming.le-LN Plug-in.

2 Sign out from Infor Ming.le and sign on again. See "Signing on and signing out" on page 19.
3 Click the LN icon. A selection dialog box is displayed.
4 Click New to open the Create new User Profile dialog box.
5 Add a user profile and configure the settings for the selected application. See "Specifying properties

for a user profile".

Changing user profiles
To change a user profile:

1 Unselect the Use default User Profile on next login option in the Options menu in the Infor
Ming.le-LN Plug-in.

2 Sign out from Infor Ming.le and sign on again. See "Signing on and signing out" on page 19.
3 Click the LN icon. A selection dialog box is displayed.
4 Select a profile and click Modify to open the User Profile dialog box.

Change the user profile settings and, optionally, the configuration settings of the selected application.
See "Specifying properties for a user profile".

5 Click OK to save the changes.

Specifying properties for a user profile
1 Add a user profile

In the Create new User Profile dialog box, enter a user profile name and select the following:

• Skin
• Language
• Font
• Fixed font
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• The preferred application.

2 Configure the settings for the selected application
Complete the following steps:

1 Click Configure. The Bshell Environment dialog appears.

2 Enter the name of the bshell and, optionally, one or more bshell commands.
Click Next. If DEM is configured for the selected environment, the Dynamic Enterprise Modeling
Configuration dialog appears.

3 In the Company pane, select a company. Then, in the DEM Model pane, select the related DEM
model.
Click Next. If Workflow is configured for the selected environment, the Infor Workflow dialog
appears.

4 Specify the Workflow server, user name, and password.
Click Next. The Verify Configuration dialog appears.

5 Verify the settings. If necessary, go back to the previous dialogs and change the settings.
Click Finish to store the configuration and to return to the Create new User Profile dialog.

3 Save the user profile
Click OK to save the new user profile and to return to the Select User Profile dialog box.
The user profile is now visible and available.

Choosing an environment
An environment consists of a server and an available application on that server.

Depending on the log-in configuration your system administrator chooses, you may have to choose an
environment during login.

The Select User Profile dialog box
This dialog box displays the available Web UI user profiles.

The dialog box contains the following options:

Opens Web UI with the selected user profile.Open

Starts a dialog where you can modify the selected user profile. If you click OK or Cancel,
you can return to the Select User Profile dialog box.

Modify

Removes the selected user profile. If you click OK, you must confirm removal of the user
profile. If no user profiles remain, you are prompted to create one.

Remove
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Creates a copy of the selected user profile.Copy

Creates a new user profile.New

Closes the Select User Profile dialog box.Cancel

Starting a web page
You can use these methods to start a web page in Web UI:

• Select Options > Run Program. Select "Internet" and specify the web page you want to start.
• Click a hyperlink in a form field or in the LN Text Editor. See "Hyperlink support" on page 33.

Hyperlink support
If a text-based form field only contains a URL, Web UI can perform a hyperlink action.

For example:

• mailto:info@techwrite.com
• http://www.techwrite.com

Web UI also supports "http://www." and "mailto:" links in the LN Text Editor.

The text of the links is underlined.

When you click an "http://www." link, the corresponding web page is opened in your default internet
browser.

When you click a "mailto:" link, a new e-mail starts in your default e-mail program.
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4Working with LN

Switching to other sessions
Session tabs
If you start multiple sessions, only the last session is displayed in the application area. The other
sessions are still open. For each open session, a tab is displayed below the application navigation
menu bar.

This figure shows an example:

To switch to another open session, click the corresponding tab.

To close a session, click the  icon in the corresponding tab.

You can use keyboard shortcuts to switch between running sessions.

Note:  You can also switch between running DEM processes. See "Starting a DEM process" on page
65.
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Switching between sessions or DEM processes
This table shows the keyboard shortcuts to switch between running sessions or DEM processes:

NoteShortcutAction

You must hold the Ctrl key.
If the current focus is inside a tab in a session,
the list also displays the available tabs. To switch

Ctrl+TabDisplay a list of open
sessions or DEM pro-
cesses

to another session or tab, select the correspond-
ing item from the list. To close the list, release
the Ctrl key.

You must immediately release the keys.Ctrl+TabNext session
Next tab
Next DEM process

You must immediately release the keys.Ctrl+Shift+TabPrevious session
Previous tab
Previous DEM process

This shortcut does not work in Windows 7.Ctrl+Alt+TabNext session

This shortcut does not work in Windows 7.Ctrl+Alt+Shift+TabPrevious session

Shortcuts
You can create shortcuts that provide links to LN sessions. The shortcuts are displayed in the Shortcuts
context application. See the  Infor Ming.le User Guide.

Finding records in a session
1 Press Ctrl+F.

The Find dialog starts.

2 If multiple indices are available, select the desired index in the left part of the dialog.
The dialog shows the corresponding input fields.

3 Enter (part of) the desired code or value in at least one field.
If you enter values in more than one field, LN searches for records that match all the criteria. Find does
not distinguish between uppercase and lowercase letters.

4 To start the search, click OK.
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When the search is finished, the Find dialog box is closed. The first record found is the first record
listed. If no records were found, the nearest matching record is shown.

Changing the company number
In Web UI the change company functionality is available on the Options menu. If you change the
company here, the next session you start then starts in the new company. The sessions that were
already opened remain in the old company.

Note: 
Your administrator can give each company a different color, which enables the user to more easily
distinguish between companies

Changing company can be a problem if you have both a DEM authorization and an Infor LN or Baan
authorization. You might be authorized by the Infor LN or Baan authorization for companies that you
cannot use in combination with DEM. In DEM navigation, you can only switch to those companies that
have specified the same central modeling company as defined in your user profile. If the central modeling
company differs from the company in your user profile, you can no longer start sessions from the DEM
tree. Ask your system administrator to change your user profile.

Changing the DEM Company
Definitions

LN Company (ERP Company)
Company as defined in the User Data. Can be overruled through a Change Company action (accessible
through the Options menu).

This company applies to the menu navigation.

DEM Company
Company as used by DEM. The DEM Company is related to a DEM Project Model.

You select the DEM Company and the Project Model when you create a Web UI user profile.
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The DEM Company always same as ERP company setting
The DEM Company always same as ERP company setting determines whether DEM automatically
follows the LN company.

The setting is available in the Options menu. By default, the setting is turned off.

Allowed values
• Not selected

This is the default behavior. A switch to another company (through the Change Company option
in the Options menu) implies only a company switch for the LN company. So if LN is enabled, only
the LN company changes.
If only DEM is enabled, a Change Company does not affect the DEM company. Sessions, started
from the Business Process Diagram are still started from the DEM company.

• Selected
The DEM Company follows the LN company. So when you perform a Change Company, Web UI
will also change the DEM company.
The DEM company is related to a Project Model; therefore also the correct Project Model must be
selected. Web UI selects the Project Model of the new company in the following way:

• First Web UI tries to use the Project Model of the old company.
• If this Model does not exist for the new company, Web UI uses the default Project Model.
• If there is one Project Model available, Web UI uses this one.
• If there are multiple Project Models, Web UI displays a dialog where you must select the Project

Model.

Note: After you performed a Change Company, the new company (and Model) are not saved in the
Web UI user profile. So when you do a re-connect, you will come back in the original companies.

Paperclip icon
In various sessions, you can attach documents to records. For example, you can attach documents to
BOM lines.

If a record has an attachment, a paperclip icon is displayed before the corresponding row in the grid.

To attach a document to a record, or to view the already attached documents, click the paperclip icon
in the toolbar.

See "Document Management" in the LN online help.
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Draggable splitter bar
Various sessions contain a draggable splitter bar that separates different areas in the session window.
For example, the Sales Quotation - Lines session contains a splitter bar that separates the details in
the upper part of the window from the data in the lower part of the window.

You can drag the splitter bar to resize the areas in the session window to your needs.

Any tab titles at the top of a window area always remain visible, even if you browse to the bottom of
that area.

This figure shows a session with a splitter bar:

Multi Main Table sessions
Web UI supports Multi Main Table (MMT) sessions.

The Multi Main Table session is designed to improve the ease of use with the application. Multiple
sessions are comprised into one to limit the number of sessions you must open in your daily work. In
an MMT session, you can enter, change, and delete data. The MMT session provides you a quick
overview of all your relevant information.

The Multi Main Table session consists of two parts:

• The header session: The coordinating session. A Multi Main Table session contains only one header
session. The header session is situated on the upper part of the screen.
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• The related sessions: The session types that can be available in each MMT session. The related
sessions are situated on the lower part of the screen.

This figure shows an MMT session, in which various sessions are combined:

MMT functionality
The MMT session type can have a deep copy or delete function. Deep copy or delete in an MMT
session means you copy or delete data of both the header and all lines within all related sessions.

In MMT sessions an implicit save is active, your data is saved if you:

• Change focus from header session to related session.
• Change focus from related session to related session.

Filtering
This topic describes how to use filtering to limit the number of records on your screen.
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The Filter menu
To apply a filter in a session, open the Filter menu. To do this, complete one of the following steps:

• On the session's View(s) menu, click Filter.
• Click this icon:

The Filter menu contains the following options:

• Advanced Filtering
• Save As
• None
• Easy Filtering
• Instant Filtering
• Match Case

The menu also displays the filters you saved.

Advanced Filtering
To delete or modify a saved filter, click Advanced Filtering. The Filters (ttadv9593m000) session
starts. In this session, you can delete the filter or set additional filter options to refine the filter. For
details, refer to the session help.

Save As
Select this option to save the currently active filter.

None
Select this option to disable the currently active filter.

Easy Filtering
You can enter filter criteria in the input fields above the grid. On alphanumeric fields, you can specify
the wildcards * or ?. On alphanumeric fields and on numeric fields, you can specify the operators >, <,
<=, >=, <>. You should not specify operators and wildcards in the same field.
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On date fields, it is possible to use a relative date, for example –7 showing records with a date of 7
days ago.

You can also perform advanced filtering: filter a particular value, and then refine your filter by setting
a new value on the filtered data.

Note: 
The number of fields for which easy filtering is available, depends on LN configuration settings. See
the online help of the Maintain Parameters (ttaad0100m000) session.

Instant Filtering
Instant Filtering means that the filter will be applied immediately when you tab out of a field in the easy
filter area.

You can switch Instant Filtering on or off in the Filter menu.

If Instant Filtering is switched off then the filter will be applied when you press ENTER in the easy filter
area, or when you leave the easy filter area.

Match Case
Select this option to make the filter case sensitive.

Example
You switched on the Match Case option, and you enter the filter value "ABC" for a column. The session
only displays records where the column contains "ABC" in uppercase. Records where the column
contains, for example, "abc" or "Abc", are hidden.
You can switch Match Case on or off in the Filter menu.

Auto Complete
This topic describes how you can configure and use the Auto Complete feature.

Introduction
Auto Complete enables you to partially fill in a field, and then select the appropriate item from a list.

Auto Complete is available on fields for which a zoom session has been defined (only if the corresponding
table field has a relation with another table).
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Fields that support Auto Complete have a special zoom button with a pull-down arrow.

Note: 
Auto Complete is not available on segmented fields.

Configuring Auto Complete
To configure Auto Complete:

1 On the Options menu, click Auto Complete Settings. The Auto Complete Settings dialog starts.
2 Select the Auto Complete Enabled check box and specify the remaining Auto Complete settings.

Using Auto Complete
To start Auto Complete on a zoom field, partially fill in the field and then press TAB. If Auto Complete
is enabled and there are matching items, a list with matching items will be shown. See the following
example.

Example
You enter "I" in the Locale field of the Device Data session, and then press TAB. A list of locales
starting with "I" is displayed.

Points of attention
• The Auto Complete list can only display a limited number of entries, depending on your Auto Complete

settings. If there are more matching items, a More button is displayed at the end of the list. This
button triggers the same zoom functionality as the zoom button.

• An item will match if the primary key (code) of the related table starts with the entered value.
• If the field has been set up to be able to do a search on description, also the items that have a

description starting with the value entered will be shown.
• The look-up is case insensitive.
• If more characters are entered in the field the look-up will be narrowed.

For example: In the Departments field in the Employees session, you enter "0" and then press TAB.
The list shows departments starting with "0". Then, you enter "1". The list now shows departments
starting with "01".

• The list shows items that have currently been used (displayed or entered). Therefore, the item does
not have to be valid in the current situation on the session.

• If an item is selected in the list, the value will be selected (copied to the field), if you press TAB, or
click on another field.

• To close the list, press ESC.
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Personalizing sessions
Introduction
You can personalize sessions to your own preferences. You can perform these actions:

• Personalize Form
• Personalize Toolbar
• Personalize the fields in an overview session
• Hide fields on the fly in details sessions (for LN back-ends with Enterprise Server 8.7.1 or higher)
• Move grid columns on the fly
• Miscellaneous actions
• Export and import personalizations (for LN back-ends with Enterprise Server 8.7.1 or higher)

Personalize Form
Use this option to hide/unhide form fields and change field labels.

You can only use this option if the Application Personalization check box in your user data template
properties on the LN server ( User Data Template (ttams1110m000) session) is selected.

In overview sessions, you can use this option to personalize view fields and columns in the grid.

To personalize a form:

1 On the session's menu bar, click this button:

2 Select Personalize Form ....
The Personalize Grid session starts.

3 Personalize the form.
You can perform various actions, such as:

• Format fields (Bold, Italic, etc.).
• Change the label texts of fields.
• Hide or unhide fields.
• Change the order of fields.

See the online help of the Personalize Grid session.

4 Save the changes and close the Personalize Grid (ttadv9210m100) session.

44 | Infor Ming.le-LN Plug-in User Guide

Working with LN



Personalize Toolbar
You can move and hide buttons directly in the toolbar. You can also define various personalizations
through the Personalize Toolbar command.

Move and hide buttons directly in the toolbar
To change the sequence of the toolbar buttons, you can drag buttons to another location in the toolbar.
You can drop a button before or after another button. You cannot drop a button on another button.

To hide a toolbar button, right-click the button and select Hide button.

Personalize Toolbar command
To personalize the toolbar:

1 On the session's menu bar, click this button:

2 Select Personalize Toolbar ....
The Personalize Toolbar session starts.

3 Personalize the toolbar.
You can perform various actions, such as:

• Hide or unhide commands.
• Change the order of commands.
• Link icons to non-standard commands, which are displayed in the Actions menu, the View menu,

and other menus. The icons are displayed in the toolbar.
• Add extra space between toolbar buttons.

See the online help of the Personalize Toolbar session.

Personalize menus
Use this option to personalize the session's menus. You do not need any authorization to use this
option.

For example, you can hide/unhide commands in these menus:

• Search button menu
• Actions button menu
• References button menu
• Print button menu

You can also set one of the actions in the Print menu as default action. The default action is indicated
by a green dot. If you click the Print button, this default action is executed.
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To personalize the session's menus:

1 On the session's menu bar, click this button:

2 Select Personalize Menus ....
The Personalize Menu session starts.

3 Personalize the menus. See the session help.

Personalize the fields in an overview session
In LN, you can only personalize the fields in an overview session if the Application Personalization
check box in your user data template properties on the LN server ( User Data Template (ttams1110m000)
session) is selected.

To personalize the fields in an overview session:

1 On the session's menu bar, click this button:

2 Select Personalize Form ....
The Personalize Grid (ttadv9210m100) session starts.

3 Personalize the columns in the grid and any view fields above the grid.
You can perform various actions, such as:

• Format view fields (Bold, Italic, etc.).
• Change the label texts of view fields.
• Hide or unhide view fields and columns in the grid.
• Change the order of columns in the grid.
• For enumerated (list box) values in the grid, select whether you want to view the descriptions or

the corresponding icons.

See the online help of the Personalize Grid session.

4 Save the changes and close the Personalize Grid (ttadv9210m100) session.

Hide fields on the fly in details sessions (for LN back-ends with
Enterprise Server 8.7.1 or higher)
To hide a field in a details session, right-click the field and select Hide field. If you try to hide a mandatory
field, you are prompted for confirmation.

To restore hidden fields:
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1 On the session's menu bar, click this button:

2 Select Personalize Form ....
The Personalize Grid (ttadv9210m100) session starts.

3 Restore the hidden fields. See the session help.

Move grid columns on the fly
To change the sequence of the columns in a grid, you can drag columns to another location in the grid.

Miscellaneous actions
Right-click a column header in an overview session to display a shortcut menu with these options:

Personalize the fields in the overview session.Personalize Columns

Select this option to freeze the selected column. This is especially useful in
wide screens. The frozen columns are always visible, even if you scroll horizon-
tally to the other side of the session window.

Freeze this Column

Select this option to switch Easy Filtering on or off. See "Easy Filtering" on page
41.
You do not need any authorization to use this option.

Easy Filtering

Select this option to switch Instant Filtering on or off. See "Instant Filtering" on
page 42.

Instant Filtering

Select this option to make the filter case sensitive. See "Match Case" on page
42.

Match Case

Select this option to display the online help of the column.Field Help

Export and import personalizations (for LN back-ends with Enterprise
Server 8.7.1 or higher)
You can export your personalizations to an XML file on your computer. You can import this file into
another LN environment. In this way you can copy your personalizations from one environment to
another.

To copy personalizations to another environment:

1 Start the Session Personalization (ttadv9403m000) session.
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2 Export the personalizations to an XML file.
See the session help.

3 Sign on to the other LN environment and start the Import Personalizations (ttadv9503m000) session.
4 Import the XML file.

See the session help.

Sensitivity labels support
Web UI supports the use of sensitivity labels.

These labels are used to indicate the sensitivity level of data.

Each sensitivity level has its own label. See the following example:

Sensitivity labelSensitivity level

Normal10

Medium20

High30

Very High40

Each sensitivity label has its own color.

In LN Tools, sensitivity levels can be assigned to:

• Table fields
• Tables
• Sessions
• Reports

For more information, see "Sensitivity labeling" in the Enterprise Server online help.

Web UI can display sensitivity labels on forms. This figure shows an example:
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Conditional Formatting
Web UI supports conditional formatting of data. You can define conditions to apply special formatting
effects to the data displayed in LN sessions. You can define multiple conditions per session.

You can specify, and combine, the following types of formatting:

• A foreground color for a particular field.
• A background color for a particular field.
• A background color for an entire row (record).
• A warning symbol for a row.

You can define various types of conditions, both simple and more complicated. For example:

• In the Production Orders (tisfc0501m000) session, all production orders with Order Status "Released"
must be displayed on a green back ground.

• In the Sales Contracts (tdsls3500m000) session, the Contract Date of all sales contracts older than
one year must be displayed in red.

• In the Sales Order Lines (tdsls4101m000) session, a warning symbol must be displayed for all sales
order lines with an Amount greater than the Required Ordered Quantity.

• In the Production Orders (tisfc0501m000) session, a warning symbol must be displayed and the
Planned Delivery Date must be displayed in red, for all orders that are 1 to 5 days late.

• In the Sales Orders (tdsls4100m000) session, a warning symbol must be displayed and the order
Amount must be displayed on a blue background, for all sales orders with an order amount greater
than 1000.

Note: 

• Conditional formatting is only supported in LN.
• You can only define formats if the Application Personalization check box in your user data template

properties on the LN server ( User Data Template (ttams1110m000) session) is selected.
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Defining conditional formatting
To define conditional formatting:

1 Start the session for which you want to define the formatting.
2 On the session's menu bar, click this button:

3 Select Conditional Formatting and subsequently select Edit Conditions. The Conditional Formatting
(ttadv9502m000) session starts.

4 Insert the conditions and the formatting settings.
For details, refer to the online help of the Conditional Formatting (ttadv9502m000) session.

5 Save the changes and close the Conditional Formatting (ttadv9502m000) session.
6 Restart the session you defined the formatting for. The new format is activated automatically.

Points of attention:

• The conditional formatting that you define in the procedure mentioned applies only to your own user
account.

• Super users can create System formats that apply all users. To create these formats, a super user
must start the Conditional Formatting (ttadv9502m000) session directly, for example from the LN
Tools menu or through the Run Program command in the Web UI Options menu.

• Super users can export formats to an XML file and import formats from an XML file. In this way a
super user can distribute formats to multiple LN environments. For details refer to the online help
of the Conditional Formatting (ttadv9502m000) session.

• When you hover the mouse pointer over a conditionally formatted row or field, the description of the
corresponding condition is displayed as a tooltip.

Disabling conditional formats
The conditional formats you defined for a session are activated automatically, each time you start the
session.

To disable a conditional format:

1 On the session's menu bar, click this button:

2 Select Conditional Formatting. The formats defined for the session are displayed.
3 To disable a format, clear the corresponding check box.

Note: 
The format is disabled only temporarily. The next time you start the session, the format is automatically
activated again.
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To make sure that a format is disabled each time you start a session, you must modify the format's
properties:

1 On the session's menu bar, click this button:

2 Select Conditional Formatting and subsequently select Edit Conditions. The Conditional Formatting
(ttadv9502m000) overview session starts.

3 Edit the format you want to disable. The Conditional Formatting (ttadv9502m000) details session
starts. Clear the Enabled check box.

Copy a range of records to another application
In multi-occurrence sessions, you can copy a range of records to another application, such as MS
Excel.

Complete these steps:

1 On the session's Actions menu, select Copy to Clipboard.
A message is displayed in the status bar.

2 Browse to the first record you want to copy and select this record.
A message is displayed in the status bar.

3 Browse to the last record you want to copy and select this record.
4 Start the other application. For example, start MS Excel.
5 Paste the records from the clipboard. For example, press Ctrl + V.

MS Excel integration
In LN sessions that show data directly from a table, you can export data to, and import data from, MS
Excel. After starting such a session, you can select the tabs and columns you want to export. Then
you can perform a quick export or an advanced export.

During the export, a .xlsx workbook is generated. To open this workbook you need one of the following:

• Microsoft Excel 2007 or later
• Microsoft Excel 2003 with a Microsoft Office compatibility pack

After exporting data from a session, you can edit the Excel export workbook and import the workbook
back into the same session. Only cells with edit permissions are imported.
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Excel button and menu
In each session where you can export data to Excel, the session's toolbar contains an Excel button
with a menu. The menu contains these commands:

• Quick Export: Directly exports the selected data using default settings.
• Advanced Export: Starts a session where you can specify settings for the export.
• Fields to Export: Starts a session where you can select the fields to be exported.
• Settings: Starts a session where you can specify general export and import settings for all sessions.
• Import: Starts a session where you can specify settings for the import.

You can use the Excel button to perform an export based on the default export mechanism that is
specified in your general export settings.

Export procedure
Before you can start your first export, you must specify general settings for the export process. These
settings apply to all sessions for which no session-specific settings are defined. See "Specifying general
settings" on page 52.

For details on how to export data from a session, see "Exporting data to MS Excel" on page 53.

Import procedure
Before you can start your first import, you must specify general settings for the import process. These
settings apply to all sessions for which no session-specific settings are defined. See "Specifying general
settings" on page 52.

For details on how to import data into a session, see "Importing data from MS Excel" on page 54.

Specifying general settings
The general settings apply to all sessions for which no session-specific settings are defined. Specifying
these settings usually is a once-only action.

To specify the general settings:

1 Start a session where you can export data to Excel. For example, start the Sales Orders
(tdsls4100m000) session.

2 Complete one of these steps:

• If the session runs in Infor Ming.le, in the toolbar, click the arrow next to the Excel button. Then
select Settings.

• If the session runs in classic Web UI, select Edit > Export > Settings.

The Excel Integration Settings (ttstpssidef) session starts.

3 Specify the default export and import settings. See the session help. The import settings are only
relevant for Infor Ming.le users.
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4 Save the settings and close the Excel Integration Settings (ttstpssidef) session.

Exporting data to MS Excel
This section describes these export mechanisms:

• Quick export
• Advanced export

Executing a quick export
To perform a quick export:

1 Start the session from which you want to export data.
2 Start the export.

Complete one of these steps:

• If the session runs in Infor Ming.le, in the toolbar, click the arrow next to the Excel button. Then
select Quick Export.

• If the session runs in classic Web UI, select Edit > Export > Quick Export.

The export starts.
The export process uses the export defaults of the session concerned, or the general export settings:

• If these conditions are met, the export is based on the session's export defaults:

• You saved export defaults for the session. See "Executing an advanced export" on page 53.
• The Use session defaults for quick export if present check box in the Excel Integration

Settings (ttstpssidef) session is selected.

• In all other situations, the export is based on the general settings specified in the Excel Integration
Settings (ttstpssidef) session.

Executing an advanced export
To perform an advanced export:

1 Start the session from which you want to export data.
2 Optionally, select the fields to be exported.

a Complete one of these steps:

• If the session runs in Infor Ming.le, in the toolbar, click the arrow next to the Excel button.
Then select Fields to Export.

• If the session runs in classic Web UI, select Edit > Export > Fields to Export.

The Fields to Export (ttadv9310m100) session starts.
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b Select the fields and/or tabs you want to export. See the session help.
c Save your selection and close the Fields to Export (ttadv9310m100) session.
d Restart the session from which you want to export data.

3 Start the export
To export the selected data:
a Complete one of these steps:

• If the session runs in Infor Ming.le, in the toolbar, click the arrow next to the Excel button.
Then select Advanced Export.

• If the session runs in classic Web UI, select Edit > Export > Advanced Export.

The Advanced Export (ttstpssiexp) session starts.

b Specify the export settings. You can specify for example:

• The location where the spreadsheet file will be generated.
• Whether the file must be opened automatically after generation.

See the session help.

c Optionally, click Save Defaults to save the settings as default export settings for the session
concerned. If you selected the Use session defaults for quick export if present check box in
the Excel Integration Settings (ttstpssidef) session, the saved default settings are used during a
next Quick Export.

d Click Continue.
The export starts based on the specified settings.

Importing data from MS Excel
To import data:

1 In Infor Ming.le, start the session into which you want to import data.
2 In the toolbar, click the arrow next to the Excel button. Then select Import. The Import (ttstpssiimp)

session starts.
3 Specify the required settings and click Import. See the session help.

In the import dialog, you must specify the location of the Excel file. You can copy this location from
the File tab in Excel.

Verifying the result of an import
The result of an import is stored in columns A through C in the Excel import file. To verify the result of
the import, view the content of these columns.

Column A contains the error condition. Column B and C contain the detailed import error. If there is no
error, column A contains “OK”, and column B and C are empty.
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Using the Report Viewer
The Report Viewer is used to display session-based and query-based reports.

In the Report Viewer you can perform these actions:

• Navigate through the report data.
• Export report data.
• Print the report.

See the descriptions of the toolbar buttons.

Toolbar buttons
The following toolbar buttons are available.

DescriptionButton

Starts the Export Data dialog, where you can select report columns and meta
data, such as layout names and data types, to be exported. The data is export-Export data ed in csv (Comma Separated Values) format. You can store the data in a file
or view it directly, for example in MS Excel.

Starts the Export Report dialog, where you can select the following:
Export report • The output format: Excel, PostScript, PDF, Word, or PowerPoint.

• The pages to export.
• The report size.
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DescriptionButton
You can store the data in a file or view it directly.

Starts the Print Report dialog, where you can select the following:
Print report • The output format: HTML or PDF.

• The report size (only for PDF).
• The pages to export.

The output is displayed in a print preview window. If you selected HTML, you
are automatically prompted to select a printer. If you selected PDF, click Print
to print the output.

Navigates to the first page.
First page

Navigates to the previous page.
Previous page

Navigates to the next page.
Next page

Navigates to the last page.
Last page

Navigates to the page specified in the Go to page field.
Go to

Customer defined fields
Introduction
In LN you can add extra table fields, which are shown and can be edited on session forms, without
creating customizations. In this way you can store additional information in LN tables. These extra
fields are called Customer Defined Fields (CDF).

Prerequisites
To add customer defined fields, you must be authorized for the Customer Defined Fields
(ttadv4591m000) session.
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In addition, CDF must be enabled for the LN environment. To achieve this, the customer defined fields
parameter must be set. For details, see "Customer defined fields" in the Infor Enterprise Server
Administration Guide (U8854).

Adding customer defined fields
To add customer defined fields to a table, complete the following steps:

1 Start the session that uses the involved table as its main table. For example:

• To add customer defined fields to the Employees - General (tccom001) table, start the Employees
- General (tccom0101m000) session.

• To add customer defined fields to the Sales Orders (tdsls400) table, start the Sales Orders
(tdsls4100m000) session.

2 On the session's menu bar, click this button:

3 Select Customer Defined Fields. The Customer Defined Fields (ttadv4591m000) session starts.
4 Add the desired customer defined fields. For details, refer to the online help of the Customer Defined

Fields (ttadv4591m000) session.

Session personalization
From Enterprise Server 10.4, a session can contain two types of customer defined fields:

1 Customer defined fields of the main table. These are regular customer defined fields. If set to active,
these fields are initially visible in the session. See the online help of the Customer Defined Fields
(ttadv4591m000) session.

2 Referenced customer defined fields. These are active customer defined fields that belong to a table
that is referenced by the main table of the session. Referenced customer defined fields are initially
invisible in the session.

A referenced customer defined field is linked to a session if its table is referenced through:

• A table definition (so-called hard-reference)
• A reference specified in the form definition, in particular in the Input/Ref Express property of a form

field
• A query.extend.select() call in the UI script of the session

If a session contains customer defined fields, you can perform these actions:

• Hide/unhide these fields.
• Move these fields to a different location, such as a different tab.

See "Personalizing sessions" on page 44.
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Viewing session properties
1 Start the session.
2 Press Ctrl+Shift+8.

The Properties (ttdsksession) session starts. This session displays the following information:

• Session information, session data, authorizations, and form information.
• Object information.
• Environment (Developer and Bshell) information.
• 4GL engine information.
• Query data.
• Your user data.

Highlighting columns in a session
You can highlight columns in LN sessions. In this way you can draw attention to a particular column.

This can be useful, for example:

• When you give a presentation.
• When you create screenshots.

To highlight a column, click the column header. To remove the highlighting, click the column header
again.

To highlight multiple columns, press Ctrl and click the corresponding column headers.

Resizing columns in a grid
To change the width of a column:

1 Place the mouse pointer on the column separator in the grid header. The pointer changes to a
double-headed arrow.

2 Click, and drag the double-headed arrow to the right or to the left.

To change the column width to automatically fit the contents, double-click the column separator in the
grid header.
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Showing display-only fields
To locate empty display-only fields in a session, right-click on any location in the session. A dashed
box is displayed around each display-only field.

To restore the original appearance of the fields, press any key.

Pictures
Adding pictures
Some LN sessions, such as the Contact (tccom1640m000) session, contain a picture box where you
can add pictures.

You can add a picture as follows:

• Drag a picture from a Web browser or Windows explorer window, and drop it on the session's picture
box.

• Copy a picture in a Web browser or Windows explorer window, and paste it on the session's picture
box.

• Hover the mouse pointer over a picture box. A browse button is displayed. Click this button to browse
to a folder and select a picture.

For details, see the online help of the involved sessions.

When you add a picture in a session, the picture is stored in an image repository on the LN server.

Large images are scaled automatically, so they fit in the session's picture box. When you add a small
picture, you are asked whether you want to display the picture larger.

Removing pictures
To remove a picture, right-click the picture in the session's picture box and select Delete. The picture
is removed from both, the session and the image repository.

ION Workflow Support
Some sessions are enabled for ION workflow. You can use these sessions to make changes to a
Business Object. These changes must be submitted for approval. Only when these changes are
approved, the Business Object may be processed further.
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For more information, see "Document Authorization" in the Infor Enterprise Server Administration Guide
(U8854).

This table shows the additional commands that are available in sessions that are enabled for ION
Workflow:

DescriptionCommand

Submits the selected object for approval.
This command is available as a button in the session's toolbar.

Submit

Makes a request to ignore any submitted changes for the object. Use this com-
mand, for example, if you want to make more changes to an object you already
submitted.
This command is available in the session's Actions menu.

Recall

Makes all changes to the object undone.
This command is available in the Save button's pull-down menu.

Revert to approved

Quick Flow
Various features in LN sessions are enabled for Quick Flow. You can use Quick Flow to optimize a
specific process by suppressing process steps.

For example, to optimize print processes or process actions in a session’s menu or toolbar, you can
suppress these components:

• Device selection dialogs for reports
• Option dialogs for menu actions
• Question dialogs
• Message dialogs

Administrators can publish personalized sessions and dialogs to other users.

Optimizing a process through Quick Flow
To enable Quick Flow for a menu option in a session:

1 Verify whether the option is enabled for Quick Flow. Complete these steps:

a Start the session concerned.
b Open the menu that contains the menu option.
c Move the mouse pointer over the menu option. If the option is enabled for Quick Flow, a grey

flash (lightning) icon is displayed behind the menu option. This means that no default settings
are saved yet. The dialog that belongs to the selected option will not be suppressed.
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If the menu option is enabled for Quick Flow, proceed with the next step.

2 Save defaults for the menu option. Complete these steps:

a Select the menu option. The corresponding dialog is displayed.
b Specify your default settings in the dialog.
c Click the  button in the dialog and select Save Defaults.
d Close the dialog.

3 Move the mouse pointer over the menu option again and click the flash icon. The color of the icon
changes to black. Quick flow is now active for the menu option.

4 Test the result. Complete these steps:

a Select one or more records in the session's grid.
b Select the menu option for which you activated Quick Flow. The corresponding settings dialog

is skipped.

Example
The Print menu in the Adjustment Orders (whinh5120m000) session contains the Adjustment Orders
option. When you select this option, the Print Adjustment Orders (whinh5420m000) session starts. This
session has multiple tabs, where you must select a device and specify selection ranges and various
options for the report. You want to use Quick Flow to skip these tabs, so that the report is printed
directly.
To suppress the tabs of the Print Adjustment Orders (whinh5420m000) session, you complete these
steps:

1 Start the Adjustment Orders (whinh5120m000) session.
2 Move the mouse pointer over the Adjustment Orders option in the session's Print menu. A grey

flash (lightning) icon is displayed. This indicates that the menu option is enabled for Quick Flow.
3 Select the Adjustment Orders option in the Print menu. The Print Adjustment Orders

(whinh5420m000) session starts. In this session, complete these steps:

a In the session's tabs, specify your default settings, such as a device, selection ranges, and other
options.

b Click this button:

c Select Save Defaults.

4 Move the mouse pointer over the Adjustment Orders option again and click the flash icon. The
color of the icon changes to black. Quick flow is now active for the Adjustment Orders option.

5 Return to the Adjustment Orders (whinh5120m000) session. Select one or more records in the
session's grid and, on the Print menu, select Adjustment Orders. The Adjustment Orders report
is printed directly.
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Suppressing messages and questions
During print processes and process actions, messages and questions can be displayed.

Depending on LN settings, you can suppress messages of type “Information”, and questions. Messages
of type “Critical” and “Warning” cannot be suppressed.

To suppress a message, in the message dialog, select Do not show this message again and click
OK.

To suppress a question, in the question dialog, select Do not show this question again and click the
desired answer button.

Note:  You can only suppress messages and questions if the LN application administrator has enabled
the suppression of messages and questions in LN.

Undoing the suppression of messages and questions
To undo the suppression of messages:

1 Click this button:

2 Select Reset Messages.

To undo the suppression of questions:

1 Click this button:

2 Select Reset Questions.
The Reset Questions (ttadv9102m000) session starts. See the session help.

Setting a default print action
For some menus in a session, you can set a default action. For example, the Print button menu can
have multiple actions. You can set one of the actions as default. If you click the Print button, this default
action is executed. See "Personalize menus" on page 45.
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5Introduction to DEM

Starting a process
You can start LNDEM processes through the application navigation menu bar in the Infor Ming.le-LN
Plug-in. When you start a process, a graphical representation of the business process is displayed in
the application area.

If you work from the graphical representation in the application area, the images are interactive. Some
represent a process, while others represent LN sessions or other modeled applications. The graphical
representation of a process enables you to carry out your daily work.

This figure shows a sample process in the application area:
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Using DEM processes
DEM provides you with process-based navigation through the LN application. While application-based
navigation logically bundles applications into folders, modules, and packages, process-based navigation
bundles these applications according to your task. As a result, rather than centralizing the application
itself, the task a user must perform is centralized. A diagram shows activities in a specific order. For
each task, you can create a separate Business Process. Activities can be LN sessions, URLs, manual
activities, and/or Microsoft Office applications.
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If you work with DEM, you are dependent on the authorization settings created by your system
administrator. Your work diagram can appear entirely different from your colleague's.

Note: 
A DEM activity can start an application on your client PC, for example MS Word. However, this only
works if your PC has an MS Windows operating system.

Starting a DEM process
Through the application navigation menu bar, you can start DEM processes that your modeler developed.
You can work from the graphical representation in the application area. If you click a symbol, the activity
opens and you can perform your task. Some figures represent processes, whereas others represent
a part of a process.

Click a process to view an overview of the sequential order and the number of tasks that you must
complete to perform your job.

Switching between multiple processes
If you start multiple DEM processes, only the last process is displayed in the application area. The
other processes are still open. For each open process, a tab is displayed below the application navigation
menu bar. To switch to another open process, click the corresponding tab.

Instead of using the tabs, you can use keyboard shortcuts.

Switching between sessions or DEM processes
This table shows the keyboard shortcuts to switch between running sessions or DEM processes:

NoteShortcutAction

You must hold the Ctrl key.
If the current focus is inside a tab in a session,
the list also displays the available tabs. To switch

Ctrl+TabDisplay a list of open
sessions or DEM pro-
cesses

to another session or tab, select the correspond-
ing item from the list. To close the list, release
the Ctrl key.

You must immediately release the keys.Ctrl+TabNext session
Next tab
Next DEM process

You must immediately release the keys.Ctrl+Shift+TabPrevious session
Previous tab
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NoteShortcutAction
Previous DEM process

This shortcut does not work in Windows 7.Ctrl+Alt+TabNext session

This shortcut does not work in Windows 7.Ctrl+Alt+Shift+TabPrevious session
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Glossary

access key
The underlined letter in a menu name or command name
that offers keyboard access.

actual size
The original process size. If you lose the original picture
due to zooming, actual size returns the picture to its initial
size.

administrator
An individual responsible for maintaining a multi-user
computer system, including networks such as LAN, WAN,
and Internet.
Typical duties include:

• Adding and configuring new workstations.
• Setting up user accounts and enabling central

deployment and user profiles.
• Installing system-wide software and Web UI for clients.
• Performing procedures to prevent the spread of viruses.
• Allocating mass storage space.

The system administrator is sometimes called the sysadmin
or the systems administrator. Small organizations might
have one system administrator, while larger enterprises
usually have an entire team of system administrators.

application
A program or group of programs designed for end users.
Software can be divided into two general classes: systems
software and applications software. Systems software
consists of low-level programs that interact with the
computer at a basic level. This includes operating systems,
compilers, and utilities for managing a computer resource.
In contrast, applications software, which is also known as
end-user programs, includes database programs, word
processors, and spreadsheets. Applications software runs
over systems software, because it cannot run without the
operating system and system utilities.

application-based navigation
The application is the point of departure for
application-based navigation. The Infor LN or Baan
application is developed to cover the complete enterprise
resource planning field. Users can perform their tasks in
this application, according to specific ERP logistics. No
room is available for personal interpretation.

area
Part of the Web UI window. Web UI is divided into various
areas: the Shortcuts panel, the navigation panels, the
Work Area, and the Title Bar.

authorization
The process of granting or denying access to a network
resource. Most computer security systems are based on
a two-step process. The first step is authentication, which
ensures that users are who they claim to be. The second
step is authorization, which grants access to various
resources based on the user's identity.

back command
Refers to a browser functionality in which you can click
Back to start up several Web sites and return to a former
Web site. In Web UI, this functionality is not available. For
best results, do not to use the back button because you
risk losing Web UI, which requires you to log on again.

back end
In client/server applications, the client part of the program
is often called the front end, and the server part is called
the back end. In Web UI, the back end is the Infor LN or
Baan application, the Infor LN Business Adapter
application, and/or Infor Web Help, the online Help
application.

browse list
A modal or secondary window that starts if the user
browses on an input field in the Details window or Overview
window to retrieve a value for that input field. The browse
list displays a list of objects or properties of objects. Only
those objects or properties of objects are displayed that
are valid within the context of the related input field or
browse filter.

browser
Short for Web browser, a software application used to
locate and display Web pages. The most popular browsers
are Netscape Navigator, FireFox and Microsoft Internet
Explorer, which are graphical browsers that display both
graphics and text.

button
In graphical user interfaces, a button is a small outlined
area in a dialog box that you can click to select an option
or command.
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BW
Thick client software to connect to the Infor LN or Baan
application; Windows UI solution.

central modeling company
The company where all DEM models are stored. If you
Change Company to a company with a different central
modeling company, you get an error.

check box
A standard Windows control that displays a setting, either
selected (checked) or cleared (unchecked).

collapse and expand
To expand is to show the lower level. To collapse is to hide
the lower level.

combined window
A combined window presents two different views: a group
by and a list, all in one window. Used for displaying two
views of one object. The top level of the window is the
Group By part. Details of the group may be present. The
lower level of the window offers a list.

command
An instruction to a computer or device to perform a specific
task. Commands come in various forms, such as special
words or keywords that a program understands, function
keys, choices on a menu, buttons, or other graphical
objects on your screen.

command button
A control that starts an action when clicked. This button
contains a label that describes the action.

company
A financial or logistic division of classification that identifies
the data that is stored in a database. Each company is a
different record in Infor LN or Baan to work in.

DEM
Dynamic Enterprise Modeling; Web UI user meaning: a
process-oriented user interface.

diagram
Graphical representation of a task.

DMB
The Dynamic Menu Browser, DMB, is the dynamic version
of the Infor LN or Baan Menu Browser. The content of the

DMB is based on the modeling of Business Processes in
the DEM repository and a project model modeled with DEM.

environment
Web UI is the front end for many Infor LN or Baan back-end
applications. If you select or create an environment, you
specify to which or how many back-end systems you want
to connect with your user name and password.

ERP Menu Browser
A primary display window that presents the user-interface
objects in a hierarchical way to the user, such as a tree
control or menu structure.

filters
A pattern through which data is passed. Only data that
matches the pattern is permitted to pass through the filter.

focus
State of a Graphical User Interface, GUI, element that
handles keyboard input, for example the cursor.

grid
The table of objects/items in an overview window, combined
window, or browse list. In the rows, the fields of one object
are displayed. The grid can be Editable or Display.

icon
A small picture that represents an object or program. Icons
are useful in applications that use windows because they
make functionality easily accessible. Icons are a principal
feature of graphical user interfaces.

Infor ES Web UI
See Infor Web User Interface.

Infor ES Web User Interface
The web based client user interface for various Infor
applications, such as Infor LN, Infor Baan 5.x, Infor Baan
IV, Infor DEM, Infor Workflow, and Infor Web Help.

Infor LN or Baan
The Infor LN or Baan application, the version can be Infor
Baan IV, Infor Baan 5.x or Infor LN.

keyboard
Computer keyboards are similar to electric typewriter
keyboards, but with additional specialized keys.

keyboard shortcut
A special key combination that causes a specific command
to be executed. Typically, keyboard shortcuts combine the
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CTRL or ALT keys with some other keys. In Windows
environments, for example, you can use CTRL+C as a
keyboard shortcut to copy. On computers, the function keys
are also used as keyboard shortcuts. F1, for example, is
used to call Help.

locate
The command button that returns you to the original
location of the activity. When you work on a process, you
might forget where you are in the process. The locate
function shows the activity's location in the tree.

modal window
A modal secondary session requires the user to complete
interaction within the secondary window and to close the
window before continuing with any further interaction of
the parent window.

modeless window
A modeless secondary window enables the user to interact
with the secondary window or the primary window, just as
the user can switch between primary windows.

online Help
You can get Help while using a program or session. The
function key F1 is normally used as a Help key.

option button
A choice you can make, which is neither a command nor
a directive.

overview session
A session that lists the available elements or records of
one type and a number of the relevant fields.

package
A set of related sessions.

password
A secret series of characters that enables a user to access
a file, computer, or program. On multi-user systems, users
must enter their password before the computer responds
to commands. The password helps ensure that
unauthorized users do not access the computer. In addition,
data files and programs may require a password. Ideally,
the password must be an alphanumeric string of characters
that no one else can guess. This code enables users to
log onto the Web UI and Infor LN or Baan applications.

personalize
The ability of Web UI functionality to be adjusted to
customers' wishes.

pop-up menu
A menu that appears temporarily if you click on a selection.
After you make a selection from a pop-up, or more
accurately a shortcut menu, the menu usually disappears.
You can right-click on the Shortcuts panel, in the
navigation panels, or in the Work Area to open the shortcut
menu.

process
In Web UI, a process is a range of activities that you must
perform to complete a task.

process model
A collection of Business Processes.

Process Viewer
The middle part of your screen that graphically displays
the process you have activated. From this part of the
screen, you can carry out your tasks.

Progress Indicator
A control that displays the percentage of a particular
process that has been completed, such as printing or
setting up a program. In Web UI, this progress indicator is
indeterminate. In the Web UI Title Bar an undulating motion
indicates tthat a process is being executed.

Remember Password
Web UI saves your entered password of the login dialog.
The password is stored in an encrypted format on your
local machine. The next time you logs on to Web UI, the
password field in the login dialog is pre-filled with your
saved password.

role-based navigation
To create a clear overview and bounded working
environment for a role, role-based navigation contains only
the information relevant to a specific task.

scroll bar
A bar that appears on the side or bottom of a window. This
bar contains a slide bar, which you can move with your
mouse to view other portions of the window.

session
An elementary part of the Infor LN or Baan application that
the user can start to complete an activity.
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shortcut
A special type of file that points to another file or device.
You can place shortcuts on the Shortcuts panel to
conveniently access files that may be stored deep in the
directory structure. Clicking the shortcut icon is the same
as double-clicking the actual file. You can give the shortcut
any name you choose.

Static Menu Browser
The representation of the complete Infor LN or Baan
application. The SMB is built in a general acknowledged
range of subjects that are addressed in an ERP application.

system
Computer system. In a Web UI evironment the term system
is usually used for Infor LN or Baan system.

tab
Tabs enable programmers to present a batch of information
that is too large for a single screen. The information of a
record is distributed across several tabs, each of which
includes a unique label with a name to describe the tab's
contents. To display the information, the user must click
the relevant tab.

taskbar
The Taskbar is the area normally at the bottom of your
Desktop where all open tasks or windows are displayed
as buttons. Web UI has its own taskbar at the bottom of
the Work Area.

template
In Web UI, a template is a blank form that lists the fields,
the fields' location, and the fields' length. A template
includes all of the options available, but with no data yet
entered. If you start Web UI, a copy of this template with
which you can work is made available. In Microsoft Word,
for example, you must open a new document or template
potentially to be able to work with Word.

template list
A list of templates from which a workflow participant can
create processes.

thinDEM application
The Web-enabled version of the Infor DEM application.
See also DEM.

ToolTip
Small window that displays the name of a button or other
control if the button contains no text or insufficient text. The
ToolTip appears when you hover your cursor over a GUI
element.

URL
Acronym for Uniform Resource Locator. An address for a
resource on the Internet. Web browsers use URLs to locate
Internet resources. A URL specifies the protocol to be used
in accessing the resource, such as http for a World Wide
Web page, or ftp for an FTP site; the name of the server
on which the resource resides, such as http://www.infor.
com/; and, optionally, the path to a resource, such as an
HTML document or a file on that server.

user authorization
The system administrator who is entitled to set certain limits
to user authorization in the User Data session. You can
obtain further information from the Installation Guide that
is distributed with the Web UI media.

user defined attribute (UDA)
A workflow variable that a user can define when modeling
the template.

user interface
The junction between a user and a computer program. An
interface is a set of commands or menus through which a
user communicates with a program. The user interface is
one of the most important parts of any program because
it determines how easily you can make the program
perform. A powerful program with a poorly designed user
interface has little value. Graphical user interfaces, such
as Web UI, that use windows, icons, and pop-up menus
have become standard on personal computers.

user name
A name assigned by the systems administrator that
identifies a user. A user name can be authorized to create
user profiles. If a user name is not authorized to create its
own user profile, the system administrator is responsible
for creating a template for this user.

user profile
In the Select User Profile dialog box, you can define the
skin, the language, and the application with which to work.

Web address
Also known as a URL, which is short for Uniform Resource
Locator, a Web address is a type of Uniform Resource
Identifier, URI, the generic term for all types of names and
addresses that refer to objects on the World Wide Web. A
URL refers to an object by address.

Web Help
If you encounter a problem or forget a command while you
run the Web UI, click F1 to display the Help topics. Infor
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Web Help contains session Help, DEM Help, and Web UI
Help.

Web site
A site or location on the World Wide Web. Each Web site
contains a homepage, which is the first document users
see when they enter the site. The site can also contain
additional documents and files. Each site is owned and
managed by an individual, company, or organization.

Web UI
See Infor Web User Interface.

Windows NT
A version of the Windows operating system. Windows NT,
New Technology, is a 32-bit operating system that supports
multi-tasking.

Workflow
Manages the flow of work and information in a company.
By means of modeled business processes, a company's
work processes are controlled.

work list
A list of activities associated with a specific workflow
participant, or with a group of workflow participants who
share a common work list. The work list forms part of the
interface between a workflow engine, for example iflow
server, and the work list handler, for example Web UI/
Worktop.

Worktop
Windows-based thick client variant of Web UI.

zoom in/zoom out
Zoom in enlarges the process on your screen, while zoom
out reduces the process.

zoom session
The session in which you can browse through the available
records and select a record. A zoom session is an overview
session in read-only mode. You can use a zoom session
to select the code of an existing record, for example, an
item, order type, or warehouse, in another session. Use
CTRL+B on a zoom field to start a zoom session.
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