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About this Guide

This guide explains how to configure and use BarTender with Infor Factory Track. BarTender application
used for designing and printing barcoded labels. The information provided in this guide is in addition
to the documentation provided by the BarTender application manufacturer.

About Infor Factory Track
Infor Factory Track is a comprehensive manufacturing, labor, and attendance operations and collection
system. The application integrates with the ERP system, streaming the latest and updated information
directly to and from the shop floor.

Contacting Infor
If you have questions about Infor products, go to the Infor Xtreme Support portal at www.infor.com/
inforxtreme.

If we update this document after the product release, we will post the new version on this Web site.
We recommend that you check this Web site periodically for updated documentation.

If you have comments about Infor documentation, contact documentation@infor.com.
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1Introduction

An Infor Factory Track barcode label provides text and barcoded data on a durable label. The text is
the descriptive information, while the barcode provides information in a format that can be read by a
barcode scanner.

BarTender application is used for designing and printing barcode labels. BarTender includes a
label-designing editor and a utility called Integration.

Creating a label format
A label format helps structure the layout of the printed barcode labels. The format organizes the label
into a series of fields and specifies the size and position of each field. A field is a placeholder for a
piece of information (such as item number or order number). Using BarTender you can design the
format for the barcode labels.

This section explains how to create a sample label format containing three data fields (Item, Unit of
Measure, and Description) for Infor Factory Track. See the BarTender Online Help for more information.

To create a label format:

1 Launch the BarTender application.
2 Go to File > New. The New Label Format Wizard opens.
3 Select Blank Label Format, click Next. The Printer Selection page opens.
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4 Select the network printer to print labels, and click Finish. The New Label Format Wizard closes.
5 Go to File > Page Setup. The Page Setup dialog opens.
6 Select the required page size on the Page tab.
7 Specify the label size in the Width and Height fields on the Layout tab.
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8 Click OK.
9 To create label fields:

• Click Barcode toolbar and click in the design area to place a barcode.
• Click Text toolbar and click in the design area to place a text label Item next to the barcode.
• Place a second barcode in the design area. Place a text label UOM adjacent to the barcode.
• Place two more text labels Desc and Sample Text in the design area.

When completed, the design area looks similar to this.

Note: A text file 'Standard_Layout.txt' provided with the Factory Track installation, serves as a
database. This text file specifies the order of values within the data file generated by Infor Factory
Track.

10 Go to File > Database Connection Setup. Associate this text file with the appropriate label format.
The Database Connection Setup Wizard opens.

11 Click Next. The Type page opens. Select Text File.
12 Click Next. The File page opens.
13 Click Select File, browse to select the text file. Click Next.
14 The  FileFormat page opens. Specify this information:

Encoding Type
Select the encoding type

Field Separator
Set this field to custom separator character.
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Customer Separator field
Specify | (Vertical bar character)

Note: This field is displayed only when Field Separator field is set to Customer separator character.

15 Click Next.
16 The  Field Names page opens, select the first option.
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17 Select The First Row is a Header Containing Field Names.
18 The Database Setup dialog opens. Click OK.
19 Open the BarTender design area and double-click the Item barcode object to add database field.
20 The  Barcode Properties page opens. Specify this information:

Name
Set the field to Field
Type
Set the Type to Database Field
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21 Click Finish and click Close.
Repeat steps 20 and 21 to add database fields for the UOM barcode object and Desc text object
(labeled Sample Text).

22 The Modify Selected Bar Code Object screen opens.
23 Go to File > Save to save the label format.

12 | BarTender Configuration with Infor Factory Track

Introduction



2Using BarTender Integration Builder

The BarTender Integration Builder utility is used as a print daemon, to send print jobs to label printers.

Infor Factory Track generates a file containing label-specific data, such as item number or order number.
The data file also contains instructions for the Integration Builder, such as the name of the printer or
quantity of labels to print. Integration Builder processes the file information and prints the job according
to instructions specified in a task list.

To create a new task list:

1 Go to Apps Menu > Integration Builder.
The BarTender IntegrationBuilder screen opens.

2 Click Create New Integration. Select File as integration method.
3 Click the Integration tab. Specify this information:

Name
The name of the integration.

Description
The description of the integration.

User Account
The details for Domain user account.
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4 Click on the File Detection section. Specify this information:

Folder to Scan
Specify the required information in this field.

Note: Update the same information in the File Path field on the Label Interface screen (See
Configuring Infor Factory Track section)

File Pattern
Set File Pattern to .dd
New Extension
Set New Extension to dat in the Actions After Detection section.
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Note: The default values in the Input Data and Variables sections must not be modified.

5 In the Actions tab on the left, modify the user account to specific user credentials and provide
domain credentials.
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6 Delete the Print Document tab by clicking x Click + to add Print Command Script.
7 In the Print Command Script, modify the user account section to Specific user credentials.
8 Specify the information in all the sections and save the integration file.
9 Click the Test tab to test the integration.
10 Click Start in the test section to check if the integration was completed successfully. Resolve errors

(if any) and close the integration builder.

Note:  You can re-open the builder to verify if the errors are resolved.

11 Click Manage button in the Integration Builder utility and click Deployments. The Bartender
Administration Console screen opens.

12 Click New Deployments to add a name, description and integration file location to it. Click OK.
You can view the integration details in the Deployment section of Bartender Administration Console
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13 The integration service can now monitor the deployed integration to process the label printing.

Selecting a user account
The BarTender Integration service must be started with a user account that has access to all the network
printers used for label printing. If the service is started with a user account that has insufficient printer
access, BarTender cannot print labels.

To select another user account:

1 Open Windows Services dialog and search Bartender Integration Service.
2 Double-click Bartender Integration Service from the Services list. The Bartender Integration Service

Properties dialog opens.
 

BarTender Configuration with Infor Factory Track | 17

Using BarTender Integration Builder



 

3 Specify the appropriate account and password on the Log On tab.
4 Click OK.

Troubleshooting Integration
1 Log file for integration errors is located at C:\ProgramData\Seagull\Services\Logging.

Open Integration.Service.txt file to check if there are any errors recorded as a part of integration.
2 To test the integration functionality as a part of troubleshooting, you can test the integration in

integration builder and check for errors.
3 Go to Manage > Deployment > Stopto stop the integration. The BarTender Administration Console

is displayed. Click Integration on the left and stop the currently deployed integration. Return to the
Integration Builder screen, click the Integration on the left and click Test tab to go to the File
integration testing screen. Click Start to run the test and verify.
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3Configuring Label Printing utility

The Label Printing utility is only required when Factory Track is operating in a cloud environment. The
utility must be installed on an on-premise server (with Bartender installed) and is used to extract label
files generated by Factory Track from the FT database to the local server. The label files in the local
server are processed and printed by Bartender.

This section provides information for installing and configuring Label Printing Utility in FT.

Configuration prerequisites
The configuration requirements for the Factory Track Label Printing utility are described in the Label
Printing Utility Install Guide.

The other prerequisites include:

• Factory Track server access
• Factory Track URL
• Factory Track Configuration data
• Factory Track Site
• Username
• Password

Accessing the Label Printing utility
To access the Label Printing utility:

1 Select Start Menu > Infor.
2 Click Label Printing Configuration application.
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Label Printing utility
The Label Printing Configuration utility consists of two tabs to configure the Label Printing service.

Label Printing Data tab
Use the Label Printing Data tab to specify the configuration related data.

• File Creation Path: The path where labels are stored until processed by the Bartender software.
• Timer (in Seconds): The period for which you must wait before you check in the new labels.

Click Save Configuration to save the Label Printing configuration to the local machine.

FT Connection Data
Use the FT Connection Data tab to specify the information related to the Factory Track communication
parameters:

• URL: The URL to link the label printing utility to the Factory Track server address. http://<Factory
Track Server Name>/IDORequestService/RequestService.aspx

Note: If https is in use, adjust the URL to reflect this. Ensure the changes are made to the URL
based on the site's setup in the cloud.
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• Configuration: The Factory Track configuration which the label printing utility needs to be linked to.
• Site: Use the Site Parameters form to validate this field.
• FT User: A valid FT user.

Note:  Recommended to use PrintUser.

• FT Password: The password of the FT user.

Note:  If PrintUser is used, this is blank by default. The FT User must be assigned FactoryTrackAuto
License or FactoryTrackCloud.

Note:  To check the validation of the configuration data, click Test Connection.

Click Save Configuration to save the Configuration data.

Initiating the Label Printing utility service
To initiate the Label Printing utility service:

1 Select Start Menu > Services Type on the Windows Service Control Panel.
2 Select the Infor Factory Track Cloud Label Printing Service in the list.
3 Right Click Infor Factory Track Cloud Label Printing Service and select Start.
4 Ensure that the Infor Factory Track Cloud Label Printing Service status is set to Running.
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4Configuring Infor Factory Track

Infor Factory Track uses BarTender Commander to print barcode labels. For each label-printing
transaction, an .xml file is used to configure the barcode label.

Note: All printers used for printing barcode labels must be configured on the Label Printer Configuration
form in Infor Factory Track.

Setup Label Interface Form in FactoryTrack
To setup label interface form in Factory Track:

1 Open Label Interface form in FactoryTrack.
2 Specify the following information:

Interface Number
FT Defaults the Interface number.

Interface Type
Interface type is set to Database Only for cloud deployments and the interface type is set to File
for On-prem deployments.

File Path
Specify the File Path.

File Separator
Specify the Field Separator as '|'.

Label Template Path
Specify the Label Template Path.

3 Provide the FilePath and Label Template Path in this form.
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Defining label formats
All label formats you create in the BarTender application must be defined in Infor Factory Track.

To define label formats:

1 Log on to Infor Factory Track.
2 Open the Label Formats form.
3 Click New to define a new label format. To modify an existing label format, select it from the grid.
4 Specify this information:

Label Name
Specify a name for the label. This name must match the label format file name used in the BarTender
application.

Description
Specify a description for the label.

Label Size
Specify the label size.

5 Click Save.

Adding a printer
To add a printer:

1 Log onto Infor Factory Track.
2 Open the Label Printer Configuration form.
3 Click New.
4 Specify the following information:
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Printer Name
Specify a name for the printer.

Physical Location
Specify the physical location of the printer. For example, Receiving Dock.

Printer Path
Specify the network path for the printer.

Mobile Printer
Select this check box if the printer is mobile.

5 Click Save.

Specify label formats and printers for transactions
To enable label printing for transactions, you must specify which label format and printer to use for
each transaction.

Note: You can also assign printers to specific user IDs using the User Extensions form.

1 Log onto Infor Factory Track.
2 Open the Transaction Warehouse Order Type Print Parameters form.
3 Select a transaction from the grid.
4 Specify this information:

Transaction Name
FT defaults the transaction name

Warehouse
Specify a warehouse to configure settings for the warehouse

Print Labels
Select this checkbox to print labels for this transaction, warehouse, and order type.

Label Name
Select a label name. This field is available only if the Print Labels check box is selected.

Number of Labels
Specify the number of labels to print. This field is only available if the Print Labels check box is
selected.

Default Printer
Select a default printer from which to print. This field is available only if the Print Labels check box
is selected.

5 Click Save.
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Using the Label Print Summary Form
You can use the Label Print Summary form to view printed label records and re-print labels.

Note: You can also re-print labels using a mobile scanner device.

Viewing printed label records
To view printed label records:

1 Log onto Infor Factory Track.
2 Open the Label Print Summary form.
3 Specify this information to define label search criteria:

Transaction Name
Select the transaction for which the label is originally printed.

User ID
Specify the user ID of the person printing the label.

Request ID
A request ID is recorded for each label that is printed. Specify the first and the last request ID to
search for a label by its request ID.

Create Date
To search for a label by the date it was created, specify a starting and ending date.

4 Click the Search button.
The label request IDs that match the search criteria specified above are listed in the grid.

5 R ight-click the request ID and select Details to view additional details for each label printed for a
label request ID.
The Label Print Details form is displayed.

Re-printing labels
To re-print labels:

1 Log onto Infor Factory Track.
2 Open the Label Print Summary form.
3 To define label search criteria, specify this information:

Transaction Name
Select the transaction for which the label was originally printed.

User ID
Specify the user ID of the person who prints the label.
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Request ID
A request ID is recorded for each label that is printed. Specify the first and the last request ID to
search for a label by its request ID.

Create Date
Specify a start date and an end date to search for a label.

4 Click the Search.
The label request IDs that match the search criteria specified above are listed in the grid.

5 Select the ID from the grid and click Reprint to re-print a label request ID. All labels associated with
that label request ID are printed.

6 Right-click the request ID and select Details to print an individual label on a label request ID. The
Label Print Details form is displayed. On this form, select a label and click Print.
The label is printed.
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