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About this guide

This help file is concerned only with the Web-based functionality.

 

About Infor Demand Planning
Infor Demand Planning includes two key applications:

The Windows-based application
The Windows-based application comprises these modules:

• Demand Forecaster

• Inventory Planner

• Replenishment Planner

• Database Administration

The Web-based Collaborate
Collaborate comprises these modules:

• Collaborate Demand Forecaster

• Collaborate Replenishment Planner

• Collaborate Database Administration

• Sales and Operations Planner

• Demand Forecaster Reports

• Replenishment Planner Reports

• Demand Planning Monitor

This help file is concerned only with the Windows-based functionality.
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What's New?
New features and enhancements introduced in Infor Demand Planning Release 11:

Enhanced user experience

Infor Demand Planning 11 sees the introduction of a Tool Bar Ribbon, Selection Navigation Tree, and
Enhanced Exception Alerting.

The Interactive Navigation Tree provides a more modern and user-intuitive manner to select Channel
Products. Selections can be performed based on Views, Filters, Hierarchies or a combination of these,
and drilled into at different levels. Each of the types of possible selections are displayed in a series of
Selection Panes.

The different Selection Panes can be set to display or not and be resized if required.

Demand Planning Exception Alerting

This function provides management by exception logic to the Core user. Time to plan is reduced by
alerting to problem areas.

The new floating Exceptions pane is enabled. When a planner selects a channel product, each channel
product in the selection is checked. The enabled exceptions enabled that are triggered by the current
CP are identified.

The Exception can be easily viewed. The planner can easily remove exceptions that pertain to the
selected Channel Product.

Offline Channel Balancing

Offline Channel Balancing provides an option for Channel Balancing to occur in a non-user-interactive
model, improving planner productivity for large scale problems or complex Channel Structures.

A setting at the product level determines whether balancing occurs interactively or offline.

If the offline option is used, during edits to a Channel Product, the Channel Product is flagged as
requiring balancing and the balancing is performed in the background.

Forecast BOMs

Forecast BOMs enable the Net Forecast at a parent channel product to be added as Market Intelligence
to any component products that are linked to the parent. The quantity of Market Intelligence added,
and any offset can be specified to suit requirements.

Forecast BOMs are channel specific and can be created for numerous channels.

Enhanced Edit Grid in Core

Customer Forecast is included, replacing Net Forecast where Customer Forecast periods exist.

Customer Forecast is displayed as default with the option of editing in the Detail view of the grid.

Option to display a single User Data Series in the grid instead of Customer Forecast.

Enhanced Edit Grid in Collaborate.

Provides the ability to work with forecast in Calendar Months whilst still using a weekly database, as
per the Core Edit Grid.
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Inclusion of Customer Forecast, replacing Net Forecast where customer forecast periods exist.

Customer Forecast displayed as default with the option of editing in the Detail view of the grid.

A Single User Data Series can be displayed in the grid instead of Customer Forecast.

The Edit Grid functionality now gives more consistency between Core and Collaborate.

Contacting Infor
If you have questions about Infor products, go to the Infor Xtreme Support portal at http://www.infor.
com/inforxtreme.

If we update this document after the product release, we will post the new version on this Web site.
We recommend that you check this Web site periodically for updated documentation.

If you have comments about Infor documentation, contact documentation@infor.com.
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1Getting Help

Ways to get help while you work
The easiest way to get help while you work is to use Infor Demand Planning Help.

To get help about a dialog or window
Many dialog boxes and windows in Infor Demand Planning have Help buttons, marked either by the
word "Help" or a  help icon.

Click the Help button to view a topic about the dialog or window.

To get help about a particular task
1 Select Help > Help Index or Help Contents.
2 If the table of contents is not visible in the left-hand pane of the Infor Demand Planning Help window,

click the Contents tab.
Use the table of contents to find a help topic about the task.

To get help about a particular subject
1 Select Help > Help Index or Help Contents.
2 In the Infor Demand Planning Help window, click the Index tab.
3 Type the subject about which you want help, in the box just below the Index tab.

The index adjusts automatically to highlight the index term that best matches what you type.
4 Click the index term.

If the term is associated with only one help topic, that topic is displayed. If the term is associated
with more than one topic, a shortcut menu appears from which you can select the most appropriate
topic.
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To view related topics
If a help topic doesn’t contain all the information you need, you may be able to view related help topics.

1 Click See Also at the bottom of the topic.
2 Select the most appropriate topic from the shortcut menu.

Note: 

• The See Also button is not available for all topics.
• To print the current topic, click Print in the button bar.

About the types of help topics
Infor Demand Planning Help includes several different types of help topics. These types are marked
by icons that appear in the topic titles.

Type of help providedIcon

dialogs and windows

Data tables and reports

Graphs and charts

Wizards

Tasks and procedures

Concepts, examples and background information

Processes

Reference information

How database fields are identified
Infor Demand Planning uses Oracle databases. In the Help system, and in the user manual, the tables
and fields within these databases are identified in either of two ways.

By their Oracle names
Oracle table and field names are shown in uppercase. They cannot contain spaces.
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Example: the ANNUALISED_FC field of the CHAN_PRODS table

Another way of identifying a field is to write the table name followed by the field name, separated by a
period.

Example:CHAN_PRODS.ANNUALISED_FC

You need to know the Oracle table and field names whenever you are editing SQL expressions that
address the database.

By their descriptive names
Because the Oracle names are sometimes hard to read, tables and fields also have more descriptive
names. For example, the Annualized Forecast field of the Channel Products table. You can change
the names of fields by editing the database’s application defaults.

See "Editing application defaults" on page 70.

Another way of identifying a field is by writing its descriptive name followed by a table abbreviation in
brackets.

Example:   Annualised Forecast (CPt)

Usually, in the Help system, this kind of field reference is followed by a small "Annualised Forecast
(CPt)" symbol. If you click the symbol, you get a definition of the field.

Here is a list of the most common table abbreviations:

TableAbbreviation

Channels tableCt

Channel Products tableCPt

Orders tableOt

Products tablePt

System tableSt

How toolbar command buttons are identified
In Infor Demand Planning, many menu commands have toolbar equivalents. In the Help system, and
in the manual, whenever you are given instructions for performing a task, the menus and the commands
are always identified in bold. For example:

Select Modules > Demand Forecasting > Generate Forecasts.

However, if there is also a toolbar equivalent for a menu command, the icon that appears on the toolbar
button is shown in front of the command. For example:

Select Modules > Demand Forecasting > Edit Forecasts.
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This tells you that, instead of using the menus, you can simply click the Edit Forecasts button on one
of the toolbars that are available at this point in the task.

Hiding the help navigation pane
By default, the Infor Demand Planning Help window has a navigation pane with Contents, Index, and
Search tabs. You can hide and show this pane to give more room to display help topics.

Click Help Topics in the button bar.

Searching help topics
1 Select Help > Help Index or Help Contents.
2 In the Infor Demand Planning Help window, click the Search tab.
3 Follow the numbered instructions on the tab.

To set search options, select Search > Options.

Defining bookmarks for help topics
You can define bookmarks for topics so that you can return to them later.

To define a bookmark for the current topic
1 Select Bookmark > Define.
2 Type a name for the bookmark in the Bookmark name box and click OK.

The default name is the title of the current topic.

To return to a bookmark
On the Bookmark menu, click the name of the required bookmark.

Note: 

• Each top-level book in the help file has its own separate set of bookmarks.
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• Your bookmarks are lost if the help file is updated.

Annotating help topics
You can add an annotation to a help topic, for example, as a reminder.

Annotating the current topic
1 Select Edit > Annotate.
2 Type an annotation for the topic in the Current annotation box. You can also use the Copy and

Paste buttons to copy text to and from the annotation.
A paper-clip icon is displayed next to the topic title and shows that the topic is annotated.

Deleting an annotation
1 Select Edit > Annotate.
2 Click Delete.

Note: Your annotations are lost if the help file is updated.

International support
Technical support is available for Infor Demand Planning users in the form of telephone helpdesks.
Infor Demand Planning users are requested to contact the helpdesk nearest to where the software was
purchased.

Infor UK Ltd, Solihull, UK

+(44) (0)1252 556556 Customer Care

www.infor.com\inforxtremeOnline

Infor (Australia) Pty Limited, NSW, Australia

1800 895 681 (Outside Australia +65 6346 4636)Helpdesk

+(61) 2 9021 7298Fax
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www.infor.com\inforxtremeOnline

Infor Inc, USA

+(1) 877-772-4111Helpdesk

www.infor.com\inforxtremeOnline

European Computing Consultants, Madrid, Spain

+(34) 91 406 19 15
+(34) 902 900 190

Helpdesk

+(34) 91 406 19 16Fax

soporte@ecc.esEmail

The lines are open during office hours and are answered by technical staff. Primarily, the technical
personnel are responsible for the running of the Infor Demand Planning help desk service for our
customers, the development of Infor Demand Planning to meet the needs of industry and, if required,
the specialist customization of Infor Demand Planning for any individual needs of a company. Technical
team members combine academic achievement in the field of computing, statistics and operational
research with a sound level of expertise in the area of materials management.
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2Common Tasks

Starting Infor Demand Planning
1 On the Windows Start menu, select Programs > Infor Demand Planning, then click one of these

options:

• Database Administration
• Demand Forecaster, for Demand Forecaster (including Sales Budgeting & Tracking and Inventory

Planner).
• Replenishment Planner, for Replenishment Planner.

When the selected application starts, the Select Database Profile dialog is displayed.
2 Click the database profile you want, then click OK.

The Log On dialog box is displayed.
3 Type your user ID and password, then click OK.

Opening a database
1 Select File > Open or Open Database.

The Select Database Profile dialog box is displayed.
2 Click the database profile you want, then click OK.

The Log On dialog box is displayed.
3 Type your user ID and password, then click OK.

Note: The current database profile is identified in the status bar.

Closing a database
Select File > Close or Close Database.
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Passwords

Changing your password
At first, your password is the same as your user ID. You can change your password in Database
Administration, Demand Forecaster and Replenishment Planner.

1 Do one of the following:

• In Database Administration, select DB Admin > Change Password.
• In Demand Forecaster, select Tools > Change Password.
• In Replenishment Planner, select Tools > Change Password.

2 Specify this information:

Old Password
Type your current password.

New Password
Type your new password.

Verify Password
Type your new password again.

Note: 

• Passwords are not case-sensitive prior to Oracle 11g, but are case-sensitive from Oracle 11g
onwards.

• A password cannot include spaces or begin with a number.

If you forget your password
If you forget your password, inform a steward. There is no easy way to recover a lost password.
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CP Notes

About CP Notes
You can enter and store free-form information relevant to the current Channel Product. This is possible
using a text edit dialog, accessed through a common menu option in all modules. Rather than be
restricted to the limitation of a standard database character field, this information exists in a table,
containing a large object for memo-type storage.

Adding CP Notes
1 Do one of the following:

• In Database Administration, select Product Admin > Channel Products and click the Open
the text editor to edit notes for this CP icon in the Channel Products dialog toolbar.

• In Demand Forecaster, select Tools > CP Notes.
• In Replenishment Planner, select Tools > CP Notes.

The CP Notes dialog box is displayed.
2 Type the new note in the box provided.
3 Click OK.

Viewing CP Notes
1 Do one of the following:

• In Database Administration, select Product Admin > Channel Products and click the Open
the text editor to edit notes for this CP icon in the Channel Products dialog toolbar.

• In Demand Forecaster, select Tools > CP Notes.
• In Replenishment Planner, select Tools > CP Notes.

The CP Notes dialog box is displayed.
2 Click OK to close the dialog box.
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Messages

About messages and broadcasts
You can send and read messages and broadcasts while using either Database Administration or
Demand Forecaster.

• Messages are sent to individual Infor Demand Planning users. If the user is currently logged on,
she can read the message immediately. Otherwise, her messages are kept and displayed
automatically the next time she logs on.

• A broadcast is simply a message that is sent simultaneously either to all users or to all users who
are currently logged on (excluding the sender, of course).

Messages and broadcasts are internal to Infor Demand Planning. However, in Demand Forecaster,
you can also access your company’s email system.

Sending a message to a user
1 Do one of the following:

• In Database Administration, select Messages > Send Message.
• In Demand Forecaster, select Tools > Messages > Send Message.

2 Select the user ID of the intended recipient.
3 Type the message in the box provided.
4 Click Send.

Note: Messages of more than 60 characters may be truncated when read.

Broadcasting a message to more than one user
1 Do one of the following:

• In Database Administration, select Messages > Broadcast.
• In Demand Forecaster, select Messages > Broadcast.

2 Type the message in the box provided.
3 Click Send.

Note: Messages of more than 60 characters may be truncated when read.
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Reading your messages
1 Do one of the following:

• In Database Administration, select Messages > Open Messages.
• In Demand Forecaster, select Tools > Messages > Open Messages.

The Mailbox dialog box shows each message, the user ID of the sender and the date and time it
was sent.

2 To delete a message, click the message then click Delete Message.
3 To delete all messages, click Delete All.
4 To reply to a message, click the message then click Reply to Sender. The Mail – Send Message

dialog box is displayed, in which you can type a reply message.

Note: If, when you log on to Database Administration, there are any messages for you, the Mailbox
dialog box is displayed automatically.

Sending an email
In Demand Forecaster, select Tools > Mail.
Your company’s email client opens, ready for you to type an email.

Language

Changing the language
You can change the language used for the menus and dialog boxes in Demand Forecaster,
Replenishment Planner and Database Administration.

1 In Demand Forecaster and Requirements Planner, select Tools > Language or Set Language.
In Database Administration, select Settings > Set Language.
The Set Interface Language dialog box is displayed.

2 In the Available Languages list, click the language you want to use.
3 Select the Set As Default check box if you want to keep this language until you change it again.

Otherwise, the original language is restored when you next start Infor Demand Planning.

Note: 

• Changing the language in Demand Forecaster or Replenishment Planner only affects these
modules. Dialogs that rely on Microsoft Windows, including the help system, continue to use the
language of your Windows installation.
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• If Set as default is selected in Set Language in Database Administration, the language of all
three core modules is changed.

• You cannot change the language of the Infor Demand Planning Help.

Exception Views

About exception views
There are currently 139 default exception views that are generated within Infor Demand Planning.
Users may activate exceptions, categorize exceptions with a severity and assign exceptions to various
user roles so the exception views can be used as a better basis for initiating a work flow.

Infor Demand Planning gives an overview of the exceptions within the system, but in a method that is
applicable to the current user. It is possible to view exception detail, including applicable items affected,
and directly drill down into the functionality to view or action those products.

There are currently two different ways to gain access to the core system and Collaborate functionality:

• Standard Product and Channel select.

• A predefined selection for a particular user stored on the database.

See "Index of exception views".

Editing exception views in DF and RPD
You can edit exception views in which the currently selected Channel Product appears in both the
Demand Forecaster and Replenishment Planner modules.

1 Select Tools > Exception View Edit.
The Exception View Edit dialog box is displayed.

2 Select the required user role from the Select Role list box.
3 Either select the check box in the Remove column to remove the currently selected Channel Product

from that exception view or click the Remove CP from all available exception views check box
to remove it from all exception views.

4 Click Save.
5 Click Yes.

Note: Removing a Channel Product from an exception view removes it from all user roles associated
with that exception view.
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3Selecting Products and Channels

About Products
In Infor Demand Planning, a Product is typically any item which is produced, procured and consumed
in discrete quantities.

Product types
• Standard Product

The majority of items are likely to be of this type. Standard Products are further classified:

• Normal Products are items whose pattern of demand is regular and common enough to be forecast
by dynamic linear modeling (DLM).

• Slow-Moving Products (SMPs) are items whose demand is too irregular to be forecast by DLM.
SMPs typically show many periods in which there is no recorded demand at all; in fact, this is how
Infor Demand Planning identifies them.

See "About Slow Moving Products" on page 271.

• Non-Standard Product (NSP)

A Product variant used in promotional activities (for example, 3-for-2 offers, or "buy one get one free").
Infor Demand Planning allows you to link NSPs to related Standard Products in a variety of ways. For
example, a promotional pack may be assembled from two or more standard items, or a promotional
pack may steal demand from one or more standard packs.

• Unspecified Forecast Product (UFP)

A dead Product that may become live, or a notional Product used to forecast a proposed item to allow
its predicted sales to be taken into account in budgeting and capacity planning. A UFP can be upgraded
to a Standard Product when appropriate.

See "About Unspecified Forecast Products" on page 274.

• Forecast Group Product

A notional Product used as the placeholder for a system view of Standard Products that are to be
forecast collectively as a permanent forecast group (PFG). This is often useful in detecting seasonal
demand patterns that can then be applied to new Products added to the group (for example, a new
flavor or a new pack size).
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See "About permanent forecast groups" on page 279.

• Returns Product

A Product returned to stock (linked to base Products in Demand Forecaster).

See "About Returns Products" on page 274.

• Scenario Product

A fictitious variant of a real Product created to try, and save, "what-if" forecast projections. If the
projections prove valuable, the Scenario Product’s forecast can replace the original Product’s forecast.

See "About Scenario Products" on page 276.

Product status
• Live

A live Product is one which is actively processed, forecast and reported by Infor Demand Planning.

• Dead

A dead Product can be kept in the database for future reference but is not used in any processing and
does not appear in any reports.

About Channels
The term "Channel" as it is used in Infor Demand Planning must not be confused with the more familiar
concept of a distribution channel, although there are some similarities.

In Infor Demand Planning, a Channel can represent a physical location such as a factory, depot or
warehouse, or a less tangible element such as a sales region or market sector. It can also be a theoretical
aggregate, such as the sum total of all a company’s depots.

Channel types
Infor Demand Planning includes up to ten predefined Channel types which can be edited to suit your
implementation.

• Region• Factory

• Depot • Country

• Division• Sales region

• Customer • Field Stocks

•• Total (all-purpose aggregate)Distribution center

When you create a Channel, you must say what type of Channel it is.
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See "About Channel types" on page 77.

Channel behaviors
Every Channel is characterized by a set or vector of nine behaviors. Initially, these behaviors are
inherited from the Channel type, but they can be replaced or edited when the Channel is added to a
Channel matrix.

Collectively, a Channel’s behaviors govern how the statistical forecast, sales/demand history and stock
requirements are stored at, passed to or accepted from its superior and subordinate Channels in a
Channel matrix.

See "About Channel behaviors" on page 72.

Channel matrices
A Channel matrix is a collection of Channels assembled in a hierarchical or pyramidal structure.

You can define as many Channel matrices as you need. A Channel can appear in several different
matrices, and its behaviors may be different in each one.

See "About Channel matrices" on page 78.

About selecting Products and Channels
Selecting Products
There are five methods of selecting Products or Channel Products:

"Selecting all Products" on page 40  By selecting all Products

"Selecting views" on page 46  By selecting one or more views

"Selecting Product codes" on page 46  By selecting Product codes

"Selecting recently-used Products" on page 47  By selecting recently-used Products

"Specifying a selection manually" on page 47  By specifying a selection manually

When making a selection you can filter it, sort it, and save it as a view.

Selecting Channels
You can select Channels either by type or by choosing particular Channels. You have to select Products
before you can select Channels.

See "Selecting Channels" on page 48.
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Pre-defined views
You can avoid both the above selection processes by using a predefined view.

See "About pre-defined views" on page 40.

Note: 

• Your data access privileges may restrict the Products and Channel Products you are allowed to
select.

• In Database Administration, selecting Channel Products automatically selects both the Products
and the Channels. In other Infor Demand Planning modules, Products and Channels must be
selected separately.

• In Replenishment Planner, to include Scenario Products in your selections you must first select
Scenario Products on the View menu.

• Selections cannot be sorted in Database Administration.

About Selection Panes
For Infor 11, a series of selection panes have been introduced providing a more modern and user-intuitive
manner to select Channel Products.

All panes can be switched on or off. Use the check boxes that are displayed in the Home tab of the
ribbon in the Navigation by Products and Channels, and Navigation by Channels and Products sections.

All panes can be resized to suit the user's requirements. The selection of panes is saved for future
sessions of Demand Forecaster.

The selections that are displayed in the panes use all the channel products in the database and are
not linked to any prior selections.

Views by Products and Channels
In this pane, double-clicking at the top of the tree, Views by Products and Channels, shows all the
types of view to which the user has set up or has access. Different types of view are possible:

• Exception views
• Exception views (products)
• Private Product views
• Public Product views
• Private Channel Product views
• Public Channel Product views
• Marketing Group views
• Predefined views

Double-clicking on the view type shows the views of that type to which the user has access.
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Double-clicking on a shows the products in that view and double-clicking on the product code shows
the channels that are linked to that product.

For Exception Views, the roles that a user has assigned to them and the Exception Views that are
active for each role are observed.

The data access filters are observed. The users cannot see the views that only contain the channel
products to which they do not have access.

Views by Channels and Products
This pane shows the same views and channel products as the Views by Products and Channels pane,
except that, when drilling down into the view, the channel level is displayed with products listed
underneath it.

Hierarchies by Products and Channels
In this pane, double-clicking at the top of the tree, Hierarchies by Products and Channels, shows all
hierarchies on the database.

Double-clicking on each level of the tree drills down into the levels of the hierarchy and shows the
products in that branch. When double-clicking on the product code, the channels are displayed.

Any data access filters will be observed and any hierarchy branch containing channel products that
the user does not have access to will be displayed, but cannot be selected (the hierarchy will disappear
if selected)

Hierarchies by Channels and Products
This pane will show the same hierarchies and channel products as the Hierarchies by Products and
Channels pane, with the difference being that when drill down into the hierarchy, the channel level is
displayed with products listed underneath it.

Filters by Products and Channels
In this pane, double-clicking at the top of the tree, Filters by Products and Channels, shows all filters
on the database to which the user has access. Different types of filter are possible:

• Private Product Filter
• Public Product Filter
• Private Channel Product filter
• Public Channel Product filter
• Private Advanced Filter
• Public Advanced filter

Double-clicking on the filter type shows the filters of that type to which the user has access.

Double-clicking on a filter shows the products in that filter. When double-clicking the product code, the
channels are displayed.

The data access filters are observed. The users cannot see the filters that only contain the channel
products to which they do not have access.
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Filters by Channels and Products
This pane shows the same filters and channel products as the Filters by products and channels pane,
except that, when drilling down into the filter, the channel level is displayed with products listed
underneath it.

Views by Hierarchies, Products and Channels
In this pane, double-clicking at the top of the tree, Views by Hierarchies, Products and Channels, shows
all types of view that the user has set up or has access to.

Double-clicking on the view type shows the views of that type.

Double-clicking on a view shows all hierarchies on the database.

Drilling down into the hierarchy shows the channel products in that view that contained in each branch
of the hierarchy

As per the Views by Products and Channels and the Hierarchies by Products and Channels panes, all
data access filters are observed. Views or hierarchies may not be displayed if the user does not have
access to these.

Any levels of the hierarchy that contain null values are hidden once drilled into.

Views by Hierarchies, Channels and Products
This pane shows the same views by hierarchies and channel products as the Views by hierarchies,
Products and Channels pane, except that, when drilling down into the hierarchy, the channel level is
displayed with products listed underneath it.

Views by Filters, Products and Channels
In this pane, double-clicking at the top of the tree, Views by Filters, Products and Channels, shows all
types of view that the user has set up or has access to.

Double-clicking on the view type shows the views of that type that the user has access to.

Double-clicking on a view displays some or all of the six filter types. A filter type is not displayed if no
filter of that type contains channel products in the selected view.

Expanding a filter type shows all filters that contain channel products in the selected view and
double-clicking on that view will drill into it, displaying the product and then channel level branches of
the tree.

As with all other panes, data access filters are observed. Views and filters are not displayed if the user
does not have access to the channel products in them.

Views by Filters, Channels and Products
This pane shows the same views by filters and channel products as the Views by Filters, Products and
Channels pane, except that, when drilling down into the filter, the channel level is displayed with products
listed underneath it.
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Filters by Views, Products and Channels
In this pane, double-clicking at the top of the tree, Filters by Views, Products and Channels, shows all
filters on the database to which the user has access. The possible filter types are the same as in the
Filters by Products and Channels pane.

Double-clicking on the filter type shows the filters of that type.

Double-clicking on a filter shows the view types that contain views that have channel products in the
selected filter.

If all views of a particular type do not contain any channel products returned by the selected filter, the
view type is not displayed at all.

Expanding the view type displays the views that contain the channel products that are returned by the
selected filter. Double-clicking on that view will drill into it displaying the product and then channel level
branches of the tree.

As with all other panes, data access filters are observed. Views and filters are not displayed if the user
does not have access to the channel products in them.

Filters by Views, Channels and Products
This pane shows the same Filters by views and channel products as the Filters by Views, Products
and Channels pane, except that, when drill down into the view, the channel level is displayed with
products listed underneath it.

In all the Selection Panes, when the selection is loading, if you press Escape, the selection stops
loading up to the point that it has loaded. Selections can then be performed from what has been loaded.

Select Group
For each of the above panes, once a view, hierarchy or filter has been opened and drilled into, the user
can select a level of the tree, right-click and select Select Group.

If the group selection is performed at the lowest level of the tree, that is, the single channel product
level, only this channel product is selected.

If the group selection is performed at each level of the tree, the channel products at that level and below
are selected.

For example, in the Views by Hierarchies panes, the group selection is performed for an Exception
view, all the channel products in that view are selected. On the contrary, if the group selection is
performed at a level in the hierarchy seen under the exception view, only the channel products in that
branch of the hierarchy and below for that exception view are selected.

Group selection cannot be performed at the level of filter type, view type or hierarchy name. Once these
are drilled into, the Select Group option is available.

If more than one channel product is selected using this option, a temporary forecast group is created.
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Refresh
As the circumstances of a channel product can change, especially in the form of exception views, the
channel products that are displayed in a view, filter or hierarchy must be refreshed in line with other
changes.

For example, if a channel product is contained in a particular exception view, but changes are made
to the channel product and the exception view no longer contains this channel product, the selection
trees must be refreshed, either at the top level of the tree or, in this case, at the level of the exception
view name. Refreshing is required in each pane.

If changes have been made prior to logging into Demand Forecaster, any changes are automatically
reflected in the selection trees.

About pre-defined views
In order to provide a more structured and user-friendly way to manage the 139 exception views that
are generated within Infor Demand Planning, it is possible to use a predefined list of items selected by
individual users which are stored on the database and may be used as an alternative to the standard
Product and Channel selection process. As all exceptions views are categorized with a severity and
can be assigned to various user roles, they can be used as a better basis for initiating a work flow.

There are currently two sign on options available when entering the core modules of Infor Demand
Planning and Collaborate:

• The standard select Products and Channels dialog boxes. This is the default for all current users.
• The user will bypass the select Products and Channels dialog boxes and, using a predefined

Product/Channel selection, open a default module or Collaborate page, stored on the database.

The predefined option is only available if the PREDEF sign-on option is allocated to the current user.
The sign-on option for each user is maintained in the Maintain Users: ADD/EDIT dialog boxes within
the Database Administration module. The default sign-on module or Collaborate page is also selected
in these dialog boxes.

A predefined Product/Channel selection can be saved in any Infor Demand Planning core module and
in Collaborate.

Selecting Products

Selecting all Products
1 Select File > Select Products.
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2 Do either of the following:

• Select the All products check box.
• In the Select box, click All Products.

3 Optionally, you can specify a filter, a sort order, or a view into which to save the selection when it
is retrieved.

4 Click OK.

Selecting by Hierarchy

About hierarchies
A hierarchy is a useful way of arranging Products or Channel Products so that you can easily select
those that have one or more values in common. (Remember that your data access privileges may
prevent you accessing some Products or Channel Products.)

A hierarchy is defined by one or more Product or Channel Product database table fields. For each field,
Infor Demand Planning creates a separate branch of the hierarchy for each distinct value found in that
field, and includes in that branch the Products or Channel Products that share those values. As you
add more fields to the hierarchy, Infor Demand Planning creates further nested, branches.

Once you have created a hierarchy, you can select which branches, or individual Products or Channel
Products, you want for a particular selection. The hierarchy itself is stored in the database, and can be
accessed by any user.

Hierarchies, unlike views, are not static collections of Products or Channel Products and are based on
the current values of the Product or Channel Product fields on which the hierarchy is based.

Products and Channel Products with null values in any one of these fields are automatically excluded
from the hierarchy. It is therefore possible for a hierarchy to be empty (that is, contain no Products or
Channel Products).

Examples of hierarchies
Suppose you have the following Products:

GroupCategoryABC ClassDescriptionCode

 CommercialBDual Sink Unit (Steel)DSU100

 DomesticADual Sink Unit (Marble)DSU103

ElectricalDomesticCCeramic Hob (Standard)Hob001

ElectricalDomesticBCeramic Hob (Enhanced)Hob002

ElectricalCommercialACeramic Hob (Deluxe)Hob003
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GasDomesticCGas Hob (2-ring)HobG002

GasDomesticBGas Hob (4-ring)HobG012

ElectricalDomesticCMicrowave (Portable)MWO101

ElectricalCommercialBMicrowave (Industrial)MWO220

ABC Class is a standard Products table field. Category and Group are user-defined Products table
fields, although ones that are often included in Infor Demand Planning installations.

Example 1: A hierarchy based on only the ABC Class field
Such a hierarchy would look as shown below. Given this hierarchy, you could select one or more ABC
classes.

 All Products

  A

Dual Sink Unit (Marble)DSU103 

Ceramic Hob (Deluxe)Hob003 

  B

Dual Sink Unit (Steel)DSU100 

Ceramic Hob (Enhanced)Hob002 

Gas Hob (4-ring)HobG012 

Microwave (Industrial)MWO220 

  C

Ceramic Hob (Standard)Hob001 

Gas Hob (2-ring)HobG002 

Microwave (Portable)MWO101 

Example 2: A hierarchy based on the Category and Group fields
A hierarchy that organized Products by Category first, and then Group, would look as shown below.
Notice that DSU100 and DSU103 are excluded from the hierarchy because their Group fields are null.
Given this hierarchy, it would be easy to select, for example, all commercial Products that are electrical.

 All Products

 Commercial

 Electrical 

Ceramic Hob (Deluxe)Hob003  

Microwave (Industrial)MWO220  

 Domestic
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 Electrical 

Ceramic Hob (Enhanced)Hob002  

Ceramic Hob (Standard)Hob001  

Microwave (Portable)MWO101  

 Gas 

Gas Hob (4-ring)HobG012  

Gas Hob (2-ring)HobG002  

Creating a hierarchy
1 In Database Administration, select Product Admin and Hierarchies.
2 Click Add.
3 Specify the hierarchy name, up to 30 characters.
4 Specify the hierarchy description, up to 255 characters.
5 To select the field or fields on which you want to base the new hierarchy, select the Display check

box.
You can select several fields. A hierarchy can consist of just Product or Channel Product table fields,
or a mix of the two.

6 To change a field’s position in the nesting order, click it and click To Top, Up, Down, or To Bottom
to move it up or down in the hierarchy.

7 Click OK.
The hierarchy is saved to the database and listed in the Hierarchies dialog box.

Note:  Once created, the new hierarchy is immediately available to you and all other Infor Demand
Planning users in the Selection panes in Demand Forecaster.

Editing a hierarchy
1 In Database Administration select Product Admin and Hierarchies.
2 From the list, select the hierarchy that you want to edit and select Edit.

The Hierarchies dialog box is displayed. Selected fields are listed first, in the order in which they
have been saved. All other Channel Product and Product fields are listed below the selected fields.

3 To add fields to the hierarchy, select Display next to the field name.
4 To remove a field from the hierarchy, clear Display next to the field name.
5 To change a field’s position in the nesting order, click it and click To Top, Up, Down, or To Bottom

to move it up or down in the hierarchy.
6 Optionally, modify the hierarchy description.
7 Click OK.

Infor Demand Planning User Guide | 43

Selecting Products and Channels



Deleting a Hierarchy
1 In Database Administration, select Product Admin and Hierarchies.
2 From the list, select the hierarchy that you want to delete and select Delete.

The hierarchy is removed from the list and deleted from the database.

Selecting by Views

About views
A view is a named, re-usable set of one or more Products or Channel Products. A view that contains
only Products is a Product view; a view that contains Channel Products is a Channel Product view.
Views are typically used to select related groups of items.

See "Selecting views" on page 46.

You can create, edit, copy, split, combine and delete your own views. When you create a view, you
can save it as either a public view or a private view. A public view can be used by anyone with the
correct access privileges. A private view can be used only by you or a steward. Views generated by
Infor Demand Planning itself are known as exception views.

Special uses of views
There are three special uses of views:

• Exception views

An exception view is a system-created view that contains Products or Channel Products that are in
some way exceptional and which Infor Demand Planning wants to bring to your attention. All exception
views only appear once and are always owned by the database steward. Exception views may be
saved as predefined views.

See "About pre-defined views" on page 40.

In order to provide a more structured and user-friendly way to manage the 139 exception views that
are generated within Infor Demand Planning, it is possible to use a predefined list of items selected by
individual users which are stored on the database and may be used as an alternative to the standard
Product and Channel selection process. As all exceptions views are categorized with a severity and
can be assigned to various user roles, they can be used as a better basis for initiating a work flow.

The predefined option is only available if the PREDEF sign-on option is allocated to the current user.
The sign-on option for each user is maintained in the Maintain Users: ADD/EDIT dialogs within the
Database Administration module. The default sign-on module or Collaborate page is also selected in
these dialogs.

A predefined Product/Channel selection can be saved in any Infor Demand Planning module and in
Collaborate.

See "About exception views" on page 105.
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• Permanent forecast groups

A permanent forecast group view is a system-created view containing Product or Channel Products
that are grouped together for forecasting purposes.

See "About permanent forecast groups" on page 279.

• Marketing groups

A marketing group view is usually a public view containing Products or Channel Products that are
grouped together for promotional purposes.

See "About promotions" on page 290.

Ownership of public/private views
You are automatically the owner of all the public and private views that you create.

Restrictions on managing views
Permanent forecast groups and marketing groups can be managed only in the Demand Forecaster
module; all other views can be managed in the Database Administration module, provided that you
have the correct access privileges.

Also, you can edit exception views in which the currently selected Channel Product appears in both
the Demand Forecaster and Replenishment Planner modules.

See "Editing exception views in DF and RPD" on page 32.

If you are a non-steward user you can edit, copy, combine or split a view if you have data access
privileges to all of the Products or Channel Products in that view and it is not a private view owned by
another user. You can rename, overwrite or delete a view if it is a private or system view that you own.

If you are a steward, you have similar privileges except that you can also access other users’ views.

See "About access privileges" on page 61.

Reports
Infor Demand Planning has two reports that tell you what views there are and what Products and
Channel Products they contain.

• Detailed Report (Views)

This report shows views, and the Products or Channel Products within them. It shows, for each selected
view:

• The Products or Channel Products in that view.

• The view’s owner.

• The date the view was created or last edited.

• The type of view (private, public or system).

• The total number of Products or Channel Products in the view.
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• Cross Reference Report (Products and Channel Products)

This report shows Products and Channel Products, and the views of which they are members. It shows
each view’s owner, the date the view was created or last edited and the type of view (private, public
or system).

Selecting views
1 Select File > Select Products.
2 In the Select box, click View.
3 Optionally, you can specify a filter, a sort order, or a view into which to save the selection when it

is retrieved.
4 Click OK.

The Select Views dialog box is displayed.
5 Under Prod/CP View, specify whether you want to see Product views or Channel Product views.
6 Under View Type, specify the types of views you want to see: your private views, public views,

system views and marketing group views. (If you are a steward, you can also select the Select
other private views check box to see the private views of other users.)

7 Optionally, you can filter the views shown according to their names, descriptions or owners, by
selecting the Filter Views check box.
See "Filtering views" on page 55.
The available views are shown in the central panel of the Select Views dialog box.

8 Select the views you want.
9 Click OK.

Note: 

• At step 2, if you type V in the Select box and press ENTER, the Select Views dialog box is
displayed immediately.

• If you select a marketing group view, you get all the items in the view to which you have access;
but unless you have access to all the items in the view you are unable to edit the associated
promotions.

Selecting by Product Code

Selecting Product codes
1 Select File > Select Products.
2 In the Select box, click Product Codes.
3 Optionally, you can specify a filter, a sort order, or a view into which to save the selection when it

is retrieved.
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4 Click OK.
The Select Products dialog box is displayed.

5 Select the Products you want.
6 Click OK.

Note: At step 2, if you type P in the Select box and press ENTER, the Select Products dialog box
is displayed immediately.

Selecting recently-used Products
Infor Demand Planning keeps a record of your four most recent Product selections.

1 Select File > Select Products.
2 In the Select box, click one of the recently-used selections.

Recent selections are either a list of one or more Product codes or a list of one or more views:
p='code1','code2','code3'
v=view(user_ID),view(user_ID),view(user_ID)

3 Optionally, you can specify a filter, a sort order, or a view into which to save the selection when it
is retrieved.

4 Click OK.

Specifying a selection manually
1 Select File > Select Products.
2 In the Select box, type either:

• A list of Product codes of the form:
p='code1','code2','code3'

• A list of views of the form: 
v=view(user_ID),view2(user_ID),view3(user_ID)
where user_ID is the user ID of the view’s owner.

3 Optionally, you can specify a filter, a sort order, or a view into which to save the selection when it
is retrieved.

4 Click OK.

Note: Invalid codes are ignored; invalid views are reported as errors.
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Selecting Channels

Selecting Channels
1 Select File > Select Channels.
2 Under Options, if you want to select Channels of a particular type, click that type. If you want all

Channels, click All. Otherwise, the default option is Choice.
3 In the Channels box, select the Channels you want.
4 Click OK.

Note: 

• You must select Products before you can select Channels.

• Infor Demand Planning retrieves only the Channels that are applied to the currently-selected
Products.

Selections

Clearing the selection
Select File > Clear Selects or Clear Selection.

Saving the selection as a view
You can at any time save the current selection, however it was produced, as a view.

1 Select File > Save Current View.
2 Specify whether you want to save the selection as a Product view or a Channel Product view.
3 Specify whether the view is a private or public view.
4 Type a name for the view, or select the name of an existing view.
5 Optionally, type a description of the view.

Note: 

• You cannot save the selection as a Channel Product view unless both Products and Channels
have been selected.
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• At step 4, you can specify the name of an existing view if it is either a public view, or a private
view that you own. If it is a public or private view that you own, then saving the selection overwrites
the existing view. If it is a public view owned by someone else, then saving the selection produces
a view with the same name but owned by you.

• Different Infor Demand Planning modules use slightly different dialog boxes for this function.

Saving the selection as a pre-defined view
If your user id has been set up to use a predefined view, you can at any time overwrite your current
predefined view with the current selection.

See "About pre-defined views" on page 40.

1 In the Demand Forecaster, Database Administration or Replenishment Planner module, select File
>  Save selection as pre-defined view.

2 Click No (unless you want to save the original predefined view as a private Product or Channel
Product view).

Preserving selections between sessions
1 In Database Administration, select Settings > Edit Internal Settings.
2 Select the Save selections between sessions check box.

Note: This feature is usually restricted to stewards.

Filtering

About Product and Channel Product filters

What is a filter?
A filter is a sequence of constraints based on the values of database table fields. A Product filter is
based on Products table fields; a Channel Product filter is based on Channel Products table fields.

Each constraint includes three elements:

• A field from the Products or Channel Products table
• A constant value with which the field value is compared
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• An operator that specifies the relationship between the field value and the constant value:

Equal=

Greater than>

Less than<

Greater than or equal>=

Less than or equal<=

Not equal<>

Field is nullIS

Field is not nullIS NOT

(for alphanumeric values only)IncludesLIKE

(for alphanumeric values only)Does not includeNOT LIKE

Successive constraints are linked to each other by the logical operators AND and OR. You can also
bracket constraints together to make the logic of the filter clearer.

See "Examples of Product and Channel Product filters" on page 51.

What is an Advanced Filter?
An Advanced filter is a filter consisting of Product and/or Channel Product fields constructed using sql
syntax.

Advanced filters give the user the ability to create more detailed filters using the free form text editor.

See "Examples of Product and Channel Product filters".

When you can use filters
Product, Channel Product and Advanced filters can be used in two situations:

• When you are selecting Products

When you are selecting Products, you can apply a Product filter, a Channel Product filter, both a Product
and Channel Product filter, or an Advanced filter, to refine the Products that would otherwise be retrieved.
Notice that the filter always acts on some other selection, whether it is based on a view, or some other
method. This sort of filter is known as a pre-retrieval filter.

In Database Administration, a pre-retrieval Channel Product filter also affects the Channels that are
retrieved, as well as the Products (basically, it retrieves the Channels of the Channel Products that
satisfy the filter).

• After you have selected Products and Channels

After you have selected Products and Channels, you can apply a Product filter, a Channel Product
filter, or both to refine the current selection of Products and Channels via the File menu option.

This  form of filtering is not available in Database Administration.
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Private and public filters
You can save a Product or Channel Product filter as a private filter (one that only you can use) or a
public filter (one that anyone can use). You are the owner of any filters that you save.

The difference between filters and views
A filter always needs an existing selection of Products or Channel Products to which it is applied;
therefore, the items that satisfy a filter vary depending on what has already been selected. Often, you
will ensure that the initial selection contains all the Products and Channels that are accessible to you,
so that the filter has the widest possible application.

In contrast, a view is a static collection of Products or Channel Products that does not change unless
it is explicitly edited.

Another difference is that stewards cannot access the private filters of other users, but they can access
the private views of others.

Examples of Product and Channel Product filters
You build a filter by defining one or more constraints, linked by logical operators. The logic flows from
the first constraint to the last, although this can be modified by bracketing constraints together.

Example 1
To filter for Products whose codes begin with the text "Hob":

Logical)LogicalValueOperatorField(

   Hob%LIKEProduct Code 

Note the % wildcard character.

Example 2
To filter for Products that have a standard cost between €300 and €1000 inclusive (assuming the Euro
is the base currency):

Logical)LogicalValueOperatorField(

AND  300>=Standard Cost 

   1000<=Standard Cost 

Example 3
To filter for Products that either have a standard cost of at least €300 or are class A Products:

Logical)LogicalValueOperatorField(
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OR  300>=Standard Cost 

   A=ABC Class 

Example 4
To filter for Products that either have a standard cost between €300 and €1000 or are class A Products:

Logical)LogicalValueOperatorField(

AND  300>=Standard Cost 

OR  1000<=Standard Cost 

   A=ABC Class 

Another way of achieving the same effect would be:

Logical)LogicalValueOperatorField(

  AND300>=Standard Cost(

OR) 1000<=Standard Cost 

   A=ABC Class 

It is a good idea to use brackets whenever you have more than two constraints in your filter, to make
it easier to read.

Example 5
To filter for either class A Products that cost less than €300 or class B Products that cost more than
€1000:

Logical)LogicalValueOperatorField(

  ANDA=ABC Class(

OR) 300<Standard Cost 

  ANDB=ABC Class(

 ) 1000>Standard Cost 

Example 6
The previous examples are all Product filters, but Channel Product filters are defined in exactly the
same way.

To filter for class A Products that have a shelf life of less than 10 days, you need the following Product
filter:

Logical)LogicalValueOperatorField(

   A=ABC Class 
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And this Channel Product filter:

Logical)LogicalValueOperatorField(

   10<Shelf Life 

If you apply both a Product filter and a Channel Product filter when selecting Products, the Products
that satisfy both filters are retrieved. (In Database Administration, the Channels of the Channel Products
that satisfy both filters are also retrieved.)

Creating a filter
You can at any time create a new Product or Channel Product filter to filter the current selection.

1 Select File > Filter.

Note: The Filter command is not available in Database Administration. However, you can filter a
selection while you are making it.

The Filter Product Selection dialog box is displayed.
2 Click either the Product Filter tab, or the Channel Product Filter tab, as required.
3 For each line of the filter, select a field, an operator, then type a value. Click Add to add further lines

to the filter, and link successive lines by AND or OR operators. If necessary, use brackets to group
lines to make the logic of the filter clearer.
See "Examples of Product and Channel Product filters" on page 51.

4 Click Verify to verify the filter.
You can select the name of an existing filter if it is either a public filter, or a private filter that you
own. If it is a public or private filter that you own, then saving overwrites the existing filter. If it is a
public filter owned by someone else, then saving produces a filter with the same name but owned
by you.

5 If you want to save the filter for future use, click Save (otherwise, click OK).
The Save Filter dialog box is displayed.

6 Specify whether this is a private or a public filter.
7 Type a name for the filter, or select the name of an existing filter.
8 Optionally, type a description of the filter.

Loading a filter
You can at any time load a previously-saved filter to filter the current selection.

1 Select File > Filter.
The Filter Product Selection dialog box is displayed.

Note: The Filter command is not available in Database Administration. However, you can filter a
selection while you are making it.
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2 Click either the Product Filter tab, or the Channel Product Filter tab, as required.
3 Click Load.

The Select Filters dialog box is displayed.
4 Select the Private check box if you want to see your own private filters; click the Public check box

if you want to see your own and other users’ public filters.
5 In the Click filters to select list, click the filter you want, then click OK.

Deleting a filter
1 In Database Administration, select at least one Channel Product.

See "About selecting Products and Channels" on page 35.

2 Select File > Delete Filters.
The Delete Filters dialog box is displayed.

3 Click either Products or Channel Products, depending on whether you want to delete a Product
filter or a Channel Product filter, then click OK.
The Filter Deletion dialog box is displayed.

4 Under Filter Type, specify whether you want to see public or private filters, or both.
5 Click the filter you want to delete, then click Delete.

Note: 

• Filters can be deleted only within the Database Administration module.

• You have to select at least one Channel Product before the File > Delete Filters command
becomes available. It does not matter which Channel Product you select.

• Public filters can be deleted by anyone with the correct privileges. Private filters can be deleted
only by their owners.

Examples of view filters
You build a filter by defining one or more constraints, linked by logical operators. The logic flows from
the first constraint to the last, although this can be modified by bracketing constraints together.

Example 1
To filter for views whose names include with the word "Bath":

Logical)LogicalValueOperatorField(

   %Bath%LIKEView Name 

Note the % wildcard characters.
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Example 2
To filter for views whose descriptions include with the word "Depot" and are owned by John Doe:

Logical)LogicalValueOperatorField(

AND  %Depot%LIKEDescription 

   JOHN_DOE=Owner 

 

Filtering views
If there are very many views from which to select, you may want to filter the views shown in the Select
Views dialog box.

1 In the Select Views dialog, select the Filter Views check box.
The Filter Views dialog box is displayed.

2 Create a single- or multi-line filter to refine the views shown in the Select Views dialog box.
For each line of the filter, select either View Name, Description or Owner, an operator, and a value.
Click Add to add further lines to the filter, and link successive lines by AND or OR operators.
See "Examples of view filters" on page 54.

3 Click Verify to verify the filter.
4 Click OK to return to the Select Views dialog, where the filter is applied to the listed views.

Note: This filter merely narrows the set of views from which you can select. It does not filter the
Products or Channel Products within those views.

Specifying a pre-retrieval filter
You can specify a Product filter or a Channel Product filter (or both) so that, when a selection is retrieved,
only Products that satisfy the specified criteria are included. You can either create a new filter, or load
a previously-saved filter.

Creating a new Product or Channel Product filter
1  In the Select Products dialog, click either the Product Filter tab, or the Channel Product Filter

tab, as required.
2 For each line of the filter, select a field, an operator, then type a value. Click Add to add further lines

to the filter, and link successive lines by AND or OR operators. If necessary, use brackets to group
lines to make the logic of the filter clearer.
See "Examples of Product and Channel Product filters" on page 51.
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3 Click Verify to verify the filter.

Creating a new Advanced Filter
1 In the Select Products dialog, click the Advanced Filter tab.
2 Select a product and/or channel product field from the drop downs. Once selected the free form text

field is populated with the selected field(s).
3 Construct the filter using SQL syntax.

See "Examples of Product and Channel Product filters".

4 Click Verify to verify the filter.

Loading a filter
1 In the Select Products dialog, click either the Product Filter, Channel Product Filter, or Advanced

Filter tab as required.
2 Click Load.

The Select Filters dialog box is displayed.
3 Select the Private check box if you want to see your own private filters; click the Public check box

if you want to see your own and other users’ public filters.
4 In the Click filters to select list, click the filter you want, then click OK.

Note: 

• If you create a filter, you can click Save to save it as a private or public filter for future use.
• In Database Administration, a pre-retrieval Channel Product filter affects not only the Products

that are retrieved but also the Channels.

Specifying a pre-retrieval sort order
You can specify a sort order so that, when a selection is retrieved, it is already sorted.

1 In the Select Products dialog, click the Sort tab.
2 In the Source Data list, select a Products table field by which you want to sort the selection, then

click Add to move it to the Ascending Columns list. Repeat as necessary.
3 To move a chosen field up or down the sort order, click it in the Ascending Columns list and then

click Move Up or Move Down as required.
4 To sort a field in descending rather than ascending order, clear the check box next to that field in

the Ascending Columns list.

Note: 

• In Database Administration, the Select Products dialog does not have a Sort tab.
• Without an explicit sort order, items are listed in alphabetical order by their Product codes.
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Specifying a pre-retrieval view
You can specify a Product view to which the selection should be saved when it is retrieved.

1 In the Select Products dialog, click the Sort tab.
2 Specify whether the view is a private or public view.
3 Type a name for the view, or select the name of an existing view.
4 Optionally, type a description of the view.

Note: At step 3, you can select the name of an existing view if (a) you are a steward, or (b) it is a
public view or (c) it is a private view that you own. If it is a public or private view that you own, then
retrieving the selection overwrites the existing view. If it is a public view owned by someone else,
then retrieving the selection produces a view with the same name but owned by you.
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4Database Administration

About Database Administration
The principal functions for which one may use the Database Administration (DBA) module include:

• Add, edit, copy and delete users, and specify their system access privileges and data access
restrictions

• Add and delete Channels and Channel types

• Add, edit, copy, delete and apply Channel matrices

• Add and delete Products

• Add and delete Channel Products

• Add user-defined fields to the Products, Channels, Channel Products, Orders and Order Book tables.

• Create, edit, copy, split, combine and delete views

• Add, edit and delete static weightings

• Add, edit and delete time-phased weightings

• Edit the System, Products, Channels and Channel Products, Orders and Order Book tables

• Import and export data, and create, edit and delete import/export templates

• Add, edit, delete and apply discount factors

• Copy and aggregate history, and edit and delete open history

• Add, edit, copy and delete calendars

• Add and delete currencies and their rates of exchange

• Add, edit, copy, delete and apply interpolation vectors

• Add, edit and delete suppliers and supply channels

• Add, edit and delete transport types and alternative Channel transfer routes

• Edit application defaults and registry settings

At least one database must be available before starting this module. This may be Personal Oracle
running on the same computer or a database located on a remote Oracle server.
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Users

About user licensing
Infor Demand Planning supports two licensing schemes:

• Named users

Infor Demand Planning is limited to a specified total number of users. Each user must be logged on at
only one client PC. For example, if your licence is restricted to 10 named users, you can define only
10 users in Infor Demand Planning.

• Concurrent users

Infor Demand Planning is restricted to a specified number of users logged on at the same time. For
example, if your licence is restricted to 10 concurrent users, you can define any number of users in
Infor Demand Planning but only 10 can be logged on at any one time.

Individual modules within Infor Demand Planning and Infor Demand Planning - Collaborate are licensed
separately, possibly for different numbers of users; however, you cannot use different licensing schemes
within these applications.

For example, you can use named user licensing for the core modules, and concurrent user licensing
for Collaborate, and specify different numbers of named or concurrent users for each module within
those applications. But you cannot use, for example, named user licensing for Demand Forecaster and
concurrent user licensing for Replenishment Planner, because these are modules within the same
application.

See "About Infor Demand Planning" on page 17.

Note: 

• Distribution Planner is part of the Replenishment Planner module.

• Sales Budgeting & Tracking is part of the Demand Forecaster module.

About user roles
Five default user roles exist based on standard process functions, although it is possible to extend this
with up to 5 additional roles in order to match responsibilities more closely. The default roles are:

• Forecaster
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• Planner

• Inventory Planner

• Database Administrator

• DRP Planner

User roles are maintained in the Database Administration module. The ROLE_SYS_VIEW table holds
linked information between user roles and exception views. This table allows the storage of the exception
views that each active user role is assigned to. This is used to restrict information seen when accessing
exception views, based on the roles they have been assigned.

An exception view can be assigned to any number of active user roles, and a user role can be assigned
to any number of exception views (and users). As each exception view is created only once for all items
across the database, it is the use of user roles (assigned to users) that restricts exception view
information that is applicable to the individual user.

About access privileges

System access privileges
Each user’s access to Infor Demand Planning functions can be finely controlled, to the level of individual
menu commands, by granting and removing system access privileges.

See "Granting system access privileges" on page 64.

The ability to grant and remove access privileges is itself controlled by the "System: Access Control"
privilege.

See "Grantable access privileges".

Data access restrictions
Each user’s access to particular Product and Channel Product data can be restricted by defining a filter
based on the values of selected Products or Channel Products table fields.

See "Restricting data access" on page 65.

Defining generic users
You may want to define generic users and use them to define real users. For example, you can define
a generic PLANNER user, then add individual planners by copying and, if necessary, editing the generic
PLANNER user.

1 Add the generic user.
See "Adding a user" on page 62.
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2 Grant system access privileges to the generic user.
See "Granting system access privileges" on page 64.

3 Optionally, restrict the generic user’s data access.
See "Restricting data access" on page 65.

4 Add a real user by copying, then editing the generic user’s details.
See "Copying a user" on page 63.

Adding a user
If your Infor Demand Planning installation uses named user licensing, you cannot add more users than
permitted by your licence agreement.

1 In Database Administration, select DB Admin > Maintain Users.
2 Click Add.
3 Specify this information:

User ID
Specify a unique user ID for the user. User IDs must be uppercase, and cannot contain spaces.

User Name
Optionally, specify the name of the user.

User Role
Select the role with which the user can access Oracle from Infor Demand Planning.
This role is typically ML_USER or ML_STEWARD. See "Editing registry settings" on page 68.

Caution: Three Oracle roles are predefined:

• ML_USER for normal users
• ML_STEWARD for stewards
• ML_READ for users who have read-only access to the database

To avoid accidental changes to the database, we strongly advise you to select ML_READ
as the default role to access Oracle outside of Infor Demand Planning.

Default Role
Optionally, select a role with which the user can access Oracle outside Infor Demand Planning.
This role is typically ML_READ.

4 Optionally, specify the user location, that is, the address, phone number, fax number, and e-mail
address.

5 Select the default Collaborate function screen and Channel Product selection option from the Sign-on
Options lists.

6 Select the Steward option if the user is an Infor Demand Planning database steward.
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7 Click Next.
8 Select the Infor Demand Planning modules that the user can access.
9 Click Add User.

Caution: After adding a user, you must grant the user specific system access privileges and,
optionally, restrict the user's access to data.

Copying a user
If your installation of Infor Demand Planning uses "named user" licensing, you cannot add more users
than permitted by your licence agreement.

1 In Database Administration, select DB Admin > Maintain Users.
2 Click the user who you want to copy.
3 Click Copy.
4 Specify a unique ID for the new user.
5 Edit the other details as required.
6 If you want the new user to inherit the data access restrictions of the copied user, select this option:

Copy data access in addition to system access rights.

The new user automatically inherits the system access privileges of the copied user.

Editing a user
1 In Database Administration, select DB Admin > Maintain Users.
2 Click the user that you want to edit.
3 Click Edit.
4 Edit the user’s details as required.

Note: You cannot edit the user’s ID.

Deleting a user
1 In Database Administration, select DB Admin > Maintain Users.
2 Click the user who you want to delete.

Note: 

• You cannot delete the predefined STEWARD user.
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• You cannot delete users who currently have this access privilege: System: Protected User.
This privilege must first be removed by a steward.

• Users without any access privileges are automatically deleted.

3 Click Delete, then Yes to confirm.

Granting system access privileges
1 In Database Administration, select DB Admin > Maintain Users.
2 Click the user for whom you want to grant or remove privileges.

You cannot change your own privileges.

3 Click System Access.
4 To grant privileges, select them in the Grantable Privileges list and click Add.

To grant all privileges except these privileges, click Add All:

• System: Access Control
• System: Lock Access Privileges
• System: Protected User

These three privileges must always be granted explicitly.
See "Grantable access privileges".

5 To remove privileges, select them in the Privileges Held list and click Remove. Click Remove All
to remove all privileges.

Granting user roles
1 In Database Administration, select DB Admin > Maintain Users.
2 Click the user for whom you want to grant or remove roles.
3 Click Define Roles.
4 To grant roles, select them in the Grantable Roles list and click Add.

To grant all roles, click Add All.

5 To remove roles, select them in the Roles Granted list and click Remove.
To remove all roles, click Remove All.

Granting buyer groups
1 In Database Administration, select DB Admin > Maintain Users.
2 Click the user for whom you want to grant or remove buyer groups.
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3 Click User Buyers.
4 To grant buyer groups, select them in the Buyers Group Code list and click Add.

To grant all buyer groups, click Add All.

5 To remove buyer groups, select them in the Selected Buyer Groups list and click Remove.
To remove buyer groups, click Remove All.

Restricting data access
1 In Database Administration, select DB Admin > Maintain Users.
2 Click the user for whom you want to restrict access to data.
3 Click Data Access.
4 Create a single or multi-line filter to restrict the user’s access to product or channel product data.
5 For each line of the filter, select a Product or Channel Product field, an operator, and a value.

Click Add to add further lines to the filter, and link successive lines by AND or OR operators.
See "Examples of data access filters".

6 Click Verify to test the filter.
If a filter is not defined, the user has unrestricted access to all product and channel product data.

Defining user roles
1 In Database Administration, select View Admin > User Role Maintenance.
2 In the Maintain User Roles dialog box, select the Active check box for the selected user role.
3 Click OK.

Monitoring and locking users
You can find out who is currently logged on to Infor Demand Planning. You can also specify who can
log on in the future.

1 In Database Administration, select DB Admin > Monitor Users.
The User Monitor dialog box lists the users who are currently logged on or locked out. Users who
are logged on are indicated by a non-zero session count.

2 To prevent a user who is currently logged on from logging on in the future, select the Lock Out
check box for this user.
The user is not immediately logged off.

3 You can lock out users who are not currently logged on:
a To lock out all users except yourself and stewards, click Lock All.
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b Clear the relevant Lock Out check boxes.
You cannot lock yourself or stewards out.

Changing your password
At first, your password is the same as your user ID. You can change your password in Database
Administration, Demand Forecaster and Replenishment Planner.

1 Do one of the following:

• In Database Administration, select DB Admin > Change Password.
• In Demand Forecaster, select Tools > Change Password.
• In Replenishment Planner, select Tools > Change Password.

2 Specify this information:

Old Password
Type your current password.

New Password
Type your new password.

Verify Password
Type your new password again.

Note: 

• Passwords are not case-sensitive prior to Oracle 11g, but are case-sensitive from Oracle 11g
onwards.

• A password cannot include spaces or begin with a number.

If you forget your password
If you forget your password, inform a steward. There is no easy way to recover a lost password.
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Databases

About monthly- and weekly-controlled databases
A database can be set up to be either monthly-controlled or weekly-controlled. The decision rests
primarily on whether you intend to adjust the statistical forecast with market intelligence on a monthly
or weekly basis.

• In a monthly-controlled database, market intelligence is stored in monthly periods, and can be
specified only in monthly amounts.

• In a weekly-controlled database, market intelligence is stored in weekly periods, although you can
specify it in either monthly or weekly amounts.

However, the decision to use a weekly-controlled database has some important consequences:

• The monthly forecast must be interpolated into weekly periods (you specify this in the System table).

• You have to apply the same demand calendar at all Channels, because otherwise the forecast
would not be interpolated in the same way at all levels.

• The type of the demand calendar must be either 4-4-5 or 13 equal periods, because there must be
an integer number of weeks in each month.

• A weekly-controlled database cannot be changed to a monthly-controlled database, orvice-versa
(at least, not easily).

In a weekly-controlled database, you can decide whether you want to store history monthly, weekly or
daily, and also, for each Channel, whether to accumulate daily or weekly demand into monthly demand
at period end. When populating the database for the first time, monthly history must be loaded because
this is required to generate the statistical model.

Registry Settings

About registry settings
Database Administration needs to save certain parameters between sessions. These are stored in the
Windows registry ready for the next time Database Administration is loaded.

There are three groups of registry settings:

• System settings

These settings include the path and file name of the Database Administration program file, language
file (for the user interface), help file and resource folder (where the application’s bitmaps are stored).
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You can also specify whether you want Infor Demand Planning to remember your Product and Channel
Product selections between sessions.

• Products and Channel Products table settings

These settings relate to how the Products and Channel Products tables are displayed for editing.

• Oracle settings

These settings specify the default Oracle roles for Infor Demand Planning users and stewards. An
Oracle role is a set of permissions that define what database tables a user with that role is allowed to
access, and how. You must also specify what versions of Oracle are supported by this installation of
Infor Demand Planning.

The three predefined Oracle roles are:

• ML_STEWARD; this role allows the user to read, select, write and delete data, and set user privileges
in the Oracle database.

• ML_USER; this role allows the user to read, write and delete data.

• ML_READ; this role allows the user to read and select data.

Important

• You should rarely, if ever, need to edit this information. Do not edit this information unless you are
sure you know what you are doing. If in doubt, contact Infor Demand Planning Technical Support.

Editing registry settings
1 In Database Administration, select Settings > Edit Internal Settings.

The Registry Editor dialog box is displayed.
2 On the System Settings tab, specify the path and file name of the Database Administration program

file, language file (for the user interface), help file and resource folder.
3 Select the Save selections between sessions check box if you want Infor Demand Planning to

preserve your Product and Channel Product selections from one session to the next.
4 Select the Enable splash screen check box if you want Infor Demand Planning to display a logo

every time it starts.
5 On the Product/CP Table Editing tab, specify whether you want to see each Channel Product’s

local (that is, Channel-specific) code and description when editing the Channel Products table. You
can also specify the point size of the font used to display database tables, and whether or not the
column headings are to be displayed in bold.

6 On the Oracle Roles and Settings tab, specify the default Oracle roles for ordinary users and
stewards. You can also specify up to three vendor codes that identify the Oracle database versions
supported by this release of Infor Demand Planning.

• You need to restart Infor Demand Planning for any changes to take effect.

• You should be cautious about editing the registry settings. Inappropriate values may cause Infor
Demand Planning to stop working properly.
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Database Profiles

About database profiles
A database profile defines an Oracle database that can be accessed by Infor Demand Planning. A
database profile consists of the following settings:

• A database name. This is the name by which the database is referenced within Infor Demand
Planning.

• A TNS name. This is the command fragment required to connect to the database.

• A URL. This is the connection string to Collaborate.

• A schema name. This is the name of the Oracle schema that defines the database..

• The DBMS. This is the version of Oracleappropriate for this database, selected from among those
defined in the registry settings.

• A connection pool. This is used when connecting to Collaborate.

• The maximum attempts allowed when connecting to Collaborate.

• The cycle time. This is the Collaborate pool cycle time in minutes.

• The default user ID to be suggested when users log on to this database. The user can, of course,
use another valid user ID.

One or more database profiles are defined for you when Infor Demand Planning is installed.

Important

• You should rarely, if ever, need to edit this information. Do not edit this information unless you are
sure you know what you are doing. If in doubt, contact Infor Demand Planning Technical Support.

Maintaining database profiles
Database profiles are maintained in the Database Settings dialog box of the Infor Demand Planning
Maintenance Tool. See the Infor Demand Planning Installation Guide for more information or contact
Infor Demand Planning Technical Support.
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Application Defaults

About application defaults
The application defaults do not relate to Infor Demand Planning itself but to the current database. More
precisely, they are attributes of database table fields. You can change the following attributes of each
field:

• The name or description of the field as it appears in editable tables within Infor Demand Planning.

• The width of the field as it appears in editable tables within Infor Demand Planning.

• The default initial value of the field.

• The field’s active status; that is, whether it is unused, read-only or editable.

• The field’s report category, if it is a user-defined Channel Products table field.

Note: 

• If you change the status of a field whose value is calculated by Infor Demand Planning from read-only
to editable, an Oracle error may result.

• A read-only field cannot be edited within Infor Demand Planning but can still be changed by importing
data from outside Infor Demand Planning.

Editing application defaults
1 In Database Administration, select DB Admin > Application Defaults.

The Application Defaults dialog box is displayed.
2 In the left-hand panel, select the database table you want to edit.

The fields of the selected table are displayed in the right-hand panel. You can edit the following
attributes of a field:

• The name or description of the field as it appears in editable tables and grids within Infor Demand
Planning.

• The width of the field as it appears in editable tables and grids within Infor Demand Planning.

• The default initial value of the field.

• The field’s active status, that is, whether it is unused, read-only or editable.

• The field’s report category, if it is a user-defined Channel Products table field.

3 To edit an attribute, click its cell, type or select a new value, then click outside the cell.
4 Click Apply to save the changes you make.
5 Repeat steps 2 to 4 for each table you want to edit.

If you change the status of a field whose value is calculated by Infor Demand Planning from read-only
to editable, an Oracle error may result.
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Channels

About Channels
The term "Channel" as it is used in Infor Demand Planning must not be confused with the more familiar
concept of a distribution channel, although there are some similarities.

In Infor Demand Planning, a Channel can represent a physical location such as a factory, depot or
warehouse, or a less tangible element such as a sales region or market sector. It can also be a theoretical
aggregate, such as the sum total of all a company’s depots.

Channel types
Infor Demand Planning includes up to ten predefined Channel types which can be edited to suit your
implementation.

• Region• Factory

• Depot • Country

• Division• Sales region

• Customer • Field Stocks

•• Total (all-purpose aggregate)Distribution center

When you create a Channel, you must say what type of Channel it is.

See "About Channel types" on page 77.

Channel behaviors
Every Channel is characterized by a set or vector of nine behaviors. Initially, these behaviors are
inherited from the Channel type, but they can be replaced or edited when the Channel is added to a
Channel matrix.

Collectively, a Channel’s behaviors govern how the statistical forecast, sales/demand history and stock
requirements are stored at, passed to or accepted from its superior and subordinate Channels in a
Channel matrix.

See "About Channel behaviors" on page 72.

Channel matrices
A Channel matrix is a collection of Channels assembled in a hierarchical or pyramidal structure.

You can define as many Channel matrices as you need. A Channel can appear in several different
matrices, and its behaviors may be different in each one.

See "About Channel matrices" on page 78.
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About Channel behaviors
Every Channel is characterized by a set or vector of twelve behaviors. Each behavior can be either
enabled or disabled by means of check boxes.

"Store History" on page 72  Store History

"Accept Forecast" on page 72  Accept Forecast

"Exclude Passing Up Net" on page 73  Exclude Passing Up Net

"Adjust Using Forecast Below" on page 73  Adjust Using Forecast Below

"Adjust Using MI Below" on page 73  Adjust Using MI Below

"Force Forecast Down" on page 73  Force Forecast Down

"Calculate Channel Requirements" on page 73  Calculate Channel Requirements

"Pass Up Requirements" on page 74  Pass Up Requirements

"Exclude From History Pass Up" on page 74  Exclude From History Pass Up

 

Note that some of these behaviors are mutually incompatible; Infor Demand Planning prevents you
making impossible choices.

Store History
Yes: History is stored at this Channel. In most databases this behavior is appropriate to the lowest
Channels in the Channel matrix, but it is also possible to store history at aggregate Channels.

No: History is not stored at this Channel, but can be forcibly aggregated up from any subordinate
Channels.

Back to top: "About Channel behaviors" on page 72

Accept Forecast
Yes: The net forecast at this Channel is adjusted by accepting (a proportion of) the net forecast at a
superior Channel in the Channel matrix from which the forecast is forced down. The adjustment is
achieved by adding C-type market intelligence to this Channel’s statistical forecast.

The method of spreading the forced-down forecast for an item is defined by the "Forecast Forcing Code
(CPt)" field at the superior Channel. There are four possibilities:

• Spread in proportion to the monthly forecasts held at the subordinate Channels.

• Spread in the proportions defined by the "Forecast Forcing Factor (CPt)" fields at the subordinate
Channels.

• Spread in proportion to the annual usages held at the subordinate Channels.

• Spread in proportion to the last 12 months of adjusted history at the subordinate Channels.

No: The net forecast at this Channel is not affected by the forecast at any superior Channel.
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Back to top: "About Channel behaviors" on page 72

Exclude Passing Up Net
Yes: The net forecast at this Channel is not available to be passed up to any superior Channels in the
Channel matrix. If a consistent forecast is not required at a superior Channel, this behavior often
improves the performance of the database.

No: The net forecast at this Channel may be passed up to any superior Channels in the Channel matrix.

Back to top: "About Channel behaviors" on page 72

Adjust Using Forecast Below
Yes: The net forecast at this Channel is adjusted using C-type market intelligence so that it equals the
sum of the net forecasts held at any subordinate Channels (omitting only those subordinate Channels
that have the Exclude Passing Up Net behavior).

No: The net forecast at this Channel is not affected by the forecast at any subordinate Channel.

Back to top: "About Channel behaviors" on page 72

Adjust Using MI Below
Yes: The market intelligence at this Channel is adjusted so that it equals the sum of the market
intelligence held at any subordinate Channels (omitting only those subordinate Channels that have the
Exclude Passing Up Net behavior).

No: The market intelligence at this Channel is not affected by the market intelligence at any subordinate
Channel.

Back to top: "About Channel behaviors" on page 72

Force Forecast Down
Yes: The net forecast at this Channel is forced down to any subordinate Channels that can accept
forecasts (that is, those subordinate Channels that have the Accept Forecast behavior).

No: The net forecast at this Channel does not affect the forecasts at any subordinate Channels.

Back to top: "About Channel behaviors" on page 72

Calculate Channel Requirements
Yes: A schedule of requirements for stock to arrive at this Channel is calculated.

• If requirements are not passed to this Channel from below then the schedule is based on the net
forecast at this Channel.

• If requirements are passed up from below then the schedule is based on the sum of the requirements
from subordinate Channels and any extra needs for safety stock at the aggregate Channel.

Infor Demand Planning User Guide | 73

Database Administration



It is not normally possible to sum requirements from subordinate Channels and at the same time
incorporate a local forecast in the requirements calculation. If necessary, the local market must be
defined as a separate Channel.

(However, if alternate sourcing is enabled, a Channel may have its own forecast requirements and
also DRP requirements arising from items alternately sourced from there.)

No: The requirements for stock at this Channel are not calculated.

Back to top: "About Channel behaviors" on page 72

Pass Up Requirements
Yes: Requirements at this Channel are passed up to the primary superior Channel in the hierarchy.

No: Requirements at this Channel are not passed up to superior Channels.

Back to top: "About Channel behaviors" on page 72

Exclude From History Pass Up
Yes: History stored at this Channel cannot be aggregated to its superior Channels. This behavior is
most often used to stop history being passed up both branches of a folded Channel matrix. For example,
if history is stored at two subordinate Channels where one is a plant and the other a sales region, both
sets of history should not be summed at the superior Channel.

See "About folded Channel matrices" on page 80.

No: History stored at this Channel can be aggregated up to its superior Channels.

Note that Infor Demand Planning does not aggregate history automatically; you must explicitly request
this function.

See "About aggregating history" on page 162.

Back to top: "About Channel behaviors" on page 72

 

Exclude Aggregated Mi

Yes: If this check box is selected, MI aggregated from other channels in the matrix, is not passed to
other channels.

Used in relation to the Force Forecast Down, Force Mi Down and Adjust using forecast from below
options.

No: If this check box is selected, MI aggregated from other channels in the matrix is passed to other
channels.

A channel cannot be set to Force Forecast Down and Force Mi Down, it must be forcing down Mi or
Forecast.

Back to top: "About Channel behaviors" on page 72

 

Force Mi Down
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Yes: If this check box is selected, all Market Intelligence at this level is forced down to lower level
channels. Aggregated Mi is excluded from the spread when the Exclude Aggregated Mi option is also
selected.

No: If this check box is selected, Market intelligence at this channel is not forced to lower level channels.

Back to top: "About Channel behaviors" on page 72

 

Accept Mi

Yes: If this check box is selected, MI is accepted at this channel from other channels in the matrix.

No: If this check box is selected, MI is not accepted at this channel.

Back to top: "About Channel behaviors" on page 72

 

Exclude Aggregated Mi, Force Mi Down and Accept Mi options allow the creation of three new types
of channel relationship, creating 'Partial control channels'

• Accept Mi, Force Forecast Down, Exclude Aggregated MiThis allows the control to be maintained
at the upper level of the channel structure without the individual MI below being over written.

• Adjust using forecast from below, Force MI down, Exclude Aggregated Mi. This allows the
control to be maintained at the Lower level of the channel structure without the individual MI above
being over written.

• Accept Mi, Force MI down, Exclude Aggregated Mi. This allows the control to be maintained at
the upper level of the channel structure without the individual MI below being over written.

Adding Channels
1 Database Administration, select DB Admin > System > Add Channels.

The Add Channels dialog box is displayed.
Use the Help button in the Add Channels dialog to get more information about each tab.

2 On the Channels tab, specify this information:

• A unique Channel code of up to 20 characters.

• The name or description of the Channel.

• The default type of this Channel, selected from the predefined Channel types.
See "About Channel types" on page 77.

• The demand calendar to be used by this Channel.
See "About demand calendars" on page 170.
In a monthly-controlled database, different Channels can use different demand calendars, and
have different fiscal years, provided that the calendars all have the same number of forecast
periods per year.
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• The end date of the current fiscal year.

• The end date of the most recent historical period.

• The number of periods of history that have been input for the current fiscal year.

3 On the Details tab, specify this information:

• The group code of the Channel group to which this Channel belongs, if any.

• The date that stock quantities at this Channel were last updated, if known.

• The first day of the working week (for replenishment planning).

• Whether recommended shipments are automatically processed without user review.

• A deployment horizon (expressed in days).

• An interval (expressed in days) in which recommended orders can be firmed to planned orders,
and planned orders can be firmed to open orders.

• Whether daily history at this Channel is to be accumulated into weekly history, and whether daily
or weekly history at this Channel is to be accumulated into monthly history.

• Whether back orders are allowed (that is, whether projected on-hand stock can fall below zero).

• How the forecast at this Channel is consumed by actual demand within a forecast period.

4 On the User Dates, User Strings and User Numbers tabs, specify the values of any user-defined,
editable Channel fields.
"Editing user-defined Channel fields" on page 89

5 Click OK.
6 If you want to add another Channel, click Add Another Channel and repeat steps 2 to 5. When

you have finished adding Channels, click Finish.
Infor Demand Planning confirms the number of channels added and asks if you want to edit the
corresponding Channels table entries.

Deleting Channels
1  In Database Administration, select DB Admin > System > Delete Channels.

The Delete Channels dialog box is displayed, showing all the currently-selected Channels.
2 On the Select Channels to be Deleted tab, select the channels you want to delete. To select all

Channels, click Select All.
3 Click Next. The Channels to be Removed from Database tab appears, showing the selected

Channels and indicating whether or not they can be deleted.
4 Click Next to delete the Channels marked as OK to Delete, then click Yes to confirm.

• Deleting a Channel also deletes any associated Channel Products and removes the Channel
from any Channel matrices of which it is a part.
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• Channels that are the primary or secondary parents in any Channel matrix cannot be deleted.
You must first edit the relevant Channel matrices to remove this status.

5 When the Channels have been deleted, click OK to acknowledge, then click Close.

Channel Types

About Channel types
The following Channel Types are available by default:

DescriptionNo.

 
Factory

 
1.

 
Depot

 
2.

 
Sales

 
3.

 
Customer

 
4.

 
Distribution

 
5.

 
Region

 
6.

 
Country

 
7.

 
Division

 
8.

 
Field Stocks

 
9.

 
Total

 
10.

Each Channel type consists of:

• A name or description

• A set or vector of behaviors

Infor Demand Planning User Guide | 77

Database Administration



• A symbol representing this type

A maximum of 100 Channel Types can be added to the database.

When you create a Channel, you must select one of these Channel types to be its default type.

When you add a Channel to a Channel matrix, the Channel inherits the behaviors and symbol of its
default type.

You can, if necessary, edit a matrix to change the change the types and behaviors of its Channels.
Thus a Channel’s behaviors in one matrix may be quite different from its behaviors in another matrix.
However, to avoid confusion it is best to define a set of default Channel types, and keep to them.

Defining Channel types
You can define up to one hundred Channel types.

1 In Database Administration, select DB Admin > System > Channel Types.
The Channel Types dialog box is displayed, showing an editable table of the existing Channel types.

2 To add a new Channel type, on the Edit menu click Add New Channel Type.
You can use the Channel Types toolbar instead of the Edit menu.

3 To define the default behaviors of a Channel type, select or clear the corresponding check boxes
in the table.
See "About Channel behaviors" on page 72.

4 To assign a symbol to a Channel type, click the drop-down button in its Channel Bitmap cell and
select a new symbol from the list.

5 To name or rename a Channel type, click its Channel Description cell, type the new name and
then click outside the cell.

Channel Matrices

About Channel matrices
A Channel matrix is a collection of Channels assembled in a hierarchical or pyramidal structure.

For example, the Channel at the top of the hierarchy often represents a factory, intermediate Channels
may represent distribution centers or depots, while the lowest Channels may represent customers.
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In this example, sales/demand history and requirements are likely to be aggregated from the bottom
upwards, while stock is distributed from the top downwards. However, many other structures are
possible, including matrices with more than one branch.

Every Channel is characterized by a set or vector of nine behaviors that govern how the statistical
forecast, sales/demand history and stock requirements are stored at, passed to or accepted from its
superior and subordinate Channels in a particular matrix. (A Channel’s behaviors in one matrix may
be entirely different from its behaviors in another matrix.)

You can define as many Channel matrices as you need.

See "Adding a Channel matrix" on page 80.

Folded Channel matrices
A folded Channel matrix is one which at least one Channel has a secondary as well as a primary parent.
The secondary parent must be a in a separate branch of the matrix.

See "About folded Channel matrices" on page 80.

Applying a Channel matrix to Products
Once defined, you apply a Channel matrix to selection to one or more Products. No Product can be
associated with more than one Channel matrix.

Applying a matrix to a Product does not necessarily mean that the Product exists at all of the Channels
in that matrix. But it does mean that the Channels where that Product does exist must be a subset of
those in the matrix. In Infor Demand Planning, every combination of a particular Product at a particular
Channel is known as a Channel Product.

Infor Demand Planning allows you to specify one Channel matrix to be a default which is automatically
applied to all newly-imported Products.

Editing a Channel matrix
If you edit a Channel matrix, this change may not be immediately apparent to other Infor Demand
Planning users because some data is cached locally. Users may have to log off from Infor Demand
Planning and then log on again to see the changed matrix.
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About folded Channel matrices
In a regular Channel matrix, each subordinate Channel has only one parent Channel, the so-called
primary parent. However, it is possible for a Channel to have a secondary parent in another branch of
the matrix. In this case, the matrix is said to be "folded".

In the following example, the matrix comprises two branches, topped by the Manufacturing and Account
Management Channels. Unbroken lines represent the primary structure, while the broken lines represent
the secondary structure of the matrix.

Note that, even though a Channel’s secondary parent is in another branch of the matrix, it must still be
at a higher level in the matrix to qualify as a parent. For example, Corporate could not be a secondary
parent to Distribution Centre A, because both these Channels are on the same level of the matrix.

Why are folded matrices useful?
Folded matrices enable Infor Demand Planning to more accurately reflect the flow of information in
your organization.

In the example above, it would be possible to define the individual Channel behaviors so that a forecast
made at Account Management is forced down to the Customer Channels, and so that the requirements
calculated at Customer Channels can be passed back up through Distribution Centre A and Distribution
Centre B to Manufacturing.

See "About Channel behaviors" on page 72.

Note: 

• A structure that links Channels in a '\/\' or a '/\/' shape, where market intelligence is moved down
one side of the structure and then up the other (or up one side and down another, respectively) is
perfectly acceptable, but structures shaped ‘/\/\’ or ‘\/\/’ are currently not allowed.

Adding a Channel matrix
1 In Database Administration, select DB Admin > Channel Structure.

The Channel Matrix Maintenance dialog box is displayed.
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2 Click Add.
The Channel Matrix Maintenance: Add dialog box is displayed. In the center of the Channel Matrix
Explorer tab is the Matrix panel where the matrix is assembled. At first, the panel is empty except
for the apex symbol.

3 Type a name for the new matrix in the Matrix name box.
4 In the Channel list on the left-hand side of the tab, select the Channels that you want to include in

the matrix. You can select all Channels of a particular type by clicking the corresponding Options
button.

5 Either click Add, or drag the selected Channels into the Matrix panel.
Each Channel in the matrix is identified by its Channel code, its symbol and, if you select the Show
Channel Names check box, its name. Channels that have been added to the Matrix panel are
shaded green in the Channel list.

6 Drag individual Channels to their required places in the matrix.
Click the Expand and Collapse icons to expand and collapse branches of the matrix. Click Collapse
and Expand to collapse and expand the entire matrix.

7 To change the type of a Channel in the matrix, click the Channel and select a different type from
the right-hand Set to Channel Type list box. The Channel acquires the symbol and behaviors of
the selected type.

8 To change the behaviors of a Channel in the matrix, click the Channel and select or clear the check
boxes in the Behaviour of selected channel area.
See "About Channel behaviors" on page 72.

9 To fold the Channel matrix, click each of the affected Channels in the matrix in turn and select a
secondary parent from the Secondary Chan list box. This list is constrained to show only those
Channels that are capable of being secondary parents.
See "About folded Channel matrices" on page 80.

10 To view a diagram of the matrix, click the Channel Matrix Graphical Display tab.
11 To apply the matrix to either the current or a new selection of Products, click Apply Matrix to

Products.
See "Applying a Channel matrix to Products" on page 82.

12 To save the current state of the matrix, click Apply. When you are satisfied, click OK.

Note: 

• Get advice from your Infor Demand Planning consultant before attempting to set up a folded
matrix.

• Changing the type of a Channel in the Channel Matrix Maintenance: Add dialog does not change
the Channel’s default type; it changes only the symbol and behaviors of the Channel within this
particular matrix.

• Use the Help button in the Channel Matrix Maintenance: Add dialog to get more information
about each tab.
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Editing a Channel matrix
1 In Database Administration, select DB Admin > Channel Structure.

The Channel Matrix Maintenance dialog box is displayed.
2 Click the matrix you want to edit, then click Edit.

The Channel Matrix Maintenance: Edit dialog box is displayed.
Use the Help button in the Channel Matrix Maintenance: Edit dialog to get more information about
each tab.

3 You can edit any characteristic of the matrix, as if you were adding it for the first time.
See "Adding a Channel matrix" on page 80.

Copying a Channel matrix
1 In Database Administration, select DB Admin > Channel Structure.

The Channel Matrix Maintenance dialog box is displayed.
2 Click the matrix you want to copy, then click Copy.

The Channel Matrix Maintenance: Copy dialog box is displayed, showing a copy of the selected
matrix.
Use the Help button in the Channel Matrix Maintenance: Copy dialog to get more information about
each tab.

3 Type a name for the new matrix in the Matrix name box.
4 You can edit any characteristic of the copied matrix, as if you were adding it for the first time.

See "Adding a Channel matrix" on page 80.

Deleting a Channel matrix
1 In Database Administration, select DB Admin > Channel Structure.

The Channel Matrix Maintenance dialog box is displayed.
2 Click the matrix you want to delete.

You cannot delete a matrix that is currently applied to one or more Products. You must first apply
another matrix to those Products.

3 Click Delete, then click Yes to confirm.

Applying a Channel matrix to Products
You can apply a Channel matrix to Products when creating the matrix, or by editing the matrix. The
following procedure assumes you are editing the matrix.

1 In Database Administration, select DB Admin > Channel Structure.
The Channel Matrix Maintenance dialog box is displayed.

2 Click the matrix you want to edit, then click Edit.
The Channel Matrix Maintenance: Edit dialog box is displayed.
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3  Click Apply Matrix to Products.
You can also effectively apply a matrix by editing the Channel Matrix Code column of the Products
table. See the help topic on editing the Products table.

4 If there is a current selection of Products, click Yes if you want to apply the matrix to that selection,
or No if you want to make another selection.
See "About selecting Products and Channels" on page 35.
Once the selected Products have been updated, the Channel Matrix Maintenance: Edit dialog
re-appears.

Products

About Products
In Infor Demand Planning, a Product is typically any item which is produced, procured and consumed
in discrete quantities.

Product types
• Standard Product

The majority of items are likely to be of this type. Standard Products are further classified:

• Normal Products are items whose pattern of demand is regular and common enough to be forecast
by dynamic linear modeling (DLM).

• Slow-Moving Products (SMPs) are items whose demand is too irregular to be forecast by DLM.
SMPs typically show many periods in which there is no recorded demand at all; in fact, this is how
Infor Demand Planning identifies them.

See "About Slow Moving Products" on page 271.

• Non-Standard Product (NSP)

A Product variant used in promotional activities (for example, 3-for-2 offers, or "buy one get one free").
Infor Demand Planning allows you to link NSPs to related Standard Products in a variety of ways. For
example, a promotional pack may be assembled from two or more standard items, or a promotional
pack may steal demand from one or more standard packs.

• Unspecified Forecast Product (UFP)

A dead Product that may become live, or a notional Product used to forecast a proposed item to allow
its predicted sales to be taken into account in budgeting and capacity planning. A UFP can be upgraded
to a Standard Product when appropriate.

See "About Unspecified Forecast Products" on page 274.
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• Forecast Group Product

A notional Product used as the placeholder for a system view of Standard Products that are to be
forecast collectively as a permanent forecast group (PFG). This is often useful in detecting seasonal
demand patterns that can then be applied to new Products added to the group (for example, a new
flavor or a new pack size).

See "About permanent forecast groups" on page 279.

• Returns Product

A Product returned to stock (linked to base Products in Demand Forecaster).

See "About Returns Products" on page 274.

• Scenario Product

A fictitious variant of a real Product created to try, and save, "what-if" forecast projections. If the
projections prove valuable, the Scenario Product’s forecast can replace the original Product’s forecast.

See "About Scenario Products" on page 276.

Product status
• Live

A live Product is one which is actively processed, forecast and reported by Infor Demand Planning.

• Dead

A dead Product can be kept in the database for future reference but is not used in any processing and
does not appear in any reports.

Adding Products
You can add new products manually. If you need to add more than a few products at once, it is usually
quicker to import products table records.

1 In Database Administration, select DB Admin > Add Products.
2 On the Product tab of the Add Products dialog box, specify this information:

• A unique product code of up to 20 characters.
• The name or description of the product.
• The type of the product:

• Standard Product.
• Non-Standard Product (NSP).
• Unspecified Forecast Product (UFP).
• Forecast Group Product.
• Returns Product.
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• Scenario Product.

See "Product types" on page 33.

• The status of the product, that is, live or dead.
See "Product status" on page 34.

• The channel matrix to which the product belongs.
See "About Channel matrices" on page 78.
If you specify the channel matrix to which a product belongs, the specific channels in that matrix
are not added to the product. This action merely establishes which channels can be added.
Adding channels to products to make channel products is a separate task.

3 If you want the product to be added to the NEW PRODUCTS exception view, select Add to New
Products View.
See "NEW PRODUCTS".

4 Optionally, on the Details tab, specify this information:

• The budgeted standard cost, that is, the average cost across the matrix.
• The budgeted selling price, that is, the average selling price across the matrix.
• The unit of measure. Specify a textual description, for example "Each" or "Case".
• The weight of each unit.
• For shipping purposes, the cubic volume of each unit.
• The barcode of the product.
• If known, the ABC classification.

See "About ABC analysis" on page 344.

• The requirements horizon in days.

5 If you want the forecasts for this product to be interpolated into daily quantities, select Daily Forecast
Interpolation.

6 Optionally, on the User Dates, User Strings, and User Numbers tabs, specify the values of any
user-defined, editable product fields.
See "Editing user-defined Product fields" on page 88.
To get more information about each tab, use the Help button in the Add Product dialog box.

7 Click OK.
8 Perform one of these actions:

• To add another product, click Add Another Product and repeat steps 2 to 7.
• To specify channels for the new products, click Add Channels to the Products Added.

See "Adding Channel Products" on page 86.

• To add another product, click Add Another Product and repeat steps 2 to 7.
• To specify channels for the new products, click Add Channels to the Products Added.

See "Adding Channel Products" on page 86.

• If you have finished adding products, click Finish.

Infor Demand Planning User Guide | 85

Database Administration



Deleting Products
1 In Database Administration, select DB Admin > Delete Products.

The Delete Products dialog box shows all the currently selected products.
2 On the Select Products to be Deleted tab, select the products that you want to delete. To select

all products, click Select All.
3 Click Next.

The Products and Channels to be Deleted tab shows the corresponding channel products and
indicates whether or not they can be deleted.
Products that have no corresponding channel product, that is, products to which no channel has
been added, are not listed in this tab, but they are deleted.

4 To delete the channel products that are marked as OK to Delete, click Next. To confirm, click Yes.
If a channel product cannot be deleted, the Products/Channel Products not Deleted tab shows
a report. The report indicates the products and channel products that could not be deleted, the
reason, and possible remedial action.
See "When Products and Channel Products cannot be deleted".
If not all of the channel products corresponding to a product can be deleted, the product itself cannot
be deleted.

5 To print the report, click Print. To save the report as a text file, click Save.

Channel Products

Adding Channel Products
When you add products to the database or at any later time, you can manually add channels to products.

1 In Database Administration, select DB Admin > Add Channel Products.
The Add Channel Products dialog box shows two tables:

• The left-hand table shows the currently selected or newly added products.
• The right-hand table shows the channels in the matrices to which the products belong.

2 In the right-hand table, select the channels that you want to add to the displayed products. To select
all channels, click Select All.
The sources of the channel that you select are automatically selected according to the channel
matrix.

3 Click Next.
4 If the products belong to different matrices, your selection of channels may be invalid for some

products. In this case, in the Add Channel Products dialog box, the invalid product and channel
combinations are identified. Perform one of these actions:
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• To ignore the invalid combinations and continue, click Next.
• To select a different set of channels, click Back.

5 In the Add Channel Products dialog box, the product and channel combinations that are already
defined are identified. Perform one of these actions:

• To continue, click Next.
• To select a different set of channels, click Back.

6 In the Add Channel Products dialog box, the product and channel combinations that can be added
to the database are identified. If you want to include these new channel products in the NEW CPS
exception view, select Add to New CPs View. Click Add CPs.
See "NEW CPS".

7 If you want to edit the data for the new channel products, click Yes. Otherwise, click No.
See "Editing the Channel Products table" on page 116.

Deleting Channel Products
1 In Database Administration, select DB Admin > Delete Channel Products.

The Delete Channel Products dialog box shows all the currently selected products and channels in
two separate tables. You can select a product or channel.

2 On the Select Channel Products to be Deleted tab, select the products, then the channels that
correspond to the channel products that you want to delete.

3 Click Next.
The Channel Products to be Deleted tab shows the selected channel products and indicates
whether or not these channel products can be deleted.

4 To delete the channel products that are marked as OK to Delete, click Next. To confirm, click Yes.
If a channel product cannot be deleted, the Channel Products not Deleted tab is shows a report.
This report indicates the channel products that could not be deleted, the reason, and possible
remedial action.
See "When Products and Channel Products cannot be deleted".

5 To print this report, click Print. To save the report as a text file, click Save.
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User-Defined Fields

About user-defined fields
Various database tables include space for user-defined fields. These are fields that are already present
in the tables but are idle until you decide to use them.

You can edit the following attributes of a user-defined field:

• The name or description of the field as it appears in editable tables within Infor Demand Planning.

• A label for the field, used in dialogs and reports within Infor Demand Planning.

• The default initial value of the field.

• The field’s active status; that is, whether it is unused, read-only or editable.

• The field’s report category, if it is a Channel Products table field. This is the report under which the
field appears when editing the Channel Products table.

See "About table editing" on page 113.

User-defined fields may be alphanumeric strings, numbers or dates. The following grid shows how
many user-defined fields of each format are available in each table:

Date fieldsNumber fieldsString fieldsTable

51010Channels table

102020Products table

102020Channel Products table

Nonenone5Orders table

Nonenone5Order Book table

Nonenone5Customer table

101010Addresses table

101010Supplier Assortments table

Note: 

• A read-only field cannot be edited within Infor Demand Planning but can still be changed by importing
data from outside Infor Demand Planning.

Editing user-defined Product fields
1 In Database Administration, select DB Admin > System > User Fields > Products.
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The User Field Setup: Products dialog box is displayed, showing the user-defined fields of the
Products table. You can re-order the columns by dragging the column headers.

2 To edit a blue value, click its cell, type a new value and then click outside the cell.
3 To make a field active, click its Active cell and select either Read Only or Editable. Either type of

field can be imported, but an editable field can also be changed manually, for example when a
Product is added to the database.
See "Adding Products" on page 84.

4 To specify a static weighting based on a Products table field, click Adjust Weightings.
See "Adding a static weighting" on page 107.

5 To save changes, click Apply. When you have finished editing, click OK.

Editing user-defined Channel fields
1 In Database Administration, select DB Admin > System > User Fields > Channels..

The User Field Setup: Channels dialog box is displayed, showing the user-defined fields of the
Channels table. You can re-order the columns of the table by dragging the column headers.

2 To edit a blue value, click its cell, type a new value and then click outside the cell.
3 To make a field active, click its Active cell and select either Read Only or Editable. Either type of

field can be imported, but an editable field can also be changed manually, for example when a
Channel is added to the database.
See "Adding Channels" on page 75.

4 To specify a static weighting based on a Channels table field, click Adjust Weightings.
See "Adding a static weighting" on page 107.

5 To save changes, click Apply. When you have finished editing, click OK.

Editing user-defined Channel Product fields
1 In Database Administration, select DB Admin > System > User Fields > Channel Products.

The User Field Setup: Channel Products dialog appears, showing the user-defined fields of the
Channel Products table. You can re-order the columns of the table by dragging the column headers.

2 To edit a blue value, click its cell, type a new value and then click outside the cell.
3 To make a field active, click its Active cell and select either Read Only or Editable.

Either type of field can be imported, but an editable field can also be changed manually.

4 To change the table report category under which the field is listed when editing the Channel Products
table, select a category from the list.
See "Editing the Channel Products table" on page 116.

5 To specify a static weighting based on a Channel Products table field, click Adjust Weightings.
See "Adding a static weighting" on page 107.
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6 To save changes, click Apply. When you have finished editing, click OK.

Editing user-defined Order fields
1 In Database Administration, select DB Admin > System > User Fields > Orders.

The User Field Setup: Orders dialog box is displayed, showing the user-defined fields of the Orders
table. You can re-order the columns of the table by dragging the column headers.

2 To edit a blue value, click its cell, type a new value and then click outside the cell.
3 To make a field active, click its Active cell and select either Read Only or Editable.

Either type of field can be imported, but an editable field can also be changed manually.

4 To save changes, click Apply. When you have finished editing, click OK.

Editing user-defined Order Book fields
1 In Database Administration, select DB Admin > System > User Fields > Order Book.

The User Field Setup: Order Book dialog box is displayed, showing the user-defined fields of the
Order Book table. You can re-order the columns of the table by dragging the column headers.

2 To edit a blue value, click its cell, type a new value and then click outside the cell.
3 To make a field active, click its Active cell and select either Read Only or Editable.

Either type of field can be imported, but an editable field can also be changed manually.

4 To save changes, click Apply. When you have finished editing, click OK.

Editing user-defined Customer fields
1 In Database Administration, select DB Admin > System > User Fields > Customer.

The User Field Setup: Customer dialog box is displayed, showing the user-defined fields of the
Customer table. You can re-order the columns of the table by dragging the column headers.

2 To edit a blue value, click its cell, type a new value and then click outside the cell.
3 To make a field active, click its Active cell and select either Read Only or Editable.

Either type of field can be imported, but an editable field can also be changed manually.
The Customer table fields are not editable in all versions of Infor Demand Planning.

4 To save changes, click Apply. When you have finished editing, click OK.

Editing user-defined Addresses fields
1 In Database Administration, select DB Admin > System > User Fields > Addresses.
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The User Field Setup: Addresses dialog box is displayed, showing the user-defined fields of the
Addresses table. You can re-order the columns of the table by dragging the column headers.

2 To edit a blue value, click its cell, type a new value and then click outside the cell.
3 To make a field active, click its Active cell and select either Read Only or Editable.

Either type of field can be imported, but an editable field can also be changed manually.

4 To save changes, click Apply. When you have finished editing, click OK.

Editing user-defined Supplier Assortments fields
1 In Database Administration, select DB Admin > System > User Fields > Supplier Assortments.

The User Field Setup: Supplier Assortments dialog appears, showing the user-defined fields of the
Orders table. You can re-order the columns of the table by dragging the column headers.

2 To edit a blue value, click its cell, type a new value and then click outside the cell.
3 To make a field active, click its Active cell and select either Read Only or Editable.

Either type of field can be imported, but an editable field can also be changed manually.

4 To save changes, click Apply. When you have finished editing, click OK.

Configuring the Information tabs of the Data window in Edit
Forecasts
In Database Administration, you can specify which user-defined Channel Product and Product fields
are displayed to particular users on the Chan Prod Info and Prod Info tabs of the Data window in the
Demand Forecaster module’s Edit Forecasts feature. See "About the Data window" on page 236 and
"Editing user-defined Product fields" on page 88.

1  If you have not already done so, edit the Channel Products and Products tables to activate the
required user-defined fields.
See "Editing user-defined Channel Product fields" on page 89.

2 Select  DB Admin > System > DP Information Page Defaults.
The DP Information Page Defaults dialog box is displayed.

3 In the User box, select the user, or one of the users, you want to configure.
4 Select either the Product Fields or Channel Product Fields tab.
5 Select the Display check boxes of the fields you want to include. Only active, user-defined

Product/Channel Product fields are available for selection.
You can use the Move buttons to change the order in which the fields are displayed on the information
tabs.

6 To apply these fields only to the selected user, click OK. To apply these fields to more than one
user, click Apply to, select the users you want, then click OK.
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Views

About views
A view is a named, re-usable set of one or more Products or Channel Products. A view that contains
only Products is a Product view; a view that contains Channel Products is a Channel Product view.
Views are typically used to select related groups of items.

See "Selecting views" on page 46.

You can create, edit, copy, split, combine and delete your own views. When you create a view, you
can save it as either a public view or a private view. A public view can be used by anyone with the
correct access privileges. A private view can be used only by you or a steward. Views generated by
Infor Demand Planning itself are known as exception views.

Special uses of views
There are three special uses of views:

• Exception views

An exception view is a system-created view that contains Products or Channel Products that are in
some way exceptional and which Infor Demand Planning wants to bring to your attention. All exception
views only appear once and are always owned by the database steward. Exception views may be
saved as predefined views.

See "About pre-defined views" on page 40.

In order to provide a more structured and user-friendly way to manage the 139 exception views that
are generated within Infor Demand Planning, it is possible to use a predefined list of items selected by
individual users which are stored on the database and may be used as an alternative to the standard
Product and Channel selection process. As all exceptions views are categorized with a severity and
can be assigned to various user roles, they can be used as a better basis for initiating a work flow.

The predefined option is only available if the PREDEF sign-on option is allocated to the current user.
The sign-on option for each user is maintained in the Maintain Users: ADD/EDIT dialogs within the
Database Administration module. The default sign-on module or Collaborate page is also selected in
these dialogs.

A predefined Product/Channel selection can be saved in any Infor Demand Planning module and in
Collaborate.

See "About exception views" on page 105.

• Permanent forecast groups

A permanent forecast group view is a system-created view containing Product or Channel Products
that are grouped together for forecasting purposes.

See "About permanent forecast groups" on page 279.
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• Marketing groups

A marketing group view is usually a public view containing Products or Channel Products that are
grouped together for promotional purposes.

See "About promotions" on page 290.

Ownership of public/private views
You are automatically the owner of all the public and private views that you create.

Restrictions on managing views
Permanent forecast groups and marketing groups can be managed only in the Demand Forecaster
module; all other views can be managed in the Database Administration module, provided that you
have the correct access privileges.

Also, you can edit exception views in which the currently selected Channel Product appears in both
the Demand Forecaster and Replenishment Planner modules.

See "Editing exception views in DF and RPD" on page 32.

If you are a non-steward user you can edit, copy, combine or split a view if you have data access
privileges to all of the Products or Channel Products in that view and it is not a private view owned by
another user. You can rename, overwrite or delete a view if it is a private or system view that you own.

If you are a steward, you have similar privileges except that you can also access other users’ views.

See "About access privileges" on page 61.

Reports
Infor Demand Planning has two reports that tell you what views there are and what Products and
Channel Products they contain.

• Detailed Report (Views)

This report shows views, and the Products or Channel Products within them. It shows, for each selected
view:

• The Products or Channel Products in that view.

• The view’s owner.

• The date the view was created or last edited.

• The type of view (private, public or system).

• The total number of Products or Channel Products in the view.

• Cross Reference Report (Products and Channel Products)

This report shows Products and Channel Products, and the views of which they are members. It shows
each view’s owner, the date the view was created or last edited and the type of view (private, public
or system).
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About combining views
You can combine two or more views to make a new view, subject to the following limitations:

• You can combine views if you are a steward, or if they are private or system views that you own.

• You can also combine public views if you have data access privileges to all of the Products or
Channel Products in those views.

In all cases, the original views are unchanged.

You can combine two views A and B by specifying one of the three logical operations:

ResultOperation

All the items in view A and all the items in view B, without duplication. This is
the union of A and B.

A OR B

All the items that are in both view A and view B. This is the intersection of A
and B. If A and B have no items in common, the result is an empty view.

A AND B

All the items in view A, minus any items that are also in view B. This is the
difference between A and B. If A and B are identical, the result is an empty
view.

A NOT B

You combine more than two views by assembling a series of such operations, each successive operation
building on the result of the previous one. Note that the order of the views being combined is usually
significant.

A OR B OR C
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A OR B AND C

A OR B NOT C

A AND B OR C

A AND B AND C

A AND B NOT C

A NOT B OR C

A NOT B AND C

A NOT B NOT C

Infor Demand Planning User Guide | 95

Database Administration



Note: 

• The resulting new view can be saved as a public view or a private view but not an exception view.

About splitting views
You can split a view into new views based on the value of a Products or Channel Products table field,
depending on whether the original view is a Product view or a Channel Product view. The original view
is unchanged.

• You can split a view if you are a steward, or if it is a private or system view that you own.

• You can also split a public view if you have data access privileges to all of the Products or Channel
Products in that view.

You need to select a view, and a field by which to split it. Infor Demand Planning examines the value
of that field for all the items in the view, and suggests possible new views based on items that have
the same value. The default names of these possible views are of the form:

original_view_(field_description = `value’)

For example, if you wanted to split a Product view called Appliances according to the "ABC Class (Pt)"
field, the possible views produced might be named:

Appliances_(ABC Class =‘A’)

Appliances_(ABC Class =‘B’)

Appliances_(ABC Class =‘C’)

Appliances_(ABC Class =‘U’)

Appliances_(ABC Class =‘NULL’)

You can decide which of these possible views you want to produce, and rename them as desired. (A
view name is limited to 30 characters. If a default view name exceeds this you are compelled to rename
it.)

You own the views you make by splitting, and you can save them as either private or public views.

Note: 

• The resulting views can be saved as public views or private view but not as exception views.

Creating a Product view

Creating a Product view by selecting
You can create a view by selecting from among the currently-selected Products.
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1 In Database Administration, select View Admin > View Maintenance.
The View Maintenance dialog box is displayed.

2 Click New.
The New View dialog box is displayed.

3 Under Create View Using, click Select.
4 Under View Type, click Products.
5 Click OK.

The New View (Product) dialog box is displayed.
6 In the Available Products table, select the Products you want to include in this view, then click Add.

To include all the currently-selected Products, click Add All.
7 Click OK.

The Save New View dialog box is displayed.
8 Specify this information:

View Name
Type a name for this view.

View Type
Specify whether this is a public or a private view.

View Text
Type a description of this view.

9 Click OK to return to the View Maintenance dialog box.

Creating a Product view by filtering
You can create a view by filtering the currently-selected Products.

1 In Database Administration, select View Admin > View Maintenance.
The View Maintenance dialog box is displayed.

2 Click New.
The New View dialog box is displayed.

3 Under Create View Using, click Use Additional Filter.
4 Under View Type, click Products.
5 Click OK.

The New View – Filter dialog box is displayed.
6 Build a filter based on Products table fields.

See "Building a filter for a view".

7 Click OK.
The Save Filtered View dialog box is displayed.

8 Specify this information:

View Name
Type a name for this view.
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View Type
Specify whether this is a public or a private view.

View Text
Type a description of this view.

9 Click OK to return to the View Maintenance dialog box.

Note: The filter can be saved, and used later to filter another selection of Products.

Creating a Product view from a Channel Product view
1 Select the Channel Product view.

See "Selecting views" on page 46.

2 Create a Product view based on the current selection. Optionally, you can save it with the same
name as the original Channel Product view, which causes the original view to be overwritten.
See "Creating a Product view by selecting" on page 96.

Creating a Channel Product view

Creating a Channel Product view by selecting
You can create a view by selecting from among the currently-selected Channel Products.

1 In Database Administration, select View Admin > View Maintenance.
The View Maintenance dialog box is displayed.

2 Click New.
The New View dialog box is displayed.

3 Under Create View Using, click Select.
4 Under View Type, click Channel Products.
5 Click OK.

The New View (Channel Product) dialog box is displayed.
6 In the Products and Channels tables, select the required Products and Channels.

To select all Products or all Channels, click Select All below the relevant table.
Infor Demand Planning updates the content of the Available CPs table to show the valid Channel
Products corresponding to your selections.

7 In the Available CPs table, select the Channel Products you want to include in this view.
8 Click OK.

The Save New View dialog box is displayed.
9 Specify this information:

98 | Infor Demand Planning User Guide

Database Administration



View Name
Type a name for this view.

View Type
Specify whether this is a public or a private view.

View Text
Type a description of this view.

10 Click OK to return to the View Maintenance dialog box.

Creating a Channel Product view by filtering
You can create a view by filtering the currently-selected Channel Products.

1 In Database Administration, select View Admin > View Maintenance.
The View Maintenance dialog box is displayed.

2 Click New.
The New View dialog box is displayed.

3 Under Create View Using, click Use Additional Filter.
4 Under View Type, click Channel Products.
5 Click OK.

The New View – Filter dialog box is displayed.
6 Build a filter based on Products and Channel Products table fields.

See "Building a filter for a view".

7  Click OK.
The Save Filtered View dialog box is displayed.

8 Specify this information:

View Name
Type a name for this view.

View Type
Specify whether this is a public or a private view.

View Text
Type a description of this view.

9 Click OK to return to the View Maintenance dialog box.

Creating a Channel Product view from a Product view
1 Select the Product view.

See "Selecting views" on page 46.

2 Select the Channels you want in the view.
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See "Selecting Channels" on page 48.

3 Create a Channel Product view based on the current selection. Optionally, you can save it with the
same name as the original Product view, which causes the original view to be overwritten.
See "Creating a Channel Product view by selecting" on page 98.

Editing

Editing a public or private Product view
1 In Database Administration, select View Admin > View Maintenance.

The View Maintenance dialog box is displayed, initially showing a table of private Product views.
2 If the view you want to edit is a public or system view, select the Public or System check box.
3 In the table, click the view you want to edit, then click Edit.

The Edit View (Product) dialog box is displayed.
4 To add more Products to the view, select them in the Available Products table and click Add. To

add all available Products, click Add All.
5 To remove Products from the view, select them in the Products in View table and click Remove.

To remove all Products, click Remove.
6 Click OK to return to the View Maintenance dialog box.

Editing a public or private Channel Product view
1 In Database Administration, select View Admin > View Maintenance.

The View Maintenance dialog box is displayed, initially showing a table of private Product views.
2 Under View Type, click Channel Products.
3 If the view you want to rename is a public or system view, select the Public or System check box.
4 In the table, click the view you want to edit, then click Edit.

The Edit View (Channel Product) dialog box is displayed. The Channel Products currently in the
view are preselected in the dialog box.

5 In the Products and Channels tables, select the required Products and Channels.
To select all Products or all Channels, click Select All below the relevant table. To deselect all
Products or all Channels, click the corresponding Deselect All button.
Infor Demand Planning updates the content of the Available CPs table to show the valid Channel
Products corresponding to your selections.

6 In the Available CPs table, select the Channel Products you want to include in this view.
7 Click OK to return to the View Maintenance dialog box.
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Renaming a view
When you rename a view, you can also change it from a private to a public view (and vice versa).

1 In Database Administration, select View Admin > View Maintenance.
The View Maintenance dialog box is displayed, initially showing a table of private Product views.

2  If the view you want to rename is a public or system view, select the Public or System check box.
If the view is a Channel Product view, under View Type, click Channel Products. To see all views,
select the All Views check box.

3 In the table, click the view you want to rename, then click Rename.
The Rename View dialog box is displayed.

4 Specify this information:

View Name
Type a new name for this view.

View Type
Specify whether this is a public or a private view.

View Text
Type a description of this view.

5 Click OK to return to the View Maintenance dialog box.

Note: 

• You can rename a view only if you are a steward, or if it is a private or system view that you own.
• Renaming an exception view does not change the name that Infor Demand Planning uses when

it next creates that view.

Copying a view
When you copy a view, you can change it from a private to a public view (and vice versa).

1 In Database Administration, select View Admin > View Maintenance.
The View Maintenance dialog box is displayed, initially showing a table of private Product views.

2 If the view you want to copy is a public or system view, select the Public or System check box. If
the view is a Channel Product view, under View Type, click Channel Products. To see all views,
select the All Views check box.

3 In the table, click the view you want to copy, then click Copy.
The Copy View dialog box is displayed.

4 Specify this information:

View Name
Type a name for the copied view.

View Type
Specify whether this is a public or a private view.
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View Text
Type a description of this view.

5 Click OK to return to the View Maintenance dialog box.

Note: 

• You can copy a view if you are a steward, or if it is a private or system view that you own.
• You can also copy a public view if you have data access privileges to all of the Products or

Channel Products in that view.
• The resulting new view can be saved as a public view or a private view but not an exception

view.

Splitting a view
You can split a view into new views based on the value of a Products or Channel Products table field,
depending on whether the original view is a Product view or a Channel Product view. The original view
is unchanged.

See "About splitting views" on page 96.

1 In Database Administration, select View Admin > View Maintenance.
The View Maintenance dialog box is displayed, initially showing a table of private Product views.

2 To see all views, select the All Views check box.
3 In the table, select the view you want to split, then click Split.

The Split View dialog box is displayed.
4 In the Split on field list, select the field by which you want to split the view.
5 In the Possible Views list, select the views you want to create. If you want to create all of the

possible views, click Select All.
6 Click OK.

A series of Save Split View dialog appears, one for each of the views selected in the Split View
dialog box.

7 Specify this information:

View Name
Type a name for the new view.

View Type
Specify whether this is a public or a private view.

View Text
Type a description of this view.

8 Click OK. When all views have been named and saved, the View Maintenance dialog re-appears.

Note: 

• You can split a view if you are a steward, or if it is a private or system view that you own.
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• You can also split a public view if you have data access privileges to all of the Products or Channel
Products in that view.

• The resulting views can be saved as public views or private view but not as exception views.

Combining views
You can combine two or more views to make a new view. The original views are unchanged.

1 In Database Administration, select View Admin > View Maintenance.
The View Maintenance dialog box is displayed, initially showing a table of private Product views.

2 To see all views, select the All Views check box.
3 In the table, select the views you want to combine, then click Combine.

The Combine Views dialog box is displayed, listing the selected views in alphabetical order. By
default, the selected views are all linked by OR operators, producing a combined view that is union
of all the selected views.

4 If you want to change the order in which the selected views are combined, click a view to select it
and then click either Up or Down to move it up or down one row in the list.

5 For each view, specify how the combined view (that is, the view assembled up to and including that
view) is to be combined with the next view in the list, by selecting a logical operator from the adjacent
Operator list:

• Select OR to add all the Products or Channel Products in the next view, without duplication.
• Select AND to remove any Products or Channel Products that are not in the next view.
• Select NOT to remove all the Products or Channel Products that are in the next view.

The number of Products or Channel Products in the combined view is shown in the dialog box. See
"About combining views" on page 94.

6 When you are satisfied, click OK.
The Save Combined View dialog box is displayed.

7 Specify this information:

View Name
Type a name for the combined view.

View Type
Specify whether this is a public or a private view.

View Text
Type a description of this view.

8 Click OK to return to the View Maintenance dialog box.

Note: 

• You can combine views if you are a steward, or if they are private or system views that you own.
• You can also combine public views if you have data access privileges to all of the Products or

Channel Products in those views.
• The resulting view can be saved as a public view or a private view but not as an exception view.
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Deleting

Deleting a view
Permanent forecast group views and marketing group views can be deleted only in the Demand
Forecaster module; all other views can be deleted in the Database Administration module, provided
that you have the relevant access privileges.

1  In Database Administration, select View Admin > View Maintenance.
The View Maintenance dialog box is displayed, initially showing a table of private Product views.

2 If the view you want to delete is a public or system view, select the Public or System check box. If
the view is a Channel Product view, under View Type, click Channel Products. To see all views,
select the All Views check box.

3 In the table, click the view you want to delete, then click Delete.
The Delete View dialog box is displayed.

4 Click Yes to confirm the deletion and return to the View Maintenance dialog box.

Note: You can delete a view if you are a steward, or if it is a private or system view that you own.

Deleting permanent forecast groups
1 In Demand Forecaster, select Modules > Demand Forecasting > Forecast Group > Delete.

The Delete Forecast Group dialog box is displayed.
2 Select the forecast group item of the group to delete.

The Group members will be displayed in the right-hand panel.
3 Click OK.

The forecast group item will not be deleted, only the group.

Deleting marketing group views
1 In Demand Forecaster, select Modules > Demand Forecasting > Promotions > Delete Marketing

Groups.
The MG View Delete dialog box is displayed.

2 Select the MG views to delete.
If more than one MG view is selected, and one or more has the MG view name the same as the
NSP code, a message is displayed advising that the views should be deleted individually to avoid
orphan market intelligence.

3 Select the Remove All T-Type MI check box if you want to delete the T-type market intelligence
associated with the view.

4 Select the Remove transferred history check box if you want to remove any history stored against
the NSPs.

5 Click OK.
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Reports

Viewing a Detailed Report
1 In Database Administration, select View Admin > Reports > Detailed Report.

The Select Views dialog box is displayed.
2 Under View Types, select the types of views you want to include in the report.
3 In the table of views, select the specific views you want, then click OK.

Note: 

• If the report is very long, you can search for Product codes by using the Edit > Find command.
• You can print the report by using the Edit > Print command.
• You can use the View Maintenance Reports toolbar instead of the Edit menu.

The View Maintenance Reports – Detail dialog box is displayed, showing the Detailed Report.

Viewing a Cross Reference Report
1 In Database Administration, select View Admin > Reports > Cross Reference Report.

The Select Views dialog box is displayed.
2 Under View Types, select the types of views you want to include in the report.
3 In the table of views, select the specific views you want, then click OK.

Note: 

• If the report is very long, you can search for views by using the Edit > Find command.
• You can print the report by using the Edit > Print command.
• You can use the View Maintenance Reports toolbar instead of the Edit menu.

The View Maintenance Reports – Cross Reference dialog box is displayed, showing the report.

Exception views

About exception views
There are currently 139 default exception views that are generated within Infor Demand Planning.
Users may activate exceptions, categorize exceptions with a severity and assign exceptions to various
user roles so the exception views can be used as a better basis for initiating a work flow.

Infor Demand Planning gives an overview of the exceptions within the system, but in a method that is
applicable to the current user. It is possible to view exception detail, including applicable items affected,
and directly drill down into the functionality to view or action those products.
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There are currently two different ways to gain access to the Infor Demand Planning functionality:

• Standard Product and Channel select.

• A predefined selection for a particular user stored on the database.

See "Index of exception views".

About exception view action paragraphs
Each exception view has an action paragraph, which provides detailed information on the exception
conditions and an explanation of the process that should be undertaken in order to review and action
items contained in the exception.

Maintaining exception views
1 In Database Administration, select View Admin > Exception View Maintenance.
2 In the Exception View Maintenance dialog box, clear the Active check box for the selected exception

view.

• Previously created exception views that are not active are listed in this dialog box.

• If you clear the Active check box of an exception view that has not previously been created, the
exception view is not created.

3 Edit the List Text field as required.
4 Click OK.

Editing exception view action paragraphs
1 In Database Administration, select View Admin > Exception View Maintenance.
2 In the Exception View Maintenance dialog box, select the required exception view.
3 In the toolbar that is on the right-hand side, click this option: Open the text editor to edit notes for

this CP.
4 In the Exception View Action Paragraph dialog box, edit the text in the Action Paragraph field as

required.
5 Click OK.

Creating exception view and user role links
1 In Database Administration, select View Admin > Exception / Role Maintenance.
2 In the Exception/Role Maintenance dialog box, specify this information:

User Role
Select the required role.
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Assign To
Select the check box in the column of the desired exception view.

Severity
Select the required severity.

Goto
Select the default destination function.

3 Click OK.

Static Weightings

About static weightings
It is often useful to view, export or print historical and forecast data about Products or Channel Products
in quantities other than their basic unit of measurement.

For example, when considering quantities for shipping in a cargo container, you might want to multiply
the number of units by their cubic volume. For financial control, you may want to multiply the number
of units by the gross margin.

A static weightingis a named relationship of this type. Each weighting simply multiplies the number of
units by the value of a specified Products, Channels or Channel Products table field.

Infor Demand Planning has several predefined static weightings, but you can add more of your own.
These can be based on standard fields, or on user-defined fields, provided that the fields are numeric.
As soon as you add a new weighting, it becomes available for selection within Infor Demand Planning.

See "About user-defined fields" on page 88.

Adding a static weighting
1 In Database Administration, select DB Admin > System > User Fields, then select Products,

Channels, Channel Products, Orders, Addresses, or Supplier Assortments.
2 Click Adjust Weightings.

The Edit Weightings dialog box is displayed, showing a table of the existing static weightings.
3 Click Add.

A blank row is added to the end of the table.
4 In the Weighting Refcell of the new row, type the internal reference name of the new weighting.
5  In the Operator cell, select "*" (multiplication).

This is the only choice currently available.
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6  In the Decimal Places cell, type the number of decimal places to be used in the weighted value.
7 In the Table cell, select the table that contains the field on which the weighting is to be based.
8  In the Column cell, select the numeric field on which the weighting is based.

Do not select a user-defined field unless it is active.

Editing a static weighting
1 In Database Administration, select DB Admin > System > User Fields, then select Products,

Channels, Channel Products, Orders, Addresses, or Supplier Assortments.
2  Click Adjust Weightings.

The Edit Weightings dialog box is displayed, showing a table of the existing static weightings.
3 You can edit any cell by clicking it and either typing a new value or selecting an option from a list.

Deleting a static weighting
1 In Database Administration, select DB Admin > System > User Fields, then select Products,

Channels, Channel Products, Orders, Addresses, or Supplier Assortments.
2 Click Adjust Weightings.

The Edit Weightings dialog box is displayed, showing a table of the existing static weightings.
3 Click the name of the weighting you want to delete, then click Remove.

Time-Phased Weightings

About time-phased weightings
In Infor Demand Planning, named static weightings enable you to view, export or print data by selling
price, standard cost, gross margin, and so on. Time-phased weightings are a refinement that allows
greater flexibility.

Time-phased weightings allow you to define a weighting factor that varies by time period, both historical
and forecast. It follows that TPWs are only ever applied to period-based data such as sales, demand,
forecasts, plans and budgets.

There are three types of time-phased weightings (TPWs):

• Product TPWs

TPWs that relate to Products regardless of Channel, for example, standard cost.
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• Channel Product TPWs

TPWs that relate to Products at their Channels, for example, average selling price. (Channel Product
TPWs can be copied from a base Product to its Scenario Products.)

• System TPWs

TPWs that relate to the whole database regardless of Product or Channel, such as a currency conversion
weighting.

The TPW values of a newly-created TPW are all 1.0, which is effectively no weighting. The TPW
becomes effective when you edit TPW values to be something other than 1.0. By editing particular
Product or Channel Product TPW values, you are effectively applying the TPWs to those Products and
Channel Products.

Historical and forecast TPWs are held in separate database tables. At period end, when the database
is rolled forward, the forecast TPWs for the period just passed automatically become the most recent
historical TPWs.

Adding a time-phased weighting
1 In Database Administration, select DB Admin > System > Set Up TPWs.

The Set Up TPWs dialog box is displayed, showing a table of the existing TPWs.
2 Select Edit > Add TPW.

You can use the Set Up TPW toolbar instead of the Edit menu.
A blank row is added to the end of the table.

3 In the Description cell of the new row, type the name of the new TPW.
4 In the TPW Type cell, select the type of this TPW: Product TPW, Channel Product TPW, or System

TPW.

Renaming a time-phased weighting
1 In Database Administration, select DB Admin > System > Set Up TPWs.

The Set Up TPWs dialog box is displayed, showing a table of the existing TPWs.
2 Click the Description cell of the TPW you want to rename, type a new name and then click outside

the cell.
You cannot change the type of an existing TPW.

Deleting a time-phased weighting
1 In Database Administration, select DB Admin > System > Set Up TPWs.

The Set Up TPWs dialog box is displayed, showing a table of the existing TPWs.
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2 Click the name of the TPW you want to delete.
3 Select Edit > Remove TPW.

You can use the Set Up TPW toolbar instead of the Edit menu.

Editing time-phased weighting values
1 In Database Administration, select Product Admin > Time-Phased Weightings.

The Time-Phased Weightings dialog box is displayed. Once you have selected a particular TPW,
the central panel of this dialog shows an editable table of historical and forecast TPW values for
each period. Historical and forecast TPW values are separated by a break in the table.

2 Select the TPW you want to edit.
3  For a Product or Channel Product TPW, select the Product code of the required Product.
4 For a Channel Product TPW only, select the Channel code of the required Channel.
5 To edit an individual TPW value, click its cell, type the new value, then click outside the cell.
6 To edit a range of consecutive TPW values, double-click the first cell in the range, hold SHIFT, then

double-click the last cell in the range. Then do either of the following:

• Select Edit > Repeat TPW value across cells. In the Repeat Value dialog, type a value to be
repeated across the selected cells, then click OK.

• Select Edit > Edit TPW Function. In the Adjust TPW dialog, specify an operation (add, subtract,
multiply or divide) and a constant to be applied to the selected cells, then click OK.

You can use the Time-Phased Weightings toolbar instead of the Edit menu.

7 Click Apply.
8 To select the next or previous Product/Channel Product when editing a Product/Channel Product

TPW, select Edit > Scroll TPW Product/CP, then select Scroll to Next Product/CP or Scroll to
Previous Product/CP.

9 When you have finished editing, click OK.

Copying time-phased weighting values
You can copy the TPW values of a Product or Channel Product TPW from one Product or Channel
Product (the source) to another (the target).

1 In Database Administration, select Product Admin > Time-Phased Weightings.
The Time-Phased Weightings dialog box is displayed.

2 Select the TPW you want to copy.
3 Select the Product code of the target Product.
4 For a Channel Product TPW, select the Channel code of the target Channel.
5 Select Edit > Copy TPW.

You can use the Time-Phased Weightings toolbar instead of the Edit menu.
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The Replace TPW for Product/Channel Product dialog appears.
6 Select the source Product or Channel Product, and click OK.
7 Click Apply.

Removing time-phased weighting values
You can reinitialize the TPW values of a Product or Channel Product TPW to 1.0, thereby removing
that TPW from that item (when all weighting values are 1.0, there is effectively no weighting).

1 In Database Administration, select Product Admin > Time-Phased Weightings.
The Time-Phased Weightings dialog box is displayed.

2 Select the TPW you want to copy.
3  Select the Product code of the target Product.
4 For a Channel Product TPW, select the Channel code of the target Channel.
5 Select Edit > Remove Current TPW. Click Yes to confirm.

You can use the Time-Phased Weightings toolbar instead of the Edit menu.

6 Click Apply.

About importing TPWs
Once a TPW has been created, you can import TPW values into that TPW. The database table you
need to use depends on the type of TPW and whether you are importing historical or forecast TPW
values:

Table for importing forecast TPW
values

Table for importing historical TPW valuesType

Product Forecast TPW
(FCAST_TPW_PROD)

Product History TPW
(HIST_TPW_PROD)

Product

Channel Product Forecast TPW
(FCAST_TPW_CP)

Channel Product History TPW
(HIST_TPW_CP)

Channel Product

System Forecast TPW
(FCAST_TPW_SYS)

System History TPW (HIST_TPW_SYS)System

Import file format
The format of the target database table, and hence the import file, is similar in each case.

For historical TPWs, it looks like this:

UsageFormatColumn

Product code.A30PROD_CD*
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Channel Product Reference.I10CP_REF*

System TPW Reference.I6REF*

Unique reference number assigned by Infor Demand Planning
when the TPW was created.

I3WEIGHTING_REF

Date of the first period of history.DateSTARTDATE

The number of periods in the file (up to 65).I2HIST_LENGTH

TPW value for the 1st month.F14.4PERIOD_1 …

TPW value for the 65th month.F14.4PERIOD_65

For forecast TPWs, it looks like this:

UsageFormatColumn

Product code.A30PROD_CD*

Channel Product Reference.I10CP_REF*

System TPW Reference.I6REF*

Unique reference number assigned by Infor Demand Planning
when the TPW was created.

I3WEIGHTING_REF

TPW value for the 1st month.F14.4PERIOD_1 …

TPW value for the 78th month.F14.4PERIOD_78

See "More about importing" on page 130.

Note: 

• In the import files described above, only one of the asterisked * fields is needed, depending on the
type of TPW. Thus a Product TPW needs a Product code, a Channel Product TPW needs a Channel
Product Reference, and a System TPW needs a System TPW reference.

• Any TPW vectors that are too long are truncated, and any that are too short are regarded as
exceptions; (a) the number of historical or forecast TPW values for a Channel Product TPW must
always match the number of periods of history or forecast held for that Channel Product, (b) for a
Product TPW, there must be as many TPW values as the longest history or forecast of all the
Channel Products defined for that Product, (c) system TPWs always have the maximum allowable
history and forecast. Any TPW vectors that are too long are truncated, and any that are too short
are regarded as exceptions.
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Table Editing

About table editing
Infor Demand Planning exposes four main database tables for editing:

• System table (St), which holds information that controls the behavior of the entire database.

• Products table (Pt), which holds information that defines each Product.

• Channels table (Ct), which holds information that defines each Channel.

• Channel Products table (CPt), which holds information that defines a Product at a particular Channel.

The System table fields are edited by using a tabbed dialog box.

Channels, Products and Channel Products table fields can be edited directly. Often, only a subset of
fields need to be edited at any one time. Infor Demand Planning therefore includes, for each of these
three tables, some predefined collections of fields called "reports". You can also define your own reports.
(Remember that a report is a collection of fields, not records.)

Only fields that are specified as "editable" in the application defaults can be edited manually.

See "About application defaults" on page 70.

Table editing techniques
When editing the Channels, Products or Channel Products table you can:

• Sort the selected records by any one column.

• Sort the selected records by more than one column (expert sort).

• Filter the selected records by one or more columns (expert filter).

• Edit individual fields of a record.

• Edit a field in one record and all subsequent records at the same time (vertical edit).

• Copy data from one record to any other records in the current table report (copy rows).

• Copy data from one column to any other columns in the current table report (copy columns).

• Calculate data in one column using data from one or two other columns in the current table report
(calculate columns).

Note: 

• The terms record/row, and field/column, are used interchangeably.
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Editing the System table
1 In Database Administration, select DB Admin > System > System Data.

The System Data dialog box is displayed.
2 On the General Settings tab, specify various parameters such as:

• The company name.

• Whether the monthly forecast is to be interpolated into weeks.

• The base currency.

• The scope of Sales & Operations Planner (S&OP) and Sales Budgeting & Tracking (SBT).

• The forecast horizon (in various granularities).

• How market intelligence is processed at period end.

• The amount of historical data to store (in various granularities) and when it is to be deleted.

• Whether data is displayed in integer or decimal format.

See "System Data dialog [General Settings 2 tab]".

3 On the Forecasting Settings tab, specify various forecasting parameters.
See "System Data dialog [General Settings tab]".

• You should be cautious about editing the System table. Inappropriate values may cause Infor
Demand Planning to stop working properly.

• You can specify which fields of the System table are editable by setting the application defaults.

Editing the Products table
1 In Database Administration, select the Products you want to edit.

See "About selecting Products and Channels" on page 35.

2 Select Product Admin > Products.
The Products dialog box is displayed, showing an editable grid of Product fields.

3 Select a report (the default report is All Data).
See "Selecting a report" on page 117.

4 You can search the report to find the rows you want to edit.
See "Finding data in a report" on page 118.

5 You can edit any blue value directly, by clicking its cell and either typing or selecting a new value.
Additionally, you can use any of the following editing techniques:

• "Editing a row" on page 120
• "Editing a column" on page 121 (vertical editing)
• "Copying a row (table editing)" on page 121
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• "Copying a column (table editing)" on page 122
• "Calculating columns (table editing)" on page 122

6 You can filter the report to review any unsaved changes.
See "Filtering the unsaved changes in a report" on page 118.

7 When you are satisfied, you can save the changes you have made.
See "Saving changes" on page 116.

Note: 

• In most cases, you can use the Products toolbar instead of menu commands.

• You can specify which fields of a table are editable by setting the application defaults.

Editing the Channels table
1 In Database Administration, select the Channels you want to edit.

See "Selecting Channels" on page 48.

2 Select DB Admin > System > Edit Channel Data.
The Channels dialog box is displayed, showing an editable grid of Channel fields.

3 Select a report (the default report is All Data).
See "Selecting a report" on page 117.

4 You can search the report to find the rows you want to edit.
See "Finding data in a report" on page 118.

5 You can edit any blue value directly, by clicking its cell and either typing or selecting a new value.
Additionally, you can use any of the following editing techniques:

• "Editing a row" on page 120
• "Editing a column" on page 121 (vertical editing)
• "Copying a row (table editing)" on page 121
• "Copying a column (table editing)" on page 122
• "Calculating columns (table editing)" on page 122

6 You can filter the report to review any unsaved changes.
See "Filtering the unsaved changes in a report" on page 118.

7 When you are satisfied, you can save the changes you have made.
See "Saving changes" on page 116.

Note: 

• In most cases, you can use the Channels toolbar instead of menu commands.
• You can specify which fields of a table are editable by setting the application defaults.
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Editing the Channel Products table
1  In Database Administration, select the Products and Channels you want to edit.

See "About selecting Products and Channels" on page 35.

2 Select Product Admin > Channel Products.
The Channel Products dialog box is displayed, showing an editable grid of Channel Product fields.

3 Select a report (the default report is Basic Report).
See "Selecting a report" on page 117.

4 You can search the report to find the rows you want to edit.
See "Finding data in a report" on page 118.

5 You can edit any blue value directly, by clicking its cell and either typing or selecting a new value.
Additionally, you can use any of the following editing techniques:

• "Editing a row" on page 120
• "Editing a column" on page 121
• "Copying a row (table editing)" on page 121
• "Copying a column (table editing)" on page 122
• "Calculating columns (table editing)" on page 122

6 You can filter the report to review any unsaved changes.
See "Filtering the unsaved changes in a report" on page 118.

7 When you are satisfied, you can save the changes you have made.
See "Saving changes" on page 116.

Note: 

• In most cases, you can use the Channel Products toolbar instead of menu commands.
• You can specify which fields of a table are editable by setting the application defaults.

Saving changes
When editing a database table, you can save the changes you have made so far.

1 Select Edit > Save Changes.
The report changes to show only the updated rows.
Infor Demand Planning tells you how many rows it has updated.

2 Click OK to acknowledge.
The report reverts to showing all rows, but with the updated rows at the top of the report.
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Reports

Selecting a report
When editing the Products, Channels or Channel Products table, you can at any time select a different
report to view.

 In the Report Type box, do one of the following:

• Select a predefined report.
• Select User-Defined Report if you want to create a new report. See "Creating a report" on page

117.
• Select Saved Report if you want to load a previously-saved report. See "Loading a report" on

page 118.

If there are any unsaved changes, Infor Demand Planning warns you that they are lost if you load
a new report, and asks if you want to continue.

Creating a report
When editing the Products, Channels or Channel Products table, you can create a report containing
any combination of columns. Each column in the report corresponds to a field in the table.

1 In the Report Type box, select User-Defined Report.
At step 1, be careful not to select the predefined User-Defined Fields report by mistake.
The Column Selection dialog is displayed.

2 On the Table and Column Selection tab, in the Column Description list, select the columns you
want to include in your report. To include all columns, click Select All.

3 If you want to arrange the selected columns in a particular order, click Arrange to view the Arrange
Columns tab; if not, click OK.
The Arrange Columns tab shows a list of the selected columns. The top-to-bottom order of the list
represents the left-to-right order of the columns in your report.

4 On the Arrange Columns tab, click the column you want to move, then do one of the following:

• Click To Top to move the selected column to the top of the list.
• Click Up to move the selected column up one place in the list.
• Click Down to move the selected column down one place in the list.
• Click To Bottom to move the selected column to the bottom of the list.

Repeat as required.

5 Click Back to return to the Table and Column Selection tab.
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Loading a report
When editing the Products, Channels or Channel Products table, you can load a previously-saved
report.

1 In the Report Type box, select Saved Report.
The Select File dialog is displayed.

2 Select the required Product (.DBP), Channel (.DBH) or Channel Product (.DBC) report file, and then
click Open.

Finding data in a report
When editing a database table, you can find data by searching any column of the current report. Each
column in the report corresponds to a field in the table.

1 Select Edit > Find.
You can use the dialog’s toolbar instead of the Edit menu.
The Find dialog is displayed.

2 In the Column Description list, click the column you want to search.
3 Under Options, click the operator that defines the relationship between the value of the field and

the search pattern. The choice of operators depends on the type of field; there are different operators
for numeric, date and alphanumeric fields.

4 In the Search pattern box, type the value to which the field is to be compared.
5 For an alphanumeric field, select the Case sensitive check box if you want the search to differentiate

between uppercase and lowercase characters.
6 Click Find First to highlight the first row in the report (starting from the top) that matches the search

pattern.
7 Click Find Next to highlight the next row that matches the search pattern. Repeat as required.

Infor Demand Planning tells you when there are no more matching rows; click OK to acknowledge.
8 Click Close.

Filtering the unsaved changes in a report
When editing a database table, you can filter the current report to view only the rows with unsaved
changes.

1 Select Edit > Apply/Remove Filter.
The report changes to show only the rows with unsaved changes. If there are no such rows, the
report is empty.

2 Select Edit > Apply/Remove Filter again.
The report reverts to showing all rows, but any rows with unsaved changes are now at the top of
the report.

118 | Infor Demand Planning User Guide

Database Administration



Refreshing the current report
When editing a database table, you can refresh the current report with data from the database, effectively
undoing any unsaved changes.

1 Select Edit > Re-retrieve Data.
Infor Demand Planning asks whether you want to save any unsaved changes before proceeding.

2 Click Yes to save these changes or No to overwrite them.

Note: Refreshing the report also undoes any sorting or filtering you may have applied.

Exporting a report
When editing a database table, you can export all of the current report to a file outside Infor Demand
Planning.

1 Select Edit > Export.
The Save As dialog box is displayed.

2 In the File name box, type a name for the exported file.
3 In the Save as type box, select the data format to be used.

See "About export file types" on page 156.

4 Click Save.

Note: 

• The exported data reproduces how the report is currently sorted and filtered.
• If you don’t want to export all of the columns of the report, use the Edit > Print function, but

export rather than print.

Printing a report
When editing a database table, you can print all or part of the current report.

1 Select Edit > Print.
The Print Data window Report dialog box is displayed.

2  In the Column Description list, select the columns you want to include.
By default, all columns are selected.

3 In the Title box, edit or replace the default title of this report.
4 If you want to use a printer other than your default printer, click Setup. In the Printer Setup dialog,

select the printer you want to use and click OK.
You can also configure the printer if you need to.

5 Specify whether you want to use portrait or landscape orientation, and how many copies you want
to print.

6 Click Print to print the report, then click Close.
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Note: 

• The printed report reproduces how the report is currently sorted and filtered.

• You can also use the Edit > Print function to export some or all of the current report to a file
outside Infor Demand Planning.

Saving the current report
When editing the Products, Channels or Channel Products table, you can save the current report for
future reuse.

1 In the Report Type box, select Save Current Report.
The Select File dialog box is displayed.

2 In the File name box, type a name for the file.
You do not need to type the file name extension; Infor Demand Planning adds this automatically
depending on which table you are editing: Product (.DBP), Channel (.DBH) or Channel Product
(.DBC).

3 Click Save.

Note: The saved report does not reproduce how the report is currently sorted or filtered. This is
because the report is a collection of columns/fields, not a collection of rows/records.

Editing Techniques

Editing a row
When editing the Products, Channels or Channel Products table, you can edit a particular row of the
table by using a dialog, rather than editing the values directly in the table.

1 Click the row you want to edit.
2 Select Edit > Detail.

Another way of opening the Detail dialog is to double-click the row you want to edit.
A dialog box is displayed, showing the data from the selected row. You can edit only the values
shown in blue. Depending on the table you are editing and the current report, the dialog may have
tabs.

3 To select the next or previous row, select Edit > Scroll to Row > Scroll to Next Row or Scroll to
Previous Row.

4 When you have finished editing, click Close.
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Editing a column
When editing a database table, you can specify a value for the currently-selected cell and all subsequent
cells in the same column. This is known as vertical editing.

1 If necessary, sort the table so that the rows are in the required order.
2 Click the cell at which you want to start the vertical edit. The cell must correspond to an editable

field.
3 Select Edit > Vertical Edit..

The Vertical Edit dialog box is displayed.
4 Type or select the required value, click OK, then click Yes to confirm.

Note: 

• Infor Demand Planning validates the specified value, and does not update the table if it is invalid.

• You can specify which fields of a table are editable by setting the application defaults.

Filtering a table
1 Right-click any column heading.
2 On the shortcut menu, click Expert Filter.

The Specify Filter dialog box is displayed.
3 Assemble the filter in the upper panel of the dialog by combining the following elements, either by

selecting them or by typing them directly into the panel.

• relational operators

• parentheses (for expressing operator precedence)

• mathematical functions

• table columns (identified by their Oracle names)

• constants

4 Click Verify to test the filter.
5 Click OK to apply the filter.

Note: If you re-open the Specify Filter dialog, the upper panel shows the filter you have just applied.
You can edit this filter and re-apply it. The filter is always applied to the original unfiltered table; you
cannot further filter a table that is already filtered.

Copying a row (table editing)
When editing the Products, Channels or Channel Products table, you can copy some or all of the data
in one row to one or more other rows.

1 Select Edit > Edit Function.
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The Edit Database Fields dialog box is displayed.
2 Click Copy Row Data.

The Copy Row Data dialog box is displayed.
3 In the Copy from row: panel, select the row from which you want to copy data.
4 In the Copy the highlighted items below: panel, select the fields you want to copy. To select all fields,

click Select All below the panel.
Infor Demand Planning ensures that you can select only editable fields.

5 In the Copy to row: panel, select the rows to which you want to copy the selected data. To select
all rows, click Select All below the panel.

Note: You can specify which fields of a table are editable by setting the application defaults.

Copying a column (table editing)
When editing the Products, Channels or Channel Products table, you can copy data in one column to
one or more other columns. Each column corresponds to a field in the table.

1 Select Edit > Edit Function.
The Edit Database Fields dialog box is displayed.

2 Click Copy Column Data.
The Copy Column Data dialog box is displayed.

3 In the Copy data in column: panel, select the single column you want to copy (the source column).
4 In the Copy to columns: panel, select the columns to which you want to copy the source column.

To select all columns, click Select All.
Infor Demand Planning ensures that you can select only editable columns with compatible data
formats.
See "Restrictions on copying columns".

Note: 

• You cannot use this function if there are no editable fields in the current report.
• You can specify which fields of a table are editable by setting the application defaults.

Calculating columns (table editing)
When editing the Products, Channels or Channel Products table, you can use the data values in one
or two columns to calculate the data values in one or more other columns. Each column corresponds
to a field in the table. The calculation is applied to all the Products, Channels or Channel Products in
the current report.

1 Select Edit > Edit Function.
The Edit Database Fields dialog box is displayed.

2 Click Calculate.
The Enter Criteria For Column Calculation dialog box is displayed.
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3 In the Take data in column: panel, select the column which is to provide the first operand in the
calculation.

4 Select the operator: add, subtract, multiply, divide, square root or power.
5 Do one of the following:

• To use a constant value as the second operand, select Constant and type the value of the
operand in the adjacent box.

• To use another column as the second operand, select Column and select the required column
in the central panel of the dialog box.

The square root operator does not require a second operand.

6 In the To column(s): panel, select the columns you want to receive the result of the calculation.

Note: You cannot use this function if there are no numeric fields in the current report.

Sorting a table by a column
1 Right-click the column heading of the column you want to sort by.
2 On the context menu, click either Sort Ascending or Sort Descending, as required.

Sorting a table by more than one column
1 Right-click any column heading.
2 On the shortcut menu, click Expert Sort.

The Specify Sort Columns dialog box is displayed.
3 Drag the columns by which you want to sort the table from the Source Data list to the Columns

list.
4 Drag the columns within the Columns list into the required sequence. Select or clear the Ascending

check box next to each column according to whether you want to sort that column in ascending or
descending order.

5 Click OK to sort the table.

Note: 

• If you re-open the Specify Sort Columns dialog, it shows the sort you have just applied. You can
edit this sort and re-apply it. The sort is always applied to the original unsorted table.

• You can specify more a complex sort by combining columns in a mathematical expression, and
sorting the table according to the result. To specify such an expression, double-click any column
in the Columns list. The Modify Expression dialog box is displayed.

Setting a column width
1 Adjust the width of the column heading by dragging its right-hand column divider.
2 Right-click the column heading.
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3 On the context menu, click Set Column Width.

• Changing the column width changes the way the column is displayed throughout Database
Administration.

• Changing a column that corresponds to a database field has the same effect as editing the field’s
Column Width attribute within the application defaults.

Editing a column heading
1 Right-click the column heading you want edit.
2 On the shortcut menu, click Edit Column Heading.

The Change The Column Heading dialog box is displayed, showing the column’s Oracle name and
the current heading.

3 In the New Heading box, type a new heading for this column.

Note: 

• Changing the column heading changes the way the column is labeled throughout Database
Administration.

• Changing the heading of a column that corresponds to a database field has the same effect as
editing the field’s Header Text attribute within the application defaults.

Batch Editing

About batch editing
Batch editing is a way of editing the Products and Channel Products tables without having to load either
of them into Infor Demand Planning (it works by accessing the Oracle tables directly). The batch edits
apply to all the currently-selected Products and Channel Products.

This is a powerful feature that must be used with caution.

Batch editing techniques
There are three batch editing techniques:

• Editing columns (vertical editing): enables you to specify a value for any editable column/field in the
Products and Channel Products tables. You can edit any number of columns at the same time.

• Copying columns: enables you to copy data in one column/field of the Products or Channel Products
table to one or more other columns/fields. You can also copy from the Products table to the Channel
Products table (but not vice versa).
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• Calculating columns: enables you to calculate the value in one or more columns/fields of the Products
or Channel Products table from one or two other columns/fields.

Note: 

• These techniques are very similar to their table editing counterparts.

Editing columns (batch editing)
Batch editing enables you to specify a value for any editable column/field in the Products and Channel
Products tables. You can edit any number of columns at the same time.

1 In Database Administration, select the Products or Channel Products you want to edit.
See "About selecting Products and Channels" on page 35.

2 Select Product Admin > Batch Editing.
The Batch Editing dialog box is displayed.

3 Click Vertical Edit.
The Batch Editing – Vertical Edit dialog box is displayed. The Column Selection tab shows a
combined list of editable Products and Channel Products table fields.

4 Select the columns/fields that you want to edit. To select all fields, click Select All. Click OK.
The Vertical Edit tab shows two editable tables, one for Products and one for Channel Products,
containing the columns/fields selected on the Column Selection tab.

5 Specify the values that you want to apply to each column.

Note: 

• Be careful to select only the fields you want to edit, because selected fields that you don’t edit
may be reset to their default values.

• On the Vertical Edit tab, you can undo any unsaved changes by clicking Re-retrieve Data on
the Batch Editing toolbar.

• You can specify which fields of a table are editable by setting the application defaults.

Copying columns (batch editing)
Batch editing enables you to copy data in one column of the Products or Channel Products table to
one or more other columns. You can also copy from the Products table to the Channel Products table
(but not vice versa).

1 In Database Administration, select the Products or Channel Products you want to edit.
See "About selecting Products and Channels" on page 35.

2 Select Product Admin > Batch Editing.
The Batch Editing dialog box is displayed.

3 Click Copy Column Data.
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The Batch Editing - Copy Column Data dialog box is displayed.
4 In the Copy data in column: panel, select the single column you want to copy (the source column).
5 In the Copy to columns: panel, select the columns to which you want to copy the source column.

Infor Demand Planning ensures that you can select only editable columns with compatible data
formats.
See "Restrictions on copying columns".

6 If you intend to copy another column, click Save to update the database but leave the Batch Editing
- Copy Column Data dialog open. Otherwise, click OK.

Note: You can specify which fields of a table are editable by setting the application defaults.

Calculating columns (batch editing)
Batch editing enables you to calculate the values in one or more columns/fields of the Products or
Channel Products table from one or two other columns/fields.

1 In Database Administration, select the Products or Channel Products you want to edit.
See "About selecting Products and Channels" on page 35.

2 Select Product Admin > Batch EditingOn the .
The Batch Editing dialog box is displayed.

3 Click Calculate.
The Batch Editing – Calculate dialog box is displayed.

4 In the Take data in column: panel, select the column which is to provide the first operand in the
calculation.

5 Select the operator: add, subtract, multiply, divide, square root, power or reciprocal.
6 Do one of the following:

• To use a constant value as the next operand, select Constant and type the value in the adjacent
text box.

• To use another column as the next operand, select Column and then select the required column
from the adjacent list box.

The square root and reciprocal operators do not require another operand.

7 In the To column(s): panel, select the columns you want to receive the result of the calculation.
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Importing and Exporting

About importing and exporting
Database Administration provides the following import/export functions:

• You can import data into any database table, using delimited or fixed-length records.

See "More about importing" on page 130.

• You can export data from any database table, or any combination of database tables that have fields
in common. You can export to a variety of standard file formats.

See "More about exporting" on page 155.

• To make the task of importing and exporting easier, Infor Demand Planning includes several standard
import/export templates, and enables you to define your own.

See "About import/export templates" on page 127.

• Infor Demand Planning also includes an automated importing feature, where the choice of a particular
import table can trigger a process that imports raw data, discards erroneous data and updates the
correct database table.

See "About automated importing" on page 138.

Templates

About import/export templates

Import templates
An import template specifies:

• The database table and fields into which data is to be imported.

• The arrangement of the fields within each row of the import file.

• The import actions (that is, whether the import process can add to or update the affected table, and
how each column (field) in the import file is to be processed).

Export templates
An export template specifies:

• The database tables and fields from which data is to be exported.
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• If data is to be exported from more than one table, how those tables are to be joined together in the
export file.

• Optionally, the arrangement of the fields within each row of the export file. If no particular arrangement
is specified, the order of the columns in the database tables is assumed.

• Optionally, whether and how the exported data is sorted or filtered.

Note: 

• You can export data by using an import template (the import actions are simply ignored in this case),
but you cannot import data by using an export template.

Private, public and system templates
An import/export template may be defined for your own personal use (a private template), for use by
all other users (a public template) or as a template owned by Infor Demand Planning itself (a system
template).

Standard templates
The following table shows some of the standard system templates that you can expect to find installed
with Infor Demand Planning. Note that some of the templates are designed for automated importing.

See "About automated importing" on page 138.

Is used to …This standard template …

Auto-import new BOMsAdd BOM

Add new ChannelsAdd Channels

Add new ProductsAdd Products

Add new Channel ProductsAdd Channel Products

Auto-import ordersAdd Orders

Update existing Channel information.Update Channels

Add or replace Product information.Update Products

Update existing Channel Product information.Update Channel Products

Add or replace monthly sales history.Update Monthly Sales History

Add or replace monthly demand history.Update Monthly Demand History

Add or replace adjusted demand history.Update Monthly Adj. Demand History

Add or replace weekly sales history.Update Weekly Sales History

Add or replace weekly demand history.Update Weekly Demand History

Add or replace weekly adjusted demand history.Update Weekly Adj. Dem. History

Import a new net forecast.Net Forecast Import

Export the last calculated monthly net forecast.Net Forecast Table - Monthly
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Export the last calculated weekly net forecast.Net Forecast Table - Weekly

Note: 

• When a new Channel Product is created, a row is created for it in all the relevant history tables. As
its history length, at this point, is zero, the new Channel Product appears to have no history. However,
its history must be updated rather than added because some data (zero) already exists.

Creating a template
1 In Database Administration, select Product Admin > Export / Template maintenance.

The Export / Template Maintenance dialog box is displayed.

2 On the Table and Column Selection tab, select the tables and columns that you want in the
template. If this is an import template, there are restrictions on the tables and columns you can
select.
See "Automatic resolution of Channel Product References" on page 131.

3 If this is an export template, and if you select more than one table, click Join and then specify how
the tables are joined.
See "Joining tables".

4 Optionally, you can click Arrange and then specify the arrangement of the columns.
See "Arranging columns".

5 Optionally, if this is an export template, you can click Sort or Filter and then specify how the exported
data is to be sorted or filtered.

6 Click Verify to test the selection, then click Save.
7 On the Save Template tab, in the Template Name box, type the name of the new template.
8 Under Template Owner, specify the owner of this template, and whether it is a public, private or

system template.
9 If this is an import template, select the Import Template check box and specify the import actions.

See "About import actions" on page 134.
For each selected column:

• Under Import Instruction, specify how imported data is to be processed for this field.
• Under Default Value, specify the value to be used to populate the field if imported data is

prohibited, missing or null. For certain fields, a special default value must be selected.

Under Import Action, specify whether the import process is allowed only to add new rows, modify
existing rows, or both.

10 Click Save, then click OK to acknowledge.

Editing a template
1 In Database Administration, select Product Admin > Export / Template maintenance.

The Export / Template Maintenance dialog box is displayed.
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2 On the Table and Column Selection tab, click Load.
3 On the Maintain Templates tab, select the template you want to edit and click Load.
4 On the Table and Column Selection tab, make any required changes to the tables and columns

in the filter.
5 Optionally, you can click Arrange and then change the arrangement of the columns.

See "Arranging columns".

6 Optionally, if this is an export template, you can click Sort or Filter and then change how the exported
data is to be sorted or filtered.

7 Click Verify to test the selection, then click Save.
8 On the Save Template tab, in the Template Name box, select the name of the template (if you

want to overwrite it) or type a new name for the edited template. Edit the other attributes of the
template as required.

9 Click Save, then click OK to acknowledge.
You cannot overwrite a system template unless you are a steward. You cannot overwrite a private
template unless you are its owner or a steward.

Deleting a template
1 In Database Administration, select Product Admin > Export / Template maintenance.

The Export / Template Maintenance dialog box is displayed.
2 On the Table and Column Selection tab, click Load.
3 On the Maintain Templates tab, select the template you want to delete, click Delete, then click Yes

to confirm.
You cannot delete a system template unless you are a steward (all of the standard templates are
system templates). You cannot delete a private template unless you are its owner or a steward.

Importing

More about importing
This diagram summarizes the import process:
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There are two ways of specifying what data is imported:

• Select the table and columns you want, the arrangement of the columns in the import file, and the
import actions. (In most cases, you can specify only one table. The exception to this rule is described
below.)

• Load a standard or a previously-saved import template that defines the table and columns to be
imported. The template may also specify the arrangement of the columns and the import actions,
but you can edit these if you wish.

Import file formats
You can import files with fixed-length or delimited records.

See "About import file types" on page 133.

Automatic resolution of Channel Product References
Normally, you can select only one table into which to import data. However, if that target table includes
a Channel Product Reference field, you are also allowed to select the Product Code and Channel ID
fields of the Channel Products table.

The Channel Product Reference is a number that uniquely identifies each Channel Product. It is used
internally by Infor Demand Planning.
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When the file is imported, Infor Demand Planning automatically uses the Product Code and Channel
ID to resolve the corresponding Channel Product Reference, which is then written into the target table.
In this way, you can import data into tables that are keyed by the Channel Product Reference field
without having to know the value of that field.

It follows that the import file must contain the Product Code and Channel ID fields as key fields, but it
cannot include the Channel Product Reference field.

You can use this feature only when modifying existing records; when adding new records it is possible
that the Channel Product may not already exist, and so the Channel Product Reference cannot be
automatically resolved.

Because the relationship between Product Code, Channel ID and Channel Product Reference is
resolved automatically, there is no need to specify how the target table and the Channel Products table
are joined.

Important

• When modifying data in the Channel Products table, you must ensure that all the Channel Products
identified in the import file already exist. Otherwise, because of the way Infor Demand Planning
modifies records in batches, valid as well as invalid records may be discarded.

Import templates
A template may be a created as a private, public or system template. You can load any public template.
You can load a private template if you are its owner or a steward. You can load a system template only
if you are a steward.

See "About import/export templates" on page 127.

Import control options
When you import data, you must specify this information:

• The number of rows to skip at the start of the file. Typically, this is either 1 or 0, depending on whether
or not the file has a header row.

• The number of successive rows Infor Demand Planning should read before writing the imported
data to the database.

• The maximum number of rows Infor Demand Planning can reject before abandoning the import.

• Whether missing data in the import file should be replaced by default values.

• Whether extra columns in the import file should be ignored.

• Whether Infor Demand Planning should create a discard file (.DIS) containing unacceptable records.

• Whether Infor Demand Planning should display a report once the import is complete.

Import actions
You must define whether the import process can add to or modify the affected table, and how each
column (field) in the import file is to be processed. This information may be predefined in an import
template.
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See "About import actions" on page 134.

Logs
Infor Demand Planning may generate up to three import logs. These logs can be viewed, printed and
saved to a file (for possible correction and re-import).

• Import

The import log shows what happened during the import. This may be either a standard or a detailed
log. The detailed import log includes the imported and default values of the fields in any rejected rows.

• Discard

The discard log contains rows that were unacceptable because of the import actions (see above); that
is, they incorrectly attempted to add to, or to modify, the database.

• Reject

This reject log contains rows that failed to import because of errors in the data.

About import file types
Infor Demand Planning accepts two kinds of import files:

• Delimited

The rows (records) in the import file are of variable length, with columns (fields) within a row separated
by delimiting characters. Examples of possible delimiting characters are spaces, tabs and commas.

• Fixed-length

The rows (records) in the import file are of a fixed length, with columns (fields) in fixed positions in each
row. The position of each column is specified in a header record, which must be the first record in the
import file.

For example, if the import file consists of a 7-character Product code, 14-character Product description,
6-digit selling price and 7-digit cost price, then an example header record for could look like this:

A111111A1111111111111N11111N111111

The letters denote the field data type and the ‘1’ characters define the fixed length of the fields. (In fact,
the data type of each field in the import file is not determined by the letter used in the header record;
instead the data types in the file must match the data types of the database columns you specify, either
manually or in a template, when you import the file. However, a header record can make the file easier
to understand.)

File name extensions
Infor Demand Planning offers you the following choices of file name extension when you attempt to
import a file:

*.IMP Import files
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*.EXP Export files

*.DAT Data files

*.TXT Text files

*.DIS Discard files

*.CSV Comma-separated files

In fact any type of file can be selected, provided that it is formatted correctly with either delimited or
fixed-length records.

About import actions
Import actions and instructions define whether the import process can add to or modify the affected
table, and how each column (field) in the import file is to be processed.

Table import actions
You can choose one of three import actions:

• Add rows

Allows new rows to be added to the affected table, but prevents modification of existing rows.

• Modify existing rows

Allows existing rows to be modified by imported data, but prevents new rows being added.

• Modify existing rows and add missing rows

Allows existing rows to be modified, and new rows to be added.

Column import instructions
You can choose one of three types of import instruction for each column (field) in the import file:

• Key value

Import data to this field and use it, together with other key values in the same table, to uniquely identify
the correct record to be modified. If the table import action permits rows to be modified, then at least
one key value must be specified.

• Import

Import data from the file into this field; if the data is missing or null, use the default value instead.

• Use default value

Do not import data to this field; always use the default value instead.

The default value is usually the field’s initial value as specified in the application defaults, but a different
value can be specified if required. For certain fields, a special default value must be selected.
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Special default values
There are some default values that have a special significance.

Channel Products (CHAN_PRODS)Table

Channel Product Reference (CP_REF)Column

SEQUENCE CPDefault value

When inserting rows into the Channel Products table, the Channel Product
Reference is generated automatically using an Oracle sequence. The

Action taken

Channel Product Reference field should not be included in the import file, so
you must set the import action to use the default value of SEQUENCE CP.
The Channel Product Reference need not then be specified anywhere in the
import.

 

Channels (CHANNELS)Table

Channel Reference Number (CHAN_REF)Column

SEQUENCEDefault value

Obtains the next Channel Reference Number from an Oracle sequence.Action taken

 

Channel Types (CHAN_TYPES)Table

Channel Type (CHAN_TYPE)Column

SEQUENCEDefault value

Obtains the next Channel Type from the Channel Types table.Action taken

 

Time-Phased Weighting Header (TPW_HD)Table

Weighting Reference (WEIGHTING_REF)Column

SEQUENCEDefault value

Obtains the next Weighting Reference from an Oracle sequence.Action taken

 

AnyTable

Any date-format fieldColumn

TODAYDefault value

Obtains the current date.Action taken
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AnyTable

Any numeric fieldColumn

COUNT(n)Default value

Obtains the number of columns in the import file + n.
This default is typically used only when importing history, in which case it is
used for the History Length (HIST_LENGTH) column, and n should be –3

Action taken

(because the first 3 columns are History Type (needed because it’s a key),
Start Date and History Length. COUNT(n) is calculated for each row in the
import, so an import file containing rows with different number of columns
will be dealt with correctly.

 

AnyTable

Start Date (START_DATE)Column

COMPUTE DATEDefault value

Obtains the start date of a sequence of period-based data.
This default is typically used only when importing history, in which case the
import file must also include Channel Code (CHAN_ID) column and a History

Action taken

Length (HIST_LENGTH) column. Infor Demand Planning obtains the "Date
Demand Last Updated (Ct)" for the relevant Channel, then counts back the
number of periods specified by the History Length.

Importing data by selecting tables and columns
You can import data into only one table at a time (the target table).

1 In Database Administration, select Product Admin > Import.
The Import and Database Import Utility dialog box is displayed.

2 In the Database Import Utility dialog, select the file you want to import and click Open.
See "About import file types" on page 133.
At step 2, if you select the wrong import file by mistake, click the Browse button on the Import
Control tab to re-open the Database Import Utility dialog box.

3 On the Import Control tab of the Import dialog, under Import File Format, specify whether the file
contains fixed-length or delimited records (and, if the latter, specify the delimiting character).
Optionally, specify whether you want to remove quotation marks from around non-numeric fields
(including date fields).
If you are not sure of the file format, click View to view the file.

4 Under Import Control Options, specify how the file is to be processed.
See "Specifying import options".

5 Under Specify Columns, click Manual Selection, then click Select.
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6 On the Table and Column Selection tab, select the tables and columns that correspond to the
data in the file.
Normally, you must select columns from only the target table. However, if that table includes a
Channel Product Reference field, you are also allowed to select the Product Code and Channel
Code fields of the Channel Products table, in order to resolve these into the Channel Product
Reference.
See "Automatic resolution of Channel Product References" on page 131.
The Join button on the Table and Column Selection tab is redundant when importing data.

7 Click Arrange and then specify the arrangement of the columns in the file.
See "Arranging columns".

8 Click Back to return to the Import Control tab.
9 Under Import Action, and on the Import Column Actions tab, specify the import actions.

See "Specifying import actions".

10 Click Import.
The Import Log tab appears, reporting the result of the import. You can print and save the import
log. If rows are discarded or rejected by the import process, you can click Discarded or Rejected to
view, print and save them.

11 If you have more files to import, click Back to return to the Import Control tab; otherwise, click
Close to close the dialog box.

Importing data by loading a template
You can import data into only one table at a time (the target table).

1 In Database Administration, select Product Admin > Import.
The Import and Database Import Utility dialog appear.

2 In the Database Import Utility dialog, select the file you want to import and click Open.
See "About import file types" on page 133.
At step 2, if you select the wrong import file by mistake, click the Browse button on the Import
Control tab to re-open the Database Import Utility dialog box.

3 On the Import Control tab of the Import dialog, under Import File Format, specify whether the file
contains fixed-length or delimited records (and, if the latter, specify the delimiting character).
Optionally, specify whether you want to remove quotation marks from around non-numeric fields
(including date fields).
If you are not sure of the file format, click View to view the file.

4 Under Import Control Options, specify how the file is to be processed.
See "Specifying import options".

5 Under Specify Columns, click Use Template, then click Load.
6 On the Load Template tab, select the required template and click Load.
7 Under Import Action, and on the Import Column Actions tab, specify the import actions. (Import

actions are usually specified as part of the template, but you can edit them if you wish.)
See "Specifying import actions".
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8 Click Import.
The Import Log tab appears, reporting the result of the import. You can print and save the import
log. If rows are discarded or rejected by the import process, you can click Discarded or Rejected
to view, print and save them.

9 If you have more files to import, click Back to return to the Import Control tab; otherwise, click
Close to close the dialog box.

Automated Importing

About automated importing
Some imports follow an automated process once you have selected the correct template or the
appropriate "raw" import table, provided that "Automatically Trigger Imports (St)" is true.

Raw import tableAutomated import

Raw Sales Import Data (IMP_RAW_SALES)"About importing open history" on
page 147 Importing open history

Import Customer Forecast (IMP_RAW_C_FCAST)"About importing customer forecasts"
on page 142 Importing customer fore-
casts

Import Net Forecast (IMP_RAW_NET)"About importing net forecasts" on
page 145 Importing net forecasts

Raw Orders Import Data (IMP_RAW_ORDERS)"About importing orders" on page 148
Importing orders

Import SOH Data (IMP_RAW_STOCK)"About importing stock quantities" on
page 152 Importing stock quantities

Import Of Bill Of Materials (IMP_RAW_BOM)"About importing BOMs" on page 139
Importing BOMs

Import Of Budgets (IMP_RAW_BUDGETS)"About importing SBT budgets" on
page 152 Importing SBT budgets

Import SOP Budget Data (IMP_RAW_SOP_BUDGET)"About importing S&&OP budgets" on
page 151 Importing S&OP budgets

Import Customer Data (IMP_RAW_CUSTOMERS)"About importing customers" on page
144 Importing customers

Import Order Book Data (IMP_RAW_ORDERBOOK)"About importing customer orders" on
page 143 Importing customer orders

Import Channels (IMP_RAW_CHAN)"About importing Channels" on page
141 Importing Channels

Import Products (IMP_RAW_PROD)"About importing Products" on page
150 Importing Products
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Import Channel Products (IMP_RAW_CPS)"About importing Channel Products"
on page 140 Importing Channel Prod-
ucts

Import Alternative Supplier Data (IMP_RAW_ALT_SUPPLIER)"About importing alternative supplier
details" on page 153 Importing alterna-
tive suppliers

In each case, the data from the import file is initially read into the raw table. Infor Demand Planning
then automatically transfers the data into the appropriate "final" table. Rows within these tables are
updated or added as appropriate. The raw import table is then cleared. Invalid rows are placed in a
corresponding "discard" table, together with an indication of the problem and a timestamp.

Therefore the raw import table always accepts new data, regardless of the required action on the final
table.

Correcting erroneous data
If incorrect data is imported, take care when correcting the error. In some cases you can simply repeat
the process using the correct data. This will then overwrite the existing (erroneous) data in the final
table. However, the automated import process may be designed to discard duplicate data, in which
case the system rejects the second (corrected) import when trying to update the final table, because
the affected rows are already populated. In these situations, the final table must be populated directly
through by an import that modifies existing rows or, alternatively, all the data in the tables must be
cleared and the original process repeated.

Example

As an example, consider the period end procedure where sales data for the month just ended is
imported. In this case the data must first be imported into the Raw Sales Import Data table
(IMP_RAW_SALES) and then, provided that "Automatically Trigger Imports (St)" is true, automatically
transferred and stored in one of three tables:

• Open Monthly History table (OPEN_MONTHLY)

• Open Weekly History table (OPEN_WEEKLY)

• Open Daily History table (OPEN_DAILY)

If the data used is subsequently found to be incorrect then the appropriate table must first be cleared
by deleting open history before the correct data can be imported.

See "Deleting open history" on page 169.

About importing BOMs

Standard template used
Add BOM
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Tables used
• Import Of Bill Of Materials (IMP_RAW_BOM)

• Discarded Import BOM (DISC_RAW_BOM)

• Bill Of Materials Detail (BOM)

Effect of import
Provided that "Automatically Trigger Imports (St)" is true, importing data into the Import Of Bill Of
Materials table automatically updates the Bill Of Materials Detail table. As usual, invalid records are
written to the discard table.

New BOMs are listed in the "NEW BOM" exception view. Updated BOMs are listed in the "UPDATED
BOM" exception view.

To correct errors
Re-import data to the Import Of Bill Of Materials table. This overwrites the data in the Bill Of Materials
Detail table. However, a parent can have at most one BOM defined for it at the same Channel. If the
amended import has the effect of attempting to create a second BOM with the same parent this is
rejected by Infor Demand Planning. In this case the original imported BOM would need to be deleted
before re-importing. BOMs can be deleted in Replenishment Planner.

Import file format

UsageFormatColumn

Channel ID of the Channel where this BOM is assembled.A20CHAN_ID

Product code of the parent Product.A30PARENT_PROD_CD

Product code of the subordinate Product.A30SUB_PROD_CD

The quantity of the subordinate needed to make one unit of
the parent.

F14.4DRAW_QTY

The (average) number of days needed to assemble the sub-
ordinate into the parent.

I3OFFSET_DAYS

Description of the BOM.A50DESCRIPTION

The file should be sorted by Channel ID and parental Product code so that all the entries relating to
the same BOM are contiguous.

About importing Channel Products

Tables used
• Import Channel Products (IMP_RAW_CPS)
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• Discarded Imported Channel Products (DISC_RAW_CPS)

• Channel Products (CHAN_PRODS)

Effect of import
Provided that "Automatically Trigger Imports (St)" is true, importing data into the Import Channel Products
table automatically populates the Channel Products table.

For a new Channel Product, the remaining fields of the record are populated by default values.

If "Automatically Create Aggregates (St)" is true, Infor Demand Planning also automatically creates
corresponding Channel Products at all "higher" Channels in the matrix that is applied to the Product.

As usual, invalid records are written to the discard table. All new records are discarded if "Automatically
Create Channel Product (St)" is false. Records are also discarded if the Product does not exist, the
Channel does not exist, or the Channel is not part of the Product’s matrix.

To correct errors
Delete data from the raw and discard import tables, then import correct data.

See "Deleting data from the automated import tables" on page 154.

Import file format
The format of the import file must match the format of the Import Channel Products table:

UsageFormatColumn

Product code.A30PROD_CD

Channel ID.A20CHAN_ID

Channel-specific Product code.A30LOCAL_CD

Channel-specific Product description.A40LOCAL_DESCRP

Cost price.F14.4C_PRICE

Channel-specific ABC class.A3INV_CLASS

Opening stock.F14.4OPN_STK

Due-in stock.F14.4DUE_IN_STK

Lead time.I3LD_TIME

Preferred lot quantity.F14.4PREF_LOT_QTY

About importing Channels

Tables used
• Import Channels (IMP_RAW_CHAN)
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• Discarded Imported Channels (DISC_RAW_CHAN)

• Channels (CHANNELS)

Effect of import
Provided that "Automatically Trigger Imports (St)" is true, importing data into the Import Channels table
automatically populates the Channels table.

For a new Channel, the remaining fields of the record are populated by default values, except for the
"Demand Calendar Code (Ct)", "Date Demand Last Updated (Ct)", "Current Period Fiscal (Ct)" and
"End Of Current Financial Year (Ct)" fields, which are populated from the record of the Channel identified
by the "Control Channel For Stock Posting Date (St)" field.

As usual, invalid records are written to the discard table. All records are discarded if the "Control Channel
For Stock Posting Date (St)" field is null.

To correct errors
Delete data from the raw and discard import tables, then import correct data.

See "Deleting data from the automated import tables" on page 154.

Import file format
The format of the import file must match the format of the Import Channels table:

UsageFormatColumn

Channel ID.A20CHAN_ID

Channel name or description.A30CHAN_NAME

About importing customer forecasts

Tables used
• Import Customer Forecast (IMP_RAW_C_FCAST)

• Discard Customer Forecast (DISC_RAW_C_FCST)

• Customer Forecast (CUST_FCST)

Effect of import
Provided that "Automatically Trigger Imports (St)" is true, importing data into the Import Customer
Forecast table automatically populates the Customer Forecast table.

As usual, invalid records are written to the discard table.
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To correct errors
Re-import data to the Import Customer Forecast table; this overwrites the Customer Forecast table.

About importing customer orders

Tables used
• Import Order Book Data (IMP_RAW_ORDERBOOK)

• Discarded Order Book Entries (DISC_RAW_ORDERBOOK)

• Order Book (ORDER_BOOK)

Effect of import
Provided that "Automatically Trigger Imports (St)" is true, importing data into the Import Order Book
Data table automatically populates the Order Book table. As usual, invalid records are written to the
discard table.

To correct errors
Delete data from the raw and discard import tables, then import correct data.

See "Deleting data from the automated import tables" on page 154.

Import file format
The format of the import file must match the format of the Import Order Book Data table:

UsageFormatColumn

Reference number for this Order
Book entry. If a reference is

I19ORDERBOOK_REF

supplied and is already present
in the Order Book table, the ex-
isting entry is updated. If the
reference is not already present,
Infor Demand Planning adds a
new entry. If this field is blank,
Infor Demand Planning gener-
ates a new reference and adds
a new entry in the Order Book.

Product code.A30PROD_CD

Channel ID.A20CHAN_ID

Customer code, identifying the
customer. Infor Demand Plan-

A20CUST_CD

ning generates these codes
when customers are added to
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the system manually, but they
can also be defined by importing
customer data.
See "About importing cus-
tomers" on page 144.

The original quantity on the or-
der.

F14.4GOOD_QTY

Projected date that the order
should be shipped to the cus-
tomer.

DateSHIP_DATE

Date that the customer requires
delivery.

DateCUST_DUE_DT

User-defined purchase order
number.

A50PO_NUM

The Infor Demand Planning user
ID of the current user.

A30USER_ID

User-defined string field #0A250USERSTRING_0

User-defined string field #1A250USERSTRING_1

User-defined string field #2A250USERSTRING_2

User-defined string field #3A250USERSTRING_3

User-defined string field #4A250USERSTRING_4

About importing customers

Tables used
• Import Customer Data (IMP_RAW_CUSTOMERS)

• Discarded Customers (DISC_RAW_CUSTOMERS)

• Customer (CUSTOMERS)

Effect of import
Provided that "Automatically Trigger Imports (St)" is true, importing data into the Import Customer Data
table automatically populates the Customer table. As usual, invalid records are written to the discard
table.

To correct errors
Delete data from the raw and discard import tables, then import correct data.

See "Deleting data from the automated import tables" on page 154.
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Import file format
The format of the import file must match the format of the Import Customer Data table:

UsageFormatColumn

Customer code. It must be unique, but need
not necessarily be in the format used by Infor

A20CUST_CD

Demand Planning to generate codes when
customers are added manually.

Customer description.A40CUST_DESC

Channel ID.A20CHAN_ID

The Infor Demand Planning user ID of the
current user.

A30USER_ID

User-defined string field #0A250USERSTRING_0

User-defined string field #1A250USERSTRING_1

User-defined string field #2A250USERSTRING_2

User-defined string field #3A250USERSTRING_3

User-defined string field #4A250USERSTRING_4

About importing net forecasts

Standard templates used
Net Forecast Import

Tables used
• Import Net Forecast (IMP_RAW_NET)

• Discard Net Forecast (DISC_RAW_NET)

• Market Intelligence (MARKET_INTEL) and Market Intelligence Header (MARKET_INTEL_HD)

Effect of import
Adds new, or adjusts existing, E-type market intelligence to make the net forecast match the imported
values. Existing E-type MI before or after the imported data may be deleted according to whether you
specify start and end dates, and depending on whether the "Remove MI On Import (Ct)" field is true
or false.

See "Examples of importing net forecasts".

As usual, invalid records are written to the discard table.

Infor Demand Planning User Guide | 145

Database Administration



To correct errors
Re-import data to the Import Net Forecast table; this adds additional E-type MI to re-adjust the values
in the Market Intelligence and Market Intelligence Header tables.

Import file format
The format of the import file must match the format of the Import Raw Net Forecast table:

UsageFormatColumn

Product code.A30PROD_CD

Channel ID.A20CHAN_ID

Y = Yearly data M = Monthly data W = Weekly data (only for weekly-
controlled databases)

A1PERIODICITY

Period end date of the first period's data. If specified, Infor Demand
Planning deletes or retains existing E-type MI before this date de-

DateSTARTDATE

pending on whether the "Remove MI On Import (Ct)" field is true or
false. If omitted, Infor Demand Planning uses the period end date
of the first forecast period and so does not delete any MI.

Period end date of the last period's data. If specified, Infor Demand
Planning deletes all existing E-type MI after this date. If omitted, Infor

DateENDDATE

Demand Planning uses the period end date of the last forecast period
and so does not delete any MI.

Net forecast for period 1.F14.4PERIOD_1

Net forecast for period 2.F14.4PERIOD_2

………

Net forecast for period 212. Infor Demand Planning ignores yearly
or monthly data beyond the "Monthly Forecast Horizon (St)".

F14.4PERIOD_212

Description of the market intelligence. If omitted, Infor Demand
Planning uses "MI generated from Net Forecast".

A40DESCRP

Note: 

• Importing a zero net forecast for any period means that the existing net forecast for that period is
to be kept unchanged.

• Weekly period end dates must be a multiple of 7 days starting from the monthly period end date.

• When importing yearly data, the imported annual net forecast for the first year is split amongst the
remaining number of monthly periods up to the end of the current fiscal year, in proportion to their
net forecast before the import. The subsequent annual net forecast values are spread across the
number of forecast periods in the fiscal year (either 12 or 13, as defined by "Forecast Periods Per
Year (St)") in proportion to their net forecast before the import.

• When importing monthly data into a weekly-controlled database, the monthly net forecast is split
into weekly amounts according to each Channel Product’s month-to-weeks interpolation vector
("Month To Week Interpolation Code (CPt)").
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• This import function does not balance the changed net forecasts throughout the affected matrices.

About importing open history
Open history is sales or demand data imported into Infor Demand Planning during the current period.
This data does not become committed as actual history until the database is rolled forward. If necessary,
you can import open history more than once during the current period; in this case, the history you
import is assumed to be cumulative (that is, it overwrites the existing open history).

Standard templates used
• Add Monthly Sales History

• Add Monthly Demand History

• Add Monthly Adj Demand History

• Add Weekly Sales History

• Add Weekly Demand History

• Add Weekly Adj Demand History

• Add Daily Sales History

• Add Daily Demand History

• Add Daily Adj Demand History

Tables used
• Raw Sales Import Data (IMP_RAW_SALES)

• Raw Sales Discard Data (DISC_RAW_SALES)

• Open Monthly History (OPEN_MONTHLY)

• Open Weekly History (OPEN_WEEKLY)

• Open Daily History (OPEN_DAILY)

Effect of import
Provided that "Automatically Trigger Imports (St)" is true, importing data into the Raw Sales Import
Data table automatically populates either the Open Monthly History, Open Weekly History or Open
Daily History table.

As usual, invalid records are written to the discard table. Records that attempt to import open history
for a Channel which does not have the Store History behavior are written to the discard table.

See "About Channel behaviors" on page 72.

Records relating to a Channel Product are also discarded if:

• Weekly data is being imported, and "Accumulate Daily History To Weeks (Ct)" is true.
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• Monthly data is being imported, and either "Accumulate Daily History To Months (Ct)" or "Accumulate
Daily History To Weeks (Ct)" is true.

To correct errors
Delete the open history. Re-import the data to the Raw Sales Import Data table.

See "Deleting open history" on page 169.

Import file format
The format of the import file must be as follows:

UsageFormatColumn

Product code.A30PROD_CD

Channel ID.A20CHAN_ID

Datestamp for this dataDateDATESTAMP

1 = Sales 2 = Demand 3 = Adjusted DemandI1HIST_TYPE

0 = Monthly data 1 = Weekly data (only for weekly-controlled
databases) 2 = Daily data

I1PERIOD_TYPE

The monthly, weekly or daily data point VALUE

Note: 

• When importing open history for a predecessor CP in a predecessor/successor relationship, make
sure that the correct history types are available for eventual transfer to the successor CP.

About importing orders

Standard template used
Add Orders

Tables used
• Raw Orders Import Data (IMP_RAW_ORDERS)
• Raw Orders Discard Data (DISC_RAW_ORDERS)
• Order (ORDERS)

Effect of import
Provided that "Automatically Trigger Imports (St)" is true, importing data into the Raw Orders Import
Data table automatically populates the Orders table with a mixture of the imported data and additional
values derived from that data. As usual, invalid records are written to the discard table.
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To correct errors
Re-import data to the raw table. This adds additional orders, or changes existing ones, in the Orders
table. Any redundant orders from the erroneous import must be deleted in Replenishment Planner.

See "Deleting orders" on page 413.

Import file format
The format of the import file should match the format of the Add Orders template:

UsageFormatColumn

Product code.A30PROD_CD*

Channel ID.A20CHAN_ID*

The quantity on the order.F14.4GOOD_QTY*

The date that the order is expected to arrive at this Channel.DateDUE_DATE*

A unique number allocated automatically by Infor Demand
Planning to each order. It is required only when updating an
existing order, or deleting an order with a null Good Quantity.

I10ORDER_REF

0 = Recommended order 1 = Open order 2 = Closed (archived)
order 3 = Independent order

I1TYPE

If this is null, and there is no Order Reference, it is set to equal
the Good Quantity.

F14.4ORIG_QTY

To be completed when the order is received at this Channel.DateRECEIVED_DATE

Optional order reference number used by systems outside Infor
Demand Planning.

A50PO_NUM

Supplier code if the item is sourced externally.A20SOURCE_CD

The source Channel ID if the item is sourced internally.
This is combined with the Product Code to get the source’s
Channel Product Reference for use in the Orders table.

A20SOURCE_CHAN

0 = Normal order 1 = Held orderI1STATUS

The Infor Demand Planning user ID of the current user.A30USER_ID

User-defined string field #0A250USERSTRING_0

User-defined string field #1A250USERSTRING_1

User-defined string field #2A250USERSTRING_2

User-defined string field #3A250USERSTRING_3

User-defined string field #4A250USERSTRING_4

Schedule dateDateSCHED_DATE

Whether this order is used in capacity calculations:
0 = False 1 = True

I1USED_CAP
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Note: 

• Fields marked with an asterisk * are required fields.
• The Orders table has space for up to five optional user-defined alphanumeric fields. These fields

can be specified in any order.

Orders table fields that are not usually imported
The automated import process calculates or otherwise derives the values of the following Orders table
fields using the data in the import file.

• "Channel Product Reference (Ot)"
• "Release Date (Ot)"
• "Estimated Need Date (Ot)"
• "Creation Date (Ot)"
• "Ship Date (Ot)"
• "Schedule Date (Ot)"
• "Safety Stock Target (Ot)"
• "Critical Flag (Ot)"
• "Days Cover (Ot)"

About importing Products

Tables used
• Import Products (IMP_RAW_PROD)

• Discarded Imported Products (DISC_RAW_PROD)

• Products (PRODUCTS)

Effect of import
Provided that "Automatically Trigger Imports (St)" is true, importing data into the Import Products table
automatically populates the Products table. For a new Product, the remaining fields of the record are
populated by default values.

As usual, invalid records are written to the discard table.

To correct errors
Delete data from the raw and discard import tables, then import correct data.

See "Deleting data from the automated import tables" on page 154.

Import file format
The format of the import file must match the format of the Import Products table:
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UsageFormatColumn

Product code.A30PROD_CD

Product description.A40PROD_DESCRP

Budgeted standard cost.F14.4STD_COST

Budgeted selling price.F14.4SELL_PRICE

ABC class.A3CLASS

About importing S&&OP budgets

Tables used
• Import SOP Budget Data (IMP_RAW_SOP_BUDGET)

• Discard SOP Budget Data (DISC_RAW_SOP_BUDGET)

• S&OP Sales Budgets/Actuals(SOP_SALES_BDATS)

• S&OP Requirements Budgets/Actuals(SOP_REQS_BDATS)

• S&OP Inventory Budgets/Actuals(SOP_INV_BDATS)

Effect of import
Provided that "Automatically Trigger Imports (St)" is true, importing data into the raw table automatically
updates the relevant SOP Budgets/Actuals table. As usual, invalid records are written to the discard
table.

To correct errors
Re-import data to the raw table; this overwrites the relevant S&OP Budgets/Actuals table.

Import file format
The format of the import file must match the format of the raw table:

UsageFormatColumn

Product code.A30PROD_CD

Channel ID.A20CHAN_ID

S = Sales (for the SOP_SALES_BDATS table) R = Requirements
(for the SOP_REQS_BDATS table) I = Inventory (for the
SOP_INV_BDATS table)

A1BUDGET_TYPE

1 = Budget 1 2 = Budget 2 3 = Budget 3 4 = Budget 4N1BUDGET_CLASS

Period end date of the first period's data. This enables a budget to
be imported part way through a year.

DateBUD_1ST_PD
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Budget data for period 1.F14.4PERIOD_1

Budget data for period 2.F14.4PERIOD_2

………

Budget data for period 24.F14.4PERIOD_24

Note: 

• A zero budget value for any period means that the existing value for that period is to be kept
unchanged.

About importing SBT budgets

Tables used
• Import Of Budgets (IMP_RAW_BUDGETS)

• Discarded Import Budgets (DISC_RAW_BUDGETS)

• SOP Plans (SOP_PLANS)

Effect of import
Provided that "Automatically Trigger Imports (St)" is true, importing data into the Import Of Budgets
table automatically updates the SOP Plans table. As usual, invalid records are written to the discard
table.

To correct errors
Re-import data to the raw table; this overwrites the SOP Plans table.

About importing stock quantities

Tables used
• Import SOH Data (IMP_RAW_STOCK)

• Discarded SOH Data (DISC_RAW_STOCK)

• Channel Product (CHAN_PRODS)

Effect of import
Provided that Automatically Trigger Imports (St) is true, importing data into the Import SOH Data table
automatically updates the "Date Stock Last Updated (Ct)", "Opening Stock (CPt)" and "Due In Stock
(CPt)" fields. As usual, invalid records are written to the discard table.
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To correct errors
Re-import data to the Import SOH Data table; this overwrites the data in the Channels and Channel
Products tables.

Import file format

UsageFormatColumn

Channel ID.A20CHAN_ID

Datestamp for this data; that is, the date that stock was last
updated for this Channel.

DateDATESTAMP

Product code.A30PROD_CD

The latest stock quantity. At period end, this represents the
opening stock for the following period.

F14.4STOCK_ON_HAND

The total quantity of stock on currently outstanding incoming
orders. (This value is often zero, because it is usually possible

F14.4STOCK_DUE_IN

to calculate it from the good quantities of all incoming open
orders.)

About importing alternative supplier details

Tables used
• Import Alternative Supplier Data (IMP_RAW_ ALT_SUPPLIER)

• Discarded Alternative Supplier Data (DISC_RAW_ ALT_SUPPLIER)

• Alternative Supplier (ALT_SUP_TRANS)

Effect of import
Provided that "Automatically Trigger Imports (St)" is true, importing data into the Import Alternative
Supplier Data table automatically populates the Alternative Supplier table. As usual, invalid records
are written to the discard table.

To correct errors
Delete data from the raw and discard import tables, then import correct data.

See "Deleting data from the automated import tables" on page 154.

Import file format
The format of the import file must match the format of the Import Alternative Supplier Data table:

UsageFormatColumn
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Unique loader reference number
for import.

I10LOADER_REF

The Infor Demand Planning user
ID of the current user.

A30USER_ID

Product in which to define the
supplier.

A30PROD_CD

Channel in which to define the
supplier.

A20CHAN_ID

Valid supplier.A20SUP_CD

Supplier lead time in days for this
transport type and preference in-
dex.

F14.4OFFSET

Preference or priority index that
specifies the order of preference

I3PREF_INDEX

when choosing a supplier (1 be-
ing the highest preference).

Minimum order quantity for this
supplier link.

F14.4MIN_BUY QTY

Incremental quantity for this sup-
plier link.

F14.4INC_VALUE

Valid value in the
TRANS_TYPES table.

A3TRANS_TYPE

Deleting data from the automated import tables
Infor Demand Planning’s automated import feature works by importing records into "raw" tables, then
moving any invalid records to "discard" tables before adding or updating the valid records in the target
database tables. From time to time, you may need to clear these raw and discard tables.

1 In Database Administration, select Product Admin > Delete Import/Discard Raw Tables.
The Delete Data from Discard and Import Raw Data Tables dialog box is displayed.

2 On the Select Data to View or Delete Data tab, select the required table.
3 To view the selected table, click View.
4 To delete the selected table, click Delete, and then click Yes to confirm.

Repeat as required.

5 When you are finished, click Close.
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Exporting

More about exporting
There are three ways of specifying the data to be exported:

• Select the tables and columns you want, including how multiple tables are joined. Optionally, you
can also specify how the data is to be sorted and filtered, and the arrangement of the columns in
the export file.

• Load a standard or a previously-saved export template. A template can specify the tables, columns,
table joins, sorting, filtering and column arrangements.

• Type, or load from a file, the necessary SQL expression.

These three methods can be mixed. For example, you can load a template, change how the data is
sorted, then edit the resulting SQL expression.

In all cases you can restrict the data to only the currently-selected Products and Channel Products,
rather than all the data in the database.

Export templates
A template may be a created as a private, public or system template. You can load any public template.
You can load a private template if you are its owner or a steward. You can load a system template only
if you are a steward.

See "About import/export templates" on page 127.
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About export file types
Infor Demand Planning supports the following file types for data exported from database tables. Some
file types include headers; in these cases, the first line of the file contains the Oracle names of the
exported table columns/fields.

 

NotesCan be opened with …File type

Comma-separated values.MS ExcelCSV

Comma-separated values.MS ExcelCSV with headers

 dBase, MS ExcelDbase 2

 dBase, MS ExcelDbase 3

Data interchange format. An ASCII
file containing only integer values.

MS ExcelDIF

Comma-separated values.Infor Demand PlanningDIS

 MS ExcelExcel

 MS ExcelExcel with headers

 MS ExcelExcel 5

 MS ExcelExcel 5 with headers

Comma-separated values.Infor Demand PlanningEXP

 Any HTML editor.HTML Table

Comma-separated values.Infor Demand PlanningIMP

.PSR file name extension.Sybase PowersoftPowersoft Report

 TOAD, Sybase InfoMaker, SQL,
MS Excel

SQL

Symbolic Link format.MS Excel, MS GraphSYLK

Symbolic Link format.MS Excel, MS GraphSYLK with headers

Tab-separated.Any text editorText

Tab-separated.Any text editorText with headers

Lotus 1-2-3 format.Lotus, MS Excel, MS GraphWKS

Lotus 1-2-3 format.Lotus, MS Excel, MS GraphWKS with headers

Lotus 1-2-3 format.Lotus, MS Excel, MS GraphWK1

Lotus 1-2-3 format.Lotus, MS Excel, MS GraphWK1 with headers

Windows metafile.Most graphics programsWMF
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Exporting data by selecting tables and columns
1 In Database Administration, select Product Admin > Export / Template maintenance.

The Export / Template Maintenance dialog box is displayed.
2 On the Table and Column Selection tab, select the Preselected Data check box if you want to

export only data relating to the currently-selected Products and Channel Products. Otherwise, all
data is eligible for export.
The Preselected Data check box is only available if you have the necessary access privilege.

3 Select the tables and columns that you want to export.
4 If you select more than one table, click Join and then specify how the tables are joined.

See "Joining tables".

5 Optionally, you can click Arrange and then specify the arrangement of the columns.
See "Arranging columns".

6 Optionally, you can click Sort or Filter and then specify how the exported data is to be sorted or
filtered.

7 Click Verify to test the selection, then click Preview.
8 On the Preview tab, click Export. The Save As dialog box is displayed.

On the Preview tab, you can print the data as well as export it.

9 In the File name box, type a name for the exported file.
10 In the Save as type box, select the data format to be used.

See "About export file types" on page 156.

11 Click Save, then click OK to acknowledge.

Exporting data by loading a template
1 In Database Administration, select Product Admin > Export / Template maintenance.

The Export / Template Maintenance dialog box is displayed.
2 On the Table and Column Selection tab, select the Preselected Data check box if you want to

export only data relating to the currently-selected Products and Channel Products. Otherwise, all
data is eligible for export, depending on the template.
The Preselected Data check box is only available if you have the necessary access privilege.

3 Click Load.
4 On the Maintain Templates tab, select the template you want and click Load.

Once you have loaded a template, you can edit it as necessary.
5 On the Table and Column Selection tab, click Verify to test the selection, then click Preview.
6 On the Preview tab, click Export. The Save As dialog box is displayed.

On the Preview tab, you can print the data as well as export it.

7 In the File name box, type a name for the exported file.
8 In the Save as type box, select the data format to be used.

See "About export file types" on page 156.
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9 Click Save, then click OK to acknowledge.

Exporting data by using an SQL expression
1 In Database Administration, select Product Admin > Export / Template maintenance.

The Export / Template Maintenance dialog box is displayed.
2 On the Table and Column Selection tab, select the Preselected Data  check box if you want to

export only data relating to the currently-selected Products and Channel Products. Otherwise, all
data is eligible for export.
The Preselected Data check box is only available if you have the necessary access privilege.

3 Click SQL.
4 On the SQL Control tab, do one of the following:

• Edit the SQL expression directly in the Export data SQL syntax box.
• Click Open to select and load a previously-saved SQL file.

Click Save if you want to save the contents of the Export data SQL syntax box to an external file.

5 Click Execute.
6 On the Preview tab, click Export. The Save As dialog box is displayed.

On the Preview tab, you can print the data as well as export it.

7 In the File name box, type a name for the exported file.
8  In the Save as type box, select the data format to be used.

See "About export file types" on page 156.

9 Click Save, then click OK to acknowledge.

Discount Factors

About discount factors
Discount factors, also known as smoothing rates, are parameters that are used in the BATS forecasting
calculations. They determine how much weight or emphasis the calculations put on recent data.

See "About Bayesian theory and the Dynamic Linear Model" on page 209.

Each discount factor can have a value of between 0 and 1. A value of 1 represents a static model in
which all data points are given equal weight; a value closer to 0 gives more weight to recent data.

In order to consistently apply these discount factors to a range of Channel Products, you can define
sets of factors in the Database Administration module. You can then apply a particular set to selected
Channel Products by editing the "Discount Factor Code (CPt)" field.
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Each set comprises eight discount factors; four standard factors and four matching intervention factors:

Intervention factorsStandard factors

Intervention Trend Rapid discount factor which will
be applied to revise the trend elements of the

Trend Discount factor to be applied to the trend
elements of the forecast (level and growth) when

forecast (level and growth). It should typically be
set lower than the standard discount factor.

the forecast is created, or revised at period end.
The default value of 1 represents a static model.

Intervention Seasonal Rapid discount factor to be
applied to revise the seasonal coefficients of the

Seasonal Discount factor to be applied to the
seasonal model coefficients when the forecast is

forecast. It should typically be set lower than the
standard discount factor.

created, or revised at period end. The default value
of 1 represents a static model.

Intervention Variance Rapid discount factor which
will be applied to revise the variance estimate of

Variance Discount factor to be applied to the vari-
ance when the forecast is created, or revised at

the forecast. It should typically be set lower than
the standard discount factor.

period end. The default value of 1 represents a
static model.

Intervention Regression Rapid discount factor
which will be applied to independent variables used
in causal modeling during the DLM process.

Regression Discount factor to be applied to the
independent variables used in causal modeling
during the dynamic linear modeling (DLM) process.

Intervention factors can be applied in two circumstances:

• If the item has a tracking signal. The intervention factors are applied between the detected step
change and the point at which the tracking signal is issued. The maximum number of periods used
to detect tracking signals is defined by the "Run Length Limit (St)" field, and thus that field acts as
a maximum limit to the number of periods to be used along with this rapid discount factor to revise
the forecast.

• If the corresponding threshold is broken. "Scale Inflation Factor (St)" stores a factor, which is used
to develop an alternative model to monitor the increase in the estimate of variance. This comparison
of the two models provides a Bayes factor which is compared to the value held in the "Scale Inflation
Threshold (St)" field, thus providing a tracking signal for items where there is believed to be a
significant change in the variance over a period of months.

Default sets of discount factors
Infor Demand Planning comes with (at least) two default sets of discount factors:

• Default static settings ("Discount Factor Code (CPt)" = 0)

These are the default factors for Normal Products.

1.0Intervention Trend1.0Trend

1.0Intervention Seasonal1.0Seasonal

1.0Intervention Variance1.0Variance

1.0Intervention Regression1.0Regression

• Default SMP settings ("Discount Factor Code (CPt)" = 1)

These are the default factors for Slow Moving Products.
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1.0Intervention Trend0.6Trend

1.0Intervention Seasonal1.0Seasonal

1.0Intervention Variance0.6Variance

1.0Intervention Regression1.0Regression

These sets of discount factors can be automatically applied when a model is fitted to a Channel Product
in the Demand Forecaster module, if the process detects that the status of the item has changed. If an
SMP is changed to a Normal product, its "Discount Factor Code (CPt)" is set to 0; conversely, if a
Normal Product is changed to an SMP, its "Discount Factor Code (CPt)" is set to 1.

Adding a set of discount factors
1 In Database Administration, select DB Admin > System > Discount Factors.
2 In the Discount Factors dialog box, click Add.

A second Discount Factors dialog box is displayed.
3  In the Description field, specify a name for this set of discount factors.
4 Specify the values for each discount factor in the set.

Editing a set of discount factors
1 In Database Administration, select DB Admin > System > Discount Factors.

The Discount Factors dialog box shows the existing sets of discount factors.
2 Click the set you want to edit, then click Edit.

A second Discount Factors dialog box is displayed.
3 Edit the name of this set and the values of each discount factor in the set, as required.

Deleting a set of discount factors
1 In Database Administration, select DB Admin > System > Discount Factors.

The Discount Factors dialog box shows the existing sets of discount factors.
2 Click the set you want to delete.
3 Click Delete, then Yes to confirm.

Applying a set of discount factors to a Channel Product
You apply a set of factors to one or more channel products by editing the Channel Products table.
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1 In Database Administration, select the products and channels that you want to edit.
See "About selecting Products and Channels" on page 35.

2 Select Product Admin > Channel Products.
The Channel Products dialog box shows an editable table.

3 In the Report Type box, select Forecasting.
4 Scroll the right-hand pane until the Discount Factor Code column is visible.
5  In the Discount Factor Code cells of the channel products that you want to edit, select the required

set of discount factors.
If the Channel Products dialog box only shows the channel products that you want to edit, you can
vertically edit all the cells in the Discount Factor Code column at once. See "Editing the Channel
Products table" on page 116.

History

About history
To begin the forecasting process, the system requires historical data for each Channel Product. You
can import history using the periodicity that is most convenient for your business. If daily or weekly
data is used, Infor Demand Planning aggregates it into monthly amounts in order to calculate the
statistical forecast.

Ideally, demand history should be used as this provides the most accurate record of what the customer
actually wanted. However, capturing real demand data is a difficult task and consequently many
businesses use invoiced sales as a second-best approximation.

Daily data may be stored for up to 159 weeks, weekly for up to 212 weeks and monthly for up to 120
months.

History may be stored in integer or decimal format. This decision affects the whole database as decimal
format requires more disk space.

History types
Three types of history are stored in the database:

• Sales history

Sales history represents what was actually sold. However, this is not always a reliable indicator of
demand. For example, if stock runs out, this is likely to lower the sales figures artificially. And when
stock becomes available gain, abnormally high sales may be recorded as backorders are cleared.
Because this is a record of actual sales, this type of history should not normally be edited. It is used
mostly for reporting purposes.
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• Demand history

Demand is defined as "What the customer wanted, when the customer wanted it." Demand history is
often difficult to record. It should represent what would have been sold in each period if there had been
stock available. If there is no record of demand history, Infor Demand Planning allows you to copy data
from the sales history.

• Adjusted demand history

Over time, it is often possible to build a record of demand stored alongside sales history. For instance,
if an business has knowledge of an incident which artificially affected sales (such as the stock-out
situation described above) it may be best to copy the recorded sales or demand history and make
manual adjustments that reflect what happened. This history is called adjusted demand and is the only
history that should be edited. Adjusted demand is used for generating the demand forecast.

Another example where demand and adjusted demand may be different would be promotional demand
on a non-standard pack added to the demand of the standard item (which may or may not have been
selling at the same time). Other possibilities include permanent forecast groups, where the parent item
actually has no demand of its own but simply records the total demand of all members within that group.

Masking history
You can mask individual periods of adjusted demand if you judge them to be unrepresentative and
likely to falsify the statistical forecast. A forecast model is then produced from the non-masked adjusted
demand. (Alternatively, the adjusted demand history may be edited to give a more "realistic" pattern
of demand.)

Note: 

• You can copy one type of history (for example, sales history) to another type of history (for example,
demand history) for one or all of the currently-selected Channel Products.

• Only the most recent 65 monthly periods of history is readily accessible in Infor Demand Planning,
because it is used for the forecast calculations. Any earlier periods of history are archived within
the database, and can be exported if required.

About aggregating history
To allow Infor Demand Planning to work more quickly, history is usually not recorded at aggregate
Channels, unless such Channels are explicitly given the Store History behavior.

This means, for example, that it is not normally possible to export history for Channel Products at
aggregate Channels.

However, Infor Demand Planning does allow you to populate the Daily History, Weekly History or
Monthly History table for aggregate Channel Products by aggregating the history from their subordinate
Channels.
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This feature enables you to aggregate sales, demand and adjusted demand history to Channels that
do not have the Store History behavior, from all subordinate Channels that do not have the Exclude
From History Pass Up behavior, for a given selection of Products.

See "About Channel behaviors" on page 72.

Example 1
In the following example matrix, the shaded Channels have the Store History behavior; the non-shaded
Channels do not. Assuming that no Channels have the Exclude From History Pass Up behavior, history
can be aggregated to all the non-shaded Channels.

However, if England were given the Exclude From History Pass Up behavior, the aggregated history
at UK would consist only of the aggregated history from Wales and Scotland.

Example 2
In this slightly modified example, the UK Channel has the Store History behavior, which means that
history is stored here in its own right and is not aggregated from below. In this case, the aggregated
history at the Europe Channel is the stored history at UK plus the aggregated history at Switzerland.
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Renaming history types
With Infor Demand Planning, three types of history can be stored with these initial names:

• Sales
• Demand
• Adjusted Demand

Mask-to-mask unrepresentative periods of adjusted demand are also stored.

You can change these names, but not the underlying meaning of the data that they represent.

Note: You are unlikely to need to use this feature.

1 In Database Administration, select DB Admin > System > History Options.
The History Options dialog box shows the types of history.

2 To change the name of a history type, click its Description cell, specify a new name or description,
then click outside the cell.

Copying history types for all the selected channel products
You can copy one type of history to another type of history, for example, from sales to demand.

1 In Database Administration, select the products and channels that you want to edit.
See "About selecting Products and Channels" on page 35.

2 Select Product Admin > Copy History.
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3 In the Copy History dialog box, specify this information:

History Periods
Click Monthly or Weekly. The Weekly option is available only if the database has a weekly
periodicity. See "About monthly- and weekly-controlled databases" on page 67.

History to Copy
Click All Currently Selected.

4 In the panel at the bottom of the dialog box, click a type of history and drag it where you want to
copy it.

5 Click Yes to confirm.

Caution: This is a powerful feature. Be careful not to overwrite history by mistake.

All the periods of the selected history type are copied for all channel products.

History is copied within the channel products.

If you want to copy history between the channel products, use the Alternate History function in Demand
Forecaster.

Copying history types for one channel product
You can copy one type of history to another, for example, from sales to demand. You can also edit
history before or after you copy it.

1 In Database Administration, ensure that the channel product that you want to edit is among the
currently selected channel products.
See "About selecting Products and Channels" on page 35.

2 Select Product Admin > Copy History.
3 In the Copy History dialog box, specify this information:

History Periods
Click Monthly or Weekly. The Weekly option is available only if this is a weekly-controlled database.
See "About monthly- and weekly-controlled databases" on page 67.

History to Copy
Click Individual Selection.

Product Code and Channel Code
In the lists, select the channel product that you want to edit.

The panel at the bottom of the dialog box shows an editable table of historical data for each monthly
or weekly period. The first period or week is the oldest historical period, the second period or week
is the next oldest, and so on.

4 You can edit any of the history values that are displayed in blue:

• To edit a history value, double-click its cell, specify a new value and click outside the cell.
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• To remove all history of a particular type, click its row, click Clear, then Yes to confirm.

5 Click the row that contains the type of history that you want to copy and drag it where you want to
copy it.

6 Click Yes to confirm.

Caution: This is a powerful feature. Be careful not to overwrite history by mistake.

All periods of the selected history type are copied for the selected channel product.

History is copied to another type for the same channel product.

If you want to copy history between channel products, use the Alternate History function in Demand
Forecaster. When editing the forecast in Demand Forecaster, you can also edit history.

Aggregating history
1 In Database Administration, select the products that you want to aggregate.

See "About selecting Products and Channels" on page 35.

2 Select Product Admin > Aggregate History.
3 In the Aggregate History dialog box, specify this information:

History Types
Select the types of history that you want to aggregate.

Periodicity
Specify whether you want to aggregate history in daily, weekly or monthly amounts. The periodicity
of the database determines which of these options are available.

4 To start the process, click OK.
5 When the process is complete, click Close.

Open History

About open history
Open history is sales or demand data imported into Infor Demand Planning during the current period.
This data does not become committed as actual history until the database is rolled forward at period
end.
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Infor Demand Planning’s automated importing feature is used to import data into the Raw Sales Import
Data table and then, provided that "Automatically Trigger Imports (St)" is set, automatically transfer it
to the appropriate database table:

• Open Monthly History table

• Open Weekly History table

• Open Daily History table

While data is stored in these tables – that is, after being imported but before rolling the database forward
– you can edit it or, if necessary, delete it.

See "About automated importing" on page 138.

When the database is rolled forward, data in these tables is transferred to the corresponding history
table:

• Monthly History table

• Weekly History table

• Daily History table

For items in a predecessor/successor relationship, the predecessor’s open history is also copied to
the successor’s history at period end. When you set up the relationship, you specify what types of
history to transfer (typically, only demand). You must therefore ensure that you have imported this type
of open history for the predecessor before period end.

See "About predecessors/successors" on page 283.

Note: 

• Open history is sometimes referred to as "current demand".

• If you put a value in an item’s "Adjusted Monthly Demand (CPt)" field, this overrides the open monthly
adjusted demand at period end.

About importing open history
Open history is sales or demand data imported into Infor Demand Planning during the current period.
This data does not become committed as actual history until the database is rolled forward. If necessary,
you can import open history more than once during the current period; in this case, the history you
import is assumed to be cumulative (that is, it overwrites the existing open history).

Standard templates used
• Add Monthly Sales History

• Add Monthly Demand History

• Add Monthly Adj Demand History

• Add Weekly Sales History
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• Add Weekly Demand History

• Add Weekly Adj Demand History

• Add Daily Sales History

• Add Daily Demand History

• Add Daily Adj Demand History

Tables used
• Raw Sales Import Data (IMP_RAW_SALES)

• Raw Sales Discard Data (DISC_RAW_SALES)

• Open Monthly History (OPEN_MONTHLY)

• Open Weekly History (OPEN_WEEKLY)

• Open Daily History (OPEN_DAILY)

Effect of import
Provided that "Automatically Trigger Imports (St)" is true, importing data into the Raw Sales Import
Data table automatically populates either the Open Monthly History, Open Weekly History or Open
Daily History table.

As usual, invalid records are written to the discard table. Records that attempt to import open history
for a Channel which does not have the Store History behavior are written to the discard table.

See "About Channel behaviors" on page 72.

Records relating to a Channel Product are also discarded if:

• Weekly data is being imported, and "Accumulate Daily History To Weeks (Ct)" is true.

• Monthly data is being imported, and either "Accumulate Daily History To Months (Ct)" or "Accumulate
Daily History To Weeks (Ct)" is true.

To correct errors
Delete the open history. Re-import the data to the Raw Sales Import Data table.

See "Deleting open history" on page 169.

Import file format
The format of the import file must be as follows:

UsageFormatColumn

Product code.A30PROD_CD

Channel ID.A20CHAN_ID

Datestamp for this dataDateDATESTAMP
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1 = Sales 2 = Demand 3 = Adjusted DemandI1HIST_TYPE

0 = Monthly data 1 = Weekly data (only for weekly-controlled
databases) 2 = Daily data

I1PERIOD_TYPE

The monthly, weekly or daily data point VALUE

Note: 

• When importing open history for a predecessor CP in a predecessor/successor relationship, make
sure that the correct history types are available for eventual transfer to the successor CP.

Editing open history
1 In Database Administration, select the products and channels that you want to edit.

See "About selecting Products and Channels" on page 35.

2 Select Product Admin > Current Demand and select one of these options:

• Monthly
• Weekly
• Daily

When editing open monthly adjusted demand, you can also edit the Adjusted Monthly Demand
(CPt). See "Adjusted Monthly Demand (CPt)".
The Monthly, Weekly, or Daily Current Demand dialog box is displayed.

3  In the upper panel of the dialog, select the type of history you want to edit.
The lower panel in the dialog box shows an editable table of the open history of the selected type
for each of the currently selected channel products. If the channel products have no open history
of the selected type, the panel is empty. You can edit any of the values that are displayed in blue.

4 To edit a value, click its cell, specify a new value, then click outside the cell.
5 To save changes, select Edit > Save Changes. To discard unsaved changes, select Edit >

Re-retrieve Data.
You can use the dialog box's toolbar instead of the Edit menu.
When you select a different type of history, you are prompted to save unsaved changes.

Deleting open history
1 In Database Administration, select Product Admin > Current Demand > Remove Open History.
2 In the Remove Open History dialog box, select the tables from which you want to remove open

history:

• Open Monthly History table

• Open Weekly History table
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• Open Daily History table

3 Specify the data that you want to remove:

• All the data in the selected tables
• Only the data that is relating to the current selection of channel products

4 If you want to remove only certain types of history, or only history prior to a specified date, click
More, then select the types of history or specify the date.
You cannot delete particular weeks or days.

5 Click OK, then Yes to confirm.

Demand Calendars

About demand calendars
Demand calendars are one of the two kinds of calendars used by Infor Demand Planning (the other
kind is receiving calendar).

Demand calendars are used for two main purposes:

• To normalize history and forecast data to account for forecast periods of varying lengths (for example,
calendar months).

• To produce reports of historical and forecast demand in any specified period.

A demand calendar contains, for each period, the period end date and a weighting that represents that
period’s relative contribution to the total number of periods in the year.

Demand calendars are applied to Channels. You can create as many demand calendars as you need.

Types of demand calendar
Infor Demand Planning supports four types of demand calendar, characterized by their periodicities:

• Last day of calendar month

In this type of calendar, the periods are the twelve months of the year. The period end date is simply
the last day of the corresponding month.

• 12 equal periods

In this type of calendar, each year consists of twelve ~30-day periods (actually either 30 or 31 days).

• 13 equal periods

In this type of calendar, each year consists of thirteen 4-week (28-day) periods.
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• 4-4-5

In this type of calendar, each year consists of a mixture of 4-week, 5-week or 6-week periods, initially
arranged in a repeating 4 4 5 pattern. (This pattern can be edited if necessary.)

For a weekly-controlled database, only the 4-4-5 type and the 13-equal-periods type can be used.

See "About monthly- and weekly-controlled databases" on page 67.

Applying calendars to Channels
Each Channel must use one, and only one, demand calendar.

• In a weekly-controlled database, every Channel must use the same demand calendar, to ensure
that the monthly statistical forecast is consistently interpolated into weekly periods. In addition, that
calendar must have an integer number of weeks in every month.

• In a monthly-controlled database, however, different calendars can be assigned to different Channels.
For example, the calendar at a Channel that represents an international manufacturing facility may
be different from the calendars at subordinate Channels representing national distribution centers.

Changing a Channel’s demand calendar could invalidate certain dates relating to the corresponding
Channel Products (for example, effectivity and discontinuation dates, promotional events, and so on).

Editing a demand calendar
If you edit a demand calendar, this change may not be immediately apparent to other Infor Demand
Planning users because some data is cached locally. Users may have to log off from Infor Demand
Planning and then log on again to see the changed calendar.

Editing period labels
Infor Demand Planning assumes that any 12-period fiscal year runs from January to December. If this
is not the case, you need to edit the period labels used at each Channel where the calendar is applied.

About a demand calendar's default start date
The start date of a demand calendar is the first period end date.

When a calendar is created, Infor Demand Planning attempts to set a default start date so that the
calendar can cover all possible historical periods.

For every Channel, Infor Demand Planning looks at the date that demand was last updated.

• If the dates are not all the same, Infor Demand Planning chooses the earliest one (then warns you
that it has done this).

• If no Channel shows a date that demand was last updated (because, for example, the database is
empty) you are prompted to supply one.
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From this date, Infor Demand Planning counts back the permitted number of months of history that
can be retained "Monthly History Retained (Months) (St)") and chooses a suitable start date based on
the calendar’s periodicity.

By default, from this start date the calendar extends forward for 10 full years.

You can edit the start date when creating a calendar, but you cannot edit it after it has been saved.
However, you can add or remove periods at the start of the calendar, and this makes Infor Demand
Planning recalculate the start date.

Start period of a 4-4-5 calendar
For a 4-4-5 type calendar, you must also specify the period to which the start date corresponds.

By default, Infor Demand Planning suggests the period most appropriate to the start date. For example,
if the start date is 28th March, the default start period is 3, meaning that the calendar starts in the third
period of the year. This is correct if your fiscal year runs from January to December, but not if it runs
from April to March. In this latter case 28th March represents, not the third period of the year, but the
twelfth period.

Whichever period you choose, Infor Demand Planning applies the 4-4-5 week pattern from that period
onwards.

See "About demand calendars" on page 170.

About a demand calendar's period end dates
Infor Demand Planning calculates period end dates based on the type (periodicity) of the calendar and
the calendar start date.

Both the 4-4-5 type and 13 equal periods type of demand calendar have an integer number of weeks
in each period, meaning that the period end dates always fall on the same day of the week.

You can edit the period end dates of these types of calendars, provided that the dates still fall on the
same day of the week and the number of weeks in a year adds up to 52 (or 53, if you also change the
number of weeks in that year).

Editing the period end dates makes Infor Demand Planning recalculate the period weightings.

About a demand calendar's weeks-per-period
Both the 4-4-5 and 13 equal periods types of demand calendar have an integer number of weeks in
each period. Initially, the pattern over a year is:

Total13121110987654321 

52 weeks 5445445445444-4-5

52 weeks444444444444413 equal periods
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You can edit calendars of these types so that particular periods have more or fewer than the default
number of weeks, provided that the total in a year adds up to 52 (or 53, if you also change the number
of weeks in that year).

Editing the number of weeks in a period makes Infor Demand Planning recalculate the period end dates
and the period weightings.

About a demand calendar's weightings
Each period has a weighting that represents that period’s relative contribution to the total number of
periods in the year (that is, either 12 or 13 periods). The BATS calculation uses these weightings when
producing a forecast from historical data.

Initially, each period’s weighting is calculated by Infor Demand Planning according to the length of that
period, as determined by the period end dates.

You can edit these weightings for all types of demand calendar, except those with 12 equal periods.

When editing weightings, you must ensure that the total for each year is approximately 12 or 13 as
appropriate (allowing for precision errors).

Editing the weightings does not change the period end dates, but editing the period end dates makes
Infor Demand Planning recalculate the weightings (overwriting any changes you may have made).

Example
If:

Periods per year = 12

Weeks per year = 52

then:

Weighting per week = 12/52 = 0.230769

and therefore:

Weighting for a 4-week period = 0.230769 ´ 4 = 0.9231

Weighting for a 5-week period = 0.230769 ´ 5 = 1.1538

Weighting for a 6-week period = 0.230769 ´ 6 = 1.3846

Note: 

• You should rarely need to edit the weightings calculated by Infor Demand Planning.
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About monthly- and weekly-controlled databases
A database can be set up to be either monthly-controlled or weekly-controlled. The decision rests
primarily on whether you intend to adjust the statistical forecast with market intelligence on a monthly
or weekly basis.

• In a monthly-controlled database, market intelligence is stored in monthly periods, and can be
specified only in monthly amounts.

• In a weekly-controlled database, market intelligence is stored in weekly periods, although you can
specify it in either monthly or weekly amounts.

However, the decision to use a weekly-controlled database has some important consequences:

• The monthly forecast must be interpolated into weekly periods (you specify this in the System table).

• You have to apply the same demand calendar at all Channels, because otherwise the forecast
would not be interpolated in the same way at all levels.

• The type of the demand calendar must be either 4-4-5 or 13 equal periods, because there must be
an integer number of weeks in each month.

• A weekly-controlled database cannot be changed to a monthly-controlled database, orvice-versa
(at least, not easily).

In a weekly-controlled database, you can decide whether you want to store history monthly, weekly or
daily, and also, for each Channel, whether to accumulate daily or weekly demand into monthly demand
at period end. When populating the database for the first time, monthly history must be loaded because
this is required to generate the statistical model.

Summary of demand calendar editing restrictions
The features of a demand calendar that you can edit depend on its type.

Weightings?52-/53-weeks in a
year?

Number of
weeks in a peri-
od?

Period end dates?Type of calendar

EditableNot editableNot editableNot editableLast day of calendar
month

Not editableEditableNot editableNot editable12 equal periods

EditableEditableEditableEditable at weekly
intervals

13 equal periods

EditableEditableEditable
 

Editable at weekly
intervals

4-4-5
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Adding a demand calendar
1 In Database Administration, select DB Admin > Calendars > Demand Calendars.

The Demand Calendars dialog lists the existing calendars.
2 Click Add. The Demand Calendar dialog is displayed, initially showing information about the default

start date.
See "About a demand calendar's default start date" on page 171.

3 In the Name box, type a name for this calendar.
4 In the Periodicity box, select the type of calendar according to its periodicity:

• Last day of calendar month

• 12 equal periods

• 13 equal periods

• 4-4-5

5 If you select 4-4-5, the Define 445 Period End dialog is displayed. Specify the period – between 1
and 12 – to which the calendar start date relates, then click OK.

6 If you want to change the default start date, click the  button next to the Start Date box. In the
calendar, select the start date you want, then click  again to close the calendar. (If you change the
start date of a 4-4-5 calendar, the Define 445 Period End dialog is redisplayed.)

7 If applicable, select a predefined quarter profile from the Quarterly Split list box.
8 In the Demand Calendar dialog, click OK, then click Yes to save the new calendar to the database.

Infor Demand Planning assumes that any 12-period fiscal year runs from January to December. If
this is not the case, you need to edit the period labels used at each Channel where the calendar is
applied.
The Demand Calendars dialog is redisplayed, listing the new calendar and its demand calendar
code (assigned automatically by Infor Demand Planning).

Editing a demand calendar
1 In Database Administration, select DB Admin > Calendars > Demand Calendars.

The Demand Calendars dialog box is displayed.
2 Click the calendar you want to edit, then click Edit.

The Demand Calendar dialog box is displayed. The editable features of the calendar depend on its
type. See "Summary of demand calendar editing restrictions" on page 174.

3 To change the name of the calendar, type a new name in the Name box.
4 To edit period end dates, select Period end dates in the Display box. To edit a date, click its cell,

type a new value, then click outside the cell. If the new date does not fall on the same day of the
week as the old date, or if it is later than the next period end date, Infor Demand Planning does not
accept the change.
See "About a demand calendar's period end dates" on page 172.
You cannot edit a calendar’s periodicity or start date.
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5 To edit the number of weeks in a particular year, or the number of weeks in a particular month,
select Weeks in the Display box. To edit a number, click its cell, type a new number, then click
another cell (in the same row, if you want to edit more cells in that row). If the total number of weeks
in a year is not either 52 or 53, Infor Demand Planning does not accept the change.
See "About a demand calendar's weeks-per-period" on page 172.

6 To edit weightings, select Weightings in the Display box. To edit a weighting, click its cell, type a
new weighting, then click another cell (in the same row, if you want to edit more cells in that row).
If the total weighting for the year is not (approximately) the number of periods in the year, Infor
Demand Planning does not accept the change.
See "About a demand calendar's weightings" on page 173.

7 To assign a new predefined quarter profile, select one from the Quarterly Split list box.
8 Click OK, then click Yes to save the changes to the database.

The Demand Calendars dialog re-appears.

Copying a demand calendar
1 In Database Administration, select DB Admin > Calendars > Demand Calendars.

The Demand Calendars dialog box is displayed.
2 Click the calendar you want to copy, then click Copy. The Copy Demand Calendar dialog box is

displayed.
3 Type a new name for the copied calendar, then click OK.

The Demand Calendars dialog re-appears, listing the new calendar and its demand calendar code
(assigned automatically by Infor Demand Planning).

Deleting a demand calendar
1 In Database Administration, select DB Admin > Calendars > Demand Calendars.

The Demand Calendars dialog box is displayed.
2 Click the calendar you want to delete, click Delete, then click Yes to confirm.

You cannot delete a calendar that is currently applied to one or more Channels; you must apply a
different calendar to those Channels first.

Adding periods to a demand calendar
You can extend a demand calendar into the past (history) or future (forecast) by adding more periods.

1 In Database Administration, select DB Admin > Calendars > Demand Calendars.
The Demand Calendars dialog box is displayed.

2 Click the calendar you want to edit, then click Edit. The Demand Calendar dialog box is displayed.
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3 Click Add. The Add Periods dialog box is displayed.
4 Under Calendar, specify whether you want to add periods of history or forecast.

If you add history periods, Infor Demand Planning recalculates the calendar’s start date accordingly.

5 In the Periods To Add box, type or select the number of periods you want to add.
6 Click OK, then OK again to confirm.

The Demand Calendar dialog re-appears.

Removing periods from a demand calendar
1 In Database Administration, select DB Admin > Calendars > Demand Calendars.

The Demand Calendars dialog box is displayed.
2 Click the calendar you want to edit, then click Edit. The Demand Calendar dialog box is displayed.
3 Click Remove. The Remove Periods dialog box is displayed.
4 Under Calendar, specify whether you want to add periods of history or forecast.
5 In the Periods To Remove box, type or select the number of periods you want to remove.

If you remove history periods, Infor Demand Planning recalculates the calendar’s start date
accordingly.

6 Click OK, then OK again to confirm.
The Demand Calendar dialog re-appears.

Viewing weekly end dates
You can view and print a table of weekly end dates for 4-4-5 or 13 equal periods type calendars (that
is, calendars with an integer number of weeks in each period).

1 In Database Administration, select DB Admin > Calendars > Weekly Dates.
An initial Weekly Dates dialog box is displayed.

2 Click the calendar you want to view, then click OK. A second Weekly Dates dialog box is displayed,
showing the calendar’s weekly end dates.

3 To print the table to the default printer, click Print.
4 Click Cancel to close this dialog and return to the initial Weekly Dates dialog box.

Applying a demand calendar to a Channel
You apply a demand calendar to one or more Channels by editing the Channels table. In a
weekly-controlled database, all Channels must use the same demand calendar.

1 In Database Administration, select the Channels you want to edit.
See "Selecting Channels" on page 48.
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2 Select DB Admin > System > Edit Channel Data.
The Channels dialog box is displayed, showing a editable grid of Channels table fields.

3 Scroll the right-hand pane until the Demand Calendar Code column is visible.
4 Do one of the following:

• To apply a demand calendar to an individual Channel, select the required calendar in that
Channel’s Demand Calendar Code cell.

• To apply a demand calendar to all Channels, click the topmost Demand Calendar Code cell.
Select Edit > Vertical Edit. In the Vertical Edit dialog, select the required calendar and click OK.
Click Yes to confirm.

Note: You can use the Channels toolbar instead of the Edit menu.

Infor Demand Planning reminds you that changing a Channel’s demand calendar could invalidate
certain dates relating to the corresponding Channel Products (for example, effectivity and
discontinuation dates, promotional events, and so on). It may also compromise their interpolation
vectors.

Editing period labels
Infor Demand Planning assumes that the fiscal year runs from January to December. If this is not the
case, you can change this for individual Channels by editing the labels associated with each fiscal
period.

1 In Database Administration, select DB Admin > System > Period Labels.
The Maintain Channel Period Labels dialog box is displayed.

2 In the Channel ID box, select the Channel code of the Channel you want to edit.
The dialog shows an editable table of fiscal periods. You can edit the period labels shown in blue.

3 To edit a label, click its cell, type a new value, then click outside the cell.

Currencies

About currencies
In Database Administration, you can define a base currency, and then define other currencies by
specifying their exchange rates relative to the base currency.

Usually, Infor predefines the base currency to your requirements when Infor Demand Planning is
installed. You can then add other currencies as required.
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You can change the exchange rate for any currency as frequently as you wish. Each exchange rate
has an effectivity date. This means that each exchange rate is applied from its effectivity date until the
effectivity date of the subsequent rate (or indefinitely, if there is no subsequent rate).

If you apply a currency to one or more Channels, the selling price and cost price of the associated
Channel Products are assumed to be expressed in terms of that currency.

Note: 

• These currency features are not yet fully implemented. You can define currencies and apply them
to Channels, but their exchange rates are not used within Infor Demand Planning.

Adding a currency
1 In Database Administration, select DB Admin > System > Currency.

The Currency Table dialog box is displayed.
2 Select Edit > Add new Currency to Header.

A new currency row is added to the list of existing currencies in the upper panel of the dialog box.
3 Specify a unique currency code (up to three characters), and a name or description, for the new

currency. Optionally, you can also give a reason for the new currency.
4 If you do not want to specify an initial exchange rate, click OK. Otherwise, select Edit > Add new

Currency Rate to Table and click Yes when asked if you want to save the new currency before
adding the rate.
You can use the Currency Table toolbar instead of the Edit menu.
A new exchange rate row, relating to the new currency, is added to the list of existing rates in the
lower panel of the dialog box.

5 If necessary, change the effectivity date (that is, the date from which the rate will take effect). By
default, it is today’s date.

6 Specify the exchange rate, relative to the base currency.

Deleting a currency
1 In Database Administration, select DB Admin > System > Currency.

The Currency Table dialog box is displayed.
2 Click the currency you want to delete then, select Edit > Remove Currency from Header.

• You cannot delete the base currency.

• You cannot delete a currency that is applied to one or more Channels; you must first edit the
Channels table to apply a different currency.

• You can use the Currency Table toolbar instead of the Edit menu.

3 Click Yes to confirm.
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Adding an exchange rate
1 In Database Administration, select DB Admin > System > Currency.

The Currency Table dialog box is displayed.
2 Click the currency to which the new rate applies then, select Edit > Add new Currency Rate to

Table.

• You cannot specify exchange rates for the base currency, because this is the currency relative
to which all exchange rates are defined.

• You can use the Currency Table toolbar instead of the Edit menu.

A new exchange rate row, relating to the selected currency, is added to the list of existing rates in
the lower panel of the dialog box.

3 If necessary, change the effectivity date (that is, the date from which the rate will take effect.) By
default, it is today’s date.

4 Specify the exchange rate, relative to the base currency.

Deleting an exchange rate
1 In Database Administration, select DB Admin > System > Currency.

The Currency Table dialog box is displayed.
2 Click the rate you want to delete then, select Edit > Remove Currency Rate from Table.

You can use the Currency Table toolbar instead of the Edit menu.

Changing the base currency
1 In Database Administration, select DB Admin > System > System Data.

The System Data dialog box is displayed.
2 On the General Settings tab, in the Base Currency box, select the currency you want.

• Any exchange rates associated with the new base currency are deleted automatically.

• The previous base currency will not have any exchange rates relative to the new base currency;
you must add these rates manually.

Applying a currency to a Channel
By default, all Channels use the base currency. You can apply a different currency to one or more
Channels by editing the Channels table.

1  In Database Administration, select the Channels you want to edit.
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See "Selecting Channels" on page 48.

2 Select DB Admin > System > Edit Channel Data.
The Channels dialog box is displayed, showing a editable grid of Channels table fields.

3 Scroll the right-hand pane until the Currency Code column is visible.
4 Do one of the following:

• To apply a currency to an individual Channel, type the required currency code in the Channel’s
Currency Code cell.

• To apply a currency to all Channels, click the topmost Currency Code cell. Select Edit > Vertical
Edit. In the Vertical Edit dialog, type the required currency code and click OK. Click Yes to
confirm.
You can use the Channels toolbar instead of the Edit menu.

Interpolation Vectors

About the forecasting frequency

Monthly forecasting
The most appropriate periodicity for statistical forecasting is normally monthly.

Calculating statistical forecasts more frequently than this rarely brings significant benefit, for two main
reasons:

• In most business sectors, product demand has an annual seasonality, and this is most apparent
when analyzed on a monthly basis. Forecasting on a weekly or daily basis may mask this annual
seasonality.

• At period end, when the forecast should be updated, a significant amount of work may be needed
to ensure that the correct data is available. If period end processing is performed on a weekly or
daily basis, the workload is likely to be disproportionate to the benefit gained.

For these reasons, statistical forecasting within Infor Demand Planning is always done on a monthly
basis using either a 12- or 13-period forecasting year. At the end of each forecast period Infor Demand
Planning automatically updates the model to take into account any changes in the pattern of demand.
All components of the forecast are updated at this time.

However, in Infor Demand Planning monthly forecasting is completely compatible with weekly or daily
operational control. Demand can be imported monthly, weekly or daily. If daily or weekly demand is
imported, then these figures can be regularly compared to the forecast and, at period end, aggregated
to a monthly figure which is used to update the forecast. Similarly, the monthly forecast can be
interpolated into weekly and daily figures, which can be used for planning requirements and order
scheduling.
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Weekly forecasting
Although the statistical forecast is always monthly, it is possible to adjust it on a weekly basis (by adding
market intelligence) in a database that is set up as a "weekly-controlled" database.

In a weekly-controlled database, market intelligence (MI) is stored in weekly periods, although it may
be specified in either weekly or monthly amounts. (In contrast, in a monthly-controlled database MI
can be stored and specified only in monthly amounts.)

Daily forecasting
Daily forecasting can be used for order scheduling. It works by interpolating the forecast into days.
Because such daily interpolation imposes a significant computational overhead, Infor Demand Planning
does not allow you to perform daily forecasting more than two years ahead (and less is advised).

About interpolation vectors
Interpolation vectors are of two types:

• Month-to-weeks, used to derive weekly forecasts from a monthly forecast.

• Week-to-days, used to derive daily forecasts from a weekly forecast.

Note that interpolation vectors are only applied to forecast data, and never to historical data. If weekly
or daily history is required, it must be imported separately.

Each interpolation vector must be associated with a named demand calendar. The demand calendar
must be of the 4-4-5 or 13 equal periods type (because only these types have an integer number of
weeks in every month), and must be applied to at least one Channel.

See "About demand calendars" on page 170.

What’s in an interpolation vector?
An interpolation vector consists of a set of one or more default and date-specific period vectors.

• Default period vectors

The default period vectors are automatically included in every new interpolation vector. The default
vectors for a month-to-weeks interpolation vector are:

Total654321 

1.0  0.250.250.250.25Default 4 Week

1.0 0.200.200.200.200.20Default 5 Week

1.00.170.170.170.170.170.15Default 6 Week

The default vector for a week-to-days interpolation vector is:

Total7654321 
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1.00.140.140.140.140.140.140.16Default 7 Day

• Date-specific period vectors

As their name suggests, within an interpolation vector you can add your own period vectors for particular
months (in a month-to-weeks interpolation vector) or weeks (in a week-to-days interpolation vector).
For example, April (in which Easter usually falls) probably has a different demand spread than December
(in which Christmas falls).

Periods that do not have their own date-specific vectors use the appropriate default vectors instead.

A Channel Product can have only one associated interpolation vector. If a Channel Product has no
specific interpolation vector, Infor Demand Planning uses the appropriate default vectors instead.

See "Example of a month-to-weeks interpolation vector".

How are interpolation vectors defined?
There are two ways to define interpolation vectors:

• In Database Administration, you can define each interpolation vector manually and apply it to one
or more Channel Products.

See "Applying an interpolation vector to a Channel Product" on page 187.

• In Demand Forecaster, you can select a temporary forecast group (TFG) of Channel Products and
have Infor Demand Planning automatically calculate an interpolation vector for them from their
combined histories.

See "About the automatic calculation of period vectors".

If you edit an interpolation vector, this change may not be immediately apparent to other Infor Demand
Planning users because some data is cached locally. Users may have to log off from Infor Demand
Planning and then log on again to see the changed vector.

Adding a month-to-weeks interpolation vector
To add a month-to-weeks interpolation vector:

1 In Database Administration, select DB Admin > Calendars > Interpolation Vectors.
The Interpolation Vector Maintenance dialog displays the existing interpolation vectors.

2 Click Add.
The Select Demand Calendar dialog displays the demand calendars that are currently applied to
Channels. Only 4-4-5 or 13 equal periods calendars can have month-to-weeks interpolation vectors.

3 Click the calendar for which to define the vector.
4 Click OK.

The Interpolation Vector Maintenance (Add) dialog is displayed.
5 In the Interpolation Vector field, specify a name for the vector and select M to W in the adjacent

list.
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The dialog displays an editable grid containing the default 4 week, 5 week and 6 week period vectors.

Note: Do not forget to specify a name for the interpolation vector. If you save it without a name, it
cannot be named later.

6 To add a date-specific period vector, click Add.
A new vector is added to the grid with the description "New Period Vector" and a period end date.
The period end date is the first available forecast period end date after the date that demand was
last updated at the Channels that use this calendar.

Note: You cannot add a date-specific period vector if the date that the demand was last updated is
missing or invalid.

7 Click the Month End Date cell of the vector, and select the required period end date from the
available forecast period end dates in this calendar.
The number of weeks in the vector depends on the number of weeks in the selected period.

8 Click the Description cell and specify a name or description for the vector.
To delete a data-specific vector, click its row, click Delete and click Yes to confirm.

9 To add a Monthly Split, select Monthly Split. Save changes and select the required Month to Day
vector from the list. Click OK to generate the values.

10 To calculate new default vectors select Default Vectors.
This calculates new default vectors using history data of all Channel Products with this vector
assigned to them.

11 To calculate new date specific vectors select Date Specific Vectors.
This calculates new date specific vectors using history data of all Channel Products with this vector
assigned to them.

12 To remove a calculation, select Remove and select No to keep existing date-specific vectors. Or,
select Yes to delete existing date-specific vectors.

13 Repeat steps 6 to 12 as required.
14 Click OK, then Yes to confirm.

The Interpolation Vector Maintenance dialog is displayed. It includes the newly-added interpolation
vector.

Adding a week-to-days interpolation vector
To add a week-to-days interpolation vector:

1 In Database Administration, select DB Admin > Interpolation Vectors.
The Interpolation Vector Maintenance dialog displays the existing interpolation vectors.

2 Click Add.
The Select Demand Calendar dialog displays the 4-4-5 or 13 equal periods demand calendars that
are currently applied to Channels.

3 Click the calendar for which to define the vector and click OK.
The Interpolation Vector (Add) dialog is displayed.
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4 In the Interpolation Vector field, specify a name for the vector and select W to D in the adjacent
list.
The dialog displays an editable table containing the default 7-day vector.

Note: Do not forget to specify a name. If you save the interpolation vector without a name it cannot
be renamed later.

5 To add a date-specific period vector, click Add.
A new vector is added to the table of vectors with the description "New Period Vector" and a week
end date. The week end date is the first available forecast period end date after the date that demand
was last updated at the Channels that use this calendar.

Note: You cannot add a date-specific vector if the date that demand was last updated is either
missing or invalid.

6 Click the Week End Date cell of the vector and select the required week end date from the available
forecast week end dates in this calendar.

7 Click the Description cell and specify a name or description for this period vector.
8 To delete a data-specific vector, click its row, click Delete and click Yes to confirm.
9 To edit any default or date-specific vector value, click its cell, specify a new value, then click outside

the cell. The values in the vector must total 1.0.
10 To add a Monthly Split, select Monthly Split, save changes and select the required Month to Day

vector from the list. Click OK to generate the values.
11 To calculate new default vectors select Default Vectors. This will calculate new default vectors

using history data of all Channel Products with this vector assigned to them.
12 To calculate new date specific vectors select Date Specific Vectors. This calculates new date

specific vectors using history data of all Channel Products with this vector assigned to them.
13 To remove a calculation, select Remove. At the prompt, select No to keep existing date-specific

vectors or Yes to delete them.
14 Repeat steps 5 to 13 as required.
15 The Interpolation Vector Maintenance  dialog is displayed. It includes the newly-added interpolation

vector.

Editing an interpolation vector
1 In Database Administration, on the DB Admin menu, point to Calendars, then click Interpolation

Vectors.
The Interpolation Vector Maintenance dialog is displayed.

2 Click the vector to edit and click Edit.
The Interpolation Vector Maintenance (Edit) dialog displays an editable table of default and
date-specific period vectors.

3 To change the end date of a date-specific vector, click its Month End Date or Week End Date cell
(depending on the type of interpolation vector) and select the required date.

4 To edit the name of a date-specific vector, click its Description cell, type a new name, then click
outside the cell.
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5 To edit any vector value, click its cell, type a new value, then click outside the cell. The values in
the vector must total 1.0. To spread values evenly over a vector, click its row, and then click Even
Spread.

6 To add a date-specific vector, click Add and edit the period end date, name and values as required.
7 To delete a date-specific vector, click its row, click Delete, and then click Yes to confirm.
8 To add a Monthly Split, select Monthly Split, Save Changes and select the required Month to Day

vector from the list. OK will generate the values.
9 To calculate new default vectors select Default Vectors. This will calculate new default vectors

using history data of all Channel Products with this vector assigned to them.
10 To calculate new date specific vectors select Date Specific Vectors. This calculates new date

specific vectors using history data of all Channel Products with this vector assigned to them.
11 To remove a Calculation, select Remove At the prompt select No to keep any existing date specific

vectors or select Yes to delete them.
12 To delete a date-specific vector, click its row, click Delete, and then click Yes to confirm.
13 Repeat Steps 3 to 11 as required.
14 Click OK, then click Yes to confirm.

The Interpolation Vector Maintenance dialog is displayed.

Note: 

• You cannot edit the name of an interpolation vector or its type (M-to-W or W-to-D).
• You cannot rename or delete a default vector
• You must remove an existing monthly split before you can add another.

Copying an interpolation vector
To copy an interpolation vector:

1 In Database Administration, select DB Admin > Calendars > Interpolation Vectors.
The Interpolation Vector Maintenance dialog is displayed.

2 Click the vector to copy and then click Copy.
The Interpolation Vector Maintenance (Copy) dialog displays an editable table containing the default
and date-specific period vectors of the copied interpolation vector.

3 In the Interpolation Vector field, specify a name for the vector.
4 To change the end date of a date-specific vector, click its Month End Date or Week End Date cell

(depending on the type of interpolation vector) and select the required date.
5 To edit the name of a date-specific vector, click its Description cell, specify a new name, then click

outside the cell.
6 To edit any vector value, click its cell, type a new value, then click outside the cell.

The values in the vector must total 1.0. To spread values evenly over a vector, click its row, and
then click Even Spread.

7 To add a date-specific vector, click Add and edit the period end date, name and values as required.
8 To delete a date-specific vector, click its row, click Delete, and then click Yes to confirm.
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9 To add a Monthly Split, select Monthly Split > Save Changes and select the required Month to
Day vector from the list. Click OK to generate the values.

10 To calculate new default vectors select Default Vectors.
This calculates new default vectors using history data of all Channel Products with this vector
assigned to them.

11 To remove a Calculation, select Remove At the prompt select No to keep any existing date specific
vectors or select Yes to delete them.

12 Repeat steps 4 to 11 as required.
13 Click OK, then Yes to confirm.

The Interpolation Vector Maintenance dialog is redisplayed.

Note: You cannot edit the type of an interpolation vector (M-toW or W-to-D).

Note: You cannot rename or delete a default vector.

Deleting an interpolation vector
1 In Database Administration, select DB Admin > Calendars > Interpolation Vectors.

The Interpolation Vector Maintenance dialog box is displayed.
2 Click the vector you want to delete, then click Delete.

You cannot delete an interpolation vector that is currently applied to one or more Channel Products;
you must first remove the interpolation vector from those Channel Products.

3 Click Yes to confirm.

Applying an interpolation vector to a Channel Product
You apply an interpolation vector to one or more Channel Products by editing the Channel Products
table.

1 In Database Administration, select the Products and Channels you want to edit.
See "About selecting Products and Channels" on page 35.

2 Select Product Admin > Channel Products.
The Channel Products dialog box is displayed, showing a editable grid of Channel Product fields.

3 In the Report Type box, select Forecasting.
4 Scroll the right-hand pane until either the M to W Interpolation Code or W to D Interpolation Code

column is visible, as appropriate.
5 Do either of the following:

• To apply an interpolation vector to an individual Channel Product, select the required vector in
that Channel Product’s M to W Interpolation Code or W to D Interpolation Code cell.
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• To apply an interpolation vector to all Channel Products, click the first M to W Interpolation
Code or W to D Interpolation Code cell. Select Edit > Vertical Edit. In the Vertical Edit dialog,
select the required vector and click OK. Click Yes to confirm.

Note: You can use the Channel Products toolbar instead of the Edit menu.

Every interpolation vector is based on a particular demand calendar. Any interpolation vector that
you apply to a Channel Product should be based on the same demand calendar that is applied to
the Channel.

Suppliers and Supply Channels

About suppliers and supply channels
If a Channel Product is sourced from an external supplier, you must either specify a default supplier in
its "Supplier Code (CPt)" field, or else or edit particular orders to specify the supplier as the source.

When Infor Demand Planning generates a schedule of recommended orders for a CP, the orders are
always external if a "Supplier Code (CPt)" is defined, and always internal otherwise.

For this to be possible, you need first to define suppliers and supply channels, and then assign the
appropriate suppliers to the relevant Channel Products.

Suppliers
You can define as many external suppliers as you need. Each supplier is characterized by a name or
description, and a unique supplier code.

When you add suppliers manually, Infor Demand Planning generates a unique supplier code. If you
import a list of suppliers, their codes do not have to be in the format used by Infor Demand Planning.

It is possible to link information such as contact names and addresses to suppliers along with
"assortments". An assortment may be REFRIGERATED where you identify a group of items that must
be ordered together and be delivered in refrigerated trucks.

See "Adding addresses" on page 192.

See "Adding an assortment" on page 192.

See "Adding supplier assortments links" on page 193.

Supply channels
A supply channel is simply a combination of a supplier and a Channel, and provides a means of holding
information that is particular to that supplier at that Channel. Each supply channel is characterized by:

• A supplier code
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• A Channel ID

• A short textual reminder of the terms under which items are supplied. For example, COD for "cash
on delivery" or 60-days for "payment within 60 days", and so on.

• A minimum order value, expressed in the base currency, of each individual order.

The minimum order value is likely to be a negotiated figure. It does not automatically prevent a
lower-value order being recommended, but you should compare it with the total order value before
committing the order.

See "Adding orders" on page 409.

Adding a supplier
1 In Database Administration, select DB Admin > System > Suppliers > Suppliers.

The Suppliers dialog box shows the existing suppliers.
2 Select Edit > Add New Supplier.

You can use the Suppliers toolbar instead of the Edit menu.
A blank row is added to the table.

3 In the Supplier Name  field, specify the name of the supplier.
4 Select the HQ and invoice address codes.
5 If required, specify the URL of the supplier’s Web site.

A unique supplier code is automatically assigned.

Editing a supplier
You can change the name, address and Web site details of a supplier.

1 In Database Administration, select DB Admin > System > Suppliers > Suppliers.
The Suppliers dialog box shows the existing suppliers.

2 Click the cell that you want to edit, and specify a new value.

Deleting a supplier
1 In Database Administration, select DB Admin > System > Suppliers > Suppliers..

The Suppliers dialog box shows the existing suppliers.
2 Click the Supplier Name cell of the supplier that you want to delete.
3 Select Edit > Remove Supplier.

You can use the Suppliers toolbar instead of the Edit  menu.
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Adding a supply channel
1 In Database Administration, select DB Admin > System > Suppliers > Supply Channels.

The Supply Channels dialog box shows the existing supply channels.
2 Select Edit > Add Supplier Code/Channel.

You can use the Supply Channels toolbar instead of the Edit menu.
A blank row is added to the table.

3 Specify this information:

Supplier Code
Select the code of the required supplier. You cannot assign a supplier to the same channel more
than once.

Channel ID
Select the channel ID of the required channel.

Terms
Specify a short reminder of the terms on which the supplier supplies this channel.

Minimum Order Value
Specify the minimum value of any single order that is placed with the supplier at this channel.

Note: To undo unsaved changes, select Edit > Re-retrieve Data.

Editing a supply channel
1 In Database Administration, select DB Admin > System > Suppliers > Supply Channels.

The Supply Channels dialog box shows the existing supply channels.
2 Modify the characteristics of the supply channel.

You can modify all the characteristics identically to creation. See "Adding a supply channel" on page
190.

Note: To undo unsaved changes, select Edit > Re-retrieve Data.

Deleting a supply channel
1 In Database Administration, select DB Admin > System > Suppliers > Supply Channels.

The Supply Channels dialog box shows the existing supply channels.
2 Click the row that corresponds to the supply channel that you want to delete.
3 Select Edit > Remove Supplier Code/Channel.

You can use the Supply Channels toolbar instead of the Edit menu.

To undo unsaved changes, select Edit > Re-retrieve Data.
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Applying a supplier to a Channel Product
To apply a supplier to one or more channel products, edit the Channel Products table.

1 In Database Administration, select the Products and Channels entity that you want to edit.
See "About selecting Products and Channels" on page 35.

2 Select Product Admin > Channel Products.
3  In the Report Type field, select General.
4 Scroll the right-hand pane to show the Supplier Code column.
5 Perform one of these steps:

• To apply a supplier to an individual channel product, select the required supplier in the product’s
Supplier Code cell.

• To apply the same supplier to all channel products, click the first Supplier Code cell. Select Edit
> Vertical Edit. In the Vertical Edit dialog box, select the required vector and click OK. Click Yes
to confirm.

You can use the Channel Products toolbar instead of the Edit menu.

Adding a buyer group
1 In Database Administration, select DB Admin > System > Suppliers > Buyer Groups.

The Buyer Groups dialog box shows the existing buyer groups.
2 On the Buyer Groups toolbar, click Add New Buyer Group.

A blank row is added to the table.
3 Specify this information:

Buyer Groups Code
Specify the code of the buyer group.

Description
Specify the name of the buyer group.

Editing a buyer group
You can change the code and the name of a buyer group.

1 In Database Administration, select DB Admin > System > Suppliers > Buyer Groups.
The Buyer Groups dialog box shows the existing buyer groups.

2 Click the cell of the buyer group that you want to edit, and then type a new code or name.
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Deleting a buyer group
1 In Database Administration, select DB Admin > System > Suppliers > Buyer Groups.

The Buyer Groups dialog box shows the existing buyer groups.
2 Click the Buyer Groups Code cell of the buyer group that you want to delete.
3 On the floating Buyer Groups toolbar, click Remove Buyer Group.

Adding an assortment
1 In Database Administration, select DB Admin > System > Suppliers > Assortments.

The Assortments dialog box shows the existing assortments.

2 On the Assortments toolbar, click Add New Assortment.
A blank row is added to the table.

3 In the new Assortment Code cell, specify the code of the new assortment.
4 In the new Description cell, specify the name of the new assortment.

Editing an assortment
You can change the code and the name of assortments.

1 In Database Administration, select DB Admin > System > Suppliers > Assortments.
The Assortments dialog box shows the existing assortments.

2 Click the cell that you want to edit, and modify the code or name.

Deleting an assortment
1 In Database Administration, select DB Admin > System > Suppliers > Assortments.

The Assortments dialog box shows the existing assortments.
2 Click the Assortment Code cell of the buyer group that you want to delete.
3 On the Assortments toolbar, click Remove Assortments.

Adding addresses
1 In Database Administration, select DB Admin > System > Suppliers > Addresses.

The Addresses dialog box shows the existing supplier addresses.
2 On the Addresses toolbar, click Add Addresses.

A blank row is added to the table.
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3 Specify this information:

Description
Specify the name of the address.

Contact
Specify the name of the new contact.

4 Specify the other details.

A unique Addresses code is automatically assigned.

Editing addresses
You can change the name and other address-related information, but you cannot change the code.

1 In Database Administration, select DB Admin > System > Suppliers > Addresses.
The Addresses dialog box shows the existing supplier addresses.

2 To edit a cell, click the cell, specify the new value, then click outside the cell.

Deleting addresses
1 In Database Administration, select DB Admin > System > Suppliers > Addresses.

The Addresses  dialog box shows the existing addresses.
2 Select the Address Code cell of the address that you want to delete.
3 On the Addresses toolbar, click Remove Addresses.

Adding supplier assortments links
1 In Database Administration, select DB Admin > System > Suppliers > Supplier Assortments.

The Supplier Assortments dialog box shows the existing supplier assortments.
2 On the Supplier Assortments toolbar, click Add Supplier Assortments.

A blank row is added to the table.
3 Select the supplier, assortment, and buyer group codes from the lists.
4 In the new Preferred Buy Quantity cell, specify the relevant quantity.
5 Specify the other information.

Editing supplier assortments links
You can modify the content of all the displayed cells.
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1 In Database Administration, select DB Admin > System > Suppliers > Supplier Assortments.
The Supplier Assortments dialog box shows the existing supplier assortments.

2 Click the cell that you want to edit, modify the value, and click outside the cell.

Deleting supplier assortments links
1 In Database Administration, select DB Admin > System > Suppliers > Supplier Assortments.

The Supplier Assortments dialog box shows the existing supplier assortments links.
2 Click the Supplier Code cell of the supplier assortments link that you want to delete.
3 On the Supplier Assortments toolbar, click Remove Supplier Assortment.

Configuring the Supplier Select screen
You can specify which fields are displayed to specific users in the Supplier Select dialog box.

1 In Database Administration, select DB Admin > System > Supplier Select Defaults.
The Supplier Select Defaults dialog box is displayed.

2 In the User box, select the user that you want to configure.
3 In the Available fields panel, select the Display check boxes of the fields that you want to include.
4 To change the display order of the fields in the Supplier Select dialog box, use the Move buttons.
5 To apply the configuration only to the selected user, click OK. To apply the configuration to several

users, click Apply to, select the users, and click OK.

Alternative Channel Transfer Routes

About alternative Channel transfer routes
Within a matrix, stock that is sourced internally is normally supplied to a Channel from its primary
Channel.

However, there may be times when sufficient stock is not available at the primary Channel, or the stock
is needed sooner than it can usually be supplied. In such circumstances, it may be beneficial to supply
stock via an alternative transfer route. This may still be from the primary Channel, but using a faster
type of transport, or it may be from a different Channel altogether.

Database Administration allows you to define alternative transfer routes between any two Channels.
Each route is characterized by:
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• The type of transport used.

• The cost of shipping stock by that route (by volume, by weight or per item).

• The relative preference for using this route compared to other alternatives.

• The average shipping offset lead time (in days).

You can define various transport types; each type being characterized by its capacity expressed in
cubic volume, weight and number of pallets. For example:

PalletsWeight (kg)Volume (cubic meter)Transport Type

  0  20  0.25Courier

  5  500  10Train

  25  2500  32Truck

You can use the Stock Re-balancing report in the Replenishment Planner module to identify and
compare alternative transfer routes.

See "Viewing the Stock Re-balancing report" on page 434.

If the report shows an opportunity to supply stock via an alternative route, you must add or edit open
orders to carry out the transfer. Such orders must specify the source, destination, date and quantity of
the required shipment.

See "Editing individual orders" on page 410.

Note: 

• Not all stock is sourced internally; it may be procured from an external supplier.

Adding an alternative Channel transfer route
1 In Database Administration, select  DB Admin > System > Edit Alternate Channel Transfer Table.
2 Click Add.
3 Select the source Channel and the destination Channel for this route.
4 Type the name of the new route (up to 20 characters).
5 Select the code of a predefined type of transport to be used for this route.

See "Adding a transport type" on page 196.

6 Specify the preference for using this route over other alternative routes (type 1 for the most-preferred
route, 2 for the second preference, and so on).

7 Specify the offset lead time (in days).
8 Specify the costs of using this route, by weight, by volume and per item.
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Editing an alternative Channel transfer route
1 In Database Administration, select DB Admin > System > Edit Alternate Channel Transfer Table.
2 Click the route you want to edit, then click Edit.
3 You can edit any characteristic of the route except the source and destination Channels.

Deleting an alternative Channel transfer route
1 In Database Administration, select DB Admin > System > Edit Alternate Channel Transfer Table.
2 Click the route you want to delete.
3 Click Delete, then click Yes to confirm.

Adding a transport type
1 In Database Administration, select DB Admin > System > Edit Transport Types.
2 Click Add.
3 Type a description of the new transport type (up to 20 characters).
4 Type a short code to identify the transport type (up to 3 characters).
5 Specify the capacity of this transport type by cubic volume, weight and number of pallets.

The units of measurement of volume and weight depend on your Infor Demand Planning
implementation, but are typically cubic meters and kilograms.

Editing a transport type
1 In Database Administration, select DB Admin > System > Edit Transport Types.
2 Click the transport type you want to edit, then click Edit.
3 Edit the description and the capacities of this transport type as required.

You cannot edit the code of a transport type.

Deleting a transport type
1 In Database Administration, select DB Admin > System > Edit Transport Types.
2 Click the transport type you want to delete.
3 Click Delete, then click Yes to confirm.
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You cannot delete a transport type that is currently assigned to one or more alternate Channel
transfer routes. You must first edit those routes to remove the transport type.

Orders

Configuring defaults when committing orders
You can specify which fields are available to particular users when committing orders in Infor Demand
Planning Replenishment Planner and Collaborative Replenishment Planner.

1 In Database Administration, select DB Admin > System > Commit Orders Defaults.
The Commit Orders Defaults dialog box is displayed.

2  In the User box, select the user, or one of the users, you want to configure.
3 On the Received at Selected Channels tab, specify the fields you want to display for "pull" orders,

and on the Distributed at Source Channels tab, specify the fields you want to display for "push"
orders. You do this by selecting the content of each field’s Status cell.
The status of the fields can be either Off (not displayed) or Read Only (displayed but not editable)
or Editable(displayed and editable). Initially, all fields are set to Off.

4 Specify a default sort order for the fields displayed when loading orders by selecting a number to
indicate the order of the sort to be applied (1 – 5).

5 Chose whether the field is to be displayed in ascending or descending order. Select the check box
for ascending.
You can use the Move buttons to change the order in which the fields are displayed. (The top-down
order in the Commit Orders Defaults dialog represents the left-right order when committing orders.)

6 To apply these fields only to the selected user, click Apply. To apply these fields to more than one
user, click Apply to. select the users you want, then click OK.

• You are prompted to save changes for the selected user when moving from one tab to another.

• The default sort facility selected in 4 is currently only available when used with the Received at
Selected Channels option. It will only function properly if the fields included are populated correctly.

Configuring the RP Information Page
You can specify which fields are available to particular users in the RP Information Page dialog box.

1 In Database Administration, select DB Admin > System > RP Information Page Defaults.
The RP Information Page Defaults dialog box is displayed.

2 In the User box, select the user, or one of the users, you want to configure.
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3 On the Product Fields, Channel Product Fields and Order Fields tabs, select the Display check
boxes of the fields you want to include from the Products, Channel Products and Orders tables
respectively.
You can use the Move buttons to change the order in which the fields are displayed in the RP
Information Page dialog (except that Product fields always appear before Channel Product fields).

4 To apply these fields only to the selected user, click OK. To apply these fields to more than one
user, click Apply to, select the users you want, then click OK.
The fields displayed in the RP Information Page Defaults dialog are not editable.

Order Book

About the Order Book
In Replenishment Planner, it is possible to use an Order Book in conjunction with the forecast to drive
the procurement scheduling process. The Order Book is a list of customer orders in the replenishment
pipe-line to be processed at particular times in the future.

Order Book functionality is optional. It is enabled by setting the "Order Book (St)" field.

Order Book table
The information that can/must be stored for each order is:

Required/OptionalDescriptionField name

Required but read-onlySystem generated reference for the
entry.

Order Book Reference Number

RequiredSystem generated code of the re-
quired Channel Product.

Channel Product Reference
Number

RequiredCode of the customer that the order
is intended for. It must be a valid
code set up in the Customer table.

Customer Code

RequiredThe quantity of stock required by
the customer.

Good Quantity

RequiredProjected date that the stock should
be despatched to the customer.

Ship Date

OptionalDate that the customer requires
delivery of the stock.

Customer Due Date
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OptionalA user maintained field defining the
purchase order number for the or-
der.

PO Number

Required but not displayedSystem generated field to deal with
multiple user edits.

Multi-user locking number

OptionalUser-definable fields.Userstring 0-3

The required fields must be populated. The optional fields are provided to store other relevant information
to maintain more complete records.

This table may be maintained in both the Replenishment Planner and Database Administration modules.

Customers table
The Customers table is used in conjunction with the Order Book table to ensure that customers are
recognized and correctly linked to potential supply Channels. It contains the following information:

Required/OptionalDescriptionField name

RequiredSystem generated code, unique for
each Customer. Alternative codes may
be imported however.

Customer Code

RequiredCustomer name.Customer Description

OptionalUser definable fields.Userstring 0-3

This table is maintained in the Database Administration module.

Channel Product fields used
The following fields are used when calculating planning requirements using Order Book:

"Days To Use Order Book (CPt)"

"Days To Compare Order Book/Forecast (CPt)"

"Greater Period Or Cumulative (CPt)"

"Use Order Book Plus Forecast (CPt)"

"Use Comparison Or Add Forecast (CPt)"

Enabling the Order Book
1 In Database Administration, select DB Admin > System > System Data.

The System Data dialog box is displayed.
2 On the General Settings tab, select the Order Book check box.
3 Click OK.
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Adding a customer
1 In Database Administration, select Product Admin > Order Book > Customers.

The Customers dialog box is displayed, showing a table of the existing customers.
2 Select Edit > Add New Customer.

You can use the floating Customers toolbar instead of the Edit menu.
A blank row is added to the table.

3 In the new Customer Description cell, type the name of the customer.
4 Specify any other user-defined information that may be required.

Note: 

• Infor Demand Planning automatically assigns a unique customer code.
• Up to five items of user-defined information can be specified for a customer, provided that the

corresponding user-defined fields of the Customer table have been made editable.
• Instead of adding customers manually, you can use Infor Demand Planning’s automated importing

feature to import a list of customers.

Editing a customer
You can change the name and supply Channel of a customer, and any editable user-defined information
related to that customer.

1 In Database Administration, select Product Admin > Order Book > Customers.
The Customers dialog box is displayed, showing a table of the existing customers.

2 To edit any blue cell, click the cell, type or select the new value, then click outside the cell.

Deleting a customer
1 In Database Administration, select Product Admin > Order Book > Customers.

The Customers dialog box is displayed, showing a table of the existing customers.
2 Click the customer you want to delete.
3 Select Edit > Remove Customer.

Note: 

• You cannot delete a customer who is currently referenced in the order book.
• You can use the floating Customers toolbar instead of the Edit menu.
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Adding a customer order to the Order Book
1 In Database Administration, select Product Admin > Order Book > Order Book.

The Order Book dialog box is displayed, showing all existing orders in the Order Book.
2 Select Edit > Add Order. A blank row is added to the Order Book dialog box.
3 To edit any cell in the new order (other than the Order Book Ref), click the cell, type or select the

required value, then click outside the cell. Alternatively, click any cell in the order then, select Edit
> Detail to open the Order Book (Details) dialog box.
In either case, you must specify this information:

• The Channel Product reference number, or the Product code and Channel ID.
• The customer code of the customer who placed the order.
• The order’s ship date and, optionally, the date it is due at the customer.
• The good quantity.
• The purchase order number (optional).
• Any other user-defined information.

4 Select Edit > Save Changes.

Note: 

• Infor Demand Planning prompts you to add a customer if none has yet been defined.
• The content of the Order Book and the Order Book (Details) dialog boxes depends on which

fields of the Order Book table have been made active in the application defaults; unused fields
are not shown, read-only fields are grey, and in the Order Book dialog most editable fields are
blue.

• Up to five items of user-defined information can be specified for a customer order, provided that
the corresponding user-defined fields of the Order Book table have been made editable in the
application defaults.

• You can use the floating Order Book toolbar instead of the Edit menu.

Editing a customer order in the Order Book
1 In Database Administration, select Product Admin > Order Book > Order Book.
2 To edit any value in the Order Book, click its cell, type or select the new value, then click outside

the cell. Alternatively, if you want to edit several cells in a particular order, click any cell in the order
then, select Edit > Details to open the Order Book (Details) dialog box.

3 When you have finished, select Edit > Save Changes.

Deleting a customer order from the Order Book
1 In Database Administration, select Product Admin > Order Book > Order Book.
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2 Click the order you want to delete then, select Edit > Remove Order.
3 Click Yes to confirm.

Sales and Operations Planner

Configuring Sales and Operations Planner
Sales & Operations Planner (S&OP) is usually configured when the database is set up.

Note: 

• You can enable Sales Budgeting & Tracking (SBT) at the same time as enabling S&OP.
• The database’s application defaults are usually set up so that every channel product that you import

or create is automatically enabled for the S&OP and SBT functions that you have configured.
• If you reconfigure S&OP after adding channel products to the database, you must explicitly reinitialize

the S&OP database tables to add rows for these channel products.

1 Enable the required S&OP functions.
See "Enabling S&OP" on page 202.

2 Specify which S&OP plans you want.
See "Specifying which S&OP plans to store" on page 203.

3 If you include the S&OP inventory plan, you must specify on which of the selected S&OP sales
plans it is based.
See "Specifying which sales plan underlies the inventory plan" on page 203.

Enabling S&OP
1 Select DB Admin > System > System Data.

The System Data dialog box is displayed.
2 In SOP Control, select one of these values:

• Forecasting Only (SBT), to enable the Sales Budget and Tracking function.
• Full SOP, to enable full S&OP Sales, Requirements and Inventory functions.
• Full SBT and SOP, to enable all SBT and S&OP Sales, Requirements and Inventory functions.
• S&OP Sales Only, to enable S&OP Sales functions (but not S&OP Requirements or S&OP

Inventory).
• SBT & S&OP Sales Only, to enable SBT and also S&OP Sales functions.
• Weekly S&OP Sales Only, to enable weekly S&OP Sales functions.
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• SBT & Weekly S&OP Sales Only, to enable SBT and weekly S&OP Sales functions.
• Full Weekly S&OP, to enable full weekly S&OP Sales, Requirements and Inventory functions.
• SBT & Full Weekly S&OP, to enable all SBT and weekly S&OP Sales, Requirements and

Inventory functions.

Changing this setting affects the value of the S&OP Data Stored (St) field. See "S&OP Data Stored
(St)".

3 Click OK.

Specifying which S&OP plans to store
1 Select DB Admin > System > Set Up S&OP > Plans to Store.
2 Under Plans To Store in the Plans To Store dialog box, specify whether you require the following

plans:

• S&OP Sales Plan 101: Net Forecast, including Customer Forecast
• S&OP Sales Plan 102: DRP Requirements, including Dependent Demand
• S&OP Sales Plan 103: Statistical Forecast
• S&OP Sales Plan 104: Total Demand, that is, 101 + 102
• S&OP Requirements Plan 101: Requirements Orders
• S&OP Inventory Plan 101: Inventory

S&OP Requirements and Inventory plans are available as options only if full S&OP functions have
been enabled.

3 Click OK.

Specifying which sales plan underlies the inventory plan
1 Select DB Admin > System >  System Data.
2 In the Sales Plan for Inventory Calculation list in the System Data dialog box, select the sales

plan on which the inventory plan is based. Depending on which plans you have decided to store,
this can be one of the following:

• S&OP Sales Plan 101: Net Forecast, including Customer Forecast
• S&OP Sales Plan 102: DRP Requirements, including Dependent Demand
• S&OP Sales Plan 103: Statistical Forecast
• S&OP Sales Plan 104: Total Demand, that is, 101 + 102

Changing this setting affects the value of the Sales Plan For Inventory Calculation field of the
System table. See "Sales Plan For Inventory Calculation (St)".

3 Click OK.
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Enabling Channel Products for S&OP and SBT
Typically, the application defaults ensure that when new channel products are added to the database,
they are automatically enabled for all S&OP and SBT functions that have been configured. This is
achieved by configuring the application defaults so that the default initial value of Store SOP Data (CPt)
is "1". See "Store SOP Data (CPt)" and "Editing application defaults" on page 70.

However, if a channel product is not enabled, you can enable it by editing the Channel Products table.

1 In Database Administration, select the required channel products and perform these actions for the
selected channel products:
a Select the check box in the Store SOP Data cell.
b Optionally, for SBT functions, in the SOP Offset Periods cell, specify the offset, in periods,

between the SBT sales plan values and the period forecast values.
See "Editing the Channel Products table" on page 116.

2 If S&OP functions are already in use, reinitialize the S&OP tables.
This is necessary because the S&OP tables require new rows for the newly enabled channel products.
See "Reinitializing sales and Operations Planner" on page 204.

Caution: If the S&OP tables contain data that you do not want to lose, export the data before
you reinitialize S&OP, then import it again afterwards.

See "Configuring Sales and Operations Planner" on page 202  and "Configuring Sales Budgeting
&& Tracking" on page 458.

Reinitializing sales and Operations Planner
Reinitializing the S&OP database tables clears all the existing plan data and ensures that there are
rows for every channel product that has been enabled for S&OP functions. See "Enabling Channel
Products for S&OP and SBT" on page 204.

You may need to reinitialize the S&OP tables if one of these situations occur:

• After channel products have been added to the database, you have reconfigured S&OP.
• You have newly enabled some channel products for S&OP.

1 In Database Administration, select DB Admin > System > Set Up SOP > Set Up SOP.

Caution: If the S&OP tables contain data that you do not want to lose, you should export
the data before you reinitialize S&OP, then import it again.

2 Click Yes to confirm.
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Collaborate

About Collaborate
Infor Demand Planning Collaborate is a Web-based application that replicates a subset of the functionality
of the Infor Demand Planning Demand Forecaster and Infor Demand Planning Replenishment Planner
modules. It enables users to access databases via an Internet or extranet connection. Some features
of Collaborate are managed within Database Administration.

Collaborate’s data displays
Collaborate has the ability to display selected database fields to particular users. There are two pages
within Collaborate where such database fields can be displayed:

• Information

The Information page can display a wide selection of fields from the Products and Channel Products
tables.

• Schedule Worksheet

The lower part of the Schedule Worksheet page, termed the Worksheet Manager, can display up to
ten fields from the following tables:

• Products table

• Channel Products table

• Product Notes table (can contain a 255-character note for each Product)

• Collaborate Schedule Worksheet Manager CP Status table (can contain a 255-character status
description for each Channel Product)

The specific fields for each user are configured within Database Administration. Fields that are marked
as editable in the application defaults are editable within Collaborate.

See "About application defaults" on page 70.

Collaborate’s report templates
Report templates are used in Collaborate to assist in the presentation of Sales & Operations Planner,
Net Forecast Change, Schedule Summary or Demand Planning Monitor reports. Although these
templates can be created, edited and deleted individually within the Collaborate, you can delete several
at once only within Database Administration.
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Configuring Collaborate's Information page
You can specify which fields of the Products and Channel Products tables are displayed to particular
users in Collaborate’s Information page.

1 In Database Administration, select DB Admin > System > Collaborate > Collaborate Information
Page Defaults.
The Collaborate Defaults dialog box is displayed.

2 In the User box, select the user, or one of the users, you want to configure.
3 On the Product fields tab, select the Display check boxes of the Product fields you want to include,

and on the Channel Product fields tab, select the Display check boxes of the Channel Product
fields you want to include.
You can use the Move buttons to change the order in which the fields are displayed in Collaborate.

4 To apply these fields only to the selected user, click Apply. To apply these fields to more than one
user, click Apply to, select the users you want, then click OK.
You are prompted to save changes for the selected user when moving from one tab to another.

Configuring Collaborate's Schedule Worksheet page
You can specify up to ten database fields to be displayed to particular users in the Worksheet Manager
part of the Schedule Worksheet page in Infor Demand Planning Collaborative Replenishment Planner.

1 In Database Administration, select DB Admin > System > Collaborate > Collaborate Schedule
Worksheet Manager Options.
The Collaborate Schedule Worksheet Manager Options dialog box is displayed.

2 In the User box, select the user, or one of the users you want to configure.
3 Select the Display check boxes of up to ten fields.

You can use the Move buttons to change the order in which the fields are displayed in Collaborate.

4 To apply these fields only to the selected user, click Apply. To apply these fields to more than one
user, click Apply to, select the users you want, then click OK.

• You can specify a maximum of ten fields for each user.
• Fields that have been configured as editable within the application defaults can be edited in the

Schedule Worksheet page; otherwise, they are merely displayed.

Adding an initial order status
1 In Database Administration, select DB Admin > System > Initial Order Status.

The Initial Order Status dialog box shows the existing codes.
2 Select Edit > Add New Initial Order Status.

You can use the floating Initial Order Status toolbar instead of the Edit menu.
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A blank row is added to the table.
3 Type a short code to identify the initial order status (up to 2 characters).
4 Type a description of the new initial order status (up to 40 characters).

Editing an initial order status
You can change the code and name of an initial order status.

1 In Database Administration, select DB Admin > System > Initial Order Status.
The Initial Order Status dialog box shows the existing codes.

2 Click the initial order status cell you want to edit, then type a new code and/or description as required.

Deleting an initial order status
1 In Database Administration, select DB Admin > System > Initial Order Status.

The Initial Order Status dialog box shows the existing codes.
2 Click the initial order status you want to delete.
3 Select Edit > Remove Initial Order Status.

You can use the floating Initial Order Status toolbar instead of the Edit menu.

Deleting Collaborate report templates
1 In Database Administration, select DB Admin > Delete Collaborate Report Templates.

The Delete Collaborate Report Templates dialog box is displayed.

2 Select the type of report template you want to delete:

• Collaborate S&OP Report
• Collaborate Net Forecast Change Report

3 Select the report templates you want to delete. To select all the listed templates, click Select All.
4 Click Delete, then click Yes to confirm.

• Stewards can delete any public template and their own private templates. Other users can delete
only their private templates.

• If Database Administration does not allow you to delete a particular type of report template, this
may be because you are not licensed to use the Collaborate module that produces templates of
that type, or you do not have the system access privilege needed to delete templates of that
type.
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5Demand Forecaster

About Demand Forecaster
The principal uses of the Demand Forecaster (DF)module are:

• To generate and edit statistical forecast models.

• To apply market intelligence.

• To define and apply promotions.

• To report and review the accuracy of the net forecast.

Sales budgeting and tracking (SBT) reports enable you to track actual sales against the forecast and
to create and monitor sales budgets.

See "About Sales Budgeting and Tracking" on page 457.

About Bayesian theory and the Dynamic Linear Model
The Bayesian method was developed by the Reverend Thomas Bayes over 200 years ago. The essence
of Bayes is how a belief may be modified in outcome in the light of new evidence: ‘belief’ and ‘evidence’
may be based on hard facts, but they are just as likely to be based on a more subjective view. The
latter concept does not fit easily into the world of science; it does however closely resemble the real
world where the question - ‘how many packs of a new flavor of snack will we sell next month?’ cannot
be answered without subjective input.

The Dynamic Linear Model is the mathematical construct used to model a time series and incorporate
and quantify a subjective input. The advantage of the DLM is that it is a superset of the existing
techniques and has been structured to support the Bayesian concept from inception.

At a basic level, the Bayes theorem shows how the chances of an event happening are altered by the
occurrence of another event. Given a situation with hard evidence it is easy to see how this may be
applied, for example, what is the probability of picking an ace from a pack of cards, given that the 3 of
clubs, the ace of hearts and the 6 of spades have already been drawn?

However, there is another, more powerful, way of interpreting Bayes’ theorem. A belief in an initial
theory, for example, how many packs of the new flavor snack could be sold, is firstly influenced by the
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results from the last time a new flavor was launched. It is subsequently influenced by the early sales
figures as the product is rolled out. Bayes’ theorem then turns into a recipe, highlighting how the original,
"prior" belief should be updated in the light of the new evidence.

Example
Suppose a researcher is conducting an experiment in which he is aware that the results are affected
by whichever one of many existing alternatives prevails. Although he is not certain as to which one of
these alternatives will ultimately prevail, nevertheless he has some information on which he is willing
to make a subjective judgement concerning the probabilities of the alternatives. Thus he assigns
probabilities to all the alternatives before obtaining the experimental evidence.

Since these probabilities primarily affect the researcher’s judgement before an actual occurrence, they
are known as prior probabilities. Now the researcher is in a position to obtain experimental evidence
by collecting a set of data, and therefore the conditional probabilities can be computed. These
probabilities are known as posterior probabilities in the sense that they are determined after the
experimental evidence has been obtained.

See "Thomas Bayes".

About the Exception view pane
Demand Planning Exception Alerting provides management by exception logic to the Core user. Time
to plan is reduced by alerting to problem areas.

The floating Exceptions View pane is enabled. When a planner select channel product, each channel
product in the selection is checked. The enabled exceptions that are triggered by the current CP are
identified.

Exceptions are grouped by Severity. Drilling down into each severity displays the Exception Views in
that severity and the number of Channel Products in the Exception, based on the current selection.

The number of Channel Products in each severity is also displayed.

Once the Exceptions have been expanded, any Channel Product can be selected by right-clicking
selecting Select Channel Product.

After a Channel Product within an Exception has been selected, the previous grouping can be reselected
by right-clicking and selecting Reselect Group.

Channel Products can be removed from Exceptions by selecting the Channel Product, right-clicking
and selecting Delete Exception View. Alternatively, the Exception can be removed by selecting the
Exception, right-clicking and selecting Delete Exception Views. In the latter case, the Channel Products
that listed in the Exception are removed based on the current selection.

Via the Display section on the Home tab of the ribbon, the Exception pane can be set to be displayed
or not.

It can also be resized and hidden.
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Alternate Channel Matrices

Applying an alternate matrix to individual Channel Products
Once established, the Channel matrix applied to a Product can only be changed in the Database
Administration module. However, an alternative matrix may be applied to a Product on a temporary
basis for the purpose of balancing forecast changes through the alternative structure.

See "About Channel matrices" on page 78.

1 In Demand Forecaster, select the desired Product and Channel.
See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Model > Alternative Forecast Balance.
The Apply Alternate Matrix dialog box is displayed.

4 Click the required matrix in the Matrix Description panel.
5 Optionally, click Details to review the structure of the selected matrix. This includes the matrix ID,

its description, the component Channels and their behaviors. Click OK to return to the Apply Alternate
Matrix dialog box.

6 Click OK to start the process. A log is displayed in the Output pane.

Note: 

• If, having applied an alternate matrix, you want to revert to the CP's usual matrix, follow this
procedure but select the Use current matrix check box at step 4. This causes Infor Demand
Planning to balance using the matrix defined in the "Channel Matrix Code (Pt)" field. Any selection
in the Matrix Description panel is disregarded.

• To close the Output pane, select View > Output.

Applying an alternate matrix to several Channel Products
Once established, the Channel matrix applied to a Product can only be changed in the Database
Administration module. However, an alternative matrix may be applied to a group of Products on a
temporary basis for the purpose of balancing forecast changes through the alternative structure.

See "About Channel matrices" on page 78.

1 In Demand Forecaster, select the desired Channel Products.
See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Alternative Channel Matrix.
The Apply Alternate Matrix dialog box is displayed.

3 Click the required matrix in the Matrix Description panel.
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4 Optionally, click Details to review the structure of the selected matrix. This includes the matrix ID,
its description, the component Channels and their behaviors. Click OK to return to the Apply Alternate
Matrix dialog box.

5 Click OK to start the process. A log is displayed in the Output pane.

Note: 

• If, having applied an alternate matrix, you want to revert to each CP's usual matrix, follow this
procedure but select the Use current matrix check box at step 3. This causes Infor Demand
Planning to balance using the matrix defined in the "Channel Matrix Code (Pt)" field. Any selection
in the Matrix Description panel is disregarded.

• To close the Output pane, select View > Output.

The Forecast Model

About the forecast model
The principal modeling technique used is known as Bayesian Learning and the Dynamic Linear Model
(DLM). The DLM is particularly effective at forecasting product sales in changing environments, and
is quick to spot shifts in trend or seasonal patterns as well as changes in the uncertainty of forecasts.

See "About Bayesian theory and the Dynamic Linear Model" on page 209.

You can establish forecast models inside the system and manipulate as necessary until you are satisfied
that an acceptable forecast has been achieved. This manipulation can take the form of changes to
level/ growth and seasonality as well as the addition of market intelligence.

See "About market intelligence" on page 251.

Once established, a forecast is maintained at period end by the system when the actual period
performance is compared to the expected forecast.

How is seasonality calculated?
The system uses Fourier series (sine and cosine waves) to detect seasonality. A model is expressed
as containing a number of model terms. Level and growth are model terms and peaks and troughs
(seasonality) come in pairs or harmonics.

See "About seasonality calculations" on page 213.

Slow Moving Products
A special forecasting case is Slow Moving Products (SMPs). An SMP is defined as being a live item
on the database with a user defined minimum number of periods of zero or negative history within the
last year. The default value is six.
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All periods where no sales were made are ignored and a single term (level) DLM forecast, through the
periods with any demand, produced. When looking at the graph of an SMP in the Edit Forecasts Graph
window, the top forecast line (red) represents the estimate of the next demand event that will occur.
The bottom forecast line (green) is this estimate of the next event multiplied by the estimate of an event
happening, and therefore represents the best estimate of average period sales.

See "About Slow Moving Products" on page 271.

About seasonality calculations
Demand Forecaster uses Fourier Series (Sine and Cosine waves) to detect seasonality. A model is
expressed as containing a certain number of model terms. Level and growth are model terms and
peaks and troughs (seasonality) come in pairs or harmonics.

Not all pairs of model terms (harmonics) are said to be significant. Significant means that when using
that harmonic the forecast error is significantly reduced, hence better representing the adjusted demand
history.

Assuming that there is sufficient history for the system to generate a forecast, the simplest model would
contain a single model term, that is a straight line only containing a level. This would have no detectable
growth, either positive or negative.

Next would be a model with both level and growth. This model still contains a straight line but with a
gradient, two model terms. Growth is often described as a number of units increase (or decrease) per
period and is expressed either as a number or a percentage of the level.

A Fourier analysis is applied to discover any seasonality (regular variations) in the historical data. The
Fourier analysis attempts to match the data by superimposing sine and cosine waves of various
amplitudes, frequencies and phase angles.

If the model has a seasonal profile it is described by additional pairs of terms, which are the coefficients
of cosine and sine waves of increasing frequency. This pair of terms is equivalent to the amplitude and
phase angle of a sine wave, but it is easier to deal mathematically with the terms as two sinusoidal
waves that are always 90 degrees out of phase with each other. A forecast model is considered seasonal
if it has more than 2 terms in the model.

The most complex model is 13 model terms for a twelve period database (Level + Growth + 6 harmonics
but the term in the last harmonic will always be zero). In a 13 period database, the maximum number
of terms will be 14 as the condition that caused the term in the last harmonic will no longer exist.

Fitting a forecast model to individual Channel Products
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.
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3 With the Graph window selected, select Model > Fit Model.
If the calculation generates exception conditions, the Exception Views dialog box is displayed.

4 Click OK to continue.
5 Select File > Save.

Note: 

• Although this process may generate and display exceptions conditions, it will not save any
exception views to the database.

• The fields normally updated during the period end roll will not be updated if the Channel Product
has an invalid statistical model. The offending Channel Product will be include in the "INVALID
STAT" exception view.

Fitting a forecast model to several Channel Products
1 In Demand Forecaster, select the desired Products and Channels.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Generate Forecasts.
The Fit DLM dialog box is displayed.

3 On the Main tab, select the Clear market intelligence check box if you want to delete any existing
market intelligence.

4 Specify this information:

Clear future trend changes
Select this check box if you want to clear out any future changes stored against the selected Channel
Products.

Recalculate history start date
Select this check box if you want to reposition the history length marker at the first non-zero history
value.

Recalculate annual forecast
Select this check box if you want to recalculate the extra 10 years of annual figures as well as the
periods up to the forecast horizon.

Permanently remove all Independent Variables
Select this check box if you want to remove from the database all of the independent variables
applied to the selected Channel Products.

5 On the Parameters tab, select the control fields required. As these parameters are key to the
generation of a successful forecast, they should be changed only with caution and a full understanding
of their effects on the forecast.
See "About parameter sensitivity" on page 222.

6 On the Mask tab, select the mask required.
See "About history" on page 161.

7 Click OK. Any exception views created are displayed in the Output panel at the bottom of the window.
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Note: The fields normally updated during the period end roll will not be updated if the Channel
Product has an invalid statistical model. The offending Channel Product is included in the "INVALID
STAT" exception view.

Summary of the CP fields updated when fitting a model
The following Channel Products table fields are automatically updated when running Fit DLM:

"Annualised Forecast (CPt)""Annual Average Safety Stock (CPt)"

"Date Forecast Last Changed (CPt)""Current Level (CPt)"

"Discontinuation Date (CPt)""Days Cover (CPt)"

"Forecast For Next Year (CPt)""First Forecast Period (CPt)"

"Growth (CPt)""Future Change Level Or Growth (CPt)"

"Model Start Date (CPt)""Model Calculation Date (CPt)"

"Obsolescence Quantity (CPt)""Number Of Coefficients (CPt)"

"Re-order Point (CPt)""Preferred Lot Quantity (CPt)"

"Safety Stock Units (CPt)""Replenishment Period (CPt)"

"SMP Average Event (CPt)""Estimated Annual Usage (CPt)"

"Standard Deviation (CPt)""SMP Chance Of Monthly Event (CPt)"

"Theoretical Stock On Hand (CPt)""Standard Deviation Covering The Re-supply Lead Time (CPt)"

Note: 

• If "Automatically Update Successor (CPt)" is true, then the "Introduction Date (CPt)" is updated for
the successor Product to reflect any changes.

• The fields normally updated during the period end roll will not be updated if the Channel Product
has an invalid statistical model. The offending Channel Product is included in the "INVALID STAT"
exception view.

Summary of the exception views related to fitting a model
The following exception views may be created when fitting a model:

"FUT EFFECTIVITY""FUT DISCON""CAUSAL MODEL INVALID"

"INVALID SS CODE""INVALID BAYES FACTOR""FUT PROMOTION"

"NO DLM FIT""LUMPY HISTORY""INVALID TPSS CODE"

Infor Demand Planning User Guide | 215

Demand Forecaster



"NO FIT UFP""NO FIT NSP""NO FIT DEAD"

"OHS OVER SHELF""OHS OVER MAX""OBSOLESCENCE"

"PASSED EFF""PASSED DISCO""OUTLIERS"

"SMP DEMAND ZERO""SHORT HISTORY""POSSIBLE NORMAL"

"SPARSE HISTORY""SMP SIG DIFF""SMP LONG GAP"

"TREND SHIFT""TPSS LIMIT""STEP CHANGE"

About Periodic Item Forecasting
Periodic Items are those items that sell in a predictable manner, but only for a few months of the year:
sunscreen for example.

These differ from seasonal items as they have a zero forecast for a selection of certain months. These
are different to slow-moving products as the zero data points are contiguous, whereas with SMPs the
zero values are sporadic.

Periodic item forecasting can be applied in two different ways:

A periodic detection percentage, as seen in Data window Parameters, can be set which will identify
sales and non-sales periods based on their percentage of overall demand.

A stored periodic pattern can be created (see Model>Periodic pattern in Edit Forecasts) and applied
to the item.

Stored periodic pattern can also be applied as part of an Alternate Model Forecast.

Items can use a periodic detection percentage or a stored periodic pattern.

By default, periodic item forecasting is turned off.

Masking History

Masking history for individual Channel Products
Demand Forecaster allows any unrepresentative periods of history to be masked so that these periods
are ignored by the forecasting process, allowing a forecast model to be produced from the remaining
representative data. Alternatively the demand history may be edited to give a more "realistic" pattern
of demand.

1 In Demand Forecaster, select the desired Product and Channel.
See "About selecting Products and Channels" on page 35.
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2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 In the Graph window, do one of the following:

• Right-click a single history period, then click Mask out history on the shortcut menu.
• Click and drag horizontally across a range of history periods (identified by a yellow bar along the

x-axis). Right-click the selected periods, then click Mask out history on the shortcut menu.

4 Click Yes to confirm the correct period or periods are selected.
The masked periods are identified by  symbols over the data points.

5 Select Model > Fit Model to recalculate the model, ignoring the masked periods.

Note: 

• To remove a mask, select one or more periods as before, then right-click the periods, click
Remove mask on the shortcut menu, and click Yes to confirm.

• To make it easier to select individual periods, select Tools > Zoom in.

Masking history for several Channel Products
Demand Forecaster allows any unrepresentative periods of history to be masked so that these periods
are ignored by the forecasting process, allowing a forecast model to be produced from the remaining
representative data. Alternatively the history may be edited using the adjusted demand history option
to give a more "realistic" pattern of demand.

1 In Demand Forecaster, select the desired Products and Channels.
See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Generate Forecasts.
The Fit DLM dialog box is displayed.

3 Select the Masks tab.
4 Click the periods to mask and type "1" in the cells to mask for this run of Fit DLM. The mask applied

will also be saved against all the Channel Products processed so that you can use it in the future.
5 Select the Mask Type you want to use.
6 Click OK to start the model fitting process.

See "About the forecast model" on page 212.
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Forecasting Periodicity

About forecasting periodicity
The periodicity of the forecast is an area of flexibility within the Demand Forecaster and Collaborative
Demand Forecaster modules. Statistical forecast calculations are always made at monthly intervals.
This frequency offers the most advantageous combination of stability and responsiveness. However,
control may be exercised at more frequent intervals. The system is able to record sales demand at
weekly or monthly intervals. If sales are recorded weekly, then these values may be regularly compared
to forecast and, at the period end, aggregated to a monthly figure and used to generate a further
forecast. The monthly forecast generated by the system may be interpolated to weekly figures for
comparison and control purposes. In order to utilize this functionality it is necessary to establish the
database with this in mind.

A database may be established which will maintain a forecast at a weekly level. This facility is initially
controlled by "Level Of Forecast Control (St)". There are several options to consider when a weekly
forecasting option is selected.

Under a weekly-controlled database, the statistical forecast is always monthly. This is then interpolated
to weekly periods. Market intelligence (MI) can be added to this forecast figure in either weekly or
monthly time periods. In a monthly-controlled database MI can only be entered and stored in monthly
periods.

If a weekly-controlled database is set to allow daily market intelligence ("Allow Daily MI (St)" is true)
and valid values exists in the "Daily Forecast Horizon In Weeks (St)" and "Weekly Forecast Horizon
(St)" fields, you can add, view and manipulate daily market intelligence in the Table page of Collaborative
Demand Forecaster. The daily option is not available when using temporary forecast groups, however.

Calendars
For a weekly-controlled database, the demand calendar must be an integer number of weeks per period
and the same calendar must be used for every Channel.

Interpolation vectors
Interpolation vectors are used to express a monthly forecast in weekly buckets and a weekly forecast
in days. These vectors only apply to the forecast, and are never applied to historical information, as
monthly history is never interpolated into weeks. If weekly history is required, it must be loaded
separately. Interpolation vectors are stored as a period end date and a value. This means that they
are not rolled at month end, and therefore, must periodically be extended manually.

Interpolation vectors may be assembled manually in the Database Administration module. Additionally,
the facility exists within the Demand Forecaster module to assemble interpolation vectors automatically
from historical data.

See "About interpolation vectors" on page 182.
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History
Weekly history is not a requirement for a weekly-controlled database. The weekly data is only used to
accumulate to monthly data at month end, and for information purposes, such as, analysing the pattern
of sales throughout the month. For the initial database population, monthly history must be loaded due
to the fact that this data is required to generate the statistical model. If there is no weekly history, then
the Edit Forecasts option, when displaying weekly data (and other reporting tools), will display only
forecast information.

Period end processing
At period end there are three fields that can potentially be used:

• "Accumulate Daily History To Weeks (Ct)"
• "Accumulate Weekly History To Months (Ct)"
• "Accumulate Daily History To Months (Ct)"

These fields are only relevant at period end, where they are used to control the potential aggregation
of daily history to weeks and/or months, and the aggregation of weekly history to months. These table
fields are not used in any of the interactive forecast editing/reporting tools.

Sales, Demand, and/or Adjusted Demand history is posted firstly to the Import Raw Sales table and
then moved to the Open Daily, Open Weekly, and Open Monthly tables. This transfer will utilize the
above fields in the following way. A Channel Product is rejected if:

• Weekly data is being imported and "Accumulate Daily History To Weeks (Ct)" is true.
• Monthly data is being imported and "Accumulate Weekly History To Months (Ct)" is true.
• Monthly data is being imported and "Accumulate Daily History To Months (Ct)" is true.

Databases
There are three types of weekly-controlled database that may be encountered:

Set upDatabase Required

"Accumulate Weekly History To Months (Ct)"= 1Store weekly and
monthly history, no accu-
mulation from weeks to
months at period end.

"Accumulate Weekly History To Months (Ct)"= 0Store weekly and
monthly history, accumu-
late from weeks to
months at period end.

"Weekly History Retained (Weeks) (St)" = 0Store monthly history
only.

See "About monthly- and weekly-controlled databases" on page 67.

Infor Demand Planning User Guide | 219

Demand Forecaster



System table fields
• "Weekly Forecast Interpolation (St)":If "Level Of Forecast Control (St)" is set to weekly, using this

switch will allow a forecast to be interpolated into weeks. This allows the population of the weekly
net forecast table and allows the forecast display and reporting tools to operate on weekly information.

• "Weekly History Retained (Weeks) (St)":controls the number of weeks of history to be shown in the
Edit Forecasts windows. It is subject to a maximum of 212 weeks. If this field is zero, then no weekly
history will exist on the database.

Note: If "Level Of Forecast Control (St)" is set to 1 (weekly), "Weekly Forecast Interpolation (St)" must
also be set to 1 (true).

Discount Factors

About discount factors
Discount factors, also known as smoothing rates, are parameters that are used in the BATS forecasting
calculations. They determine how much weight or emphasis the calculations put on recent data.

See "About Bayesian theory and the Dynamic Linear Model" on page 209.

Each discount factor can have a value of between 0 and 1. A value of 1 represents a static model in
which all data points are given equal weight; a value closer to 0 gives more weight to recent data.

In order to consistently apply these discount factors to a range of Channel Products, you can define
sets of factors in the Database Administration module. You can then apply a particular set to selected
Channel Products by editing the "Discount Factor Code (CPt)" field.

Each set comprises eight discount factors; four standard factors and four matching intervention factors:

Intervention factorsStandard factors

Intervention Trend Rapid discount factor which will
be applied to revise the trend elements of the

Trend Discount factor to be applied to the trend
elements of the forecast (level and growth) when

forecast (level and growth). It should typically be
set lower than the standard discount factor.

the forecast is created, or revised at period end.
The default value of 1 represents a static model.

Intervention Seasonal Rapid discount factor to be
applied to revise the seasonal coefficients of the

Seasonal Discount factor to be applied to the
seasonal model coefficients when the forecast is

forecast. It should typically be set lower than the
standard discount factor.

created, or revised at period end. The default value
of 1 represents a static model.

Intervention Variance Rapid discount factor which
will be applied to revise the variance estimate of

Variance Discount factor to be applied to the vari-
ance when the forecast is created, or revised at

the forecast. It should typically be set lower than
the standard discount factor.

period end. The default value of 1 represents a
static model.
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Intervention Regression Rapid discount factor
which will be applied to independent variables used
in causal modeling during the DLM process.

Regression Discount factor to be applied to the
independent variables used in causal modeling
during the dynamic linear modeling (DLM) process.

Intervention factors can be applied in two circumstances:

• If the item has a tracking signal. The intervention factors are applied between the detected step
change and the point at which the tracking signal is issued. The maximum number of periods used
to detect tracking signals is defined by the "Run Length Limit (St)" field, and thus that field acts as
a maximum limit to the number of periods to be used along with this rapid discount factor to revise
the forecast.

• If the corresponding threshold is broken. "Scale Inflation Factor (St)" stores a factor, which is used
to develop an alternative model to monitor the increase in the estimate of variance. This comparison
of the two models provides a Bayes factor which is compared to the value held in the "Scale Inflation
Threshold (St)" field, thus providing a tracking signal for items where there is believed to be a
significant change in the variance over a period of months.

Default sets of discount factors
Infor Demand Planning comes with (at least) two default sets of discount factors:

• Default static settings ("Discount Factor Code (CPt)" = 0)

These are the default factors for Normal Products.

1.0Intervention Trend1.0Trend

1.0Intervention Seasonal1.0Seasonal

1.0Intervention Variance1.0Variance

1.0Intervention Regression1.0Regression

• Default SMP settings ("Discount Factor Code (CPt)" = 1)

These are the default factors for Slow Moving Products.

1.0Intervention Trend0.6Trend

1.0Intervention Seasonal1.0Seasonal

1.0Intervention Variance0.6Variance

1.0Intervention Regression1.0Regression

These sets of discount factors can be automatically applied when a model is fitted to a Channel Product
in the Demand Forecaster module, if the process detects that the status of the item has changed. If an
SMP is changed to a Normal product, its "Discount Factor Code (CPt)" is set to 0; conversely, if a
Normal Product is changed to an SMP, its "Discount Factor Code (CPt)" is set to 1.
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Parameter Sensitivity

About parameter sensitivity
Manipulating the statistical models in order to get the best statistical forecasts possible requires an
understanding of the parameters involved:

Monitoring parameters

Sensible ValuesTableParameter Field

1 <= 100SystemScale Inflation

0 < 1SystemScale Inflation Threshold

1 <= 100Channel ProductLevel Inflation Factor

0 < 1Channel ProductLevel Inflation Threshold

1 < 10SystemRun Length Limit

These parameters are used to control the sensitivity of the forecast monitoring. Monitoring refers to
checking for outliers, tracking signals and step-changes. The two parameters referring to the scale
inflation operate together, and the two parameters referring to the level operate together.

To increase the sensitivity of the monitoring, decrease the factor and/or increase the threshold. This
means that more outliers and tracking signals are likely to be flagged. To decrease the sensitivity of
the monitoring increase the factor and/or decrease the threshold.

Model selection parameters

Sensible ValuesTableParameter Field

1,2,4,6,8,10,12, or 14Channel ProductMaximum No. Of Model Terms

0, 90, 95, 97.5, 99, 99.5Channel ProductConfidence % For Seasonality

0 < 10SystemLumpy History Threshold

The form that the model takes can be manipulated through the "Maximum Model Terms (CPt)" and the
"Confidence For Seasonality (CPt)" fields. The maximum number of model terms values correspond
to the maximum number of coefficients that are allowed in the model prior to significance testing on
seasonal terms.

The level of the harmonic significance test is determined by the "Confidence For Seasonality (CPt)"
field. To prevent any harmonic selection occurring, set this value to 0 (there is no test for significance).
The higher this value the more significant a harmonic needs to be for selection, that is the higher the
value, the less likely a given harmonic is to be selected.
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To make the lumpy data test less sensitive, that is less likely to flag a data set as lumpy, increase the
value of the "Lumpy History Threshold (St)" field.

Model sensitivity parameters

Sensible ValuesTableParameter Field

0<=1Discount FactorTrend Discount Factor

0<=1Discount FactorSeasonal Discount Factor

0<=1Discount FactorVariance Discount Factor

0<=1Discount FactorRegression Discount Factor

0<=1Discount FactorIntervention Trend Discount Factor

0<=1Discount FactorIntervention Seasonal Discount Factor

0<=1Discount FactorIntervention Variance Discount Factor

0<=1Discount FactorIntervention Regression Discount Factor

These parameters deal with the dynamic/weighting aspect of the statistical model fit. This refers to the
amount of weighting given to each data point. For static models, that is making all data points equally
weighted, make the discount factors 1. To increase the dynamic aspect, that is put more weight on
more recent data, the discount factors should tend to, but not be set at, zero.

The routine discount factors, that is the ones without interventionin the name, should generally be set
near to 1 for less dynamic behavior. The intervention discount factors are only used in certain monitoring
situations where the model needs to learn quickly about a potential model change and should certainly
be set lower than the routine discount factor.

Multiplicative seasonality
The default value for this code is 0 which denotes Additive seasonality. It can be changed to Level
Modulated type multiplicative seasonality by changing the code to 1. Codes 2 and 3 are reserved for
future development.

Slow moving products (SMP) specific parameters

Sensible ValuesTableParameter Field

0<=1SystemSMP Discount Factor

The chance of an event calculation performed for SMPs is a dynamic calculation using the forecasting
algorithms. It uses a one-term model and has been given its own specific discount factor. The "SMP
Discount Factor (St)" is defaulted to be 0.8 and is effectively the equivalent of the trend discount factor.
This default is significantly more dynamic than for normal items.

Growth damping parameters

Sensible ValuesTableParameter Field
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0< 1.2 (any higher value
causes exponential
growth).

Channel ProductGrowth Damping Factor

0 <= 100 (this relates di-
rectly to the factor).

Ad-hoc in the Growth
Damping Factor dia-
log

Growth Damping Percentage

No restrictions.Ad-hoc in the Growth
Damping Factor dia-
log

Growth Damping Level

Growth damping growth
and existing model growth
must be the same sign.

Ad-hoc in the Growth
Damping Factor dia-
log

Growth Damping Growth

Within the forecast hori-
zon.

Channel ProductGrowth Damping Start Date

Within the forecast hori-
zon.

Channel ProductGrowth Damping End Date

The Growth damping factor of the forecast can be manipulated in the Edit Forecasts screens. The
factor is applied to the model growth value for the duration of the damping period so a factor less than
1 will reduce the model growth whereas a value greater than 1 will increase the growth and a value of
1 will not change the model growth.

Editing History, Forecast and MI

About forecast editing
The Edit Forecasts option in Demand Forecaster provides a safe environment where you can
experimentally adjust history and forecast data, the statistical model and market intelligence for selected
Channel Products, with an instantaneous graphical display of the results. The changes you make within
a session do not affect the underlying database unless or until you decide to save them.

Five windows become available:

• The graph (Graph window).
• The history and forecast in two spreadsheet-like grids (Table window).
• The history and forecast in a Fiscal Year format in a grid (Fiscal Year window).
• Various fields from the database (Data window).
• A general information and legend window, which is not editable (Information window).

Any changes you make to the data in one window is automatically reflected in the other windows. All
windows need not be open at once and closing one window does not close the others. Changes you
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make to any Channel Product must be saved before the last window is closed. There are buttons on
the toolbar that either open any of the windows that have been closed, or position that window on top.
If the window has not been closed, you can select it from the Window menu.

There is one toolbar which controls all of the four windows which appears directly below the main
toolbar but can be moved by clicking and dragging on any blank (no buttons) area. Buttons may be
active or greyed out depending on the window currently in use.

You may open more than one set of windows at any one time. A different Channel Product selection
may be chosen in each set of windows. To avoid confusion, the title bars of all windows in the set
display the current item details (Product code, description, Channel code, and Channel name).

About negative forecasts
A forecast for any Channel Product may or may not be allowed to go negative according to the setting
of the field "Allow Negative Forecasts (CPt)".

Whether or not a negative forecast is a sensible concept depends upon the nature of the business. A
negative forecast may, for example, indicate seasonal returns.

If a negative forecast is not allowed for a Channel Product then any forecast that would otherwise be
a negative quantity is displayed and reported as zero. In this case the aggregation of such a forecast
either to a higher Channel or within a temporary or permanent forecast group is handled in the following
manner:

Example 1 - Allow negative forecast

Net ForecastMarket IntelligenceStatistical Forecast 

3000300CP 1

-20-10080CP 2

280-100380Aggregated CP

Example 2 - Do not allow negative forecast

Net ForecastMarket IntelligenceStatistical Forecast 

3000300CP 1

0-10080CP 2

300-80380Aggregated CP

The aggregated market intelligence in example 1 (allow negative forecast) is -100 whilst in example 2
(do not allow negative forecast) is -80. This is because the -20 net forecast for CP2 in example 1 is
treated as zero.
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If market intelligence is added at the aggregated level (higher Channel, TFG or PFG) which results in
a negative forecast at that level, the net forecast may be displayed as the negative figure or as zero
according to the setting of the field "Allow Negative Forecasts (CPt)" at that Channel Product level.

About forecast uncertainty
The principal forecasting technique used within the Demand Forecaster module is the Dynamic Linear
Model (DLM). Because of its "dynamic nature", the DLM is particularly effective at forecasting Product
sales in changing environments, and is quick to spot shifts in trend or seasonal patterns as well as
changes in the uncertainty of forecasts.

In order to manage this uncertainty, the system compares the calculated forecast to the actual sales
demand at each period end. By means of tracking signals, the variability is monitored and intervention
discount factors substituted for routine discount factors as required in order to increase the rate at
which the system learns about a new trend.

See "About parameter sensitivity" on page 222.

When using the following techniques, a different mechanism is used to deal with the uncertainty involved
in the creation of the new forecast.

"Applying an alternate model forecast" on page 244  Applying an alternate model forecast

"Applying future changes (level)" on page 241  Applying future changes to level

"Applying future changes (growth)" on page 241  Applying future changes to growth

"Applying an alternate forecast" on page 243  Applying an alternate forecast

To help the model learn more quickly following the application of a new technique, the component
variances of the BATS statistical model will be inflated. The inflation is carried out using the factor
defined in "Variance Inflation Factor (St)".

The operation of this factor is such thata value greater than one will cause the model to ‘learn’ more
quickly, whilst a value less than one will cause it to ‘learn’ less quickly. In the case of Future
Changes(only to level or growth) the component variances will be inflated for the changed component
(level or growth) from the time of that change forward. With the other changes, the variances are inflated
throughout the forecast horizon. The system will automatically reduce or inflate these variances
depending on the long term accuracy of the new forecast.

About the buttons and icons used in Edit Forecast
The following icons and buttons are displayed in the Graph Window. Other windows within Edit Forecasts
display a reduced number of icons according to the functionality within the selected window.

If this icon is displayed, a control Channel has been selected. This is a Channel at which
forecast changes may be made without the risk of being subsequently overwritten by the
effects of Channel balancing.

Control
Channel
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If this icon is displayed, a non-control Channel has been selected. This is a Channel at
which forecast changes may be subsequently overwritten by the effects of Channel bal-
ancing.

Non Con-
trol Chan-
nel

Save changes.Save

Print the Graph, Fiscal Year, and Table windows.Print

Move to first Product from list box.First

Move to previous Product from list box.Previous

Move to next Product from list box.Next

Move to last Product from list box.Last

Zoom in - enlarge a section of the graph area.Zoom In

Zoom out - reduce a section of the graph area.Zoom Out

Fit model.Fit Model

Add/edit a future level or growth change.Future
Change

Add/edit the growth damping factor.Growth
Damping
Factor

Add/remove/move an effectivity date.Effectivity
Date

Add/remove/move a discontinuation date.Discontin-
uation
Date

Change weighting.Promo-
tional
Event
Weight

Display the Edit Forecast - Fiscal Year window.Fiscal
Year Win-
dow

Display the Edit Forecast - Graph window.Graph
Window

Display the Edit Forecast - Table window.Table
Window

Display the Edit Forecast - Data window.Data Win-
dow
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Changing multiplicative seasonality
When the initial forecast model is fitted, the system will automatically apply additive seasonality, however,
there is an option to apply multiplicative seasonality if required.

Multiplicative seasonality can be described as a seasonal peak to trough difference (amplitude) increasing
or decreasing through time in proportion to the underlying level of demand. This differs from additive
seasonality where the peak to trough difference is constant.

1 In Demand Forecaster, select the desired Product and Channel.
See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Model > Multiplicative seasonality.
The Multiplicative Seasonality dialog box is displayed.

4 Choose one of the two types of multiplicative seasonality currently available (Linear Expansion and
Exponential Expansion are not available in this release):

• Additive allows the model to be returned to the default setting of additive if a multiplicative option
has been previously imposed.

• Level Modulated the peak to trough difference changes depending on the underlying level of the
model. For example, if the level goes down, the peak to trough difference will go down, and vice
versa.

5 Click Test to apply the changes to the graph without exiting the dialog (this provides the opportunity
to view the change and make corrections if required).

6 Click OK to apply the change.
7 Select File > Save.

Editing forecasting data fields
It is possible to change certain forecast data fields for the selected Channel Products. Some fields,
however, contain sensitive calculation factors and, although editable, changing these without a clear
understanding of their function may cause unexpected alterations to forecast and safety stock
calculations.

1 In Demand Forecaster, select the desired Product and Channel.
See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Click the Data window.
4 Select the tab required:

• Base
• Supercession
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• SMP
• Parameters
• Forecast
• Inventory
• Chan Prod Info (displayed if custom Channel Product fields have been defined)
• Product Info (displayed if custom Product fields have been defined)

The data presented are fields from various tables, which affect the forecast or inventory levels.
Editable fields have a white edit box alongside the field description.

5 Edit the appropriate fields.
6 Select File > Save.

Note: 

• When Channel Products are grouped (using the Group check box), the Data window only displays
three tabs, Base, Forecast and Parameters. The other tabs contain data inapplicable to
Temporary Forecast Groups and are therefore not displayed.

• When displaying information for scenario items, an extra tab will appear, labeled Scenarios.

Refreshing the forecast
Changes made to the forecast during the current Edit Forecasts session may be canceled.

Select Model > Refresh  and click Yes, or click the Refresh icon on the Edit Forecasts toolbar
and click Yes.
This restores the model to the original position, i.e. up to the last save.

Edit Forecast windows

The Graph Window

About the Graph window

The Graph window is one of the windows within the Edit Forecasts function. It displays a graphical
representation of the history and forecast for a Channel Product. It has many features that you can
use to view and manipulate the history and forecast.

The Graph window has three modes of operation, which you can access by double-clicking the left
mouse button to cycle through the options. The modes are:

• Basic mode. No handles drawn on any periods or the trend line.
• Edit individual periods mode. Handles drawn on each history and forecast period.
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• Edit trend line mode handles drawn at each end of the trend line (SMPs only have the first handle
to allow level to be edited because there is no growth for these items).

Although the display is set by default to display a monthly periodicity, a weekly selection may be
available depending upon the setting in "Level Of Forecast Control (St)".

There is a vertical grid line for every quarter year, which may be hidden. All displayed graph lines
including the now line are defined within the Plot Options dialog (select Tools and Options).

The title of the graph window contains the Product code and description and the Channel code and
description. The selections in the Product and Channel list boxes on the main toolbar reflect the items
that are displayed in the Edit Forecasts windows.

If the Control Channel icon is displayed, a control Channel has been selected. This is a Channel at
which forecast changes may be made without the risk of being subsequently overwritten by the effects
of Channel balancing.

If the Non Control Channel icon is displayed, a non-control Channel has been selected. This is a
Channel at which forecast changes may be subsequently overwritten by the effects of Channel balancing.

See "About balancing" on page 245.

The label for the y-axis defaults to units/month. The x-axis, by default, displays monthly period end
dates. If a weekly display is possible and selected (from Tools, Display, Weekly), the y-axis is labeled
by default units/week and the x-axis displays specified weekend dates. If a different weighting is selected
in either case, the y-axis displays items per month or week as selected.

If selected in the Options box, outliers are marked on the graph by a black circle around the particular
data point on the graph after running Fit Model. Periods of history that have been masked out are
shown by a black circle and a black cross through the data point.

Optionally, the presence of Forecast, History and MI notes can be flagged in the Graph window. It is
also possible to see the notes via tool tip tabs in the Fiscal Year window.

The Information box displays the legend for the graph. Above the legend is the information section,
which contains history length, outlook, rolling 12 months forecast, current level, growth, standard
deviation and the number of outliers in the history used to fit the model.

See "About the Information box" on page 236.

Status Bar
The status bar of the application frame displays extra pieces of information when a Graph window is
open and the net forecast is being manipulated, that is which period(s) are currently selected and cursor
tracking (the period that the mouse is currently over and the value of adjusted demand or net forecast
at that period).

Scrolling
The Graph window has both a vertical and a horizontal scroll bar. These scroll bars scroll the graph
area of the window only.
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Scaling
The scaling of the Y-axis may be changed. Both the minimum and maximum values of the Y-axis can
be specified. The scale of the Y-axis is also changed if the user chooses to zoom the graph in or out.
The scale of the Y-axis is specified in the Plot Options dialog (select Tools and Options).

Zooming
Choose the range of periods to display on the graph. Choosing a smaller range of periods has the
effect of ‘zooming in’ and choosing a larger range of periods has the effect of ‘zooming out’. Use the
Zoom In and Zoom Out buttons on the toolbar.

Generating a model
To generate a model using existing criteria, click Fit model on the toolbar or select Model and Fit
model from the main menu.

See "About the forecast model" on page 212.

Note: When the Weekly option is selected, some features described above are not available.

Periodicity
By default the periodicity displayed is monthly. Provided that the database has been appropriately
established, weekly data may be displayed. This is selected through the main menu options Tools and
Display. Click the required periodicity.

See "About forecasting periodicity" on page 218.

If "Level Of Forecast Control (St)" is set to monthly but with the weekly forecast interpolation set to
Yes, the data may not be edited. If, however, the setting is weekly, editing is possible by adding/editing
market intelligence in weekly or monthly buckets.

See "About market intelligence" on page 251.

See "About Notes" on page 257.

See "About the buttons and icons used in Edit Forecast" on page 226.

Editing history in the Graph window

You can edit history in Edit Forecasts mode but only Adjusted Demand. Changes to the adjusted
demand are allowed for group items (both permanent forecast groups and ad hoc groups), however,
these changes are not spread down to the members of the group.

1 In Demand Forecaster, select the desired Product and Channel..
See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
3 In the Graph window, either:

• Double-click to display rectangles on each data point and click and drag one data point to the
required position
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• Click and hold down the left mouse button over the first history period in a range and drag across
to the last history period in the range then release the button. A yellow strip is highlighted along
the x-axis to show which periods are selected. Click and drag the selection to the new position.

4 Select File > Save.

Note: 

• History changes will not be saved at an aggregate Channel
• History changes made to a temporary forecast group is not saved
• History changes made to a permanent forecast group item will be saved
• If Monthly/Weekly History Synchronisation is set in the System table, upon save, any monthly

history edits will be synchronized to the weeks in that month based on their previous values. Any
weekly history edits are synchronized to the corresponding month(s)

• If Weekly/Daily History Synchronisation is set in the System table, upon save, any weekly history
edits are synchronized to the days in that week(s)

Changing what is displayed in the Graph window

You can change what and how data is displayed in the Graph window in Edit Forecasts.

1 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

2 Select Tools > Options.
The Plot Options dialog box is displayed.

3 Select the tab required:

• Graph
• Line Settings
• Display
• General

4 Make the appropriate changes and click OK.

The Fiscal Year Window

About the Fiscal Year window

The Fiscal Year window is a window of the Edit Forecasts function.

The Fiscal Year window allows the history, forecast, and any time-phased weightings to be edited from
within a spreadsheet-type environment. Budgets may be selected for viewing only; they may not be
edited. Select from the central list box to change the display.

The presentation is laid out to cover at least 5 fiscal years. By default, the grid contains six columns (5
years) but if there is more than 3 years of history or 2 years of forecast stored, you can scroll back and
forward in the grid to display the required period.
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Columns to the left of the Now line contain history. The history displayed is, by default, Adjusted Demand.
You can display all types of history (by choosing the history type in the list box in the Edit Forecasts
toolbar) but only the Adjusted Demand history is editable. Double-clicking on the historical period you
wish to amend allows the existing number to be typed over.

If Monthly/Weekly History Synchronisation is set in the System table, upon save, any monthly history
edits are synchronized to the weeks in that month based on their previous values. Any weekly history
edits will be synchronized to the corresponding month(s).

If Weekly/Daily History Synchronisation is set in the System table, upon save, any weekly history edits
are synchronized to the days in that week(s).

Rows contain either months or weeks according to the selection made in Tools, Display. In the case
of the sales/forecast display, total and outlook rows are also displayed. In the Budget display, a total
row is included. Outliers are displayed with a red background and masked out periods are displayed
with a black background.

The forecast displayed is the total of the forecast elements that have been chosen from the Options
dialog box. You may edit the market intelligence but not the statistical forecast.

See "About market intelligence" on page 251.

It is possible to add Forecast, History and MI notes in the Fiscal Year window. They can be displayed
via tool tip tabs.

See "About Notes" on page 257.

You can use the Fiscal Year window to apply effectivity and discontinuation dates and any time-phased
weightings defined on the database may be edited.

See "About effectivity and discontinuation dates" on page 247 and "About time-phased weightings" on
page 108.

Predefined budgets may be displayed but not edited.

See "Viewing budgets in the Fiscal Year window" on page 234.

User data series can be displayed and edited.

See "About User Data series" on page 340.

Editing TPWs in the Fiscal Year window

1 In Demand Forecaster, select the desired Product and Channel.
See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Click the Fiscal Year window.
4 Select TPW Edit from the central list box on the toolbar.

The Select TPW dialog box is displayed.
5 Select the required TPW from the list box.
6 Click OK.
7 Click the appropriate cell, type the new value and press ENTER (all cells are editable).
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8 Select File > Save.

Viewing budgets in the Fiscal Year window

1 In Demand Forecaster, select the desired Product and Channel.
See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Click the Fiscal Year window.
4 Select Budget from the central list box on the toolbar.

The Select Budget Type dialog box is displayed.
5 Select the budget type to view and click OK.

Note: 

• You cannot edit budget data in this window.

• This screen is not available when viewing a returns item (Product type 3).

Editing history in the Fiscal Year window

In Edit Forecasts mode, you can edit only adjusted demand history. Any changes you make to a
permanent forecast group or a temporary forecast group are not be spread to the members of the
group.

1 In Demand Forecaster, select the desired Product and Channel.
See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Click the Fiscal Year window.
4 Select Adjusted Demand from the central list box on the toolbar.
5 Click the appropriate cell, type the new value and press ENTER (all cells are editable).
6 Select File > Save.

Note: 

• Any changes made to the adjusted demand in this way is automatically reflected in both the Graph
window and the Table window.

• If Monthly/Weekly History Synchronisation is set in the System table, upon save, any monthly
history edits will be synchronized to the weeks in that month based on their previous values. Any
weekly history edits are synchronized to the corresponding month(s)

• If Weekly/Daily History Synchronisation is set in the System table, upon save, any weekly history
edits are synchronized to the days in that week(s)
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The Table Window

About the Table window

The Table window is a window of the Edit Forecasts function.

The Table window contains two spreadsheet type displays, one for history and one for forecast. From
within this window, you can edit the adjusted demand, add market intelligence, edit customer forecasts
and add effectivity or discontinuation dates. Any other information displayed in the window is not
editable.

History table
To display the history details, click the list box on the Edit Forecasts toolbar and select History.

The table then contains the following rows:

• Adjusted Demand
• Demand
• Sales
• Weighting

By default, the table displays six columns of history on the screen but you are able to scroll through
the entire history as required. The adjusted demand row (if it is displayed) is the only row that you can
edit. Outliers are displayed with a red background and masked out periods are displayed with a black
background.

See "About history" on page 161.

Forecast table
To display the forecast details, click on the list box on the Edit Forecasts toolbar and select Forecast.

The table then contains the following rows by default:

• Net
• Statistical
• Market intelligence
• Customer Forecast
• Demand to date
• Weighting

As in the history table, the forecast table displays six columns by default but you can use the scroll
controls to view through the forecast horizon.

See "About market intelligence" on page 251 and "About customer forecasts" on page 260.

Any User Data Series that are assigned to the user will also be displayed in both Forecast and History
views.

See "About User Data series" on page 340.
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Forecast and History Notes
These can be added in the Table window.

See "About Notes" on page 257.

The Data Window

About the Data window

The Data window is a window of the Edit Forecasts function. It contains information relating to the
Channel Product being viewed, some of which is editable.

The Data window has these tabs:

• Base
• Supercession
• SMP
• Parameters
• Forecast
• Inventory
• Demand Sensing
• Chan Prod Info (if Channel Product custom fields have been defined)
• Product Info (if Product custom fields have been defined)
• Scenarios (if this is a Scenarios product)

The data presented are fields from various database tables, which affect the forecast or inventory
levels.

Note:  When Channel Products are grouped using the Group check box before Edit Forecasts is
selected, the Data window displays only three tabs, Base, Forecast and Parameters.

Some fields contain sensitive calculation factors. Although editable, changing these without a clear
understanding of their function may cause unexpected alterations to forecast and safety stock
calculations.

The Information Box

About the Information box

The Information box is one of the windows within the Edit Forecasts function. It displays general
information about the current Channel Product forecast and legends for the Graph, Fiscal Year and
Table windows.

If the control Channel icon is displayed, the selected Channel Product is one at which forecast changes
may be made without the risk of being subsequently overwritten by the effects of Channel Balancing.
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If the non-control Channel icon is displayed, the selected Channel Product is one at which forecast
changes may be subsequently overwritten by the effects of Channel Balancing.

If the Partial Control icon is displayed, the selected Channel Product is one at which forecast changes
can be made but are not necessarily overwritten, but the Channel Product is not a full control channel
either.

Items listed in the Information box are:

• Pds of history used for model fit. The number of history periods used to calculate the forecast. Set
in the History Length dialog (from the main menu, select Edit > History Length).

• Outlook. The sum of the history to the current month in this fiscal year and the net forecast for the
rest of the year.

• Rolling 12 months. The sum of the forecast periods for the next 12 months from "now".

• Level. The current model level, that is the point on the Y-axis at which level & trend line cuts the
now line.

• Growth. Displayed for standard items only. It is the period-by-period increase or decrease in the
forecasted demand.

• Standard Deviation. The current estimate of the average variability between the forecast model and
the demand for the item at the period in time. This is initialized with the creation of the original model
and then revised during each period end process.

• Re-order point. Calculated as part of the inventory routines. This item is only displayed for slow
moving Products (SMPs). To view a normal item’s re-order point, see the Data window, Inventory
tab.

• SMP Average Event. Only displayed for SMP items and will hold the value returned from the BATS
routines for the estimate of demand in any month that has a sales event.

• SMP Chance of monthly event. Only displayed for SMP items and will hold an estimate of the chance
of getting an event in any month.

• Number of Outliers. The number of outliers detected by the model fitting process. Outliers are
statistically unrepresentative periods of historical data which have been ignored in the forecast
calculation. They are identified during model fitting according to threshold settings in the Channel
Products table.

• Weighting. The weighting currently in use to display the history and forecast data.

• Legend (Graph). Established in the Plot Options dialog (select Tools and Options).

• Legend (Scenarios). Included if the current item has associated Scenario Products.

• Legend (Table & Fiscal Year). The legends for the Table and Fiscal Year windows.

Note: 

• All the decimal fields are shown to four decimal places.
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Editing History

Editing the history length
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Do one of the following:

• Click the history length arrow  displayed on the x-axis, and drag to the desired period of history.
This is then used as the first period of history from which to fit the model.

• Select Edit > History lengthOn the . In the History Length dialog enter either a number of periods
of history, or the date of the first period of history to use for the model fitting process.

4 Click OK.
5 Click Yes to refit the model.
6 Select File > Save.

Applying alternate history
This feature enables you to take an established Channel Product's history and donate it to another
Channel Product. It is often used in cases of Product succession.

To apply an alternate history:

1 In Demand Forecaster, select both the donor and the recipient Channel Products.
See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.
To give Product B the history of Product A, display Product B in the Graph window.

3 Select Model > Alternate History.
The Alternate History dialog box is displayed.

4 On the Selection tab, choose the history to be given to Product B (Product A's history profile) by
clicking the appropriate Product and Channel in the list boxes.
The history profile is displayed if the Display Profile check box is ticked.

5 On the Detail tab, select a level of demand for the new item, if expected to be different to the donor
item. Either over-type the Level edit box or specify a Factor by which to multiply the donor's history
level.

6 Select the history type(s) to donate.
7 Select Add to existing history if you want to add the history of the donor Product to the history of

the receiving Product, rather than overwriting it.
8 Click OK.
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9 Select File > Save.

Note: Click Test to apply the alternative history to the current Product without closing the dialog box.
You can view the changes and additional editing may be carried out, if required, before confirming the
new history.
Note: When using the Add to existing history option, if the Test button is clicked and then the OK
button, the history for the currently selected source item will be transferred twice. If the Test button is
used to apply the history then the Close button should be used to close the dialog, not the OK button.
Remember to then save the changed history to the database.
Note:  If Monthly/Weekly History Synchronization is set in the System table, when saved, any monthly
history edits are synchronized to the weeks in that month based on their previous values. Any weekly
history edits will be synchronized to the corresponding month(s)
Note:  · If Weekly/Daily History Synchronization is set in the System table, upon save, any weekly
history edits are synchronized to the days in that week(s)

Level and Growth

Editing the level
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 In the Graph window, do one of the following:

• Select Edit > Level or right-click anywhere in the forecast area of the graph and click Edit level.
Enter a new value in the Edit Level dialog and click OK.

• Double-click twice on the graph and a blue level and growth line appears with handles at either
end. Drag and drop the left-hand handle to the desired value.

4 Select File > Save.

Editing the growth
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 In the Graph window, do one of the following:

• Select Edit > Growth or right-click anywhere in the forecast area of the graph and click Edit
growth. Enter a new value in the Edit Growth dialog and click OK.
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• Double-click twice on the graph and a blue level and growth line appears with handles at either
end. Drag and drop the right-hand handle to the desired value.

4 Select File > Save.

Applying a growth damping factor
A growth damping factor may be used to level off or increase the growth rate in the future. It can be
applied to the model growth value for the duration of the damping period, so a factor less than 1 will
reduce the model growth whereas a value greater than 1 will increase the growth. A value of 1 (the
default) will not change the model growth. The factor must be within a range 0 to 1.2.

1 In Demand Forecaster, select the desired Product and Channel.
See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Edit > Growth Damping Factor.
The Growth Damping Factor dialog box is displayed.

4 Select the date on which the growth damping will start from the Start date list box.
5 Either select the date on which the growth damping will end or select the number of periods during

which the growth damping is to be applied.
6 Use the option buttons to select the type of growth damping to be applied and type the value required

in the adjacent edit box.
7 Select the Zero growth beyond end date check box if you want the system to level off the forecast

after the end date. If the box is not ticked then the growth rate at the end of the damping period will
continue into the future as the database rolls forward.

8 Click OK to file the change.
9 Click Yes if you wish to refit the model.
10 Select File > Save.

Future Changes

About future changes
A future change is a change to the level or growth of an item that takes effect on a specified date in
the future. For example, you might define future changes to take account of the opening of new stores,
competitors ceasing to trade, or predicted changes in buying patterns.

Future changes can be specified only for Normal Products that already have a statistical model.
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Example
Consider the case where a new customer agrees to take the product at some known point in the future.
You believe that overall sales will increase, and you can estimate this quantity. This number is highly
subjective, but an examination of what happened in similar circumstances in the past combined with
a view of current market conditions can provide a good estimate.

The variance attached to the new level is increased by a factor that is typically higher than the existing
model, as a phase of increased uncertainty is being entered. This makes the model learn more quickly
at the time the change is expected.

Applying future changes (level)
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Edit > Future Changes.
The Future Changes dialog box is displayed.

4 On the Level tab, in the Date of Change box, select the period from which the change is to be
applied.

5 Enter the Future Value for the level, either as an absolute value or a percentage increase.
6 Edit the default Description as required.
7 Click Test to apply the changes to the graph without exiting the dialog (this provides the opportunity

to view the change and make corrections if required).
8 Click OK to file the future change.
9 Click Yes if you wish to refit the model.

See "About future changes" on page 240.

Applying future changes (growth)
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Edit > Future Changes.
The Future Changes dialog box is displayed.

4 On the Growth tab, in the Date of Change box, select the period from which the change is to be
applied.

5 Enter the Future Value for the growth, either as an absolute value or a percentage increase.
6  Edit the default Description as required.
7 Click Test to apply the changes to the graph without exiting the dialog (this provides the opportunity

to view the change and make corrections if required).
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8 Click OK to file the future change.
9 Click Yes if you wish to refit the model.
10 Select File > Save.

See "About future changes" on page 240.

Viewing/removing future changes
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Edit > Future Changes.
The Future Changes dialog box is displayed.

4 Select the View/Remove tab.
5 Select the date required from the Date of Change list.
6 Click Remove to delete the displayed future change data or click Remove All to delete all future

change data against the selected Channel Product.
7 Click OK to file the change.
8 Click Yes if you wish to refit the model.
9 Select File > Save.

See "About future changes" on page 240.

Annual Forecasts

About the annual forecast
A facility exists within the Demand Forecaster module to generate and edit an annual forecast for the
displayed Channel Product. This is a net forecast and is therefore inclusive of all MI and other forecast
additions and adjustments. It will be calculated and displayed in years to the forecast horizon specified
in the field, "Annual Forecast Horizon (St)". This horizon is subject to a 10 year maximum and may be
set in the Database Administration module using the System Table Data option.

The feature is accessed from the Edit Forecasts windows, menu option, Model, Annual Forecast,
Generate, or Edit. Provided that at least one year of annual forecast horizon has been specified in the
system table field identified above, when the feature is first used only the Generate option will be
available. When this option is selected the forecast will be generated, the menu list closed and control
returned to the main screen.
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Generating the annual forecast
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Model > Annual forecast > Generate.

Note: To view the generated forecast, select Model > Annual forecast > Edit.

See "About the annual forecast" on page 242.
The forecast is generated, the menu list closed and control returned to the Edit forecasts main
screen.

Editing the annual forecast
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Model > Annual forecast > Edit.
The Annual Forecasts - Forecast Edit screen is displayed.

4 Use the Units, TPW and Actual tabs to edit as desired.
If the annual forecast has not been generated for the selected Channel Product, this option is not
available.
See "About the annual forecast" on page 242.

Alternate Forecasts

Applying an alternate forecast
This feature enables you to take an established Channel Product’s forecast model and donate it to
another Channel Product. This is usually used when introducing a new Product without history, but it
is known that this new Product will have a similar seasonal pattern to an existing Product.

1 In Demand Forecaster, select both the donor and the recipient Channel Products.
See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Model > Alternate forecast.
The Alternate Forecast dialog box is displayed.
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4  On the Selection tab, choose the forecast model to be given to Product B (Product A’s profile) by
clicking on the appropriate Product and Channel in the list boxes. The forecast profile is displayed
if the Display Profile check box is ticked.

5 On the Detail tab, select a level of demand for the new item, if expected to be different to the donor
item. Either over-type the Level edit box or type a Factor to be used to multiply the donor’s forecast
by.

6 Select a level of growth for the new item if expected to be different to the donor item. Either over-type
the Growth edit box or type a Factor to be used to multiply the donor’s forecast by.

7 Type an anticipated Standard Deviation or select an existing Variance Estimate from the list.
See "About variance estimates" on page 299.

8 Click Test to apply the alternative forecast model to the current Product without closing the dialog
box. You can view the changes and additional editing carried out if required before confirming the
new forecast.

9 Click OK.
10 Select File > Save.

Applying an alternate model forecast
This feature enables you to create a statistical model for a Channel Product using market intelligence
from within the Edit Forecasts Graph window.

1 In Demand Forecaster, select both the donor and the recipient Channel Products.
See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Modules > Demand Forecasting > Alternate model forecast.
If effectivity or discontinuation dates are in place, a warning is displayed. Click OK to continue.
The Alternate Model Forecast dialog box is displayed and, in the Edit Forecasts windows, the forecast
is zeroed. All the current model information, for example, model coefficients, growth damping, future
changes, market intelligence etc. are held in memory and cleared from the Graph window. If the
item is a slow moving Product, it is set to normal. The Edit Values option should be selected by
default.

4 Do one of the following:

• Select the Edit Values option and type values for each period to define the seasonal profile. The
values entered are used to calculate a level and growth. This seasonal pattern is then repeated
over the monthly forecast horizon using the previously calculated level and growth to calculate
the forecast up to the forecast horizon.

• Select the Edit Level/Growth option if you wish to change the level and growth of the forecast.
If this option is checked, the previously entered seasonal profile is lost. A warning message
appears to indicate this.

5 Select the Effectivity Date i.e. the date from which the alternative model forecast is effective.
6 Select a Variance Estimate from the list.
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7 Select the Retain initial net forecast check box if you want to keep the original net forecast. If the
original net forecast is saved, the difference between the new model created and the original net
forecast is saved as I-type market intelligence.

8 Click Test to view the alternate model forecast in the forecast windows.
9 Click OK if you are happy with the forecast created.

Warnings are displayed that the original model is lost and, if applicable, that the chosen effectivity
date has been set up.

10 Click OK.
11 Select File > Save.

Note: 

• This functionality is only available if variance estimates have been defined.

• This functionality is not available when Weekly is selected in the Display option on the Tools
menu.

Balancing

About balancing
Balancing through a Channel matrix is the process where changes at a Channel are passed through
the sequence of linked Channels. The controls for this procedure are contained within the Channel
behaviors, which hold information relating to individual Channels. They permit or deny history, forecast
or requirements data to be passed to or accepted from other Channels in the matrix.

See "About Channel behaviors" on page 72.

The sum of the statistical forecasts at the lower levels is not always equal the statistical forecast of the
total level; market intelligence is added to balance the forecasts in these instances. This will be in
addition to any market intelligence you have added to change the forecast.

Channels that pass data to other Channels are known as control Channels. Data that passes from a
control Channel to a non-control Channel may overwrite any changes previously made to that non-control
Channel.

Release 6.5 sees the introduction of partial control channels, enabling the user to create market
intelligence at multiple levels in the channel matrix.

Changes made to the forecast in Edit Forecasts may be overwritten by the balancing process, which
occurs automatically when saving to the database. Such changes may therefore be lost when the data
is saved. During the saving process, warnings will be issued which indicate the revisions being made
by balancing.

Balancing may be forced through an alternative matrix in order to transfer an edited change though a
series of Channels that may differ from those in the prescribed Products Channel matrix.

See "Applying a Channel matrix to Products" on page 82.
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Within Edit Forecasts, Balance may be selected and executed from the menu option Model. This option
may not be available if balancing will not cause any change to the displayed Channel Product, for
example, at a control Channel.

Any changes made to the level, growth, step changes, discontinuation dates and so on at a control
Channel will be reflected at other Channels that accept the forecast being passed to them from that
control Channel, however, all changes are seen as C-type market intelligence at the non control
Channels.

Channel Product fields automatically updated by this process are as follows:

• "Safety Stock Units (CPt)"
• "Preferred Lot Quantity (CPt)" or "Replenishment Period (CPt)"
• "Re-order Point (CPt)"
• "Theoretical Stock On Hand (CPt)"
• "First Forecast Period (CPt)"
• "Forecast For Next Year (CPt)"

Note: These fields will not be updated if the forecast is unchanged.

Examples of Channel balancing:
• Bottom Up Structure the forecast is changed at the lowest level and the system aggregates to the

top level.
• Top Down Structure the forecast is changed at the top level and the system spreads to the lower

levels.
• Centre Out Structure the forecast is changed at a middle level (of 3 or more) and the forecast is

overridden at the higher and lower levels.

About Offline Channel Balancing
Offline Channel Balancing provides an option for Channel Balancing to occur in a non-user-interactive
model, improving planner productivity for large scale problems or complex Channel Structures.

Offline balancing is done at a product level. The Offline Balance setting in the Products table determines
whether balancing occurs interactively or offline.

If the offline value is selected, during edits to a Channel Product, the Channel Product is flagged as
requiring balancing and the balancing is performed in the background. Consequently, during the
balancing, the forecast at aggregated or pro-rated channels may be displayed incorrectly.

The application server must be running and the server host and application server Port number must
be added to the user who is performing and saving the edits. The Server host and Server Port details
are added to a user via Maintain Users in Database Administration.

If the offline balancing flag is set for a product, the application server is running and linked to the user
currently logged in, then upon save balancing is performed offline and the offline balancing log is
generated.
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If the application server is not running or the user's port and host information is incorrect, offline balancing
is be run and the products are flagged as having dirty data. These products are displayed as Pending
Balancing in the Edit Graph and the Grid screens in Core.

Once the application server is running or the user's port and host information has been correctly updated
after saving, the edited products whose dirty data flag is set are no longer flagged as having dirty data.
The display is refreshed in the Edit Graph and Edit Grid screens.

For temporary forecast groups, the offline balancing flag must be set for all the products in the group
so that offline balancing can be performed. If only some products in the temporary forecast group are
set to use offline balancing, offline balancing is be performed and balancing is performed from within
Demand Forecaster.

The same rule applies to edits made in the Edit Grid to a grouping where only some products in the
group are set to Offline Balance.

When edits are saved in the Edit Graph and the Edit Grid in Demand Forecaster and in the Demand
Forecaster section of Collaborate, balancing is performed.

Balancing the forecast
Changes made in Edit Forecasts mode may be subject to being overwritten by the balancing process
that occurs automatically when saving to the database. The potential effects of such changes to the
item being edited may be checked prior to saving.

Select Model > Balance.
See "About balancing" on page 245.

Effectivity and Discontinuation Dates

About effectivity and discontinuation dates
Effectivity and discontinuation dates can be applied and edited in the Graph, Fiscal Year and Table
windows. (This feature is not available when the weekly view option is selected.)

The effectivity date is the date at which the Channel Product’s forecast begins. Usually, the forecast
begins "now", but you might want a future effectivity date if, for example, the Channel Product is replacing
another Channel Product that is being phased out. Prior to the effectivity date, the statistical forecast
is zero.

See "Applying an effectivity date" on page 248.

The discontinuation date is the date past which no more demand is anticipated. Typically, this is because
the Channel Product is to be phased out by that date. After the discontinuation date, the statistical
forecast is zero.

See "Applying a discontinuation date" on page 249.
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Infor Demand Planning can automatically calculate a discontinuation date if required. This feature can
be accessed from within either the Demand Forecaster or Replenishment Planner module.

See "About the automatic calculation of discontinuation dates" on page 248.

Note: Effectivity dates are sometimes referred to as "introduction dates".

About the automatic calculation of discontinuation dates
This function may be accessed from within either the Demand Forecaster or Replenishment Planner
modules. It will attempt to calculate the projected stock run out date on each of the currently-selected
Channel Products. If successful, the system will then place the preceding month end date to this
calculated run out date as the date in the "Discontinuation Date (CPt)" field. Discontinuation datesare
used in the Replenishment Planner module to plan future orders.

The automatic calculation of the discontinuation date uses the current forecast stored in the net forecast
table and any current RP plans stored on the database. The on-hand stock at each Channel is consumed
by the monthly net forecast held in the net forecast table where the Channel is not aggregating
requirements from a lower Channel. If a Channel is aggregating requirements, the consumption of
stock is based on the RP orders from the lower Channels.

The opening stock at each Channel is based on the values in the fields "Opening Stock (CPt)" and
"Due In Stock (CPt)", as well as the good quantities of open orders due in and planned for shipment.
Specifically, any order with a "Ship Date (Ot)" in the past (stock posting date or earlier)has been assumed
to have been picked and so the quantity is not included in the reported on-hand stock. Where the "Ship
Date (Ot)" is later than the stock posting date the assumption is that the orders have not been picked
and so the on-hand stock will therefore be decreased by the order in the calculations.

If the "Update Successor Effectivity Date (CPt)" field is set to 1 for the predecessor, the effectivity date
of the successor is automatically set equal to the newly calculated discontinuation date of the
predecessor.

The following fields are checked by the system for each selected Channel Product:

Setting required for the automatic calculation of discon-
tinuation dates

Field

Must be code 0: Live."Product Status (Pt)"

Must not be code 2: Not UFP."Product Type (Pt)"

Must be codes 3 or 4: Automatic codes."Discontinuation Type (CPt)"

Must be codes 0 or 1: Not a BOM subordinate."BOM Level Code (CPt)"

Applying an effectivity date
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
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The five Edit Forecasts windows are displayed.
3 Select Model > Effectivity.

The Period End Dates dialog box is displayed.
4 Select the period in which you want to add the effectivity date.
5 Click OK.
6 Select File > Save.

Note: If an effectivity date exists, the Launch Date dialog box is displayed, giving you the options
to remove or move the existing effectivity date.

Moving an effectivity date
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Model > Effectivity or right-click in the forecast area of the Graph window and click Move
effectivity date on the shortcut menu.
The Period End Dates dialog box is displayed.

4 Select the period in which you want to move the effectivity date to.
5 Click OK.
6 Select File > Save.

Deleting an effectivity date
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Model > Effectivity > Remove effectivity date or right-click in the forecast area of the Graph
window and click Drop Effectivity Date on the shortcut menu.

4 Click OK or Yes.
5 Select File > Save.

Applying a discontinuation date
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.
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3 Select Model > Discontinue.
The Period End Dates dialog box is displayed.

4 Select the period in which you want to add the discontinuation date.
5 Click OK.
6 Select File > Save.

Note: If a discontinuation date exists, the Launch Date dialog box is displayed, giving you the options
to remove or move the existing discontinuation date.

Moving a discontinuation date
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Model > Discontinue or right-click in the forecast area of the Graph window and click Move
Discontinuation Date on the shortcut menu.
The Period End Dates dialog box is displayed.

4 Select the period in which you want to move the discontinuation date to.
5 Click OK.
6 Select File > Save.

Deleting a discontinuation date
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Model > Discontinue > Remove discontinuation date or right-click in the forecast area of
the Graph window and click Drop Discontinuation Date on the shortcut menu.

4 Click OK or Yes.
5 Select File > Save.

Calculating discontinuation dates
1  In Demand Forecaster, select the desired Products and Channels.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Discontinuation Dates.
The Automatic Calculation of Discontinuation Dates dialog box is displayed.

3 Select the Remove MI check box if you want to drop all market intelligence (except T-type MI) after
the calculated discontinuation date.
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4 Select the Align existing Pre/Suc dates check box if you want to automatically set the effectivity
date of the successor equal to the newly calculated discontinuation date of the current (predecessor)
item.
These dates will always be aligned when the "Update Successor Effectivity Date (CPt)" field for the
predecessor is set to 1 (true), irrespective of this selection.

5 Click OK.
On completion, the output screen is displayed providing details of the calculations completed and
any restraints encountered.
Exception Views
The process may generate these exception views:

• "BOM SUB AUTO DISC"
• "FUT EFF AUTO DISC"
• "POT OBS AUTO DISC"
• "RETURNS AUTO DISC"

Market Intelligence

About market intelligence
The generic term "market intelligence" (MI) is used to describe any short term changes that you may
make to a statistical forecast, whether it be the result of sales and marketing activity or external factors
such as legislation, competitive activity or economic conditions.

MI is treated differently in monthly-controlled and weekly-controlled databases. In a monthly-controlled
database, MI can be specified and stored only in monthly amounts. In a weekly-controlled database,
MI can be specified in either monthly or weekly amounts but is always be stored in weekly amounts.

Each time MI is input or calculated by the system, it is allocated a MI type code. Certain types of MI
also gain an identifier (name and description). The name is an internally generated code, whilst the
description is supplied by the user. The identifier allows you to select the specific MI to be changed,
moved or deleted.

Types of market intelligence
• I -type: Individual item has been manually input against an individual Channel Product. This MI type

requires an identifier (text description) to be defined in order to enable it to be selected and deleted,
changed or moved in time.

• S-type: Spread from Groups is created by spreading the forecast from a group of items, temporary
forecast groups (TFGs) or permanent forecast groups (PFGs), down to the individual members of
the group.

• C-type: Channel is created as a result of forcing the net forecast down through the Channel structure.
It is automatically allocated the identifier "Balance".
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• A-type: Aggregated is created by aggregating the MI only, up through the Channel structure. It is
automatically allocated the identifier "Balance".

• N-type: Net Freeze refers to MI created by period end routines to ensure that the defined net forecast
remains the same.

• E-type: External refers to any changes made to the forecast in the Offline Forecast Workbench or
any other imported changes to the forecast.

• T-type: Transferred is market intelligence transferred from associated Products within the Promotions
function.

• B-type: Baseline has been manually input against an individual Channel product. This MI type
requires an identifier (text description) to be defined in order to enable it to be selected and deleted,
changed or moved in time.

Market intelligence categories
Market intelligence of types I, B and T require an MI Category to be assigned to them.

Market intelligence categories enable users to expand on the MI type, with different market intelligence
events able to have the same MI Type, but different categories, depending on their significance.

Each MI Type (I, B and T) will have a default MI Category, but additional categories and the default of
these can be set up and assigned from within Database Administration.

Note: 
The "Level Of Forecast Control (St)" field determines whether the database is monthly- or
weekly-controlled.

Adding market intelligence in the Graph window

Adding MI to a single point

To add MI to a single point:

1 Use the Product and Channel list boxes to select the required Channel Product from among the
currently selected items.

2 In the Graph window, double-click the left mouse button in the graph area to display rectangles on
each data point.

3 Click the data point of the period to be changed and drag to the desired position.
This information relating to the change is displayed at the bottom of the window:

• 1 period selected: Periods you have selected and the date involved
• MI Offset: Value of the market intelligence you have added
• Total Net: Sum of the statistical forecast and the market intelligence which you have added
• Total MI Offset: The sum of all market intelligence added if more than one value of market

intelligence has been added for this period.

The MI details dialog box shows the change (I-type MI) you have made.
4 Make any changes required.
5 Select a different MI category if the category required differs from the default.
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6 Annotate the Notes pane if required.
7 Select Display this note on Edit Graph screen if you want to indicate that a note exists by flagging

it in the Edit Graph window.
8 Select File > Save.

Adding MI to a range of points

To add MI to a range of points:

1 Use the Product and Channel list boxes to select the required Channel Product from among the
currently selected items.

2 Drag to select the range of periods.
A yellow strip is highlighted along the x-axis to show which periods are selected.

3 Click anywhere within the selected range and drag up or down to the required position.
The MI details dialog box is displayed.

4 Make any changes required.
5 Select a different MI category if the required category differs from the default.
6 Annotate the Notes pane if required.
7 Select Display this note on Edit Graph screen if you want to indicate that a note exists by flagging

it in the Edit Graph window.
8 Select File > Save.

See "Specifying market intelligence adding options" on page 256.
Note: If a range of forecast periods are edited, the market intelligence at each period in the range is
given the same identifier.
Note: Depending on the switches set in the Options dialog, the MI is added as new MI, extend existing
MI, or you are prompted to decide the action to take. If it is Add New Market Intelligence, a dialog box
prompts you for a description. If you choose to Add To Existing Market Intelligence and the MI is being
entered into a period in which there is existing MI, you are presented with a list of the existing MI.
Decide which event to edit.

Adding S-type market intelligence
1 In Demand Forecaster, select the required Products and Channels.

See "About selecting Products and Channels" on page 35.
2 Click the Group tick box in the toolbar of the main screen.
3 Select Modules > Demand Forecasting > Edit Forecasts.

The five Edit Forecasts windows are displayed.
4 Make the desired forecast changes to the Group item as you would a normal Channel Product.

See "About forecast editing" on page 224.

5 Click to save the changes.
The Spread dialog box is displayed.

6 On the Spread tab, specify the forecast components to spread, the method to be used to calculate
the spreading ratios and the periods to spread. Type a market intelligence description if required.
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7 On the Exclude tab, select the Channel Products to be excluded from the spread and the exclusion
option to use.

8 Click OK.
9 Select File > Save.

Moving market intelligence

Moving market intelligence in the Graph window

1 Use the Product and Channel list boxes to select the required Channel Product from among the
currently selected items.

2 In the Graph window, right-click the data point of the period containing the MI to be moved and
select Move Market Intelligence.
The Period End Dates dialog box is displayed.

3 Click to highlight and select the period to move the MI to.
4 Click OK.
5 Select File > Save.

Moving market intelligence in the Fiscal Year window

1 Use the Product and Channel list boxes to select the required Channel Product from among the
currently selected items.

2 In the Fiscal Year window, click the cell containing the MI to be moved.
3 Right-click the selected cell and click Move Market Intelligence.

The Period End Dates dialog box is displayed.
4 Click to select the period to move the MI to.
5 Click OK.
6 Select File > Save.

Moving market intelligence in the Table window

1 Use the Product and Channel list boxes to select the required Channel Product from among the
currently selected items.

2 In the Table window, click the Market Intelligence cell containing the MI to be moved.
3 Click Show Market Intelligence details.
4 Right-click the cell and select Move Market Intelligence.

The Period End Dates dialog box is displayed.
5 Click to highlight and select the period to move the MI to.
6 Click OK.
7 Select File > Save.

Note: 

• Only I-type and S-type MI can be moved in these ways.
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• Daily market intelligence cannot be moved in the Demand Forecaster module. See Infor Demand
Planning Collaborate Help.

See "Specifying market intelligence adding options" on page 256.

Dropping market intelligence

Dropping market intelligence in the Graph window

1 Use the Product and Channel list boxes to select the required Channel Product from among the
currently selected items.

2  In the Graph window, right-click the data point of the period containing the MI to be dropped and
select Drop Market Intelligence.

3 Select File > Save.

Dropping market intelligence in the Fiscal Year window

1 Use the Product and Channel list boxes to select the required Channel Product from among the
currently selected items.

2 In the Fiscal Year window, click the cell containing the MI to be dropped.
3 Right-click the selected cell and click Drop Market Intelligence.
4 Select File > Save.

Dropping market intelligence in the Table window

1 Use the Product and Channel list boxes to select the required Channel Product from among the
currently selected items.

2 In the Table window, click the Market Intelligence cell containing the MI to be moved.
3 Click Show Market Intelligence details.
4 Right-click the cell and select Drop Market Intelligence.
5 Select File > Save.

Note: This does not apply to promotional MI (T-type).

Clearing market intelligence
1 Use the Product and Channel list boxes to select the required Channel Product from among the

currently selected items.
2 Select Modules > Demand Forecasting > Edit Forecasts.

The five Edit Forecasts windows are displayed.
3 Select Edit > Clear Market Intelligence or click Clear MI on the Edit Forecasts toolbar.
4 Select File > Save.

Note: This does not apply to promotional MI (T-type).
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Adding/editing market intelligence in the Fiscal Year window
• You can also add MI by editing the total row for the forecast columns. This extra amount will then

either be spread evenly or proportionally over each period in the year, depending on the selection
made in the MI Details dialog box.

To add or edit market intelligence in the Fiscal Year window:

1 Use the Product and Channel list boxes to select the required Channel Product from the currently
selected items.

2 Highlight the required cell or cells in which the MI is to be added.
Click the first period and press the SHIFT key then click the last period; alternatively, click and drag
over the required period, release to select.

3 Right-click the selected cell(s) and select Add Market Intelligence.
4 Add any new MI or change existing MI as desired.

The MI Details dialog box is displayed.
5 Make any changes required.
6 Select a different MI category if the require category differs from the default.
7 Annotate the Notes panel if required.
8 Select Display this note on Edit Graph screen if you want to indicate that a note exists by flagging

it in the Edit Graph window.
9 Select File > Save.

Note: Depending on the switches set in the Options dialog, the MI will be: added as new MI, will
extend existing MI, or you will be prompted to decide the action to take. If it is Add New Market
Intelligence, a dialog prompts you for a description. If you choose to Add To Existing Market
Intelligence and the MI is being entered into a period in which there is existing MI, you will be
presented with a list of the existing MI. Decide which event to edit.

Specifying market intelligence adding options
There can be more than one piece of market intelligence against any one period for a particular item.
If there is already market intelligence at the period where the net forecast is being edited one of two
things could happen; the value of the market intelligence already present could be changed or a new
piece of market intelligence added altogether. There are 3 options to choose between to handle this
behavior.

1 In Demand Forecaster, select the desired Products and Channels.
See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Tools > Options.
The Plot Options dialog box is displayed.

4 Select the General tab.
5 In the Editing Market Intelligence panel, select one of the following:
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Add new Market Intelligence a new piece of market intelligence is added against the particular
period for the item every time the net forecast for a period is edited.

•

• Add to existing Market Intelligence if this option is chosen and the net forecast is being edited at
a period where there already exists manually created market intelligence, then the value of the
existing market intelligence is changed accordingly. If there is more than one piece of manually
entered market intelligence at the period being edited, the system will prompt you for which piece
of market intelligence to change.

• Prompt each time you will be prompted whether to change an existing piece of market intelligence
or add a new piece of market intelligence each time the net forecast is edited where individual
market intelligence already exists.

6 Click OK.

Notes

About Notes
In Demand Forecaster you can add annotations (notes) to any new or existing market intelligence
event, with the exception of temporary forecast group (TFG) MI events. Such notes are intended to
explain why the MI has been added. You are also able to add forecast and history notes to any selected
Channel Product (excluding TFGs) via the Graph and Fiscal Year windows.

Notes must be added for a specific week or month end date. On monthly-controlled databases, notes
are added on month end dates. On weekly-controlled databases, the dates are week end dates. If
adding a note in the monthly view on a weekly-controlled database, you will have to select a weekly
period end date within that month.

Optionally, the presence of Forecast, History and MI notes can be flagged in the Graph window. It is
also possible to see the notes via tool tip tabs in the Fiscal Year window.

All notes are stored in the PERIOD_NOTES table.

Adding MI notes
1 In Demand Forecaster, select the required MI event in either the Edit Graph or Fiscal windows.

The MI Details dialog box is displayed.
2 Type the annotation in the Notes panel.
3 If required, select the Display this note on Edit Graph Screen check box.
4 Click OK.
5 Select File > Save.

Note: There are restrictions on the characters Oracle can accept.
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Adding forecast and history notes
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 In either the Graph or Fiscal Year window, right-click the period in which to add the note.
4 Select Add Forecast Note or Add History Note from the shortcut menu.

The New Note dialog box is displayed.
5 Type a description in the Description box (up to 40 characters).
6 If required, click the Date list box to select a different date.
7 Select the Display this note on user interface check box to make the annotation visible in both

the Graph and Fiscal Year windows.
8 Type the annotation in the main panel and click OK.

Note: There are restrictions on the characters Oracle can accept.

Viewing notes
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Tools > Notes Maintenance.
The Notes Maintenance dialog box is displayed.

4 Select the tab and note required and click View Note.
The View Note dialog box is displayed.

5 Click OK.

Note: You can view notes as tool tips by either clicking on tab in the Fiscal window or pointing the
cursor at the flag in the Graph window.

Editing notes
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Tools > Notes Maintenance.
The Notes Maintenance dialog box is displayed.

4 Select the tab and note required in and click Edit Note.
The Edit Note dialog box is displayed.
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5 Change the annotation as required.
6 Click OK.
7 Select File > Save.

Note: You can edit notes by either right-clicking on the flag in the Graph window or the tool tip tab
in the Fiscal window. Select Edit Note from the shortcut menu.

Deleting notes
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Tools > Notes Maintenance.
The Notes Maintenance dialog box is displayed.

4 Select the required tab and the note to be removed and click Delete Note.
5 Click Yes to confirm.
6 Click OK.
7 Select File > Save.

Adding flags and tabs in the Edit Forecast windows
1 In Demand Forecaster, select the desired Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Tools > Notes Maintenance.
The Notes Maintenance dialog box is displayed.

4 Select the tab required, either MI Notes or History/Forecast Notes.
If History/Forecast Notes is selected, choose the type of notes to include, Forecast, History or
both.

5 Click the note required and select the Display Flag check box in the View Flag column.
6 Click OK.
7 Select File > Save.

Note: The flag types to be displayed must be selected in the Notes panel of the Display tab in the
Plot Options dialog.

Removing flags and tabs in the Edit Forecast windows
1 In Demand Forecaster, select the desired Product and Channel.
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See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Do one of the following:

• Select Tools > Notes Maintenance. Select the relevant tab in the Notes Maintenance dialog
and clear the Display Flag check box for the selected note. Click OK.

• In the Graph window, right-click on the flag to be removed and select Edit Note from the shortcut
menu. In the Edit Note dialog and clear the Display this note on user interface check box for
the selected note. Click OK.

4 Select File > Save.

Customer Forecasts

About customer forecasts
A customer forecast is a forecast imported from outside Infor Demand Planning which is intended to
be used as a Channel Product's net forecast, at least in the medium term. The net forecast generated
by Infor Demand Planning (that is, statistical forecast plus market intelligence) still exists but is
overridden.

A CP's customer forecast is configured by three database fields:

• "Customer Forecast Periodicity (CPt)" must be defined as either monthly or weekly (the latter option
is available only in a weekly-controlled database). This defines whether the customer forecast is
specified in monthly or weekly amounts.

• "Periods Of Customer Forecast (CPt)" specifies for how many periods (weeks or months) the
customer forecast is to be used as the net forecast. If this field is zero, the customer forecast is
effectively disabled for this CP. The customer forecast values themselves are kept in the Customer
Forecast table.

• "Periods Of Customer Forecast Retained (CPt)" specifies how many historical periods (weeks or
months) of customer forecast are to be kept in the Customer Forecast History table. (At period end,
the current value in the Customer Forecast table is automatically shifted into the Customer Forecast
History table.)

Comparing the customer forecast with the net forecast
There are no standard reports currently available to compare the accuracy of the customer forecast
with the net forecast generated by Infor Demand Planning. Instead, you can export the "Forecast Last
Period (CPt)" and "Market Intelligence Last Period (CPt)" fields and compare the total with the most
recent value in the Customer Forecast History table.
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Net Forecast

About the net forecast
There is a facility within Infor Demand Planning that allows the component tables making up the net
forecast to be assembled. These tables are:

• The Statistical Forecast

• Different MI Types

• Customer Forecasts

These components of the net forecast are assembled and stored in the Net Forecast function accessible
from the Demand Forecaster and Replenishment Planner modules.

When the program is run for the first time during a month, the existing Net Forecast table (previous
month) is deleted and a new table is created with column names set to the current period names. The
net forecast is assembled and the new table updated. If no Net Forecast table exists then a new one
is created.

Only live items with the following values in "Product Type (Pt)" may be created or updated:

• 0 = A Standard Product.
• 1 = A Non-Standard Product (promotional variant).
• 2 = An Unspecified Forecast Product (UFP).
• 3 = A Returns Product.
• 8 = A Forecast Group Product.
• 9 = A Scenario Product.

And where the "SMP Code (CPt)" is:

• 1 = A Slow Moving Product which will be reviewed to see if it could be forecasted.
• 2 = A Slow Moving Product which is not to be reviewed to suggest moving to a forecasted item.

This table holds a snapshot of the current forecast that is available to report against. The table is not
updated as the forecast changes; it exists to publish an official statement of the forecast when prompted
and is used in the Replenishment Planner module.

Whenever necessary, the Net Forecast table can be updated or overwritten. If the Net Forecast table
is updated, then any matching Channel Products are updated with the current net forecast. If there are
Channel Products in the update list that do not exist on the current Net Forecast table then these are
appended as extra rows.

Net Forecast tables
The Net Forecast procedure produces two tables for each forecast period, a header and a data table
with columns as follows:
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Header Table

NET_FCAST_HD for monthly, NET_FCAST_WEEK_HD for weekly or NET_FCAST_DAY_HD for daily.

The column names for the header table are explained below:

MeaningColumn

This is an incremental integer for cross-reference from the header table
to the data table.

Ref

This refers to the user that updated/overwrote the net forecast table
(not the user that last changed the forecast).

User_Id

This is when the forecast was published (not when it was last changed
and not the period in the year to which it refers).

Pub_date

As "Date Demand Last Updated (Ct)".Period

This is the text that is typed into the Net forecast export dialog by the
user.

Descrip

Should contain the period end dates of the forecast from the first fore-
cast period up to the last forecast period (forecast horizon).

Period_1, Period_2 etc

Data Tables

The column names for the data table are explained below:

Table 1: NET_FCAST for monthly and NET_FCAST_WEEK for weekly

MeaningColumn

This is an incremental integer for cross-reference to the header table
described above.

Ref

This is the Product code for this item.Prod_cd

This is the Channel id for this item.Chan_id

There are a number of period labels depending on the forecast horizon
selected, with the first date matching the header date. The numbers in
these columns are the net forecast for each period.

Period_1, Period_2 etc

Table 2: NET_FCAST_DAY for daily

MeaningColumn

This is an incremental integer for cross-reference to the header table
described above.

Ref

This is the Product code for this item.Prod_cd

This is the Channel id for this item.Chan_id

The day in the forecast horizon. For example, "1" means the forecast
horizon's first day.

Datenum

Net forecast value for this day.Value
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Table 3: NET_FCAST_MONTHLY for calendar months

MeaningColumn

This is the Product code for this item.Prod_cd

This is the Channel id for this item.Chan_id

Net forecast value for this calendar month.Value

The calendar month period end date.Pd_end_dt

Note: 

• Any fields in the above tables that store dates will use the format as defined by the database setting.
However, for any client application, it is possible to display dates that have been read from the
database in an alternative date format. This means that for the core Infor Demand Planning modules,
the date format that is used to display this information is defined by the locale setting of the client
PC the client application is running on.

• Values stored in the Net Forecast table can be stored in either integer of decimal format, depending
on the setting of the "Net Forecast Table: Integer Or Decimal (St)" field.

• To produce daily tables, "Allow Daily MI (St)" must be true, "Level Of Forecast Control (St)" set to
1 (weekly) and valid values must exist in the "Daily Forecast Horizon In Weeks (St)" and "Weekly
Forecast Horizon (St)" fields.

• If the current Net Forecast table is for a period other than the current period on the database the
option to update is not available due to the miss-match of dates in the table.

• Only Channel Products selected at the beginning of the session will be updated in the Net Forecast
table.

• If any returns Products, "Product Type (Pt)" = 3 exist on the database, they may affect the results
in this table.

• Calendar months can only be exported on weekly-controlled databases where "Level Of Forecast
Control (St)" is set to 1 (weekly).

• Calendar months can only be exported from Demand Forecaster.

About Forecast BOMs
Forecast BOMs enable the Net Forecast at a parent channel product to be added as Market Intelligence
to any component products that are linked to the parent. The quantity of Market Intelligence is added
and any offset can be specified to suit requirements.

Forecast BOMs are channel specific and can be created for numerous channels.

Forecast BOMs are created and maintained within Database Administration. Select DBAdmin > System
> Forecast BOM's.
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After you have created Forecast BOM relationships, to Explode the BOM for the currently selected
channel product, select the parent of the BOM, specify the Edit Forecasts and select Explode BOM.
This will explode the BOM at this channel level.

If the selected channel product is not the parent of a Forecast BOM, the Forecast BOM option is not
available.

Exploding the BOM allows you to add market intelligence to the component products of the BOM at
that channel. The Market Intelligence equals the Net Forecast at the parent of the BOM.

To Explode BOM for multiple channel products, based on the current selection, select the Forecast
BOM option on the Demand Forecaster tab of the ribbon.

Market Intelligence is in the same manner to all the component products, at the channels based on
the current selection.

The Market Intelligence applied has a separate Market Intelligence category.

Updating the Net Forecast table
1 In Demand Forecaster, select the desired Products and Channels.

See "About selecting Products and Channels" on page 35.

2 Select Tools > Export Forecasts > Net Forecast.
The Net forecast export dialog box is displayed.

3 Select the Product types to include.
See "About Products" on page 33.

4 Choose to:

• Update table. This option is not available if the existing Net Forecast table is for a month other
than the current one (normally this would be last month’s data).

• Overwrite table. The data from the existing net forecast table (usually last month’s) is deleted
and new data assembled.

5 Select the periodicity required, Monthly, Weekly , Daily, or Calendar Months.
The Calendar months option is only available in a weekly controlled database and can only be
exported from Demand Forecaster.
If you choose to report the data in weekly periods and weekly history is stored on the database, this
is the reported history. If there is no weekly history stored on the database, the monthly history is
interpolated into weeks based on the calendar. The daily option is only available in a weekly-controlled
database when "Allow Daily MI (St)" is true and valid values exist in the "Daily Forecast Horizon In
Weeks (St)" and "Weekly Forecast Horizon (St)" fields.
See "About forecasting periodicity" on page 218.

6 A short Description may be typed in the edit box if required.
7 Click OK to close the dialog and assemble the table.
8 Select View > Output to remove the progress log information at the bottom of the screen.
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Note: The setting of the Net Forecast Table: "Net Forecast Table: Integer Or Decimal (St)" field
determines whether the forecast values are stored in integer (0) or decimal (1) format.

The Net Forecast table will now be up to date and can be exported (using Database Administration)
or used for interfacing to other systems.

Edit Grid

Edit Grid
The Edit Grid initially displays a summary view of the net forecast for the selected Channel Products.
You can expand the view to display the components of the net forecasts. The display is in either integers
or decimals as defined in the Forecast: Integer Or Decimal (St) field.

From Infor 11, Customer forecast and User Data Series can be displayed and edited in the grid.

You can display History only, or a combination of History and Forecast, by using the All option.

Select the Periodicity option to specify your preferred periodicity settings for Forecast, History or both.

Forecast periodicity can only be set if you are currently viewing Forecast or All.

History periodicity can only be set if you are currently viewing History or All.

These settings can be changed for the current session and can be saved to the database.

The last columns in the grid display the MI Description and the MI category. The default description is
"MI Added by <username>". The default MI category is assigned by the user. MI categories can be
created and assigned in the database administration core module.

Net Forecast view
If the Forecast option is selected, the Net Forecast view displays the net forecast (the statistical forecast
+ any market intelligence), for each Channel Product displayed.

The Net forecast and Total Net forecasts can be edited for single and/or multiple periods by directly
entering a value (single period/channel product only) or by right-clicking and selecting Edit Net Forecast
(valid for both single and multiple period edits)

From Infor 11, Customer Forecast can be displayed in the grid, and is the default display when entering
the grid. In the Detail view of the grid, the new row Customer Forecast is displayed.

Where Customer Forecast exists, the Net Forecast is overridden for the periods of Customer Forecast.
For example, if a channel product has six periods of monthly Customer Forecast, for the first six months
the Customer Forecast replaces the Net forecast that is displayed in the grid. However, the type label
remains "Net Forecast". From month 7 onwards, and even if Customer Forecast exists for month 7
and beyond, the Net forecast equals statistical forecast plus Market intelligence. This formula reflects
the display in the Table window in Edit Forecasts.
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Channel products with 0 period of Customer Forecast show the usual net of statistical forecast plus
Market intelligence.

Totals sum the total of what is displayed in the grid.

Monthly Customer Forecast is interpolated to weeks and days based on the interpolation vectors that
are assigned to the channel product. Daily Customer Forecast values are summed into calendar months.

Weekly Customer Forecast are summed to months and interpolated to days, based on the interpolation
vector that is assigned to the channel product. Daily Customer Forecast values are summed into
calendar months.

For Channel products where Net forecast equals Customer Forecast, the Net forecast and the New
MI cannot be edited up until the end of the periods of Customer Forecast. Non-customer forecast Net
forecast periods can be edited.

Totals that comprise the Net forecast and Customer Forecast cannot be edited. If the New MI is
apportioned to periods where Net Forecast equals Customer Forecast, the Total New MI, that is
displayed in the Detail view of the grid, cannot be edited.

If the new Net forecast is apportioned to periods where Net Forecast equals Customer Forecast, multiple
periods and channel products cannot be edited.

Profiles can be applied from non-customer forecast periods onwards and can only be applied to totals
once all periods in that total use non-customer forecast Net Forecast.

In the Customer forecast row in the Detail view, any negative Customer Forecast is displayed as such.
However, in the Net Forecast view, if negative forecasts are allowed, a negative Net Forecast is
displayed, otherwise the Net Forecast is displayed as 0.

If the History option is selected, the Net Forecast view displays the Adjusted Demand for each Channel
Product displayed.

The Adjusted Demand and Total Adjusted Demand can be edited for single and/or multiple periods by
directly entering a value or by right-clicking and selecting Edit Adjusted Demand (valid for both single
and multiple period edits).

If the All option is selected the grid displays the Adjusted Demand and the Net forecast. Both can be
edited in the same way as the Adjusted Demand and Total Adjusted Demand.

Detailed view
If the Forecast option is selected in the Net Forecast view, either right click and select Detail View
from the options or click in the left-hand side of the grid. The grid expands to display these details:

Net
The net forecast, the sum of the statistical forecast and any market intelligence.

From Infor 11, Customer Forecast can be displayed in the grid, and is the default display. In the Detail
view of the grid, the new row Customer Forecast is displayed.
Where Customer Forecast exists, the Net Forecast equals Customer Forecast for the periods of
customer forecast only.
Editing rules where Customer Forecast exists and the negative Customer Forecast display are as per
the Customer Forecast in the Net Forecast view of the grid.
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Stat
The statistical forecast calculated in the Infor Demand Planning Demand Forecaster module.

Old MI
Summed market intelligence (MI) values across all the MI events.

New MI
New MI is any market intelligence entered in this view that has not been saved.
New MI can be entered by directly typing a value into the New MI period and then pressing Enter, Tab
or clicking on another cell to register the edit.
Total New MI (period and channel product totals) can be overtyped, with the MI spread to the individual
periods/channel products based on the spreading options defined in Edit Grid Spreading Options.

Customer Forecast
This field displays any Customer Forecast for this channel product. When entering the grid, Customer
forecast is the default view but can be changed to display a User Data Series via a list.
Customer forecast can be edited in any periodicity and saved back to the database.
Where Net forecast equals Customer Forecast, any edit to the Customer Forecast is reflected in the
Net forecast.
Customer forecast periods beyond the periods of Customer Forecast can also be edited but the Net
Forecast is not updated with the edits.

When the History option has been selected, whilst in the Net Forecast view, either right click and
select Detail View from the options or click in the left-hand side of the page. The grid expands to
display these details:

Adjusted Demand
The Adjusted Demand values for the displayed Channel Products. Initially read from the database,
but updated if adjusted demand has been edited, or recalculated if New Adjusted Demand has been
added.

Demand
The Demand values for the displayed Channel Products.

Sales
The Sales values for the displayed Channel Products.

New Adjusted Demand
Any New Adjusted demand that has been added to the Channel Product.
New Adjusted Demand can be entered by directly typing a value into the New Adjusted Demand
period and then pressing Enter, Tab or clicking on another cell to register the edit.
Total New Adjusted Demand (period and channel product totals) can be overtyped, with the Adjusted
Demand spread to the individual periods/channel products based on the History spreading options
defined in Edit Grid Spreading Options.
When the All option has been selected, the Detail View displays these details:

• Adjusted Demand/Net
• Demand/Stat
• Sales/Old MI
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• New Adjusted Demand/New MI

You can edit New MI and New Adjusted Demand in the same way as New and Total New Adjusted
Demand.

User Data Series
From Infor 11, User Data Series can be displayed in the grid.
Initially, Customer Forecast is displayed in the Detail View of the grid, but all the User Data Series to
which the user has access can be selected via a list that is displayed under the Weighting list.
After a User Data Series has been selected, a new row is displayed in the Detail View under New MI
with the Type User Data Series selected.
User Data Series can be displayed in any of the available periodicities.
Monthly User Data Series are interpolated down into weeks and days, based on the interpolation
vectors that are assigned to the channel product. Daily User Data Series values are summed to
calendar months.
Weekly User Data Series are summed to months and interpolated down into days, based on the
interpolation vector that is assigned to the channel product. Daily User Data Series values are summed
to calendar months.
Editable User Data Series can be edited in any periodicity and saved back to the database.
Weightable User Data Series can be weighted by any of the available weightings.
User Data Series can be displayed in History and Forecast periodicities.

Views
The Edit Grid can one of four views. Click the appropriate icon on the toolbar.
The Views are:

Current CP
Displays the currently selected Product at the currently selected Channel.

Note: The product and channel must form a valid channel product.

Changing the Product or Channel selected from the selection drop downs or product navigation buttons
will update the channel product displayed in the Edit Grid.

Product at All Selected Channels
Displays the Product in focus at all selected Channels.
Changing the Product selected from the selection drop downs or product navigation buttons will update
the channel products displayed in the Edit Grid.

All Products at selected Channel
Displays All Selected Products at the Channel in focus.
Changing the Channel selected from the selection drop downs will update the channel products
displayed in the Edit Grid.

Select All
Displays All selected Products at all selected Channels.
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Sorting
Click the Product, Description, or Channel column headers to sort the data in ascending or descending
order.

You can only sort in the Net Forecast view of the grid.

Copy and Paste
You can use the Edit menu options to copy some or all of the data from the edit grid.

You can paste values into the grid for single and multiple periods and channel products.

You can paste Net forecast values only in the Net forecast view of the grid.

You can paste New MI and New Adjusted Demand values only in the Detail view of the grid.

You cannot edit Old MI, Statistical forecast, Demand, and Sales values.

You cannot paste values in periods where the Net Forecast equals Customer forecast or in a Total that
imply spreading to periods where the Net Forecast equals Customer forecast.

Weighting
All data in the grid can be weighted by a Product, Channel Product or Time Phased Weighting.

Default weighting is Units.

Period Notes
You can add Forecast notes to any of the channel products displayed in the grid when in the Forecast
view or in the Forecast section of the All view.

You can add History notes to any of the channel products displayed in the grid when in the History
view, or in the History section of the All view.

You can add notes in any periodicity.

You can view, edit and delete notes from within the grid.

Profiles
You can apply Profiles to single and multiple channel products in both the Net forecast and Detail view.

When applying to multiple channel products, the MI can be spread to all or some of the channel products
in the grid, depending on the option selected.

You cannot apply a profile to periods where the Net forecast equals Customer Forecast.

Similarly, profiles cannot be applied to Totals where the periods in that total comprise Customer Forecast
and Net Forecast.
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Database field display
You can specify that up to three database fields (from the Products and/or Channel Products tables)
are displayed in the grid alongside the standard data.

Note:  Changes not saved in the Detail view are retained when moving to the Net Forecast view.
Negative Net forecast will only display as negative if Yes is specified as the value of Allow Negative
Forecasts in the Channel Product field for the channel product in question. If No is specified, the net
Forecast will display as zero
You are prompted to save if changes have been made and any of these actions are taken:

• Product or Channel selection is changed via the drop down selection boxes/Product Navigation
buttons.

• A different View is selected.
• A different periodicity is set and Revise is selected.
• Any Product Filters, Channel Product Filters, Product Views, Channel Product Views and User Data

Access Filters will be adhered to when displaying channel products in the Edit Grid.

It is not advisable to select all channel products on a large database with the Select All grouping.

Preferences - Display options

Edit Grid - Graph
The Edit Grid graph is available in all views and periodicity buckets and is a graphical representation
of the Forecast and/or History values displayed in the grid.

Any edits made in the grid will be displayed in the graph once the edits have been saved.

Hovering over each of the points on the graph will highlight the channel product in the legend as well
as displaying the channel product and value for the selected period.

The graphical display can be changed to suit your requirements using the Graph toolbar options.

The graph is accessible via the Window menu or the Graph icon on the Edit Grid toolbar.
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Preferences - Forecast Periodicity Settings

Preferences - History Periodicity Settings

Preferences - Spreading Options

Products

Slow Moving Products

About Slow Moving Products
Some items may be difficult to forecast with normal statistical methods because sales are so sparse.
There are many companies where, although the greatest proportion of items are constant sellers which
can be forecasted using normal statistical methods, problems are still encountered when handling a
few sparse items.

The Slow Moving Product functions in the Demand Forecaster module provide a general solution to
all sparse items, not just the true slow movers, but also items that sell in large numbers, but only
intermittently.

You can classify Channel Products as Slow Moving Products (SMPs). The classification is held in the
"SMP Code (CPt)" field. There are three valid codes for this field:

• 0 - Not an SMP item.

• 1 - An SMP item which should be reviewed at period end roll to see if it could be moved to being a
normal item.

• 2 - An SMP item which should not be reviewed at period end roll to see if it could be moved to being
a normal item.

When a Channel Product is classed as a SMP, the forecast routine applied to the item is different to
that used for normal items. A single term dynamic linear model is calculated through the periods, which
have seen any positive demand. A second single term model is calculated to give an estimate of a
demand happening in any given month. This means that SMP items will not have a forecast model
with growth or seasonality, there will only be an estimate of the next demand event and an estimate
of the current average period demand.
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When a forecast is created by Fit DLM, or by recalculating a forecast in Edit Forecasts, an SMP is
defined as being a live item on the database with more than a user defined minimum number of periods
of zero or negative history, within the last year. This number is held in "Minimum Zero Periods For
Sparse History (CPt)", the default value for this field is 6. This means that if, for example, a Channel
Product shows a historical demand pattern of 2 periods (which is 6 or less) with demand in the last
year then it is likely to be classified as a SMP.

There are also tests that happen during the period end processes. There is a forecasting field establishing
the number of periods of zero or negative history used to detect normally forecasted items which could
be moved to SMP status. The minimum number of periods with zero demand in the last year for migration
of a normal Product to SMP status must be specified to the system. The default field value is 8 and is
stored in "Minimum Periods For SMP (CPt)". Items are checked during the forecast revision process
and any item which have this number (or greater) of periods of history with zero or negative demand,
and which are not yet set up as SMP items, are listed as probable SMP items.

The "Maximum Zero Periods For Normal Product (CPt)" field controls those items which may need to
be migrated to a normal forecast item. This field requires a value for the maximum number of periods
with zero demand in the historical demand over the last year. The system default value for this field is
4. Items are checked during the forecast revision process at period end. Any items which have this
number (or less) of periods of history with zero or negative demand, and which are set up as "SMP
Code (CPt)" = 1 will be listed as probable normal forecast items.

Calculation of the SMP forecast
Slow Moving Products present a number of difficulties for any business trying to provide an acceptable
level of customer service, while avoiding unnecessarily high inventory levels. Normal methods for the
calculation of a Product forecast would use every data point within the chosen history. However, the
high occurrence of zero demand periods distorts the forecast as it treats zero as a valid number and
would significantly reduce the average demand per period. Trying to obtain a realistic estimate of the
amount of the next period of demand or indeed an estimate of how often it is likely to occur in the future
together with an annual forecast figure is difficult.

The calculation of future demand for SMPs within Demand Forecaster addresses these problems by
adopting a totally different approach. By removing the periods of zero demand from the calculation, it
is possible to obtain a more accurate estimate of the size of the next event (period of sales) and also
the associated estimate of forecast error.

Having derived the size of the next event, the next step is to calculate the number of times the event
is likely to occur within the forecast horizon. This is achieved by analysing the demand history to
determine the number of periods with positive activity. Once the estimate of the next event and the
likelihood of occurrence have been calculated. The system uses the two estimates to determine a
realistic estimate of the annual demand forecast.

The choice is available to switch an item between SMP and normal status. For an SMP item, the
adjusted demand history can be edited and changes made to the current level. If an SMP item is a
member of an ad hoc group it is excluded from any changes that are spread down.

Slow moving Products may be edited within the Edit Forecasts function. In some cases the displays
and available data are different to those for a normal item.
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Graph window
When displaying slow moving Products, the Graph screen is constructed as a bar chart (or histogram).
Vertical bars in the history area show the size and distribution of past sales. The forecast is represented
by a series of horizontal lines showing:

• SMP Average Event

• Re-order point

• Statistical forecast

The Graph screen may be used to add MI in the same way as for a Standard Product. The level of the
Product may be adjusted, but not the trend. Growth Damping and Future Changes are not available
when editing a SMP.

Information box
This window displays information specific to slow moving Products:

• Re-order point. If the "SMP Re-order Point Code (CPt)" field for the Channel Product is set to "0",
the re-order point represents the integer number of expected sales events (rounded up to the next
integer) multiplied by the average event quantity plus the required safety stock at the end of the
lead-time. If "SMP Re-order Point Code (CPt)" is set to "1", the re-order point is calculated as for
normal items, that is, the net forecast during the lead-time (including unusual demand) plus the full
safety stock at the end of that lead time. This value is rounded up to the next integer. The forecast
over the lead-time used in the re-order point calculation is then set to which ever is greater between
the net forecast or the integer number of expected events, multiplied by the average SMP event.
The greater of these values is then added to the safety stock at the end of the lead time to give the
re-order point.

• SMP Average Event. The value returned from the BATS routines for the estimate of demand in any
month which has a sales event.

• SMP Chance of monthly event. Only displayed for SMP items and holds an estimate of the chance
of getting an event in any month.

Data window - SMP tab
The SMP tab shows the status of the Product:

• SMP code. General field used to define whether the item is treated as a normal forecast item, a
slow moving Product which is reviewed to see if it could be forecasted or a slow moving Product
which is not to be reviewed to suggest moving to a forecastable item. Select from the list box.

• SMP average event. Will only be valid for SMP items and will hold the value returned from the BATS
routines for the estimate of demand in any month which has a sales event. Normally system
generated, no editing allowed from this tab.

• SMP chance of a monthly event. Will only be valid for SMP items and will hold an estimate of the
chance of getting an event in any month. Normally system generated, no editing allowed from this
tab.

Note: 

• The other screens within Edit Forecasts contain data as for a Standard Product.

Infor Demand Planning User Guide | 273

Demand Forecaster



• Discount factors may be changed by the Fit DLM function. Within this function, if a normal Channel
Product is changed to a slow moving Product then the Discount Factor code is changed to 1 (default
SMP settings). If, within the same functions, a slow moving Product is changed to Normal, the
Discount Factor code is changed to 0 (default static settings).

Unspecified Forecast Products

About Unspecified Forecast Products
New Products need a forecast in advance so that production or purchasing plans can be derived and
where appropriate, raw materials, components and packaging scheduled. You can establish a record
for a notional Product in the early stages of Product design to aid with planning and budgeting.

Unspecified Forecast Products (UFPs) may hold market intelligence for the forecast and this forecast
and history of the forecast may be incorporated into the sales planning data. You can also import and
store customer forecasts against these items.

You cannot store normal history against a UFP, nor create or control a statistical forecast. Safety stocks,
schedules, RP calculations and deployment plans are not available for these items. UFPs may not be
specified as promotional or slow moving Products and there is no facility for successor/predecessor
functionality.

Returns Products

About Returns Products
A Returns Product is a Product that has been returned by the customer may be returned to stock as
one or more base products. The Returns Product features of Infor Demand Planning will be available
if "Return Type (St)" has been set to a value other than zero (the default).

To identify a Returns Product, a separate Product code is required. This new item has its "Product
Type (Pt)" field set to 3. The Returns Product must be linked to one or more base products (standard
ornon-standard). The relationship between the returns and the base items must specify the proportion
of the returned item that will be available to be returned to stock and the number of each linked base
product to be restocked for each unit of return. The same specification will also define the offset period
involved in this stock return process.

The returns functionality may be enabled by selecting one of the returns options in the System database
table and a Returns Product may be created in the usual way.

See "Adding Products" on page 84.
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A relationship between the Returns Product and one or more base Products must then be specified
for each base product. This relationship must specify this information:

• The proportion of the returned items that will be available to be returned to stock.

• The number of each linked base item to be restocked for each unit of the returned item.

• The offset period involved in this stock return process.

These relationships are established by using the Returns wizard in the Demand Forecaster module.

Enabling Returns relationships
Before you can create Returns relationships, you must first enable them in the database.

1 In Database Administration, select DB Admin > System > System Data.
The System Data dialog box is displayed.

2 On the General Settings tab, in the Returns Code box, select Forecasting Returns (Internal).

Creating Returns relationships
1 In Demand Forecaster, select Modules > Demand Forecasting > Returns > Create/Modify.

The Returns wizard is displayed.
2 Choose to either use the Products which are currently selected or to open the Select Products dialog

to re-select.
See "About selecting Products and Channels" on page 35.

3 Click Next.
4 Click the Product to be used as the returns item then click Next.
5 Select a Channel to be used as the returns Channel in the relationship then click Next.
6 Select the Product or Products in the Available items panel to be included in the returns relationship

and click Add to transfer them to the Selected items panel.
7 Click Next.
8 In the Offset column, type the number of days between the input of the return Channel Product and

the stock increase in the linked base Channel Product.
Enter a positive integer.

9 In the Proportion column, type the proportion of the return Channel Product that may be converted
into good base Channel Product.
Enter a decimal between zero and one.

10 In the Quantity column, type the number of base Channel Product that will result from processing
each good unit of return Channel Product.
Enter a positive integer.

11 Click Finish.
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Editing Returns relationships
1 In Demand Forecaster, select Modules > Demand Forecasting > Returns > Create/Modify.

The Returns wizard is displayed.
2 Choose to either use the Products which are currently selected or to return to the Select Products

dialog to re-select.
See "About selecting Products and Channels" on page 35.

3 Click Next if using currently selected Products or OK when different Products have been selected.
4 Select the returns item for the relationship to be modified.
5 Select the Channel for the relationship to be modified.
6 Use the Add and Remove buttons to change the items to be included in the relationship.
7 Change the relationship parameters as required:

• Offset specify with a positive integer.
• Proportion overtype with a decimal between zero and one.
• Quantity overtype with a positive integer.

8 Click Finish.

Deleting Returns relationships
1 In Demand Forecaster, select Modules > Demand Forecasting > Returns > Delete.

The Delete Returns Relationships dialog box is displayed.
2 In the Existing returns items panel, select the returns items to be deleted and click Add to transfer

to the Deleted returns items panel.
3 Click OK.

Scenario Products

About Scenario Products
A Scenario Product is a fictitious variant of a real Product created to try ‘what-if’ projections. If these
changes need to be saved for later reference, a Scenario Product must be created, the forecast amended
and then saved. This amending of the forecast will not be applied to the live, Product (known as the
base case) until the Scenario Product forecast has been approved and formally copied across to the
base case.

The Product code selection routine used elsewhere in the module does not allow any access to Scenario
Product codes, and consequently none of these codes appear in the standard Select Products dialog
box. Scenario Products may however be included in RP and DP module selection.

As Scenario Products cannot be selected, they cannot be used in any Demand Forecaster functionality
unless specifically allowed. For instance, if all Products are selected and Fit DLM is run, the Scenario
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Products are unaffected. The only cases where Scenario Products can be accessed are from within
the Edit Forecasts windows and for forecast reporting.

Within the Fiscal Year window, time-phased weightings (TPWs) may be selected, these will be those
transferred from the base case Product. However, it is important to note that only Channel Product
TPWs are copied to the Scenario Product in this manner.

At period end, Scenario Products are controlled by "Forecast Calculation Code (CPt)", which is set to
2 by default when the Scenario Product is created. This means that the forecast rolls to the correct
month, but is not revised. If a month end revision is required this field must be manually re-set to code
0. This will cause the Scenario Product to be smoothed as with a normal item.

Note: 

• This functionality is only available for Standard Products and PFGs.

• You can not define sales planning or budgeting for Scenario Products and sales plans are not stored
at period end.

• When a Scenario is created, it is created for all Channels associated with the base case Product.

Creating Scenarios
1 In Demand Forecaster, select Modules > Demand Forecasting > Edit Forecasts.

The five Edit Forecasts windows are displayed.
2 Select the required Product from the list.
3 Select Edit > Scenarios > Create Scenario.

The Select scenario suffix dialog box is displayed.
4 Select a Scenario suffix from the list or type a new one.
5 Type a description if required.
6 Click OK, then click OK again when created successfully.

Note: 

• This functionality is only available for Standard Product and PFGs.
• When a Scenario is created, it is created for all Channels associated with the base case Product.

Copying Scenarios
1 In Demand Forecaster, select Modules > Demand Forecasting > Edit Forecasts.

The five Edit Forecasts windows are displayed.
2 Select the required Product from the list.
3 Select Edit > Scenarios > Copy Scenario.

The Copy Scenario dialog box is displayed.
4 Click the code of the Product to copy to.
5 Click OK, then click Yes to confirm.
6 Click OK when copied successfully.
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Deleting Scenarios
1 In Demand Forecaster, select Modules > Demand Forecasting > Edit Forecasts.

The five Edit Forecasts windows are displayed.
2 Select the required Product from the list.
3 Select Edit > Scenarios > Delete Scenario.

The Delete Scenario dialog box is displayed.
4 Select the Scenario you want to delete and click Delete.
5 Click Yes to confirm.
6 Click OK when deleted successfully.

Editing Scenarios
You edit Scenario Products in the same way as a Normal Product.

1 In Demand Forecaster, select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

2 Select the required Scenario Product from the list box in the Scenarios toolbar.
3 Perform the required changes in the normal way.

Note: An additional Scenarios tab now exists in the Data window. This tab indicates the scenario’s
parent Product and enables you to specify the percentage chance of the scenario occurring (although
this percentage is not used in any calculations).

Reporting Scenario forecasts
1 In Demand Forecaster, select Modules > Demand Forecasting > Reports > Current Forecasts.

The Current Forecast Reports dialog box is displayed.
2 Select the desired options in the General tab as for normal items and click the Details tab.
3 Select Other Options, ensuring the Include Scenarios check box is selected.
4 Click OK.

The Select scenario(s) to include dialog box is displayed.
5 Click to highlight and select the scenarios to report from the Scenario List.
6 Click OK.

278 | Infor Demand Planning User Guide

Demand Forecaster



Permanent Forecast Groups

About permanent forecast groups
A permanent forecast group is a system view established to monitor and control groups of Products.
You can assemble the groups from any items on the database and the group identity consolidated into
a single fictitious Product known as a Group Product. The individual items within the group maintain
their individual identities and the group item reflects the aggregated forecast of the group generated
from a history assembled from the weighted totals of the group members.

You can manipulate the forecast by the usual Edit Forecasts routines and market intelligence (MI) may
be added as required. Options are available to relate the forecast of the forecast group to its group
items as follows:

• The net forecast of the forecast group may be constructed such that it equals the weighted sum of
the constituent items.

• The net forecast of the forecast group, as generated from a weighted aggregate history from
constituent items, may be forced down to those items.

Uses for permanent forecast groups
• To facilitate the creation and maintenance of a permanent group forecast across period ends

• To provide the facility to create and maintain group seasonal patterns which may be useful in setting
up forecasts for new items.

• To provide statistical comparison between the group and the sum of the forecasts for the members
of that group.

Limitations of forecast groups
• Stock may not be held against a forecast group.

• Sales planning functions are not allowed with a forecast group.

• Returns and non-returns Products may not be mixed in the same group.

Creating permanent forecast groups
1 In Demand Forecaster, select Modules > Demand Forecasting > Forecast Group > Create/Modify.

The Forecast Groups wizard is displayed.
2 Select the Products to use then click Next.
3 Select a group item from the list then click Next.
4 Select the group members then click Next.
5 If history is to be weighted, select the field to use and the table in which it is stored from the lists.
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6 Use the Transfer check box to select the history types to transfer. Sales are transferred by default.
7 For each history type selected, use the Weight check box to weight it by the chosen weighting field

then click Next.
8 Select the options to use to create a forecast model for the new group Product.

See "About the forecast model" on page 212.

9 If you want to remove all of the independent variables relating to the selected Channel Products
select the Permanently remove all Independent Variables check box.

10 Click Finish.

Editing permanent forecast groups
1 In Demand Forecaster, select Modules > Demand Forecasting > Forecast Group > Create/Modify.

The Forecast Groups wizard is displayed.
2 Select the Products to use then click Next.
3 Select the group item from the list then click Next.
4 Add and remove group members as required then click Next.
5 If history is to be weighted, select the field to use and the table in which it is stored from the lists.
6 Use the Transfer check box to select the history types to transfer. Sales are transferred by default.
7 For each history type selected, use the Weight check box to weight it by the chosen weighting field

then click Next.
8 Select the options to use to create a forecast model for the new group Product.

See "About the forecast model" on page 212.

9 If you want to remove all of the independent variables relating to the selected Channel Products
select the Permanently remove all Independent Variables check box.

10 Click Finish.

Deleting permanent forecast groups
1 In Demand Forecaster, select Modules > Demand Forecasting > Forecast Group > Delete.

The Delete Forecast Group dialog box is displayed.
2 Select the forecast group item of the group to delete.

The Group members will be displayed in the right-hand panel.
3 Click OK.

The forecast group item will not be deleted, only the group.
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Spreading MI to PFG members
1 In Demand Forecaster, select the required group Product and Channel.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Make the desired forecast changes to the group item as you would a normal Channel Product.
See "About forecast editing" on page 224.

4 Select Model > Force forecast down.
The Force forecast down to member items dialog box is displayed.

5 On the Spread tab, specify the forecast components to spread, the method to be used to calculate
the spreading ratios and the periods to spread. Type a market intelligence description if required.

6 On the Exclude tab, select the Channel Products to be excluded from the spread and the apportion
option to use.

7 Click OK.
8 To save the new forecasts, select File > Save.

Recalculating group forecasts
It is possible to recalculate the Permanent Forecast Group item forecast by summing the forecast of
its members.

1 In Demand Forecaster, select the PFG item and associated Channels.
See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Model > Sum forecast up.
The Recalculate group forecast dialog box is displayed.

4 Select the forecast components of the group subordinates to sum.
5 Click OK.
6 To save the new forecast, select File > Save.
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Temporary Forecast Groups

About temporary forecast groups
You can create temporary forecast groups (TFGs) to manipulate forecasts at a group level which can
then be pro-rated down to individual Channel Product level for saving. They may also be used for
grouping Products together for reporting purposes. As suggested in their name, TFGs are not stored
on the database. They are created during a session by clicking the Group tick box within the toolbar
of the main screen.

TFGs may also be created from a predefined view on the database. Such a View may, for example,
contain Channel Products with a common factor, identified by the business.

Once grouped, the forecast may be manipulated as if it were a normal Channel Product.

Notes

• You cannot mix Standard Products with Non-Standard, Returns, Scenario, Unspecified Forecast or
Forecast Group Products in the same TFG, and Infor Demand Planning reminds you of this if you
try.

• Take care if a model is fitted to a weighted TFG whose member items have MI. There may be
unexpected results.

• You can edit TFGs in weekly as well as monthly periodicity provided that the database has been
configured to support this.

• Grouped history can be manipulated, but can never be saved.
• Periodic patterns cannot be applied to TFGs
• User Data Series will not be displayed or calculated for TFGs.
• Any new Market Intelligence added to a TFG will not have a category assigned to it.

Creating and spreading temporary forecast group forecasts
Temporary forecast groups (TFGs) may be created to enable forecasts to be manipulated at a group
level and then pro-rated down to individual Channel Product level for saving. They may also be used
for grouping Products together for reporting purposes. As suggested in their name, TFGs are not stored
on the database, but are created during the session for manipulation.

1 In Demand Forecaster, select the desired Channel Products.
See "About selecting Products and Channels" on page 35.

2 Click the Group check box in the toolbar of the main window.
3 Select Modules > Demand Forecasting > Edit Forecasts.

The five Edit Forecasts windows are displayed.
4 Make the desired forecast changes to the group item as you would a normal Channel Product.

See "About forecast editing" on page 224.
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5 Select File > Save.
The Spread dialog box is displayed.

6 On the Spread tab, specify the forecast components to spread, the method to be used to calculate
the spreading ratios and the periods to spread. Type an MI description if required.

7  On the Exclude tab, select the Channel Products to be excluded from the spread and the apportion
option to use.

8 Click OK
9 Select File > Save.

See "About temporary forecast groups" on page 282.

Predecessors and Successors

About predecessors/successors
The Demand Forecaster module enables you to achieve smooth succession from one Product to
another by establishing a link between a replacement Product and its predecessor. On a monthly basis,
the system copies demand from the predecessor to the new Product. There is also the facility to link
discontinuation and effectivity dates for both Products. The discontinuation datemay be time fixed or
dependant on the depletion of stocks. If this is the case, the theoretical on-hand stocks are taken into
account and the discontinuation and effectivity dates changed accordingly.

You may set up a chain of Products, for example, if there is an annual Product code change, these
new Product code successions can be defined:

A > B >  C > D > E etc.

time-------------------------->

There is no limit to the number of predecessors and successors you can have in a chain for a particular
Channel. The system however will not allow one predecessor to be divided into two or more successors
at the same Channel.

Once a predecessor/successor relationship is established and discontinuation/effectivity dates set,
demand data should not be entered at period end to a predecessor after its discontinuation date or to
a successor before its effectivity date. If such data is added, the CHANNEL PRODUCT is written to
the appropriate exception view, either "PASSED DISCO" or "PASSED EFF".

Note: 

• A returns item may not be used as part of a succession chain with any other Product type.
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Creating predecessor/successor relationships
1 In Demand Forecaster, select Modules > Demand Forecasting > Predecessor/Successor >

Create.
The Predecessor - Successor wizard is displayed.

2 Choose to either use the Products which are currently selected or to open the Select Products dialog
to re-select.
See "About selecting Products and Channels" on page 35.

3 Click Next.
4 Click the Product to be used as the predecessor item then click Next.
5 Click the Product to be used as the successor item then click Next.
6 Select the Channels you want to use for the linkage. To select all the listed Channels, use the Select

All option.
7 Click Next.
8 Use the History check boxes to select the history types to transfer to the successor during the set

up and at period end.
9 Select the corresponding Weight check boxes if weightings are to be applied to the transfer.
10 Specify the weighting factors for each Channel:

a Click Define History Weightings.
The Define History Weightings dialog box is displayed.

b Type the desired factors in the Weighting column and click OK.

11 Click Next.
12 Use the check and edit boxes to define the discontinuation date of the predecessor and the effectivity

date of the successor for the selected Channels.
13 Select the Pred. Remove MI check box if you want to delete any non T-type market intelligence for

the predecessor, up to and including the successor’s introduction date.
14 Select the Succ. Remove MI check box if you want to delete any non T-type market intelligence

for the successor, after the predecessor’s discontinuation date.
15 Click Next.
16 Select Permanently Remove All Independent Variables to delete any existing independent

variables for the successor Channel Products.
17 Select the Options to use and click Finish to fit a DLM to the successor Channel Products.

Editing predecessor/successor relationships
1 In Demand Forecaster, select the predecessor Product.
2 Select Modules > Demand Forecasting > Predecessor/Successor > Modify.

The Modify Predecessor/Successor Relationships dialog box is displayed.
3 On the Main tab, click the Channel/Successor item to modify.
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4 On the Dates tab, use the check and edit boxes to modify the discontinuation date of the predecessor
and the introduction date of the successor.
See "About effectivity and discontinuation dates" on page 247.

5 On the History tab, use the History and Weight check boxes to modify the history types to transfer
to the successor at period end, and if the history should be weighted or not.

6 Click OK.

Reporting predecessor/successor relationships
1 In Demand Forecaster, select the predecessor Product.
2 Select Modules > Demand Forecasting > Predecessor/Successor > Report.

The Report Predecessor/Successor Relationships dialog box is displayed.
3 On the Report tab, select the Channel from the Current Channel list.

Successor descriptions, codes, introduction dates and discontinuation dates are displayed.
4 Click the Graph tab.

The graph shows the chain of Channel Products that were shown in the Report tab, displaying the
history and/or forecast from each introduction date to each discontinuation date.

5 If required, select an alternative Channel from the Current Channel list.
6 Click OK to close the dialog.

Deleting predecessor/successor relationships
1 In Demand Forecaster, select the predecessor Product.
2 Select Modules > Demand Forecasting > Predecessor/Successor > Modify.

The Modify Predecessor/Successor Relationships dialog box is displayed.
3 On the Main tab, click the Channel/Successor item to be deleted.
4 Click Remove.
5 Click OK.

Calculating discontinuation dates
1  In Demand Forecaster, select the desired Products and Channels.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Discontinuation Dates.
The Automatic Calculation of Discontinuation Dates dialog box is displayed.

3 Select the Remove MI check box if you want to drop all market intelligence (except T-type MI) after
the calculated discontinuation date.
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4 Select the Align existing Pre/Suc dates check box if you want to automatically set the effectivity
date of the successor equal to the newly calculated discontinuation date of the current (predecessor)
item.
These dates will always be aligned when the "Update Successor Effectivity Date (CPt)" field for the
predecessor is set to 1 (true), irrespective of this selection.

5 Click OK.
On completion, the output screen is displayed providing details of the calculations completed and
any restraints encountered.
Exception Views
The process may generate these exception views:

• "BOM SUB AUTO DISC"
• "FUT EFF AUTO DISC"
• "POT OBS AUTO DISC"
• "RETURNS AUTO DISC"

Reports

About forecast reports
The process of reporting is key to the usage of any planning system. The Demand Forecaster module
offers a selection of standard reports to represent the most commonly reported information such as
summary forecasts, stock reports and performance reports. There are also tools for Sales Budgeting
and Tracking (SBT) and Sales and Operations Planner (S&OP) reporting. These facilities are totally
flexible, allowing the presentation of information in any chosen periodicity or format (integers, decimals,
percentages).

Exporting

There may be a need to export data from for external analysis. Data may be exported in a variety of
formats to any preferred non-Infor Demand Planning systems, for example, spreadsheet packages.
This feature provides an easily accessible format for analysis and reporting.

See "About importing and exporting" on page 127.

Graphical displays

Graphs may be printed directly or exported as bitmap files. The buttons that appear with report graphs
are as follows:

Arrow buttons allow you to view the next or previous items or the first and last
items.

First, Previous,
Next, Last

Allows you to print the graph.Print
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Allows you to view the graph in either 2D or 3D.

Vertical lines are displayed on the graph.Vertical Grid

Horizontal lines are displayed on the graph.Horizontal Grid

Allows you to change the fonts.Fonts

Viewing a Current Forecast report
1 Select the Channel Products to report on.

See "About selecting Products and Channels" on page 35.

2 In Demand Forecaster, select Modules > Demand Forecasting > Reports > Current Forecasts.
The Current Forecast Reports dialog box is displayed.

3 On the General tab, configure the following aspects of the report as required:

• the report style
• the forecast types
• the report periodicity
• the history types
• whether report totals are included
• whether report data is summarized

4 On the Details tab, select or type the following:

• the report length
• the scale by factor
• the group by field
• the calendar
• the weighting field
• the time-phased weighting if applicable
• whether scenarios are included

5 Click OK.
6 Use the First, Previous, Next, and Last buttons on the toolbar to view the first, previous, next or

last item in the report.

Viewing an MI Effectivity report
1 Select the Channel Products to report on.

See "About selecting Products and Channels" on page 35.

Infor Demand Planning User Guide | 287

Demand Forecaster



2 In Demand Forecaster, select Modules > Demand Forecasting > Reports > Forecast Analysis
> MI Effectivity.
The MI Analysis - Options dialog box is displayed.

3 Select the Percentage tolerance required.
4 Select the Display totals check box if you want to include a grand total for the report and, if a

grouping is selected, a group total for each control break.
5 Select the Sort by improvement check box if you want to base the sort order on the degree of MI

improvement.
6 From the list, select Ascending or Descending.
7 Select a Weight field for the report if required.
8 Select a Group by field if required.
9 Type a Scale by factor if required.
10 Click OK.
11 Use the First, Previous, Next, and Last buttons on the toolbar to view the first, previous, next or

last item in the report.

Viewing Accuracy Data
1 Select the Channel Products to report on.

See "About selecting Products and Channels" on page 35.

2 In Demand Forecaster, select Modules > Demand Forecasting > Reports > Accuracy.
The Accuracy Report Options dialog box is displayed.

3 Select the table from which to select a grouping field, either Products or Channel/Products.
4 Select the field to group by from the selected table.
5 Select a Weight By field for the report if required.
6 Select the Demand Type to use, Adjusted Demand, Demand or Sales.
7 Enter a Scale By factor if required.
8 Click OK.

The following windows are displayed:

• "Accuracy Data reports"
• "Accuracy Histogram"
• "Accuracy Scatter Chart"

Viewing a Demand Analysis report
1 In Demand Forecaster, select Modules > Demand Forecasting > Period End > Demand Analysis.

The Demand Analysis dialog box is displayed.
2 On the Main tab, select the following:
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• History to compare

• MTD (first forecast period)
• MTD (to date)
• Last Month

• History type

• Default
• Sales
• Demand
• Adjusted demand

• Options

• Transfer NSP History
• Sum Forecast Groups
• Generate exception view
• Show description

3 On the Report tab, select the criterion you want the exceptions reported by.
4 On the Sort tab select the fields to sort and weight the report by.
5 Click OK.

The Channel Dates Confirmation dialog box is displayed.
6 Check that the latest demand has been loaded successfully and click OK.

Changing the Graph options
1 In Demand Forecaster, select Modules > Demand Forecasting > Reports > Forecast Graph.

The Graph Options dialog box is displayed.
2 On the General tab, configure the following aspects of the report as required:

• the graph style
• the forecast types
• the graph periodicity
• the history types

3 On the Details tab, select or type the following:

• the graph length
• the scale by factor
• the group by field
• the calendar
• the weighting field

Infor Demand Planning User Guide | 289

Demand Forecaster



• the time-phased weighting if applicable
• whether scenarios are included

4 Click OK.

Promotions

About promotions
The Promotions feature is designed to assist in the task of managing the forecast for heavily promoted
and frequently grouped Products.

There are three main types of promotion:

• Standard Product Promotion. Many promotions involve more than one item but have no special
pack requirements.

• Product Replacement Promotion. In this case a Non-Standard Product (NSP) may be sold for a
period of time instead of the standard item. This situation applies particularly in fast moving consumer
goods (FMCG) companies where competition, price flash and extra content packs are regularly
produced and sold. Most companies need to treat these special packs as unique item codes for
production and logistical purposes.

• Special Kit Promotion. In this case a set, comprising of standard and non-standard items, is sold
bundled together often in a special presentation container. Typically this is a promotional strategy
used by some FMCG companies but many other industries produce special kits, for example, medical
supplies, introductory offers to new customers and so on.

Marketing group structure
The assumption has been made that a marketing group might be comprised of a parent Product, which
is the Standard Product, a number of Non-Standard Products (NSPs) and Associated Standard Products
(ASPs).

The NSPs are essentially the same as the parent but exist as a separate code due to slight differences
in detail (10% extra, money off flashes etc.). If an NSP item is a member of an ad-hoc group it will be
excluded from any changes that are spread down.

Any standard items which may be affected by a particular promotion are called Associated Standard
Products (ASPs).

A Standard Product will have its own sales and demand history, as well as having a statistical forecast
and the ability to include market intelligence and dependant demand. All functions within Edit Forecasts
will be available for standard pack items.

A marketing group view is of great importance in controlling replacement and kit promotions and may
contain:
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• one NSP which is not linked to any other standard item.

• one or more NSPs linked to a parent item.

• one NSP linked to one or more ASPs.

• one or more NSPs linked to a parent item and to one or more associated items.

History details
The demand for the Standard Product is an aggregation of its own demand and the demand from the
NSPs. It is this combined demand that would normally be used to produce the statistical forecast and
that would be smoothed against the aggregate forecast to revise the statistical model. The sales history
of the Standard Product would consist of its own independent demand.

The parent Product's history of demand is an aggregation of its own demand and the demand from the
NSPs. Its history of sales is its own independent sales.

On a monthly or weekly basis the parent and the NSPs demand are brought into the system separately
using the standard Import Demand routines.

Forecast details
The NSPs, by their very nature have no statistical forecast. The NSPs, having no statistical forecast,
are not smoothed at period end.

Preparing for a promotion
Before any marketing groups can be established, the Products that are to be the non-Standard Products
must be defined. Ensure the field "Product Type (Pt)" is set to NSP (1) for each.

See "Creating marketing group views" on page 295.

Edit Promotions
The Edit Promotions grid has the same look and feel as the Edit Grid but with increased functionality.
This enables Promotional events and Promotional Market intelligence to be added to Marketing group
views and Ad-hoc promotional groups. The creation and management of Ad-hoc promotional groups
is also done within the grid.

To add promotional market intelligence to a marketing view, select the required marketing view and
enter Edit Promotions. The marketing group view selected is displayed at the top left of the grid.

For marketing group views, the only available view of the Edit Promotions grid is All Products at selected
channel.

Any Market Intelligence, profile, or Promotional event added to single or multiple periods/channel
products will be of Promotional, T-type, MI and have a Promotional MI Category assigned to it.

After saving, the Market intelligence event is listed in a drop down containing all MI events that are
linked to the selected marketing group. The default is New Event.
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When another marketing group is selected, the list of MI events updates to events linked to the newly
selected marketing group.

Previously saved MI events can be loaded by selecting an event from the list. This loads the New MI
that was created in the event, which can be edited and saved back to the event.

MI events can be deleted from the database by selecting an event and selecting the x button.

Ad-hoc promotional groups can be created in the Edit Promotions grid by selecting channel products,
entering the grid and selecting the view you wish to create the ad-hoc group in - for example, All
Channels at selected product.

When any edits are saved, the ad-hoc group is created after specifying a name and description for the
group at the prompt.

The Ad-hoc view is be displayed at the top left of the grid with any other Ad-hoc views on the database.

When another ad-hoc view is selected, the channel products in that view are loaded in the view of the
grid it was created (for example, All Channels at selected product) and the list of MI events updates to
events linked to the newly selected view.

Promotional events can be added to marketing groups and ad-hoc views in Edit Promotions, allowing
for promotional MI to be created on a cross CP basis, and also allowing for any negative effect on
related, non-promotional items. See: "Promotions Workbench" on page 292.

From Infor 11, Customer Forecast and User Data Series can be displayed in the Edit Grid and the Edit
Promotions grid.

Customer forecast is the default display. In the Detail view of the grid, an extra row is displayed. The
Net forecast value that is displayed in the grid equals Customer Forecast up until the end of periods
of customer forecast.

Where Net forecast equals Customer forecast, edits cannot be performed to the Net Forecast or to the
New MI values for these periods.

Any of the User Data Series to which the user has access can be selected via a list and displayed in
any periodicity. Where editable, the User Data Series can be edited and saved back to the database.
See "Edit Grid" on page 265.

Promotions Workbench
Use the  Promotions Workbench dialog to create a promotional event, allowing for promotional MI to
be created on a cross CP basis, and also allowing for any negative effect on related, non-promotional
items.

The  Promotions Workbench dialog has these fields and options:

Promotional Event
A drop-down of any previously saved promotional events for the currently selected Marketing Group
or Ad-hoc promotional group. The default is New Promotional Event.
Delete Event
Select the event to delete and select Delete Event  to delete it from the database.
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On Promotion, Off Promotion and Cannibalized tabs
All three tabs have these options:

• Start Date: Prepopulated with the data of the selected period. The Start Date drop-down contains
all period dates based on the current edit grid selection and periodicity.
Note: You can specify a different start date on each of the three tabs.

• Promotional Profile: A drop-down of all promotional profiles on the database, with their graphical
representation displayed underneath.
Note: You can specify a different profile on each of the three tabs.

Items, Factors, Select
These are column headings in the left hand pane:

• Items: A list of the channel products currently displayed in the grid.
• Factors: The forecast group factor to be assigned to the channel product. Pre-defined factor=1
• Select: Select which channel products is included in the promotional event.

Note:  If you enter the  Promotions Workbench dialog with a Marketing Group view selected in the
edit grid, any NSP's is selected by default in the On Promotion tab, the Parent of the MG View is
selected by default in the Off Promotion tab, and any ASPs are selected by default in the Cannibalized
tab.
If you enter with a standard selection of Channel Products, all tabs show all channel products currently
displayed in the edit grid with none selected by default.
You cannot select the same channel product(s) in more than one tab.

Uplift/Downturn
These options are enabled or disabled according to whether the selected profile has a downturn or
an upturn.

• Value: Specify a value to add to the forecast.
• Percentage of Net Forecast: Alternatively, specify a percentage of Net forecast to be applied to the

selected On Promotion items.

The percentage value is the sum of the net forecast of the Channel Products selected in the tab, from
the Start date, for the positive promotional periods of the selected profile.
When applying a % of Net forecast for downturn, the % value is the sum of the net forecast of the
Channel Products selected in the tab, from the Start date, for the negative promotional periods of the
selected profile.
Base Split
If multiple promotional items are selected, the New MI is spread back to the selected items in the tab
based on the Base Split option selected. The options are:

• Evenly: An even split between the selected items
• Percentage of Net Forecast
• Factors: Split based on user-defined factors that can be input in the dialog. Default of 1.

If the Promotional Event is being applied to a Marketing Group view, on clicking OK, the user is
prompted to save a description for the promotional event, which can be saved and re-selected for
future promotions.
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If the Promotional Event is being applied to an unsaved Ad-hoc view, on clicking OK, the user is
prompted to save a name and description of the Ad-hoc view, followed by a description of the
Promotional Event. The event can be saved and re-selected for future promotions.

The event is applied to the grid. The MI Description takes the name of the promotional event.

All further events that are applied to the grid in the same session are added to the existing event MIs.

All market intelligence that is created from a promotional event can be saved via the usual save method.
Saved MI Events are different from saved Promotions workbench events:

• The saved MI events are the actual Market Intelligence that is applied to the grid.
• The saved promotions workbench is the method of applying the MI to the grid.

Reselecting promotions workbench event

All promotions workbench events can be reused for any future promotion.

Select the promotions workbench and select an event from the list. The listed events are linked to the
marketing group or ad-hoc group currently in the grid. The event is loaded with channel product selection,
profiles, dates, options, and values that are set in each of the three tabs, as per when the event was
saved.

You can modify values in the three tabs. When the event, that is, the Market Intelligence, is applied
back to the grid, you can save the changes for future use if required. If unsaved, the event remains
unchanged in the database, but is still applied to the grid.

If, in the same session, you create a promotions workbench, reselect it and apply it back to the grid,
even if you have modified or saved it, it is added to the current Market Intelligence in the grid. The
current Market Intelligence is not overridden.

Reselecting a promotions workbench event can be seen as selecting a type of profile, but a more
detailed one.

Note:  You cannot apply a promotions workbench to periods where the Net Forecast equals Customer
Forecast.

Marketing Groups

About marketing groups
Marketing group structure

The assumption has been made that a marketing group might be comprised of a parent Product, which
is the Standard Product, a number of Non-Standard Products (NSPs) and Associated Standard Products
(ASPs).

The NSPs are essentially the same as the parent but exist as a separate code due to slight differences
in detail (10% extra, money off flashes etc.)
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Any standard items which may be affected by a particular promotion are called Associated Standard
Products (ASPs).

A Standard Product will have its own sales and demand history, as well as having a statistical forecast
and the ability to include market intelligence and dependant demand. All functions within Edit Forecasts
are available for standard pack items.

A marketing group view is of great importance in controlling replacement and kit promotions and may
contain:

• one NSP which is not linked to any other standard item.

• one or more NSPs linked to a parent item.

• one NSP linked to one or more ASPs.

• one or more NSPs linked to a parent item and to one or more associated items.

History details
The demand for the Standard Product is an aggregation of its own demand and the demand from the
NSPs. It is this combined demand that would normally be used to produce the statistical forecast and
that would be smoothed against the aggregate forecast to revise the statistical model. The sales history
of the Standard Product would consist of its own independent demand.

The parent Product's history of demand is an aggregation of its own demand and the demand from the
NSPs. Its history of sales is its own independent sales.

On a monthly or weekly basis the parent and the NSPs demand are brought into the system separately
using the standard Import Demand routines.

Forecast details
The NSPs, by their very nature have no statistical forecast.

The NSPs, having no statistical forecast, are not smoothed at period end.

See "Creating marketing group views" on page 295.

Creating marketing group views
1 In Demand Forecaster, select Modules > Demand Forecasting > Promotions > Marketing Group

View.
The MG View wizard is displayed.

2 Choose to either use the Products which are currently selected or to open the Select Products dialog
to re-select.
See "About selecting Products and Channels" on page 35.

3 Click Next.
4 Click the Product to be used as the parent Product for the view, then click Next.
5 Select the Products in the Potential NSPs panel to be included in the view and click Add to transfer

them to the Selected NSPs panel.
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6 If required, type the weighting factor in the NSP Weighting column.
7 Click Next.
8 In the Potential ASPs panel, select the Products to be included in the view and click Add to transfer

them to the Selected ASPs panel.
9 Select the Define history transfer from NSPs to ASPs check box and click Next to open the

Define History Weightings dialog and enter the required multiplication factor.
These factors will determine how the demand history is weighted and transferred from the NSPs to
any ASPs at period end.

10 Click Next.
11 Type a Description for the MG view.
12 Click Finish.

Editing marketing group views
1 In Demand Forecaster, select Modules > Demand Forecasting > Promotions > Marketing Group

View.
The MG View wizard is displayed.

2 Choose to either use the Products which are currently selected or to return to the Select Products
dialog to re-select.
See "About selecting Products and Channels" on page 35.

3 Click Next if using currently selected Products or OK when different Products have been selected.
4 Click the parent Product of the view to be amended, then click Next.
5 Use the Add and Remove buttons to change the items in the Selected NSPs panel.
6 If required, type the weighting factor in the NSP Weighting column.
7 Click Next.
8 Use the Add and Remove buttons to change the items in the Selected ASPs panel.
9 Select the Define history transfer from NSPs to ASPs check box and click Next to open the

Define History Weightings dialog and enter the required multiplication factor.
These factors determine how the demand history is weighted and transferred from the NSPs to any
ASPs at period end.

10 Click Next.
11 Click Finish.
12 Click Yes to overwrite the existing view.

Deleting marketing group views
1 In Demand Forecaster, select Modules > Demand Forecasting > Promotions > Delete Marketing

Groups.
The MG View Delete dialog box is displayed.

2 Select the MG views to delete.
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If more than one MG view is selected, and one or more has the MG view name the same as the
NSP code, a message is displayed advising that the views should be deleted individually to avoid
orphan market intelligence.

3 Select the Remove All T-Type MI check box if you want to delete the T-type market intelligence
associated with the view.

4 Select the Remove transferred history check box if you want to remove any history stored against
the NSPs.

5 Click OK.

Promotional Profiles

About promotional profiles
A promotional profile is the shape of a promotion over time. You can set up profiles with a name and
description and can be any number of periods long up to the forecast horizon.

In Collaborate Database Administration and Demand Forecasterit is possible to create promotional
profiles based on historical data. It is also possible to base a profile on the history of multiple Products.
This functionality allows you to find the average profile if the promotion was run on a group of Products.
The grouping is limited to Products at the same Channel. When multiple Products are selected the
history is summed per period and then divided by the number of Products in the selection.

You can store profiles as monthly or weekly profiles depending on the set up of the database. In a
monthly-controlled database the profiles are in monthly buckets and in a weekly-controlled database
the profiles are weekly.

The profiles created are used to apply a periodic shape to the promotional quantity supplied. The
promotional quantity values for each individual period are calculated by spreading the total quantity,
such that that the proportion of the total quantity allocated to a given period is based upon the ratio of
the period profile value to the sum of all the values in the profile.

Example
Consider a 5 period profile shape of 5, 10, 15, 20 and 0 using a total promotional quantity uplift of 1000
units:

Net Fcst.Resulting T-
Type MI

Calculation for Promotional QuantityStat. Fcst.ProfilePeriod No.

200100(5 / (5+10+15+20)) x 100010051

300200(10 / (5+10+15+20)) x 1000100102

400300(15 / (5+10+15+20)) x 1000100153

500400(20 / (5+10+15+20)) x 1000100204

1000(0 / (5+10+15+20)) x 100010005
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15001000 50050TOTAL

Creating a promotional profile
1 In Demand Forecaster, select Modules > Demand Forecasting > Promotions > Promotional

Profiles.
The Promotional Profiles dialog box is displayed.

2 Click Add.
3 Enter the name of the new profile in the dialog displayed and click OK.
4 Enter a description of the new profile in the dialog displayed and click OK.
5 In the Promotional Profiles dialog, select Edit.
6 To specify the uplift for each week of the profile, click the existing value (initially all zero), type the

new value (between 99.99 and -99.99) and press ENTER.
To review the "shape" of the profile, in the Promotional Profiles dialog, click Plot before clicking OK.

7 When you have edited all the required values click OK.

Editing a promotional profile
1 In Demand Forecaster, select Modules > Demand Forecasting > Promotions > Promotional

Profiles.
The Promotional Profiles dialog box is displayed.

2 Click the profile to change and select Edit.
3 To edit the uplift value for any week of the profile, click the existing value, type the new value (between

99.99 and -99.99) and press ENTER.
To review the "shape" of the profile, in the Promotional Profiles dialog, click Plot before clicking OK.

4 When you have edited all the required values click OK.

Applying a promotional profile

Deleting promotional profiles
1 In Demand Forecaster, select Modules > Demand Forecasting > Promotions > Promotional

Profiles.
The Promotional Profiles dialog box is displayed.

2 Click the profile you want to delete.
3 Click Delete, then click Yes to confirm.
4 Click OK to close the dialog box.
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Variance Estimates

About variance estimates
In order to develop an inventory policy based on a forecasted future requirement, the probable accuracy
of the forecast needs to be established. This accuracy is expressed as a standard deviation calculated
from past performance. In cases where a forecast is generated without history, the standard deviation
must be derived independently.

It has been well established that in every Product range there is a variance estimate that describes the
general relationship between the standard deviation and the average level of forecast. As the average
monthly forecast increases, so does the standard deviation. This is not a direct or linear relationship,
as the proportion that the standard deviation represents of the average forecast decreases as the level
of the forecast increases. The relationship can be seen as a linear relationship if a graph is plotted with
the standard deviation on the vertical axis, on a logarithmic scale, whilst the average monthly forecast
is plotted on the horizontal axis, again on a logarithmic scale.

The Variance Law is a function that allows a standard deviation to be obtained at a given level. The
function may be created by considering the level and standard deviation for Channel Products that
have known levels and standard deviations and then fitting a straight line through them to create a
function of the form y=mx+c (the values of the level and standard deviation are logged). Using the
value of the known level (x) a sensible value for the unknown standard deviation (y) can be calculated.

In use, the variance estimate has proved to be very robust, however, it has been observed that different
industries and inventory types tend to have significantly different relationships. Two important facts
have been observed through the use of variance estimates in various industries:

• The exponent (for standard deviation) is generally less than 1. This reflects the fact that the relative
(percentage) error in forecasting demand for fast-moving parts tends to be smaller than the same
error in forecasting slower moving parts.

• The actual error for any parts with the same level of forecast can vary dramatically. This emphasizes
the fact that the variance estimate should normally only be used to give an estimated starting position
for the standard deviation, and that this should be revised with respect to actual sales to find the
true level of error for each Channel Product.

Demand Forecaster makes provision for:

• Holding any number of named variance estimate relationships. These must be stored by
name/Channel.

• Calculating a variance estimate (and saving as a named relationship) from any set of items by a
defined Channel. This will enable businesses to create a variance estimate for any of the various
inventory types in stock.

• The manual input and saving as a named relationship of a variance estimate.
• The facility to choose a variance estimate to use when a forecast is created without running a model

through history. This will happen for instance where the user is creating a model using the Alternate
forecast function.
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Adding a variance estimate
1 Select a range of Products and Channels to use to establish a new variance estimate.

See "About selecting Products and Channels" on page 35.

2 In Demand Forecaster, select Modules > Demand Forecasting > Variance Estimate.
The Current Variance Estimates window is displayed.

3 Right-click in the table area and select Add Variance Estimate from the displayed options.
The Variance Estimate Details dialog box is displayed.

4 Type a name for the new variance estimate in the Description edit box.
5 Select from the Channel ID list box the Channel at which the new Variance Estimate is to be used.
6 If known, enter values in the Estimate Coefficient and the Estimate Exponent edit boxes.
7 If you want the system to calculate these values, leave the edit boxes blank and click OK to display

the Current Variance Estimate window. Right-click the newly created row and click Calculate.
The Variance Estimate Scatter Diagram window is displayed. The Coefficient and Exponent are
displayed in boxes at the bottom of the graph.

8 Click OK.
9 Close the Current Variance Estimate window, which now includes details of the newly created

variance estimate.

Applying a variance estimate
1 Apply an Alternate Forecast to the chosen Channel Product.

See "Applying an alternate forecast" on page 243.

2 In the Detail tab of the Alternate Forecast dialog, select Variance Estimate.
3 Select the required variance estimate from the adjacent list box.
4 Click OK.
5 Select File > Save.

Calculating a variance estimate
1 Select a range of Products/Channels to use to establish a new variance estimate.

See "About selecting Products and Channels" on page 35.

2 In Demand Forecaster, select Modules > Demand Forecasting > Variance Estimate.
See "Adding a variance estimate" on page 300.
The Current Variance Estimates window is displayed, showing the variance estimates that have
been created earlier.

3 Right-click in the row containing the variance estimate you want to calculate, then click Calculate
on the shortcut menu.
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A warning message indicates if the number of items having levels and standard deviations above
zero is less than 50. The purpose of this message is to inform you that the end results of the
calculation could be inaccurate because of the low number of items over which the variance estimate
would be established.
a Click Yes to continue.
b If the number of items having levels and standard deviations above zero is less than 10, a warning

to that effect is given and in this case, click OK to acknowledge the message. The process is
stopped because of insufficient data.

Provided that sufficient valid data points are available, the Variance Estimate Scatter Diagram
window is displayed. This is a visual representation of the calculation to establish a coefficient and
exponent for a set of Products. The diagram presented shows a point on a graph for each Channel
Product selected. The graph is constructed using logarithmic scales for both the forecast level
(horizontal) and Standard deviation (vertical Scale). A regression line through the scatter points is
the line from which the coefficient and exponent have been derived. The Coefficient and Exponent
are displayed in boxes at the bottom of the graph.

4 Click OK.
5 Close the Current Variance Estimate window, which now includes the new values.

Editing a variance estimate
1 In Demand Forecaster, select Modules > Demand Forecasting > Variance Estimate.

The Current Variance Estimates window is displayed.
2 Left click the row to edit.
3 Right-click in the table area and select Edit.

The Variance Estimate Details dialog box is displayed.
4 Over type the new values in the Estimate Coefficient and the Estimate Exponent edit boxes.
5 Click OK.

A warning message that the name/Channel combination exists is displayed.
6 Click Yes.
7 Close the Current Variance Estimate window, which now includes the new values.

Deleting a variance estimate
1 In Demand Forecaster, select Modules > Demand Forecasting > Variance Estimate.

The Current Variance Estimates window is displayed.
2 Left-click the row to delete.
3 Right-click in the table area and select Remove.
4 Right-click in the table area and select Save.
5 Close the Current Variance Estimate window.

Note: You cannot delete the Dummy variance estimate.
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Causal Modelling

About causal modeling
Warning: Causal modeling is a powerful technique. Its use may cause unexpected changes to the
forecast model. You should use it with care and, if necessary, with the assistance of Infor Demand
Planning consultancy support.

Causal modeling is performed as part of the statistical forecasting routine. Its purpose is to provide an
additional forecasting facility by the introduction of the ability to regress a number of independent
variables against a dependent variable. A regression model is one that relates changes in history to
factors other than time and predicts changes in sales levels with respect to that factor.

Sensibly used, causal factors improve the forecast accuracy of a Product and, by reducing its standard
deviation, reduce the recommended safety stock for a fixed service level.

The dependent variable is the demand pattern of a Channel Product. The independent variables may
be other Channel Products and/or other variables. Independent variables should be observable events
in history which explain some variability in past sales and have predictability in the future. They may
be qualitative or quantitative.

Take care that factors which are not predictable are not used as independent variables. Such factors,
because of their possible past correlation, serve only to reduce the standard deviation of a forecast
without adding to its real accuracy. A principle consequence of this would be to incorrectly reduce the
recommended safety stock for the product. An example of such an incorrect independent variable is
temperature.

As all statistical modeling is carried out at monthly level, this functionality will only be allowed in the
monthly view, whether in a monthly-controlled or weekly-controlled database.

You may save up to 7 independent variables against the dependent variable. Live Product types which
may be dependent variables are:

• 0 - Standard
• 8 - Permanent forecast groups

Slow Moving Products (SMPs) and Scenario Products cannot be used as independent variables.

Allowable data series for use as independent variables are:

• History/forecasts associated with Channel Products as specified above. Note that history masking
will not be effective, all history is included for independent variable purposes.

• Time phased weightings containing external variables.

Both types must have a minimum of 2 years history and forecast to the horizon

The implementation of causal modeling follows the traditional DLM lines. The DLM is already the sum
of independent components. For example, Forecast = Trend + Seasonality. A Causal component may
be added to the formula. For example, Forecast = Trend + Seasonality + Causality.
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Independent variables can only be applied to the dependent variable in Edit Forecasts mode. It is a
matter for your discretion whether or not to retain them.

See "About independent variables selection messages" on page 307  and "About causal factors" on
page 303.

About causal factors
The following explains the calculation behind causal factors. By means of simple examples the
relationship between the dependent variable and the independent variable may be followed.

The dependent variable is so called because of its possible dependence on another variable. If it is
suspected that the demand for this Channel Product may, in part, be dependent upon an external
measurable factor, this factor could be used as an independent variable.

Base case
In the following example, the demand for a Product is a steady 10 units per period. It is however subject
to apparently random, large increases in demand to 100 units. The random nature of these "peaks" of
demand is lost in a normal forecast. The peaks are either ignored as "outliers" or treated as lumpy
demand and averaged when the forecast is created:

Outliers

121110987654321Period

10101001010101010010101010History

101010101010101010101010Forecast

In the above example the two 100 unit demands have been ignored by the forecast as "outliers". The
forecast has been based on the remaining periods and set at a level 10 units. The normal demand
pattern has been maintained but the possible future additional demand has been lost.

Lumpy demand

121110987654321Period

10101001010101010010101010History

252525252525252525252525Forecast

In this case the history period has been treated as "lumpy", no seasonal element has been calculated
and the forecast has been set at the average monthly demand of 25 units. In this case the possible
total demand has been forecast but the normal demand pattern has been lost.

Causal factor
In the above example, consider the possibility that the peaks in demand are not random but based on
a measurable and predictable external influence. This may be, for example, a customer promotion. If
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the presence of the customer promotion is identified as a 1 and the absence of the promotion as a 0
the following historical demand pattern may result.

121110987654321History Period

10101001010101010010101010History

001000010000Promotion

Note that the timing of the promotion is aligned to the peaks in demand. If the promotion data is now
used as an independent variable influencing the forecast model of the product the following forecast
will result.

121110987654321Fcst Period

001000100100Promotion

101010010101010010101001010Forecast

In this case, the future dates of the promotions have been used to supplement the previous historical
demand of the product. The combination of these factors results in a forecast which predicts an increase
in demand to the historical peak levels whenever a promotion is to be held. The periods between retain
the forecast at the steady, normal demand level.

The forecast was considerably improved by the addition of an independent variable. The full picture
is:

1211100987654321Period

10101001010101010010101010History

001000010000Promo (History)

             

001000100100Promo (Fcst)

101010010101010010101001010Forecast

Causal factor lag
Consider a situation where the promotion pattern does not correspond with the peaks of demand.

121110987654321History Period

10101001010101010010101010History

000010000100Promotion

In this case, if the promotions data was used as an independent variable, no direct relationship would
be established with the demand data for the dependent variable.

The forecast would be unchanged. For example (lumpy demand):

121110987654321Fcst Period
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010000100100Promotion

252525252525252525252525Forecast

However, re-consider the historical data and note that the promotion precedes the peak demand by
two periods in each case.

121110987654321History Period

10101001010101010010101010History

000010000100Promotion

This situation could arise if the customer used existing stocks to supply the promotion and re-orders
afterwards. Independent Variables may be applied to a dependent variable with a specified lag. In the
above example, the correlation is re-established with a lag of 2 and the following forecast would result.

121110987654321Fcst Period

001000100100Promotion

100101010100101010010101010Forecast

Note that the peaks of demand have now been correctly forecast 2 periods ahead of the promotional
event. This now models the historical situation. A full picture is:

121110987654321Period

10101001010101010010101010History

000010000100Promo (Hist)

             

001000100100Promo (Fcst)

100101010100101010010101010Forecast

Additional information
The regression data used in the model fitting is centred data. This means that the independent variable
data has been treated by calculating the mean of the history and forecast and then deducting the mean
from all data points. This is done to negate an effect called "confounding".

When generating forecasts, the validity of independent variables will be examined. If a Channel Product
is encountered that has an invalid causal model, for example, an independent variable has been
changed to a Slow Moving Product after being selected as an independent variable, the Channel
Product will be put into the exception view "CAUSAL MODEL INVALID", a Channel Product where the
causal model is invalid.

In the case of an invalid causal model exception, no model is fitted to the Channel Product (dependent
variable) and any existing statistical model should be assumed to be invalid. This Channel Product
should be examined in Edit Forecasts.
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When generating forecasts, the selected Channel Products are ordered in such a way so that those
with a causal model are processed last. This is so that if there are any dependent variables selected
whose independent variables are also selected, the dependent variable uses the up to date forecast
for the independent variable.

If independent variables are selected but their corresponding dependent variables are not, the statistical
model for the dependent variable will not be updated.

During a period end roll forward, if a causal model is deemed invalid the statistical model is rolled
forward as normal and the Channel Product is put into the exception view "CAUSAL MODEL INVALID",
a Channel Product encountered during roll forward where the causal model is invalid.

All messages triggered while you are operating in the Causal Modelling dialog are sent to the Message
area on that dialog box. It is advisable to check this area after each action. Messages are not cleared
until replaced by a subsequent message. An audible tone indicates that a new message has been
posted.

Applying independent variables
Causal modeling is a technique performed as part of the statistical forecasting routine. Its purpose is
to provide an additional forecasting facility by the introduction of the ability to regress a number of
independent variables against a dependent variable.

See "About causal modeling" on page 302.

1 In Demand Forecaster, select the desired Product and Channel.
See "About selecting Products and Channels" on page 35.

2 Select Modules > Demand Forecasting > Edit Forecasts.
The five Edit Forecasts windows are displayed.

3 Select Model > Causal Modelling.
The Potential Independent Variables dialog box is displayed.

4 Select the range of items from which independent variables may be selected.
5 Click Next. The Causal Modelling dialog box is displayed.
6 To choose a Channel Product potential independent variable, click CP Potential Independent

Variables then select a Product and a Channel from the lists.
7 To choose a time phased weighting potential independent variable, click TPW Potential Independent

Variables then choose System, Product or Channel Product TPW and select the TPW from the
displayed list.

8 Transfer the selected independent variables to the Causal Factors - Variable and Lag Selection
panel by clicking to highlight and select then clicking Add Selection.
Checks are carried out to determine whether the selected Channel Product and/or TPW are suitable
to be used as an independent variable. If not, information to this effect is displayed in the Messages
panel. Click the independent variable selected and click Remove Selection to cancel the selection.
See "About independent variables selection messages" on page 307.

9 If required, enter a Lag number in the column to the left of the selected independent variable to
cause an offset between the independent variable data and the dependent variable.
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This lag may vary from zero (no offset) to a maximum figure such that there are enough time periods
to match the dependent variable’s length after the lag has been taken into account. This must still
allow for at least 2 years worth of dependent variable history to be used. Negative lag is not supported.

10 Click View Data to display a graph of the dependent variable and all the selected independent
variables.
The trace beyond the Now line shows the forecast for the Independent variables only. As indicated
in the text of the window, the scale used reflects the values of the dependent variable. The values
of the independent variable are adjusted when displayed on this scale.

11 Click Back to close the window and return to the Causal Modelling dialog box.
12 Click Fit Model to calculate a new forecast model incorporating the effects of all the independent

variables selected.
13 Click View Fit to display a graph, which shows the original history of the dependent variable together

with the Original Fit and the New Fit. The Original Fit is the model relating to the selected Channel
Product before the addition of the new independent variables. The New Fit includes all the selected
independent variables.

14 Click Back to close the window and return to the Causal Modelling dialog box.
15 Click OK if you are happy with the forecast created.
16 Select File > Save.

About independent variables selection messages
As independent variables are selected, messages may be displayed which indicate various features
of the independent variables selection. The following is a complete list of these messages together
with an explanation for each:

ExplanationMessage

The Channel Product selected to be the independent variable is the
same as the Channel Product used as the current dependent variable.
No selection is added.

"No independent variable se-
lection has been made as the
product is the same as the
dependent variable product"

A Channel Product has been selected as an independent variable
which itself has a causal relationship as part of its forecast model. The

"The potential independent
variable already has a causal

use of such a Channel Product as an independent variable is not al-
lowed. No selection is added.

model associated with it so
cannot be used"

If this message is displayed and a selection has been made, a system
error has occurred. There has been a general failure in the Product,

"No independent variable se-
lection has been made"

Channel, and TPW list boxes. Contact Infor Demand Planning technical
support for further advice.

A negative value has been entered in the Lag column of the selected
independent variables. This relationship is not supported by the system.

"The lag cannot be negative.
Please enter an integer
greater than or equal to 0" A positive value in this column causes the system to relate a dependent

variable event to an independent variable event that occurred earlier.
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The history length of the selected independent variable is shorter than
that of the current dependent variable. In order to fit a causal relation-

"The history for the dependent
variable has been shortened

ship the system reduces the effective history length of the dependentto match the independent
variable history length" variable by setting the history marker at a position such that the history

length used in the model matches the available history for the indepen-
dent variable. If the selected independent variable is confirmed the
system prevents the history marker being subsequently moved to an
earlier date.

The history length of the proposed independent variable is longer than
that of the current dependent variable. In order to fit a causal relation-

"The history for the proposed
independent variable has

ship the system reduces the history length of the independent variablebeen shortened to match the
such that the history length used in the model matches the available
history for the dependent variable.

independent variable history
length"

The history length of the proposed independent variable is less than
the 2 years required by the system to calculate a causal relationship.
It is therefore invalid and no selection is added.

"The history for the proposed
independent variable is not
long enough. It needs to be at
least 2 years long"

The View fit selection has been made before Fit Model. No model is
available and View Fitcannot be used. Click Fit Model to proceed.

"You have not fitted a model
to this selection of indepen-
dent variables. Please do so
before continuing"

A maximum of 7 independent variables may be included in the model
calculation. If more are selected and Fit Model clicked this message

"7 independent variables is
the maximum allowed due to

is displayed. Select each independent variable to remove to reducedatabase restrictions. Please
the selected number to 7 and click the Remove Selection button for
each selection before proceeding.

reduce your selection to 7 or
less and refit the model"

The same independent variable has been selected more than once.
When Fit Model is clicked this message is displayed. Select each du-

"There have been duplicate
independent variables added.

plicated independent variable and click the Remove Selection button
for each selection before proceeding.

You must remove the dupli-
cates or ensure the lag value
is different before continuing"

The system has detected that a Product type other than standard or
a dead product has been selected as an independent variable. The

"Product type or status of inde-
pendent variable is not cor-

selection is not valid and is not added to the selected independent
variable list.

rect. It should be of STAN-
DARD type and live status.
Independent variable not
added"

The independent variable forecast is not as long as that for the depen-
dent variable. This is an abnormal situation. All forecasts should always
be out to the forecast horizon.

"Independent variable forecast
is too short. See Help"

The demand calendar is allocated at Channel level. If the demand
calendar for the independent variable differs from that allocated to the

"Demand calendar of indepen-
dent variable does not match

dependent variable a causal link cannot be established and the inde-
pendent variable is rejected.

the dependent variable. See
Help"
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The system has detected that a Slow Moving Product (SMP) has been
selected as an independent variable. SMPs cannot be used as inde-

"Independent variable is an
SMP. This is not allowed. See
Help" pendent variables and is not added to the selected independent variable

list.

The usable history length of an independent variable must be at least
2 years. A lagvalue has the effect of reducing the useable history length

"Invalid Lag value - the inde-
pendent variable must have
at least 2 years of history" by the length of the lag. If this reduction causes the useable history to

fall below the 2 year minimum period the lag value is rejected.

Only positive whole numbers may be used as lag values. Decimal
values are not supported by the system and the lag value is rounded
down to the next whole number.

"The lag cannot be non-inte-
ger. Please enter an integer
greater than or equal to 0"

Interpolation Vectors

About interpolation vectors
Interpolation vectors are of two types:

• Month-to-weeks, used to derive weekly forecasts from a monthly forecast.

• Week-to-days, used to derive daily forecasts from a weekly forecast.

Note that interpolation vectors are only applied to forecast data, and never to historical data. If weekly
or daily history is required, it must be imported separately.

Each interpolation vector must be associated with a named demand calendar. The demand calendar
must be of the 4-4-5 or 13 equal periods type (because only these types have an integer number of
weeks in every month), and must be applied to at least one Channel.

See "About demand calendars" on page 170.

What’s in an interpolation vector?
An interpolation vector consists of a set of one or more default and date-specific period vectors.

• Default period vectors

The default period vectors are automatically included in every new interpolation vector. The default
vectors for a month-to-weeks interpolation vector are:

Total654321 

1.0  0.250.250.250.25Default 4 Week

1.0 0.200.200.200.200.20Default 5 Week
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1.00.170.170.170.170.170.15Default 6 Week

The default vector for a week-to-days interpolation vector is:

Total7654321 

1.00.140.140.140.140.140.140.16Default 7 Day

• Date-specific period vectors

As their name suggests, within an interpolation vector you can add your own period vectors for particular
months (in a month-to-weeks interpolation vector) or weeks (in a week-to-days interpolation vector).
For example, April (in which Easter usually falls) probably has a different demand spread than December
(in which Christmas falls).

Periods that do not have their own date-specific vectors use the appropriate default vectors instead.

A Channel Product can have only one associated interpolation vector. If a Channel Product has no
specific interpolation vector, Infor Demand Planning uses the appropriate default vectors instead.

See "Example of a month-to-weeks interpolation vector".

How are interpolation vectors defined?
There are two ways to define interpolation vectors:

• In Database Administration, you can define each interpolation vector manually and apply it to one
or more Channel Products.

See "Applying an interpolation vector to a Channel Product" on page 187.

• In Demand Forecaster, you can select a temporary forecast group (TFG) of Channel Products and
have Infor Demand Planning automatically calculate an interpolation vector for them from their
combined histories.

See "About the automatic calculation of period vectors".

If you edit an interpolation vector, this change may not be immediately apparent to other Infor Demand
Planning users because some data is cached locally. Users may have to log off from Infor Demand
Planning and then log on again to see the changed vector.

Creating an interpolation vector
1 In Demand Forecaster, select the Channel Products to include in the temporary forecast group

(TFG).
See "About selecting Products and Channels" on page 35.

2 Select the Group check box on the toolbar.
3 Select Modules > Demand Forecasting > Edit Forecasts.
4 Select Model > Automatic Calculation of Interpolation Vectors.
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The first Automatic calculation of month to week interpolation vectors dialog box is displayed.
5 Click Create a new interpolation vector and click Next.

A second Automatic calculation of month to week interpolation vectors dialog box is displayed. At
first, the new interpolation vector is unnamed and contains only the three default 4-week, 5-week
and 6-week vectors.

6 Type a Description for the new interpolation vector.
7 Click Create date-specific vector.

The Create date-specific period vector dialog box is displayed.
8 From the Date list box, select the period end date of the forecast period to which this vector relates.
9 Type a Description for the period vector.
10 Click Generate period vector.

The Select dates to generate from dialog box is displayed.
11 Select the historical periods from which you want to calculate the new period vector. To select all

available historical periods, click Select All.
Infor Demand Planning ignores any selected periods that do not contain the same number of weeks
as the period specified at step 8. Infor Demand Planning calculates the period vector as you select
the periods.

12 When you are satisfied, click OK to return to the Create date-specific period vector dialog box.
13 If necessary, you can edit the generated values of the period vector in the Values boxes.
14 Click OK to return to the Automatic creation of month to week interpolation vectors dialog box.
15 Repeat steps 7 to 14 until you have added all the required period vectors to this interpolation vector.
16 Click OK.

You are asked whether you want to apply the new interpolation vector to the Channel Products in
the TFG.

17 Click Yes to create and apply the interpolation vector; click No to create it but not apply it.

Note: 

• All of the selected Channel Products must have at least 52 weeks of adjusted demand history.
• You can also, if required, edit the values of the default vectors in the interpolation vector before

saving it.

Editing an interpolation vector
1 In Demand Forecaster, select the Channel Products to include in the temporary forecast group

(TFG).
See "About selecting Products and Channels" on page 35.

2 Select the Group check box on the toolbar.
3 Select Modules > Demand Forecasting > Edit Forecasts.
4 Select Model > Automatic Calculation of Interpolation Vectors.

The first Automatic calculation of month to week interpolation vectors dialog box is displayed.
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5 Click Update an existing interpolation vector, select the interpolation vector you want to edit,
then click Next.
A second Automatic calculation of month to week interpolation vectors dialog box is displayed,
showing the default and period vectors of the chosen interpolation vector.

6 To rename the interpolation vector, edit the description in the Description box.
7 To create a new period vector, click Create date-specific vector.

You can specify the values of this vector directly, or generate values from the combined histories
of the Channel Products in the TFG.

8 To edit an existing default or period vector, select the vector and click Edit selected vector.
You can change the description and any of the vector's values. You can edit the values directly, or
generate new values from the combined histories of the Channel Products in the TFG.

9 To delete a period vector, select the vector and click Delete selected vector.
10 Repeat steps 7 to 9 until you are satisfied.
11 Click OK.

You are asked whether you want to apply the edited interpolation vector to the Channel Products
in the TFG.

12 Click Yes to save and apply the interpolation vector. Alternatively, click No to save it but not apply
it to the TFG.
In the latter case, the changes affect only the Channel Products to which the interpolation vector is
already applied.

Force Model

About forcing a model
The Demand Forecaster module gives you the facility to force a forecast model down from an aggregate
Channel to the lower Channels in your Channel matrix. The function takes the statistical model defined
at the selected upper level aggregate Channel and forces the model and forecast down to all lower
level Channels in the Channel matrix.

Because this facility has the ability to affect the forecast of a large number of Channel Products, it
requires the necessary level of access privileges to gain access to the function.

Running the process will remove all previous statistical model information from any of the target
Channels, including step changes, growth damping factors and causal model information. The process
will then add a new statistical model that will be a scaled down version of the model held at the aggregate
Channel. The statistical forecast from the aggregate level will also be scaled down and stored at the
subordinate Channels.

Note: 
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• This function will only force a model down a Channel structure. Where there is a folded Channel
structure no attempt will be made to sum models up through different arms of a folded V type
structure.

Forcing the model
1 In Demand Forecaster, select Modules > Demand Forecasting > Force Model.

The Force model wizard is displayed.
2 Confirm that you want to force the current selection of Products then click Next or re-select different

Products and click Next, then OK when selected.
See "About selecting Products and Channels" on page 35.

3 Click the aggregate Channel to force from.
4 Choose to use existing DLM parameters or to define new ones.

See "About parameter sensitivity" on page 222.

5 Choose to scale the variance from the aggregate Channel or select a variance estimate from the
list.
See "About variance estimates" on page 299.

6 To delete any existing market intelligence at the lower level Channel Products, select the Remove
MI from target CPs check box.

7 To force down existing effectivity or discontinuation dates from the aggregate Channel, select the
Force down effectivity / discon dates check box.

8 Click Next.
9 If you chose to define new DLM parameters, select the new Discount factor code from the list and

type values for the following:

• Maximum model terms (integer between 2 and 14 inclusive)
• Level shift inflation factor (between 0 and 99.9 inclusive)
• Level shift threshold (between 0.001 and 1 inclusive)
• Confidence for seasonality (between 0 and 100 inclusive)
• Confidence for causal factors (between 0 and 100 inclusive)
•

10 Click Next.
11 Choose to use predefined forcing factors or define temporary ones.
12 Select the Channel matrix to use from the list.

See "About Channel matrices" on page 78.

13 If you wish to save the factors defined, select the Save temporary factors check box. The factors
are saved in the field, "Forecast Forcing Factor (CPt)" for all the processed Channel Products at
the lower levels.

14  If you have selected Define temporary factors, type a Factor against each subordinate Channel.
15 Click Finish.
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Sales and Operations Planner

About S&&OP plans and budgets
Budgets may be assembled and production plans and actuals posted to the database within the
Replenishment Planner module.

Sales & Operations Planner must first be configured before these options become available.

See "Configuring Sales and Operations Planner" on page 202.

In addition, S&OP functions must be enabled for the relevant Channel Products.

See "Enabling Channel Products for S&OP and SBT" on page 204.

Posting sales plans
1 In Demand Forecaster, select the Channel Products for which you want to post sales plans.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Sales & Operations Planner > Post Plans.
The Post Plans dialog box is displayed.

3 In the Plan panel, select the plans you wish to post:

• S&OP Sales Plan 101 (net forecast including customer forecast)
• S&OP Sales Plan 102 (DRP requirements including dependent demand)
• S&OP Sales Plan 103 (statistical forecast)
• S&OP Sales Plan 104 (total demand: 101 + 102)

4 In the Post panel, choose to either insert new or update existing plans in the S&OP Sales Plans
table (SOP_SALES_PLANS), or insert temporary plans in the S&OP Temporary Sales Plans table
(SOP_SALES_TMP).

5 Click OK.
See "About S&&OP plans and budgets" on page 314.

Note: If you want to store the net forecast without the customer forecast, ensure customer forecasts
are disabled before posting the plans. To do this, set Periods Of Customer Forecast (CPt) to zero
for the relevant Channel Products. See "Periods Of Customer Forecast (CPt)".

Making a sales budget
1 In Demand Forecaster, select the Channel Products for which you want to create a budget.
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See "About selecting Products and Channels" on page 35.

2 Select Modules > Sales & Operations Planner > Make Budget.
The Make Budget dialog box is displayed.

3 Under Post Budgets For, specify whether you want to create a budget for this year, next year, or
both.

4 Select the budget name and the plan type for each budget from the Post Budgets As and Post
Plan Type list boxes and click Add Budget.
Up to four budgets are allowed.

5 Click OK.

Note: 

• It is possible to store all four plan types to separate budget rows, or store a single plan over four
revisions. Any of these budgets can then be reported.

• Budgets may also be imported using the normal import routines in the Database Administration
module.

See "About S&&OP plans and budgets" on page 314.

Posting sales actuals
1  In Demand Forecaster, select the Channel Products for which you want to post sales actuals.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Sales & Operations Planner > Post Actuals.
The Post Actuals dialog box is displayed.

3 In the Post panel, select the actuals to be posted.
Shipments can be posted prior to the period end roll but adjusted demand can only be posted after
the period end roll.

4 Click OK.
See "About S&&OP plans and budgets" on page 314.

Period End

Period end stages
For databases using Sales and Operations functionality, period end is split into three stages. These
stages are:
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Pre-roll S&OP process
• Post DRP requirements

• Post requirements plans

• Post actual shipments

• Post production to date

• Post inventory actuals

Main period-end process
• Roll the database forward

Post-roll S&OP process
• Post sales actuals

• Post sales plans

• Post inventory plans

About the pre-roll S&OP process
The timing of posting data during an S&OP process is critical. Because period end processing is rarely
run at the physical month end, some of the S&OP data would be out of date and therefore inaccurate.
Data that needs to be updated prior to running period end at the actual month end date is listed below.

This data can be split into two:

• Data that can be populated automatically as part of the pre-roll S&OP processing routine:

• DRP requirements including dependant demand if the database is set to store DRP
(SOP_SALES_PLANS type 102).

• Requirements plans (SOP_REQS_PLANS Type 101).

This means that Channel Products using DRP and/or dependent requirements can be reported
immediately after period end.

• Data that must be populated using import routines or interfaces:

• Actual shipments ("Open Ship (CPt)").

• Production to date ("Production This Period (CPt)").

• Inventory actuals ("Opening Stock (CPt)" and "Due In Stock (CPt)").

Prior to rolling the database forward, the shipment, requirements and inventory actuals for the period
must be posted to the S&OP tables. Before this is done, however, it is essential to have imported the
latest shipments from the source Channel to the "Open Ship (CPt)" fields, actual production for source
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Channels and shipment receipts for subordinate Channels that are passing up requirements to the
"Production This Period (CPt)" field and the latest stock position for all Channels must also be posted
to the "Opening Stock (CPt)" and "Due In Stock (CPt)" fields.

The DRP shipment values in the "Open Ship (CPt)" field are posted to SOP_SALES_BDATS Type 304
for each Channel Product where the "Store SOP Data (CPt)" field is set to 1 (true) and "S&OP Data
Stored (St)" is set to 2, 3, 4 or 5.

The values in the "Production This Period (CPt)" field are posted to the Requirements actuals
(SOP_REQ_BDATS type 301) for each Channel Product where the "Store SOP Data (CPt)" field is set
to 1 (true) and the "S&OP Data Stored (St)" is set to 2 or 3.

The values in the "Opening Stock (CPt)" and "Due In Stock (CPt)" fields are posted to the Inventory
table (SOP_INV_BDATS Type 301) for each Channel Product where the "Store SOP Data (CPt)" field
is set to 1 (true) and "S&OP Data Stored (St)" is set to 2 or 3.

For each Channel Product where the "Store SOP Data (CPt)" field is set to 1 (true) and "S&OP Data
Stored (St)" is set to 2, 3, 4 or 5, actual shipment values are copied from "Open Ship (CPt)" to
SOP_SALES_BDATS Type 304.

During the period end process, the "Open Ship (CPt)" and "Production This Period (CPt)" fields are
zeroed for all Channel Products in order to have a starting point of zero for the new period. The "Opening
Stock (CPt)" and "Due In Stock (CPt)" fields are not changed.

Note: 

• Actuals, plans and budgets for both sales and requirements can be posted manually in the
Replenishment Planner and Demand Forecaster modules.

About rolling the database forward

Pre-roll checks
Before the period end process starts, Infor Demand Planning checks that:

• History is available at the Channels that should store history.
• The SBT and/or S&OP tables (if in use) have been rolled forward for the last month.
• All calendars are extended far enough forwards to deal with another month of forecast.
• All interpolation factors are extended far enough forwards to deal with another month of forecast.

If the history is not yet available, or the SBT/S&OP tables have not been rolled forward for the last
month or any of the calendars or interpolation percentages are not set far enough into the future the
forecast roll is aborted and an appropriate message displayed.

Period end roll
All non-steward users are locked out when a master client starts a period end roll. The Locked Out
fields of the User List table are set to 1. When the roll has completed, successfully or not the fields are
set back to zero.
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The history tables are moved back one period and any ‘excess’ history is archived. Excess history is
history that exceeds the value in the following system fields appropriate to each periodicity:

• "Monthly History Retained (Months) (St)"
• "Weekly History Retained (Weeks) (St)"
• "Daily History Retained (Days) (St)"

The "Date Demand Last Updated (Ct)" field is set to the month end date for the month to be rolled into
history. The date used is the month end date accessed from the current demand calendar, stored in
"Demand Calendar Code (Ct)".

The system checks if the above date is the last in the fiscal year and, if so, runs year end processes
to update SBT tables. Additionally, "End Of Current Financial Year (Ct)" is set to the next fiscal year
end date and "Current Period Fiscal (Ct)" is set to zero.

Where "Date Demand Last Updated (Ct)" is not the last in the fiscal year, "Current Period Fiscal (Ct)"
is incremented by one.

If sufficient data is not available to roll future forecast periods then the "Forecast Revision Possible
(Ct)" field is re-set to zero and the process ended. Otherwise, each item is processed and rolled forward
through one month. A series of exception views are created and those from the previous month end
are deleted.

Live items are checked to determine to which Product type they have been assigned. If they are standard
items a further check establishes if they are parents of a marketing group. This enables the relevant
sub-process to be run.

Once the last item on the database has been processed a sequence of sub-processes are run to deal
with successor/predecessor history sequences, then forecast group items, and finally to populate the
SBT tables. The Open History table is then purged of all data prior to the end of the last month of history
and the Channel Product field, "Adjusted Monthly Demand (CPt)" set to null for all Channel Products.
Any daily, monthly or complete weekly history data with dates equal to or earlier than the month end
date just processed are removed. Any incomplete weekly data are adjusted so that the value left in the
Open History table only reflects the new first forecast month. Month end roll summary and error reports
are produced, and the database unlocked.

Depending on the status and type of Channel Products in the database, the following sub-processes
are carried out:

Standard Items
This sub-process is used for normal forecasting or SMP items. It is not used for dead items, UFPs,
NSPs, parents of marketing group views or forecasting group items.

A check establishes which forecast calculation code is set up in the "Forecast Calculation Code (CPt)"
field. This check establishes if there is a statistical model to be smoothed. If the value is 3 or more, the
Channel Product uses a user defined forecast routine. If the value is 1 (do not forecast) or 2 (create
initial forecast but do not smooth) then no smoothing is required.

A check determines if the Channel Product would be potentially better treated as an SMP. This is the
case if the number of months with 0 or less demand (from the history row defined by Channel Products
table field, "Forecast History Row (CPt)" in the last year (including the new monthly history being rolled)
exceed the value of the "Minimum Periods For SMP (CPt)" field. If this is the case, the Channel Product
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is appended to an exception view ("POSSIBLE SMP"), in which the situation may be reviewed. The
Channel Product continues to be processed as a normal item.

The forecast information is passed to the Bayesian Time Series (BATS) modeling function. The forecast
is smoothed and the model information used to create a new forecast for the whole of the forecast
horizon, based on the model coefficients of level, growth and seasonality. Any existing growth damping
factors are applied to the model. Changes to level or growthas indicated by an entry in the "Future
Change Level Or Growth (CPt)" field are applied.

The two Channel Products table fields, "Start Period To Freeze Net Forecast (CPt)" and "End Period
To Freeze Net Forecast (CPt)" are checked as entries in these fields indicate that there are forecast
periods in which the forecast must remain frozen. If so, the net forecast in the periods defined by the
fields are adjusted with N-type MI so that it remains unchanged.

Dead items
A dead item is one that no longer carries a current forecast. It has been left on the database with its
history still visible so it can be used to help build profiles and to provide accurate summations of history.
The only period end processes undertaken with dead items are to ensure that various Product and
Channel Products table fields have settings appropriate to dead items, and as with all other Product
types, Sales and Operations Planner fields are populated and rolled in the normal way.

Unspecified Forecasting Products
UFPs are normally new Products with no demand history and therefore no statistical forecast. However,
they can hold market intelligence and customer forecasts. The period end processing of UFPs involves
storing any customer forecasts, setting up sensible defaults in the table fields, rolling the forecast
horizon, removing any statistical forecasts currently held for the UFP and rippling the forecast through
the Channel structure.

Slow Moving Products
If there is any monthly demand in the row defined by the Channel Products table field, "Forecast History
Row (CPt)" and if the Channel Product has a code of 1 in Channel Products table field, "SMP Code
(CPt)", then a check is carried out to establish if the Channel Product might be better forecasted as a
normal Channel Product. If so the Channel Product is appended to an exception view "POSSIBLE
NORMAL".

For SMPs with demand in the last month, the forecast information is passed to BATS and the SMP
forecast routine carried out. The information is received back from BATS and where indicated, the
Channel Product added to the exception views "OUTLIERS" and "TRACKING". The required table
fields are updated.

If there is no demand in the month being smoothed, the Channel Product is tested to see if the current
string of zero demands is greater than 5 forecast periods, and equal to or greater than the longest
previous string of consecutive zero demand periods. If so the Channel Product is appended to the
exception view "SMP LONG GAP". This list may assist a possible decision to delete the Channel
Product.
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The forecast for SMPs cannot contain step changes. All SMPs are tested as part of the period end
routine to establish if there are any future changes in level registered for the item in the step change
table. If so, they are removed, and "Future Change Level Or Growth (CPt)" is set to false.

The two Channel Products table fields, "Start Period To Freeze Net Forecast (CPt)" and "End Period
To Freeze Net Forecast (CPt)" are checked. Entries in these fields indicate that there are forecast
periods in which the forecast must remain frozen. If so, the net forecast in the periods defined by the
fields are adjusted with N-type MI so that it remains unchanged.

If the "Discontinuation Type (CPt)" denotes an automatically calculated date, any forecast that extends
beyond the calculated discontinuation date is removed. If "Automatically Update Successor (CPt)" is
true, then the effectivity date of a valid successor is set equal to the discontinuation date of the current
Channel Product.

Non-Standard Products
Non-Standard Products (NSPs) are items, which do not have a statistical forecast. An NSP may be a
member of a promotional group, in which case it is directly related to a standard parent item or it may
be a promotional item, which has no direct or obvious parent. This structure is provided to forecast
items with short sales lives purely using market intelligence.

Since they do not have a statistical forecast, they are not smoothed through BATS or carry future
changes in level or growth. There is no requirement for freezing the net forecast and no facility to set
up successor/predecessor products is provided. There is no option to store customer forecasts for NSP
items.

At period end, the rolling process:

• Moves any history to the History table from the Open History table and Channel Product field,
"Adjusted Monthly Demand (CPt)".

• Moves any TPW values from the first monthly forecast period to the new last period of history.
• Rolls the forecast horizon.
• Sets any statistical forecasts to zero.
• Optionally, rolls forward any over or undersold vales to the following forecast periods and produces

NSP exception views.
• Ripples the forecasts through the Channel structure.
• Sets up the relevant table fields for NSPs.

Where the Channel Products table field, "Roll Forward NSP Forecast (CPt)" switch is on, any over or
under sell in a month with a forecast is rolled forward into the next few forecast periods to adjust the
MI held in those future periods.

If there is no further future T-type MI with the same identifier then any remaining MI, because of an
undersell, is placed in the next forecast month. In this case any negative MI carryover because of an
oversell is lost, as the MI may not be negative.

Where there is a positive carry over and there are future months with the correct MI (same identifier)
then all the MI numbers in these future periods are adjusted proportionally to the current MI (same
identifier) value held for those months. For example, consider what should happen with a carry forward
of 34 units to be spread across three months holding forecasts of 100, 50 and 20.
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The new forecast for each month = Original MI qty for month + ((Carry over qty / sum of all future MI)
x Original MI qty for month). Therefore:

The new MI for future month 1 = 100 + ((34/170) x 100) = 120

The new MI for future month 2 = 50 + ((34/170) x 50) = 60

The new MI for future month 3 = 20 + ((34/170) x 20) = 24

This process has inflated the original sum of future MI from 170 to (120 + 60 +24) 204, which is 34
units greater This is the value to be carried over.

Where there is a negative carry over because of an oversell, and there are future months with MI with
the same identifier then the last of these months is reduced by the carry over quantity. The MI value
in the last month is reduced to zero but no further. Any further required reductions can be made to the
next previous month again with the limit that it can only be reduced to zero, and so on.

Marketing group parent items
The process to roll period end for a marketing group parent item is similar to the process for a standard
item. The parent item is usually a normally forecasted item, but there is the chance that it could be set
up as a SMP.

A marketing group parent item, however, can not be a dead item, a UFP, an NSP or a forecasting
group item. The main difference is the need to aggregate the demand from the NSPs which are part
of the marketing group view, to compare with the aggregate forecast across the group.

The net MI across the marketing group view at each Channel is calculated as follows:

Parent MI + ∑ from each NSP belonging to the marketing group view NSP MI x Products table field,
"NSP Weighting Factor (Pt)".

This aggregated MI is subtracted from the aggregated adjusted demand calculated for the parent item
to give a net demand, which is used to smooth against the statistical forecast in BATS.

When the Channel Products table fields, "Forecast Last Period (CPt)", "Market Intelligence Last Period
(CPt)" and "Demand Last Period (CPt)" are populated the values entered for the parent item are the
aggregated values for the whole marketing group view.

Forecast Group Products
A forecast group item has forecast and history constructed from a defined group of normal items. This
sub-process is run once the last of the individual items has been rolled. Each of the forecast groups is
treated individually. The Channels where history should be stored in the History table are identified
from the Channel matrix, referenced by the Products table field, "Channel Matrix Code (Pt)", row 2 of
the matrix is "Yes". The required history types at these Channels are then calculated by extracting the
history stored in the equivalent history type at that Channel for the member items of the group (or from
the Channels defined by row 13 of the Channel matrix for the member item which are used to provide
the aggregate history to that Channel). This extracted history is multiplied by the relevant weighting
factor and summed with the history from the other member items to give the required total for the group
item.

Once the last member item has been processed and all the group item history has been calculated,
then the value for Channel Product fields, "Adjusted Monthly Demand (CPt)", and "Demand Last Period
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(CPt)" are set up as the value in the last period of adjusted demand history, for the Channels which
store history. These values are aggregated to the Channels, which do not store history.

From this point onwards the forecast group item is processed as a standard item, except for the
sub-process to transfer history, which is not run.

Note: The fields normally updated during the period end roll are not updated if the Channel Product
has an invalid statistical model. The offending Channel Product is included in the "INVALID STAT"
exception view.

About the post-roll S&OP process
The following are automatically updated during the post-roll:

• Sales actuals (SOP_SALES_BDATS Type 301) ) previously imported prior to the period end for
forecasting analysis using the import routines or interfaces.

• Sales plans. Net, stat and total, if the database is set to store these (SOP_SALES_PLANS Types
101, 103 and 104).

• Inventory plans. Based on changes to the forecast together with requirements figures posted during
the pre-roll S&OP process (SOP_INV_PLANS type 101).

Sales actuals for the current period are set to zero at the beginning of the roll and re-populated, in case
sales actuals have been populated prior to the roll.

Note: 

• The above values can be posted manually in the Replenishment Planner and Demand Forecaster
modules.

See "Manually posting S&OP data".

Period end procedures
These are the functions regularly performed at period end:

• Import Product and Channel Product files

• Import the latest demand and/or sales

• Review the Demand Analysis report

• Edit adjusted demand as required

• Import the latest time-phased weightings

• Backup the database

• If S&OP has been activated, run the pre-roll S&OP process. The following are posted:
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• DRP requirements

• Requirements plans

• Actual shipments

• Production to date

• Inventory actuals

• Roll the database forward (main period-end process)

• If S&OP has been activated, run the post-roll S&OP process. The following are posted:

• Sales actuals

• Sales Plans

• Inventory plans

• Review any exception views created

• Review the Accuracy Data report

• Review and evaluate the Market Intelligence Effectivity report

These functions are performed using the Demand Forecaster (DF), Replenishment Planner (RP) and
Database Administration (DBA) modules.

See "Configuring Sales and Operations Planner" on page 202.

Rolling the database forward (master)
In order to run period end, you must be a steward. More than one user may carry out the roll forward
simultaneously, acting as a slave client to the master client. By starting a slave client roll, the database
is segmented into areas and the month end roll is subsequently processed faster.

A check is performed to see if another client has already begun the roll, and assuming the current
session is the start of the process an information box advises that the current session will become the
master client.

Before starting this process you must backup the database.

1 In Demand Forecaster, select Modules > Demand Forecasting > Period End > Roll Forward.
2 Click OK.
3 Click Yes only if you have backed up your database.

The Period End Stages dialog box is displayed.
4 Select the stage or stages to be run in this session. The stages must be run in the sequence

displayed:

• Pre-roll S&OP process
• Main period-end process
• Post-roll S&OP process

Infor Demand Planning User Guide | 323

Demand Forecaster



5 Click OK.
The Infor Demand Planning  - Client:1 (Master) dialog box is displayed.

6 Click OK on completion.

Note: When a master client starts a period end roll, all non-steward users are locked out of Infor
Demand Planning until the process has completed, successfully or not.

Rolling the database forward (slave)
In order to run period end, you must be a steward. More than one user may carry out the roll forward
simultaneously, acting as a slave client to the master client. By starting a slave client roll, the database
is segmented into areas and the month end roll is subsequently processed faster.

A check is performed to see if another client has already began the roll, and if so, an information box
advises that the current session will become a slave client to the pre-existing master client.

Before starting this process you must backup the database.

1 In Demand Forecaster, select Modules > Demand Forecasting > Period End > Roll Forward.
2 Click Yes only if you have backed up your database.

The Infor Demand Planning - Client:X (Slave) dialog box is displayed.
3 Click OK on completion.

Period end exception views
Following the completion of the period end roll, a number of exception views are created. These views
highlight Channel Products that may need intervention and should be prioritized for review, as each
anomaly found could be having a negative impact on forecast performance and safety stock levels.
Reviewing these exceptions on an ongoing basis will help ensure a higher quality statistical forecast.

The possible exception views are:

Action requiredMeaningException view

Consider re-fitting over a different
history length or applying a
growth damping factor

A Channel Product where the
new statistical model trends to
zero within the monthly forecast
horizon

"ALL TIME SUPPLY"

Ensure that the safety stock per-
formance level is set to the re-
quired value

A Non-Standard Product with an
invalid safety stock code. The
code will have been reset to 6
(fixed quantity) and safety stock

"BAD NSP SS CODE"

performance level will have been
set to zero
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Either break the predecessor
successor link or add the re-

A Product’s successor does not
exist at a Channel

"BAD SUCCESSOR CP"

quired successor Channel Prod-
uct to the database

Either correct or remove the
causal relationship

A Channel Product encountered
where the causal model is invalid

"CAUSAL MODEL INVALID"

Change the Channel vector set-
tings to be logically consistent

A Channel Product with an invalid
Channel matrix

"CHANNEL MATRIX ERROR"

Review whether Product should
still be classed as dead or if a
forecast should be reinstated.

A dead item with history for cur-
rent month in Open History table
or in Channel Products table
(adjusted monthly demand)

"DEAD WITH HISTORY"

Confirm that the Channel Product
does not require smoothing

A normal Channel Product (not a
dead item, an NSP or a UFP)
which is not smoothed at month

"DO NOT SMOOTH"

end because the value of the
"Forecast Calculation Code
(CPt)" field is set to 1 (do not
forecast) or 2 (initialize forecast
but do not smooth)

Either reduce the number or days
or extend the forecast horizon

Number of days stock cover,
based on the monthly net fore-
cast, exceed the (monthly) fore-
cast horizon

"FCST HOR SHORT"

Ensure that the MI is still validA Channel Product with N-type
MI

"FROZEN MI"

Ensure that the forecast should
have been discontinued and rein-
state if necessary

A Channel Product where history
has been imported after the de-
fined discontinuation date

"HISTORY AFTER DISCON"

Review the effectivity date and
pull forward if necessary

A Channel Product where history
has been imported prior to the
defined introduction date

"HISTORY PRIOR TO EFF"

Check dates in the calendarOne or more dates seem to be
incorrect for this Channel Product

"INVALID DATE"

Break relationship or if required,
set up a valid predecessor rela-
tionship

Invalid predecessor for this suc-
cessor

"INVALID PREDECESSOR"

Re-fit model as either a normal
or SMP Product as required

SMP Channel Product has more
than one model coefficient:
smoothing as a normal item

"INVALID SMP"
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Change the SMP Code (CPt) to
a valid code and re-fit the model

A normal Channel Product (not a
dead item, an NSP or a UFP)
was smoothed as an SMP item

"INVALID SMP CODE"

but there was an invalid value in
the "SMP Code (CPt)" field

Update with a valid code and re-
computed safety stock

A Channel Product which has an
invalid value in the "Safety Stock
Strategy (CPt)" field. No inventory
fields updated

"INVALID SS CODE"

Re-fit the statistical modelA Channel Product with an invalid
statistical model

"INVALID STAT"

Update with a valid codeInvalid value in the Time-phased
"Time-phased Safety Stock Code
(CPt)" field

"INVALID TPSS CODE"

Review and create a forecast
model if required or set "Forecast
Calculation Code (CPt)" to 1

A normal Channel Product (not a
dead item, an NSP or a UFP)
which is allowed to be smoothed
but cannot be processed as there
is no forecast model

"NO MODEL"

Either remove the Channel Prod-
uct from the PFG or add the
Channel to the PFG Product

A Channel Product which is a
member of a PFG, but the PFG
Product does not exist at this
Channel

"NO PFG PARENT CP"

Follow up and rectify for next
forecasting cycle

Channel Products checked out
to the OFW but have not been
checked back in

"NOT CHECKED IN"

Review the NSP forecast and
demand

An NSP with a non-zero history
or forecast in the rolled month

"NSP ACTIVITY"

Review the promotional MI and
increase in the future if necessary

An NSP where the promotional
event MI has been rolled and
been totally consumed by de-
mand

"NSP CONSUMED"

Ensure that the promotional MI
is still valid

An NSP where the promotional
event MI has been rolled forward
into a new month which previous-
ly held no MI for this event

"NSP EXTEND HORIZON"

Review MI for future monthsAn NSP with a positive forecast
in the rolled month, which has

"NSP MI ROLLED"

had later months MI adjusted to
cope with any over or under-sell
in the rolled month
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Review to see if non zero or
negatives are valid

An NSP where demand and or
forecast is negative whilst the
other value is zero or negative in
the rolled month

"NSP NEG VALUE"

Review the promotional sales
and consider amending future
promotional activity

An NSP with a positive demand
value but zero or negative fore-
cast in the rolled month. Early or
late sales outside of the planned

"NSP NO FORECAST"

promotional period will cause this
condition

Review the forecast and correct
if necessary

An NSP with a positive forecast
but zero or negative demand in
the rolled month, this is a typical

"NSP NO HISTORY"

situation where the start of a pro-
motion has been delayed but the
forecast has not been corrected

Review promotional activityAn NSP with a positive demand
value in the rolled month

"NSP WITH DEMAND"

Review promotional forecastAn NSP with a positive forecast
in the rolled month

"NSP WITH FORECAST"

For review by inventory analystsOn hand stock exceeds the max-
imum storage capacity

"OHS OVER MAX"

For review by inventory analystsOn hand stock exceeds the shelf
life

"OHS OVER SHELF"

Review to understand if it is a
one-off (ideally edit) or investigate
amending the forecast

A Channel Product where outliers
have been identified during the
forecast roll

"OUTLIERS"

Either add members or consider
dropping PFG

The PFG(s) had no members and
were not processed

"PFG NO MEMBERS"

Change the code to 0 and re-fit
model

A Channel Product with the "SMP
Code (CPt)" set to 1 (forecast as
an SMP but review for normal

"POSSIBLE NORMAL"

status) where demand in the last
year is sufficient to consider
moving to normal status

Change the code to 1 and re-fit
model

A Channel Product with the
Channel Product field, "SMP
Code (CPt)" set to 0 (forecast

"POSSIBLE SMP"

using normal full BATS process)
which should be considered for
moving to SMP status

Infor Demand Planning User Guide | 327

Demand Forecaster



Review Product and consider
discontinuing

An SMP with long gap in history
(period since the last demand is
greater than 5 months and is

"SMP LONG GAP"

greater than or equal to the
longest gap seen in this Channel
Product’s history)

Ensure that the MI is still validA Channel Product with S-type
MI

"SPREAD MI"

Review limit to ensure service
levels can still be achieved

Safety stock exceeds defined
limits

"TPSS LIMIT"

Review the TPWs for the Chan-
nel Product

A Channel Product time-phased
weighting has failed to roll

"TPW CP ROLL ERR"

Review models and re-fitA Channel Product where a
tracking signal has been generat-

"TRACKING"

ed during the smoothing process
and the forecast has been auto-
matically smoothed using the
system defined fast smoothing
settings

Find out whyA UFP with current history report-
ed. History for current month in

"UFP WITH HISTORY"

Open History table or in the "Ad-
justed Monthly Demand (CPt)"
field

Check that this setting is correctA standard Channel Product
which uses a customer defined

"USER ROLLED"

forecasting routine for smoothing
at month end

Viewing a Demand Analysis report
1 In Demand Forecaster, select Modules > Demand Forecasting > Period End > Demand Analysis.

The Demand Analysis dialog box is displayed.
2 On the Main tab, select the following:

• History to compare

• MTD (first forecast period)
• MTD (to date)
• Last Month

• History type

• Default
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• Sales
• Demand
• Adjusted demand

• Options

• Transfer NSP History
• Sum Forecast Groups
• Generate exception view
• Show description

3 On the Report tab, select the criterion you want the exceptions reported by.
4 On the Sort tab select the fields to sort and weight the report by.
5 Click OK.

The Channel Dates Confirmation dialog box is displayed.
6 Check that the latest demand has been loaded successfully and click OK.

Viewing Accuracy Data
1 Select the Channel Products to report on.

See "About selecting Products and Channels" on page 35.

2 In Demand Forecaster, select Modules > Demand Forecasting > Reports > Accuracy.
The Accuracy Report Options dialog box is displayed.

3 Select the table from which to select a grouping field, either Products or Channel/Products.
4 Select the field to group by from the selected table.
5 Select a Weight By field for the report if required.
6 Select the Demand Type to use, Adjusted Demand, Demand or Sales.
7 Enter a Scale By factor if required.
8 Click OK.

The following windows are displayed:

• "Accuracy Data reports"
• "Accuracy Histogram"
• "Accuracy Scatter Chart"

Changing Accuracy Histogram defaults
It is possible to change the number of standard deviations to use when defining Accuracy levels.

1 In Demand Forecaster, view Accuracy Data.
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See "Viewing Accuracy Data" on page 288.

2 Select Window > Accuracy Histogram.
3 Select Tools > Options.

The Properties dialog box is displayed.
4 Type the new accuracy levels and click OK.

Note: Illogical values are not accepted. The threshold for Red must be greater than the upper limit
for Orange and the threshold for Green lower than the lower limit for Orange.

Viewing an MI Effectivity report
1 Select the Channel Products to report on.

See "About selecting Products and Channels" on page 35.
2 In Demand Forecaster, select Modules > Demand Forecasting > Reports > Forecast Analysis

> MI Effectivity.
The MI Analysis - Options dialog box is displayed.

3 Select the Percentage tolerance required.
4 Select the Display totals check box if you want to include a grand total for the report and, if a

grouping is selected, a group total for each control break.
5 Select the Sort by improvement check box if you want to base the sort order on the degree of MI

improvement.
6 From the list, select Ascending or Descending.
7 Select a Weight field for the report if required.
8 Select a Group by field if required.
9 Type a Scale by factor if required.
10 Click OK.
11 Use the First, Previous, Next, and Last buttons on the toolbar to view the first, previous, next or

last item in the report.

ASClient

About ASClient
ASClient allows access to the application server functionality from the command line. There are three
batch functions (also called methods) provided by the application server:

• Balance, which will balance forecasts throughout the Channel structure
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• Forecast_Ahead, which will regenerate the forecast
• Generate_Forecast. which will refit the model and regenerate the forecast

To use ASClient you must decide which of the above methods you wish to call and how you intend to
select the items to process. Use the method as an option when running ASClient, for example:

asclient /METHOD generate_forecast

There are three ways to select the items to process:

• By Channel Product Reference numbers
• By Product codes
• By SQL filters

About the configuration file
This is the default configuration file, generated when installing Infor Demand Planning Client. Ensure
the <db_server> and <port> values are valid:

mle-asclient-settings.xml

<?xml version="1.0" encoding="utf-8" ?>

<host>http://localhost</host>

<port>35950</port>

<db_username>M_LINCS</db_username>

<db_password>M_LINCS</db_password>

<db_server>xe</db_server>

<selection_type>cp_refs</selection_type>

<api_method>balance</api-method>

<!-- interval determines how often progress is written to the log (seconds) -->

<mark_interval>1</mark_interval>

<!-- items that could not be processed are written to invalid_log_file -->

<invalid_log_file>asinvalid.log</invalid_log_file>

<!-- log detail level (LOG, FATAL, ERROR, INFO, WARN, INFO, DEBUG or TRACE) -->

<log_level>ERROR</log_level>

<filters>

     <product_filter>products.prod_type &lt;&gt;9</product_filter>

     <channel_filter></channel_filter>

     <chanprod_filter></chanprod_filter>
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</filters>

<product_codes>

     <item>609-08L</item>

     <item>032-83K</item>

</product_codes>

<cp_refs>

     <item>1</item>

</cp_refs>

See "Example of a configuration file" on page 338.

Getting started
1 The Application Server must be running in order for ASClient to function. To check if it is running,

type the following address (or similar) in your browser:
http://127.0.0.1:35950/

Note that the IP address and port number may differ from this example, depending on the location
the service is installed and the port number it is configured to use. Replace with your details as
appropriate.
If the Application Server is running you will see the message "Infor Application Server is operational".

2 It can be started in two ways:

• as a service,
• from DOS.

a To run as a service, start a DOS session by selecting click Start > Run, typing cmd in the Open
list box, and typing the following command:
C:\Program Files\Infor\DP6.5\dp>dp_as.exe -install

(depending on the version number)

b Select Start > Settings > Control Panel.
c Double-click Administrative Tools.
d Double-click Services.

The Services dialog box is displayed, listing the services available on your machine. You should
now see Infor Demand Planning Service in the list.

e In the Services dialog, select Demand Planning AppServer 6.5 and do one of the following:

• Click the Start Service button.
• Click Start on the Action menu.
• Click Start the service.

To set the service to start automatically, right-click Infor Demand Planning Service, select
Properties and select Automatic from the Startup type list box.
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a To start from DOS, start a DOS session by selecting Start > Run and typing cmd in the Open
list box.

b Type the following command:
C:\Program Files\Infor\DP6.5\dp>dp_as.exe -console

(depending on the version number)

Configuring ASClient
After deciding which method to run and on which items, ASClient can be configured to perform the
processing. Configuration is done via a configuration file mle-asclient-settings.xml and also
via the command line. Note that ASClient values from the command line will override the values in the
configuration file.

See "Example of a configuration file" on page 338.

To run ASClient, type asclient /[OPTION] at the DOS prompt. Be sure to type a space between
asclient and /[OPTION]. If an option is not typed here, ASClient will use the details in the xml
file.
The command line options are as follows:

• /HELP - show command line help
• /LOG FILENAME - set log file name (default is asclient.log)
• /DBUSERNAME USERNAME - set database user name
• /DBPASSWORD PASSWORD - set database password
• /DBSERVER SERVER - set database server name (Oracle TNS)
• /METHOD METHOD - set the API call method. Valid values are:

• balance
• generate_forecast
• forecast_ahead

• /SELECTIONTYPE SELECTIONTYPE - set the item selection method. Valid values are:

• cp_refs
• product_codes
• filters

• /HOST URL - host of the application server e.g. http://localhost
• /PORT PORTNUMBER - port of the application server (typically 35950)
• /CANCEL REQUESTID - cancel a request
• /NOPROMPT - disable prompting the user before starting to process
• /NOVALIDATION - disable validating settings using database
• /SHOWOPTIONS - display options before starting to process
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• /VERSION - asclient version

Although the above options are self explanatory, the following may need some explanation:

•  /CANCEL REQUESTID

When ASClient makes a request to the application server, the request itself is given a number
called the request ID. The request ID is shown In this example:
C:\>asclient

asclient v6.5

Copyright 2012 Infor. All rights reserved.

Using settings file: C:\Documents and Settings\<USERNAME>\Infor\Demand
Planning\6.5\mle-asclient-settings.xml 
Continue y/N?

Fit options not found - using defaults

Calling Generate Forecast using filter selection

Request ID 1

14:42:59 - 0% done

14:43:00 - 0% done

14:43:01 - 0% done

14:43:02 - 0% done

14:43:03 - 41% done

14:43:04 - 41% done

14:43:04 - 100% done

Finished

If after starting ASClient, you wish to cancel the request but have been disconnected from the
application server, then the /CANCEL option can be used along with the correct Request ID to
cancel the call:
C:\>asclient  /cancel 11

asclient v6.5

Copyright 2012 Infor. All rights reserved.

Command line options:

CANCEL : 11

Using settings file: C:\Documents and Settings\<USERNAME>\Infor\Demand
Planning\6.5\mle-asclient-settings.xml

Trying to cancel request 11

Request cancelled successfully

• /NOPROMPT

Start the process without prompting the user to continue.

• /NOVALIDATION
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Skip the validation step. Since there are many configuration parameters, ASClient tries to validate
as much as possible before calling the application server. This requires ASClient to have direct
access to the DB server. If ASClient doesn't have access to the same DB the application server
has access to then this facility may need to be disabled, in which case you should use this option.

• /SHOWOPTIONS

• Prints out all the options ASClient will use to call the application server.

Item Selection

• CP Refs
Should be included in the configuration file as follows:
<cp_refs>

 <item>1</item>
 <item>2</item>
 <item>3</item> ….and so on.
</cp_refs>

• Product Codes
Should be included in the configuration file as follows:
<product_codes>

<item>609-08L</item>

 <item>032-83K</item>

<item>065-39Y</item>

<item>073-61S</item>

</product_codes>

• Filters
Should be included in the configuration file as follows:
<filters>

<product_filter>enter Product filter here</product_filter>

<channel_filter>enter Channel filter here</channel_filter>

<chanprod_filter>enter Channel Product filter here</chanprod_filter>

</filters>

A Product filter is based on Product table fields, a Channel filter is based on Channel table fields
and a Channel Product filter is based on Channel Product table fields.
Each constraint includes three elements:

• A field from the Product or Channel Product or Channel table
• A constant value with which the field value is compared
• An operator that specifies the relationship between the field value and the constant value:

Equal=

Greater than&gt;

Infor Demand Planning User Guide | 335

Demand Forecaster



Less than&lt;

Greater than or equal&gt;=

Less than or equal&lt;=

Not equal&lt;&gt;or !=

The following example shows a Product filter selecting Products with a Product Type not equal
(<>) to "9".
 <product_filter>products.prod_type &lt;&gt;9</product_filter>

Methods

• Balance
The Balance section only applies if balance is set as the <api_method>. No other options are
required. Balancing through a Channel matrix is the process where changes at a Channel are
passed through the sequence of linked Channels. The controls for this procedure are contained
within the Channel behaviors, which hold information relating to individual Channels. They permit
or deny history, forecast or requirements data to be passed to or accepted from other Channels
in the matrix.

• Forecast Ahead
The Forecast Ahead section only applies if forecast_ahead is set as the <api_method>. No
other options are required. The forecast is regenerated using the existing forecast model.

• Generate Forecast
The Generate Forecast section only applies if generate_forecast is set as the <api_method>.
If the <generate_forecast> section is missing then the default is the default options used by
Generate Forecast in the Demand Forecaster module of Infor Demand Planning.
Other generate_forecast options are:

• <fit_history_type> - Enter the type of history to use: 1 for Sales 2 for Customer demand
3 for Adjusted demand 4 for History exclusion mask

• <clear_mi> - Enter true to remove all existing market intelligence
• <clear_future_changes> - Enter true to remove any future changes
• <recalc_history_start_date> - Enter true to calculate the forecast from the first non-zero

history value
• <recalc_annual_forecast> - Enter true to recalculate the annual forecast figures beyond

the monthly forecast horizon
• <recalc_safety_stock> - Enter true to recalculate the safety stocks
• <remove_causal_factors> - Enter true to remove all independent variables applied using

the causal modeling process

Enter the following parameters if you want to use different values from those of the underlying
Channel Products table fields.

• <forecast_calc_code> - Enter a valid forecast calculation code from the Forecast
Calculation Formulae table
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• <model_start_date> - Enter the starting date (yyyy-mm-dd) for history to be used to
calculate the new forecast model

• <growth_damping_start_date> - Enter the date (yyyy-mm-dd) when you want the growth
rate damping factor to start from

• <growth_damping_end_date> - Enter the date (yyyy-mm-dd) when you want the growth
rate damping factor to end

• <growth_damping_factor> - Enter a valid factor that will control the way that the growth
damping factor is applied

• <level_inflation_factor> - Enter a valid level inflation factor that is applied to the
current standard deviation estimate

• <level_shift_threshold> - Enter a multiplication factor to be applied to the current
standard deviation estimate

• <allow_negative_forecast> - Enter true if you want to allow the forecast to become
negative

• <conf_for_seasonality> - Enter the level of significance which determines whether
seasonal coefficients are included in the forecast model

• <introduction_date> - Enter the date (yyyy-mm-dd) for the introduction of a new Product
• <discontinuation_date> - Enter the discontinuation date (yyyy-mm-dd)
• <min_sparse_periods> - Enter the minimum number of sparse periods to define slow

moving Products
• <max_short_periods> - Enter the maximum number of periods to define short history

Products
• <max_model_terms> - Enter the maximum number of coefficients that should be used in

calculating a statistical model Enter the following parameters if you want to use different values
from those stored in the System table.

• <scale_inflation_factor> - Enter a factor that is used to develop an alternative model
to monitor the increase in the estimate of variance.

• <scale_bayes_factor> - Enter the minimum value that the variance Bayes factor can be
allowed to be before a tracking signal is activated

• <run_length_limit> - Enter a value defining the number of monthly periods that are
monitored for significant shifts in the level and/or the variance

• <save_changes> - Enter true to save any changes made to the above System parameters
back to the System table

• <mask_type> - Can be one of the following:

• OPTIONS - use the mask given in the <mask> section
• DB - read the mask from the DB
• COMBINE - merge the mask given in <mask> and the one from the DB

Generate Forecast will initialize using the default settings so that if you only want to change the
introduction date then you only need to set the <introduction_date> in the configuration file; all
other options are set to the default values.
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Example of a configuration file
This is an example of a typical configuration file, annotated where necessary. In this example, Generate
Forecast functionality is applied to items selected by Channel Product Reference Number:

<?xml version="1.0" encoding="utf-8" ?>

<host>http://localhost</host>

<port>35950</port>

<db_username>M_LINCS</db_username>

<db_password>M_LINCS</db_password>

<db_server>xe</db_server>

<selection_type>cp_refs</selection_type>

<!-- which method on the application server to call -->

<api_method>generate_forecast</api-method>

<!-- interval determines how often progress is written to the log (seconds) -->

<mark_interval>1</mark_interval>

<!-- items that could not be processed are written to invalid_log_file -->

<invalid_log_file>asinvalid.log</invalid_log_file>

<!-- log detail level (LOG, FATAL, ERROR, INFO, WARN, INFO, DEBUG or TRACE) -->

<log_level>ERROR</log_level>

<!-- which selection type to use to select the items to process -->

<!-- can be either cp_refs, product_codes or filters -->

<selection_type>cp_refs</selection_type>

<filters>

     <product_filter>products.prod_type &lt;&gt;9</product_filter>

     <channel_filter></channel_filter>

     <chanprod_filter></chanprod_filter>

</filters>

<product_codes>

     <item>609-08L</item>

     <item>032-83K</item>

     <item>065-39Y</item>

     <item>073-61S</item>

     <item>100-77D</item>
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</product_codes>

<cp_refs>

     <item>1</item>

     <item>2</item>

     <item>3</item>

     <item>4</item>

     <item>5</item>

     <item>6</item>

     <item>7</item>

     <item>8</item>

     <item>9</item>

     <item>10</item>

</cp_refs>

<!-- generate forecast options - these relate directly to the options -->

<!-- shown in the Generate Forecast dialog box shown in DP -->

<!-- dates should be in YYYY-MM-DD format -->

<generate_forecast>

     <fit_history_type>3</fit_history_type>

     <clear_mi>true</clear_mi>

     <clear_future_changes>true</clear_future_changes>

     <recalc_history_start_date>false</recalc_history_start_date>

     <recalc_annual_forecast>false </recalc_annual_forecast>

     <recalc_safety_stock>false </recalc_safety_stock>

     <remove_causal_factors>false</remove_causal_factors>

     <forecast_calc_code_>0</forecast_calc_code>

     <model_start_date>2008-07-01</model_start_date>

     <growth_damping_start_date_>2008-07-01</growth_damping_start_date>

     <growth_damping_end_date_>2008-07-01</growth_damping_end_date>

     <growth_damping_factor>0.3</growth_damping_factor>

     <level_inflation_factor_>3.5</level_inflation_factor>

     <level_shift_threshold_>0.135</level_shift_threshold>

     <allow_negative_forecast>true</allow_negative_forecast>
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     <conf_for_seasonality>95</conf_for_seasonality>

     <introduction_date_>2008-17-01</introduction_date>

     <discontinuation_date_>2008-07-01</discontinuation_date>

     <min_sparse_periods>6</min_sparse_periods>

     <max_short_periods>6</max_short_periods>

     <max_model_terms>14</max_model_terms>

     <scale_inflation_factor>20</scale_inflation_factor>

     <scale_bayes_factor>0.3</scale_bayes_factor>

     <run_length_limit>4</run_length_limit>

     <save_changes>false</save_changes>

     <mask_type>options</mask_type>

     <mask>

         <item>1</item>

         <item>0</item>

         <item>1</item>

         <item>1</item>

     </mask>

     <use_commit>true</use_commit>

</generate_forecast>

User Data Series

About User Data series
User Data Series (UDS) can be used to store simple or calculated values for custom requirements and
are useful for, for example, track stock-outs in history, back-orders, DIFOT violations, store (scan) sales
comparatives to Warehouse sales.

Existing data and weightings on the database can be used to create a UDS, or UDS can be manually
input, depending on the requirements.

UDS are created and managed from within Database Administration. Whether a UDS is editable is
specified in User Data Series Preferences.

To which users UDS are available is also specified in User Data Series Preferences.
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Editable UDS can be edited directly by over-typing in the Table or Fiscal windows, or can have another
row of data copied or added to them from the Table window. Non-editable UDS are display only.

In the Table window, selecting a UDS and right-clicking displays options to Copy to UDS, Add to UDS
and Display/Do not display the UDS on the graph.

Selecting any row of data in the Table window and right-clicking displays additional options to Copy to
UDS and Add to UDS, enabling existing Channel Product data to be stored in a UDS.

If the Display option has been specified for a UDS in User Data Series Preferences, it will automatically
display on the Graph. Select 'Display/Do not display UDS on Graph'

UDS are accessible in the Fiscal window by selecting UDS Edit from the drop down on the main toolbar
and selecting a UDS from the list.

The selected UDS is displayed in the Fiscal window where, if editable, it can be edited as required.

You can edit single periods or Totals, which will spread the Total value to the individual periods in that
year, based on their previous values.

UDS calculations are created and managed from within Database Administration. Calculations can be
run in both Database Administration and in Demand Forecaster on selected Channel Products.

Demand Sensing

About Demand Sensing
Demand Sensing provides true 'Sense & Respond' capability giving better visibility of daily, weekly,
and month to date actual sales for current period.

New Exceptions to alert of real-time sales behavior changes.

Automatically evaluate new exceptions;

• "Demand Sensing - High"

• "Demand Sensing - Low"

Enhancement to Demand Analysis Report with new Channel Product parameters for Demand Sensing
tolerance percentages.

Default new Data Series for recording Sales to Date.

Demand Sensing Channel Product parameters can be set within Edit Forecasts, Data Window or from
the Channel Products table in Database Administration.

Whether an item is flagged as sensing high or low demand depends on the Demand Sensing Parameters
and tolerances defined. For example a % sales filter with a tolerance of 30% may flag an item as
Sensing Low Demand but a percentage of 50% does not sense low demand.
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The sensing is based on Live data. The live data values are displayed on a read-only basis for information
purposes.

The Channel Product Demand Sensing parameters can be used when running the Demand Analysis
report by selecting the CP Settings option in the Report tab when setting up the report.

Items flagged in the report are those identified as having significant differences between current demand
and the most recent forecast based on the comparison criteria of the Channel Product Demand Sensing
Parameters.
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6Inventory Planner

About Inventory Planner
The Inventory Planner module provides three functions:

• ABC analysis

You can classify items according to their relative importance to your business, typically determined by
the monetary value of their annual forecast demand. You can do this either interactively or automatically
(that is, in "batch mode").

• Simulating and calculating safety stock

You can specify a safety stock strategy for one or more items, and have Infor Demand Planning calculate
the optimum safety stock to fulfil that strategy. You can simulate the effects of different strategies and
examine the trade-off between investment in stock and various measures of customer service.
Alternatively, if you already know what strategy you want, you can apply it and calculate safety stocks
directly (that is, in "batch mode"). The calculation of safety stock includes the calculation of the re-order
point.

• Calculating economic order quantities

You can have Infor Demand Planning calculate economic order quantities for one or more items,
balancing the costs of holding stock against the costs of raising procurement or production orders. You
can then, if you wish, make each item’s preferred lot quantity equal to the economic order quantity.

Note: 

• In earlier releases, Inventory Planner was known as both Strategic Inventory Planning and Inventory
Optimizer.
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ABC Analysis

About ABC analysis
An ABC analysis classifies Products or Channel Products according to their annual forecast. The annual
forecast is usually weighted by a monetary value, such as standard cost, selling price or margin, but
you can choose any other static weighting.

See "About static weightings" on page 107.

Class A items are typically those with the highest weighted annual forecast, Class B items are those
with lesser forecast, and so on. (In fact, Infor Demand Planning supports class labels of up to three
characters, so you could have classes labeled TOP, MID and LOW. Class Z is reserved.)

As shown in this diagram, an ABC analysis demonstrates that Pareto’s Law applies; that is, a relatively
small percentage of the total number of items (X-axis) accounts for a relatively large percentage of the
annual value (Y-axis).

Once you have defined the classes and applied them, you can devise inventory optimization strategies
that relate to the relative importance of each item.

More about ABC analysis
You can choose to set ABC breakpoints interactively, on the basis of an ABC Classification report, or
automatically, according to parameters you specify in advance.

You can classify only live Standard Products; that is, Normal Products and Slow-Moving Products.

Classify items at the Product or Channel Product level
You can choose to classify items either at the Product level (in other words, the same classification at
all Channels) or at the Channel Product level (potentially different classifications at different Channels).
Your choice depends on the details of your business.

If you decide to classify at the Product level, you should be careful which Channels you choose to
determine the total annual forecast. If you choose a mixture of aggregate and node Channels, the

344 | Infor Demand Planning User Guide

Inventory Planner



annual forecast may be inflated by double-counting. (This cannot happen when classifying at the
Channel Product level.)

Two measures of annual forecast
Annual forecast can be measured in either of two ways:

• Next year’s forecast

The total net forecast over the next 12 or 13 periods. This is the default measure.

• Annualised forecast

A simple forward projection of the current level and growth over the next 12 or 13 periods, ignoring
market intelligence, effectivity and discontinuation dates, and the forecast horizon. If growth is strongly
negative, this can result in a negative annual forecast.

Whether 12 or 13 periods are used depends on the demand calendar applied at each Channel.

Weighting the annual forecast
Static weightings can be based on Product or Channel Products table fields. If you are classifying by
Product but select a CP-based weighting, Infor Demand Planning calculates an average weighting
across the selected Channels.

See "Example of an average weighting".

Where the classification is stored
By default, when classifying at the Product level the result is stored in the "ABC Class (Pt)" field, and
when classifying at the Channel Product level the result is stored in the "Inventory Classification (CPt)"
field.

However, you may instead choose any suitable user-defined field of the Product or Channel Products
table in which to store the classification.

See "About user-defined fields" on page 88.

Note: 

• Alternatively, you can of course import ABC classifications directly into the Product or Channel
Products table.

Interactive Analysis

Classifying items interactively
1 Generate an ABC Classification report.

See "Generating an ABC Classification report" on page 347.
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2 Define the ABC breakpoints, or add classifications directly to selected items.
See "Defining ABC breakpoints" on page 349 and "Adding an ABC classification" on page 350.

3 Save the new ABC classes.
See "Saving new ABC classes" on page 350.

ABC Classification Report

About the ABC Classification report

The ABC Classification report enables you to classify selected Products or Channel Products, by listing
them in decreasing order of their weighted annual forecasts. You can then set breakpoints that define
the class boundaries, and assign labels to these classes. The report has a "toolbar" on page 347
(described below) to help you with these tasks.

The report shows, for each item, the following information:

MeaningColumn

Rank order of this item.Sequence

The new ABC class assigned to this item in this session.New Class

The item’s current ABC class as recorded in the database.Current Class

The Product code.Product Code

The name or description of the Product.Product Description

The Channel ID. This column is present only when classifying by
Channel Product.

Channel ID

The name or description of the Channel. This column is present only
when classifying by Channel Product.

Channel Name

The static weighting factor used for this item. If you are classifying by
Product but select a CPt-based weighting, Infor Demand Planning
calculates an average weighting across the selected Channels.
See "Example of an average weighting".

Weighting

The item’s annual forecast (either next year’s forecast or the annual-
ized forecast).

Forecast

The item’s annual forecast multiplied by the static weighting factor.Weighted Forecast

The sum of the weighted annual forecasts of this item and all items
of higher rank.

Cumulative Weighted Forecast

Weighted annual forecast for this item expressed as a percentage of
the total weighted annual forecast of all selected items.

Percentage Of Forecast

The weighted annual forecasts of this item and all items of higher
rank, expressed as a percentage of the total weighted annual forecast
of all selected items.

Cumulative Percentage Of
Forecast
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ABC Classification toolbar

FunctionButton

File > Save
Saves the new ABC classes assigned in this session.

Save

Edit > Reset Breakpoints
Removes all the ABC breakpoints defined in this session.

Reset
Breakpoints

Edit > Insert Breakpoint
Enables you to define a new ABC breakpoint.

Insert
Breakpoint

Edit > Alter Scaling
Enables you to change the scaling of the ABC Classification report.

Alter Scal-
ing

Edit > Alter Weighting
Enables you to change the weighting of the ABC Classification report.

Alter
Weighting

View > Summary Report
Generates an ABC Classification Summary report.

Summary
Report

Generating an ABC Classification report

1 In Inventory Planner, select the Products you want to classify, and the Channels from which you
want to calculate annual forecast.
See "About selecting Products and Channels" on page 35.
The Products that are not live Standard Products are removed from your selection.

2 Select Modules > Inventory Planner > ABC Classification.
The ABC Classification dialog box is displayed.

3 Specify whether you want the selected items to be classified at the Product level or the Channel
Product level, and whether you want the class stored in the default field or a user-defined field.

4 Click Interactive Mode, then click OK.
5 If you decided to classify at the Product level, but have selected aggregate and node Channels,

Infor Demand Planning warns you that the annual forecast is totaled across all these Channels;
click OK if you want to continue.

6  If you decided to store the class in a user-defined field, the Select User Field dialog box is displayed,
where you can select the field you want; click OK to continue.
The Inventory Classification Options dialog box is displayed.

7 Specify whether you want to classify items by Next year’s forecast or the Annualized forecast.
8 Under Items to display, type or select the number of items you want to view in the ABC Classification

report.
9 Optionally, in the Scale by box, type the factor by which you want to scale the annual forecast and

weighted annual forecast figures in the ABC Classification report.
10 Optionally, in the Weight by box, select a static weighting by which to weight the annual forecast.
11 Click OK.
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The ABC Classification window appears, showing an ABC Classification report. The report lists
selected items in decreasing order of their weighted annual forecast.

Note: To change the appearance of the report, select Tools > Fonts.

Scaling the ABC Classification report

When using the ABC Classification report, you can change the scaling of the annual forecast and
weighted annual forecast values to make them easier to read.

1 Select Edit > Alter Scaling.
If you have already specified some new classes, Infor Demand Planning warns you that these will
be removed. Click OK to continue.
The Alter Scale Factor dialog box is displayed, showing the current scale factor.

2 Type the factor by which you want to scale the values in the report.

Note: Another method is to right-click anywhere in the ABC Classification report and then click
Change Scaling Factor on the shortcut menu.

Weighting the ABC Classification report

When using the ABC Classification report, you can change the weighting used for the weighted annual
forecast values.

1 Select Edit > Alter Weighting.
If you have already specified some new classes, Infor Demand Planning warns you that these will
be removed. Click OK to continue.
The Inventory Classification Options dialog box is displayed, but only the Weight by box is available.

2 Select a static weighting by which to weight the annual forecast.

Note: 

• Another method is to right-click anywhere in the ABC Classification report and then click Change
Weighting Factor on the shortcut menu.

• Static weightings are defined in the Database Administration module.

About the ABC Classification Summary report

You can generate an ABC Classification Summary report for either the new classes defined in this
session, or the current classes in the database. The report shows how many of the selected items
there are in each class.

The classes are listed in alphabetical order. The report shows, for each class:

MeaningColumn

The class label, or "Undefined" for unclassified items.Classification

The number of selected items in this class.Number of Items
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The number of selected items in this class and all preceding classes.Cumulative Number of Items

The total annual forecast of all the items in this class.Total Annualized Forecast

The total weighted annual forecast of all the items in this class.Total Weighted Annualized
Forecast

The total weighted annual forecast of all the items in this class and
all preceding classes.

Cumulative Total Weighted
Annualized Forecast

The total weighted annual forecast of all the items in this class, ex-
pressed as a percentage of the total weighted annual forecast of all
selected items.

Percent Total Weighted Annu-
alized Forecast

The total weighted annual forecast of all the items in this class and
all preceding classes, expressed as a percentage of the total
weighted annual forecast of all selected items.

Cumulative Percent Total
Weighted Annualized Forecast

Generating an ABC Classification Summary report

1 Select View > Summary Report.
2 Click Yes to view the report for the newly-defined classes or No to view the report for the current

classes.
The Classification Summary window appears, showing the ABC Classification Summary report.

Note: To change the appearance of the report, select Tools > Fonts.

ABC Breakpoints

Defining ABC breakpoints

When using an ABC Classification report, you can define new breakpoints interactively. At first, all the
items in the report are newly unclassified, although the report also shows their current classes.

1 Select Edit > Insert Breakpoint.
The Enter Value and Classification dialog box is displayed.

2 In the Select items where weighted forecast is greater than or equal box, type the weighted annual
forecast value at which you want to insert a breakpoint.

3 In the Classification label box, type a label for the class (up to three characters).
If you have used this label for a class you have already defined, Infor Demand Planning asks you
to confirm that you really want to use it again.
All the items that have a weighted annual forecast greater than or equal to the specified value are
given the new classification.

4 Repeat as required.
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Removing ABC breakpoints

When using the ABC Classification report, you can remove any breakpoints you have defined and
return to the initial state in which all the items are newly unclassified.

Select Edit > Reset Breakpoints.

ABC Classifications

Adding an ABC classification

When using an ABC Classification report, you can specify the ABC class of one or more selected items.

1 Select one or more items in the ABC Classification report. The items do not have to be next to each
other.

2 Right-click any one of the selected items, and on the shortcut menu click Add Classification. The
Enter Classification dialog box is displayed.

3 Type a class label for the items (up to three characters).

Renaming an ABC classification

You can rename any new ABC class shown in an ABC Classification report.

1 Select Edit > Rename Classification.
The Rename Classification dialog box is displayed.

2 In the Current Classification Label box, select the class you want to rename.
3 In the New Classification Label box, type a new class label (up to three characters).

Note: Another method is to right-click any item in the ABC Classification report that has the class
you want to rename, and then click Rename Classification on the shortcut menu.

Removing ABC classifications

When using the ABC Classification report, you can remove any new classifications you have defined
and return to the initial state in which all the items are newly unclassified.

Right-click anywhere in the ABC Classification report and then click Reset Classifications on the
shortcut menu.

Saving ABC Classes

Saving new ABC classes

1 Select File > Save.
The Enter Classification dialog box is displayed.

2 Type a label for the unclassified items (up to three characters).
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By default, the label U is used.

Note: 

• Another method is to right-click anywhere in the ABC Classification report and then click Save
Inventory Classes on the shortcut menu.

• The new classes are saved to either the Products table or the Channel Products table, depending
on your choice when you generated the ABC Classification report.

Batch Analysis

Classifying items automatically
1 In Inventory Planner, select the Products you want to classify, and the Channels from which you

want to calculate annual forecast.
See "About selecting Products and Channels" on page 35.
Infor Demand Planning removes from your selection any Products that are not live Standard Products.

2 Select Modules > Inventory Planner > ABC Classification.
The ABC Classification dialog box is displayed.

3 Specify whether you want the selected items to be classified at the Product level or the Channel
Product level, and whether you want the class stored in the default field or a user-defined field.

4 Click Batch Mode, then click OK.
5 If you decided to classify at the Product level, but have selected aggregate and node Channels,

Infor Demand Planning warns you that the annual forecast is totaled across all these Channels;
click OK if you want to continue.

6 If you decided to store the class in a user-defined field, the Select User Field dialog box is displayed,
where you can select the field you want; click OK to continue.
The Inventory Classification Options dialog box is displayed.

7 On the Classifications tab, specify this information:

• Specify whether you want to classify items by next year’s forecast or the annualized forecast.
• Type a label for the unclassified items (up to three characters). By default, the label U is used.
• Optionally, select a static weighting by which to weight the annual forecast.

8 On the Set Breakpoints tab, select either Cumulative % of Forecast or Value.
9 Specify the ABC class labels and the associated breakpoint values.
10 Click OK to apply the breakpoints to the selected Channel Products.

An ABC Classification dialog box is displayed, showing the progress of the re-classification.
An Output pane appears, showing the number of CPs processed and whether any exception views
were generated:

• "DATA CHANGED"
• "INCOMPLETE ABC"
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When the process is complete, Infor Demand Planning updates the database with the new
classifications.

Note: 

• Infor Demand Planning ensures that each breakpoint has a valid class label and a non-zero
value, but it does not ensure that they are mutually consistent.

• To close the Output pane, select View > Output.

Safety Stock

About safety stock
The purpose of maintaining safety stock is to counteract variability in demand. If demand exceeds
forecast, it can lead to shortages and lower customer service levels. Clearly, the more safety stock is
carried, the lower the probability of shortages. On the other hand, more safety stock implies a greater
investment, with consequent opportunity costs.

The optimal amount of safety stock is the minimum quantity needed to achieve a required service level.

Safety stock strategies
Inventory Planner enables you to choose between seven different safety stock strategies and calculate
the optimal safety stock.

The advanced strategies offered by Infor Demand Planning use a computed safety factor (k) and the
standard deviation of forecast errors over the lead time (s) to calculate a statistical safety stock that
makes allowance for the accuracy of the forecast. Other, simpler strategies either do not compute a
safety factor (but simply take it as given) or make no allowance for the accuracy of the forecast.

Safety stock strategies can be selected independently for different items or collections of items. For
example, you can apply a different strategy according to each item’s ABC classification.

Each strategy is characterized by a required performance level. Strategies and their performance levels
should be reviewed periodically to ensure that they continue to match your business objectives.

Re-order point
In Infor Demand Planning, the basis for replenishing stocks is to compare the available stock after each
transaction with the re-order point (ROP). For most products, the ROP is the forecast of demand during
the re-supply lead time, plus the safety stock at the end of the lead time (including, optionally, some
allowance for contingency stock). The calculation of safety stock includes the calculation of the re-order
point.
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Time-phased safety stock
Inventory Planner calculates the average safety stock needed to provide the required service level for
the year ahead.

If demand is seasonal, the actual service level achieved at any point during the year can be expected
to be below average in periods of high demand, and above average in periods of low demand. However,
it is possible to achieve a constant service level throughout the year by using time-phased safety stocks
(TPSS).

About time-phased safety stocks and Inventory Planner
The safety stock calculations produce an annual average safety stock quantity. But to achieve a constant
level of service throughout the year, it may be necessary to vary the safety stock so that more than the
average is available during periods of high demand, and less than the average is available during
periods of low demand.

There are three different ways of interpreting "demand" in this context:

• The net forecast (that is, statistical forecast plus market intelligence, including the customer forecast
where applicable)

• DRP requirements (that is, outgoing orders to supply other Channels)

• Either net forecast or DRP requirements, plus dependent (BOM) requirements

It is important to understand that Inventory Planner does not calculate a full schedule of TPSS values
for the year ahead. That function is performed by Replenishment Planner. Instead, Inventory Planner
converts the annual average safety stock into a number of days’ cover (plus contingency) and calculates
a single TPSS value appropriate for the end of the re-supply lead time. This value is based solely on
the net forecast, not DRP or dependent requirements.

About the Current Weeks of Supply report
The Current Weeks of Supply report categorizes the selected Channel Products according to how
many weeks of supply are covered by their respective current safety stocks.

The report is presented as a table, with columns for each week of cover (0-1, 1-2, 2-3, and so on) up
to a maximum of 25-26. If some Channel Products have more than 26 weeks’ cover, they are grouped
together under a >26 column. The final column is a Total column.

The rows of the table are as follows:

MeaningRow

The number of the selected Channel Products with the same weeks’
cover.

Count
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The total units of current safety stock for these Channel Products.
å "Annual Average Safety Stock (CPt)"

Total Safety Stock

The total units of current sales.
å ("Estimated Annual Usage (CPt)" / 52)

Weekly Sales

The total value of current safety stock, at standard cost.
å ("Annual Average Safety Stock (CPt)"´ "Cost Price (CPt)")

Total Safety Stock Value

The total value of current sales at standard cost.
å (("Estimated Annual Usage (CPt)" / 52) ´ "Cost Price (CPt)")

Weekly Sales Value

The total of current safety stock multiplied by the weighting identified
in the Safety Stock Simulation toolbar. This row is present only if
the weighting is not Units or Standard Cost.
å ("Annual Average Safety Stock (CPt)"´ weighting)

Total Safety Stock Weight

The total of current sales multiplied by the weighting identified in
the Safety Stock Simulation toolbar. This row is present only if the
weighting is not Units or Standard Cost.
å (("Estimated Annual Usage (CPt)" / 52) ´ weighting)

Weekly Sales Weight

Indicates by an asterisk (*) if the current safety stock or the theoret-
ical on-hand stock is limited by shelf life, storage capacity, or mini-
mum/maximum limits for any one of these Channel Products.
The limitations are governed by the following fields:

Limit

"Shelf Life (CPt)"
"Maximum Storage Capacity (CPt)"
"Minimum Time-phased Safety Stock Days (CPt)"
"Minimum Time-phased Safety Stock Units (CPt)"
"Maximum Time-phased Safety Stock Days (CPt)"
"Maximum Time-phased Safety Stock Units (CPt)"

Note: 

• Contingency stock is ignored.

• The Standard Cost static weighting is typically based on the "Cost Price (CPt)" field.

About the Weeks Forward Cover histogram
The Weeks Forward Cover histogram shows both current and simulated data, taken from the Count
row of the Current Weeks of Supply report and the Safety Stock Simulation Weeks of Supply report.

The x-axis of the histogram shows weeks’ cover starting at 0-1, 1-2, 2-3, and so on up to 25-26 and (if
necessary) >26.
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The y-axis shows how many of the selected Channel Products share the same number of weeks of
supply. The current distribution is shown by green bars, the simulated distribution by blue bars.

You can double-click a bar to display the underlying data. You can click and drag in the plot area to
display crosshairs that can make it easier to read the axes.

Safety Stock Strategies

About the safety stock strategies
"Key to the safety stock formulae" key to formulae "1" on page 356|"2" on page 356|"3" on page 356|"4"
on page 356|"5" on page 357|"6" on page 357|"7" on page 357

Inventory Planner provides seven different safety stock strategies, each being configured by specifying
a required performance level:

• 1: Specified Service Level by Itemks

• 2: Specified Number of Safety Factors

• 3: Service Level by Order Fill ks

• 4: Minimise Shortage Occurrencesks

• 5: Days Supply

• 6: Nominated Average Safety Stock Quantity

• 7: Anticipated Years Between Shortagesks

The strategies marked with the symbol ks denote those that depend on a computed safety factor
(represented by k) and the accuracy of the forecast (represented by s, the standard deviation of forecast
errors over the lead time). The other strategies either do not compute a safety factor (k is merely
specified) or make no allowance for the accuracy of the forecast.
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Strategies 3, 4 and 7 are intended to be applied to groups of items. The specified performance level
may be achievable for the group as a whole, but not necessarily for individual items within the group.
For this reason, these strategies are described as having "dependent" performance levels.

Strategy 1: Specified Service Level by Item
Performance level: Fraction of annual demand to be filled from stock

Formula: ss = (k ´s) where E(k) = ((1 – PL) ´ q)/s

Under this strategy, a performance level of 0.97 means that, over the course of a year, for any given
item, 97% of the demand that occurs between placing a replenishment order and its arrival should be
immediately satisfied from stock. Items with less accurate forecasts or higher replenishment frequencies
tend to be allocated more safety stock than others.

This strategy is recommended where inventory is used to protect customer service, for example in a
distribution depot.

Strategy 2: Specified Number of Safety Factors
Performance level: Number of standard deviations

Formula: ss = (k ´s) where k = PL

Under this strategy, rather than let Infor Demand Planning compute a safety factor, you can specify it
directly via the performance level. Thus a performance level of 2.0 means that the average safety stock
for a given item is twice the standard deviation of forecast errors over the lead time.

This strategy is most often used for slow-moving items. The service levels achievable with this strategy
are usually lower than those with the Specified Service Level by Item strategy.

Strategy 3: Service Level by Order Fill
Performance level: Marginal cost of increasing the probability of completely filling orders

Formula: ss = (k ´s) where F(k) = (v ´ q)/((P/100) ´ PL)

This strategy aims to maximize the proportion of orders that are completely satisfied from stock for a
group of items that typically appear together on orders. (However, the strategy assumes that the
probability that any one item is on an order is independent of the inclusion of any other item.) The
performance level is not a precise quantity, although it represents a monetary value. You are encouraged
to simulate the effects of various performance levels.

Although this strategy is appropriate when very high levels of order fill are required, it is not often used
because of the practical difficulty in determining the probability that any given item will be on an order.
When it is used, it tends to recommend higher stock levels for the items that appear most frequently
on orders.

Strategy 4: Minimise Shortage Occurrences
Performance level: Imputed marginal cost of a shortage

Formula: ss = (k ´s) where p(k) = (r ´ v ´s)/((365/D) ´ PL)
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This strategy aims to minimize the number of shortages for a group of items. The performance level is
not a precise quantity but is proportional to the cost of each additional shortage. You are encouraged
to simulate the effects of various performance levels.

This strategy is appropriate for items that can be swiftly expedited through the manufacturing or
procurement process. In a plant location, this strategy gives low inventory and high customer service
to distribution depots. As a result, the strategy tends to recommend higher stocks of inexpensive,
slow-moving items and lower stocks of fast-moving items.

Strategy 5: Days Supply
Performance level: Number of days of supply

Formula: ss = (PL ´ S)/365

Under this strategy, a performance level of 14 means that, for any given item, Infor Demand Planning
computes enough safety stock to cover 14 days’ demand, based on that item’s annual forecast demand.
(If time-phased safety stocks are used, the actual quantity in any given period may vary.)

This strategy is not often used because it makes no allowance for varying patterns of demand between
items and it cannot guarantee a minimum service level. It is provided to allow you to compare it with
more sophisticated strategies.

Strategy 6: Nominated Average Safety Stock Quantity
Performance level: Stock quantity

Formula: ss = (PL)

Under this strategy, a performance level of 750 means that, for any given item, Infor Demand Planning
assumes that on average 750 units are to be held as safety stock. (If time-phased safety stocks are
used, the actual quantity in any given period may vary.)

This strategy is appropriate only for items where inventory optimization is either impossible or inefficient.
For example, you might use this strategy for an item with infrequent demand, or one in decline for which
you want to control the safety stock manually.

Strategy 7: Anticipated Years Between Shortages
Performance level: Number of years

Formula: ss = (k ´s) where F(k) = 1/((365/D) ´ PL)

Under this strategy, a performance level of 3 means that, for a selected group of items, Infor Demand
Planning computes enough safety stock for each item to provide, on average, one shortage every three
years. Remember, however, that this dependent performance level applies to the group and may not
be achieved for individual items within the group. The performance level should not be taken too literally.

Larger safety stocks are allocated to items that are replenished with high frequency, irrespective of
how expensive they are.
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Changing the safety stock strategy
You can change the safety stock strategy for one or more Channel Products in either of two ways:

• by applying a safety stock simulation
• by editing the Channel Product database table and recalculating the inventory fields

By applying a safety stock simulation

1 In Inventory Planner, generate a safety stock simulation.
See "Generating a safety stock simulation" on page 360.

2 Select the strategy you want to simulate.
See "Selecting the safety stock strategy" on page 361.

3 Experiment with changing the performance level.
See "Specifying performance levels" on page 361.

4 When you are satisfied, apply the simulated strategy at the required performance level.
See "Applying a safety stock simulation" on page 370.

By editing the database

1 In Database Administration, select the required Channel Products and edit the SS Strategy and
SS Performance Level fields of the Channel Products table. (Both fields are included in the Inventory
Planner report.)
See "Editing the Channel Products table" on page 116.

2 In Inventory Planner, recalculate the inventory fields using the chosen strategy and performance
level.
See "Recalculating inventory fields" on page 375.

Safety Stock Simulations

About safety stock simulations
Safety stock simulations allow you to investigate the effects of changing the safety stock strategy, the
performance level, and some of the data by which the current safety stock is calculated. You can
evaluate a simulation by comparing it with the current strategy.

You can do this for individual Channel Products or groups of Channel Products. However, all the
Products must be either Normal Products or Slow-Moving Products.

You can then decide, on the basis of your simulations, to apply a new strategy or a different performance
level to the selected Channel Products.
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The elements of a safety stock simulation
When you generate a safety stock simulation, three special windows and a new toolbar appear:

"About the Safety Stock Simulation Exchange window" on page 363  Safety Stock Simulation Exchange
window

"About the Safety Stock Simulation Data window" on page 363  Safety Stock Simulation Data window

"About the Safety Stock Simulation Status window" on page 365  Safety Stock Simulation Status window

"Safety Stock Simulation toolbar"  Safety Stock Simulation toolbar

Other reports and graphs
Optionally, you can view other reports and charts to help you evaluate various strategies.

"About the Safety Stock Simulation Detail report" on page 366  Simulation Detail report

"About the Exchange Curve graphs" on page 369  Simulation Exchange Curve graphs

"About the Weeks Cover report" on page 368  Weeks Cover report

About the buttons used in Safety Stock Simulation
The following buttons are displayed when using the Safety Stock Simulation functionality in the Inventory
Planner module:

FunctionButton

Opens the Safety Stock Simulation Data window.
See "About the Safety Stock Simulation Data window" on page 363.

Data Win-
dow

Opens the Safety Stock Simulation Status window.
See "About the Safety Stock Simulation Status window" on page 365.

Current
Status

Opens the Safety Stock Simulation Exchange window.
See "About the Safety Stock Simulation Exchange window" on page 363.

Exchange
Analysis

Opens the Safety Stock Simulation Plot window.
See "About the Exchange Curve graphs" on page 369.

Plot

Opens the Safety Stock Simulation New Log window.
See "Viewing a change log" on page 362.

Change
Log Win-
dow

Opens the Safety Stock Simulation dialog before displaying the Safety Stock Simulation
Detail Report window.
See "Viewing a Safety Stock Simulation Detail report" on page 368.

Detail re-
port

Infor Demand Planning User Guide | 359

Inventory Planner



Opens the Safety Stock Simulation dialog before displaying the Safety Stock Simulation
Weeks of Supply Report, the Current Weeks of Supply Report and the Weeks Forward
Cover Histogram.
See "Viewing a Weeks Cover report" on page 368.

Weeks
cover

Reloads the originally-selected Channel Products into the safety stock simulation.
See "Reloading the Channel Products" on page 370.

Reload

Opens the Safety Stock Simulation dialog before saving the changes you have made in
this session.
See "Applying a safety stock simulation" on page 370.

Save
changes

Generating

Generating a safety stock simulation

1  In Inventory Planner, select the Channel Products for which you want to simulate the effect of
applying various safety stock strategies.
See "About selecting Products and Channels" on page 35.

2 Select Modules > Inventory Planner > Safety Stock Simulation.
The Safety Stock Simulation Options dialog box is displayed.

3 Optionally, in the Weight by box, select a static weighting by which to weight the simulation.
4 Optionally, in the Scale by box, type the factor by which you want to scale the simulation.
5 Select the Analyse non-stocked items check box if you want to include Products that are not

stocked at the selected Channels, for example, to see if it would be worth while stocking them after
all.

6 Under Include in Analysis, specify whether you want to include Normal Products, Slow-Moving
Products, or both, in the simulation.

7 Click OK.
These three safety stock simulation windows are displayed by default:

• Safety Stock Simulation Exchange. See "About the Safety Stock Simulation Exchange window"
on page 363.

• Safety Stock Simulation Data. See "About the Safety Stock Simulation Data window" on page
363.

• Safety Stock Simulation Status. See "About the Safety Stock Simulation Status window" on page
365.

Note: 

• You can change the safety stock simulation options so that not all of these windows are displayed
by default.

• The easiest way to move between the windows is to use these toolbar buttons:
Safety Stock Simulation Exchange Window, Safety Stock Simulation Data Window, Safety
Stock Simulation Status Window
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• To close all the simulation windows at once, select Window > Close All.

Changing the safety stock simulation options

You can change the safety stock simulation options after generating a simulation. The changed options
apply to the simulations you generate from then onwards.

1 Select either the Safety Stock Simulation Exchange or the Safety Stock Simulation Status window.
2 Select Tools > Options.

The Safety Stock Simulation Options dialog box is displayed.
3 Specify whether you want the Safety Stock Simulation Data and Safety Stock Simulation Status

windows to appear by default when a new safety stock simulation is generated.
4 Under Default Values, select the safety stock strategy, and the upper and lower bounds of its

performance level, that are to be applied by default when a new safety stock simulation is generated.
5 Select the Include Line Fill and Order Fill check box to include two additional rows in the Safety

Stock Simulation Exchange window.
These rows express the expected service level in terms of the percentage of orders and lines (of
orders) filled.

Note: 

• The Safety Stock Simulation Exchange window always appears by default.

• To add the additional Line Fill and Order Fill rows to the Safety Stock Simulation Exchange
window, you must either recalculate the simulation or reload the Channel Products.

Selecting the safety stock strategy

While working on a safety stock simulation, you can change the simulated strategy.

On the Safety Stock Simulation toolbar, select the required safety stock strategy.
The content of the Safety Stock Simulation Exchange window is updated automatically.

Specifying performance levels

You can vary the effect of a simulated safety stock strategy by specifying a range of performance levels
and a particular level within that range.

By using the toolbar

1 In the Lower and Upper boxes on the Safety Stock Simulation toolbar, type the upper and lower
bounds of the desired range.

2 Select Tools > Recalculate.
The content of the Safety Stock Simulation Exchange window is updated.

By using the Safety Stock Simulation Exchange window

Click the  and  buttons at the top of the Safety Stock Simulation Exchange window to increase
and decrease the lower, upper and mid-range performance levels in incremental steps.
The content of the Safety Stock Simulation Exchange window is updated automatically.
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Recalculating a safety stock simulation

You can force Inventory Planner to recalculate the safety stock simulation.

1 Select either the Safety Stock Simulation Exchange or the Safety Stock Simulation Status window.
2 Select Tools > Recalculate.

The simulated strategy, and the upper and lower performance levels, are as specified in the Safety
Stock Simulation toolbar.

Viewing a change log

While working on a safety stock simulation, you can view a log of the significant changes you have
made in this session.

On the Inventory Planner toolbar, click the Change Log Window button.
The Safety Stock Simulation Log Of Changes window appears, showing any changes you have
made to editable parameters in the Safety Stock Simulation Data window.

Weighting & Scaling

Weighting the safety stock simulation

While working on a safety stock simulation, you can change its weighting.

In the box to the right of the Scale By box on the Safety Stock Simulation toolbar, select the required
static weighting.

Note: Time-phased weightings are not available.

The contents of the Safety Stock Simulation Exchange, Safety Stock Simulation Data and Safety
Stock Simulation Plot windows are updated automatically.

Scaling the safety stock simulation

While working on a safety stock simulation, you can change its scaling.

1 In the Scale By box on the Safety Stock Simulation toolbar, type the required scale factor.
2 Select Tools > Recalculate.

The contents of the Safety Stock Simulation Exchange and Safety Stock Simulation Status windows
are updated automatically.

Note: This does not affect the Safety Stock Simulation Data window.

Changing the scaling in the Safety Stock Simulation Data window

1 Select the Safety Stock Simulation Data window.
2 Either double-click or right-click in the header of any editable column.
3 Type the new scale factor in the edit box.

Note: Changing this factor does not affect the data in any other safety stock simulation window, or
the data stored in the database.

4 Click OK.
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Simulation Windows

About the Safety Stock Simulation Exchange window

The Safety Stock Simulation Exchange window enables you to view the effect of varying the performance
level of the simulated strategy.

Apart from the strategy and the performance level, all the data used to calculate the simulated safety
stock is taken from the Safety Stock Simulation Data window.

You can independently change lower, upper and mid-range performance levels by using the  and 
buttons at the top of the window. The effects of the changed performance levels are shown immediately
in the window, in comparison with each other and the current strategy.

The following table describes how the effects are reported:

Lower, mid-range and upper performance levels.Performance Level

The calculated safety stock, expressed by value, by weighting
(if any), by units, by the average number of days’ cover it repre-
sents, and by the value of that cover.
See "Calculating simulated safety stock".

Safety Stock by:

Using the calculated safety stock, the expected annual short-
ages (stock-outs), expressed by value, by weighting, by units,
and by the number of such occurrences.
See "Calculating simulated annual shortages".

Annual Shortages by:

Using the calculated safety stock, the expected percentage
service levels, expressed by value, by weighting, by units and
(optionally) by orders filled and lines filled.
See "Calculating simulated service levels".

Service Levels by:

The Order Fill and Line Fill service levels are not shown by default. You need to enable them by
changing the safety stock simulation options.

See "Changing the safety stock simulation options" on page 361.

Whenever the safety stock simulation is recalculated, or the selected Channel Products are reloaded,
the content of the Safety Stock Simulation Exchange window is updated by appending a new simulation.
You can view the effects of the previous simulations merely by scrolling back the window.

Note: Weighted values are shown only if the weighting identified in the Safety Stock Simulation toolbar
is other than Units or Standard Cost. The Standard Cost weighting is typically based on the "Cost Price
(CPt)" field.

About the Safety Stock Simulation Data window

The Safety Stock Simulation Data window shows, for each selected Channel Product, the data used
to calculate its current safety stock.

The data is presented in a table, with one row for each Channel Product. The table is sorted first by
Product and then by Channel.
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Editable columns
Some of the columns are editable, so that you can see the effect of changing the data in the simulation.
However, none of the changes you make in this window are ever saved to the database; Infor Demand
Planning reminds you of this the first time you edit data during a session.

The editable columns have a headings with a white background; non-editable columns have headings
with a dark grey background. To edit a cell in an editable column, double-click the cell, type a new
value, then press ENTER.

Shaded rows
A completely shaded row means that the corresponding Channel Product has an incomplete set of
data and so cannot participate in the simulation. However, you may be able to edit the data in this
window to make it eligible. (To see the effect of such a change, you must close the window then re-open
it.)

A Channel Product cannot be simulated if any of the following Channel Product fields are null or zero:

• "Lead Time (CPt)"

• "Stocked Product (CPt)"

• "Increment (CPt)"

• "Preferred Lot Quantity (CPt)"

• "Safety Stock Strategy (CPt)"

• "Safety Stock Performance Level (CPt)"

• "Replenishment Period (CPt)"

• "Working Stock Calculate From Replenishment Period Or Lot Quantity (CPt)"

• "Cost Price (CPt)"

In addition to these required fields, a Channel Product also cannot be simulated if "Chance Customer
Order (CPt)" is greater than 100.

Finally, a row is also shaded if no statistical forecast exists for the Channel Product. In this case, there
is nothing you can do in Inventory Planner to make it eligible.

What’s shown in the window?

Required?Editable?Column

NoNoProduct Code

NoNoChannel Code

NoYesUnit or Weighting

NoYesEstimated Annual Usage

  Estimated Annual Usage
(Weighted)
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YesYesLead Time

NoYesStandard Deviation

NoNoStandard Deviation Across LT

  Standard Deviation Across LT
(Weighted)

NoYesReplenishment Period

YesYesPreferred Lot Quantity

YesYesCost Price *

YesNoCurrent Strategy

YesNoCurrent Performance Level

NoNoSafety Factor

NoNoAverage Safety Stock

YesNoStocked Item

NoNoSMP Code

NoNoWeight/Unit

NoNoCube/Unit

£ 100%Yes% Chance of being on order

NoYesAverage Quantity Per Order Line

NoNoCarrying Charge %

NoNoDays Cover

About the Safety Stock Simulation Status window

The Safety Stock Simulation Status window shows the current total estimated annual usage, service
levels and inventory investments (safety stock and working stock) for the selected Channel Products.

Because this is current data, the contents of this window do not change during a simulation, except
when you change the scaling or, of course, if you decide to apply the simulated strategy.

The data is presented in three sections.

Stock/Service Current Status

The number of Products selected.Number Of Products

The number of Channels selected.Number Of Channels

The number of Channel Products selected.Number Of CPs

The number of Normal Products selected.Number Of Normal Products

The number of Slow-Moving Products selected.Number Of SMPs
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The sum of the "Estimated Annual Usage (CPt)" for the selected
Channel Products.

Total Estimated Annual Usage
Units

The sum of "Estimated Annual Usage (CPt)"× "Cost Price (CPt)".Total Estimated Annual Usage
by Standard Cost

The sum of "Estimated Annual Usage (CPt)"× "Weight/Unit (Pt)".Total Estimated Annual Usage
by Weight Unit

The sum of "Estimated Annual Usage (CPt)"× "Cube/Unit (Pt)".Total Estimated Annual Usage
by Cube Unit

Customer Service
This section shows calculations of customer service levels, assuming current stock levels and forecast
consumption.

Shortages expressed as a percentage (units supplied from
stock / total requirements) and as a number of shortages
over a year.
See "Calculating the number of shortages".

By Number of Shortages

Backorders expressed as a percentage (orders supplied
from stock / total orders) and as a value of the backorders
at standard cost over a year.
See "Calculating the value of backorders".

By Value of Backorders

Inventory Investment
This section shows three stock categories, each expressed in units, the value of those units (at cost
price), the average weeks’ cover represented by that stock and the value of the average weeks cover.

The total calculated safety stock at the end of the lead time.
See "Calculating the inventory investment in safety stock".

Safety Stock

The total calculated working stock (half of the preferred lot
quantity for each Channel Product).
See "Calculating the inventory investment in working stock".

Working Stock

The safety stock plus the working stock.Theoretical Stock On Hand

Simulation Reports and Exchange Curves

About the Safety Stock Simulation Detail report

The Safety Stock Simulation Detail Report shows the detailed effects of the simulated strategy at a
particular performance level.

The data is presented in a table, with a row for each Channel Product. The table is sorted first by
Product and then by Channel.
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MeaningColumn

The Product code.Product Code

The Channel code.Channel Code

The standard deviation of forecast errors over the lead time.
"Standard Deviation Covering The Re-supply Lead Time (CPt)".

Std dev across lt

The projected forecast for the next twelve months, ignoring discon-
tinuation dates, forecast horizons or market intelligence.
"Estimated Annual Usage (CPt)".

Annualised usage

The number of replenishment lots in a year.
"Estimated Annual Usage (CPt)" divided by "Preferred Lot Quantity
(CPt)".

Lots per year

The current level of safety stock, prior to this simulation.
"Safety Stock Units (CPt)".

Current safety stocks - units

The safety stock recommended by this simulation (depends on the
strategy and the performance level).

Simulated safety stocks - units

The number of weeks cover with current safety stock, given the
annualized usage.
"Safety Stock Units (CPt)" multiplied by 52 divided by the "Estimated
Annual Usage (CPt)".

Current safety stocks - weeks
cover

The number of weeks cover with simulated safety stock, given the
annualized usage.

Simulated safety stocks - weeks
cover

The value of the current safety stock at standard cost.
"Safety Stock Units (CPt)" multiplied by "Cost Price (CPt)".

Current safety stocks - value

The value of the simulated safety stock at cost price.Simulated safety stocks - value

The current safety stock, weighted as specified in the toolbar. This
column appears only if the weighting is other than Units or Standard
Cost.
"Safety Stock Units (CPt)" multiplied by the weighting identified in
the Safety Stock Simulation toolbar.

Current safety stocks - by
weighting

The simulated safety stock, weighted as specified in the toolbar.
This column appears only if the weighting is other than Units or
Standard Cost.

Simulated safety stocks - by
weighting

The percentage by which the simulated safety stock exceeds the
current safety stock.

% change

Indicates whether the current safety stock is limited by shelf life,
storage capacity or minimum/maximum limits.

Current limited by

Indicates whether the simulated safety stock is limited by shelf life,
storage capacity or minimum/maximum limits.

Simulated limited by
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Note: 

• The Standard Cost static weighting is typically based on the "Cost Price (CPt)" field.

Viewing a Safety Stock Simulation Detail report

While working on a safety stock simulation, you can view a Safety Stock Simulation Detail report.

1 Select either the Safety Stock Simulation Exchange or the Safety Stock Simulation Status window.
2 Select Reports > Detail Report.

The Safety Stock Simulation dialog box is displayed.
3 Type or select a particular performance level for the strategy being simulated, then click OK.

The report appears in a Safety Stock Simulation Detail Report window.

Note: To change the appearance of the report, select Tools > Fonts.

About the Weeks Cover report

The Weeks Cover report categorizes the selected Channel Products according to how many weeks of
supply are covered by their respective current safety stocks. The Channel Products’ current safety
stocks are compared with those recommended by the simulated strategy at a particular performance
level.

The report consists of three parts, displayed in three separate windows:

• Current Weeks of Supply report

This report relates to the Channel Products’ current safety stocks.

See "About the Current Weeks of Supply report" on page 353.

• Safety Stock Simulation Weeks of Supply report

This report relates to the simulated strategy at a particular performance level.

See "About the Safety Stock Simulation Weeks of Supply report".

• Weeks Forward Cover histogram

This graph compares the current and simulated positions.

See "About the Weeks Forward Cover histogram" on page 354.

Viewing a Weeks Cover report

While working on a safety stock simulation, you can view a Safety Stock Simulation Detail report.

1 Select either the Safety Stock Simulation Exchange or the Safety Stock Simulation Status window.
2 Select Reports > Weeks Cover Report.

The Safety Stock Simulation dialog box is displayed.
3 Type or select a particular performance level for the strategy being simulated, then click OK.

The report appears in three parts, in three separate windows:

• Current Weeks of Supply report. See "About the Current Weeks of Supply report" on page 353.
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• Safety Stock Simulation Weeks of Supply report. See "About the Safety Stock Simulation Weeks
of Supply report".

• Weeks Forward Cover histogram. See "About the Weeks Forward Cover histogram" on page
354.

About the Exchange Curve graphs

When investigating a safety stock simulation, you can view three types of exchange curve graphs. An
exchange curve shows, for the simulated strategy identified in the Safety Stock Simulation toolbar, the
trade-off between the investment in stock and the performance achievable.

The three types of exchange curve are:

• Backorders vs. Stock Investment

The quantity of backordered stock that can be expected in a year for a given quantity of safety stock.

• Shortages vs. Stock Investment

The quantity of shortages that can be expected in a year for a given quantity of safety stock.

• Stock Investment vs. Service Level

The quantity of safety stock needed to secure a given service level (defined as the percentage of
estimated annual usage that is not shortages).

In each case, Infor Demand Planning plots the curve for twenty different performance levels between
the upper and lower bounds shown in the Safety Stock Simulation toolbar.

Each graph also shows the current trade-off as an intersecting pair of red lines. If one or both of the
current values are off the chart, red arrows indicate the direction along the axes to where they are
located.

Viewing a Backorders vs. Stock Investment graph

On the Inventory Planner toolbar, click Plot.
The Safety Stock Simulation Plot window appears showing a Backorders vs. Stock Investment
graph.

Viewing a Shortages vs. Stock Investment graph

1 On the Inventory Planner toolbar, click Plot.
The Safety Stock Simulation Plot window appears showing a Backorders vs. Stock Investment
graph.

2 On the Safety Stock Simulation Plot toolbar, click the Shortages vs. Stock Investment button.
The Safety Stock Simulation Plot window changes to show a Shortages vs. Stock Investment graph.

Viewing a Stock Investment vs. Service Level graph

1 On the Inventory Planner toolbar, click Plot.
The Safety Stock Simulation Plot window appears showing a Backorders vs. Stock Investment
graph.

2 On the Safety Stock Simulation Plot toolbar, click the Stock Investment vs. Service Level button.
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The Safety Stock Simulation Plot window changes to show a Stock Investment vs. Service Level
graph.

Applying

Applying a safety stock simulation

When you are satisfied with the result of a safety stock simulation, you can apply the strategy that is
identified in the Safety Stock Simulation toolbar to the selected Channel Products.

1 Select either the Safety Stock Simulation Exchange or the Safety Stock Simulation Status window.
2 Select File > Save.

The Safety Stock Simulation dialog box is displayed.
3 Type or select a particular performance level for this strategy, then click OK.
4 Click OK to acknowledge the completion of the process.

The Output pane shows this information:

• The number of Channel Products processed, and the number successfully updated
• The safety stock strategy, and its performance level
• Whether any exception views were generated

Note: 

• The parameters used for the calculation of safety stock are those currently stored in the database,
not the (possibly edited) parameters in the Safety Stock Simulation Data window.

• To close the Output pane, select View > Output.

Reloading the Channel Products

You can force Inventory Planner to reload the originally-selected Channel Products into the safety stock
simulation.

Select Tools > Reload.
The simulated strategy, and the upper and lower performance levels, are as specified in the Safety
Stock Simulation toolbar.

Safety Stock Calculations

About the safety stock calculations
This topic summarizes the calculation of the following inventory fields:

"Estimated Annual Usage (CPt)" on page 371  Estimated Annual Usage (CPt)

370 | Infor Demand Planning User Guide

Inventory Planner



"Preferred Lot Quantity (CPt) or Replenishment Period (CPt)" on page 371  Preferred Lot Quantity (CPt)
or Replenishment Period (CPt)

"Standard Deviation Covering The Re-supply Lead Time (CPt)" on page 372  Standard Deviation Covering
The Re-supply Lead Time (CPt)

"Safety Factor (CPt)" on page 372  Safety Factor (CPt)

"Annual Average Safety Stock (CPt)" on page 372  Annual Average Safety Stock (CPt)

"Days Cover (CPt)" on page 372  Days Cover (CPt)

"Safety Stock Units (CPt)" on page 373  Safety Stock Units (CPt)

"Re-order Point (CPt)" on page 373  Re-order Point (CPt)

"Theoretical Stock On Hand (CPt)" on page 374  Theoretical Stock On Hand (CPt)

In this topic, all fields are in the Channel Products table, apart from the number of "Forecast Periods
Per Year (St)".

Estimated Annual Usage (CPt)
If the Channel Product’s forecast is positive for the whole of the next year, the estimated annual usage
is either

Estimated Annual Usage = ( Level * 12 ) + ( Growth * 78 )

or

Estimated Annual Usage = ( Level * 13 ) + ( Growth * 91 )

depending on whether Forecast Periods Per Year (St) is 12 or 13. This is a simple forward projection
of the current level and growth over the next year, ignoring market intelligence, effectivity and
discontinuation dates, and the forecast horizon.

If the forecast becomes negative during the next year, then the estimated annual usage is calculated
by averaging the trends for the periods that are positive, and then extrapolating this over the whole
year:

Estimated Annual Usage = { ( Level ´ N ) + ( Growth ´ (1 + 2 + 3 + … + N ) ) } ´ ( Forecast Periods Per
Year / N )

where N  is the number of consecutive positive periods. The estimated annual usage is constrained to
be no less than 1.

See "Calculating estimated annual usage".

Back to top: "About the safety stock calculations" on page 370

Preferred Lot Quantity (CPt) or Replenishment Period (CPt)
If Working Stock Calculated From Replenishment Period Or Lot Quantity (CPt) = 0, then

Replenishment Period = ( 365 ´ Preferred Lot Quantity ) / Estimated Annual Usage

If Working Stock Calculated From Replenishment Period Or Lot Quantity (CPt) = 1, then
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Preferred Lot Quantity = Estimated Annual Usage ´ ( Replenishment Period / 365 )

Back to top: "About the safety stock calculations" on page 370

Standard Deviation Covering The Re-supply Lead Time (CPt)
Standard Deviation Covering The Re-supply Lead Time = Standard Deviation ´Ö { Forecast Periods
Per Year ´ ( Lead Time / 365 ) }

Back to top: "About the safety stock calculations" on page 370

Safety Factor (CPt)
The safety factor, often represented by the letter k, depends on the chosen safety stock strategy and
performance level.

See "About the safety stock strategies" on page 355.

For Strategy 2: Specified Number of Safety Factors, the safety factor is simply the specified performance
level:

Safety Factor = Safety Stock Performance Level

For other strategies that use a safety factor, the details of the calculation are beyond the scope of this
help file. For further information, refer to your Infor Demand Planning consultant.

Back to top: "About the safety stock calculations" on page 370

Annual Average Safety Stock (CPt)
The calculation of the annual average safety stock depends on the strategy.

For Strategy 5: Days Supply

Annual Average Safety Stock = ( Estimated Annual Usage /365 ) ´ Safety Stock Performance Level

For Strategy 6: Nominated Average Safety Stock Quantity

Annual Average Safety Stock = Safety Stock Performance Level

For all other strategies

Annual Average Safety Stock = Standard Deviation Covering The Re-supply Lead Time ́  Safety Factor

Back to top: "About the safety stock calculations" on page 370

Days Cover (CPt)
For Strategy 5: Days Supply

Days Cover = Safety Stock Performance Level + Contingency Stock

For all other strategies

Days Cover = ( Annual Average Safety Stock ´ 365 / Estimated Annual Usage ) + Contingency Stock

However, if the safety stock is time-phased, Days Cover (CPt) may be constrained as follows:
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Days Cover £ Monthly Forecast Horizon - Lead Time + 2

Days Cover ³ Minimum Time-phased Safety Stock Days

Days Cover £ Maximum Time-phased Safety Stock Days

CPs that are constrained by these limits are listed in the FCST HOR SHORT or TPSS LIMIT exception
view, as appropriate.

Back to top: "About the safety stock calculations" on page 370

Safety Stock Units (CPt)
If the safety stock is not time-phased, it is given by:

Safety Stock Units = Annual Average Safety Stock + NF(Lead Time + Contingency Stock) - NF(Lead
Time)

where NF(x) is the net forecast for the next x days.

Note that, solely for the purpose of this calculation:

Contingency Stock £ Monthly Forecast Horizon - Lead Time + 2

CPs that are constrained by this limit are listed in the FCST HOR SHORT exception view.

If the safety stock is time-phased, the safety stock is the net forecast (that is, statistical forecast plus
market intelligence, including customer forecast where applicable) for the number of days cover after
the lead time.

Safety Stock Units = NF(Lead Time + Days Cover) – NF(Lead Time)

However, this value may be constrained as follows:

Safety Stock Units ³ Minimum Time-phased Safety Stock Units

Safety Stock Units £ Maximum Time-phased Safety Stock Units

CPs that are constrained by these limits are listed in the TPSS LIMIT exception view.

Back to top: "About the safety stock calculations" on page 370

Re-order Point (CPt)
For a Normal Product, or for a Slow-Moving Product for which SMP Re-order Point Code (CPt) is 1,
the re-order point is simply the net forecast over the lead time, plus the safety stock.

Re-order Point = NF(Lead Time) + Safety Stock Units

For a Slow-Moving Product for which SMP Re-order Point Code (CPt) is 0, the re-order point is given
by the greater of:

Re-order Point = NF(Lead Time) + Safety Stock Units

or

Re-order Point = { SMP Average Event ´ INTEGER[ 1 + ( active days ´ Forecast Periods Per Year ´
SMP Chance Of Monthly Event / 365 ) ] } + Safety Stock Units
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where active days is the number of active days in the lead time, taking into account the effectivity and
discontinuation dates (if any).

For SMPs that have added market intelligence, the safety stock strategy must be Strategy 5: Days
Supply.

Back to top: "About the safety stock calculations" on page 370

Theoretical Stock On Hand (CPt)
The theoretical stock on hand is calculated as the annual average safety stock, plus the average working
stock, plus contingency stock.

Theoretical Stock On Hand = Annual Average Safety Stock + ( Preferred Lot Quantity/2 ) + ( Contingency
Stock × ( Estimated Annual Usage/365 ))

The maximum expected on-hand stock is the annual average safety stock plus the preferred lot quantity
plus the annual average contingency stock. If this value exceeds the Maximum Storage Capacity (CPt),
the CP is added to an OHS OVER MAX exception view; if it exceeds the Shelf Life (CPt), the CP is
added to an OHS OVER SHELF exception view. (Alternatively, the current user may simply be warned
of these conditions.)

Back to top: "About the safety stock calculations" on page 370

Data used in safety stock calculations

Channel Products table fields
The information required for calculating safety stock depends on the safety stock strategy. The following
table shows, for each of the seven strategies, the Channel Products table fields involved in the
calculations.

7654321 

YesYesYesYesYesYesYes"Annual Average Safety Stock (CPt)"

YesYesYesYesYesYesYes"Annualised Forecast (CPt)"

   Yes   "Carrying Charge (CPt)"

YesYesYesYesYesYesYes"Contingency Stock (CPt)"

   YesYes  "Cost Price (CPt)"

  Yes   Yes"Estimated Annual Usage (CPt)"

Yes  YesYesYesYes"Lead Time (CPt)"

    Yes  "Preferred Lot Quantity (CPt)"

Yes  Yes  Yes"Replenishment Period (CPt)"

YesYesYesYesYesYesYes"Safety Stock Units (CPt)"

YesYesYesYes YesYes"Safety Stock Performance Level (CPt)"
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YesYesYesYesYesYesYes"Safety Stock Strategy (CPt)"

Yes  YesYesYesYes"Standard Deviation (CPt)"

Yes  YesYesYesYes"Standard Deviation Covering The Re-supply Lead
Time (CPt)"

   Yes   "Chance Customer Order (CPt)"

Updating inventory fields
You may need to update the database fields used in the safety stock calculations to ensure that they
contain up-to-date data. Essentially, all the safety stock and re-order point calculations are re-done,
except for the safety factor k, stored in "Safety Factor (CPt)".

Usually, these fields are kept up to date automatically, for example as part of the period end process,
or as a consequence of changing the net forecast in the Demand Forecaster module. Occasionally,
however, you may need to update the fields manually; for example, if you import net forecast changes
from outside Infor Demand Planning.

1 In Inventory Planner, select the Channel Products to be updated.
See "About selecting Products and Channels" on page 35.
Infor Demand Planning automatically excludes ineligible or invalid CPs from your selection.

2 Select Modules > Inventory Planner > Update Inventory Fields.
3 Click OK to acknowledge the completion of the process.

An Output pane appears, showing the number of Channel Products updated, and whether any
exception views were generated:

• "DATA CHANGED"
• "FCST HOR SHORT"
• "INVALID SS DAT"
• "INVALID TPSS CODE"
• "OHS OVER MAX"
• "OHS OVER SHELF"
• "TPSS LIMIT"

Note: To close the Output pane, select View > Output.

Recalculating inventory fields
The difference between this function and merely updating the inventory fields is that in this case the
safety factor k is also recalculated.

1 In Inventory Planner, select the Channel Products for which you want to calculate safety stocks.
See "About selecting Products and Channels" on page 35.
Infor Demand Planning automatically excludes ineligible or invalid CPs from your selection.
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2 Select Modules > Inventory Planner > Recalculate SIPS Fields.
The Recalculate SIPS dialog box is displayed.

3 Clear the Include Scenarios check box if you want to exclude any selected Scenario Products.
4 Select the Save Unprocessed Items check box to ensure that, if you cancel the process before it

completes, or if it is interrupted for some other reason, the Channel Products that are not processed
are included in an INCOMPLETE SIPS exception view.

5 Click OK to start the calculation.
An Output pane appears, showing the number of CPs processed and whether any exception views
were generated:

• "DATA CHANGED"
• "INCOMPLETE SIPS"
• "INVALID SS DAT"
• "NO SIPS CALCS"

When the process is complete, Infor Demand Planning updates the database with the new safety
stocks.

Note: 

• For Channel Products that use safety stock strategy 3: Service Level By Order Fill, or 4: Minimise
Shortage Occurrences, you should first determine meaningful performance levels by manually
applying safety stock simulations. Subsequently, you can recalculate the safety stocks with this
function.

• To close the Output pane, select View > Output.

Ineligible and Invalid CPs

About ineligible items excluded from the safety stock calculations

The following classes of Products are excluded from the safety stock calculations:

• Forecast Group Products

Each FGP is a placeholder for a group of related Products. They have no safety stock of their own.

• Unspecified Forecast Products

UFPs are not fully operational items, so they do not need safety stock.

• Returns Products

Returns Products are returned to the stocking location; there is no reason to stock against shortages
or calculate safety stocks.

• Products that are dead

However, dead Products are included in safety stock simulations.

• Products that are not stocked at a particular Channel
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However, non-stocked Products can optionally be included in safety stock simulations.

• Products that are not forecast, but which attempt to use safety stock strategies that rely on the
forecast error

The following safety stock strategies use the standard deviation of forecast errors over the re-supply
lead time:

• 1: Specified Service Level by Item

• 2: Specified Number of Safety Factors

• 3: Service Level by Order Fill

• 4: Minimise Shortage Occurrences

• 7: Anticipated Years Between Shortages

But for items where "Forecast Calculation Code (CPt)"= 1, there is no forecast, and so no forecast
error.

For each of these excluded items, Infor Demand Planning resets the strategy to 6: Nominated Average
Safety Stock Quantity, and sets the relevant Channel Products table fields to zero (apart from the
"Estimated Annual Usage (CPt)", which is set to 1).

About invalid items excluded from the safety stock calculations

The following table shows, for each safety stock strategy, the invalid data that prevents a safety stock
being calculated.

Invalid DataStrategy

SMP Code Î {1,2} and SMP ROP Code Ï {0,1}
Working Stock Calculated From Replenishment Period Or
Lot Quantity = 0 and Preferred Lot Quantity £ 0

All strategies

Working Stock Calculated From Replenishment Period Or
Lot Quantity = 1 and Replenishment Period £ 0
Time-phased Safety Stock Code Ï {1,2,3,4,5}
Safety Stock Strategy Ï {1,2,3,4,5,6,7}
 

Safety Stock Performance Level < 0
Safety Stock Performance Level ³ 1

1: Specified Service Level by Item

 

Cost Price £ 0 or Chance Customer Order £ 0
Safety Stock Performance Level £ 0

2: Specified Number of Safety Factors

 

Cost Price £ 0 or Carrying Charge £ 0
Safety Stock Performance Level £ 0

3: Service Level by Order Fill
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Safety Stock Performance Level £ 0
 

4: Minimise Shortage Occurrences

Lead Time £ 0
Standard Deviation £ 0

5: Days Supply

Safety Stock Performance Level < 0
 

Lead Time £ 0
Standard Deviation £ 0

6: Nominated Average Safety Stock
Quantity

Safety Stock Performance Level < 0
 

Safety Stock Performance Level £ 07: Anticipated Years Between Shortages

Note: 

• All fields are within the Channel Products table.

Economic Order Quantities

About economic order quantities
The economic order quantity (EOQ) is the quantity at which the combined cost of an order is at a
minimum. The combined cost consists of:

• stock holding costs (that rise with increasing order size)

• costs of raising procurement or production orders (that fall with reduced numbers of orders)

Having calculated the EOQ you can, if you wish, make each item’s preferred lot quantity equal to the
EOQ.

See "About the EOQ calculation" on page 379.

See "About the constraints on the EOQ" on page 379.

See "About the assumptions underlying the EOQ calculation" on page 379.

Note: 

• You cannot calculate EOQs for Returns Products, Forecast Group Products, Unspecified Forecast
Products or dead Products.
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About the EOQ calculation
The formula used for the calculation of the EOQ is:

Q =   √((2*A*S) / (r*v))

Q =  "EOQ (CPt)"

A =  "Set-up Cost (CPt)"

S =  "Estimated Annual Usage (CPt)"

r =  "Carrying Charge (CPt)"

v =  "Cost Price (CPt)"

If any of the calculation fields are zero or negative for a particular Channel Product then Infor Demand
Planning sets EOQ (CPt) to 1 and adds that Channel Product to the "EOQ CALC INVALID" exception
view.

About the constraints on the EOQ
Infor Demand Planning automatically adjusts the calculated EOQ to fulfil to the following constraints:

• The EOQ must be no less than the "Minimum Lot Quantity (CPt)" and the "Minimum Days Supply
(CPt)".

• The EOQ must be no greater than the "Maximum Storage Capacity (CPt)" and the "Maximum Days
Supply (CPt)".

• If the minimum constraint is greater than the maximum constraint, the maximum constraint takes
preference and the EOQ can be less than the minimum.

• The EOQ quantity is always rounded up to the nearest increment (regardless of the above constraints)
using the value of "Increment (CPt)".

If any of the constraint fields are zero for a Channel Product, its EOQ is unconstrained.

About the assumptions underlying the EOQ calculation
You should be careful about how you interpret the EOQ as the model is based on a number of important
assumptions:

• The carrying charge is constant. While this assumption might be correct for factors such as the
funds invested in stocks, other costs might increase discontinuously as stock levels increase. For
example, additional staff might be hired as inventory reaches certain levels. Conversely, if stocks
decline, it may be that casual labor can be downsized once stocks fall to a certain critical level.

• The average stock balance is equal to half of the order quantity. If a constant amount of stock is not
used per day, this assumption will be incorrect; seasonal and cyclical factors can produce uneven
usage over time.
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• Safety stocks can be ignored. This rests on the assumption that safety stocks remain the same
irrespective of the order size. However, the amount of safety stock is probably not independent of
the order quantity as relatively larger safety stocks are likely to be associated with smaller order
quantities.

Calculating EOQs
1 In Inventory Planner, select the Channel Products for which you want to calculate economic order

quantities.
See "About selecting Products and Channels" on page 35.

2 Select Modules > Inventory Planner > Economic Order Quantities > Calculate.
The Economic Order Quantity Options dialog box is displayed.

3 Select the Analyse non-stocked items check box if you want to include Products that are not
stocked at the selected Channels.

4 Under Include in Analysis, specify whether you want to include Normal Products, Slow-Moving
Products, or Scenario Products in the calculation.

5 Click OK.
The Output pane shows this information:

• When the EOQ calculation began and ended
• The number of Channel Products processed
• Whether any exception views were generated

See "EOQ exception views" on page 381.

Note: 

• To close the Output pane, select View > Output.

• If exception views are generated, they overwrite any existing views of the same name.

Making the preferred lot quantity equal to the EOQ
Infor Demand Planning typically refers to an item’s preferred lot quantity when generating a schedule
of orders for that item. It can therefore be sensible to set the preferred lot quantity equal to the economic
order quantity. Both of these values are held in the Channel Products table.

In Database Administration, select the required Channel Products and copy the EOQ column to the
Preferred Lot Quantity column of the Channel Products table. (Both fields are included in the Inventory
Planner report.)
See "Editing the Channel Products table" on page 116.
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EOQ exception views
The following exception views can be generated by the EOQ calculation:

• "NO EOQ DEAD"
• "NO EOQ UFP"
• "NO EOQ PFG"
• "NO EOQ RETURNS"
• "EOQ NOT COMPLETE"
• "EOQ BELOW MIN LT QTY"
• "EOQ BELOW MIN DY SUP"
• "EOQ ABOVE MAX CAP"
• "EOQ ABOVE MAX DY"
• "EOQ MIN ABOVE MAX"
• "EOQ CALC INVALID"

Note: 

• If exception views are generated, they overwrite any existing views of the same name.
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7Replenishment Planner

About Replenishment Planner
The central concept of the Infor Demand Planning Replenishment Planner module is that requirements
are unified across all stocking locations, and upward through all Channels of distribution, to enable
production to be planned on a realistic basis of stock status and requirements at each location. The
stock available at the source is distributed to replenish the depots in a balanced way to achieve the
maximum possible sales service level.

For example, the forecast at lower level depots is used to generate an order on the top level plant by
comparing the forecast requirements with the stock on hand and the safety stock target. The orders
are passed to the plant where they are aggregated and further orders created by comparing the depot
requirements with the plant’s stock on hand and safety stock target. Orders may be created for internal
or external supply.

Orders generated by Infor Demand Planning are recommended; they may be accepted or edited and
confirmed as open (firm). Shipment instructions from the plant to the depots are generated to attempt
to meet their requirements from the available stock at the plant.

Order creation
Orders are created starting at the lowest level of the Channel matrix. Each Channel has a series of
orders created which can be used by the Channel above as requirements if the Channel behaviors are
set accordingly.

The lowest level obtains its requirements from the forecast at that level. This is obtained directly from
the Net Forecast table. Existing stock variations from target are taken in to account when calculating
requirements from the forecast. Actual stock levels, including stock in transit and current open orders
are compared to targets, which may include (time-phased) safety stock, contingency stock and stock
target overrides. The calculated orders based on the above are passed to the next level in the Channel
structure.

At each subsequent higher level the same process occurs, except that the requirements from below
are orders instead of the forecast.

Reports
A series of reports are available, designed to provide a view of the orders in progress, the forecast
demand and the resulting stock movements at various levels within the matrix. Key reports are:
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• Order Viewer. A generic report that is accessed independently and by drilling down in other reports.
It looks like a spreadsheet and displays data selected from the Orders table. Some of this data is
editable. Orders are displayed for any Products and Channels in the current selection.

• Critical Report. Checks for order lines which are either late and need expediting, or early and need
to be deferred. The report operates on the currently-selected Products and Channels.

• Stock Report. Displays the stock position by Channel for the selected Products. Stock is displayed
against forecast sales and separated into status levels in order to provide information regarding
stock over or under supply. The information can also be displayed graphically.

• Stock Re-balancing. Lists all Channel Products scheduled for commitment. It indicates the quantity,
value, weight and cubic volume in addition to each order’s due date and release date. Within the
report, you can distinguish orders for distribution from a Channel and orders for receipt at a Channel.

• To be Committed Report. Shows the location of stock excesses and shortages, and highlights
situations where it may be beneficial to move stock to a Channel from somewhere other than the
primary source.

Balanced allocation
The aim of balanced allocation is firstly to ensure that, given enough stock, product is distributed from
a source to its lower level Channels in the most cost effective manner.

See "About balanced allocation" on page 390.

About the Supplier Selection screen
The Supplier Selection screen not only displays a list of suppliers a particular user is authorized to buy
from, it also shows additional information to help the buyer decide which supplier to use.

Using the normal item selection method in Infor Demand Planning, you select Products and Channels
and then the function you want to use. This is fine for a demand or inventory planner but it is not ideal
for a buyer. Buyers needs to see a list of suppliers that they are able to buy from, select one from the
list, and then have Infor Demand Planning select the items that this vendor is the primary supplier for.

In order to further enhance the usability of the Replenishment Planner module for users responsible
for purchasing, the "select on sign-on" functionality has been extended to include the Supplier Selection
screen as a default sign-on option. When selected, (default sign-on = "SUPPLIER"), the user is
automatically presented with the Supplier Selection screen directly after logging in to a database.

See "Editing a user" on page 63.

In addition to having the Supplier Selection screen display automatically as a sign-on default, you are
able to access the screen whilst logged in to the Replenishment Planner module by selecting File and
Supplier Selection or clicking the  icon on the main toolbar.

Screen Layout
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The Supplier Selection screen is displayed in a grid format showing those suppliers and assortments
associated with the current user, the number of associated items and the number of those associated
items that have "active" orders. The following columns are always displayed:

DescriptionColumn name

System generated code, unique for each supplier.Supplier Code

Unique code allocated to the assortment. An assortment is any Channel
Product grouping, as defined within your implementation, which is linked to

Assortment Code

suppliers using the Supplier Assortment function. Each Channel Product
can be assigned to an assortment using the "Assortment Code (CPt)" field.

Only displayed if the current user is associated with more than one buyer
group.

Buyer Group Code

Number of Channel Products existing at this assortment.Items

Number of Channel Products existing at this assortment, with recommended
orders due in the current review cycle.

Active Items

The rest of the columns displayed in the grid are the ones defined as available to particular users in
the Database Administration module.

See "Configuring the Supplier Select screen" on page 194.

Item Selection

Channel Product selections can be made in two ways:

• By selecting the row(s) of the required supplier/assortment, and then clicking the Go To button. This
will retrieve all relevant Channel Products, the number of which are shown in the Items column,
regardless of the existence of any recommended orders placed on that supplier.

• By clicking on the in-cell button within the Items or Active Items column. Selecting Items will load
all the Channel Products that exist at the selected supplier/assortment; effectively replicating the
selection of a single row above. Selecting Active Items will load those items that exist at the selected
supplier/assortment and have a recommended order placed on the selected supplier and due within
the defined review cycle. It is not necessary to select the Go To button when selecting items using
this method.

Note: When the Notes field is selected to be displayed, the grid displays a command button rather
than actual text. Clicking the ellipsis button will display the Supplier Notes dialog allowing you to view
existing notes and append new text as required.

Address Data

When an address code field is selected to be displayed, the grid displays a command button rather
than actual text. Clicking the ellipsis button will display the Address Data dialog showing all address
details for the selected code.

Go To button

Will open the user’s default "Go To" destination screen, as defined in the Maintain Users dialog in the
Database Administration module. The Supplier Selection screen remains open to allow you to make
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further selections, if necessary. If no rows are selected or the selected rows have an Items count of
zero, then the button is disabled.

Close button

Closes the screen leaving the current Channel Products selection unchanged.

Supply/Receiving Calendars

About receiving calendars
Receiving calendars show whether a resource or facility is available or unavailable on that day, for
each day of the year.

This kind of calendar is applied to Channel Products, by editing the Receiving Calendar Code (CPt)
fields. You can create as many calendars as you need.

A Channel Product’s receiving calendar typically shows when the item can be accepted or put away.

See "About rough cut capacity planning" on page 443.

Creating a receiving calendar
1 In Replenishment Planner, select Edit > Calendars.

The Open Calendar dialog box is displayed, listing the existing calendars.
2 Click Add.

The Calendar Definitions dialog box is displayed.
3 In the Name box, type a name for the new calendar.
4 In the Year box, type or select a year in the new calendar.
5 In the Show Calendar by: panel, select the day that each week starts in the Week starts on box.
6 To specify which days of the year are unavailable or available, do any of the following:

• Select a weekly recurring pattern in the Recurring pattern for: panel and click Apply.
• Right-click in the calendar grid and click Unavailable, Available or Toggle on the shortcut menu.

In the Date Range dialog, type the start and end of a range of dates and click OK.
• Right-click a row header when the cursor changes to  or a column header when the cursor

changes to  and then click Unavailable, Available or Toggle on the shortcut menu.

7 If the calendar is to be used for rough cut capacity planning (RCCP), in the View Calendar by: panel,
click Work Units. To specify the work units for one or more days, do either of the following:
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• Select the required month, click the individual cell you want to edit, type the new value, then click
outside the cell.

• Select a weekly recurring pattern in the Recurring pattern for: panel, type a value in the Work
Units box, and click Apply. The values are applied to all the months in the selected year.

See "About rough cut capacity planning" on page 443.

8 Click OK to save the details to the database and return to the Open Calendar dialog, which now
includes the new calendar.

9 Click Close.

Editing a receiving calendar
1 In Replenishment Planner, select Edit > Calendars.

The Open Calendar dialog box is displayed, listing the existing calendars.
2 Click the calendar to be edited and click Edit.

The Calendar Definitions dialog appears showing the details of the selected calendar.
3 Make the necessary changes and click OK to save them to the database and return to the Open

Calendar dialog.
4 Click Close.

Copying a receiving calendar
1 In Replenishment Planner, select Edit > Calendars.

The Open Calendar dialog box is displayed, listing the existing calendars.
2 Click the calendar to be copied and click Copy.
3 Click Yes to confirm.

A new calendar appears in the Defined Calendars panel with a description consisting of the name
of the copied calendar prefixed by "Copy of".

4 Click Edit if you want to rename or otherwise edit the new calendar.

Deleting a receiving calendar
1 In Replenishment Planner, select Edit > Calendars.

The Open Calendar dialog box is displayed, listing the existing calendars.
2 Click the calendar to be deleted and click Delete.
3 Click Yes to confirm.
4 Click Close.
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Forecasts

About forecast requirements
In the Replenishment Planner (RP) module, the requirements used to generate orders at each Channel
level are those which are passed up from lower levels in the matrix. Channels at the bottom of the
matrix use their forecast and pass requirements up as orders according to their Channel behaviors.

The forecast used by Infor Demand Planning to calculate requirements and orders is generated by the
Demand Forecaster (DF) module. To use this forecast in RP, the Net Forecast table must be updated.
This can be done in either DF or RP.

See "Updating the Net Forecast table" on page 388.

Updating the Net Forecast table
The forecast used to calculate requirements schedules is generated in the Infor Demand Planning
Demand Forecaster module. To use this forecast in Replenishment Planner, the Net Forecast table
must be updated. This can be done in either Demand Forecaster or Replenishment Planner.

1 In Replenishment Planner, select the required Channel Products.
See "About selecting Products and Channels" on page 35.

2 Select Batch > Load Forecasts from Demand Planning.
The Load Forecasts From Demand Planning dialog box is displayed.

3 Select the types of Product to include.
See "About Products" on page 33.

4 Choose to:

• Update Table. This option is not available if the existing Net Forecast table is for a month other
than the current one (normally this would be last month’s data).

• Overwrite Table. The data from the existing Net Forecast table (usually last month’s) is deleted
and new data assembled.

5 Select the periodicity required, Monthly, Weekly or Daily.

• If you choose to report the data in weekly periods and weekly history is stored on the database,
this is the reported history.

• If there is no weekly history stored on the database, the monthly history is interpolated into weeks
based on the calendar.

• The daily option is only available in a weekly-controlled database when "Allow Daily MI (St)" is
true and valid values exist in the "Daily Forecast Horizon In Weeks (St)" and "Weekly Forecast
Horizon (St)" fields.

See "About forecasting periodicity" on page 218.
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6 A short Description may be typed in the edit box if required.
7 Click OK to close the dialog and assemble the table.
8 Select View > Output to view the process log.

The Net Forecast table will now be up to date and can be exported (using Database Administration)
or used for interfacing to other systems.

Note: The setting of the "Net Forecast Table: Integer Or Decimal (St)" field determines whether the
forecast values are stored in integer (0) or decimal (1) format.

About forecast consumption
In a monthly-controlled database, the first forecast period's net forecast may be partly consumed by
open history (that is, demand to date). Forecast consumption is not possible in a weekly-controlled
database.

If this Channel Product is subject to forecast consumption (that is, if "Float Current Period Forecast
(CPt)" is true), Infor Demand Planning examines the available open history and applies the Channel's
"Forecast Consumption Rule (Ct)".

Generating orders from a forecast requires a specification of the manner in which a forecast is to be
phased over a lesser time period than the forecast interval. A daily consumption rate is obtained as
follows:

• If the "Level Of Forecast Control (St)" is monthly, the monthly forecast from the Net Forecast table
is broken down into a number of even daily values based on the demand calendar.

• If the "Level Of Forecast Control (St)" is weekly, forecasts are generated from the Weekly Net
Forecast table. If the weekly table does not exist, then monthly data is used as above. As the
forecasts in the weekly table already have interpolation vectors applied, these forecasts are used
and divided by 7 to give the daily rate.

There are four rules for forecast consumptionheld in the "Forecast Consumption Rule (Ct)" field:

• 1Consume at existing forecast rate

Daily Rate = Monthly Net Forecast / Days in the period. In this case, the net forecast is unchanged by
any open history.

• 2 Consume up to period forecast (then rule 1)

Daily Rate = (Forecast - Demand to date)/Days left in the period. Until the forecast is consumed, then
revert to rule 1. Calculates the difference between the net forecast and what has been sold (the open
history posted) in the month to date. It then divides this difference (which may be negative) evenly
between the remaining number of days in the month and adds this average value to the daily forecast
for each remaining day. However, if this calculation means that the remaining days are all less than or
equal to zero, then Infor Demand Planning reverts to the interpolated daily forecast described previously.

• 3 Consume at current selling rate
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Daily Rate = Demand to date/Days to date. Calculates the average daily open history for the month to
date, and uses this amount instead of the interpolated daily forecast for the rest of the month.

• 4 Consume up to period forecast (then zero)

Daily Rate = (Forecast - Demand to date)/Days left in period until the forecast is consumed, then daily
rate reverts to zero. The unconsumed forecast is spread evenly over remaining days, until all consumed.
As Rule 2, except that if the calculation means that the remaining days are all less than or equal to
zero then Infor Demand Planning treats this a zero forecast.

The field "Float Current Period Forecast (CPt)" controls whether or not a particular Channel Product
uses a forecast consumption rule. A value of 1 means the rule is used, and a value of zero means that
the rate derived from the forecast is used. (This is the same as rule 1).

Rules 2, 3 and 4 use the demand to date for the current period. Demand to date can be accumulated
daily, weekly or monthly. In the case where demand is only being loaded monthly, then forecast
consumption can only be based on the forecast and the stock date. If demand is being loaded daily
and / or weekly this is accumulated to give the demand to date from the Open Daily and Open Weekly
tables. The history type used for forecast consumption is the one stored in the "Forecast History Row
(CPt)" field, this is usually adjusted demand.

Channel Products in their last month of forecast before discontinuation, and using a forecast consumption
rule are only decreased at the daily rate. If demand is less than forecast during the last month the
remaining forecast will stay at the daily rate. If demand is higher than forecast (perhaps due to an effort
to shift stock before discontinuation) the forecast remaining will decrease, and if the entire month’s
demand is made before the end of the month, then the remaining daily forecasts are set to zero.

Balanced Allocation

About balanced allocation
The aim of balanced allocation is firstly to ensure that, given enough stock, product is distributed from
a source to its lower level Channels in the most cost effective manner. If there is a shortage of stock
at the source, a secondary aim is to arrange distribution such that sales service levels suffer by the
same amount across the network. If a complete stock out occurs, Infor Demand Planning aims to
ensure that all Channels go out of stock at approximately the same time.

The sequence for the shipping of stock from the plant to the depots when the plant has insufficient
stock is as follows. The key stock levels at the source are:

• No stock. Plant cannot ship.

• Some stock but not enough to fill all back orders. A fraction of the back orders will be filled.

• Fill back orders. Plant fills current back orders and then waits for back orders from depots before
filling them because it needs to build up its own safety stock.
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• Fill back orders and maintain a reserve. Enough to fill all back orders and maintain a reserve.

• Fill fraction of the lead time forecast. If enough stock is available the plant will ship back orders to
depots and some fraction of the demand, for example enough for 3 days.

• Fill all lead time demand. Will fill forecast demand over the lead time from the plant to the depot,
held at depot level.

• Fill all lead time demand and a fraction of safety stock. Fractions of the depot safety stock will be
filled proportionally.

• Fill all lead time demand and the safety stock at depots. Fill calculated safety stock requirements
at the depot.

• Fill to horizon. Maximum storage capacity and shelf life of Product is taken into account in this
calculation.

This information is provided in the form of exception views. There is also a critical flag exception which
advises whether to expedite an order or to defer one. If, on a ship day, there is a critical order, the order
can be rushed, that is, to get to the depot quicker than stated in the lead time. If an order needs to be
shipped today but it isn’t a designated ship day as defined by the supply calendar, the order can be
expedited.

A key calculation is to apportion the on-hand stock into free stock at the source and reserved stock.
Free stock is any stock left after back order allocation above reserved stock. Reserved stock is the
proportion of source safety stock (between all and none) as defined by the fraction of safety stock to
reserve, which is held in the "Proportion Of Safety Stock Reserved (CPt)" field.

Allocation is always performed in increments. All shipment allocations must be rounded to practical
shipping quantities according to requirements. Two fields control increments:

• "Increment (CPt)"
• "Minimum Lot Quantity (CPt)"

If adequate stock is available at the source to ship, the rounding is carried out as above.

However, if the shipment is limited by shortage of source stock, the total available quantity is divided
in lots as above. These lots are allocated by need in proportion to the unconstrained requirements and
rounded using this field:

"Units Per Case (CPt)"

Therefore, when full orders cannot be met, the calculated fair share value is rounded to be increments
of units_case.

There is also a minimum number of days cover to ship (at the forecast rate at that time), and a minimum
quantity to ship, both rounded up by the minimum increment.

Maximum limits are set so the allocations do not exceed the free stock at the source, rounded down
to increments. In addition this must be less than the storage capacity (measured when this order
arrives), rounded down, and must be less than the maximum days cover (based on requirements,
inclusive of back orders, not forecast rate) rounded down.

The suggested allocation can be edited to be more than the maximum or less than the minimum. In
these cases a warning is issued, which may be ignored. If an override is not a rounded quantity a
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warning is issued together with a rounding suggestion. If the suggested quantity is not taken, then it is
possible to ship in a non rounded quantity.

The safety stock at both the source and the subordinate Channel may vary. Calculations need to take
account of the safety stock at each available shipping opportunity.

In auto-commit mode, shipments are committed so that the projected stock on hand at the node when
the shipment after this one arrives is (at least) the safety stock at that time.

Stocked and non-stocked Channel Products
As defined in the Channel Products table, a Channel Product is either stocked or not. A stocked item
is treated as usual but a non-stocked item only gets considered for shipment if it has a back order
(negative on hand stock), and the only order generated is for the value of the back order, rounded up
to the minimum shipment. Normally, non-stocked products have a forecast of 0 and safety stock of 0,
and any on-hand stock is the result of working stock due to lot size.

Note: 

• Non-stocked Channel Products are not considered for expedite exceptions.

Balanced allocation calculations
Balanced allocation progresses through stages attempting to fill stock to a certain stage for all of the
Channels to which supplies are to be made. The stages are:

• Fill back orders

• Fill lead time requirements

• Fill safety stock requirements

• Fill extra requirements out until the specified horizon

The calculations performed by balanced allocation for the fair share of available stock to be supplied
to each receiving Channel are:

Fill back orders
If "Opening Stock (CPt)" < 0

Back order quantity = Absolute value of Opening Stock

If "Opening Stock (CPt)" is  ≥ 0

Back order quantity =0

Fill lead time requirements
Ship date = "Date Stock Last Updated (Ct)"+ 1

Where the Channel in question is the source Channel.
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Lead time supply = "Re-order Point (CPt)"- "Safety Stock Units (CPt)"

Stock status = "Opening Stock (CPt)"+ "Due In Stock (CPt)"+ sum of open orders (where "Ship Date
(Ot)"< Ship date)

Lead time requirements = Lead time supply - Stock status - Back order quantity

This calculation is zero minimum for the purpose of summing the lead time requirements across all
subordinate Channels, but may be negative when calculating the safety stock requirements. This is so
that any unnecessary requirements are removed from the SSR for subordinate Channels with excessive
stock.

Fill safety stock requirements
If Lead time requirements ≥ 0

Safety stock requirements ="Safety Stock Units (CPt)"

If Lead time requirements < 0

Safety stock requirements = "Safety Stock Units (CPt)"+ Lead time requirements

This calculation is zero minimum for the purpose of summing the safety stock requirements across all
supplied Channels, but may be negative when calculating extra requirements. This is so that any
unnecessary requirements for distributed Channels with excessive stock are removed.

Fill extra requirements out until the specified horizon
Ship date = "Date Stock Last Updated (Ct)"+ 1

Where the Channel in question is the source Channel

Horizon ="Date Stock Last Updated (Ct)"+ "Period Beyond Freeze Fence For Open/Planned Orders
(Ct)" or "Date Stock Last Updated (Ct)"+specified extra if overriding database defaults

This value is never greater than "Date Stock Last Updated (Ct)"+ "Deployment Horizon In Days (Ct)"

All requirements =Sum of recommended orders where "Release Date (Ot)" ≥Ship date and ≤Horizon

If Safety stock requirements ≥ 0

Extra requirements = All requirements - (Back order quantity + Lead time requirements + Safety stock
requirements)

If Safety stock requirements < 0

Extra requirements = All requirements + Safety stock requirements

The calculated fair share value is then used to balance the orders within the horizon for each subordinate
Channel. It is possible for a subordinate Channel to obtain a positive fair share without any if its orders
actually being balanced. This is due to a receiving Channel having requirements within the horizon but
not actually having any orders released during this time. This fair share amount is then kept at the
source in the assumption that future shipping requirements will be needed at that subordinate Channel.

Note: 
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• Even though no balancing occurs, the receiving Channel in this situation is added to the corresponding
exception view relating to their fair share.

Examples of balanced allocation
Consider a demand for the same Product at two different Channels.

Stock LimitSafety StockLead time Fore-
cast

Reserved StockBack OrdersChannel  East

+ 10+ 5+ 15+ 55Stock Required

= 40= 30= 25= 105Cumulative Re-
quirement

Stock LimitSafety Stocklead time Fore-
cast

Reserved StockBack OrdersChannel West

+ 10+ 10+ 25+ 510Stock Required

= 60= 50= 40= 1510Cumulative Re-
quirement

There is a total requirement for 40 units for East and 60 units for West resulting in an overall requirement
for 100 units. Stock availability less than 100 units could result in demand for one Channel being fully
satisfied whilst the other was short of stock for customer supply.

The following chart shows how various levels of available stock would be allocated to the two Channels
using balanced allocation:

Stock LimitSafety
Stock

Lead time
Forecast

Reserved
Stock

Back Or-
ders

Balanced Allocation

1051555EastReq’d at

101025510West

00000East0 stock

00000West

00005East15 units

000010West

00055East25 units

000510West

007.555East45 units

0012.5510West

001555East65 units
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0025510West

051555East80 units

01025510West

1051555East100 units

101025510West

 

Note that each stage in the above sequence satisfies one more stage in each Channel’s requirements.
The exception being 45 units, which is insufficient to fill all the lead time demand for both Channels.
At this point a calculation has been carried out to allocate the available stock proportional to the demand
for each Channel:

45 Units.Avail-
able
stock

5 + 10 = 15 UnitsRe-
quire-
ments
for
back
or-
ders

5 + 5 = 10 UnitsRe-
quire-
ments
for re-
served
stock

45 – 15 – 10 = 20 UnitsStock
avail-
able
for
lead
time
de-
mand

40 UnitsRe-
quire-
ment
for
lead
time
de-
mand
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20/40 = 0.5Stock
avail-
abili-
ty

15 x 0.5 = 7.5 UnitsStock
allo-
cated
to
Chan-
nel 1

25 x 0.5 = 12.5 UnitsStock
allo-
cated
to
Chan-
nel 2

Balancing stock allocations
1 In Replenishment Planning, select the Channel Products to be included.

See "About selecting Products and Channels" on page 35.

2 Select Batch > Balanced Allocation.
The Balanced Allocation dialog box is displayed.

3 Select the Override Database Defaults check box and type or select a value in the Days Beyond
Freeze Period to Commit Orders box if you want to override the Period Beyond Freeze Fence
For Open/Planned Orders (Ct) field. See "Period Beyond Freeze Fence For Open/Planned Orders
(Ct)".

4 Click OK.
5 To view the process log, select View > Output.

Channels

About Channel matrix options
In the Replenishment Planner module, orders are created starting at the bottom level of the Channel
matrix. Each Channel has a series of orders created that can be used by the Channel above as
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requirements. Whether, and how, these requirements are passed up the matrix is determined by the
behaviors of each Channel.

See "About Channel behaviors" on page 72.

If a Channel has the Calculate Channel Requirements behavior, then orders are calculated. Otherwise,
no orders are calculated regardless of requirements, and the Channel above will not receive any
requirements from this Channel.

If a Channel has the Pass Up Requirements behavior, then any orders created at this Channel will be
seen by the Channel above as requirements. Otherwise, any orders at this Channel will not be seen
as requirements by the Channel above.

The combinations are:

RP ResponseChannel Behaviors

Each Channel tries to meet the
requirements from below.

Calculate Channel Requirements selected
Pass Up Requirements selected

Orders are created for bottom
level Channels, but these exist
in isolation.

Calculate Channel Requirements selected
Pass Up Requirements cleared

Only relevant if orders are al-
ways imported or specified

Calculate Channel Requirements cleared
Pass Up Requirements selected

manually, to be met by the
Channel above.

Manual orders, existing in isola-
tion at all levels.

Calculate Channel Requirements cleared
Pass Up Requirements cleared

Stock

About stock targets
The stock target is the safety stock target at the end of each period.

If the safety stock is not time-phased (that is, if "Time-phased Safety Stock Code (CPt)" = 1) then the
stock target is equal to the value in "Safety Stock Units (CPt)" for each and every period. This is true
for both weekly and monthly display periods.

If the safety stock is time-phased, the stock target varies from period to period according to the rule
identified by the "Time-phased Safety Stock Code (CPt)" field. There is an exception to these rules if
the Channel Product is subject to forecast consumption (that is, if "Float Current Period Forecast (CPt)"
is true and the Forecast Consumption Rule (Ct) "Time-phased Safety Stock Code (CPt)" is not Rule
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1). In this case, stock targets for periods wholly within the first month are not time-phased, but all
subsequent periods are.

See "About time-phased safety stock" on page 398.

About time-phased safety stock
Safety stock is a stock level calculated to buffer against the forecast variance. The higher the level of
forecast uncertainty the higher the level of recommended safety stock to prevent a stock-out situation
with extremes of demand. As the level of forecast uncertainty changes with time the safety stock may
also be time-phased.

Time-phased safety stock (TPSS) needs to be calculated for each scheduled arrival day at the depots
as part of the replenishment planning process. Shipments are made according to the requirements
including TPSS. In case of shortages the target needs to take account of different safety stocks to
decide on the allocation balance, and also to use this figure for the Fill to Stock calculation in case of
a shortfall.

The "Time-phased Safety Stock Code (CPt)" defines how this is calculated. This code allows for constant
safety stock, safety stock based on the annualized safety stock divided by 365 to imply the days cover,
and an absolute number of days cover. Both "days cover" rules, 2 & 3, have the option to run from
either requirements or the net forecast. The rules are:

Target = Safety stock units. This already includes contingency stock.Rule 1

Target = Net forecast volume to cover the calculated days cover stored in "Days
Cover (CPt)".

Rule 2

Reserved for future use. Code operates as 2 defined above.Rule 3

Target = Requirements from subordinate Channels for the number of days cover
stored in "Days Cover (CPt)".
This rule should only be used at a source or aggregate Channel.

Rule 4

Target = Days cover, based on average safety stock converted to average days
cover, applied to summed RP requirements to the Channel plus dependent require-
ments (BOM orders).

Rule 5

Contingency stock
Contingency stock, expressed as a number of additional days’ supply, may also be added to the TPSS
by editing the "Contingency Stock (CPt)" field. Although the contingency stock could be negative, the
resulting safety + contingency stock can not go below zero. The contingency stock is applied to every
period up to the horizon being calculated.

Target stock override
A target override may be specified for a number of periods. The quantity is added to the existing target
for the appropriate period(s) and may be negative providing the SS + Contingency + Override does
not drop below zero.
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There may be several overrides for a Channel Product. Target overrides may be specified in either
units or days cover.

Stock limits
The safety stock (including contingency and override) is finally limited by a minimum and maximum
amount and number of days cover. These limits are held in the following fields:

• Minimum TPSS In Days (CPt) "Minimum Time-phased Safety Stock Days (CPt)"

• Minimum TPSS In Units (CPt) "Minimum Time-phased Safety Stock Units (CPt)"

• Maximum TPSS In Days (CPt) "Maximum Time-phased Safety Stock Days (CPt)"

• Maximum TPSS In Units (CPt) "Maximum Time-phased Safety Stock Units (CPt)"

A zero in these fields implies no limit.  

The Stock Cover report provides a view of the stock status by Channel linked to forecast requirements.

See "About Replenishment Planner reports" on page 433.

Note: 

• The safety stock is calculated by looking into the forecast (or requirements) day-by-day starting from
that Channel’s stock posting date.

Calculating discontinuation dates in RP
1 In Replenishment Planner, select the Channel Product(s) required.

See "About selecting Products and Channels" on page 35.

2 Select Batch > Calculate Discontinuation Dates.
The Automatic Calculation of Discontinuation Dates dialog box is displayed.

3 Select Remove MI if you want to remove all MI (except T-type promotional MI) after the calculated
discontinuation date.

4 Select the Align existing Pre/Suc dates check box if you want to automatically set the effectivity
date of the successor equal to the newly calculated discontinuation date of the current (predecessor)
item.

Note: These dates will always be aligned when the "Update Successor Effectivity Date (CPt)" field
for the predecessor is set to 1 (true), irrespective of this selection.

5 Click OK.
6 Click Close.
7 Select View > Output to display the process log.

Exception Views
The process may generate the following exception views:

• "BOM SUB AUTO DISC"
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• "FUT EFF AUTO DISC"
• "POT OBS AUTO DISC"
• "RETURNS AUTO DISC"

Note: T-type MI can be removed in the Promotions sub-module of Demand Forecaster.

See "About the automatic calculation of discontinuation dates" on page 248.

Adding target stock adjustments
When viewing the Schedule Worksheet, you can make adjustments to the target stock figure either for
a single period or for a range of periods.

1 In Replenishment Planner, open the Schedule Worksheet.
See "Viewing schedules" on page 431.

2 Select Worksheet > Navigator > In Detail View.
The Schedule Worksheet - In Detail dialog box is displayed.

3 Click any cell in the Target row.
4 Select Worksheet > Edit Targets.

The Edit Target Adjustments dialog box is displayed.
5 Select the range of dates in which the stock adjustment is to fall.
6 Click Add a new adjustment.

The Target Adjustment dialog box is displayed.
7 Enter either a stock quantity or a number of days’ supply in the Quantity edit box, then click either

Unit Value or Days Cover accordingly. You can specify a positive or a negative adjustment.
8 Specify the start and end dates of the adjustment.
9 Type a unique identifier in the Description box.
10 Click OK.
11 Click Apply changes to schedule worksheet.

Editing target stock adjustments
1 In Replenishment Planner, open the Schedule Worksheet.

See "Viewing schedules" on page 431.

2 Select Worksheet > Navigator > In Detail View.
The Schedule Worksheet - In Detail dialog appears showing existing stock adjustments in green
cells.

3 Double-click the required cell in the Target row.
The Edit Target Adjustments dialog appears showing the existing target stock adjustments for the
selected period.

4 Select the row to be edited and click Edit the current adjustment.
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The Target Adjustment dialog box is displayed.
5 Make the required changes and click OK.
6 Click Apply changes to schedule worksheet.

Deleting target stock adjustments
1 In Replenishment Planner, open the Schedule Worksheet.

See "Viewing schedules" on page 431.

2 Select Worksheet > Navigator > In Detail View.
The Schedule Worksheet - In Detail dialog appears showing existing stock adjustments in green
cells.

3 Double-click the required cell in the Target row.
The Edit Target Adjustments dialog appears showing the existing target stock adjustments for the
selected period.

4 Select the row to be deleted and click Delete the current adjustment.
5 Click Apply changes to schedule worksheet.

Re-order Point

About the re-order point
The system-generated re-order point (ROP) is recalculated in the Demand Forecaster module when
forecasts are changed and stored in the "Re-order Point (CPt)" field. A calculation may be forced by
using the Calculate ROP option in the Replenishment Planner module. It is possible, however, to set
a manual re-order point which can be stored in the "ROP Manual (CPt)" field.

If you wish to use the manual re-order point value for scheduling calculations rather than the
system-generated one, set the "ROP System Or Manual (CPt)" field to 1. If the value of this field is set
to 0, the system-generated re-order point value is used.

For normal items ROP represents the forecast across the lead time plus the required safety stock at
the end of the lead time. The derivation of the value is slightly more complex for Slow Moving Products
(SMPs).

For SMPs, if the "SMP Re-order Point Code (CPt)" field for the Channel Product is set to ‘0’, the ROP
represents the integer number of expected sales events (rounded up to the next integer) multiplied by
the average event quantity, plus the required safety stock at the end of the lead time. If "SMP Re-order
Point Code (CPt)" is set to ‘1’, the reorder point is calculated as for normal items.

In both cases the ROP is designed to give a stock position, which in RP, will trigger the ordering process.
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Creating a schedule using rule code 4 (the ROP rule) will produce one order for any Product where
the current available stock at a Channel (opening stock + due-in + sum of incoming open orders) is at
or below the ROP quantity. This means that if a Channel Product is planned using the ROP rule, then
there is no forward schedule of recommended orders. This allows for the creation of orders to be carried
out with a minimum of data, and hence at maximum speed. No attempt is made to use the forward
forecast in the ROP scheduling rule in order that the processing speed should not be restricted.

See "About scheduling" on page 417.

Calculating re-order points
1 In Replenishment Planner, select the Channel Products for which you want to calculate reorder

points.
See "About selecting Products and Channels" on page 35.

2 Select Batch > Calculate ROP.
The Calculate ROP dialog box is displayed.

3 Click OK.
4 Click Close when processing is complete.
5 Select View > Output to display the process log, in which the number of Channel Products processed

is shown.

Orders

About orders
Orders are created starting at the bottom level of the Channel structure. Each Channel has a series of
orders created which can be used by the Channel above as requirements.

The bottom level obtains its requirements from the forecast at that level. This is obtained directly from
either the Weekly or Monthly Net Forecast table depending on the setting of "Level Of Forecast Control
(St)".Existing stock variations from target are taken in to account when calculating requirements from
the forecast. Actual stock levels, including stock in transit and current open orders are compared to
targets which may include safety stock, time-phased safety stock, target overrides and contingency
stock. The calculated orders based on the above are passed to the next level in the Channel structure.
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In the above example, the safety stock is the target stock that the system plans not to go below.

An order is generated at the re-order point (ROP) so that according to the lead time, the stock will arrive
at the depot on the due date, before the safety stock is used.

S = Ship Date

R = Receive Date

 

An example of an order sequence:
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Because of increased demand, the stock at the depot on the first ship date (S1) is already at the safety
stock target. By the first receive date (R1) the stock has dropped to zero. The system will ensure that
the order (1) will be planned by the system to cover the forecast over the lead time plus safety stock
requirements.

The next order (2) will ensure that, provided demand remains equal to forecast, sufficient stock is
shipped at S2 and received by R2 so that the stock immediately before R2 does not fall below the
target level.

Further orders are planned to cover the forecast over subsequent lead time. These are shipped at S3,
S4 etc and received at R3, R4 etc. Provided the demand remains equal to the forecast, this cycle will
continue.

If the demand is above or below the forecast the next order is adjusted to ensure that the stock before
the next delivery date returns to target.

The target safety stock is calculated to ensure that there is always stock available, despite the normal
variations in demand from forecast.

Rounding also has to be taken account of during this calculation. For example, if the recommended
order calculated by the system is 60 units but the minimum lot quantity is 100 then the system will
round up to 100 units:
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At each subsequent level in the Channel structure the same process occurs, except that the requirements
from below are orders instead of the forecast.

About the Order Viewer
The Order Viewer dialog can be used to view, add, edit and delete orders. If selected by clicking Orders
on the Edit menu then only orders for a single Channel Product are displayed. The Product and Channel
list boxes at the top left-hand side of the screen may be used to select the Channel Product to display.
Only those Channel Products originally selected are available from the list boxes.

If selected by clicking Tools > Order Viewer, orders for all selected Channel Products are displayed.
The list boxes used for the selection of Products and Channels are not available.

In either case, a selection of order types may be made from the list box in the center of the tool bar.

The orders listed are color coded:

Normal condition. Due date is within the specified threshold of the
estimated need date.

White background

Order may be deferred. The due date is earlier than the specified
threshold from the estimated need date. Also indicates orders
constrained, for example by minimum days supply.

Orange background

Order is critical and should be expedited. The due date is later than
the specified threshold from the estimated need date. These orders
are displayed in bold blue type during grid editing.

Red background

The table is arranged such that the Channel Products occupy rows and selected fields from the Orders
table occupy columns. An order may be selected by clicking on it to highlight in the furthest left hand
column. It is further indicated by a pointer  in this column.

The orders are displayed in a grid with the following columns:

Source ChannelChannel IDProduct Code

Order ReferenceDue DateGood Qty

Original QtySource CodeOrder Type

Ship DateRelease DateSchedule Date

Creation DateReceived DateEstimated Need Date

CriticalPo NumberUser Id

Days CoverClosing StockSS Target

 Use For Capacity
Calc

Status

 Userstring 0 to 4Transport Type
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Limited By. If the order quantity has been limited by either of the following fields, the relevant text is
displayed:

Maximum Store LimitMaximum Supply
Limit

Minimum Supply Limit

 

Orders can be sorted in ascending or descending order by clicking on a single column heading.

An Advanced Sort can be performed on a maximum of 5 columns by selecting the columns and selecting
to Apply Sort. The direction of the sort for each of the selected columns can be specified as ascending
or descending.

 

Buttons available within the Order Viewer dialog have the following functions:

Following a confirmation message, any changes made are saved to the database.Save
Changes

Prints the current screen.Print
Screen

Exports the displayed orders to an Excel file.Export to
Excel

Exports the displayed orders to a delimited file. The file is saved to a specified location.Export to
delimited
file

Opens the Edit Order dialog for the selected order. Note that orders may also be edited
by selecting a Channel Product in the body of the table, right clicking and selecting Edit
Current Order on the shortcut menu.

Edit Cur-
rent Order

Deletes the selected order without further warning. Note that orders may also be deleted
by selecting a Channel Product in the body of the table, right clicking and selecting the
Delete Current order(s) option.

Delete Cur-
rent Order

Displays the Vertical Edit dialog box.Vertical
Edit [Col-
umn
Name] Col-
umn

Converts current order type to "Closed".Close Cur-
rent Or-
der(s)

Opens the Channel / Product Selection dialog in which the Channel and Product may
be selected to receive a new order. The New Order dialog will then be displayed in which

Add New
Order

a new order may be created. Note that orders may also be created by selecting a
Channel Product in the body of the table, right clicking and selecting the New Order option.
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Changes the view to display orders edited in this session only. Click a second time to
restore the view of all orders.

View Edit
Orders

Sorts the orders such that all critical orders are at the top.Critical
Sort

Displays the Find dialog. Use this to locate an order.Find

Displays the Filter Orders dialog. Use this to filter the orders you want to display.Filter Or-
ders

Displays information from the Products, Channel Products and Orders tables relating to
the currently selected order.
See "About the RP Information Page" on page 407.

RP Infor-
mation
Page

Closes the dialog box. If changes have been made and saved, a warning message is
displayed.

Exit

Opens the on-screen help.Help

About the RP Information Page
The RP Information Page may be displayed whilst using the Order Viewer dialog by clicking RP
Information Page. It provides access to a table containing specific user selected data relating to the
currently selected order.

The Product and Channel Product data section of the grid displays fields from the Product and Channel
Products tables. The Order data section displays selected fields from the Orders table for the currently
selected Channel Product.

Note: 

• You can specify which fields are available to particular users in the Database Administration module.

See "Configuring the RP Information Page" on page 197.

About requirement horizons
Orders are created starting at the bottom level of the Channel structure. Each Channel has a series of
orders created which can be used by the Channel above as requirements.

Orders are calculated for every scheduled day until the requirements horizon, which is stored in the
Requirement Horizon In Days field, or until the last working day in the receiving calendar defined for
this Channel Product. Infor Demand Planning displays an error message if the calendar does not extend
as far as the horizon.

For shipments, only those orders within the deployment horizon, stored in the Deployment Horizon
In Days (Ct) field, are considered for commitment. This parameter defines how far from the stock date
the source looks when committing recommended orders for deployment. The Auto Commit function
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only considers the current shipment according to the field Period Beyond Freeze Fence For
Open/Planned Orders (Ct) and it is possible that, if the deployment horizon were less than this, nothing
would be shipped.

About committing orders
The process of order commitment is one in which orders internal to a Channel matrix, and orders placed
on external suppliers, are confirmed. This means changing recommended (notional) orders into open
(firm) orders. Recommended orders are typically generated by calculating order schedules, but they
can also be imported from outside Infor Demand Planning.

Orders can be committed for receipt at a Channel (so-called "pull" orders), or for distribution from a
Channel (so-called "push" orders). Internal orders between Channels can be committed either as orders
for receipt (at the receiving Channel), or as orders for distribution (at the source Channel), or both.

Committing orders for receipt

When orders are committed for receipt at a Channel ("pull"):

• The orders committed become open orders without a ship date.

• Only recommended orders are available to commit.

Committing orders for distribution

When orders are committed for distribution from a Channel ("push"):

• The orders become open orders with a ship date.

• Only recommended orders and open orders without a ship date (that is, orders previously committed
for receipt) are available to commit.

• Previously committed orders, open with a ship date, are not be displayed.

This process may be carried out in a number of ways, and may affect a single order or all currently
recommended orders.

Committing orders by category

It is possible to load and commit orders up to a specified amount, based on any one of the Results
categories. Simply select the category required, for example Number of Pallets, and enter an appropriate

value. Clicking the Load Orders up to specified amount  button loads orders until the entered quantity
is reached. If the Exceed Value check box is selected, the first order that takes the quantity over the
specified limit is included and flagged to be committed but no further order is loaded. If this check box
is not selected, the final order is loaded but not flagged to be committed.

When a category commit is active, all other load options, such as the Days from Freeze Period to
Commit on the Distribute tab, are ignored.

Note that when loading orders to be distributed from a source Channel by category, all orders up to
the selected value is flagged to be committed, irrespective of the amount of available stock at the
source.
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See "Committing orders by category" on page 412.

Orders may be committed in a batch.

See "Committing orders automatically" on page 413.

Alternatively, orders may be committed selectively.

See "Committing orders" on page 410.

Note: 

• Whether an order is open or recommended is specified by its "Order Type (Ot)" field.

Adding orders
1 In Replenishment Planner, select the Channel Products required.

See "About selecting Products and Channels" on page 35.

2 Select Tools > Order Viewer or Edit > Orders.
3 Perform one of these operations:

• Right-click on the desired Channel Product and select New Order for [Product] at [Channel]
from the shortcut menu.

• Click Add New Order. If more than one Channel Product is displayed, you must identify the
Channel Product for which the order is to be created using the Channel / Product Selection dialog
box.

4 Type or select relevant details for the new order in the Edit Order dialog box and click OK.
5 Click Save Changes.

Viewing orders for several Channel Products
1 In Replenishment Planner, select the Channel Products to be included.

See "About selecting Products and Channels" on page 35.

2 Select Tools > Order Viewer.
The Order Viewer dialog box is displayed. See "About the Order Viewer" on page 405.

Viewing orders for one Channel Product
1 In Replenishment Planner, use the Product and Channel list boxes on the toolbar to select the

required Channel Product.
2 Select Edit > Orders.

The Order Viewer dialog box is displayed. See "About the Order Viewer" on page 405.
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Viewing user defined fields in the RP Information Page
1 In Replenishment Planner, select Tools > Order Viewer.

The Order Viewer dialog box is displayed.
2 Click RP Information Page.

The RP Information Page dialog box is displayed.
3 Click Close to close the dialog.

Editing individual orders
1 In Replenishment Planner, select the Channel Products required.

See "About selecting Products and Channels" on page 35.
2 Select Tools > Order Viewer or Edit > Orders.

The Order Viewer dialog box is displayed.
3 Click on the order row you want to edit and either right-click and select Edit Current Order from

the shortcut menu or click Edit Current Order.
4 Make the changes to the relevant edit boxes in the Edit Order dialog and click OK.
5 Click Save Changes.

Vertically editing orders
When editing orders, providing the selected Orders table field is editable, you can specify a value for
the currently-selected column and apply it to all the orders displayed in the Order Viewer.

1 View the orders for the Channel Product, or Channel Products, you want to edit.
See "Viewing orders for one Channel Product" on page 409 and "Viewing orders for several Channel
Products" on page 409.

2 Select Orders > Vertical edit [column name] column.
The Vertical Edit dialog box is displayed.

3 Type the value to be applied to all orders in the edit box and click OK.
4 Click Save Changes.

Note: Alternatively, click on any row in the column to edit, right-click and select Vertical edit [column
name] column from the shortcut menu to open the Vertical Edit dialog box.

Committing orders
1 In Replenishment Planner, select the Channel Products for which you want to commit orders.

See "About selecting Products and Channels" on page 35.
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2 Select Tools > Commit Orders.
The Commit Orders dialog box is displayed.

3 Select one of these options:

• Received at Selected Channels to commit orders which will result in stock receipts at the
selected Channel(s).

• Distributed from Source Channels to commit orders which will result in stock being shipped
from the selected Channel.

4 If you selected Received at Selected Channels, select or type the number of Days from Freeze
Period to Commit.

5 If you selected Distributed from Source Channels, perform these operations:
a Select or type the Ship Date to be used to assemble the orders to be committed.
b Select or type the number of Days from Ship Date to Distribute. Only recommended orders falling

on or after this date are displayed.
c Select Run Balance Allocation if you want to run the Balanced Allocation process.
See "About balanced allocation" on page 390.

6 If you selected Run Balance Allocation, perform these operations:
a Select or type the number of Days from Ship Date to Balance the allocation to be specified.
a Select or type the Horizon (in days) to Load Orders that are not included in the fair share

calculations.

7 Click Load Orders. A warning message is displayed if any of the orders loaded have a Release
Date prior to the specified Ship Date.

8 Use one of the following techniques to commit selected orders:

• Commit individual orders by checking the appropriate Yes button in the Commit column.
• Commit blocks of orders by clicking the last item to be committed and clicking Commit to cursor.

This feature may be used in conjunction with the sort facility. Once sorted by the required key,
a selection of orders may be made. For example, to a required Cumulative Cost value.

• Commit all loaded orders by clicking Commit all orders.
• Click Advanced Commit to open the Advanced Commit dialog, which enables you to commit

or de-commit orders according to a specified criteria.

9 Click Partial Commit if you want to partially commit an order, creating a new order to maintain the
original requirement.
See "Partially committing orders".

10 Click Save.

Note: 

• The fields shown and the order they appear in the Commit Orders dialog depend on the defaults
that have been set up for you in Database Administration. This sort facility will only function
properly if the fields included are populated correctly.

• When committing orders to be distributed from source Channels, orders will not be committed if
the "Estimated Need Date (Ot)" is after the receiving Channel's stock posting date ("Date Stock
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Last Updated (Ct)") plus the "Deployment Horizon In Days (Ct)". A warning message is displayed
to this effect.

• You can use Auto Commit to commit orders in batch mode.

Committing orders by category
It is possible to load and commit orders up to a specified amount, based on any one of the Results
categories in the Commit Orders dialog box.

1 In Replenishment Planner, select the Channel Products for which you want to commit orders.
See "About selecting Products and Channels" on page 35.

2 Select Tools > Commit Orders.
The Commit Orders dialog box is displayed.

3 Select one of these options:

• Received at Selected Channels to commit orders which will result in stock receipts at the
selected Channel(s).

• Distributed from Source Channels to commit orders which will result in stock being shipped
from the selected Channel.

4 In the Results panel, select the category you wish to use to load orders to commit and enter the
appropriate value.

5 Leave the Exceed Value check box clear if you don’t want the entered value to be exceeded.
6 Click Load orders up to a specified amount.
7 Use one of the following techniques to commit selected orders:

• Commit individual orders by checking the appropriate Yes button in the Commit column.
• Commit blocks of orders by clicking the last item to be committed and clicking Commit to cursor.

This feature may be used in conjunction with the sort facility. Once sorted by the required key,
a selection of orders may be made. For example, to a required Cumulative Cost value.

• Commit all loaded orders by clicking Commit all orders.
• Click Advanced Commit to open the Advanced Commit dialog, which enables you to commit

or de-commit orders according to a specified criteria.

8 Click Save.

• When a category commit is active, all other load options, such as the Days from Freeze Period
to Commit on the Distribute tab, are ignored.

• When loading orders to be distributed from a source Channel, all orders up to the selected value
are flagged to be committed, irrespective of the amount of available stock at the source.

• The Exceed Value facility is useful when committing to a restraint such as capacity.
• If the Exceed Value check box is not selected, Infor Demand Planning will still load the order

that would exceed the stipulated value, although this order will not be flagged to be committed.
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Committing orders selectively
1 In Replenishment Planner, select the Channel Products for which you want to commit or de-commit

orders.
See "About selecting Products and Channels" on page 35.

2 Select Tools > Commit Orders.
The Commit Orders dialog box is displayed.

3 Click Load Orders to display the orders for the selected Channel Products.
4 Click Advanced Commit.

The Advanced Commit dialog appears.
5 Select Mark as ‘Do not Commit’ if you want to de-commit the selected orders.
6 Select Perform as Cumulative if you want the selection to operate cumulatively.
7 Select the Field required from the list box.
8 Select the Operator required from the list box.
9 Type the Value of the selected Field to use.
10 Click OK.

Committing orders automatically
1 In Replenishment Planner, select the Channel Products for which you want to commit orders.

See "About selecting Products and Channels" on page 35.

2 Select Batch > Auto Commit.
The Auto Commit dialog box is displayed.

3 Select the Override Database Defaults check box if you want to use a different value to the one
stored in Channels table field controlling the number of days beyond the freeze fence for creating
open and/or planned orders.

4 Type the required value in the Days Beyond Freeze Period to Commit Orders edit box.
5 Click OK.
6 Click Close when processing is complete.
7 Select View > Output to review the process log, in which the number of Channel Products processed

is shown.

Deleting orders
1 In Replenishment Planner, select the Channel Products required.

See "About selecting Products and Channels" on page 35.

2 Select Tools > Order Viewer or Edit > Orders.
The Order Viewer dialog box is displayed.
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3 Click on the order row you want to delete and either right-click and select Delete Current order[s]
from the shortcut menu or click Delete Current Order.

4 Click OK.
5 Click Save Changes.

Order Book

About the Order Book
In Replenishment Planner, it is possible to use an Order Book in conjunction with the forecast to drive
the procurement scheduling process. The Order Book is a list of customer orders in the replenishment
pipe-line to be processed at particular times in the future.

Order Book functionality is optional. It is enabled by setting the "Order Book (St)" field.

Order Book table
The information that can/must be stored for each order is:

Required/OptionalDescriptionField name

Required but read-onlySystem generated reference for the
entry.

Order Book Reference Number

RequiredSystem generated code of the re-
quired Channel Product.

Channel Product Reference
Number

RequiredCode of the customer that the order
is intended for. It must be a valid
code set up in the Customer table.

Customer Code

RequiredThe quantity of stock required by
the customer.

Good Quantity

RequiredProjected date that the stock should
be despatched to the customer.

Ship Date

OptionalDate that the customer requires
delivery of the stock.

Customer Due Date

OptionalA user maintained field defining the
purchase order number for the or-
der.

PO Number

Required but not displayedSystem generated field to deal with
multiple user edits.

Multi-user locking number

OptionalUser-definable fields.Userstring 0-3
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The required fields must be populated. The optional fields are provided to store other relevant information
to maintain more complete records.

This table may be maintained in both the Replenishment Planner and Database Administration modules.

Customers table
The Customers table is used in conjunction with the Order Book table to ensure that customers are
recognized and correctly linked to potential supply Channels. It contains the following information:

Required/OptionalDescriptionField name

RequiredSystem generated code, unique for
each Customer. Alternative codes may
be imported however.

Customer Code

RequiredCustomer name.Customer Description

OptionalUser definable fields.Userstring 0-3

This table is maintained in the Database Administration module.

Channel Product fields used
The following fields are used when calculating planning requirements using Order Book:

"Days To Use Order Book (CPt)"

"Days To Compare Order Book/Forecast (CPt)"

"Greater Period Or Cumulative (CPt)"

"Use Order Book Plus Forecast (CPt)"

"Use Comparison Or Add Forecast (CPt)"

Viewing the Order Book
1 In Replenishment Planner, select Tools > Order Book.

The Order Book dialog box is displayed.
2 Click OK to close the Order Book dialog box.

Adding a customer order to the Order Book
1 In Replenishment Planner, select Tools > Order Book.

The Order Book dialog box is displayed.
2 Click New.

The Order Book (Detail) dialog box is displayed.
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3 Select either the Channel Product reference number or the Product and Channel codes to identify
the Channel Product required.

4 Select the Customer Code required from the list box.
5 In the Ship Date box, type or select the order’s ship date.

Alternatively, click the ellipsis button to display the Select Date dialog and double-click the required
day.

6 Type the original order quantity in the Good Quantity edit box.
7 Optionally, in the Customer Due Date box, type or select the order’s due date.

Alternatively, click the ellipsis button to display the Select Date dialog and double-click the required
day.

8 Optionally, type the purchase order number in the PO Number edit box.
9 Specify any other user-defined information.
10 Click OK to return to the Order Book dialog box.
11 Click Save.

Note: 

• Infor Demand Planning prompts you to add a customer if none has yet been defined.

• The content of the Order Book and the Order Book (Detail) dialog boxes depends on which fields
of the Order Book table have been made active in the application defaults; unused fields are not
shown.

• Up to five items of user-defined information can be specified for a customer order, provided that
the corresponding user-defined fields of the Order Book table have been made editable.

Editing a customer order in the Order Book
1 In Replenishment Planner, select Tools > Order Book.
2 Either make your required changes to the orders in the Order Book dialog or click  to open the

Order Book (Detail) dialog, make the changes, and then click OK.
3 Click Save.

Deleting a customer order from the Order Book
1 In Replenishment Planner, Select Tools > Order Book.
2 Click the order you want to delete and click Delete.
3 Click Yes to confirm.
4 Click Save.
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Scheduling

About scheduling
As part of the requirement/order creation/stock allocation cycle, delivery schedules are required to
determine availability days on which the source may deliver and the depot receive.

Each Channel Product has a receiving calendar to indicate which days are available to schedule orders
to be received at a Channel, and to indicate when a source can ship to a Channel. Although it is sensible
to make a receipt day an offset time after a ship day, this is not essential as these dates may be used
for planning, and may not represent a physical departure and arrival date.

Infor Demand Planning calculates requirements at depots to arrive on scheduled receipt days and the
net shipping requirements passed up to the source in the form of orders are on these days, shifted by
the offset time to ship to this depot. This offset date defines the order release date at the source.

When orders are to be shipped from a source, the receiving calendar is used and orders are assumed
to arrive an offset time after the ship day. This day does not have to be a receipt day as defined by the
receiving calendar code.

If the database has every day defined as available, then all requirements are accumulated daily and
either manual or auto ship will ship a number of days cover whenever allocation is run.

A Channel Product may ship or schedule if the day after the stock date is defined as an available day.
Scheduling rules may be set for each Channel Product.

See "About scheduling rules" on page 419.

If scheduling is disabled for a Product at a depot, then no orders are created (they may however be
loaded externally or added manually, and existing orders will remain). The Channel above this sees
only the actual current orders that are there. In this case this will normally be zero. If the Channel above
has scheduling enabled, then it can only schedule based on the requirements it sees. If the source
Channel has scheduling disabled, then no production or procurement orders are created, although if
scheduling is enabled at lower Channels, orders are created and, providing shipping is allowed,
deployment orders are created.

Examples of the effect of scheduling rules

ResultDepot ruleSource rule

No orders created by Infor Demand Planning for this Product. Manual
only orders.

OffOff

No orders created by Infor Demand Planning at depots, manual orders
only. Source can schedule and deploy available inventory.

OffOn

Source sees requirements from some depots, and schedules for them.Some offOn

No source orders for scheduling, but can deploy.OnOff

Normal. Orders created everywhere as required.OnOn
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Fields used in the calculation
Infor Demand Planning calculates a schedule of requirements based on a forward view of sales demand
taken from the current Net Forecast table and/or the accumulated DRP orders from below, and from
the current stock position (on-hand stock and open orders) and target stock requirements (time-phased
safety stock) at each Channel. Stock figures used in Infor Demand Planning are held in the following
fields of the Channel Products table:

• Opening Stock (CPt)

• Due In Stock (CPt)

• Safety Stock Units (CPt)

And in the following fields in the Orders table:

• Safety Stock Target (Ot)

• Closing Stock (Ot)

Due in stock is in addition to open orders, and is typically used only when open orders are not held in
the Orders table.

Channel behaviors
Also of relevance are each Channel's behaviors for passing up requirements and calculating
requirements. The Channel matrix is used to define which Channels supply other Channels. It is
assumed that goods flow down through the Channel matrix, and in the following example goods go
from the National Channel out to the five global areas and then finally into geographical continents.
The Channel matrix is maintained within the Database Administration module.

It is possible to enable or disable scheduling at individual Channels. Scheduling would typically be
disabled if, rather than representing the distribution network, either all or part of the Channel matrix
actually represented the sales network. In the following example, it is assumed that Western Depot
and Northern Depot form Sales Region 1 whilst Eastern Depot, Southern Depot and Central Export all
form Sales Region 2.
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Assuming requirements are to be calculated throughout the distribution network (part of the Channel
matrix) only, then the Sales Region 1 and Sales Region 2 Channels would not be set to calculate
requirements whereas each of the other Channels would. This is achieved by enabling or disabling the
Calculate Channel Requirements behavior.

When using normal scheduling it is possible to reduce an item’s opening stock by either the net forecast
or by the sum of all subordinate Channels’ orders (net shipping requirements). This is controlled within
the Channel matrix by the Pass Requirements Up behavior. An aggregate Channel will use its forecast
when calculating future estimated stock positions unless it has at least one subordinate Channel passing
requirements up. If one subordinate Channel has the Pass Requirements Up behavior then all
subordinate Channels must be set to work this way.

In the second example above, it may be assumed that orders generated at the global total are not to
be based on the global forecast but on the sum of all orders from each of the Channels below. In this
case, all of the geographical distribution regions must be configured to Pass Requirements Up.

See "About Channel behaviors" on page 72.

Alternate sourcing
Alternate sourcing (sometimes known as flexible sourcing) allows you to change the route of a Product
through the supply chain without having to change its Channel matrix. It simplifies Channel matrices
and allows faster processing.

See "About alternate sourcing" on page 429.

About scheduling rules
As part of the stock requirement/order creation/stock allocation cycle, schedules are required to
determine the order requirements, availability days on which the source may deliver and the depot
receive and the rolling stock situation.
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Scheduling rules may be set within the "Scheduling Rule (CPt)" field. The rules are:

• Rule 0 - No Scheduling. No order is created (they may however be loaded externally or added
manually and existing orders remain). The Channel above only sees the actual current orders that
are there. In this case this is normally zero.

• Rule 1 - Normal Scheduling. Normal scheduling attempts to deliver stock just as a Channel reaches
safety stock. The rule is governed by a number of parameters detailed later. The principal inputs
are the current stock position, the forecast and the safety stock. The controlling parameters are the
calendars, rounding quantities, and various constraints and rules that override the unconstrained
schedule.

See "About normal scheduling" on page 423.

• Rule 2 - Demand Driven Replenishment (Future release). The key factor in this rule is that no formal
forecast is required, and only the next order is calculated. The timing and quantity on the order is
governed by the cumulative demand and the rounding quantity. This rule is designed to be low
intervention and fast to calculate and is appropriate where products are considered unforecastable,
lead times are short and plans flexible.

• Rule 3 - CRP Fast Deployment (Future release). This rule is designed to support a Continuous
Replenishment Process (CRP). The aim is principally for deployment and will produce a single order
for shipment to a subordinate Channel using the minimum number of calculations.

• Rule 4 - ROP Fast Scheduling. Designed to be the fastest possible rule, and uses the absolute
minimum amount of data and calculations. Usually only one order is created, and this rule does not
consider many of the rules and constraints imposed by the other rules, and so will only be appropriate
for large volumes of data where processing speed rather than sophistication is required.

See "About re-order point scheduling" on page 424.

• Rules 50+ - Custom constructed for the particular requirements of the user. Consult Infor Demand
Planning technical support for specific advice regarding this option.

Summary of fields used by different rules:

Rule code numberField description

41 

  Channel Products table fields

NY"Alternate Level Code (CPt)"

NY"Alternate Source (CPt)"

YY"Annualised Forecast (CPt)"

NY"Average Daily Demand (CPt)"

NY"Basis Of Cumulative Demand For Last Recommended Order (CPt)"

NY"BOM Explosion Code (CPt)"

NY"BOM Level Code (CPt)"

YY"Channel Product Reference (CPt)"
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NY"Contingency Stock (CPt)"

NY"Cumulative Demand Basis Date (CPt)"

NY"Cumulative Demand Since Last Shipment Date (CPt)"

NY"Daily MSE (CPt)"

YY"Date Schedule Last Calculated (CPt)"

NY"Days To Compare Order Book/Forecast (CPt)"

NY"Days To Use Order Book (CPt)"

NY"Defer Trigger In Days (CPt)"

NY"Discontinuation Date (CPt)"

NY"Discontinuation Type (CPt)"

YY"Due In Stock (CPt)"

NY"Expedite Trigger In Days (CPt)"

NY"Greater Period Or Cumulative (CPt)"

YY"Increment (CPt)"

NY"Introduction Date (CPt)"

NY"Maximum No. Of Days Between Orders (CPt)"

NY"Maximum Time-phased Safety Stock Days (CPt)"

NY"Maximum Time-phased Safety Stock Units (CPt)"

NY"Maximum Storage Capacity (CPt)"

YY"Minimum Days Between Orders (CPt)"

NY"Minimum Time-phased Safety Stock Days (CPt)"

NY"Minimum Time-phased Safety Stock Units (CPt)"

YY"Minimum Lot Quantity (CPt)"

NY"Number Of Days To Calculate Average Daily Rate (CPt)"

NY"Number Of Days To Store Orders (CPt)"

NY"Number Of Months To Store Orders (CPt)"

NY"Number Of Weeks To Store Orders (CPt)"

YY"Opening Stock (CPt)"

NY"Open Orders Freeze Period (CPt)"

NY"Planned Receipts First Order Date (CPt)"

NY"Planned Receipts Last Order Date (CPt)"

YY"Product Code (CPt)"

YY"Receiving Calendar Code (CPt)"
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NY"Recommended Prior To Open (CPt)"

YN"Re-order Point (CPt)"

YY"Requirements Offset Days (CPt)"

NY"Requirement Used To Calculate Orders (CPt)"

YN"ROP Manual (CPt)"

YN"ROP System Or Manual (CPt)"

NY"Safety Stock Performance Level (CPt)"

NY"Safety Stock Strategy (CPt)"

YY"Safety Stock Units (CPt)"

YY"Schedule Priority (CPt)"

YY"Scheduling Rule (CPt)"

NY"Shelf Life (CPt)"

NY"Stocked Product (CPt)"

NY"Supplier Code (CPt)"

NY"Time-phased Safety Stock Code (CPt)"

NY"Units Per Case (CPt)"

NY"Units Per Layer (CPt)"

NY"Units Per Pallet (CPt)"

NY"Use Comparison Or Add Forecast (CPt)"

NY"Use Forecast Or Requirements (CPt)"

NY"Use Order Book Plus Forecast (CPt)"

   

  Channels table fields

NY"Additional Days Offset For New Products (Ct)"

NY"Allow Back Orders (Ct)"

YY"Channel Reference Number (Ct)"

YY"Date Stock Last Updated (Ct)"

NY"Demand Calendar Code (Ct)"

NY"First Day Of Week (Ct)"

YY"Next Open Order Reference Number (Ct)"

YY"Period Beyond Freeze Fence For Open/Planned Orders (Ct)"

   

  Products table fields
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YY"Channel Matrix Code (Pt)"

YY"Product Code (Pt)"

NY"Requirement Horizon In Days (Pt)"

   

  Supplier table fields

NNSupplier Code

   

  Inventory table fields

NNChannel Product Reference

NNInventory Quantity

NNExpiration Date

NNBatch/Lot Number

NNAvailable Date

   

  Channel matrix fields

YYCalculate Channel Requirements

YYLevel Code

YYPass Requirements Up

About normal scheduling
In order to calculate both the size and date of orders, the normal scheduling rule firstly attempts to
calculate the estimated need date of an order. The current available opening stock is reduced by the
forecast until at some point in the future the available stock equals or goes below the safety stock
target. This is the first estimated need date.

However, in practice it is rare that companies are either able to (or want to) receive stock on any day.
Typically they may only wish to receive stock for a particular item either once a week or only on weekdays
and so on. Therefore, once Infor Demand Planning has calculated the first future estimated need date,
it then calculates the first opportunity to receive stock either on or before this date. If neither is possible
then it picks the first available date after the need date. This is the due date for the first recommended
order outside the freeze period.

In order to calculate the size of the order, Infor Demand Planning firstly calculates the next opportunity
to receive using the specified receiving calendar, following the due date of the order being considered.
The forecast between the two dates is used to ensure that when the following order arrives, the projected
available stock is once again at least equal to the safety stock target. Infor Demand Planning then
moves on to consider the following order, and so on.
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This process results in three of the most important fields stored against each order:

• "Original Quantity (Ot)". The quantity required.
• "Estimated Need Date (Ot)". The date on which the order should arrive in order to maintain target

stock levels.
• "Due Date (Ot)". The date on which the order is actually scheduled to arrive based on lead time

constraints.

If the estimated need date is before the due date, then the order should be expedited where possible
to maintain the target stock. If the estimated need date is after the due date then the order should be
deferred, as its early arrival would result in a higher stock level than is strictly necessary.

It is often the case that if an order is planned to be only a few days late, that is, the need date is only
a few days before the due date, then there is not an inventory problem. There may only be concern if
an order is more than a week late for example. It is possible to define a tolerance for an individual
Channel Product relating to how great the expedite and defer time periods need to be before messages
are generated.

An expedite message will typically occur when selling at a faster than forecasted rate, or if an order is
delivered into stock with a lower quantity than ordered or if the net forecast has been increased. This
almost inevitably leads to a certain amount of safety stock being consumed. In essence this is not a
problem as this is exactly why safety stock is held; it is only a problem if the rate of consumption is
such that all stocks will have been exhausted before the next order is scheduled to arrive.

Under normal circumstances you can avoid using safety stock by either rescheduling the next
recommended order to arrive on the estimated need date, or failing that, by increasing the size of any
preceding order. The situation can be further exaggerated if there is an open order freeze period, as
recommended orders can only be generated after the freeze period. Infor Demand Planning does
however continue to recommend that the first open order be expedited.

About re-order point scheduling
Re-order point fast scheduling is designed to efficiently calculate a single order to maintain a fixed
stock level and orders are only generated to replace a current stock shortfall. This rule therefore does
not use the forecast to calculate an estimated future stock holding, instead it relies on the re-order point
and the current stock levels. As a result of this, the re-order point rule will only ever generate one
recommended order at most per Channel Product per scheduling cycle.

The system-generated re-order point (ROP) is recalculated in the Demand Forecaster module when
forecasts are changed and stored in the Re-order Point (CPt) field. A calculation may be forced by
using the Calculate ROP option in the Replenishment Planner module. It is possible, however, to set
a manual re-order point which can be stored in the ROP Manual (CPt) field.

If you wish to use the manual re-order point value for scheduling calculations rather than the
system-generated one, set the ROP System Or Manual (CPt) field to 1. If the value of this field is set
to 0, the system-generated re-order point value is used.

If the current stock level is below the re-order point, then the system will generate an order that is equal
in size to the current stock shortfall. The first opportunity to receive stock may be a period of time into
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the future. This would be controlled by the receiving calendar for the Channel Product because
businesses do not always wish to be able to receive stock on any day they may only wish to receive
once a week or once a fortnight etc.

Another constraint on how soon stock may be received is how long it takes to manufacture/receive the
goods on order. If it takes two weeks to receive stock from a supplier then there is little point in Infor
Demand Planning generating a new recommended order to be received within this time frame. This
constraint is represented by a freeze fence within which recommended orders will not be generated.

It is also possible that within the freeze fence there are open orders already scheduled. It would be
inappropriate to generate a new recommended order if there were already an open incoming order to
replenish stocks. If however there is an open incoming order that is not large enough to fully replenish
stock then there is a need to generate a new recommended order that is large enough to cover
requirements. This is achieved by adding any open incoming order values to the current opening stock
position and then comparing this computed value with the re-order point.

When generating the recommended order Infor Demand Planning also calculates an estimated need
date for the order. To generate a recommended order, stock is already below the re-order point so the
estimated need date is set equal to one day before the stock posting date (the date the on hand stock
quantity was last updated). This therefore gives an order both a due date (the date on which the order
is due to arrive, based on the open order freeze period which represents the lead time) and an estimated
need date (when the order is required by to maintain the target stock position). If these dates are
different the system will generate an expedite message, suggesting the recommended order is bought
in sooner, if possible.

It is often the case that if the due date and the need date are only a few days apart then you may not
wish to review an expedite message, but if they are a week apart then you would probably want to
review the situation. The Channel Product fields Expedite Trigger In Days (CPt) and Defer Trigger
In Days (CPt) can be used to control the sensitivity of each type of exception.

About scheduling priority
At summary level, the scheduling priority is indicated by color coding and by priority number.

The "Schedule Priority (CPt)" field contains the priority attached to the last rescheduling of a Channel
Product. This value is recalculated every time a reschedule is carried out on a Channel Product. Note
that it is possible to edit orders without rescheduling - in this case the priority remains as at the previous
reschedule. The priority is indicated on the schedule worksheet - codes 1 & 2 in red and 3, 4 & 5 in
amber.

The values are:

0 = Priority not yet established. The default priority which refers to items that have not been scheduled.

1 = Negative on hand within freeze period. Indicates an actual or potential stock out within the freeze
period. Note that a projected stock on hand of zero does not trigger this code (for instance, I may have
no stock, but no requirements either). The negative stock position is calculated regardless of the setting
of the field, "Allow Back Orders (Ct)", as this is only relevant when calculating the order to rectify the
stock out situation. The system will not calculate recommended orders within the freeze period, so this
case may happen where there is an opportunity to schedule (with or without an open order on that
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day). A typical response may be to increase the quantity on an existing open order, or to create a new
open order, and to take the reschedule option.

2 = Negative on hand outside of freeze period. Should only occur when there is a constraint on
recommended orders. This may be due to there not being an opportunity to schedule until some time
after the end of the freeze period, or that there is a restriction of the size of an order which means the
requirements cannot be met by recommended orders.

3 = Below target within the freeze period. Similar to priority 1 in that current stock and open orders is
insufficient to maintain the safety stock target (which may vary inside the freeze period). If the projected
stock drops below the target then this becomes a priority 3.

4 = Below target outside the freeze period. Similar to priority 2 but compared to the variable stock
target.

5 = Below target in a non-schedule period. May not be a stock problem, but it may appear to be below
target because of the way the current periodicity is set. For example, viewing schedules in months, but
calculating orders twice weekly, may give the impression that the target is not being maintained. If the
periodicity was changed to days the closing stock may be satisfactory. This situation should only occur
when using the schedule worksheet, never in batch order calculations.

9 = No priority.

Note: 

• The freeze period used for priorities 1, 2, 3 and 4 is found in the "Open Orders Freeze Period (CPt)"
field.

About scheduling granularity
The schedule is calculated according to the schedule granularity, which should not to be confused with
schedule periodicity.

• Granularity describes the time periods considered in the calculation and storage of schedules.

• Periodicity describes the time periods used for the reporting of schedule data.

Three Channel Products table fields are used to define the granularity at which orders are kept on the
database:

• "Number Of Days To Store Orders (CPt)".Field defining the number of days to keep the orders in
daily buckets when stored on the database. This is the minimum number of days that is stored. The
number of days are automatically extended to the last day of a complete week so that the granularity
in weeks will start on a complete week. If the value in this field is zero, the first weekly period is an
incomplete week.

• "Number Of Weeks To Store Orders (CPt)".Field defining the number of weeks to keep the orders
in weekly buckets when stored on the database. When a daily granularity has been defined the first
week will always start from the first day of a week, this is defined by "First Day Of Week (Ct)". Where
no daily granularity is defined the first week will only be a partial week. When a number of months
and weeks granularity are defined, the last week is extended beyond 7 days to cover the last day
preceding the start of the first required full month.
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• "Number Of Months To Store Orders (CPt)".Field defining the number of months to keep the orders
in monthly buckets when stored on the database. This starts from the first monthly start date after
the daily and weekly granularity has finished. If no daily or weekly granularity is defined then the
first monthly period may only be a partial month.

Granularity may be edited via the Properties Page dialog in the Replenishment Planner module or by
editing the Channel Products table in the Database Administration module.

About planning requirements in the Schedule Worksheet
When Order Book is not being used, the Planning Requirements row in the In Detail View of the
Schedule Worksheet is the demand, either forecast and/or DRP requirements, depending on whether
alternate sourcing is in use. When Order Book is being used, the following fields are used when
calculating planning requirements:

"Days To Use Order Book (CPt)"

"Days To Compare Order Book/Forecast (CPt)"

"Greater Period Or Cumulative (CPt)"

"Use Order Book Plus Forecast (CPt)"

"Use Comparison Or Add Forecast (CPt)"

If all the above fields are set to zero, Order Book information will have no effect on the planning
requirements displayed.

Example 1

To achieve this situation the following Channel Product fields need to be set up as follows:

3 (days)Days To Use Order Book (CPt)

0Days To Compare Order Book/Forecast (CPt)

0Greater Period Or Cumulative (CPt)

4 (days)Use Order Book Plus Forecast (CPt)

1Use Comparison Or Add Forecast (CPt)
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Example 2

To achieve this situation the following Channel Product fields need to be set up as follows:

3 (days)Days To Use Order Book (CPt)

4 (days)Days To Compare Order Book/Forecast (CPt)

0 (by period)Greater Period Or Cumulative (CPt)

0Use Order Book Plus Forecast (CPt)

0Use Comparison Or Add Forecast (CPt)

Example 3

The calculation for the Planning Requirements for period 4 is:

(Greater of the cumulative forecast or the cumulative order book from Pd_1 to Pd_4 inclusive) minus
(Greater of the cumulative forecast or the cumulative order book from Pd_1 to Pd_3 inclusive)

= (Greater Sum(25+25+25+25) or Sum(50+10+15+20)) - (Greater Sum(25+25+25) or Sum(50+10+15))

= (Greater 100 or 95) - (Greater 75 or 75)

= 100 - 75

= 25

This calculation is also applied for the subsequent periods 5, 6 and 7.

To achieve this situation the following Channel Product fields need to be set up as follows:

3 (days)Days To Use Order Book (CPt)

4 (days)Days To Compare Order Book/Forecast (CPt)

1 (cumulatively)Greater Period Or Cumulative (CPt)

0Use Order Book Plus Forecast (CPt)

0Use Comparison Or Add Forecast (CPt)
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Note: 

• The above examples assume that alternate sourcing is not being used and orders are added at a
Channel where the demand is forecast.

See "About alternate sourcing" on page 429.

About alternate sourcing
Alternate (sometimes known as flexible) sourcing allows you to change the route of a Product through
the supply chain without having to change its Channel matrix. It simplifies Channel matrices and allows
for faster processing. It allows you to specify a source, either an external supplier or an internal Channel,
that is not necessarily the primary Channel within an item’s matrix. Internal flexible suppliers have to
be represented in an item’s Channel matrix. They will differ to external suppliers in that their requirements
are passed up to the defined Channel.

Each Channel Product is allowed one alternate source at any one time. Alternate sources are Channels
that calculate requirements.

When the System Table field, "Alternate Sourcing (St)" is set to 1, the following Channel Products table
fields are used:

• "Alternate Source (CPt)"

• "Alternate Level Code (CPt)"

• "Use Forecast Or Requirements (CPt)"

If alternate sourcing is in place, the Calculate Schedules process uses the values in "Alternate Level
Code (CPt)". Note that when BOMs are in use, "Alternate Level Code (CPt)" is used in conjunction with
the "BOM Level Code (CPt)" to determine the sequence of the calculations.

The "Alternate Level Code (CPt)" is a user-maintained field defining the level code for each Channel
Product. These level codes are defined based upon the relationship between Channel ID and "Supplier
Code (CPt)" for all Channels at a given Product. They specify the order in which Channels for a Product
are processed. Higher numbers are processed first.

For example:

Alternate Level CodeAlternate SourceChannel ID

0"Self" or externalNATIONAL

1NATIONALNORTH

1NATIONALSOUTH

1NATIONALEAST

2NORTHWEST

2NORTHCENTRAL
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In this example, NATIONAL is the top-level Channel, NORTH, SOUTH and EAST are at the middle
level, whilst Channels WEST and CENTRAL are at the lower level. When orders are being calculated,
it needs to be determined whether forecast and/or requirements are to be taken into account. The "Use
Forecast Or Requirements (CPt)" field specifies this and the valid values are:

• 0 - use forecast (default).

• 1 - use requirements (sum of orders).

• 2 - use forecast and requirements.

For example, the above scenario may appear as follows. Channels SOUTH, EAST, WEST and
CENTRAL use their forecast, NORTH uses both its forecast and DRP requirements and NATIONAL
uses the sum of all their orders (DRP requirements):

Use Forecast or Require-
ments

Alternate Level CodeAlternate SourceChannel ID

10"Self" or externalNATIONAL

21NATIONALNORTH

01NATIONALSOUTH

01NATIONALEAST

02NORTHWEST

02NORTHCENTRAL

Note: 

• All the above System and Channel Products table fields are an integral part of the alternate sourcing
functionality and changes should not be made without detailed system knowledge.

Creating schedules
1 In Replenishment Planner, select the Channel Product(s) required.

See "About selecting Products and Channels" on page 35.

2 Select Batch > Calculate Schedule.
The Calculate Schedule dialog appears showing the number of Channel Products selected.

3 Select the Include Sub-Ordinates with corresponding BOM Parents check box if you want to
reschedule BOM subordinates linked to any BOM parents currently selected.
See "About bills of materials" on page 438.

4 Click OK.
5 Click Close.

Details of any exception views created are displayed at the bottom of the window.

Note: If Order Book is in use, the Order Book table must be populated with the latest information
prior to running the scheduling process. See "About the Order Book" on page 198.
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Viewing schedules
1 In Replenishment Planner, select the Channel Product(s) required.

See "About selecting Products and Channels" on page 35.

2 Select Tools > Schedule Worksheet.
If the selected Channel Products span more than one Channel matrix or not all available Channels
are selected, warnings are displayed. Choose whether to load any "missing" Channels or continue
with limited functionality.
The Schedule Worksheet dialog box is displayed. See "Schedule Worksheet dialog".

Editing schedules
You can edit the following cells in the Schedule Worksheet:

• Target stock. See "Editing target stock adjustments" on page 400.
• Open and recommended orders. See "Editing individual orders" on page 410.

Recalculating schedules in the Schedule Worksheet
When viewing the Schedule Worksheet, you can recalculate the schedule for the currently-selected
Product, without leaving the worksheet.

1 Select Worksheet > Calculate Schedule.
The Calculate Schedule dialog box is displayed.

2 Select the Include Sub-Ordinates with corresponding BOM Parents check box if you want to
reschedule BOM subordinates linked to any BOM parents currently selected.
See "About bills of materials" on page 438.

3 Click Ok.
4 Click Close.
5 Select View > Output to display the processing log.
6 Click Save Schedule.

Note: If Order Book is in use, the Order Book table must be populated with the latest information
prior to running the scheduling process. See "About the Order Book" on page 198.

Defining schedule periodicity
When viewing the Schedule Worksheet, you can change the mix of days, weeks and months displayed
(the periodicity).
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1 In Replenishment Planner, open the Schedule Worksheet.
See "Viewing schedules" on page 431.

2 Select Worksheet > Define Periods.
The Periodicity dialog box is displayed.

3 Type or select the number of Days, Weeks and Months desired.
If necessary, Infor Demand Planning adds additional days or weeks to ensure that all months are
aligned with their correct period end dates. These additions may mean that the number of whole
months shown on the worksheet is one less than the number you requested.

Selecting the requirement details display default
1 In Replenishment Planner, open the Schedule Worksheet.

See "Viewing schedules" on page 431.
2 Select Worksheet > Navigator > In Detail View.

The Schedule Worksheet - In Detail dialog box is displayed.
3 Click Hide/Show default.

The Select Requirement Display Default dialog box is displayed.
4 Choose one of the following:

• Show Requirement Details
• Hide Requirement Details

5 Click OK.

Shipping

About shipping
Once a requirement has been converted into an order and that order made open, shipping requirements
must be considered. At the Channel Products level, shipping maximums and minimums are defined in
terms of both quantity and time. The data is held in the following fields:

"Maximum Storage Capacity (CPt)"

Max No. Days Between Orders (CPt) "Maximum No. Of Days Between Orders (CPt)"

Min No. Days Between Orders (CPt) "Minimum Days Between Orders (CPt)"

"Minimum Lot Quantity (CPt)"

The Channel Products table field "Shelf Life (CPt)" is used in the Inventory Planner module to limit
safety stocks and economic order quantities (EOQs). It is also used for limiting the size of orders.
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The Orders table field, "Ship Date (Ot)" is used, in addition to designating the date on which an order
must be shipped to meet the required need date, to differentiate between order types:

• An open order with the "Ship Date (Ot)" field populated is one that has been committed for distribution.

• If the "Ship Date (Ot)" is in the past (that is, on the stock posting date or earlier), then Infor Demand
Planning assumes that the "Good Quantity (Ot)" in the order has been picked and the order is in
transit. This order quantity should not be included in the initial "Opening Stock (CPt)" at the distributing
Channel.

• If the "Ship Date (Ot)" is in the future (that is, after the stock posting date) then Infor Demand Planning
assumes that the "Good Quantity (Ot)" in the order is still to be picked. The "Opening Stock (CPt)"
should therefore still include that order quantity. The calculated starting stock for schedules is the
"Opening Stock (CPt)" minus the "Good Quantity (Ot)" of all such future orders.

• An open order with the "Ship Date (Ot)" blank has been committed for receipt (a so-called "pull"
order) but not yet for distribution. The opening stock will therefore still include the order volume, as
will the calculated starting stock for a schedule.

Rounding shipments
All shipment allocations must be rounded to practical shipping quantities according to requirements.
These fields control increments for orders:

"Increment (CPt)"

"Minimum Lot Quantity (CPt)"

If there is adequate stock available at the source to ship, then the rounding is carried out as above.
However, if the shipment is limited by shortage of source stock, the total available quantity is divided
into lots as above. Then these lots are allocated by need in proportion to the unconstrained requirements
and rounded using this field:

"Units Per Case (CPt)"

Therefore, when full orders cannot be met, then the calculated fair share value is rounded to be
increments of units_case.

Note:  An order with a populated "Ship Date (Ot)" will only be created when an open or recommended
order is committed for distribution by the Commit Orders or Balanced Allocation functions.

Reports

About Replenishment Planner reports
In the Replenishment Planner module, reports may be generated to show a range of data concerned
with stock control and order scheduling. Reports are presented by selecting Reports from the main
menu. The options are:
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"Viewing the Critical report" on page 436  Critical

"Viewing the Stock Cover report" on page 435  Stock Cover

"Viewing the To Be Committed report" on page 434  To Be Committed

"Viewing the Stock Re-balancing report" on page 434  Stock Re-Balancing

All reports require an input to specify the options required. The To Be Committed report will only run
whilst the Commit Orders screen is open.

The format of each report is identical, with the report itself being in a spreadsheet format with presentation
controls available.

In the case of the Stock Cover report, a graphical presentation is a pie chart available as an alternative
to the standard spreadsheet type format.

Viewing the To Be Committed report
1 In Replenishment Planner, select the Channel Products for which you want to commit orders.

See "About selecting Products and Channels" on page 35.

2 Select Tools > Commit Orders.
The Commit Orders dialog box is displayed. See "About committing orders" on page 408.

3 Select Reports > To Be Committed.
The To Be Committed report is generated in grid format. See "Report Viewer dialog".

Viewing the Stock Re-balancing report
1 In Replenishment Planner, select the Channel Product(s) required.

See "About selecting Products and Channels" on page 35.

2 Select Reports > Stock Re-balancing.
The Stock Re-balancing Report Options dialog box is displayed.

3 Select one of the following ways to calculate available stock:

• Opening Stock
• Opening Stock + Due In Stock
• Opening Stock + Open Orders a number of days from the Stock Date
• Opening Stock + Due In Stock + Open Orders a number of days from the Stock Date

See "Stock Re-balancing Report Options dialog".

4 Type or select the number of days to use if required.
5 Select one of the following ways to calculate the excess stock threshold:

• ROP + Lot Quantity
• ROP + Number of Days Cover
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• ROP + Number of Units

6 See "Stock Re-balancing Report Options dialog".
7 Type or select the required number of days if required.
8 Click Report.
9 The Stock Rebalancing Report appears.

See "Stock Re-balancing Report dialog".

Viewing the Stock Cover report
1 In Replenishment Planner, select the Channel Product(s) required.

See "About selecting Products and Channels" on page 35.

2 Select Reports > Stock Cover.
The Stock Cover Report Options dialog box is displayed.

3 Select one of the following ways to calculate available stock:

• Opening Stock
• Opening Stock + Due In Stock
• Opening Stock + Open Orders a number of days from the Stock Date

See "Stock Cover Report Options dialog".

4 Type or select the number of days to use if required.
5 Select one of the following ways to calculate the excess stock threshold:

• ROP + Lot Quantity
• ROP + Number of Days Cover
• ROP + Number of Units

See "Stock Cover Report Options dialog".

6 Type or select the number of days to use if required.
7 Select one of the following to use as sales in the calculation:

• Current Months Sales
• Average Month Sales

See "Stock Cover Report Options dialog".

8 Click Report.
The Stock Cover report is generated in grid format.

Viewing the Stock Cover graph
1 In Replenishment Planner, select the Channel Product(s) required.
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See "About selecting Products and Channels" on page 35.

2 Select Reports > Stock Cover.
The Stock Cover Report Options dialog box is displayed.

3 Select one of the following ways to calculate available stock:

• Opening Stock
• Opening Stock + Due In Stock
• Opening Stock + Open Orders a number of days from the Stock Date

See "Stock Cover Report Options dialog".

4 Type or select the number of days to use if required.
5 Select one of the following ways to calculate the excess stock threshold:

• ROP + Lot Quantity
• ROP + Number of Days Cover
• ROP + Number of Units

See "Stock Cover Report Options dialog".

6 Type or select the number of days to use if required.
7 Select one of the following to use as sales in the calculation:

• Current Months Sales
• Average Month Sales

8 Click Graph.
If more than one Channel is currently selected, the Choose a Channel to Graph dialog box is
displayed.

9 Select the Channel required.
The Stock Cover Graph dialog box is displayed. See "Stock Cover Graph dialog".

Viewing the Critical report
1 In Replenishment Planner, select the Channel Product(s) required.

See "About selecting Products and Channels" on page 35.

2 Select Reports > Critical Report.
The Critical Report Options dialog box is displayed.

3 Do one of the following:

• Click Orders for Expedite to include only orders which should be expedited.
• Click Orders for Defer to include only orders which should be deferred.
• Click Both to include both of the above.

4 Click OK.
The Critical report is generated in grid format. See "Critical report details".
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Properties

About properties
The Properties Page window allows you to edit various table fields relevant to Replenishment Planner
functionality without having to use the Database Administration module.

It can be accessed directly from the Replenishment Planner module (select Properties on the Edit
menu)or from the Schedule Worksheet (click Properties).

Either route presents the Properties Page dialog box. It has five tabs, each one arranged in a
spreadsheet format, in which inventory and forecast fields from the Channel Products table may be
reviewed and edited.

Data can be exported from the Properties page using the Export to Excel or Export to Delimited file
options.

See "Properties Page dialog".

Viewing and editing properties
You can review and edit inventory, planning and forecast fields in the Channel Products table without
having to leave the Replenishment Planner module.

1 In Replenishment Planner, select the Channel Product(s) required.
See "About selecting Products and Channels" on page 35.

2 Select Edit > Properties.
The Properties Page dialog box is displayed.

3 Click the required tab.
4 You can edit cells directly by clicking to select and typing over the contents. Alternatively, right-click

in the selected cell and click one of the following commands on the shortcut menu:

• Click Edit Current Cell to update only the currently selected cell with the new value.
• Click Vertical Edit for Product to update all Channel Products for the Product currently selected.
• Click Vertical Edit for Channels to update all Channel Products where the Channel is the same

as the Channel currently selected.
• Click Vertical Edit for Column to update all Channel Products selected.

5 Type the new value in the edit box at the bottom of the dialog.
6 Click .
7 Click Save.
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Bills of Materials

About bills of materials
A bill of materials (BOM) enables you to specify how a parent Product is assembled from one or more
subordinate Products at the same Channel.

A BOM is characterized by:

• The code of the parent Product.

• The ID of the Channel at which the BOM is assembled.

• A description of the BOM.

• A unique BOM reference number assigned by Infor Demand Planning.

For each subordinate Product, the BOM defines:

• The code of the subordinate Product

• The quantity of the subordinate needed to make one unit of the parent (known as the "draw quantity")

• The average number of days needed to assemble the subordinate into the parent (known as the
"offset period").

The important features to note are:

• A BOM is Channel-specific. Typically, you need only define the BOM at the Channel where it is
assembled. (Although Infor Demand Planning appears to allow you to define the same BOM at
different Channels, in fact each BOM has a different reference number.)

• A BOM is single-tiered. This implies that although a Product can be a subordinate in several BOMs,
a subordinate may not also be a parent in another BOM at the same Channel. Equally, a Product
cannot be a parent in more than one BOM at the same Channel.

Demand for a parent Product produces demand for its subordinate Products; this is known as "dependent
demand." If a subordinate Product is also sold separately, it has both independent and dependent
demand. When you generate a schedule of orders for a parent Product, you can optionally generate
schedules for its subordinate Products.

See "About scheduling" on page 417.

Where Products have been defined with a predecessor/successor link, there is no automatic linking of
BOMs. In this case a separate BOM has to be defined for the successor Product.

Where balanced allocation is used, this must be done after BOM scheduling because balanced allocation
has to operate on a Product by Product basis, whereas BOMs operate by Channel, so one Product
may not be completed before moving on to the next. This will essentially require balanced allocation,
when run together with scheduling, to be done in a second pass of the database.

See "About balanced allocation" on page 390.
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See "Examples of BOMs" on page 439.

Examples of BOMs

Example 1: Locally packed promotion
A terminal Channel assembles a promotional pack from finished goods available at that Channel. The
components that make up the promotional pack can also be sold individually. Both the promotional
pack and the individual items have forecasts and safety stock. The orders generated are
requirements/shipments from the source to the terminal Channel for the individual items, and production
orders at the terminal Channel to assemble the promotional pack. In this case the promotional pack
code is assigned a Channel matrix where the terminal Channel is a source.

Items A and B are manufactured at the source plant, and shipped to nodes. Promotional pack C is
made up of A and B and packaging X. Product C only exists at Depot 1 and Depot 2. Orders for
packaging X are placed on an external supplier.

Channel matrix for A & B: Factory is a source, Depot 1 and Depot 2 store history and pass requirements
up to the Factory.

Channel matrix for C & X: Depot 1 and Depot 2 are independent sources for internally sourced C and
externally sourced X.

Example 2: Centrally packed gift pack
A terminal Channel sells a gift pack, which is assembled by the Channel above and shipped as a
Product to the terminal Channel. Here shipments are generated for both individual items and gift packs,
and production orders are generated at the source to assemble the gift pack.
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The Channel matrix for A, B and C is the same, namely the factory and the two depots. X is supplied
from an external supplier. Shipping schedules for A, B and C are generated at the depots and
requirements passed up.

Example 3: Manufacturing from raw materials
A manufacturing plant makes Products from components or raw materials, but only ships the finished
item.
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The Channel matrix for A, B and X consists of just the factory; all requirements come from BOM
dependent demand. The Channel matrix for C has the two depots passing up requirements to create
production orders at the factory.

Creating a bill of materials
1 In Replenishment Planner, select BOM Maintenance > Create BOM.

The Create BOM wizard is displayed.
2 Select the Products to use, then click Next.
3 Select a parent Product, then click Next.
4 Select the Channel or Channels at which the BOM is assembled, then click Next.

If you select more than one Channel, Infor Demand Planning creates the same BOM at each Channel
but with different BOM reference numbers.

5 Type a description for the BOM, then click Next.
6 Select the subordinate Products, and click Next.
7 For each subordinate Product, type the Draw Quantity and Offset Period. Click Next.
8 Click Finish.

Viewing a bill of materials
1 In Replenishment Planner, select Tools > BOM Structure Viewer.

The BOM Structure Viewer dialog box is displayed.
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2 Do either of the following:

• Click BOM Parent to display the BOM tree structure with the parent Product at the top level and
subordinate Products at the lower level.

• Click BOM Subordinate to display the BOM tree structure with the subordinate Products at the
top level and all relevant parent Products at the lower level.

3 Click the Expand icon to expand each level of the tree. Click the Collapse icon to collapse the level.

Note: The final level of the tree view shows the draw quantity and offset period for each subordinate
within the BOM.

Modifying a bill of materials
1 In Replenishment Planner, select BOM Maintenance > Modify BOM.

The Modify BOM wizard is displayed.
2 Select the Products to use then, click Next.
3 Select the parent Product of the BOM you want to change, then click Next.
4 Select the Channel of the BOM you want to change, then click Next.
5 Edit the existing BOM description, then click Next.
6 Add or remove subordinate Products, then click Next.
7 Edit the existing Draw Quantity and Offset Period values as required. Click Next.
8 Click Finish.

Deleting a bill of materials
1 In Replenishment Planner, select BOM Maintenance > Delete BOM.

The Delete BOM wizard is displayed.
2 Select the Products to use, then click Next.
3 Select the parent Product of the BOM you want to delete, then click Next.
4 Click Finish.

After deleting a BOM, you should re-schedule all subordinate items to remove dependent demand.

Viewing dependent requirements
1 In Replenishment Planner, select the required subordinate Product.

See "About selecting Products and Channels" on page 35.

2 Select Tools > Dependent Requirements Viewer.
The Dependent Requirements Viewer dialog box is displayed.
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3 To group the list by column, click and drag the desired column heading into a schematic view in the
grouping area above the column header.

Note: You can also view dependent requirements by double-clicking in a Dependent Requirements
cell in the Detail view of the Schedule Worksheet.

Rough Cut Capacity Planning

About rough cut capacity planning
The Demand Forecaster module generates forecasts to provide the best prediction of what customer
demand will be. The Inventory Planner module takes into account forecast uncertainty and the other
factors involved in generating safety stock levels. The requirements schedule is a statement of what
needs to be purchased, produced or distributed within a firm planned period and what the expected
requirements for inventory are beyond this time fence. This is constrained by minimum and incremental
lot sizes and further restricted by receiving calendars.

The next level of constraint is that of the capacity that applies over a group of items. With sufficient
advanced warning most capacity constraints can be solved. Action can be taken either to produce
goods in advance, to bring in extra capacity, to find external capacity, or to reduce the damage to the
business by selectively allocating the available capacity to protect key business items. Similarly, if a
company has the ability to identify excess current capacity, future planned orders may be brought
forward to ensure that valuable current capacity resources are not wasted.

The capacity workbench can help to identify these capacity issues in advance and so help to develop
schedules that will plan to produce or buy what is required, when it is needed. This facility may be used
to maximize usage of any number of resources including labor, machine hours, vehicle loads and so
on. Effective use of the capacity workbench can help to minimize production, transportation and inventory
costs.

Rough cut capacity planning (RCCP) uses the concept of workcentres. A workcentre is a resource or
group of resources that provide constraints on the supply process, either manufacturing or other supply
processes, such as distribution constraints. Any number of workcentres may be defined that have a
time-phased capacity that can be defined in any unit of measure, typically this might be hours per shift
or units per day.

See "About workcentres" on page 450.

Channel Products are then applied to one or more workcentres. Distribution requirements or procurement
schedules for these items are then converted into the appropriate unit of capacity measure and
accumulated against the available workcentre capacity.

Exceptions of over capacity are visually highlighted for corrective action. Remedial action may be taken
to create an open order within the freeze period where excess capacity is available; an action not
normally permitted during the normal scheduling routine. An alternative approach is to apply scheduling
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logic that pulls forward recommended orders (beyond the freeze period) from times of capacity constraint,
to fill periods with available capacity.

Fixing capacity plans
When two or more concurrent periods have been selected in the Capacity Worksheet, it is possible to
fix capacity plans for the selected periods.

1 Select Capacity > Fix Plans.
The Fix Capacity Plans dialog box is displayed.

2 Do one of the following:

• Click Add target adjustments to make adjustments to the target stock for all Products in the
workcentre or adhoc group.

• Click Make all selected orders open to make all recommended orders within the selected
periods open.

3 Click OK.

About filling capacity
In order to balance required capacity with available production capacity, orders may be moved within
a defined time period. The process involves a specified number of iterations in which each consists of
an attempt to balance each of the selected periods, starting with the first, to within the target capacity.
If a period is already within the defined target capacity and tolerance, then the Fill Capacity process
moves to the next period.

If capacity required for a period is greater than its target capacity (plus the specified % tolerance), then
orders are pushed out to the next period. The orders to be moved out are selected initially on the basis
of the capacity balance specified during the creation of a workcentre. Items with a capacity balance of
1 are attempted to be moved first, then 2 and so on, up to 999. Items with a capacity balance of 0 are
not moved. Orders with the same capacity balance are then selected based on "Good Quantity (Ot)"
priority, with the process attempting to move the largest orders first.

If all periods are above the target capacity, then excess orders are be moved to the first period after
the selected range.

If the required capacity is less than the target capacity (minus the specified % tolerance) for a period,
then orders are brought forward from future periods. Orders to pull in are selected using the same
method as when pushing out orders. However, orders are initially pulled from the next period, but if
there are not sufficient orders to meet the capacity, orders from each of the subsequent periods within
the selected range are also pulled in, until the current period is within tolerance of the target capacity.

Within a single iteration, a single period only has orders pushed back or pulled forward, not both. Hence,
if a large order is moved out of the period to reduce its capacity, it could result in a need to transfer a
smaller order back. In this case, the second move cannot be carried out until the system moves on to
the next iteration.
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An order is moved, if it puts the current period to within tolerance of the target capacity. All orders in
the period are initially checked in this manner, and if no single order can achieve this, then orders are
moved if they results in a decrease in the percentage deviation from tolerance.

After all the periods have been processed in this way, the iteration counter increases by 1 and the
process returns to the first selected period, and continues. This process continues until all periods are
within the requested tolerance, or the maximum number of iterations have been run.

The Average level (even spread) option calculates the target capacity as the sum of the required
capacities over the selected periods, divided by the number of periods selected. The fill capacity process
then attempts to move orders to achieve that level across all periods. The available capacity of each
period is not used in this calculation. In this rule, the tolerance is treated as the number of capacity
units above or below the average capacity that is acceptable.

The Manually defined level (capacity percentage) option calculates the target capacity for each period
separately. This is calculated as the (manually defined) percentage of available capacity for each
selected period. The fill capacity process then attempts to move orders so that the percentage capacity
used is equal to the target capacity. In this rule, the tolerance is treated as the absolute percentage
above or below the defined level that is acceptable. For example, a 95% capacity with a tolerance of
5%, fills to 90% to 100% of available capacity for each selected period. 60% capacity with the same
5% tolerance fills to 55% to 65% of available capacity.

Warning/Error messages
There are two possible messages:

ExplanationMessage

If the fill capacity process reaches the maximum
number of iterations without achieving the set toler-

"The maximum number of iterations has been
met, but some items are still outside the speci-
fied tolerance.
Consider splitting order quantities and recalcu-
lating capacity again"

ance of the target capacity within each period a
warning message is presented. In this case, some
order quantities could be split to produce smaller or-
ders or the maximum number of iterations increased.

If the fill capacity process is unable to move any or-
ders, given the selected options, and periods are

"No orders were moved whilst attempting to fill
capacity.
Check the fill capacity options, and the orders
within the selected periods"

outside tolerance then an error message is displayed.
The logic of the options specified should be checked
and re-specified as necessary.

About filling batches
The Fill Batchprocessis an option to allow recommendedandopen orders to be grouped together into
batches of a specified size. This enables the capacity of a selected period to be filled with the assembled
batch. This option will only be available if a single period outside the freeze fence has been highlighted
in the Capacity Worksheet section and the capacity worksheet is displayed in units.

The process involves bringing orders forward from future periods, in order to reach the required batch
size. Orders are moved forward in their total, and are not split to give the resultant batch size.
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An attempt is made to move orders forward according to the following Orders table field priorities:

• "Estimated Need Date (Ot)", earliest date first

• "Due Date (Ot)", earliest date first

• "Good Quantity (Ot)", largest orders first.

Steps are repeated in the above cycle until either the specified batch quantity is satisfied, no further
orders are available within the periodicity defined in the capacity worksheet or any remaining order
would take the batch quantity in excess of that required.

Warning/Error messages
There are three possible messages:

ExplanationMessage

If the process is able to move some orders forward, but
with the available orders, the requested batch size could

"Given the current quantities, the orders
within the worksheet could not meet the

not be exactly filled, a warning message is produced,specified batch size. The filled batch is n
weighted unit(s) short" detailing the number of units the batch size is short of

its target. It may be possible to split future orders such
as to create a part order of suitable size to fill the batch.

If the requested batch size could not be filled because
the total "Good Quantity (Ot)" of all available future or-

"There were not sufficient orders within the
worksheet to meet the specified batch size.
Decrease the batch size, to try again" ders within the specified period is less than the specified

batch size, then a separate warning is issued. In this
case either the batch size must be re-specified to a
lower value or additional order created to fill the batch.

If existing orders in the selected period already exceed
the specified batch quantity then an error message will

"Could not fill batch. The selected period
contains orders equal to, or larger than the

be displayed. In this case, the batch size must be re-
specified to a higher value to proceed.

specified batch size. Increase the batch size,
to try again"

Note: 

• The fill batch option is an ad-hoc activity that only applies to the capacity worksheet. It is not a group
scheduling rule.

Filling capacity
When viewing the Capacity Worksheet, it is possible to advance or delay orders to fill production
capacity for a specified range of time periods.

1 In Replenishment Planner, open the Capacity Worksheet.
See "Viewing the Capacity Worksheet" on page 448.

2 Select Capacity > Capacity View.
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3 Select the periods required.
4 Select Capacity > Fill Capacity.

The Fill Capacity wizard is displayed.
5  Do one of the following:

• Click Average level (even spread) if you want the system to work out the average level of
capacity required in the selected periods and move orders to achieve that level.

• Click Manually defined level and type or select the target capacity percentage in the (% capacity)
edit box.

6 Type or select a value in the Requirements capacity, units tolerance edit box.
7 Type or select a value in the Maximum allowed iterations edit box.
8 Select the Allow movement of Open orders check box if you want the system to additionally

consider moving open orders.
9 Click Next.
10 Select the Products to be included.
11 Click Finish.
12 Click Save Capacity.

See "About filling capacity" on page 444.

Filling a batch
When viewing the Capacity Worksheet, it is possible to advance recommended orders to fill a specified
batch quantity during a particular period.

1 In Replenishment Planner, open the Capacity Worksheet.
See "Viewing the Capacity Worksheet" on page 448.

2  Select the period required.
3 Select Capacity > Fill Batch.

The Fill Batch Wizard is displayed.
4 Do one of the following:

• Click Batch size covers workcentre to base the batch size on the entire workcentre or adhoc
group.

• Click Batch size covers selected items only to base the batch size only on the items selected
in the Capacity Worksheet.

5 Type a value in the Batch size edit box, which is consistent with the current order values and must
include the current weighting and scaling as shown in the toolbar.

6 Select the Allow movement of open orders check box if you want the system to consider moving
open orders as well as recommended.

7 Click Next.
8 Select the Products to be included.
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9 Click Finish.
10 Click Save Capacity.

See "About filling batches" on page 445.

Defining capacity periodicity
When viewing the Capacity Worksheet, you can change the mix of days, weeks and months displayed
(the periodicity).

1 In Replenishment Planner, open the Capacity Worksheet.
See "Viewing the Capacity Worksheet" on page 448.

2 Select Capacity > Define Periods.
The Periodicity dialog box is displayed.

3 Type or select the number of Days, Weeks and Months desired.
4 Click OK.

If necessary, Infor Demand Planning adds additional days or weeks to ensure that all months are
aligned with their correct period end dates. These additions may mean that the number of whole
months shown on the worksheet is one less than the number you requested.

Viewing the Capacity Worksheet
1 In Replenishment Planner, select Tools > Capacity Worksheet.

The Workcentre Selection dialog box is displayed.
2 Either select an existing workcentre or use the currently selected items.
3 Select the order date to use from the Order Date Selection list box.
4 In the Number of Days Offset edit box, type or select the of days by which the orders displayed

are offset from the order date selected.
5 Click OK.

If you selected to use the currently selected items, select a receiving calendar and Channel in the
Adhoc Workcentre Selection dialog and click OK.
The Capacity Worksheet appears. See "Capacity Worksheet dialog".

Note: The ship date is only calculated for DRP orders. If no ship date is found, the order release
date is used instead.
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Sorting the Capacity Worksheet
When viewing the Capacity Worksheet, it is possible to sort the Channel Products displayed. A simple
ascending or descending alphabetic sort can be achieved by clicking on the Product Code or Description
column headings. A second click reverses the sort order.

1 To perform a more advanced sort based on a Product or Channel Product field, select Capacity >
Sort.
The Sort Capacity Worksheet dialog box is displayed.

2 Select to sort by either a Channel Product or Product field.
3 Select the actual field to use from the list box.
4 Clear the Ascending check box if you want to arrange the Products in descending order.
5 Click OK.

Recalculating schedules in the Capacity Worksheet
When viewing the Capacity Worksheet, it is possible to recalculate schedules for the Products displayed
without leaving the worksheet.

1 Select Capacity > Reschedule.
The Recalculate Schedules dialog box is displayed.

2 Choose to reschedule only the Channel Product currently selected in the worksheet or all Channel
Products in the workcentre or adhoc group.

3 Choose to reschedule From current period selected in the worksheet or for All periods.
4 Click OK.

The Calculate Schedule dialog box is displayed.
5 Select the Include Sub-Ordinates with corresponding BOM Parents check box if you want to

reschedule BOM subordinates linked to any BOM parents currently selected.
See "About bills of materials" on page 438.

6 Click OK.
7 Click Close.
8 Select View > Output to display the process log.
9 Click Save Capacity.

Note: If Order Book is in use, the Order Book table must be populated with the latest information
prior to running the scheduling process. See "About the Order Book" on page 198.
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Workcentres

About workcentres
Rough cut capacity planning (RCCP) uses the concept of workcentres. Any number of workcentres
may be defined that have a time-phased capacity that can be defined in any unit of measure, typically
this might be hours per shift or units per day.

A workcentre models a constraint, applicable to a selection of Products at a defined Channel. A
workcentre is also associated with a receiving calendar to define available work units (for example,
shifts, man-hours or machine hours) in any given day. In most situations a Product will share the same
receiving calendar with its workcentre. If this is not the case, the available days defined by the workcentre
calendar takes precedence over the available days defined for the individual item, for the purpose of
calculating available capacity. Units produced per work unit (shifts etc.) are stored by Channel Product
at the workcentre level. This allows a Channel Product to be defined at more than one workcentre.

The RCCP worksheet summarizes the open and recommended orders for each Channel Product in a
workcentre or an ad-hoc group. It is possible to view the worksheet in units (production quantities),
weighted units or by the defined capacity measure. There is a summary of the group and comparison
to the stated capacity at the bottom of the screen.

To enable greater visibility in RCCP, it is possible to evaluate the capacity loading based on different
order date fields or on a variable offset defined at run time. For the purposes of RCCP, the following
fields are relevant:

• Due Date (Ot) time at which the Product becomes available.

• Release Date (Ot) date at which the orders should be released to production or the supplier at the
agreed lead time.

• Ship Date (Ot) allows orders generated by Balanced Allocation or Commit Orders to reflect the
loading at the time the order should be dispatched within the DRP network.

The offset allows any of these dates to be used and restates the capacity required based on the date
option selected.

Creating a workcentre
1 In Replenishment Planner, select RCCP Maintenance > Create Workcentre.

The Create Workcentre wizard is displayed.
2 Select the Products to use then click Next.
3 Select the workcentre Channel then click Next.
4 Type a code and unique name for the workcentre in the edit boxes.
5 Select the default order date from the list box then click Next.
6 Select a receiving calendar from the Receiving Calendar Code list then click Next.
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7 Select the Channel Products to be included in the workcentre then click Next.
8 Type the required Capacity Balance and Units Per Work Unit values then click Next.

See "Modify Workcentre Wizard: Capacity Balance and Units Per Work Unit dialog".

9 Use the Expand and Collapse icons to review the constituent parts of the workcentre.
10 Click Finish.

Modifying a workcentre
1 In Replenishment Planner, select RCCP Maintenance > Modify Workcentre.

The Modify Workcentre Wizard is displayed.
2 Select the Products to use then click Next.
3 Select the workcentre to be modified from the Workcentre Code list then click Next.
4 Edit the Workcentre Code and Workcentre Description as required.
5 Select the Default Order Date from the list box then click Next.
6 Select a receiving calendar from the Receiving Calendar Code list then click Next.
7 Make any changes to the selection of Channel Products included in the workcentre then click Next.
8 Edit the Capacity Balance and Units Per Work Unit values as required then click Next.

See "Modify Workcentre Wizard: Capacity Balance and Units Per Work Unit dialog".

9 Use the Expand and Collapse icons to review the modified workcentre.
10 Click Finish.

Deleting a workcentre
1 In Replenishment Planner, select RCCP Maintenance > Delete Workcentre.

The Delete Workcentre wizard is displayed.
2 Select the Channels to use then click Next.
3 Select the workcentre to be deleted from the Workcentre Code list then click Next.
4 Use the Expand and Collapse icons to review the constituent parts of the workcentre marked for

deletion.
5 Click Finish.
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Scenario Products

About Scenario Products in RP
Scenario Products may be created in the Demand Forecaster module. Once created, they may be
used within the Replenishment Planner module, subject to certain restrictions.

See "Creating Scenarios" on page 277.

Select Products
Functions within Infor Demand Planning are carried out on the current Product or Channel Product
selection. If Scenario Products are required to be included in any RP function, they must first be selected.
Scenario Products will only appear in the Product selection window, if the main menu option View and
Scenario Products is selected.

Once ticked, Scenario Products are displayed in the Product selection window as any other Standard
Product. The Product selection window can be called from either the File menu option or by clicking
on the Select Products  icon.

RP functions available for Scenario Products
If Scenario Products are part of the current Product selection (defined above), they are included in the
following functions:

• Properties Window

• Order Viewer

• Reporting

• Scheduling

• Committing and Balanced Allocation

• Rough Cut Capacity Planning.

• Load Forecasts from Demand Forecaster

• Calculate ROP

Any changes made will not be applied to the live, Standard Product (known as the base case) until the
Scenario Product details have been approved and formally copied across to the base case.

See "Copying Scenarios" on page 453.

RP functions not available for Scenario Products
Even when Scenarios Products are part of the current Product selection, they are excluded from all
bill of materials functionality. These functions are:

• Create/Modify/Delete BOMs
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• BOM Structure Viewer

• Dependant Requirements Viewer

Creating Scenarios
1 In Demand Forecaster, select Modules > Demand Forecasting > Edit Forecasts.

The five Edit Forecasts windows are displayed.
2 Select the required Product from the list.
3 Select Edit > Scenarios > Create Scenario.

The Select scenario suffix dialog box is displayed.
4 Select a Scenario suffix from the list or type a new one.
5 Type a description if required.
6 Click OK, then click OK again when created successfully.

Note: 

• This functionality is only available for Standard Product and PFGs.
• When a Scenario is created, it is created for all Channels associated with the base case Product.

Copying Scenarios
1 In Demand Forecaster, select Modules > Demand Forecasting > Edit Forecasts.

The five Edit Forecasts windows are displayed.
2 Select the required Product from the list.
3 Select Edit > Scenarios > Copy Scenario.

The Copy Scenario dialog box is displayed.
4 Click the code of the Product to copy to.
5 Click OK, then click Yes to confirm.
6 Click OK when copied successfully.

Copying Scenarios
1 In Replenishment Planner, select the Channel Product to be copied.

See "About selecting Products and Channels" on page 35.

2 Select View > Scenario Products unless there is already a check mark next to this command.
3 Select Edit > Scenarios.

The Copy Scenario dialog box is displayed.
4 Click the code of the Product to copy to.
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5 Select the Would you like to copy all DF fields? check box if you want to copy Channel Products
table forecasting fields.

6 Select the Would you like to copy all IO fields? check box if you want to copy Channel Products
table inventory fields.

7 Click OK, then click Yes to confirm.
8 Click OK when copied successfully.

Deleting Scenarios
1 In Demand Forecaster, select Modules > Demand Forecasting > Edit Forecasts.

The five Edit Forecasts windows are displayed.
2 Select the required Product from the list.
3 Select Edit > Scenarios > Delete Scenario.

The Delete Scenario dialog box is displayed.
4 Select the Scenario you want to delete and click Delete.
5 Click Yes to confirm.
6 Click OK when deleted successfully.

Sales and Operations Planner

About S&&OP plans and budgets
Budgets may be assembled and production plans and actuals posted to the database within the
Replenishment Planner module.

Sales & Operations Planner must first be configured before these options become available.

See "Configuring Sales and Operations Planner" on page 202.

In addition, S&OP functions must be enabled for the relevant Channel Products.

See "Enabling Channel Products for S&OP and SBT" on page 204.

Posting requirements and inventory plans
1 In Replenishment Planner, select the required Channel Products.

See "About selecting Products and Channels" on page 35.
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2 Select S&OP > Post Plans.
The Post Plans dialog box is displayed.

3 In the Post Plan panel, choose to either overwrite existing plans in the S&OP Requirements Plans
(SOP_REQS_PLANS) and S&OP Inventory Plans (SOP_INV_PLANS) tables, or insert temporary
plans in the S&OP Temporary Requirements Plans (SOP_REQS_TMP) and S&OP Temporary
Inventory Plans (SOP_INV_TMP) tables.

4 Click OK.
5 Click Close.
6 Select View > Output to view the process log.

Posting requirements and inventory actuals
1 In Replenishment Planner, select the required Channel Products.

See "About selecting Products and Channels" on page 35.

2 Select S&OP > Post Actuals.
The Post Actuals dialog box is displayed.

3 Click OK.
4 Click Close.
5 Select View > Output to view the process log.

Note:  For each Channel Product, the value in the "Production This Period (CPt)" field is posted as
the requirements actual and the sum of the values in the "Opening Stock (CPt)" and "Due In Stock
(CPt)" fields is posted as the inventory actual.

Making inventory and requirements budgets
1 In Replenishment Planner, select the required Channel Products.

See "About selecting Products and Channels" on page 35.

2 Select S&OP > Make Budget.
The Make Budget dialog box is displayed.

3 Do one of the following:

• Select This Year if you want to post the budget for the current year only.
• Select Next Year if you want to post the budget for the next year only.
• Select Both Years if you want to post the budget for the current year and the next year.

4 Select the budget name.
5 Click OK.
6 Click Close.
7 Select View > Output to view the process log.
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For weekly S&OP ("S&OP Data Stored (St)" field set to 8 or 9) it is not possible to post inventory
budgets if the "Sales Plan For Inventory Calculation (St)" field is set to 102 or 104.
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8Sales Budgeting and Tracking

About Sales Budgeting and Tracking
Sales Budgeting & Tracking (SBT) enables you to compare plans and budgets with actual data, to
asses their accuracy.

• Sales Plan

An SBT sales plan is a slice of net or statistical forecast data for the current fiscal year. This may be
either the most recent data, or offset from the present by a defined number of periods. The previous
fiscal year’s data is also available for review. The key to an effective sales plan is deciding which slice
to use.

See "About SBT sales plans" on page 459.

• Budget

There are three possible SBT budgets: original, revised and target. You can import a budget or save
the current forecast as a budget.

See "About SBT budgets" on page 462.

• Actuals

The data against which the sales plan and the budget are judged. This may be sales, demand or (more
usually) adjusted demand.

It is important to realize that all of the above – sales plans, budgets and actuals – are kept separately
for each individual Channel Product for which SBT has been enabled by setting the "Store SOP Data
(CPt)" field.

SBT is permissible for all types of Product except Forecast Group Products.

To compare plans and budgets with actuals, you can view Sales Planning reports. Each report consists
of one or more slant charts (and associated bar charts).

See "About Sales Planning reports" on page 463.
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About the difference between SBT and S&&OP
Infor Demand Planning offers two ways of comparing what you planned with what actually happened.

• Sales Budgeting & Tracking (SBT)

This Windows-based Demand Forecaster module enables you to compare actual sales against an
annual sales plan and budget (with the option of revising the budget part-way through the year).

• Sales & Operations Planner (S&OP)

This Web-based Collaborate module offers more sophisticated analysis of sales, with four different
types of sales plans, and the option of including requirements and inventory plans too.

These features can be run side-by-side, as they use different database tables. Both SBT and S&OP
are configured within Database Administration.

Note: 

• Although S&OP and SBT can be used at the same time, there are subtle differences in the way they
work. This means that it is sometimes not advisable to make direct comparisons between their
reports.

Configuring Sales Budgeting && Tracking
Sales Budgeting & Tracking (SBT) is usually configured when the database is set up.

1 In Database Administration, select System > System Data.
The System Data dialog box is displayed.

2 In the SOP Control box, select one of the following:

• Forecasting Only (SBT), to enable only SBT functions.
• Full SBT and SOP, if you want to enable all SBT and S&OP Sales, Requirements and Inventory

functions.
• SBT & S&OP Sales Only, to enable SBT and also S&OP Sales functions.

Changing this setting affects the value of the S&OP Data Stored field of the System table. See
"S&OP Data Stored (St)".

3 In the History Row for SBT box, select the type of history that should be used by default as "actuals"
in the SBT functions (sales, demand or adjusted demand).
You can override this default when producing Sales Planning reports.

4 In the Remove History SBT box, type the maximum number of periods of history that should be
stored for SBT purposes.
If you do not specify a number, Infor Demand Planning assumes either 36 or 39 periods, depending
on whether there are 12 or 13 forecast periods per year.

Note: 
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• You can enable Sales & Operations Planner (S&OP) at the same time as enabling SBT.
• The database’s application defaults are set up so that every Channel Product you import or

create is automatically enabled for the SBT and S&OP functions you have configured.

Enabling Channel Products for S&OP and SBT
Typically, the application defaults ensure that when new channel products are added to the database,
they are automatically enabled for all S&OP and SBT functions that have been configured. This is
achieved by configuring the application defaults so that the default initial value of Store SOP Data (CPt)
is "1". See "Store SOP Data (CPt)" and "Editing application defaults" on page 70.

However, if a channel product is not enabled, you can enable it by editing the Channel Products table.

1 In Database Administration, select the required channel products and perform these actions for the
selected channel products:
a Select the check box in the Store SOP Data cell.
b Optionally, for SBT functions, in the SOP Offset Periods cell, specify the offset, in periods,

between the SBT sales plan values and the period forecast values.
See "Editing the Channel Products table" on page 116.

2 If S&OP functions are already in use, reinitialize the S&OP tables.
This is necessary because the S&OP tables require new rows for the newly enabled channel products.
See "Reinitializing sales and Operations Planner" on page 204.

Caution: If the S&OP tables contain data that you do not want to lose, export the data before
you reinitialize S&OP, then import it again afterwards.

See "Configuring Sales and Operations Planner" on page 202  and "Configuring Sales Budgeting
&& Tracking" on page 458.

Sales Plans

About SBT sales plans
An SBT sales plan is a slice of net forecast or statistical forecast data for the current fiscal year.
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Simple and offset plans
A simple sales plan consists of the most recent forecast for each period of the year. For future periods,
this is nothing more than the current forecast. But for historical periods, the most recent forecast for
each period is the forecast that was made in the preceding period.

In contrast, an offset sales plan consists of demand forecasted at even earlier times. For example, if
a Channel Product has a lead time of two months, you might want its sales plan to be based on forecasts
made two months prior to the most recent forecast. (In fact, Infor Demand Planning allows a plan to
be offset by up to a year.)

The offset for any particular Channel Product may be defined by:

• A specific number of periods: "SOP Offset Periods (CPt)".

• The Channel Product’s lead time: "Lead Time (CPt)".

• The Channel Product’s freeze fence: "Open Orders Freeze Period (CPt)".

When you generate a Sales Planning report, you can select any of these offsets, or specify an offset
just for that report.

See "Examples of sales plans" on page 460.

Saving forecast data
It follows that in order to produce this year’s plan, and allow last year’s plan to be reviewed, Sales
Budgeting & Tracking needs to store not only the current net forecast (statistical forecast plus market
intelligence) but also historical forecasts for the current year, the previous year, and the year before
that. Moreover, each forecast must itself cover at least two years into the future.

Once SBT is enabled, the process of saving the current forecast for SBT sales plans happens
automatically at period end. If a Channel Product’s current forecast changes after period end, you can
either update its original (that is, existing) sales plan data or save the changed forecast as a temporary
(non-offset) sales plan. Any temporary sales plan is deleted automatically at the next period end.

Note: 

• If the forecast changes mid-period, but you don’t update the original plan data before period end,
the changed forecast is never reflected in SBT plans.

Examples of sales plans
The following diagrams show a series of forecasts for a Channel Product. The current period is May,
and the current forecast is highlighted in blue. (For simplicity, each forecast covers only one year, and
less than a full year’s historical forecasts are shown.)

A plan with no offset
Let us assume that the sales plan for this Channel Product has no offset, so that it is based on the
most recent forecast data for each period. The green figures are the plan, and the red figures show
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from which forecasts the plan is derived. Note that in this situation, the plan for all future periods is
simply the current forecast.

A plan with a two-period offset
Now assume that the plan has a two-period offset. Again, the green figures are the plan, and the red
figures show from which forecasts the plan is derived. Note that in this situation, the plan for all future
periods is not related to the current forecast.

Therefore, mid-period changes to the current forecast affect only sales plans that have no offset.

Updating existing SBT sales plan data
If a Channel Product’s current forecast has changed, you can update its existing SBT sales plan data.

1 In Demand Forecaster, select one or more Channel Products for which you want to update the
existing sales plan.
See "About selecting Products and Channels" on page 35.

2 Select Modules > Sales Budgeting & Tracking > Edit Sales Plans.
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3 Click Overwrite existing plan, then click OK.

Note: Although the sales plan data is updated for every currently-selected Channel Product, it has
noticeable effect only for those Channel Products which (a) actually have changed forecasts and
(b) have non-offset plans (that is, plans based on the most recent forecast data).

Creating temporary SBT sales plans
If a Channel Product’s current forecast has changed, you can use it to create a temporary, non-offset
SBT sales plan.

1 In Demand Forecaster, select one or more Channel Products for which you want to create (or update)
a temporary sales plan.
See "About selecting Products and Channels" on page 35.

2 Select Modules > Sales Budgeting & Tracking > Edit Sales Plans.
3 Click Insert temporary plan, then click OK.

Note: 

• Although a temporary plan is saved for every currently-selected Channel Product, it has noticeable
effect only for those Channel Products that (a) actually have changed forecasts and (b) have
non-offset plans (that is, based on the most recent forecast data).

• All temporary sales plans are zeroed at the next period end.

Budgets

About SBT budgets
A Channel Product can have up to three different SBT budgets:

• An original budget, typically produced at the beginning of a fiscal year.
• A revised budget, typically produced partway through the fiscal year.
• A target budget, typically produced for a specific sales promotion.

All budgets are based on fiscal years. Usually, each budget extends to just this fiscal year and the next,
but Infor Demand Planning supports 10-year budgets if required. Last year’s budgets are also available
for review.

You can either import a budget or save the current forecast as a budget. If you save the current forecast
partway through the year, the year-to-date periods are actuals and the remainder of the year is forecast.
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Creating SBT budgets from the current forecast
1 In Demand Forecaster, select one or more Channel Products for which you want to create a budget.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Sales Budgeting & Tracking > Initialize Budgets.
The Initialize Budgets dialog box is displayed.

3 Under Post Budgets For, specify whether you want to create a budget for this year, next year, both,
or up to 10 consecutive years.

4 Under Post Budgets As, specify whether this is an original budget, a revised budget or a sales target
budget.

5 If you want to copy time-phased weighting (TPW) values from one TPW vector to another, for all of
the selected Channel Products, click TPW to expand the dialog, then select the source and target
TPWs. Optionally, you can limit the number of forecast TPW values that are copied (historical TPW
values are always copied).
See "About time-phased weightings" on page 108.

6 Click OK.

Importing SBT budgets
You can import SBT budgets by an automated process that reads an import file into a raw import table,
then automatically transfers the acceptable data into the correct SBT table (named SOP_DATA).

The process is triggered by loading a special Import Raw Budgets import template when importing the
file.

See "About automated importing" on page 138 and "Importing data by loading a template" on page 137.

Sales Planning Reports

About Sales Planning reports
A Sales Planning report consists of a set of slant charts. When generating such a report for a selection
of Channel Products, you can specify which of the following slant charts you want to include:

• A slant chart for each individual Channel Product.
• A slant chart for each Product, summed across all Channels.
• A slant chart for each Channel, summed across all Products.
• A slant chart summed across all Products and Channels.
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• A slant chart for one or more groups of Products, based on a selected Products table field, summed
across all Channels.

A report can include slant charts for either the current or the previous fiscal year. The format of each
slant chart is the same in all cases.

See "Interpreting a slant chart" on page 465.

The slant charts can be weighted by any static weighting or time-phased weighting.

See "About static weightings" on page 107.

See "About time-phased weightings" on page 108.

Viewing a Sales Planning report
1 In Demand Forecaster, select the Channel Products you want to include in the report.

See "About selecting Products and Channels" on page 35.

2 Select Modules > Sales Budgeting & Tracking > Reports.
The Sales Planning Report Options dialog box is displayed.

3 On the Report Control tab, specify which of the following slant charts you want to include in the
report:

• A slant chart for each individual Channel Product.
• A slant chart for each Product, summed across all Channels.
• A slant chart for each Channel, summed across all Products.
• A slant chart summed across all Products and Channels.
• A slant chart for one or more groups of Products, based on a selected Products table field,

summed across all Channels.

4 On the Report Detail Options tab, specify this information:

• The type of history to show as "actuals" in the report (sales, demand or adjusted demand).
• The type of forecast data to show (statistical or net forecast).
• The type budget to show (original, revised or sales target).
• The type of sales plan to show (original or temporary).
• The offset, if any, between the actuals and the period forecast data to which they are compared.

5 Optionally, on the Report Weighting tab, specify this information:

• Whether the report is to be weighted by a static weighting or a time-phased weighting.

• Whether the report is to be scaled.

6 Click OK.
7 Specify whether you want the report to show the previous or the current fiscal year.

The requested slant charts are displayed as a multi-page report in the Slant Chart window. An SOP
toolbar and a Report toolbar also appear. See "Slant Chart window".
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8 To page forwards and backwards through the report, select File > Next item or Previous item.

Note: 

• To change the font used in the report, select Tools > Fonts.
• To print the report, select File > Print.

Viewing a Sales Planning bar chart
You can view a graphical representation of any slant chart in a Sales Planning report. The graph shows
a bar chart of plan, actual and budget data for each period.

1 Create a Sales Planning report that includes the slant chart that you want to view, and go to that
page of the report.
See "Viewing a Sales Planning report" on page 464.

2 On the SOP toolbar, click SOP Plot.
A Sales Planning Plot window appears, showing a bar chart based on the underlying slant chart.
The window has a Chart toolbar and a legend. See "Sales Planning Plot window".

Note: 

• To copy the chart to the Clipboard as a bitmap (.bmp) file, on the Chart toolbar, click Snapshot.
• To print the graph, on the Chart toolbar, click Print.

Interpreting a slant chart
Here is a typical example of a slant chart:
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The "Now" lines shows the current point in the fiscal year.

Forecasts
The figures above the horizontal "Now" line show the forecasts made since the beginning of the (fiscal)
year. In the following example, the most recent forecast (made in April, for May onwards) is highlighted:

Rolling totals
The Rolling column can be hard to understand until you realise that it sums a full twelve periods although
only the current (fiscal) year is shown in the slant chart. So, for example, the Rolling figure for April is
the sum of the forecast from May this year to April next year, although only this year’s forecast is shown:

In this example, only the Rolling figure for December sums values that are all present in the chart.

466 | Infor Demand Planning User Guide

Sales Budgeting and Tracking



Offset Plan
The Offset Plan row shows the sales plan, offset from the present by the defined number of periods.
For a chart that is showing an individual Channel Product, the relationship between the plan values
and the period forecast values can be seen directly. For example, if the offset is zero, the plan (green
figures) is simply the most recent forecast (red figures):

However, for summed slant charts, this relationship may not be obvious, because different Channel
Products may have different offsets.

See "About SBT sales plans" on page 459.

Budget
The Budget figures for a year can be generated either by importing, or by saving a forecast. Remember
that there are three different types of budget that can be reported. The YTD figure is really the total
budget for the year.

See "About SBT budgets" on page 462.

Infor Demand Planning User Guide | 467

Sales Budgeting and Tracking



Outlook and Actual
Actual figures show the sales, demand or adjusted demand recorded for the (fiscal) year to date.

The Outlook for a period is the total actuals up to and including that period, plus the forecast onwards
to the end of the (fiscal) year. So, for example, the Outlook in February is the sum of the actuals for
January and February, plus the forecast made in February from March to December:

Actual vs. Budget
Simply a month-by-month comparison of the Actual and Budget values. For example, the Actual vs.
Budget for March (124%) is the percentage change from the Budget (25) to the Actual (31):
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Actual vs. Plan
Simply a month-by-month comparison of the Actual and Offset Plan values. Here, March is again used
as the example:

Outlook vs. Budget
Finally, the Outlook vs. Budget figure compares each months’ Outlook with the total annual budget.
Once more, here is March as an example:
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