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Basics

Browse through this section of the help so that you understand and can use the application interface
more effectively.

NOTE: The directions and descriptions in these topics assume that you are using the smart client.
The Web client has a slightly different interface.

This section is designed to help you learn:

¢ How the system works

e What the major features of the system are

¢ How to customize the interface to your own working preferences
¢ How to most effectively use the system and its features

This area of the help includes the following major topics:

e Getting Around in the System

e Using the Explorer

o Keyboard Navigation and Other Navigation Tips

¢ Context (Right-Click) Menus

e Getting Help

e Setting Preferences

e Working with Forms, Collections, Records, Fields, and Notes

e Reference
e Keyboard Shortcuts

¢ Menus
e Toolbars







Getting Around in the System

Getting Around in the System

The application user interface is designed to be intuitive and easy to use. At the same time, we
provide you with the flexibility to customize the system and set your own preferences

This section contains information to help you learn about:

Using the Explorer: Use the Explorer to locate and open forms. You can also customize the way
you organize and use forms to reflect your preferences.

Using the Keyboard: Use your keyboard to navigate and work in the system.

Using Context (Right-Click) Menus: Context menus, often called "right-click menus," are
shortcuts to perform actions on the current field or value.

Using the Help: Get help when you need it, quickly and easily. Context-sensitive help is available
on most forms, fields and buttons.

Setting Preferences: You can customize many aspects of the user interface. For example, you
can select different colors and fonts.

Using the Explorer

Using the Explorer

The Explorer is often the starting point for working in the system. The Explorer tree pane presents a
hierarchical view of the forms in the system, similar to Windows Explorer. Within the Explorer, forms
are grouped in folders. These are things you can do in the Explorer:

Navigate through the folders to find and open a form. See Opening the Explorer and Structure of

the Explorer.
Set up your favorite forms as a group, so you can get to them easily. See Customizing '‘My
Folders'.

Change the way you view the Explorer, to accommodate the way you work. See Changing Your
View of the Explorer and Customizing the Explorer Buttons and Tree View.

Set certain forms to open automatically when you log into the system. See the AutoRun
information in Customizing 'My Folders'.
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Opening the Explorer
To open the Explorer, from the View menu, select Explorer.

Depending on what theme you are using, the Explorer might open automatically when you log in to
the system.

Setting the Opening Level

You can set the Explorer to always open at a certain level, for example, with the Customer Service
forms showing in the Explorer tree. For more information about how to do this, see Customizing the
Explorer Buttons and Tree View.

Structure of the Explorer

Structure of the Explorer

When open, the Explorer displays a hierarchy of folders and forms. Initially, the Explorer displays
only the top-level folders:

e My Folders
e Master Explorer Folders

e Public Folders

e User Folders

NOTE: Your system administrator might have reorganized, removed, or renamed any of the folders
described in this topic.

The Explorer has two panes:

o Use the top (Tree) pane to expand a folder to display and select subfolders and forms.
e Click the buttons in the lower (Button) pane to display different trees in the current folder level.

You can customize the Explorer buttons and tree view to show only the areas of the application that
you need.

The setting of the Select by Name Instead of Caption option on the Select Form dialog affects the
order in which forms display in the Explorer tree structure. If the option is selected, the forms display
in alphabetical order in the Explorer according to the form name; otherwise, they display in order by
the form caption.

Master Explorer Folders
Expand the Master Explorer folder, and you see a set of subfolders similar to this:

e All Forms
e Modules

These subfolders are divided into groups that provide different ways of locating any form in the
system.
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If the Button pane is displayed, you can also use the buttons to move to different areas within a
level.
All Forms

Expand the All Forms subfolder, and Explorer displays under it all forms available to you, arranged
in alphabetical order. If you know the name of the form you want, this is often the fastest way to
access it.

For tips on locating forms, see Finding and Opening Forms in the Explorer.

Modules Folder

The Modules folder displays forms grouped mostly by application modules. To find a form based on
the area of the application where it exists, select the appropriate module subfolder . The Modules
folder also includes the Codes subfolder, which contains forms where you set up codes that are
used throughout the system, and the System subfolder, which contains forms used for general
application administration.

Subfolders
The Modulesfolders contain multiple levels of subfolders.

The list of forms subfolders can be further subdivided by function, for example Files, Queries,
Reports, and Utilities. These are the functional subfolder types:

Folder

Type Description

Activities Forms used for day-to-day activities. These forms typically perform common
actions on records, such as copying them, generating line sequences, printing
worksheets, and so on.

Files Forms where you can set up codes and parameters used within the module.

Queries Forms to help you find specific records by using filtering techniques.
For more information, see About Query Forms.

Reports Forms to set up the parameters for printing specific information from the records.
For more information, see Reports Overview.

Utilities Forms used for activities generally performed by administrators or managers.

Utilities usually require Site Developer (system administrator) permissions to use.

NOTE: A system administrator can remove or hide folders and subfolders, so you may not see all
of the folders mentioned here in your Explorer window.
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Public Folders

The Public Folders subfolder contains any forms your system administrator has set up to appear
there. These forms are typically available to anyone in an organization.

Only those designated as a Site Developer on the Users form (usually system administrators) can
make changes in this folder.

User Folders

The User Folders folder allows those who have Site Developer editing permissions (on the Users
form) to view and edit the My Folder contents of any user in the system. This folder is available only
to those who have these editing permissions.

My Folders

You will probably find, as you work, that there are some forms that you use more often than others.
The My Folders folder is designed to provide you a place where you can create your own set of
commonly used forms. If you want, you can also rename subfolders and forms in My Folders to
reflect your preferences. Finally, you can also select sets of forms to open automatically whenever
you log on to the system.

For more information, including the procedures to do these things, see Customizing My Folders in
the Explorer.

In addition, your system administrator can use My Folders to create shortcuts to forms and
automate them opening for you when you log on.

Changing Your View of the Explorer

The system provides several ways for you to adjust the Explorer window to your preferences. You
can:

e Customize the Explorer buttons and tree view.

e Dock or undock the Explorer window in the workspace area.

e Move and the Explorer and resize its viewing area.

e Pin or unpin the Explorer window. This option allows the Explorer window to slide in and out of
view automatically as you work.

Docking and undocking the Explorer

When you dock the Explorer, the system "attaches" the Explorer window to one side of the
workspace area. There are a number options for docking: You can dock to the left, right, top, or
bottom of the workspace area.

When you undock the Explorer, the Explorer is allowed to “float,” and you can move it wherever you
want, independent of the WinStudio workspace window.

To dock the Explorer: Click-and-hold in the title bar and then drag the Explorer until you see the
superimposed docking "stations". As you drag your pointer over each docking station, the display
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highlights to show the area that the Explorer will occupy by default if you select that docking station.
To dock at a particular station, drag the Explorer window until you have the station you want the
Explorer to occupy and then release the pointer button.

To undock the Explorer: Click-and-hold in the title bar and then drag the Explorer to the position
you want it to occupy, being careful not to release the pointer button with one of the docking stations
highlighted.

Moving and resizing the Explorer

You can move the Explorer window freely only if it is undocked. You can resize the viewing area
whether Explorer is docked or undocked.

To move the Explorer, click-and-hold in the title bar and drag the Explorer to the desired location.
To resize the Explorer viewing area when it is:
o Docked, drag the "free" side of the Explorer to the desired position.

When the Explorer is docked, only one side is free to move, the side opposite to its primary
location. For example, if the Explorer is docked to the right side of the workspace area, only the
left side is movable.

e Undocked, drag any side or corner, the same as you would resize any other window.

Pinning and unpinning the Explorer

Pinning the Explorer keeps the viewing area displayed regardless of whether you are working with it
actively.

Unpinning the Explorer allows its viewing area to slide out of view automatically when you are not
actively viewing it.

To pin or unpin the Explorer, you must have the Explorer docked. With the Explorer docked, click the
pin/unpin icon in the title bar.

To view the Explorer when it is hidden (out of view), position your pointer over the Explorer button
where the Explorer is docked.

Customizing 'My Folders'

Customizing 'My Folders’
In Explorer, you can customize the contents of My Folders in several ways:

e Add your own subfolders (see Adding Folders).

e Add or copy forms into your My Folders or any subfolders you have created (see Adding Forms
to Folders or Copying Folders or Forms).

¢ Rename folders or forms to reflect your use of those folders and forms (see Renaming Folders
or Forms).
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CAUTION: Do not rename the AutoRun or PreLoad subfolders.

e Delete folders and forms (see Deleting Folders or Forms).

CAUTION: Do not delete the AutoRun or PreLoad subfolders.

e Use the AutoRun and PreLoad subfolders to set up forms that open automatically when you log
on (see Setting Up Forms to Open Automatically).

Adding Folders
You can add your own (sub)folders to My Folders.

NOTE: Your editing permissions determine whether you can add subfolders to other folders, but the
procedure is basically the same.

To add a subfolder:
1 In My Folders, select the folder or subfolder below which the new subfolder is to be added.

For example, if you want to add a subfolder at the top level underneath My Folders, select My
Folders. If you want to add a subfolder to AutoRun or another subfolder, select that subfolder.

2 Right-click the selected folder and from the context menu, select New Folder.
The system adds the new subfolder and temporarily names it New Folder.
3 Right-click the new subfolder, and from the context menu, select Properties.

4 In the Caption field of the Explorer Object Properties dialog box, enter the new name for the
folder.

5 Click OK.

Adding Forms to Folders

You can add forms to My Folders or any of its subfolders. Your editing permissions determine
whether you can add forms to other folders.

To add a form to a folder:

1 In the Explorer tree pane, right-click on the form and select Copy.

2 Navigate to My Folders.

3 Inthe tree pane, select the My Folders folder or subfolder to which you want to add a form.
4 Right-click on the folder and select Paste.

If you are working in the Explorer tree view with buttons turned off (that is, Display Explorer
Buttons is not selected in the Settings window), you can also drag and drop a form from its current
folder into the folder where you want to create a copy.

NOTES:

e You are not really creating a copy of the form itself, only creating a shortcut to that form.
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e You can copy only one form at a time.

Copying Folders or Forms

To facilitate the way you work, you can copy folders and forms from the Master Explorer folder or
Public Folders to My Folders.

NOTE: Your editing permissions determine whether you can copy forms to other folders.
To copy folders or forms:

1 In the Explorer, navigate to the folder or subfolder that contains the form or folder you want to
copy.

2 Inthe tree pane, right-click on the form or folder and select Copy.
3 Navigate to the folder in which you want to create a copy.
4 In the tree pane, right-click on the folder and select Paste.

If you are working in the Explorer tree view with buttons turned off (that is, Display Explorer
Buttons is not selected in the Settings window), you can also drag and drop a form from its current
folder into the folder where you want to create a copy.

NOTES:

e You are not really creating a copy of the form itself, only creating a shortcut to that form.
e You can copy only one form at a time.

e You can rename your copy of the form in the Explorer. For the procedure, see Renaming
Folders or Forms.

Renaming Folders or Forms

To facilitate the way you work, you can rename folders and forms in My Folders.

NOTE: Your editing permissions determine whether you can rename items in other folders.

To rename a folder or form:
1 In the Explorer window, select the folder or form you want to rename.
2 Right-click the folder name, and from the context menu, select Properties.

3 Inthe Caption field of the Explorer Object Properties dialog box, type the new name.

NOTES:
¢ When changing the name of a form, do not change the contents of the Form Name field. If
you do, either the form will not open at all, or the wrong form will open.

¢ Renaming a form changes its title (caption) only in the current folder in the Explorer window.
The actual form name, the title of the same form as displayed in other folders, and the caption
displayed in the form when it is open are all unchanged.

1 Click OK.
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Deleting Folders or Forms

You can delete folders and forms from My Folders. Your editing permissions determine whether you
can delete from other folders.

CAUTION: Do not delete the AutoRun or PreLoad subfolders. If you do, you will lose the
functionality they provide until you recreate them. For more information, see Setting Up Forms to
Load Automatically.

To delete a folder or form:
1 Select the folder or form you want to delete.

2 Right-click the item and then, from the context menu, select Delete.

Setting Up Forms to Load Automatically

Typically, you will find that there are a few forms that you use constantly or very often. You can use
the AutoRun and PreLoad folders in My Folders to load and even open these forms automatically
when you log in to the system.

e AutoRun: When you log in, the system automatically loads and opens any forms in the
AutoRun folder. The system opens them at their default size and cascades them in the
workspace.

e PrelLoad: When you log in, the system automatically retrieves any forms in the PreLoad folder
from the database into memory. This allows them to display more quickly when you open them
later.

If the AutoRun or PreLoad folder is missing from My Folders, you can recreate it by adding a new
folder and naming it AutoRun or PreLoad. For the procedure to add folders, see Adding Folders.

To set up forms to open automatically, copy the forms you want to load and/or open automatically
into either the AutoRun or the PreLoad folder.

For the instructions to copy forms, see Copying Folders or Forms.

Changing Your View of the Explorer

The system provides several ways for you to adjust the Explorer window to your preferences. You
can:

e Customize the Explorer buttons and tree view.
e Dock or undock the Explorer window in the workspace area.

¢ Move and the Explorer and resize its viewing area.

e Pin or unpin the Explorer window. This option allows the Explorer window to slide in and out of
view automatically as you work.
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Docking and undocking the Explorer

When you dock the Explorer, the system "attaches" the Explorer window to one side of the
workspace area. There are a number options for docking: You can dock to the left, right, top, or
bottom of the workspace area.

When you undock the Explorer, the Explorer is allowed to "float," and you can move it wherever you
want, independent of the WinStudio workspace window.

To dock the Explorer: Click-and-hold in the title bar and then drag the Explorer until you see the
superimposed docking "stations". As you drag your pointer over each docking station, the display
highlights to show the area that the Explorer will occupy by default if you select that docking station.
To dock at a particular station, drag the Explorer window until you have the station you want the
Explorer to occupy and then release the pointer button.

To undock the Explorer: Click-and-hold in the title bar and then drag the Explorer to the position
you want it to occupy, being careful not to release the pointer button with one of the docking stations
highlighted.

Moving and resizing the Explorer

You can move the Explorer window freely only if it is undocked. You can resize the viewing area
whether Explorer is docked or undocked.

To move the Explorer, click-and-hold in the title bar and drag the Explorer to the desired location.
To resize the Explorer viewing area when it is:
o Docked, drag the "free" side of the Explorer to the desired position.

When the Explorer is docked, only one side is free to move, the side opposite to its primary
location. For example, if the Explorer is docked to the right side of the workspace area, only the
left side is movable.

3 Undocked, drag any side or corner, the same as you would resize any other window.

Pinning and unpinning the Explorer

Pinning the Explorer keeps the viewing area displayed regardless of whether you are working with it
actively.

Unpinning the Explorer allows its viewing area to slide out of view automatically when you are not
actively viewing it.

To pin or unpin the Explorer, you must have the Explorer docked. With the Explorer docked, click the
pin/unpin icon in the title bar.

To view the Explorer when it is hidden (out of view), position your pointer over the Explorer button
where the Explorer is docked.
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Adding Images to Explorer Nodes

For Explorer folders and forms whose properties you have permission to change, you can specify a
different image. For example, if you have a My Folders folder called "MyReports," you can include a
picture of a printer on the MyReports folder.

To do this, right-click on the folder and select Properties. In the Explorer Object Properties dialog
box, click the browse button next to the Image File Name field. The browse dialog opens by default
to the application's working folder on the local computer. Your image files must reside in this folder,
and they must be graphic file types, for example .png or .gif.

Some Explorer nodes do not allow you to browse for an image filename, as indicated with an
asterisk (*) in the table below. In that case, a system administrator can choose to replace the default
image file for those nodes in the local working directory, using the same default file name.

The default image filenames are listed here:

Explorer Node Default Image File Name
Master Explorer * xMasterFolder

Public Folders * xPublicFolders

User Folders * xUserFolders

My Folder * xMyFolder

AutoRun / Preload Folders xAutoRunPreload

All Forms * xAllForms

Form (Regular) xFormRegular

Form (Query) xFormQuery
Workspace xWorkspace
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Keyboard Navigation and Other Navigation Tips

The system provides a variety of ways to use the keyboard instead of a mouse to select menu
commands, open forms, choose options, and so on. Many of these keyboard commands and
shortcuts are common to Windows applications.

For a complete list of keyboard shortcuts, see Keyboard Shortcuts.

This topic contains hints and tips for using the keyboard to accomplish many tasks and navigate
through forms more easily.

e Using Access Keys and Keyboard Shortcuts

e Navigating Through Fields, Buttons, and Other Components

e Navigating Through Notebook Tabs

¢ Navigating in Grids

Using Access Keys and Keyboard Shortcuts

You can use access key combinations and keyboard shortcuts to make selections from menus,
drop-down lists, and other form options. Access keys are indicated on menus and other components
by underlined letters in names or labels.

On Menus
To open a menu
1 Press ALT and the underlined letter in the menu's name.
If you do not see any letters underlined in menu names, press the ALT key.
2 After the menu is displayed, to choose a command do one of the following:

e Press the key corresponding with the underlined letter on the command entry.
e Use the arrows to select the command you want, and then press Enter.

Some menu entries also list keyboard shortcuts that you can use without first opening the menu.

In Forms and Dialog Boxes
To use the keyboard to select tabs, options, and buttons:
1 When you select a tab or option, the focus shifts to the selected component, and it is highlighted.

2 To run the comman represented by a button, press ALT and the underlined letter in the button's
name.

Alternatively, you can tab to the button and then, with focus on the button, press ENTER.

In Drop-down Lists

To select an item from a drop-down list box, using only key combinations:
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1 With focus on the drop-down list box, press ALT+down arrow to display the drop-down list. Then
use the up and down arrow keys to find the item you want.

2 Press TAB or ENTER.

To move away from the list without selecting an item, press ESC or SHIFT+TAB.

Navigating Through Fields, Buttons, and Other Components

When using the keyboard to navigate around non-grid forms and form views, the primary key is the
TAB key. Starting with the cursor in any field, when you press the TAB key, the cursor moves to the
next active field or button.

If you prefer, you can use the ENTER key rather than the TAB key. To use this option:
1 From the View menu, select Settings.
2 Onthe Run Time tab, select the check box labeled ENTER key behaves like TAB key.

For more information about this option, see Run Time Settings, Behavior Settings.

The general sequence, as you "tab through" fields and buttons is top-to-bottom and then left-to-right,
both within each group box and between group boxes. There are, however, exceptions, based on
the form's structure and design.

When you reach the last active field or button, the cursor moves back to the first field or button on
the form and starts back through the sequence.

To navigate backwards through the fields and buttons, press SHIFT+TAB.

Navigating Through Notebook Tabs

When a notebook tab is selected and has the focus on the form, you can use the directional arrow
keys on the keyboard to select other tabs.

You cannot use the TAB key here; if you do so, the focus changes to the first active or available field
on that notebook tab.

Navigating in Grids

The system offers several means to navigate within a grid (see Grid Forms and Grids). Which one
you use is a matter of personal choice.

NOTES:
¢ In a multiview form, clicking a row in the grid causes that record to be displayed in the detall
view.

¢ In a form with more than one collection, moving between records in the primary collection also
controls the display of records in the subcollection.

14



Getting Around in the System

To navigate to the next record in the collection (do one):

e Press F8.

e Press the down arrow key.

¢ On the toolbar, click the Go to the next object in the current collection button.
e From the Actions menu, select Next.

To navigate to the previous record in the collection (do one):

e PressF7.

e Press the up arrow key.

e On the toolbar, click the Go to the previous object in the current collection button.
e From the Actions menu, select Previous.

To navigate to the first record in the collection (do one):

e Press CTRL+up arrow.
e On the toolbar, click the Go to the first object in the current collection button.
e From the Actions menu, select First.

To navigate to the last record in the collection (do one):

e Press CTRL+down arrow.
e On the toolbar, click the Go to the last object in the current collection button.
e From the Actions menu, select Last.

To navigate to the next column in the record (do one):

e Press TAB. This takes you to the next active or enabled column, skipping over all columns that
are read-only.

e  Press the right arrow key. This takes you to the next column whether it is active or not.

NOTE: Unless you are in the last record in the collection, if you are in the last column of the record,
doing either of these actions takes you to the first column in the next record.

To navigate to the previous column in the record (do one):

e Press SHIFT+TAB. This takes you to the previous active or enabled column, skipping over all
columns that are read-only.
o Press the left arrow key. This takes you to the previous column whether it is active or not.

NOTE: Unless you are in the first record in the collection, if you are in the first column of the record,
doing either of these actions takes you to the last column in the previous record.

To view the next or previous set of records in a collection when there are more records than can fit
into the viewing area of a grid, use the PAGE UP or PAGE DOWN keys.
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Context (Right-Click) Menus

Context menus are commonly known as right-click menus, because they are typically called forth by
right-clicking on something. WinStudio makes very widespread use of context menus, so it is a good
idea to become familiar with the kinds of things you can use them for.

¢ Inthe Explorer window, right-clicking displays options for working with folders and forms.
NOTE: These options are not available by any other means.

¢ Inaform, you can right-click a field or other component (such as a button) to display commands
that help you complete or use that field.

You can also use the Edit menu for most of these same commands and options.

e Inaform, if you right-click outside a field, the context menu provides commands that help you
use that form.

You can also use the Actions menu for most of these same commands and options.

o Drop-down lists have their own sets of context menu options. For more information, see About
Drop-down Lists.

Setting Preferences

Setting User Preferences

NOTE: Some of the settings described here apply only to the smart client and are not included in the
Web client.

You can customize many aspects of the WinStudio interface to your preferences. Among other
things, you can customize:

e The way you log on to the system

e The fonts and colors the system uses for forms, fields, and other components, using themes
e How forms look and behave in Design Mode

o Whether and how the diagnostics tools work

o Whether the toolbar displays

o How often the system should check for new messages in your Inbox form

o Whether the system should notify you of new messages and if so, how

¢ How unread messages should be displayed in the grid (top) view of the Inbox form

For details about the settings options, see one of the following topics:

e Runtime and Layout Settings - These are the settings that control how the system looks and
behaves when you are using it in normal day-to-day operations. For most, these are the only
options you need be concerned with.
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e Design Time Settings - These are settings that control aspects of how forms look and behave

when you are in Design Mode. You need these only if you are actively involved with creating or
modifying forms in the system.

o Diagnostics Settings - These are settings that control how the system works when you are

trying to diagnose problems and bugs while designing and modifying forms. You need these only
if you are actively involved with creating and modifying forms in the system.

e Event System Settings - These are settings that control how often the system checks for new

messages in your Inbox, whether and how you are notified of new messages, and how the
system displays unread messages in the Inbox. There are also settings that determine how you
interact with certain Application Event System forms.

Runtime Settings

Runtime settings control how the system looks and behaves when you are using it in normal day-to-

day operations.

To make run-time settings

1 Select View > User Preferences.

2 Adjust the settings to your preferences.

3 The User Preferences dialog box has five tabs, two of which deal with run-time settings:

¢ Runtime Behaviors

¢ Runtime Layout

Runtime Behaviors

Setting

Description/Comments/Procedures

Use Workstation
Logon

To log on using a workstation user ID and workstation domain name
automatically, select this option.

When selected, the application does not prompt you for a user ID and
password but logs you in automatically, using preregistered logon
credentials. When this chec box is cleared, the system prompts you for a
login ID and password every time you log in.

To use this option, your system administrator must register your
workstation domain name and user ID on the Users form, Workstation
Domain/ID field. For more information, see the online help for that field.

This check box also appears on the Sign In dialog box. If you select the
check box on the Sign In dialog box, you do not have to provide a user
name and password, but you can still select different configurations.
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Show Configuration
Name on Caption

When selected, this option causes the name of the system configuration
to which you are currently logged on to display in the title bar of
WinStudio.

Prompt to Save
Form Splitter
Changes

When selected, this option allows you to save any changes you might
have made to the position of the splitter bar in multiview forms.

For example, suppose you have a multiview form open, and at some
point, you moved the splitter bar to enlarge your view of the grid side of
the form. You like that change and want to make it permanent, so that
every time you open the form, the splitter bar is right where you
positioned it.

If this option is selected, when you try to close the form, the system
displays a confirmation box that asks if you want to save the current
splitter bar position. To save the form configuration, click Yes.

If this check box is cleared, you cannot save splitter bar position
changes at all.

Prompt to Save Grid
Changes

When selected, this option allows you to save any changes you might
have made to the grid view in multiview forms.

For example, suppose you have a multiview form open, and at some
point, you widened some columns and narrowed other columns on the
grid side of the form. You like the changes and want to make them
permanent, so that every time you open the form, the grid side is just as
you have it now.

If this option is selected, when you try to close the form, the system
displays a confirmation box that asks if you want to save the current grid
side configuration. To save the configuration, click Yes.

If this check box is cleared, you cannot save grid side changes at all.

ENTER Key
Behaves Like TAB
Key

If you want to use the ENTER key to move between fields on a form, in
the same way the TAB key works, select this option. To use only the
TAB key to move between fields, clear this check box.

NOTE: When this option is selected you can use either the ENTER
key or the TAB key for most movement between fields and options on
the form. There are two exceptions:

¢ In fields that allow you to enter several lines of text, pressing
ENTER always starts a new line. To move to the next field, you
must use the mouse or the TAB key.

e |If the focus is on a button, pressing ENTER executes the action
represented by the button. To move to the next button or field
without executing the action, you must use the mouse or the TAB
key.
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Include Grid Column
Headers When
Copying to Clipboard

If you select this check box, column headers are included when you
copy data in a grid to the clipboard. Clear this check box to not include
column headers.

Use Default Browser
as Report Viewer

If you select this check box, your system's default web brower is used to
view reports.

If this field is cleared, the Report Viewer form is used to view reports.

Unload IDO
Metadata with Forms

To clear the IDO metadata cache each time you unload global form
objects in Design Mode, select this check box.

(To unload global form objects then, from the Form menu, select
Definition > Unload All Global Form Objects.)

In IDO or application event development, clearing the cache ensures
that you see the results of the current, edited metadata.

Auto-delete All
Unmodified New
Rows

Under normal system operation (that is, when this option is not
selected), any row that the system inserts in a grid automatically is
automatically deleted if you move away from the row without changing
anything in it. However, the system does not treat rows that you create
using a menu option, toolbar option, or keyboard shortcut the same way.
With these rows, the system normally attempts to validate them, whether
you have modified them or not.

When this option is selected, the system treats all new rows as if they
were inserted automatically by the system. In other words, if you
manually create a row and then navigate away without changing
anything, the system automatically deletes it.

Optimize Script
Execution

This option causes form and global scripts to be optimized in such a way
that they all run in one domain. This improves the loading and compiling
time of WinStudio scripts.

In most cases, this option should be selected. This option should be
cleared only for those developers and system administrators who are
engaged in creating, maintaining, or debugging scripts. In a normal run-
time environment, clearing this option can have a detrimental effect on
system performance.

Wildcard character

Enter the character to be used as a wildcard character when you search
for information with Filter-in-Place or query forms.

The default character is the asterisk (*).

Data Record Cap
and
List Record Cap

The term caps refers to the maximum number of records or items that
the system can return at one time. There are two types of caps that you
can reset for your work:
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e Data records

e Drop-down lists

Both of these types of caps have the same three options:

e Use default - Forces the system to use the system default cap setting.

This is the default option.

e Retrieve all - Forces the system to retrieve all records or display all
items in a list, overriding the system default settings.

NOTE: This option is not recommended for most operations, because
the time it takes to retrieve all records or display all items on a list can
be excessive and slow the system down.

e Use specified max - Allows you to set your own maximum.

For example, if you want the system to return 350 records, you would
set this field for the Data Records to 350.

If you select this option, you must also enter a number in the field next
to it.

A -1 in this field means that the system default setting is being used.

This setting is not saved when you sign out of the system.

NOTES:

¢ Rather than having to reset the cap for collections, you can use the
"Get more rows in the current collection" button on the main toolbar.

e System administrators can override either the "Retrieve all" or "Use
specified max" setting with a system-wide maximum record cap that
is set in the Process Defaults form.

So, for example, if you set the system to display up to 500 items, but
the system administrator has set a system-wide maximum of 250, the
greatest number of items you can actually display is 250.

For more information on caps, see About Caps.

Language

From the drop-down list, you can select a language for the text in field
labels, button labels, menus, online help, and other parts of the user
interface. Then click Apply. When you click Apply, the Settings window
closes.

NOTE: Only those languages that are installed and available on your
system appear on this drop-down list.

Restore Defaults

Click this button to restore the system defaults for all settings.
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Runtime Layout Settings

Setting

Description/Comments/Procedures

Theme

Use the drop-down list to select a theme. Any user-created themes will
be shown here along with two that are provided with the application. The
two options that are provided are:

e Infor - This theme is the more updated theme. Menu items that used to
appear along the top of the program window now appear as sub-
menus under the System menu. Those sub-menu items are Form,
Edit, View, Window, and Help.

e Classic - This theme provides a look and feel like previous versions.
The main aspect is that the menu items Form, Edit, View, Window, and
Help appear at the top of the program window.

For more information about themes, see About Themes.

Edit Button

Click this button to open the Theme Editor.

Remember Explorer
Navigation Path

Select this check box for the system to remember your Explorer settings.
For more information about customizing the Explorer, see Customizing
the Explorer Buttons and Tree View.

Tabbed Form Layout

Select this check box to create tabs for each open form. Tabs for each
form appear at the top of the screen. If you open a linked or modal child
form from within another form, tabs for the child forms are tagged as
such. You can click and drag to reorder the tabs across the top of the
screen.

Design Time Settings

Design Time settings control aspects of how forms look and behave when you are in Design Mode.
You need these only if you are actively involved with creating or modifying forms in the system.

To make design time settings:

1 Select View > User Preferences.

2 Select the Design Time tab.

3 Adjust the settings to your preferences.

For details about the settings on this tab, see these tables:

e General Settings

e Script Editor Settings
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e Visual Studio Options

General Settings

Setting

Comments

Development Mode

This option controls how properties display in the Form and
Component property sheets:

¢ Normal mode - All properties are displayed; properties that do not
apply to the current object are read-only.

e Expert mode - Only properties that can be modified are displayed. The
name and value of variables are not displayed as in Normal mode.

Show Hidden
Components

When selected, hidden components on a form are displayed when you
are in design mode. When cleared, components remain hidden.

Enforce Strict
Locking of Forms

NOTE: This option applies only to those who have editing
permissions of Site Developer or vendor developer.

and Objects
When selected, this option causes the system to:
e Automatically populate the LockedBy field with your user ID for any
forms or global objects you create.
This prevents anyone else from making changes until you check the
form or object in.
e Warn you if you are trying to open a form or global object that
someone else has checked out.
e Prevent you from saving a form or global object that someone else has
checked out.
We recommend that this option be selected in any environment where
there are multiple developers designing and/or modifying forms.
Guidelines Enter the width and height values in "character units" that you want to

use for the grid.
These settings control:

e The size of the grid display that displays on forms while in Design
Mode, that is, the distance between the vertical and horizontal lines
that are used to display the grid.

e The locations to which components will be snapped if the Snap to grid
option is selected.
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Setting

Comments

WinStudio

WinStudio has a built-in script editor you can use to develop scripts. To
use this built-in script editor, select this option.

This script editor is a very basic editor. If you plan to do any extensive
form development and/or customization, we recommend that you use
one of the Visual Studio options.

Visual Studio 2010

If you have Microsoft Visual Studio 2010 installed on your computer and
you prefer to use that (instead of the built-in script editor) to develop
scripts, select this option.

NOTE: Infor neither provides nor installs Visual Studio 2010 as part of its
software. You can select this option only if you already have Visual
Studio 2010 installed on the same computer that you are using to
develop scripts.

Visual Studio
Express VB

Visual Studio
Express C#

Visual Studio Options

If you have Visual Studio 2010 Express installed on your computer and
you prefer to use that (instead of the built-in script editor) to develop
scripts, select one of these options. You can specify whether you prefer
to script in Visual Basic (VB) or C#.

Attaching the Visual Studio debugger to an external application such as
WinStudio.exe to initiate an interactive debugging is not supported in the
Visual Studio Express editions; it is supported for the full Standard,
Professional, or Team editions of Visual Studio.

When you open the EditWinStudioScript project in Visual Studio Express
from WinStudio, the script code class (ScriptClass.vb) is not
automatically opened. You must open the ScriptClass.vb file from the
Solution Explorer to edit the script.

NOTE: Infor neither provides nor installs Visual Studio 2010 Express as
part of its software. You can select this option only if you already have
Visual Studio 2010 Express installed on the same computer that you are
using to develop scripts.

Setting Comments
Visual Studio This option is enabled only if you select the Visual Studio 2010 option.
Modeless

In most cases, you should leave this check box selected. This minimizes
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the Edit Script in Visual Studio dialog box and makes it modeless; that
is, as soon as you click Save in the Visual Studio IDE, the changes to
your script are copied to the WinStudio cache and marked as modified.
In addition, you can exit WinStudio Design Mode and still access the
Visual Studio instance from Runtime Mode. For more information, see
Edit or Create a Script with Visual Studio.

Enable the modal interface (that is, clear this check box) if you want to
enforce modal dialog access to Visual Studio. In this case, you can only
edit scripts while you are in Design Mode.

Path to Visual Studio This option is enabled only if you select one of the Visual Studio
Express Application  Express options.

To instruct WinStudio where to find the Visual Studio Express application
executable (.exe) file, click Browse. If you have selected one of the
Visual Studio Express options, and you enter an incorrect path here or
leave this field blank, an error displays when you leave this field.

Diagnostics Settings

Diagnostics settings control how the system works when you are trying to diagnose problems and
bugs while designing and modifying forms. You need these only if you are actively involved with
creating and modifying forms in the system.

CAUTION: Configure diagnostics only if Infor Support has instructed you to do so or if you are
debugging a form under development. Use these settings to specify what information is recorded in
the session log.

To make diagnostics settings:

1 Select View > User Preferences.

2 Select the Diagnostics tab.

3 Adjust the settings to your preferences.

For information about the settings on this tab, see these tables:

e General
e Form
e Variable

e Call Details

e Component
e |DO Collections

e Interpreter
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General

Setting Description/Comments/Procedures

Enabled When selected, diagnostic information is recorded in the session log.
When cleared, diagnostic information is not recorded. This is the default option for
normal operations.
CAUTION: Be aware that enabling diagnostic information to be recorded can have
negative impacts on system performance, so you should enable this only in a
development environment.

System When selected, the system includes system information in the session log when

Information  diagnostic information is recorded. Such messages identify the current language
ID, the current string table, and other general settings in effect.
When cleared, this information is omitted.

Save to When selected, the system writes the diagnostic information directly to a file on

Disk your computer's hard drive. Middle tier messages are excluded even if they are
recorded in the session log. The system creates the file WinStudio.log and puts it
in the C:\Documents and Settings\login\Local Settings\Temp folder (where
login is a workstation login) and then within a generated folder that is randomly
named. It may be simpler to use the Windows search feature to find the
WinStudio.log document than to look through the folders manually.
EXAMPLE: C:\Documents and Settings\JohnQPublic\Local
Settings\Temp\1\Winstudio.log
To record diagnostic information only in the session log and not in a separate file,
clear this check box.
CAUTION: Selecting this option slows processing.

Security When selected, information about form-level and component-level permissions are
included in the log.
When cleared, security information is omitted from the log.

Form

Setting Comments

Initialization When selected, the system includes an entry in the diagnostic record each

time a form is opened, including information about the initialization
parameters.
Events When selected, the system includes an entry in the diagnostic record about

each event that is generated by the system.
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Variable
Setting Comments
Initialization When selected, each time a variable is created, the system includes

information about whether the variable is global or form-level, persistent or
temporary.

Value Changed

When selected, each time a the value of a variable changes, the system
includes information about the previous value and the new one.

Dependent When selected, the system includes information each time the dependents of

Notification a variable are refreshed because the value of the variable is changed.

Call Details

Setting Comments

Scripts When selected, the system includes diagnostic information about the
execution of scripts, including script parameters and return values.

IDO Methods When selected, the system includes diagnostic information about IDO

methods executed from event handlers or from validators, including method
parameters, return codes, and error messages.

Form server

When selected, the system includes diagnostic information about the form
server from with forms data was obtained.

Component

Setting Comments

Initialization When selected, the system includes information about components in the log.
When cleared, no information about components is recorded, even if other
options in this group are selected.

List building When selected, the system includes information about lists, when they are
created and when they are invalidated (so that the next access will cause
them to be recreated).

User When selected, the system records the interactions of all users' with the

interaction component, including messages about the following actions:

e Focus changes to the component or away from it.
e Selection of items from lists.
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e Clicking of a button on the component.

e Data being typed into a field.

e Inagrid, any changes to a record that result in it being marked as modified.
e The saving of a record in a grid prior to the entire collection being saved.

e Any other action that causes modified data to be processed.

CAUTION: Selecting this option generates a large number of entries in the
log and can negatively impact system performance.

To/From When selected, the system includes information about data moving to and
Source from the source or data binding for the component, including variables,
properties, or the building of derived values.
CAUTION: Selecting this option generates a large number of entries in the
log and can negatively impact system performance.
To/From When selected, the system includes information about data moving to and
Control from the control for the component.
CAUTION: Selecting this option generates a large number of entries in the
log and can negatively impact system performance.
Dependent When selected, the system includes information about a component's
Notification dependent being refreshed because the value of the component changed.

IDO Collections

Setting Comments

Initialization When selected, the system includes information about the parameters passed
to the IDO to retrieve the collection, the properties to include, and which
components are bound to the collection.

Commands When selected, the system includes information about commands and
standard operations.

Update When selected, the system includes an overview of the updating or saving of

Overview a collection.

Dependent When selected, the system includes information about notifications to

Notification dependents.

Load Overview

When selected, the system includes an overview of the process of loading the
collection.

Update Values

When selected, the system includes information each time a the value of a
property is updated in the collection, including individual requests from
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components or scripts as well as a record of each individual value sent during
a collection update.

CAUTION: Selecting this option generates a large number of entries in the
log and can negatively impact system performance.

Load Values When selected, the system includes information each time a property's value
is retrieved from the collection, including individual requests from components
or scripts as well as a record of each individual value retrieved during a
collection load.

CAUTION: Selecting this option generates a large number of entries in the
log and can negatively impact system performance.

Interpreter

Setting Comments

Overview When selected, the system includes information about strings before and
after they are interpreted.

Variables When selected, the system includes information about the detailed
substitutions of the V(), FV(), and FVN() keywords.

Properties When selected, the system includes information about the detailed
substitutions of the P() and FP() keywords.

Components When selected, the system includes information about the detailed
substitutions of the C() and FC() keywords.

Scripts When selected, the system includes information about the detailed
substitutions of the SCRIPTS keyword.

Others When selected, the system includes information about the detailed
substitutions of the CURDATE(), STRINGS(), and any other substitution
keywords.

Event System Settings

Use the Event System tab to make settings related to the workings of the Application Event System
(AES). Event System settings control various aspects of your interaction with the AES, including:

e What kinds of notifications, if any, you receive when a new message arrives in this application's
Inbox form

e How often you receive notifications of new messages
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e How unread messages display in the Inbox form
¢ What information WinStudio displays when you are editing event handlers in the AES

To make AES settings:

1 Select View > User Preferences.

2 Select the Event System tab.

3 Adjust the settings to your preferences.

This table lists and describes your options:

Setting Description/Comments/Procedures
Check for New From the drop-down list, select the time interval at which the system is
Messages Every to check your Inbox for new messages.

New messages

Play a Sound When selected, the system plays the specified .wav file to notify you of a
new message.

To select the sound, click the ellipsis (...) button. Then, use the Select
an Alert Sound dialog box to select the .wav file to use.

If you do not select a .wav file, the system plays a default .wav file.
To hear the selected .wav file, click Play.

NOTE: If you are using a remote desktop connection to log on to the
system, you cannot hear this sound when it plays. For this reason, you
should use this option only if you are logged in to the system locally.

Display an Icon in (Default option) When selected, this option causes the system to display
the Notification an envelope icon in the Windows taskbar notification area whenever
Area new messages are received. This icon displays only if you are logged in

to the system.

When this icon appears in the taskbar, you can double click it to open
the Inbox form and view your messages.

The system hides this icon again when you double click it to open the
Inbox form, or when you refresh the Inbox form to display all new

messages.
Display an Alert When selected, every time a new message arrives in your Inbox, the
with Message system displays an alert message in a "balloon" above the Windows
Count taskbar notifications area. This message lets you know both that you

have new messages and how many new messages you have received
since the last alert.

When you select this option, you can also use the Alert duration slider
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to control how long each alert message is displayed. This slider uses a
scale from 10 to 30 seconds, in 5-second increments.

Selecting this option also enables the Preview button. To see a sample
of the message that is displayed, click this button and watch the lower
right corner of your screen.

Inbox: Display unread messages using

Boldface Font

When selected, the system displays any unread messages in your
Inbox using a bold face font in the grid (top) view. This allows you to
easily distinguish read and unread messages.

Background Color

When selected, the system displays any unread messages against the
specified background color, as displayed in the color square to the right
of this option.

By default, the background color is the same as the Normal background
color (see Run Time Settings).

To select a different background color for unread messages, click inside
the color box. The system then displays a Color picker dialog box that
you can use to select the color you want.

Handler Editing

This option has to do with the display of metadata in the Event Actions
form and with the behavior of the Event Handler Diagram form. You
can choose to interact with these forms either as a Novice or as an
Expert.

For more information, see Handler Editing Options.

4 To see the effects of your settings on forms that are open, close the forms and reopen them.
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Using the Help

This system provides several ways for you to get help with a form, a field or other component on a
form, or procedures to accomplish various tasks. This system makes extensive use of context-
sensitive help, which allows you to easily get help when and where you need it, so you can get back
to the task at hand.

To get help on a form, with focus on the form, select Help > Current Form.
To get help with a field, button, menu, or other component of a form, do any of these:

¢ Right-click on the component and select Help.
e With focus on the component, select Help > Current Field.
e With focus on the component, press F1.

Field-level help is available on some, but not all, forms. In most cases where field-level help is not
available, there is a Related Topics link to a process topic that describes the fields.

To get general help or to browse the help, select Help > Contents and Index.

To search for a phrase, open the help and click the Search tab. Specify a term or phrase and press
Enter. To reduce the number of results, be as specific as possible. To search for an exact phrase,
enclose the phrase in quotation marks.

When you open more than one context-sensitive help topic during a session, the new help topic
either displays in the same tab or window, or it opens a new tab or window, according to the default
option you set for your browser.

To get background and technical information about the current form, with focus on the form, select
Help > About This Form.

You can also print help topics.

Printing Help Topics

You might find it helpful to print out certain Help topics to use as quick reference.
To print the current topic:

1 Display the topic you want to print.

2 Right-click in the topic contents pane and from the context menu select Print.

The system displays the Windows Print dialog box.
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3 If necessary, select the appropriate printer, and then click Print.
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About Forms, Fields, Records, and Collections

WinStudio is a database-oriented user interface. To get or submit information, you generally access
one or more tables in databases. The application uses fields and other components on forms to
present collections of data records.

You must understand these basic concepts:

e Forms
e Fields
e Records

e Collections

Forms

A form is the window through which you interact with information in a database. Looking up
information, entering new information, and generating reports are typical interactions. Each form is
devoted to a business task or to several related tasks.

For example, you can use an Attendance form to record and track employee work attendance
records. You can use this form, then, to view attendance information about a particular employee, to
get an idea of how many employees are using sick time, how many employees were absent on a
given day, and so on. This form would display and allow you to work with all data related to
employee attendance.

For more information about forms, see Working with Forms.

Fields

A field is an area on a form that displays a piece of information from the database. If the data already
exists and can be viewed, the field typically displays the information. Fields also allow you to enter
and save new data. Forms usually have a number of fields that all display related pieces of
information.

Our example Attendance form has fields that each display a different but related piece of
information:

e Employee (ID number)
o Employee name (not labeled)
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e Date

e Reason (code)

e Reason description (not labeled)
e Hours

e Paid

For more information about fields, see Working with Fields.

Records

A record is a group of related pieces of data or information. Each piece of information displays in a
separate field on the form. Taken together, they constitute one record.

In our example, the fields together display one record that contains information about a paid
absence of an employee: the employee's name and ID number, the date and reason for the
absence, and so on.

A form can display multiple records in a grid, and you can select the record you want to see from
that grid.

For more information about records, see Working with Records.

Collections
A group of related records is a collection.
Our example Absence collection is displayed, as with many forms, on the grid (left) side of the form.

With many forms, it is possible to view collections of all available records. But, in practice, you
typically work with a specific subset of records in a particular collection. Using our Attendance form,
you can query for attendance records over a period of time. For instance, you might want to review
all attendance records for the past month. Or you might want to review the attendance records of a
single employee for the past year. In these cases, you can perform a query that will retrieve as a
collection only those records you want to view.

For more information about collections, see Working with Collections.

Primary Collections and Subcollections

Most forms display only one collection. Some forms, however, display two collections, a primary
collection and a subcollection. A subcollection is associated with a particular record in the primary
collection. For example, if each record in the primary collection represents a work group at your
company, the subcollection records associated with each work group record might include the
employees who are members of that group.

When working with forms that present primary collections and subcollections, keep in mind that:

e Subcollections are often (though not always) presented as part of a multiview form. For more
information, see About Multiview Forms.
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e Usually the primary collection is in the grid (left) side of the form and the subcollection is in the
detail view (right) side.

e As you navigate from record to record in the primary collection, the system displays the records
in the subcollection associated with the current record in the primary collection.

As an example, the Users form contains both a primary collection and a subcollection. In this case,
the subcollection (on the Groups tab) shows the group memberships for the selected user record in
the primary collection. The group membership subcollection is different for each user record.

Working with Forms

Working with Forms

A form is a window through which you interact with information in a database. Looking up
information, entering new information, and generating reports are typical interactions. Each form is
devoted to a business task or to several related tasks. Nearly everything you do in WinStudio will
involve the use of one or more forms.

Types of Forms
The system uses these basic types of forms:

e Multiview forms

e Query forms

e Grid-only forms and grids

e Detail-only forms

e Report forms
e Utilities and activities

Finding Forms

Of course, to accomplish any work in the system, you must know how to locate and open the forms
you need. The system provides two basic ways to locate and open forms:
e Using Explorer (see Finding and Opening Forms Using the Explorer)

e Using the Select Form dialog box (see Finding and Opening Forms Using the Select Form
Dialog Box)

Navigating Through Forms

The system provides a number of options for navigating through forms as you work with them. For
more information, see Keyboard Navigation and Other Navigation Tips or Changing Focus in
Collections.
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Workspaces and Forms

As you work, you will usually find that there are a limited number of forms that you use regularly. In
many cases, these forms are interrelated. You can set up and use personal workspaces to have the
system open and automatically arrange these forms for you. For more information, see Using

Workspaces.

Form Types

Query Forms

About Query Forms

Most multiview forms have query forms associated with them. These query forms usually have the
same name as the associated multiview form, appended with Query. You can use these query
forms to help locate particular records that you are concerned with. You can then return the results
of your query to the associated multiview form automatically.

Query forms typically consist of the following components:

e The criteria selection box, where you set the criteria used to limit your search. This box contains
two tabs:

e The Primary Criteria tab is used for the most common search criteria. There are typically
from two to four fields on this tab. For more information, see Primary Criteria in Query Forms.

e The Additional Criteria tab is used mostly to refine and narrow the search. For more
information, see Additional Criteria in Query Forms.

e Action buttons - These buttons, located along the upper right side of the form, allow you to
perform various actions in your search. For more information about these buttons, see Buttons
on Query Forms.

o Results grid - This grid displays the results of your query in tabular format. You can use the
scroll bars to locate and select the particular record you are looking for.

For the basic procedure to perform a typical query, see Finding Records Using a Query Form.

Finding Records Using a Query Form

Most multiview forms have a query form associated with them. You can use these query forms to
select a collection of records and return the collection to the multiview form.

CAUTION: Records retrieved by a query form replace the current collection of records in the
multiview form. Be sure to save any changes you want to retain in the multiview form before you
retrieve records with a query form.

To perform a typical query using a query form and return the results to the associated multiview
form:

1 With a multiview form open, perform one of the following actions:

e Press CTRL+Q.
e From the Actions menu, select Filter > By Query.
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¢ Right-click on the form somewhere other than on a field, and then, from the context menu,
select Filter > By Query.

NOTE: On a form that is not associated with a query form, the By Query menu option is not
available.

2 (Optional) Use one or both fields on the Primary Criteria tab to set the primary search criteria.
For more information about setting primary search criteria, see Primary Criteria in Query Forms.

3 (Optional) Use the fields and buttons on the Additional Criteria tab to refine the search criteria
further. For more information about setting addition search criteria, see Additional Criteria in

Query Forms.

Click Refresh. The system returns all records that meet your search criteria.

4
5 (Optional) Repeat Steps 2 - 4 as desired to get the return results you need.
6 To return the results of your query to the parent multiview form, click OK.

7

When asked if you want to return the result to the mutliview form, click Yes.

For examples of queries, see Sample Queries.

Primary Criteria in Query Forms

On the Primary Criteria tab of a query form, you can specify query criteria for the principal fields on
the associated multiview form. Usually these fields represent only the two or three most commonly
searched criteria for the form. For example, in a form used to maintain information about customers,
primary fields might include customer identification number and customer name.

The same fields are also listed on the Additional Criteria tab. This means that query criteria for the
principal fields can be specified on either tab.

Primary criteria consist of an operator for the selected field on which you want to filter data and a
value for the field. By default, the comparison operator for all primary criteria is like, and the values
are empty. With these settings, all records are considered a match. The result set is the same as the
result set from executing Filter-in-Place when no values are entered in fields on the form.

Primary criteria are automatically joined by a Boolean AND. That is, records are retrieved from the
database only if they meet all the specified criteria.

To specify primary criteria for a query:
1 In a query form, select the Primary Criteria tab.
2 For afield on which you want to filter, from the drop-down list, select an operator.

For more information about operators, see Operators on Query Forms.

3 Enter a value for the field.
4 Remember that you can use wildcards in your search.

For more information, Using Wildcard Characters.

5 To find records that contain a null value in the field, you can also enter the Null keyword.

For more information, see Using the Null Keyword.
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6 To find records compared to the current date, you can use the CURDATE() keyword.

See Sample Queries for more information.

7 Alphabetic input is not case-sensitive.

8 To filter on more than one field, repeat steps 2 and 3.

9 To perform the query and return the results, click Refresh.
Example

Suppose that you own a company that deals primarily with bicycle retailers. You want to retrieve all
records that contain "bi" in the Name field, so that you will get a collection displaying all records that
contain either "bike" or "bicycle."

Notice that, in the figure below, the operator for the Name field is like, which is the default.

The value *bi* restricts the results to those records containing "bi" in the Name field. The wildcard
character (*) matches all other possible combinations of characters that come either before or after
the search value "bi". Because no value is specified for the Customer field, that field can contain
any value. As a result, the query might return records containing "Bicycle Center" and "Terry's Bike
Shop" in the Name field.

NOTE:

e The text that you enter here is not case-sensitive.

Additional Criteriain Query Forms

On the Additional Criteria tab of a query form, you can specify search criteria for any of the fields
on the associated multiview form.

NOTE: This tab includes the fields that are listed on the Primary Criteria tab. This means that you
are not obligated to specify primary criteria before doing a query.

One reason for using the Additional Criteria tab for the principal fields, rather than using the
Primary Criteria tab is if you want to do a Boolean OR search, rather than a Boolean AND search
on those fields. The Primary Criteria tab only allows AND searches.

Query Clauses

Query criteria are made up of query clauses. A query clause consists of a Boolean search delimiter,
a field name, an operator, and a value. For example, to retrieve records for vendors located in New
York, you would create a clause similar to the following:

AND State = 'NY'
where

e State is a field name on the multiview form in which vendors are defined in your system.
e =is an operator specifying that returned results must match the value exactly.
e NY is the value that you want the system to search for in the State field.

NOTE: The letter N might appear between the operator and the value in the clause. This N indicates
that the system is using Unicode (double-byte) character codes.
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Multiple clauses, if you use them, work sequentially. That is, the system searches using the first
defined clause, then applies the second clause to the returns, and then the third clause, and so forth.
This means that the order in which you define your clauses must be planned carefully, as order can
make a difference.

AND and OR (Boolean) Searches

You can create multiple clauses and join them by Boolean AND or OR filters. Clauses joined by AND
retrieve only those records that meet the criteria specified in all clauses. Clauses joined by OR
retrieve records that meet any one of the criteria.

The system adds the Boolean filter automatically when you define the query clause. If you select the
check box labeled OR instead of AND with previous clause, the clause is defined as an OR
clause. If that check box is cleared, the system defines the clause as an AND clause.

To specify additional criteria:

1 In aquery form, select the Additional Criteria tab.

2 From the first drop-down list box, select a field on which you want to filter.
3 Inthe second drop-down list box, select the operator you want to use.

For more information about the operators available, see Operators on Query Forms.

4 In the third field, enter a value that you want to use as the search criteria. Remember that:

e You can use the wildcard character to match unspecified characters.
e To find records containing a null value in the field, you can enter the Null keyword.

e To use the Null keyword, the operator must be = (equals). To find records in which the field
is not null, use the Null keyword with the <> (not equal) operator.

For more information about the Null keyword, see Using the Null Keyword.

e To find records compared to the current date, you can use the CURDATE() keyword. See
Sample Queries for more information.

e Alphabetic input is not case-sensitive.
5 Specify whether to join the current query clause with the previous clause by AND or OR:

e Touse OR, select the check box labeled OR instead of AND with previous clause.
e To use AND, clear the check box labeled OR instead of AND with previous clause.

o [f the current clause is the first clause you have defined for the query form, accept the
default, which is AND.

o If you specified any primary criteria, be sure to select AND or OR according to how you want
to join the current clause with the primary criteria.

6 Click Add. The system adds the clause to the list.
7 Repeat steps 2-6 for each additional clause.
To remove a clause from the list:

1 Inthe list of clauses, select the one you want to remove.
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2 Click Remove.

Operators on Query Forms

Query forms support the following comparison operators:

Operator Description

like Returns records containing a field value that matches the value you type using
one or more wildcard characters.

If you do not use a wildcard character, Like acts the same as = (equals).
This is the default operator for the Primary Criteria tab fields.

= Returns records containing a field value that matches exactly the value you type.
You cannot use wildcard characters with this operator.

(Equal)

> Returns records containing a field value greater than the value you enter. With
letters, > refers to alphabetical order from A to Z. This entry is not case-sensitive;

(Greater in other words, "King" is the same as "king", as far as the system is concerned.

than) You can use wildcard characters with this operator.

< Returns records containing a field value less than the value you enter. With letters,
< refers to alphabetical order from A to Z. This entry is not case-sensitive; in other

(Less words, "King" is the same as "king", as far as the system is concerned.

than) You can use wildcard characters with this operator.

<>orl= Returns records containing field values that do not match exactly the value you
enter.

(Not You cannot use wildcard characters with this operator.

equal)

Not like Returns records containing a field value that does not match the value you type

using one or more % wildcard characters.
If you do not use a wildcard character, Not like acts the same as <> or != (Not
equal).

Not like does not appear in the drop-down list of operators, but you can type Not
like in the operator field.

Buttons on Query Forms

Query forms have the following action buttons:
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Button

Description

OK

Click to return any search results that match the current criteria to the parent
multiview form and close the query form.

If you opened the query form to perform a form-level query, the result set is a
collection of records, which can be returned to the parent form. If you opened
the query form to find a value for a single field in a form, the result is a field
value in the currently selected record in the Results pane. This value can be
returned to the corresponding field in the parent form.

NOTES:

¢ When you click this button, if you have selected any results to return to the
parent form, the system prompts you for confirmation. If you want to return
the results to the parent form, click Yes. You should be aware, though,
that if you do this, the system will overwrite the previous collection on the
multiview form with the collection being returned from the query form.

¢ In aform-level query, records returned to the parent form match the
current criteria. These records may be different from records displayed in
the Results pane. The difference can occur when you specify criteria,
click Refresh to display the search results, and then change the criteria
without clicking Refresh to display the new results.

e This is typically the last button you click on the query form, as it returns
you to the parent multiview form. To get the results of your query, you
must first click Refresh.

Cancel

Closes the query form without returning any search results to the parent
multiview form.

Whether you opened the query form from a form or a field, no information is
returned to the parent form or field.

Clear

Clears any search criteria from the query form without closing it.

This can be useful if you make a mistake and want to start over without having
to close the query form.

Refresh

Searches the database using the current criteria and displays the selected
records in the Results grid.

Add

(Additional
Criteria tab

only)

Adds the criteria currently in the specification fields to the list of query clauses.

Criteria in the specification fields do not become part of the filter until you click
this button.
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Remove Removes the selected query clause from the list of clauses.

(Additional
Criteria tab

only)

Sample Queries

This topic presents sample queries that are typical of the kinds of queries you might need to do in
the performance of your responsibilities. These sample queries include:

e A wildcard query

e A range query

e A null query
e A guery that includes reference to the current date

Sample Wildcard Query

Suppose you work in Human Resources, and you need to access the employee records for all
employees in the Administration department (400) whose last names begin with letters in the last
half of the alphabet. Your query might work something like this:

1 Open the Employees form, from which you can access all employee personnel records.
2 On the toolbar, click the Filter button, which retrieves all employee records to this form.
3 Press CTRL+Q to display the Employees Query form.

4 On the Primary Criteria tab:

e With Last Name as the criteria, select > (Greater than) as the operator
e Specify M* in the adjacent value field.

5 Onthe Additional Criteria tab, specify this information in the three query criteria fields:

o From the first drop-down list, select Department.
e From the operator drop-down list, select = (Equals).
e From the adjacent value drop-down list, select 400, which is the Administration department.

6 Click Add.

7 Click Refresh. The system retrieves all records that meet the specified criteria and displays them

in the Results grid.
8 To return these records to the parent multiview form (Employees), click OK.
9 When the system prompts for confirmation, click Yes.

NOTE: When you click Yes, the system returns all retrieved records to the parent form, replacing

whatever was previously displayed in that form. You cannot pick and choose which records to return.
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Sample Range Query

Suppose you want to find all records for a particular vendor (ID number 9), relating to payments
made during the latter half of the month of September, 2011. This means that we want to query for a
set of records spanning a calendar range from September 16 to September 30, 2011.

You can use a query like this:

1
2

© oo N o

10
11

12
13

Open the A/P Payments form.

On the toolbar, click the Filter button, which retrieves all accounts payable (A/P) payment
records.

Press CTRL+Q.
On the A/P Payments Query form, Primary Criteria tab, for the Vendor criteria fields:

e Select = (Equals) as the operator.
¢ Inthe adjacent drop-down list, select the appropriate vendor ID, in this case, 9.

On the Additional Criteria tab, in the three query criteria fields:

e From the first drop-down list, select Check Date.
e From the operator drop-down list, select > (Greater than).
¢ From the adjacent value drop-down list, enter 09/15/2011.

Because there is no operator for "greater than or equal to" (>=), we use the day before the first
day for which we want records.

Click Add.

From the first drop-down list, select Check Date.

From the operator drop-down list, select < (Less than).
From the adjacent value drop-down list, enter 10/01/2011.

Because there is no operator for "less than or equal to" (<=), we use the day after the last day for
which we want records.

Click Add.
Click Refresh.

The system retrieves all records that meet the specified criteria and displays them in the Results
grid.

To return these records to the parent multiview form (A/P Payments), click OK.

When the system prompts for confirmation, click Yes.

NOTE: When you click Yes, the system returns all retrieved records to the parent form, replacing
whatever was previously displayed in that form. You cannot pick and choose which records to return.
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Sample Null Query

Suppose you want to identify all locations for your company that have no work centers associated
with them. You can use a query like this:

1 Open the Locations form.
2 Press CTRL+Q.
3 Onthe Additional Criteria tab, in the three query criteria fields:

e From the first drop-down list, select WC (for "Work Center").
o From the operator drop-down list, select = (Equals).
¢ In the adjacent value field, enter null.

4 Click Add.
5 Click Refresh.

The system retrieves all records that meet the specified criteria and displays them in the Results
grid.

6 To return these records to the parent multiview form (Locations), click OK.
7 When the system prompts for confirmation, click Yes.
NOTE: When you click Yes, the system returns all retrieved records to the parent form, replacing

whatever was previously displayed in that form. You cannot pick and choose which records to return.

Sample Query Using Current Date

Suppose you want to find all jobs with a start date in the past week. From the Job Orders form, use a
guery that includes the CURDATE keyword, like this:

Start < CURDATE(1)
AND Start > CURDATE(-8)

CURDATE() with no parameters returns just the date with no time component. CURDATE(30)
represents the current date plus 30 days, and CURDATE(-30) represents 30 days in the past.

Grid-only Forms and Grids

The most common form type or part of a form used to display records and collections of records is a
grid, which displays a collection of records using a tabular (row-column) format. A grid can constitute
the sole content of a form, in which case it is called a grid form. Grids can also be used in other
forms, most commonly multiview forms.

For information about navigating through a grid, see Keyboard Navigation and Other Navigation
Tips.

Grid-only Forms
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A grid-only form is a form in which all data is displayed and modified using a grid, similar to a
spreadsheet or table display.

A grid-only form displays IDO collection data using a single grid. Each row in a grid represents one
record in the collection.

Grid-only forms are typically used to define and display related groups of values, settings,
parameters, or codes. The collections they display are usually small with a limited amount of data.

Some fields (columns) contain display-only data, usually indicated by shaded cells. Other columns
can be used to enter and modify related data. Usually, you can enter the values you want directly in
editable fields, but some fields require you to select values from a drop-down list.

Grids in Other Forms

Forms that are not purely grid forms can also make use of grids to display and manipulate data.

Grids in Multiview Forms

A multiview form uses a grid in one view of the form, usually the view on the left of the splitter bar.

The grid displayed in a mutiview form works similar to a grid form. For more information about
multiview forms, see About Multiview Forms.

Grids in Query Forms

Query forms make use of grids to display the records returned from a query using that form. These
grids display in the bottom portion of the query form and are labeled Results.

For more information about Results grids in query forms, see About Query Forms.

Grids in Report, Activity, and Utility Forms

Some report, activity, and utility forms retrieve records and allow you to preview and select what
records will be processed, using a grid.

For specific information about forms that use grids, see the online help for those forms.

NOTE: Many of these forms include a Select option (check box) for each record that is returned
for preview. When you select a record using this option, the system displays an (m) in the row
label for that record. This indicates that the record has been selected but not yet processed.

On such forms, when you select Commit and click Process, the system processes all (and only)
selected records, that is, all records with the Select option selected and the (m) indicator in the
row label. If all selected records process successfully, then typically the system refreshes the
form. Normally, when the form is refreshed, all selected records, having already been processed,
no longer display.

In a case where the system is set to process records individually, there might occur an error
midway through processing of records. In this case, typically, the records that were processed
before the error occurred are already committed in the database. The collection is not refreshed,
so they still appear in the grid; yet the (m) indicator is now gone. If you then attempt again to
process the records, these records are not processed again.
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In a case where the system is set to process all records as a batch, and there occurs an error,
the system does not complete the processing of any records. In this case, the system returns
all records to the status they had before processing was attempted.

Report Forms

Report forms are used primarily to generate reports for a wide range of uses. In some cases, report
forms are also used to generate forms or other documents required to complete some business task.

Many report forms allow you to generate a preview before actually printing or sending the generated
report file.

For more information about reports and report forms, see Reports Overview or the online help for the
specific report form you are interested in.

About Mobile Forms

Mobile forms end in the suffix .mobi and are intended to be displayed on mobile devices. They can
use special toolbars and other design features. For more information, see the related topics.

Working with Tile Forms

To display the left pane information on a multiview form in tiles instead of in a grid, an appropriate
tile form is defined and then displayed in the multiview form. For example, this multiview form
displays tiles:

E Customers

1 -
Coordinated Bicycles Custamer:
Credit Limit 100,000.00
Posted Balance: 0.00 Address [1]
On Order Balance: 6,588.35 Address [2])
2 =
. T Address [3]:
Price Brothers Dept Store Bl
Credit Limit 3,000,000.00 Address [4]
Posted Balance: 15,000.00 e |Elkeh
©On Order Balance: 64,354.50 City: art
3 Pastal/ZIF: 46514 County: |Elkhart
Claymore Bicycles Country: |US4
Credit Limit 200,000.00
Posted Balance: 2,500.00 Corporate Cust:
On Order Balance: 0.00
4 CRM Interan
Gilmore Two Wheelers Ship To Credit Contacts Codes Payme
Credit Limit 750,000.00
Posted Balance: 0.00
On Order Balance: 6,133.66 Default Ship To: | 0 lz‘ Ship t

The key fields that display in the tiles in the left pane are set up on the corresponding tile form. In
this example, the corresponding tile form looks like this:

] E Customers Tile EI@
1
Coordinated Bicycles
Credit Limit: 100,000.00
Posted Balance: 0.00
On Order Balance: 6,588.35
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Tile forms are not intended to be displayed standalone.

Utilities and Activities Forms

Utilities and activities are specialized forms that are usually associated with other, more basic forms.
They typically process multiple records in one operation, performing tasks such as purging records,
updating values, posting transactions, or changing the status of records.

For instance, suppose you need to change the status of a range of job operations to Complete. You
could use a Complete Job Operations utility to change them all at one pass, rather than having to
change each job operation separately.

Utilities and activities forms typically present pairs of fields and other options that allow you to define
ranges of and criteria for records to be processed.

Previewing and Selecting Records

Many (though not all) utilities and activities forms include a grid section, in which you can preview
records before processing. Often, these forms include a Select option (check box) for each record
that is returned for preview. When you select a record using this option, the system displays an (m)
in the row label for that record. This indicates that the record has been selected but not yet
processed.

On such forms, when you select Commit and click Process, the system processes all (and only)
selected records, that is, all records with the Select option selected and the (m) indicator in the row
label. If all selected records process successfully, then typically the system refreshes the form.
Normally, when the form is refreshed, all selected records, having already been processed, no
longer display.

In a case where the system is set to process records individually, there might occur an error midway
through processing of records. In this case, typically, the records that were processed before the
error occurred are already committed in the database. The collection is not refreshed, so they still
appear in the grid; yet the (m) indicator is now gone. If you then attempt again to process the
records, these records are not processed again.

In a case where the system is set to process all records as a batch, and there occurs an error, the
system does not complete the processing of any records. In this case, the system returns all records
to the status they had before processing was attempted.

Finding and Opening Forms

About Finding and Opening Forms
There are two ways to find and open forms:

e To locate and open a form based on its function, if you do not know the name of the form, you
can use the Explorer. For more information, see Finding and Opening Forms Using the Explorer.

¢ If you know the name or caption used for the form, you might find it easier and quicker to use the
Select Form dialog box. For more information, see Finding and Opening Forms Using the Select
Form Dialog Box.

47



Infor Mongoose Basic Concepts User Guide

You can open more than one form at a time. Each form opens in a separate window that can be
resized, minimized, or maximized. You can also use the Window menu to position opened forms in
a cascade or tile arrangement.

If there are forms that you use regularly, you can arrange these and save them as workspaces, so
that it is easier to find, open, and arrange these forms. You can also put them in your My Folders
directory, where you can find them easily and even set them to load or open automatically when you
log in. For more information on these options, see Using Workspaces or Customizing 'My Folders'.

Finding and Opening Forms Using the Explorer

You can use the Explorer to find and open forms. The Explorer is most useful when you do not know
the name of the form, but you know how the form is used, or who uses the form.

In the Explorer, you can look up forms by application module, or you can open the All Forms folder
and type the first few letters of the form name.

To find and open a form using the Explorer:

1 Inthe Explorer window, expand the Master Explorer or another folder to display the list of
forms that contains the form you want.

To see the complete list of forms, expand the All Forms folder.
2 Locate the form you want to open.
3 To quickly locate a form name in a long list of names:

a Click any form in the list.

b Type the first few letters of the form you want to find. Explorer selects the first form name
that starts with the letters you typed.

¢ Use the down arrow or scroll wheel to refine your search.

4 Double-click the name for the form you want.

Finding and Opening Forms Using the Select Form Dialog Box

If you know the name or caption of a form you need, one of the quickest and easiest ways to find
and open it is by use of the Select Form dialog box. But even if you do not know the exact name,
this is a powerful option, because of the filtering capabilities in the Select Form dialog box.

To open a form using the Select Form dialog box:
1 From the Form menu, select Open.

The system displays a list of all the forms on your system. By default, forms are listed by caption
(the title that displays when the form is open).

To toggle the list so that forms are listed by the internal form name, select the check box labeled
Select by Name Instead of Caption.

2 To restrict the list by filtering:

¢ Inthe All Containing field, enter the portion of the caption or name that you know.
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e To have the system match the capitalization as you typed it, select the check box labeled
Case-sensitive. Otherwise, clear the check box.

o Click Filter.
The system displays a list of all forms that have captions or names matching your criteria.
3 Inthe list, select the form you want.

4 Click OK.

Using Workspaces

Using Workspaces

After you have worked with the system for awhile, you will probably find that there is a certain set of
forms that you work with frequently (if not daily), and that you like to use in a particular arrangement
in your work area.

The system provides a way to save and open such a configuration of forms easily, so you do not
have to redo it every time you use the system. In the system, this configuration of forms is called a
workspace.

Once you have set up and saved a workspace, you can either open it manually through the Form
menu, open it through a shortcut in the Explorer, or set the system to open it automatically when you
log in. You can also later modify the arrangement of the forms, and even add or delete forms from
the workspace. And, should you decide you no longer need it, you can delete a workspace.

For more information, see the following subtopics:

e Setting Up and Saving Workspaces

e Opening Workspaces
e Creating a Workspace Shortcut
e Changing the Forms in Workspaces

e Deleting Workspaces

Setting Up and Saving Workspaces

A workspace is a configuration of forms that open together. If you use a group of forms often, you
can set up a workspace that lets you open all the forms with one command, with the size and
position of the forms preset.

To set up and save a workspace:

1 Open each form that you want to include in the group and then adjust the size and position of
each form to the configuration you want. Here are some tips:
e Toremove the Explorer window from the group, minimize it.
e To move a form, drag the title bar.
e To change the form's size, drag the borders.
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e To arrange the forms as tiled or cascaded windows, use the Window menu.
2 From the Form menu, select Workspaces.
3 Inthe Workspaces dialog box, click New.

4 In the Name field of the Specify a Name for the New Workspace dialog box, type the name of
the workspace.

5 Click OK.
6 Click Set from Current Forms.

7 Click Done.

Opening Workspaces
Once saved, there are three possible ways to open workspaces. You can:

o Open the workspace manually through the Form menu.
e Open a workspace shortcut in the Explorer.
¢ Have the system open the workspace automatically when you log in.

NOTE: Before you can open a workspace, you must have first saved it. For more information, and
the procedure, see Setting Up and Saving Workspaces.

To open a workspace manually:

1 From the Form menu, select Workspaces.
2 Select the name of a saved workspace.

3 Click Exit and Open.

To open a workspace from a shortcut:

1 Go to the folder in the Explorer where the shortcut is saved. (See Creating a Workspace
Shortcut for instructions to save the shortcut.)

2 Double-click on the shortcut.
To have a workspace open automatically when you log in to the system:
1 Create a shortcut to WinStudio.

For information and instructions to create a shortcut, see the documentation for your operating
system.

2 Add a command-line parameter to specify a workspace:

¢ Right-click the shortcut you just created.
e From the popup context menu, select Properties.
e Inthe Target field, after the base target definition, add the following:

-wWorkspaceName

where:
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e -w is the command option.

e WorkspaceName is the name of the workspace you want to open automatically when you
log in.

NOTES:

e There is no space between the -w command and the name of the workspace.

o [f there are any spaces in the name of the workspace, you must enclose the workspace name
in quotation marks, as in the following example:

-w"My Workspace"

EXAMPLE: The following is a typical command line in a shortcut:

"C:\Program Files\Acme\WinStudio.exe" -wMyWorkspace

When you use the shortcut to access the system, the workspace opens automatically.

NOTE: The workspace opens automatically only when you use this shortcut to open WinStudio. This
means, among other things, that you can use different shortcuts to open different workspaces when
you log in.

Creating a Workspace Shortcut
To create a workspace shortcut:

1 Set up and save the workspace.

2 Inthe Explorer, right-click on a folder and select New Workspace Shortcut. This option is
enabled when you have read and write permissions for the folder.

3 Select a workspace from the list of workspaces you have created and click OK.

4 To change the name or description of the workspace shortcut, right-click on the new shortcut and
select Properties.

To use the shortcut, double-click on it. The forms included in the workspace open.

Changing the Forms in Workspaces

After you set up and save a workspace, you can add forms to it, delete forms from it, and adjust the
size and position of the forms.

To change the forms in a workspace:

1 Open an existing saved workspace as described in Opening Workspaces.

2 Adjust the forms in the workspace as needed:

o To delete a form from the workspace, close the form.
e To add a form to the workspace, open the form.
¢ Adjust the size and position of each form.

3 From the Form menu, select Workspaces.
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4 Select the name of the workspace you are changing.
5 Click Set from Current Forms.

6 Click Done.

Deleting Workspaces

To delete a workspace:

1 From the Form menu, select Workspaces.

2 Click the name of the workspace you want to delete.
3 Click Delete.

4 Click Done.

Working with Collections

Working with Collections

A collection is a set of related records. The records that the system retrieves are almost always
related by the form you are using. Quite often, they are further limited to records that meet certain
search criteria you can set by using filters.

Retrieving Collections

A large part of the work you do in this system probably involves locating the right records you need
to work with. The system provides several means of helping you retrieve just the right collections you
need. For more information, see Retrieving Collections.

Processing Collections

Once you have the collection of records that you need, you can process them in a variety of ways,
including (but not limited to):

e Sorting collections

e Previewing collections before printing them
e Printing collections

e Exporting collections to external files

e Copying collections to or from a spreadsheet

e Create and format graphs based on the collection
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Retrieving Collections

Retrieving Collections

A large part of the work you do in this system probably involves locating the right records you need
to work with. The system provides at least two ways of helping you retrieve just the right collections
you need:

e To return records that match specified criteria in one or more fields, use Filter-in-Place.

For more information, see Finding Records with Filter-in-Place.

e To specify search criteria and return selected records to a parent multiview form, use query
forms.

For more information, see Finding Records Using a Query Form.

In performing these searches, you can usually use filters, wildcard characters, and specify records to
return if a certain field is empty (null). For more information, see Understanding Filters, Using
Wildcard Characters, or Using the Null Keyword.

You can also limit or expand the number of records that a particular search can return. For more
information, see About Caps.

Finding Records with Filter-in-Place

When you activate Filter-in-Place, any collection currently associated with the form is cleared and
fields on the form become blank. You can then specify filter criteria in one or more fields and retrieve
a collection of records that meet those criteria.

If a previous search has already been done, any fields that were used as search criteria can still
have the search criteria in them. To clear the form of all search criteria, press F5.

To find records with Filter-in-Place:
1 Open a form that is used to retrieve records.
2 Activate Filter-in-Place mode. From the Actions menu, select Filter > Begin in Place.

3 Enter a value in one or more fields to specify criteria for the records you want to retrieve. For tips
on specifying filter criteria, see Filter Options (below).

4 Perform Filter-in-Place. From the Actions menu, select Filter > Execute in Place.

The system displays all available records that match the filter criteria you designated. The
number of records retrieved is limited to the current cap on data records. For more information,

see About Caps.

5 (Optional) To view the next set of records (beyond the record cap), click the "Get more rows in
the current collection” button.

If no records meet the criteria, the system automatically places the form in "new" mode. You can
create a new record (as you would after selecting New on the Actions menu), or you can repeat this
procedure with different filter criteria. If you repeat the procedure, your previous filter criteria are
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initially specified in the fields. You can adjust them, or you can remove all of them. To remove all of
them, on the Actions menu, point to Filter, and then click Clear in Place.

Filter Options

If you leave all fields blank, the collection is unfiltered, and the system retrieves all records up to the
current cap on data records. This is often undesirable, so the system provides several means to filter
and thus limit the return results for a search:

e You can use wildcards in filter criteria as you would in a query form. The default wildcard is *. For
more information, see Using Wildcard Characters.

e You can use operators such as > (greater than), < (less than), and <> (not equal to) to augment
your filter criteria. For more information, see Operators on Query Forms.

NOTE: Unlike query forms, Filter-in-Place does not support the logical operators AND and OR. If
you need to specify multiple criteria for one field or perform Boolean searches, use the Additional
Criteria tab of the query form associated with your form, instead of Filter-in-Place. Also, Validators
do not run in Filter-In-Place mode.

e To find records that are blank (contain null values) in specific fields, you can use the null
keyword. For more information, see Using the Null Keyword.

o To retrieve filtered criteria values in certain drop-down list fields, you can use the Find command
on the right-click menu. For more information, see Finding a Specific Value in a Drop-Down List.

NOTES: To refine your search, you can use as many fields as necessary. For example, you
could:

o Specify all the customers in a particular set of zip codes, by entering 41* in a Postal Code
field.

o Further specify those customers who are past due on their payments by specifying "not null"
(<>null) in a Past due field.

e Even further specify those customers who are more than $5000 in arrears, by entering >4999
in a Past due amount field.

The results of this search would return the records of all customers who have a postal code
beginning with the numbers 41, who are $5000 or more past due on their accounts.

Finding Records Using a Query Form

Most multiview forms have a query form associated with them. You can use these query forms to
select a collection of records and return the collection to the multiview form.

CAUTION: Records retrieved by a query form replace the current collection of records in the
multiview form. Be sure to save any changes you want to retain in the multiview form before you
retrieve records with a query form.

To perform a typical query using a query form and return the results to the associated multiview
form:

1 With a multiview form open, perform one of the following actions:

e Press CTRL+Q.

54



About Forms, Fields, Records, and Collections

o From the Actions menu, select Filter > By Query.
¢ Right-click on the form somewhere other than on a field, and then, from the context menu,
select Filter > By Query.

NOTE: On a form that is not associated with a query form, the By Query menu option is not
available.

2 (Optional) Use one or both fields on the Primary Criteria tab to set the primary search criteria.
For more information about setting primary search criteria, see Primary Criteria in Query Forms.

3 (Optional) Use the fields and buttons on the Additional Criteria tab to refine the search criteria
further. For more information about setting addition search criteria, see Additional Criteria in

Query Forms.

Click Refresh. The system returns all records that meet your search criteria.

4
5 (Optional) Repeat Steps 2 - 4 as desired to get the return results you need.
6 To return the results of your query to the parent multiview form, click OK.

7

When asked if you want to return the result to the mutliview form, click Yes.

For examples of queries, see Sample Queries.

Using the Null Keyword

You can use the null keyword to search for records that contain blank fields with null values. In form
fields, a null value appears as an empty field in which no value has been specified.

You can use the null keyword in:

e Filter-in-Place mode
e Query form searches
e Saved filters

The null keyword cannot be used for searches of field values in a collection (Edit > Find Value in
Collection).

To do a null keyword search:

¢ In Filter-in-Place mode, enter null in any field in which you can type characters.

¢ In query forms, you can use the null keyword in any of the primary criteria or additional criteria
fields that use the = (equal) or <> (not equal) operator.

NOTES:

e To find records where a particular field is not blank (null), enter <>null

e The null keyword is not case-sensitive. This means that it does not matter whether you enter it
in all lower-case letters, all upper-case letters, or any combination of both lower- and upper-
case letters.

e To perform a search in which a field might contain, in whole or in part, the word "null," enclose
it in asterisks (*null*).
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Using Wildcard Characters

When you search for information, you can use the wildcard character to find items that contain your
specified sequence of characters and that may contain additional, unspecified characters.

By default, the wildcard character is an asterisk (*), but you can change it. You would especially
want to do this if you want to use the asterisk as an actual data character in fields.

You can use wildcard characters when you:

e Search for values for fields.
e Use filters and Filter-in-Place.
e Use query forms.

NOTE: Not all fields support the use of the wildcard character as might be expected. This is
especially true of fields that automatically expand a field to a required number of characters. This
functionality is commonly seen in order and ID number fields. In these cases, you might have to
place the wildcard both before and after your search characters.

How It Works

The wildcard behaves slightly differently, depending on the context in which you are using it.

In text searches

In a text search, the wildcard represents zero or more possible missing alphanumeric characters.

EXAMPLES:

e Using the default wildcard (*), a search using A* as the search string returns all items that begin
with the letter A.

Note that text wildcard searches are not case-sensitive, so this search would return all items
beginning with the letter A, for example, Anthony and automobile.

e Searching for *qui* matches all items that contain the letters qui. So, items that would be
returned could include Quigley and requisite.

In date fields

In a date search, the wildcard character matches the month, day of the month, or year.

EXAMPLES: In a system using the short date format M/d/yyyy (month/day/year):

e The search term 12/*/2008 returns records for all dates in December, 2008.

e The search term */*/2008 returns records for all dates in the year 2008.

e The search term 12/31/* returns records for December 31 in all years.

NOTE: The wildcard character stands for the entire specification for a month, a day, or a year; you

cannot use the wildcard in a combination such as 200* to return all years from 2000 to 2009 or in a
day specification such as 2* to return all days of a month from 20 to 29.
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Changing the Wildcard Character

If you want to enter the asterisk as actual data in a field, you must change the wildcard character.

To change the wildcard character

1 From the View menu, select Settings.

2 Onthe Run Time tab, in the Behavior group, the Wildcard character field, enter the new
character you want to use as the wildcard character.

It is best to use a character that you are not likely ever to need in a data field. Good possible
candidates include the tilde character (~), the circumflex character (*), and the grave accent
character ().

Understanding Filters

Understanding Filters

Before you can work with a record or a collection, you must retrieve it from the database and display
it in a form. Specifications that determine which records are retrieved are referred to as filter criteria.

The system provides several different ways for you to use filter criteria to help locate only those
records and collections you actually need.

e When you open a form and records display automatically, you see the results of a filter that has
been permanently attached to the form so that it selects certain records whenever the form is
opened.

e When you use Filter-in-Place to search for records, you create a temporary filter by entering search
criteria in selected fields. You cannot save the filter criteria used in Filter-in-Place mode.

e When you use a guery form to search for records, you create a filter by entering criteria in the
guery form to identify the records you want to retrieve.

e [f this is a search you perform often using the same search criteria, you can save the criteria
entered on a query form and create your own saved filter. YOu can later use this saved filter
without having to re-enter all the search criteria each time.

e From a query form, you can also copy or delete filters that you have saved. Copying a filter allows
you to modify and resave it without having to start from scratch.

¢ From the Row Authorizations form, you can set filters on IDOs so that users can only view
certain data, based on the user ID under which they log in. For example, you can create a filter
so that salesperson users can only view their opportunities and not those of other salespeople.
Or you can create a filter so that your customers who log into this application through a portal
can see only information about their orders.

To find out which filter is currently used in a form, display the form and then, from the Help menu,
select About This Form.
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Creating and Saving Filters

If you frequently use the same search criteria to retrieve a collection of records, you can create and
save a filter that specifies the criteria. You can then use the filter to retrieve the collection without
having to respecify the criteria each time.

NOTE: You can save a search filter only from a query form.

To create and save a filter:

1 Open the form that you frequently use for a query.

If the form is in Filter-in-Place mode, press F3 to cancel the mode or F4 to execute the filter.
From the Actions menu, select Filter > By Query.

In the query form, enter your primary criteria and additional criteria.

From the Actions menu, select Filter > Save.
Enter a name for the filter.

Click OK.
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You can also create a filter by copying an existing filter, editing it, and then saving it with a new
name.

Using a Saved Filter

Once saved, you can easily use a search filter to perform a filter search any time you need to.
To use a saved filter:

1 Open the form for which you saved the search filter.

If the form is in Filter-in-Place mode, press F3 to cancel the mode or F4 to execute the filter.
From the Actions menu, select Filter > Apply Saved Filter.

Select the filter you want to apply.

Click OK.
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In the query form, click Refresh.

Copying and Editing Filters

You can edit a saved filter. You can also create a new filter by opening an existing one, editing it,
and saving it with a new name.

To edit a filter:

1 Open a query form.

2 From the Actions menu, select Filter > Open.

3 From the list of filters, select a filter, and then click OK.
4

Edit the search criteria as required.
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5 From the Actions menu, select Filter > Save.
6 Do one of these:

e To save the edited filter, click OK. This action overwrites the existing saved filter with the
changes.

e To create a new filter, including any edited criteria, type a new Name for the filter, and then
click OK.

Deleting Filters

At this time, you cannot delete a saved filter.

About Caps

About Caps

The maximum number of records allowed in a collection is restricted to a numerical cap. The
maximum number of items in drop-down lists is similarly capped. The default cap on both records
and list items is 200, but under certain conditions, these caps can be overridden (see Cap
Overrides).

Caps are designed to maintain the performance of your local system and of the database server.
Because data retrieved from the server resides on your local system in a collection, an excessive
number of records or list items can degrade the performance of the system. Retrieval of a large
number of records or list items can put unnecessary demands on the database server as well.

Caps and Their Use in Forms

The default caps are suitable for most data-entry tasks and information-search tasks. Still, you
should be aware of options for dealing with the size of collections and lists. For more information,
see Caps on Collections and Caps on Drop-down List Items.

Caps When Exporting Collections

When exporting a collection of records to an external file, you usually want no limit on the number of
records. Note that it is not necessary to reset the cap on collections in this case. Instead, select the
Unlimited query option when you export a collection.

Caps When Processing Records

When the system processes records (for example, during posting) it ignores any cap you have set.
All records that meet the criteria are processed. However, a record cap could still affect how many
returned records display on the form, if the process returns a result set.

Cap Overrides

The default cap limits can be overridden in a couple ways:
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e System administrators can use the WinStudio Max Record Cap process default to set the
record cap to a system-wide maximum number (see Default Name, Process Defaults).

¢ Individual users can set the caps to their own maximum numbers or to retrieve all available
records.

This is accomplished on the Runtime Behaviors tab of the User Preferences dialog box.

NOTES:

e The WinStudio Max Record Cap process default overrides the user's preference setting.

¢ [f the system administrator has enabled the Disable record cap override save process
default (which is enabled by default), user preferences carry over from one session to the
next. If the system administrator has disabled the Disable record cap override save
process default, then any user preference settings last only as long as the user's current
session. When the user signs off, the record caps return to the system defaults.

Caps on Collections

Caps on Collections

When retrieving records for a collection, the system uses a cap to limit the number of records that
can be returned. You should consider this cap when you retrieve a collection for which the size might
exceed the cap.

Finding the Current Cap on Collections

If you know you need to retrieve a large number of records for a collection, you can find out whether
the current cap will allow you to display that number of records. For more information and the
procedure, see Viewing the Current Cap on Collections.

Identifying When You Have Reached the Cap

Knowing whether you have reached the cap on records is fairly straightforward: The number of
records in a collection shows in the status bar in the lower-left corner of the application window.

To determine whether a collection contains the maximum number of records allowed, compare the
number of records retrieved (the second number) with the current cap on data records.

The "Go to the last object..." button navigates to the last record displayed, not necessarily the last
actual record in the database. You can use this to help determine when a collection contains the
maximum number of records allowed but not all potential records that match your filter criteria.

The "Get more rows in the current collection" button also provides a visual cue as to whether there
are more records available. If the double arrows are blue, then there are more records available.

Retrieving Additional Records

If you have a collection that does not display all the records you need, try replacing the current
collection with a collection filtered using more specific criteria. You can:

e Do a more focused Filter-in-Place query.
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e Use the "Get more rows in the current collection” button to retrieve and display the next set of
records.

e Use the associated guery form to perform a more refined query.
In most cases, you should be able to get the collection you are looking for by one of these methods.

Only if these methods do not return the collection you need in full should you increase the cap on
records.

Viewing the Current Cap on Collections

If you suspect that the number of records the system is retrieving for a collection is not what it needs
to be, you can view the current cap being used, to find out what it currently is.

To view the current cap on collections:

1 From the View menu, select Settings.

2 Locate the Caps > Data records group box.

3 The option that is selected shows the current cap on data records in collections:

NOTE: System administrators can override either the "Retrieve all" or "Use specified max"

setting with a system-wide maximum record cap that is set in the Process Defaults form. So, for

example, if you set the system to display up to 500 items, but the system administrator has set a

system-wide maximum of 250, the greatest number of items you can actually display is 250.

e Use default - When selected, the system uses the default cap, which is 200 records.

o Retrieve all - When selected, the system retrieves all records that meet the search criteria.

e Use specified max - When selected, the number in the box is your current cap on records. If
the Use Default option is selected, this field displays -1.

4 Click Cancel.

Changing the Cap on Collections

If you cannot retrieve all the records you need to accomplish a task, it is possible to reset the default
cap so that the system retrieves the number of records you need.

NOTES:
o Rather than having to reset the cap for collections, you can use the "Get more rows in the
current collection” button on the main toolbar.

e System administrators can override either the "Retrieve all" or "Use specified max" setting
with a system-wide maximum record cap. This record cap is set with the WinStudio Max
Record Cap process default, which is set on the Process Defaults form.

So, for example, if you set the system to display up to 500 items, but the system administrator
has set a system-wide maximum of 250, the greatest number of items you can actually display
is 250.

To change the cap on records in a collection:

1 From the View menu, select Settings.
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2 Locate the Caps > Data records group box.
3 Select the option you want to specify the new cap:

e Use default - The system uses the system default cap, usually 200 records.
o Retrieve all - The system retrieves all records that meet the specified search criteria.

CAUTION: Consider carefully before selecting this option. Unlimited retrieval of a collection can
degrade system performance.

e Use specified max - In the field to the right of this option, enter the maximum number of
records you want to be able to retrieve.

Note that transferring a large number of records to your system can degrade performance.
If the Use default option is selected, the value -1 appears in this field.
4 Click OK.

5 To refresh the collection in the current form, press F5.

NOTE: The cap you designate applies to all collections in all forms.

Caps on Drop-down List Iltems

Caps on Drop-Down List Items

Certain drop-down lists, particularly business-data list boxes, have caps on the number of list items
they can display.

Finding the Current Cap on Drop-down List Items

If you know you need to display a large number of items in a drop-down list, you can find out
whether the current cap will allow you to display that number of items. For more information and the
procedure, see Viewing the Current Cap on Drop-down List Items.

Identifying When You Have Reached the Cap

Knowing whether you have reached the cap on list items is more difficult than with collections. The
following tips might help:

o Alist has probably reached the cap if it ends arbitrarily, for example, in the middle of the
alphabet in an alphabetically sorted list.

o Alist has probably reached the cap if it does not contain an item that you believe it should
contain.

Retrieving Additional List Items

If you have a drop-down list that does not display all the records you need to use, you can:

o Replace the current list with a filtered list whose items match your search criteria. For more
information and the procedure, see Filtering a Drop-down List.
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e Use the Find feature, which is built into the drop-down list box. You can access this feature by
right-clicking on the field and then selecting Find. For more information and the procedure, see
Finding a Specific Value in a Drop-down List.

In most cases, you should be able to get the item you are looking for by one of these methods. Only
if these methods do not return the list you need in full should you increase the cap on list items.

Viewing the Current Cap on Drop-Down List Items

If you suspect that the number of items the system is displaying in a drop-down list is not what it
needs to be, you can view the current cap being used, to find out what it currently is.

To view the current cap on drop-down list items:

1 From the View menu, select Settings.

2 Locate the Caps > Drop-downs group box.

3 The option that is selected shows the current cap on list items in drop-down list boxes:

NOTE: System administrators can override either the "Retrieve all" or "Use specified max"

setting with a system-wide maximum record cap that is set in the Process Defaults form. So, for

example, if you set the system to display up to 500 items, but the system administrator has set a

system-wide maximum of 250, the greatest number of items you can actually display is 250.

o Use default - When selected, the system uses the default cap, which is 200 records.

o Retrieve all - When selected, the system displays all items that meet the search criteria.

e Use specified max - When selected, the number in the box is your current cap on list items.
If the Use Default option is selected, this field displays -1.

This option applies only to business-data list boxes.

4 Click Cancel.

Changing the Cap on Drop-Down Lists

If you cannot display in a drop-down list all the items you need to see, it is possible to reset the
default cap so that the system displays the number of items you need.

To change the cap on items displayed in a drop-down list:
1 From the View menu, select Settings.

2 Locate the Caps > Drop-downs group box.

3 Select the option you want to specify for the new cap:

e Use default: The system uses the default cap, which is 200 items.
o Retrieve all: The system retrieves all items that meet any specified search criteria.

CAUTION: Consider carefully before selecting this option. Unlimited retrieval of a list of items
can degrade system performance.

e Use specified max: In the field to the right of this option, enter the maximum number of
items you want to be able to display.

Note that transferring data for a large number of items to your system can degrade performance.
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If the Use default option is selected, the value -1 appears in this field.
4 Click OK.

5 To refresh a list, type a wildcard character (an asterisk * by default) in the list box and then click
the drop-down button.

NOTES:

e System administrators can override either the "Retrieve all" or "Use specified max" setting
with a system-wide maximum record cap that is set in the Process Defaults form. So, for
example, if you set the system to display up to 500 items, but the system administrator has set
a system-wide maximum of 250, the greatest number of items you can actually display is 250.

e The cap you designate applies only to business-data lists.

e Any change you make to the cap lasts only until you exit the application. The next time you
open the application, the default cap is in effect.

Changing Focus on Collections

If a form has more than one collection of records, you can select the collection you want to work with
by clicking a part of the form that displays the collection. For example, you can click a field or a box
surrounding several fields. Doing so changes the focus of the form to the selected collection.

Another way is to locate the collection you want in a grid and click any cell for the record you want.
While working with a collection, keep in mind that:
e Actions menu commands affect only the selected collection.

For example, the Next command navigates to the next record in the selected collection.

e The selected collection is displayed in relief, with highlights and shadows.
e Status bar messages change to reflect selected fields within the collection.

For more information about navigating within a form, see Keyboard Navigation and Other Navigation
Tips.

Sorting Collections

When you retrieve a collection of records, you often sort them according to the contents of one field.
The system lets you sort based on:

e The contents of a column in a grid, or
e The value of information displayed in a field

To sort a collection based on the contents of a grid column, double-click the column heading for the
column. To toggle the sort between ascending order and descending order, repeat this action.

To sort a collection based on a field value:

1 In an open a form, display the collection you want to sort.
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Click in the field on which you want to sort.
Select Edit > Sort Collection.

(Optional) By default, records are sorted on the field in the primary collection that currently has
focus. If you are not sorting the primary collection, select a collection and field:

o From the Collection list, select the name of the collection you want to sort. If you don't know
the name of the collection, to see the name of the current collection, return to the form and
click Help > About This Form.

e Inthe By Property box, click the name of the field on which you want to sort.

(Optional) By default, records are sorted in ascending order, regardless of capitalization. To sort
by descending order, select the Descending check box.

(Optional) To take into account capitalization when sorting, select the Case-sensitive check box.
Click OK.

Notes About Sort Order

When sorting collections, a few sort-order concepts must be kept in mind:

Some fields that appear to be numeric (for example, Account) might actually be character-
based. Thus, they would use text-character sort order.

Character-based fields use text-character sorting. For example, if you attempt an ascending sort
by account number, the accounts might be sorted like this:

(blank field)
#222

222

2220

@201
XL-64

x|-64

This is because, in text-character (ascending) order:

Character strings are generally sorted from left to right. That is, the first character (furthest left) is
evaluated, then the second, and so on.

A blank field comes before any other character. Thus, any blank fields always display first.

Special characters might come before numerals, between numerals and letters, or after letters.
Thus, #222 comes before 222, but @201 comes after 222.

Numerals display in correct numeric order, regardless of size.
Numerals display before alphabetic characters.
Upper-case characters display before lower-case characters. Thus, XL-64 comes before x|-64.

Unicode strings typically are compared using a "word sort" technique, where all punctuation
marks and other non-alphanumeric characters, except for the hyphen and the apostrophe, come
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before any alphanumeric character. The hyphen and the apostrophe are treated differently than
the other non-alphanumeric symbols, in order to ensure that words such as "coop" and "co-op"
stay together within a sorted list.

Printing Collections

Printing Records or Collections of Records

When working with the system, it is sometimes useful to be able to print out a collection of records.
The system allows you not only to do this, but also to preview the collection before actually sending
it to the printer. For more information, see:

Previewing a Record or Collection Before Printing

Printing a Record or Collection

Previewing a Record or Collection Before Printing

Often, before actually sending a record or collection that you want to print to the printer, it is a good
idea to preview what will be printed.

To preview a record or a collection before printing:

1

2
3
4

Open a form and display the collection you want.
(Optional) To print a single record, select that record.
From the Form menu, select Print Preview.

In the Print Options dialog box, do one of the following:

e To preview the selected single record, click Current Field Data.
e To preview the entire collection, leave Collection Properties selected and from the drop-
down list, select the collection you want to print.

If you do not know the name, return to the form and click the section displaying the collection.
Then click Help > About This Form to see the name of the current collection.

(Optional) To sort the fields and properties listed in the Select Fields/Properties box
alphabetically, select the Sort Alphabetically check box.

From the Select Fields/Properties group box, select the items you want to include in the
preview:

e To select and preview all items, leave all items in the left pane.

e To exclude an item, select the item in the left pane, and then click Exclude.

¢ If you have marked an item for exclusion and then decide you want to include it, select the
item in the right pane, and then click Include.

e To change the order, moving an item up or down in the list, use the Up and Down buttons.

(Optional, for collections only) To have the system place a light gray background behind
alternating records, select the Shade Alternate Detail Lines check box.
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(Optional) To have the system wrap record contents that go beyond the normal width of the
page, select the Word Wrap check box.

When this check box is selected, the system is better able to present all selected
fields/properties, because the system uses multiple lines for record fields/properties that do not
fit within the normal page margins. If this option is not selected, any contents that do not fit within
the page margins simply get cut off and are not presented at all.

(Optional) To change the display font, click the Font button.

Use the Windows Font dialog box to identify the font family, size, and style you want to use, and
then click OK.

(Optional) To change the print setup options for the preview, click Print Setup.
In the Page Setup dialog box that opens, you can adjust the following print settings:

e Paper size and source

e Page orientation (portrait or landscape)

e Page margins

e Printer settings and options (Printer button)

This button opens the Printer dialog box, where you can select a printer and make other printer-
specific settings.

Click OK.

Printing a Record or Collection

The system allows you to print selected records or collections of records. Before actually printing out
a record or collection, you can also preview the output.

To print a record or a collection:

1

2
3
4

Open a form and display the collection you want.
(Optional) To print a single record, select that record.
From the Form menu, select Print.

In the Print Options dialog box, do one of the following:

e To print the selected (single) record, click Current Field Data.

e To print the entire collection, click Collection Properties. From the drop-down list, select the
collection you want to print.

If you do not know the name of the collection, you can click the section of the form that displays
the collection, and then click Help > About This Form to see the name of the current collection.

(Optional) To sort the fields and properties listed in the Select Fields/Properties group box
alphabetically, select the Sort alphabetically check box.

From the Select Fields/Properties group box, select the items you want to print;

e To print all items, leave all items in the left pane.
e To exclude an item, select the item in the left pane, and then click Exclude.
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e If you have marked an item for exclusion and then decide you want to include it, select the
item in the right pane, and then click Include.

e To change the order, moving an item up or down in the list, use the Up and Down buttons.

7 (Optional, for collections only) To have the system place a light gray background behind
alternating records, select the Shade Alternate Detail Lines check box.

8 (Optional) To have the system wrap record contents that go beyond the normal width of the
page, select the Word Wrap check box.

When this check box is selected, the system is able to print all selected fields/properties,
because the system uses multiple lines for record fields/properties that do not fit within the
normal page margins. If this option is not selected, any contents that do not fit within the page
margins simply get cut off and are not printed at all.

9 (Optional) To change the display font, click the Font button.

Use the Windows Font dialog box to identify the font family, size, and style you want to use, and
then click OK.

10 (Optional) To change the print setup options for the preview, click Print Setup.
In the Page Setup dialog box that opens, you can adjust the following print settings:

e Paper size and source

e Page orientation (portrait or landscape)

e Page margins

e Printer settings and options (Printer button)

This button opens the Printer dialog box, where you can select a printer and make other printer-
specific settings.

11 Click OK.

12 (Optional) In the Windows Print dialog box, you can select an alternate printer, set additional
print options, and so on, before sending the output to the printer.

13 Click OK.

Using Collections Outside the System

Using Collections Outside the System

There are several ways you can use the data from a collection of records outside the system. You
can:

e Export the data to an external file.

For more information, see Exporting Collections to External Files.

o Copy the data from a collection to an external spreadsheet program.

For more information, see Copying To/From a Spreadsheet.
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o Paste data from an external spreadsheet into the collection.

For more information, see Copying To/From a Spreadsheet.

e Display the data in a graph format.

For more information, see Creating and Formatting Graphs from a Collection.

Exporting Collections to External Files

You can export the data in a collection to an external file, which in turn can be imported into another
application. Field values in the external file can be separated by either commas or tabs. Each record
in the collection becomes a row in the exported file. Each field (property) becomes a column.

If you want to export the files to a spreadsheet, you can use the To Excel option instead of this
process.

NOTES:

e By default, columns in the file are ordered left-to-right according to an internal property list.
The order does not necessarily follow the order of columns in any grid shown on the form.
However, if you use the To Excel menu option, and the currently selected field is either in a
grid or has a related grid on the form, you can choose whether the spreadsheet should match
the sequence of columns in the related grid or the order of the internal property list.

¢ In the spreadsheet, columns are created for the data (property) for each visible component on
the form. If more than one visible component is bound to the same data (for example, a grid
column and a combo box), there is just one column in the export. Columns that are hidden on
the form are still included in the export if other visible components are bound to the same
property.

¢ Rows with multi-line fields that contain carriage returns and line feeds do not export to a file in
a regular way. To export such rows, you must copy the collection to a spreadsheet. For more
information, see Copying Data to/from a Spreadsheet.

To export a collection to an external file:
1 Open the form and display the collection that you want to export.
2 From the Form menu, select Export to File.

3 Inthe Export Collection to File dialog box, from the Source Collection drop-down list, select
the name of the collection you want to export. If you do not know the name, return to the form
and click a section of the form that displays the collection. Then, to see the name of the current
collection, click Help > About This Form.

4 From the Cap Option drop-down list, select one of these options:

o To export only the records currently displayed in the collection, select From data currently
in the collection.

e To retrieve and export all records that match the current filter criteria, select Unlimited
qguery.

5 From the Output File Type drop-down list, select one of these options:
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o Comma-separated with a set of double-quotes around each string item and then separated
with commas, as in this example:

"doejo",4,",1,"john.doe@acmemfg.com”,",
e Tab-separated, as in this example:
doejo 4 1 john.doe@acmemfg.com

NOTE: Make sure that the external application in which you want to view the collection supports
the format you select here.

6 Inthe Output File Name field, enter the full path and file name of the external file being created.
If you do not specify a path, the system saves the file in the folder that contains the Infor tools
program files or, if you opened the application with a Windows shortcut, in the Start in folder.

7 Click OK.

Copying Data To/From a Spreadsheet

Copying Data to/from a Spreadsheet

There are times when it is useful to be able to use the data in a collection in a spreadsheet outside
the system, or to bring data from a spreadsheet into a collection in the system. The system allows
you to do both, including:

Copying from a grid to a spreadsheet

e An entire collection

e One or more selected records

e One or more selected columns

e One or more selected cells

Pasting from a spreadsheet into a collection grid

e An entire collection

e One or more selected records (rows)

e Contents of a single cell

NOTE: Numeric values represented by check boxes in grids are 0 (zero) when cleared and 1
(one) when selected. These values are transferred to and displayed in spreadsheets as 0 and 1,
respectively. So, if you plan to paste content from a spreadsheet into a grid and a check box value
is included, you must enter the correct values as 0s and 1s in your spreadsheet.

Saving a Collection to Microsoft Excel

Use the Actions>To Excel menu option (or the To Excel toolbar button) to save a collection to a file
and then automatically open the file in Microsoft Excel. The records are placed in the file
formnameExportsequence.csv in the local My Documents folder - for example, My
Documents\itemsExport4.csv. If Excel is installed on your local system, it is launched and the new
file is opened as a spreadsheet. If you have a different application set up to open comma-separated
value (.csv) files, that application will open the file instead.

70



About Forms, Fields, Records, and Collections

If the currently selected field is either in a grid or has a related grid on the form, you see this prompt:
"Do you want to match the sequence of columns in the related grid?" Click Yes if the spreadsheet
columns should match the order of the grid on the form. Click No if the spreadsheet columns should
match the order of the property list in the form's IDO.

Only data displayed in the current collection is populated into the spreadsheet, and the usual export-
to-file rules apply.

Some collections may not have the To Excel option enabled.

Copying Entire Collections to a Spreadsheet

You can copy an entire collection of records from the system to a spreadsheet using the steps
below, or you can use the To Excel menu option.

These steps assume that you have the form open and the collection you want to copy showing.
To copy an entire collection to a spreadsheet:

1 Click the blank box in the upper-left corner of the grid. This action selects and highlights the
entire collection.

2 Press CTRL+C or select Edit > Copy. The contents of the collection are copied to the system
clipboard.

3 Inyour spreadsheet application, select the cell you want to be the first (most upper-left) cell of
the collection. Typically, this is the first cell in the worksheet.

4 Press CTRL+V or use whatever command your spreadsheet program uses to paste in the
material.

NOTES:

e Carriage returns and line feeds in a multi-line cell are removed when you copy a row to the
clipboard. So, if you have multi-line cells, you must copy those cells separately or reconstruct
them in the spreadsheet.

e This procedure can copy only the records that have actually been retrieved. So, if you want to
copy all the records from a collection, and the cap prevents some records from being
displayed, you must change the cap so that all records are retrieved. For more information,
see Retrieving Collections and About Caps.

e By default, the system does not copy and paste the header row of the collection as part of this
procedure. If you want to copy the header row as well as the records, do one of the following:

e Use the To Excel menu option.

e Select View>Settings and then select Include grid column headers when copying to
clipboard in the Runtime - Behavior section.

Copying Selected Records to a Spreadsheet
You can copy a single record or a subset of records from a collection to a spreadsheet.

These steps assumes that the form is open and showing the collection you want to copy from.
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NOTE: Carriage returns and line feeds in a multi-line cell are removed when you copy a row to the
clipboard. So, if you have multi-line cells, you must copy those cells separately or reconstruct
them in the spreadsheet.

To copy a single record to a spreadsheet:

1 Click in the left-most column for the record you want to copy. This action selects and highlights
the entire record.

2 Press CTRL+C, or select Edit > Copy. This action copies the record to the system clipboard.

3 Inyour spreadsheet application, select the cell you want to be the first (left-most) cell of the
pasted record.

4 Press CTRL+V or use the command your spreadsheet program uses to paste in the material.
To copy a subset of records from a collection to a spreadsheet:
1 Click in the left-most column for the first record you want to copy.

2 Shift-click in left-most column for the last record you want to copy. The subset of records is
highlighted and selected.

You can also select non-adjacent rows for the subset. To do this, use CTRL-click to select
multiple non-adjacent rows, and then paste them into the spreadsheet as you would any other
contiguous set of records.

Alternatively, you can select the cells to copy by pressing shift-up, shift-down, shift-right, and
shift-left.

3 Press CTRL+C, or select Edit > Copy. This action copies the selected records to the system
clipboard.

4 In your spreadsheet application, select the cell you want to be the first (most upper-left) cell of
the pasted records.

5 Press CTRL+V or use the command your spreadsheet program uses to paste in the material.

Copying Selected Columns to a Spreadsheet
You can copy a single column or a subset of columns from a collection to a spreadsheet.

These steps assume that you have the form open and showing the collection you want to copy from.

NOTE: Carriage returns and line feeds in a multi-line cell are removed when you copy a row to the
clipboard. So, if you have multi-line cells, you must copy those cells separately or reconstruct
them in the spreadsheet.

To copy a single column to a spreadsheet:

1 Click in the header row for the column you want to copy. This action selects and highlights the
entire column.

2 Press CTRL+C, or select Edit > Copy. This action copies the contents of the column to the
system clipboard.
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In your spreadsheet application, select the cell you want to be the top (upper-most) cell of the
pasted column.

Press CTRL+V or use the command your spreadsheet program uses to paste in the material.

To copy a subset of columns from a collection to a spreadsheet:

5
6

Click in the header row for the first column you want to copy.

Shift-click in header row for the last column you want to copy. The subset of columns is selected
and highlighted.

You cannot select non-adjacent columns for the subset. That is, you can use CTRL-click to
select multiple non-adjacent columns, but when you paste them into the spreadsheet only the
first column (or first set of adjacent columns) actually gets pasted into the spreadsheet.

If you have one or more columns that are not adjacent to other columns you want to copy, you
can drag non-adjacent columns to a position adjacent to the other columns you want to copy.
Then select the set of columns to be copied, once they are all in a contiguous set.

Alternatively, you can select the cells to copy by pressing shift-up, shift-down, shift-right, and
shift-left.

Press CTRL+C, or select Edit > Copy. This action copies the selected columns to the system
clipboard.

In your spreadsheet application, select the cell you want to be the first (upper-most) cell for the
pasted columns.

Press CTRL+V or use whatever command your spreadsheet program uses to paste in the
material.

Copying Selected Cells to a Spreadsheet

You can copy a single cell or a block of cells from a collection to a spreadsheet.

These steps assume that you have the form open and showing the collection you want to copy from.

NOTES:

Row labels are pasted in the spreadsheet as the first column. The labels are for reference
only and should not be copied and pasted back into a grid. In the spreadsheet, you can delete
the row-label column, unless you want to keep it for reference purposes.

Carriage returns and line feeds in a multi-line cell are removed when you copy a row to the
clipboard. So, if you have multi-line cells, you must copy those cells separately or reconstruct
them in the spreadsheet.

To copy a single cell to a spreadsheet:

1
2

Click in the cell you want to copy.

Press CTRL+C, or select Edit > Copy. This action copies the contents of the cell to the system
clipboard.

In your spreadsheet application, select the cell where you want to copy the contents.
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4 Press CTRL+V or use the command your spreadsheet program uses to paste in the material.
To copy a block of cells from a collection to a spreadsheet:
1 Click in the first (upper-left) cell you want to copy.

2 Shift-click in last (lower-right) cell you want to copy. The block of cells is selected and
highlighted.

You cannot select non-adjacent cells. That is, you can use CTRL-click to select multiple non-
adjacent cells, but when you paste them into the spreadsheet only the first cell (or first
contiguous block of cells) actually gets pasted into the spreadsheet.

Alternatively, you can select the cells to copy by pressing shift-up, shift-down, shift-right, and
shift-left.

3 Press CTRL+Insert. This action copies the selected block of cells to the system clipboard.

4 In your spreadsheet program, select the cell you want to be the first (most upper-left) cell for the
pasted columns.

5 Press CTRL+V or use whatever command your spreadsheet program uses to paste in the
material.

Pasting Entire Collections into a Grid from a Spreadsheet

The information and procedure for copying an entire collection of records from a spreadsheet and
pasting them into a grid are virtually the same as Pasting Selected Records (Rows) from a

Spreadsheet.

The only real possible difference is that you select the entire collection instead of just a subset of
rows.

Pasting Selected Records (Rows) from a Spreadsheet

You can paste the contents of selected records that you have worked on in a spreadsheet into a
grid.

This might be useful, for instance, when you have copied a set of records from the system into a
spreadsheet for editing and now you want to return the contents of the records, with the changes, to
the system.

NOTES: When pasting data into a grid, keep the following in mind:

e The spreadsheet and the grid must follow the same data scheme. Some grids contain hidden
columns. Columns in the spreadsheet must exactly match the visible columns in the grid. The
first column in the spreadsheet must correspond to the first column in the grid; the second
column in the spreadsheet must correspond to the second column in the grid; and so forth.

Normally, if you originally copied from a grid into the spreadsheet, the data schemes are
identical. However, in some cases, this is not true because the order of the grid may not
match the order of the collection that was exported; in those cases, you must reorder the
columns in the spreadsheet to match the grid order.

e Be careful, too, when ordering columns in the grid view. Because the paste order matches
that of the spreadsheet, if you paste a value into a column that affects the value of a later
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column, then when the later column value is pasted, it might overwrite the desired (calculated)
value with the value from the spreadsheet.

You can insert rows from a spreadsheet as new rows in a grid, or you can overwrite existing
rows in the grid with rows from the spreadsheet. The overwrite operation skips columns that
are read-only, leaving the current values unmaodified.

This means you might have to take other steps to get the appropriate values into those read-
only fields.

The form might validate each cell when you paste rows into a grid. Invalid data in cells in the
spreadsheet or empty cells that correspond to required fields in the grid might generate
validation error messages. Note that if you edit a cell in response to a validation message
during the paste operation, the paste operation ends with the current record. Therefore, we
recommend that you respond No to all prompts for validation during the paste operation, and
then go back after the operation is complete, to edit these fields.

The maximum number of rows you can paste into a form at one time depends on the memory
resources of your computer. Pasted rows are held in memory until you save them. You can
avoid out-of-memory conditions and related errors by dividing a large number of records into
smaller batches and then pasting and saving each batch separately.

To ignore the values in some cells of the spreadsheet and replace them with the default value
in the application, type [null] in those cells of the spreadsheet before copying the rows into
the grid. Do not leave the cells blank. Be sure to include the brackets and use lowercase.

To paste selected rows into a grid:

1

Open the form into which you want to paste the records.

To paste the records into a blank grid, you can do a Filter-in-Place query that you know will
retrieve no records. This puts the form in "new" mode. For more information, see Finding
Records with Filter-in-Place.

In the spreadsheet, select the rows you want and press CTRL+C to copy them to the system
clipboard.

Do not include the header row, if you have one. If you include the header, the paste operation
probably will not complete successfully.

In the grid, click inside the field at the location where you want to copy the data.

In many cases, especially if you have a blank form in "new" mode, this is the first cell in the grid,
though you can paste them in anywhere. Some tips:

¢ Do not create a new row; the paste action will automatically create the row.

e Do not click the row label. Instead, click inside any field on the row you want to replace or
below which you want to append the new rows. If you are replacing multiple rows, the paste
action will replace the row in which you clicked and each subsequent row, replacing the
contents of those rows except for the read-only fields.

4 From the Edit menu, select one of these options:

e Toinsert new records at (below) the selected field, select Paste Rows Append.
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e To overwrite the content of existing records, beginning with the selected field, select Paste
Rows Overwrite. This option only overwrites active fields. Fields that are read-only are left
unchanged.

Do not use CTRL+V to paste the rows. Doing so causes the system to write the entire contents
of the source row to a single cell. Use one of the options listed above.

Pasting the Contents of a Single Cell from a Spreadsheet

You can paste the contents of selected records that you have worked on in a spreadsheet into a
grid.

This might be useful, for instance, when you have copied a set of records from the system into a
spreadsheet for editing, made minor changes in a few records, and now want to copy those changes
back to the grid without having to copy and paste the entire collection.

NOTE: This does not work for blocks of cells. If you attempt to copy and paste blocks of cells, the
system attempts to write the contents of all source cells to a single cell in the destination grid.
The type of contents in the source cell must match the expected type for the contents of the grid cell.

For example, if the grid is expecting an alphanumeric character string, the cell in the spreadsheet
must contain alphanumeric character content. If the grid cell expects a numeral input, the source cell
must contain only numeric content.

Furthermore, if the grid can accept only certain values, (for instance, Active, Disabled, or Locked),
then the source cell can contain only those values. Otherwise, the paste operation will fail.

To paste the contents of a single cell from a spreadsheet into a grid cell:
1 Open the form where you want to paste the content.

2 Inthe spreadsheet, select the cell you want and then press CTRL+C to copy the content to the
system clipboard.

To avoid problems when copying content from Microsoft Excel spreadsheets, select (but do not
copy) the cell, and then copy only the cell contents in the formula bar field. If you select the
entire cell, certain hidden formatting content gets copied that can cause problems in the grid.

3 Inthe grid, click inside the field where you want to copy the data.
4 Press CTRL+V, or select Edit > Paste.

This action overwrites any content that was previously in the field.

Creating and Formatting Graphs from a Collection

Note: This topic applies to the graphing tool, which is supported for backward compatibility. We
recommend that, if you want to add charts or gauges to a form, use the newer FusionCharts tool
instead. For more information, see Adding Charts or Gauges to a Form.

There are at least two ways you can redisplay data from a collection of records using a graph format:

76



About Forms, Fields, Records, and Collections

If you have copied the data to a spreadsheet, you can use the graphing capabilities of the
spreadsheet program. For more information, see the documentation for your spreadsheet
application.

You can redisplay the data in graph format within the system, using the built-in graphing
capabilities. For more information, continue with the rest of this topic.

To create a graph using the system graphing capabilities, you identify what information is to be used
to construct the graph and what type of graph is to be drawn, such as a bar graph or a line graph.
After the graph is displayed, you can adjust it, including changing the information included, changing
the type of graph, and adjusting the labels. When you're satisfied with the online display, you can
handle the results by saving, copying, or printing the graph.

Creating a Graph

To create a graph for the current collection:

1

Open a form and display the collection of records you want to graph.

If you do not want to see the graphs for all records in the collection, you can either filter the
collection to display only the records you do want to see, or (especially if you want to view the
graph for one particular record) select the record you want to start with in the grid view.

From the Actions menu, select Graph.

In the first page of the Graph Collection dialog box (Select properties to graph from
collection, where collection is the collection you are working with), select the information you
want to include in the graph. In the list, click one or more properties (field names) that identify the
information you want to graph.

The system uses a different color in the graph for each property you include.
Click Next.

In the second page (Select property for data label, or none), select the information to appear
in the horizontal axis labels.

If you do not want any labels for the horizontal axis, do not select anything from this page.

Click Next. The system displays a preliminary view of the graph. By default, the graph is a 2D
column chart with 8 columns.

Editing or Reformattng a Graph

To edit or reformat the graph:

To change the type of graph, select a different option in the Type drop-down list and then click
Refresh.

To change the number of items that display at one time, type a number in the Scroll By box and
then click Refresh.

To resize the graph so you can see detailed labels and scaling, verify that the Lock Objects
check box is cleared.

Then, when you click an editable area of the graph, a frame with handles displays. To resize the
area, use these handles. To move the editable area, click-and-drag inside the frame.

77



Infor Mongoose Basic Concepts User Guide

e To navigate through the records displayed in graph views, click the << Previous and/or Next >>
buttons below the graph.

Handling the Graph Results

When you move your pointer over the graph area, the three buttons appear in the upper right corner

of the graph. These buttons allow you to print the graph, copy the graph to the system clipboard, or

save the graph to a file.

Printing

To print the graph:

1 Generate and modify the graph using the procedures as described in the previous sections.

2 Click the Print Chart button.

The system opens the standard Print dialog box, where you can select a printer and set printer
options. When you click OK, the system prints the graph using the selected printer and settings.

Copying

To copy the graph to the system clipboard:

1 Generate and modify the graph using the procedures as described in the previous sections.
2 Click the Copy Chart to Clipboard button.

The system copies the graph to the system clipboard. From there, you can paste it into a document
or file such as a Word document, a PowerPoint presentation, or an Excel spreadsheet. You can also
paste it into a graphics editing program for further touchup.

Saving

To save the graph to a file:

1 Generate and modify the graph using the procedures as described in the previous sections.
2 Click the Copy Chart to File button.

When saving, you can save the graph file in any of the following graphics formats:

e Bitmap (*.bmp)

* JPEG (*jpg)

e GIF (*.gif)

o TIFF (*.tif)

e PNG (*.png)

¢ Enhanced Metafile (*.emf)
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Working with Records

Working with Records

A record is a group of related pieces of data or information. On most forms, each piece of
information displays in a separate field on the form. Taken together, these pieces of information
constitute one record. On forms that display collections of records in grids, each row represents a
single record.

In most of your day-to-day operations, you will be dealing with records. Thus, knowing how to locate,
modify, and manage records is essential.

In this section of the documentation, you can find information on the following topics:

e Locating Specific Information in Records
e About Row Labels

e Printing (and Previewing) Records and Collections of Records
e About Adding, Changing, and Deleting Records

Locating Specific Information in Records

Locating Specific Information in Records

Often, when working with a collection of records, you need to find a particular record or piece of
information within that record. There are a number of ways you can do this.

e With drop-down list boxes of the business-data type, you can search for valid values and retrieve
a selected value into the field.

For more information, see Finding a Specific Value in a Drop-Down List.

¢ On most drop-down lists, you can filter for designated values, to limit the number of items you
must look through to find the ones you want.

For more information, see Filtering a Drop-down List.

¢ On most drop-down fields, you can also search the items for specific values.

For more information, see Finding a Value in a Collection of Records.

For other suggestions on how to locate the records you are looking for, see Tips for Finding
Records.

Finding a Specific Value in a Drop-Down List

With drop-down list boxes of the business-data type, you can search for valid values and retrieve a
selected value into the field.

To find and retrieve a specific value from a drop-down list:
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1 Click in a drop-down list box.

2 To select the Find feature, place the focus on the field for which you want to find a value and
then from the Edit menu, select Find Value for Current Field.

NOTE: The Find feature is not available for all fields.
3 The system opens one of these forms:

e The query form associated with the form from which you initiated the Find. If this form opens:
= Specify any primary criteria for your search.
=  Specify any additional criteria.
= Click Refresh.
= Select a record in the Results pane that contains the field value you want.
*= Click OK.

= At the prompt, click Yes. The system returns to the original form and inserts the value
you selected in the field.

e The form in which values for the field are defined. If this form opens:
= Select the record containing the value you want.
=  From the Form menu, select Close and Save Changes.

= At the prompt, click Yes. The system returns to the original form and inserts the value
you selected in the field.

Filtering a Drop-Down List

When searching within a drop-down list for a particular value, it can often be a good idea to limit the
contents of the list to make it easier to find the desired value. WinStudio makes it possible to filter
the list, thus reducing the number of values presented.

To filter a drop-down list:
1 Click in a drop-down list box.
2 If there is a value in the box, delete it.

3 Type the characters you want to match. You can type one or more instances of the wildcard
character to broaden or narrow your search. For more information, see Using Wildcard
Characters).

4 Click the drop-down arrow.

The system displays a list consisting of items that match your criteria. The number of items
displayed is limited to the current cap on lists.

NOTES:

e You can filter only on drop-down lists for business-data list boxes.

o Comparison operators are not supported in filtering drop-down lists.

e Validators do not run in Filter-In-Place mode.
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¢ In two-column lists, which show an identification number in the left column and a name or
description in the right column, filter criteria apply only to the left column. Also, the left column
may contain leading spaces and thus require a preceding wildcard when you enter filter
criteria.

For example, to find ID numbers starting with '3' in a two-column list, you may need to enter *3*.

To filter on data in the right column, use the Find feature (if available) to open a query form.

Finding a Value in a Collection of Records

You can search the records in a collection for a specific value in a field. For example, suppose you

wanted to locate the records for all customers located in the state of Indiana. Using the Customers
form, you would search on the State/Prov field for the abbreviation IN. The Find Value in Collection
feature locates the first record for the state of Indiana. You can then repeat the Find action until you
locate the particular customer you want.

NOTE: This search applies only to a collection that has been retrieved and does not query the
database. Thus, it is limited by the cap on records retrieved. For more information, see About Caps.

To find a specific field value in a collection of records:

1 In an open form, display the collection you want to search.

2 Click in the field or grid column you want to search.

3 From the Edit menu, select Find Value in Collection.

4 Inthe Find dialog box, Find field, type the value you want to find, such as a word or number.

The Find Value feature uses an "implied wildcard" search. For more information, see Implied
Wildcards.

By default, the Find Value feature searches the field in the primary collection that currently has
focus. If you do not want to search the primary collection, you can select a different collection
and field:

¢ From the In Collection drop-down list, select the name of the collection you want to search.
If you do not know the name, return to the form and click About This Form on the Help
menu to see the name of the current collection.

e From the In Property drop-down list, select the name of the field you want to search.

5 To find records that have the exact capitalization you typed, select the Case Sensitive check
box.

6 To find the first record that contains the value for which you are searching, click OK.

7 To find the next record that contain the value, press CTRL+F2; or, from the Edit menu, select
Repeat Find.

Tips for Finding Records

If you cannot find the record you want in a collection, consider these possibilities:
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Are you looking in the correct collection?

Try changing the focus of the form, to make sure you are focused on the correct collection. You can
tell which collection currently has the focus by noting where the cursor is and/or which fields are
highlighted.

Are the correct records retrieved?

To identify the current filter being used to retrieve records, from the Help menu, select About This
Form.

If necessary, use Filter-in-Place or a query form to retrieve the collection you need. For more
information, see one of the following topics:

e Finding Records with Filter-in-Place

e Finding Records Using a Query Form

Have you overlooked the record?

Try sorting the collection. On the Edit menu, click Sort Collection. For more information, see
Sorting Collections.

You can also search for a specific value in a field in a collection. From the Edit menu, select Find
Value in Collection. For more information, see Finding a Value in a Collection of Records.

Do you retrieve the same collection of records every time you use a form?

You may want to save your search criteria as a filter so that you can reuse it instead of having to re-
enter it every time. For more information, see Creating and Saving Filters.

About Row Labels

Row labels appear in the far left column of a grid form. These labels show the numerical order of
records in a collection and provide indicators about the current state of each record, whether it is
saved, new, modified, or marked for deletion. Row labels also show whether unsaved records
contain validation errors that must be corrected before the records can be saved.

Understanding Row Label Indicators

Use this table to interpret the row label indicators that display in the first column of grids:

Indicator Meaning of the Indicator

4 Indicates the current (selected) record in the collection. In a multiview form,
this is the record that displays in the detail view.

* Indicates that the record is new and contains no validation errors. It has not
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yet been saved.

Indicates that the record has been modified and contains no validation
errors. It has not yet been saved.

A modification is considered to occur whenever there is a change to a value
in any field.

X Indicates a record marked for deletion.

The record is removed from the database when you save the record or the
collection containing it.

! ] Indicates at least one validation error for a new record, modified record, or
record marked for deletion.

The indicator is added to the row label when you navigate away from the
record, receive a validation error message concerning the record, and do not
correct the error. When you subsequently try to save the record, or the entire
collection containing the record, the system repeats the validation error
message, and you cannot save it until the error has been corrected.

Replacing a Value in a Record

You can search a collection for records that contain certain field values and replace them with new
values.

To replace a field value in a collection:

1

2
3
4

Open the form and display the collection you want.

Place the cursor in the field for which you want to replace values.

From the Edit menu, select Replace Value in Collection.

In the Replace dialog box, Replace field, type the value you want to find and change.

The Replace Value feature uses what is known as an "implied wildcard" search. For more
information, see Implied Wildcards.

In the With field, type the new value you want to use.

(Optional) From the In Collection drop-down list, select the name of the collection you want to
search.

If you placed the cursor in the desired field before starting, the correct collection should already
be selected.

If you do not know the name of the collection, return to the form and click the section displaying
the collection. Then click Help > About This form to see the name of the current collection.

(Optional) From the In Property drop-down list, select the name of the field in which you want to
make replacements.
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If you placed the cursor in the desired field before starting, the correct property should already
be selected.

8 Tofind and replace a value only if it has the exact capitalization as you typed it, select the Case
Sensitive check box.

9 To replace the value in this field regardless of the current value, select the All Values check box.
The Replace field is deactivated, indicating that any value in the field will be replaced.

10 Click OK.
11 When prompted, click one of these buttons:

e To replace only the currently selected and displayed field value, click Yes.

e To skip the currently selected and displayed field value and move to the next one, click No.
e To cancel the operation and make no replacements, click Cancel.

o To replace all values for this field in the collection, click Yes to all.

Printing Records

Printing Records or Collections of Records

When working with the system, it is sometimes useful to be able to print out a collection of records.
The system allows you not only to do this, but also to preview the collection before actually sending
it to the printer. For more information, see:

e Previewing a Record or Collection Before Printing

e Printing a Record or Collection

Previewing a Record or Collection Before Printing

Often, before actually sending a record or collection that you want to print to the printer, it is a good
idea to preview what will be printed.

To preview a record or a collection before printing:

1 Open a form and display the collection you want.

2 (Optional) To print a single record, select that record.

3 From the Form menu, select Print Preview.

4 Inthe Print Options dialog box, do one of the following:

e To preview the selected single record, click Current Field Data.
o To preview the entire collection, leave Collection Properties selected and from the drop-
down list, select the collection you want to print.

If you do not know the name, return to the form and click the section displaying the collection.
Then click Help > About This Form to see the name of the current collection.
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(Optional) To sort the fields and properties listed in the Select Fields/Properties box
alphabetically, select the Sort Alphabetically check box.

From the Select Fields/Properties group box, select the items you want to include in the
preview:

e To select and preview all items, leave all items in the left pane.

e To exclude an item, select the item in the left pane, and then click Exclude.

¢ If you have marked an item for exclusion and then decide you want to include it, select the
item in the right pane, and then click Include.

e To change the order, moving an item up or down in the list, use the Up and Down buttons.

(Optional, for collections only) To have the system place a light gray background behind
alternating records, select the Shade Alternate Detail Lines check box.

(Optional) To have the system wrap record contents that go beyond the normal width of the
page, select the Word Wrap check box.

When this check box is selected, the system is better able to present all selected
fields/properties, because the system uses multiple lines for record fields/properties that do not
fit within the normal page margins. If this option is not selected, any contents that do not fit within
the page margins simply get cut off and are not presented at all.

(Optional) To change the display font, click the Font button.

Use the Windows Font dialog box to identify the font family, size, and style you want to use, and
then click OK.

(Optional) To change the print setup options for the preview, click Print Setup.
In the Page Setup dialog box that opens, you can adjust the following print settings:

e Paper size and source

e Page orientation (portrait or landscape)

e Page margins

e Printer settings and options (Printer button)

This button opens the Printer dialog box, where you can select a printer and make other printer-
specific settings.

Click OK.

Printing a Record or Collection

The system allows you to print selected records or collections of records. Before actually printing out
a record or collection, you can also preview the output.

To print a record or a collection:

1
2
3

Open a form and display the collection you want.
(Optional) To print a single record, select that record.

From the Form menu, select Print.
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4 Inthe Print Options dialog box, do one of the following:

e To print the selected (single) record, click Current Field Data.
e To print the entire collection, click Collection Properties. From the drop-down list, select the
collection you want to print.

If you do not know the name of the collection, you can click the section of the form that displays
the collection, and then click Help > About This Form to see the name of the current collection.

5 (Optional) To sort the fields and properties listed in the Select Fields/Properties group box
alphabetically, select the Sort alphabetically check box.

6 From the Select Fields/Properties group box, select the items you want to print:

e To print all items, leave all items in the left pane.
e To exclude an item, select the item in the left pane, and then click Exclude.

¢ If you have marked an item for exclusion and then decide you want to include it, select the
item in the right pane, and then click Include.

e To change the order, moving an item up or down in the list, use the Up and Down buttons.

7 (Optional, for collections only) To have the system place a light gray background behind
alternating records, select the Shade Alternate Detail Lines check box.

8 (Optional) To have the system wrap record contents that go beyond the normal width of the
page, select the Word Wrap check box.

When this check box is selected, the system is able to print all selected fields/properties,
because the system uses multiple lines for record fields/properties that do not fit within the
normal page margins. If this option is not selected, any contents that do not fit within the page
margins simply get cut off and are not printed at all.

9 (Optional) To change the display font, click the Font button.

Use the Windows Font dialog box to identify the font family, size, and style you want to use, and
then click OK.

10 (Optional) To change the print setup options for the preview, click Print Setup.
In the Page Setup dialog box that opens, you can adjust the following print settings:

e Paper size and source

e Page orientation (portrait or landscape)

e Page margins

Printer settings and options (Printer button)

This button opens the Printer dialog box, where you can select a printer and make other printer-
specific settings.

11 Click OK.

12 (Optional) In the Windows Print dialog box, you can select an alternate printer, set additional
print options, and so on, before sending the output to the printer.

13 Click OK.
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About Adding, Changing, and Deleting Records

About Adding, Changing, and Deleting Records

After you add a new record or change an existing record, you have the option of saving it
immediately or saving it later. If you do not save it immediately, the record is marked as new or
modified in its row label.

Similarly, when you delete a record, it is labeled as deleted but the deletion is not committed to the
database until you save the record.

Before you save your changes, you can undo them, singly or in a batch. You can then make further
changes, remove a new record, or restore a record you have marked for deletion.

When you save the changes, they are transferred to the database for permanent storage and the
status labels are removed.

Within a collection of records, you can:

e Add anew record

e Copyarecord
e Check for and correct errors

e Save records, either singly or all at once

e Delete records
e Undo deletion of records
e Undo changes to a record

e Undo all changes and deletions in a collection of records

e Copy records to or paste records from a spreadsheet

Adding Records

With most forms that display records in grids, you can add (new) records to the collection. When you
do so, the new record is added after whichever record is currently selected.

To add a record:
1 Locate and select the record in a collection after which you want to add the record.

If you want to add the record after the current last record in the collection, you can simply select
the last row in the grid, which has the asterisk in the row label.

2 From the Actions menu, select New.
3 Complete the fields as needed.

4 Save the record.

Copying Records

Copying a record, rather than creating a new one, and then modifying it, can often save time in
repetitive data-entry tasks.
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To copy a record:
1 Select the record to copy.
2 Do one of the following:

e From the Actions menu, select Copy.
¢ Right-click the row and then, from the context menu, select Copy.

A copy of the selected record is inserted as the next record.
3 Edit the record as needed.

4 Save the record.

NOTES:

e If the record contains a field with a number that is automatically assigned and cannot be
manually changed, the system assigns the next available number to the copied record when
you save it.

¢ If the record contains a field with a number that is automatically assigned but which can be
changed manually, the number is duplicated in the copied record. You can update the value
manually before you save the record. To allow the system to assign the next available number
automatically, make the field blank before you save the record.

Checking for and Correcting Errors

Checking for Errors

Most forms validate new and modified records and report validation errors. The system displays
messages about any field that contains an invalid value or about any field that requires a value but
does not contain one.

EXAMPLE: One such validation error is a faulty date entered in a date field. If the field requires a
date after today's date and you enter an earlier date, the system displays an error message.

The validation procedure occurs, and any error messages display, when you:

¢ Navigate away from a new or modified record.
e Attempt to save new or modified records.
e Select Validate from the Actions menu.

To check records for errors, perform any of these actions.

Some fields are set to validate immediately and not wait until you perform one of these actions. In
these cases, validation occurs as soon as you attempt to move the focus to another field in the same
record.

Validation Error Messages and Correcting Errors

When you perform an action, other than an action to save all records, that triggers validation, the
system displays an error message for the first field in the current record that contains an error. If
there are multiple errors, the system then cycles through each field with an error.
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If you attempt to save a form that has multiple records with errors, the system reports which records
in the current collection contain errors. You cannot save the form until all errors have been
corrected.

To correct the current record:

1 When the system presents the error message and prompts you to respond, click Yes.
The insertion point moves automatically to the field containing the error.

2 Enter a valid value.

3 From the Actions menu, select Validate.

4 If the system displays an error message, repeat steps 1 and 2 until no field in the record contains
an invalid value.

To correct records in the collection:

1 Note the record numbers in the error message. They correspond to row labels in the grid form.
Navigate to a record indicated by a row number.

From the Actions menu, select Validate.

Note the name of the field reported in the error message.

Move the insertion point to the field named in the error message.

S 0 A O DN

Enter a valid value.

7 Repeat steps 3 through 6 until all fields in the current record are valid.

Repeat the entire procedure until you have corrected all records indicated in the error message from
the save operation.

Other Warning and Informational Messages

Some forms are designed to report warnings and other information in a dialog box. The dialog box
opens when you attempt to save records. Use the dialog box to troubleshoot and correct the
problems:

¢ To move from the dialog box to the associated record in the form, double-click the message.

e Ifarecord is associated with several messages, you can expand the display to see them all.
Select the message and click the Expand Selection button.

e You can close the dialog box and redisplay it later.
To close it, click Done.

To reopen it, from the View menu, select Warning Messages. The messages remain available for
viewing until you refresh the collection or perform another save operation.

Saving Records

When saving records, you have two options: You can save a single record, or you can save all
records at one time.
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You can selectively save new or modified records in a collection. Similarly, you can selectively
commit single deletions to the database.

Alternatively, if you have made multiple changes in a form, for instance, if you have added new
records in a form, modified them, or marked them for deletion, you can save all changes to the
records in a single step.

To save a single record, select the record and select Actions > Save current from the menu.

To save all records, select Actions > Save.

Deleting Records

You can delete a single record or a group of adjacent records from a collection.
To delete a record:

1 Select the record you want to delete.

2 From the Actions menu, select Delete.

3 When the system notifies you that the record will be permanently deleted after a Save action,
click OK.

4 To delete the records permanently from the database, save the collection.

To delete a group of records:

5 Click the row label for the first record in the group you want to delete.

6 Hold down SHIFT and click the row label of the last record you want to delete.
7 From the Actions menu, select Delete.
8

When the system notifies you that the records will be permanently deleted after a save action,
click OK.

9 To delete the records permanently from the database, save the collection.

NOTE: The system does not actually delete a record from the database until you save your
changes. If you make a mistake or change your mind about deleting records, you can unmark
those records. For more information, see these topics:

e Undoing Deletion of Records

¢ Undoing Changes to All Records

Undoing Deletion of Records

A record is not permanently deleted from the database until you save it. Before you save the record
(thus deleting it permanently), you can undo the deletion.

Note that after you save a record or a collection that has records marked for deletion, you cannot
undo the deletions.

To undo deletion of a record:

1 Select the record marked for deletion that you want to unmark.
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Records marked for deletion have a (d) in the row label.
2 From the Actions menu, select Delete.

Notice that the system unmarks the record for deletion, and the (d) no longer appears in the row
label.

To undo deletion of a group of records:

1 Click the row label for the first record marked for deletion in the group.

2 Hold down SHIFT and click the row label of the last record marked for deletion in the group.
3 Do one of the following actions:
4

From the Actions menu, select Delete.

Undoing Changes to a Record

If you have made changes to a record but not saved the record or the form, you can undo your
changes and restore its original values. In a record marked for deletion, this procedure removes the
deletion mark as well as undoing any changes to field values.

CAUTION: Note that, after you save a record or form that has records that have been changed, you
cannot undo the changes.

To undo changes to a record:

1 Select the record for which you want to undo the changes.
Records that have been changed have (m) in the row label.

2 From the Actions menu, select Refresh Current.

Notice that the system restores any changes made to their original values, and the (m) no longer
appears in the row label.

Undoing All Changes to Records

If you have made changes to multiple records or marked multiple records for deletion, but you have
not saved the records or the form, you can undo your changes and restore records to their original
values. In records marked for deletion, this procedure removes the deletion marks as well as
undoing any changes to field values.

CAUTION: Note that, after you save a record or form that had records that had been changed or
marked for deletion, you cannot undo the changes.

To undo all changes to records:
1 From the Actions menu, select Refresh.
2 When asked if you want to save changes, click No.

Notice that the system restores any changes made to their original values, and change indicators no
longer display in the row labels.
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Working with Fields

Working with Fields

The system displays each piece of information in a record in a different field (in a detail view) or
column (in a grid view). Taken together, all the related fields on a form typically constitute one
record. Fields represent the most basic bit of information in a record.

In this section, you can find the following information about fields:

e Types of Fields
e The significance of background colors in fields

e About Drop-down Lists

e Date fields
e Changing or deleting specific field values
e Use of graphics or other binary objects in fields

About Editable Field Types and Colors

The foreground (font) and background colors of certain components can be used to indicate whether
values for those fields:

e Are required or are optional
e Can be updated or are read-only
e Can be (optionally) generated by the system (To Be Determined — TBD)

The default colors for these fields are preset in the system, though your system administrator can
change them for your system, using themes.

These are the four basic types of fields that can be controlled in this way:

Type of field Description/Comments
Required Indicates that you must enter a value for a record before you can save the
record.

NOTE: A required field that is part of an optional subcollection is required
only if you create a record in the subcollection.

For example, when you add a new user on the Users form, you can
optionally enter group information for the user, but it is not required.
However, if you do create a group record, the Group Name and Primary
Group fields on that record must be filled in.

Optionally, the system can be set to use, in place of or in addition to a set of
colors, a red asterisk in front of the field name. System administrators can set
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this using a theme.

To change the colors for required fields, use the Required Foreground and
Required Background color options in the Theme Editor.

Optional Indicates that the field does not require a value for the form to be saved.

To change the colors for optional fields, use the Foreground and
Background color options in the Theme Editor.

Read-only Indicates that the value cannot be changed by the end user.

To change the colors for display-only fields, change the Read-Only
Foreground and Read-Only Background color settings in the Theme

Editor.
To Be Indicates that the value will be generated by the system at the time the record
Determined is saved, if no other value has been specified.
(TBD) In this type of field, you have the option to enter your own value. If you do not

enter a value, the system generates a value for the field automatically when
you save the record.

Optionally, the system can be set to use, in place of or in addition to a set of
colors, a green asterisk in front of the field. System administrators can set this
using a theme.

To change the colors for TBD fields, change the TBD Foreground and TBD
Background color settings in the Theme Editor.

The components that can be controlled using these settings include:

Check boxes

Combo boxes

Date pickers

Drop-down lists

Edit fields

Grids and grid columns

Option (radio) buttons

Vertical grids and vertical grid elements

Types of Fields

WinStudio uses a variety of field types to present options and information. It is at the field level that
changes to records take place, so it is a good idea to understand the different types of fields.
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Types of Fields

Type Description
Input Input fields allow you to enter information to be saved with the record. The type of
fields input (whether alphabetic only, numeric only, alphanumeric, or other) depends on

how the field is defined.
For more information about a particular input field, see the online help for that field.

The background color of the field indicates how you are intended to use it. For
more information, see About Field Types and Background Colors

Drop- Drop-down lists are intended primarily to allow you to select an item from a list that

down lists is displayed when you click the drop-down arrow. However, in many drop-down
lists, you can type in particular values you want or values to use as the basis for a
Find operation.

Drop-down lists come in two types: Business-data lists and option lists. For more
information about these list types and how to use them, see About Drop-down

Lists.
Check Check boxes typically represent an on/off option. When selected, a check mark
boxes appears inside the box (as in the example here), and the option is considered "on."

When it is cleared (that is, the check box is empty), the option is considered "off."

Check boxes are often presented in groups where several related options can all
be either selected or not.

Option Option buttons (sometimes known as "radio buttons”) are typically used for a group
buttons of mutually exclusive options. In these cases, only one option can be selected. In
most cases, all options are not selected until you actually select one.

In grid columns, the cell displays the selected option, if any.

Using the Question Mark Character

In fields that have a green background (generated fields), you can use the question mark (?)
character to fill in and increment after a prefix. For example, if you enter “JB?”, in a Job Number field
on a Job Orders form that uses this functionality and then save, the system expands it to
“JB00000001". If you add another record with “JB?”, it increments it to “JB00000002”, etc.
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About Drop-down Lists

About Drop-Down Lists

The system uses two basic drop-down list types: business-data lists and option lists.

Business-Data Lists

The drop-down list for a business-data list displays information added to the database by system
users using data-input forms.

Filtering Lists

You can filter to reduce the number of items returned and displayed in the drop-down list. For more
information, see Filtering a Drop-down List.

Right-click Context Menus

Right-clicking a business-data list field brings up a context menu that usually presents the Add,
Details, Find, and Help commands. These commands, along with other features for using business-
data lists, are basic aids to finding and entering information in the system. For more information, see:
e Finding a Specific Value in a Drop-Down List

e Adding a New Field Value

¢ Finding Details about a Value in a Drop-down List

e Getting Help

Refreshing Lists

While you are viewing a form containing a business data drop-down list, you or another user might
edit the records in the original form from which the list is derived. Any new or removed records are
not reflected in the list, unless you refresh it.

To refresh the list:
Perform one of the following actions:

e With the cursor in the list field, press F2.
¢ Type one wildcard character (usually *) in the list field, and then click the drop-down arrow.

Option Lists

The drop-down list for an option list displays a fixed set of options. These options are built-in to the
system, rather than being created and stored in the database. You cannot usually change the
options in these lists, and they usually have fewer than ten items.

The three statement cycle options Weekly, Monthly, and Quarterly are built-in to the system and
cannot be changed or added to.
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Right-click Context Menus

The right-click context menu for option-lists usually presents only the Help command. For more
information, see Getting Help.

Finding a Specific Value in a Drop-Down List

With drop-down list boxes of the business-data type, you can search for valid values and retrieve a
selected value into the field.

To find and retrieve a specific value from a drop-down list:
1 Click in a drop-down list box.

2 To select the Find feature, place the focus on the field for which you want to find a value and
then from the Edit menu, select Find Value for Current Field.

NOTE: The Find feature is not available for all fields.
3 The system opens one of these forms:

e The query form associated with the form from which you initiated the Find. If this form opens:
= Specify any primary criteria for your search.
=  Specify any additional criteria.
»= Click Refresh.
= Select arecord in the Results pane that contains the field value you want.
= Click OK.

= At the prompt, click Yes. The system returns to the original form and inserts the value
you selected in the field.

e The form in which values for the field are defined. If this form opens:
= Select the record containing the value you want.
= From the Form menu, select Close and Save Changes.

= At the prompt, click Yes. The system returns to the original form and inserts the value
you selected in the field.

Filtering a Drop-Down List

When searching within a drop-down list for a particular value, it can often be a good idea to limit the
contents of the list to make it easier to find the desired value. WinStudio makes it possible to filter
the list, thus reducing the number of values presented.

To filter a drop-down list:
1 Click in a drop-down list box.
2 Ifthere is a value in the box, delete it.

3 Type the characters you want to match. You can type one or more instances of the wildcard
character to broaden or narrow your search. For more information, see Using Wildcard
Characters).
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4 Click the drop-down arrow.

The system displays a list consisting of items that match your criteria. The number of items
displayed is limited to the current cap on lists.

NOTES:

e You can filter only on drop-down lists for business-data list boxes.

o Comparison operators are not supported in filtering drop-down lists.
e Validators do not run in Filter-In-Place mode.

¢ In two-column lists, which show an identification number in the left column and a name or
description in the right column, filter criteria apply only to the left column. Also, the left column
may contain leading spaces and thus require a preceding wildcard when you enter filter
criteria.

For example, to find ID numbers starting with '3' in a two-column list, you may need to enter *3*.

To filter on data in the right column, use the Find feature (if available) to open a query form.

Adding a New Field Value

If a value does not exist in a drop-down list, and you need it, you can add the new value and insert it
into the field.

To add a new value and insert it in a field:

1 Open a form and display the record you want to add the field value to.
2 Click in the field you want.

3 From the Edit menu, select Add Value for Current Field.

The Add feature is available only for business-data list fields.

The system displays the form used to maintain the values (records) for this field and inserts a
new record automatically.

4 Complete the fields for the new record.
5 From the Form menu, select Close and Save Changes.

The system returns to the original form and inserts the new value into the field.

Finding Details About a Value in a Drop-Down List

At times, when looking for a particular item in a business-data list, you might want to know more
about an item before you select it, perhaps to verify that it is the correct one. Most business-data
lists allow you to search for details using a right-click menu option.

To find details on a particular list item, with the cursor in the field

1 Select the drop-down list for which you want to find details.
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NOTE: Not all drop-down lists have this option available. Generally, only business-data lists offer
this option.
2 From the Edit menu, select Details for Current Field.

3 When you are finished, close the dialog box.

Changing the Cap on Drop-Down Lists

If you cannot display in a drop-down list all the items you need to see, it is possible to reset the
default cap so that the system displays the number of items you need.

To change the cap on items displayed in a drop-down list:
1 From the View menu, select Settings.

2 Locate the Caps > Drop-downs group box.

3 Select the option you want to specify for the new cap:

e Use default: The system uses the default cap, which is 200 items.
o Retrieve all: The system retrieves all items that meet any specified search criteria.

CAUTION: Consider carefully before selecting this option. Unlimited retrieval of a list of items
can degrade system performance.

e Use specified max: In the field to the right of this option, enter the maximum number of
items you want to be able to display.

Note that transferring data for a large number of items to your system can degrade performance.
If the Use default option is selected, the value -1 appears in this field.
4 Click OK.

5 Torefresh alist, type a wildcard character (an asterisk * by default) in the list box and then click
the drop-down button.

NOTES:

e System administrators can override either the "Retrieve all" or "Use specified max" setting
with a system-wide maximum record cap that is set in the Process Defaults form. So, for
example, if you set the system to display up to 500 items, but the system administrator has set
a system-wide maximum of 250, the greatest number of items you can actually display is 250.

e The cap you designate applies only to business-data lists.

e Any change you make to the cap lasts only until you exit the application. The next time you
open the application, the default cap is in effect.

Entering Dates
To select a date from a pop-up calendar:

1 In the date field, click the drop-down arrow.
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The system displays a pop-up calendar with the current date selected.
2 Use the calendar to select the date you want:

e Click a date in the calendar to enter it in the field.
e To change the month, click the forward or back arrows at the top of the calendar.

If the system converts the date to the appropriate format when you exit the field, the input is
accepted.

To type a date manually:
1 Place the cursor in the date field.

2 Type the date in the field, using any valid date format.

Changing or Deleting Field Values

You can change or delete a value in a field's drop-down list.

NOTE: These steps apply only to business-data lists.

To change or delete a field value:

1 Open a form and display the record for which you want to change a field value.
2 Select the value you want to change, and leave the cursor in the field.

3 From the Edit menu, select Details for Current Field.

The system displays the form used to maintain the values (records) for this field and
automatically selects the value you selected.

4 Make your changes or delete the record.
5 Save your changes and close the form.

The system returns to the original form. The field you selected reflects the changes.

NOTE: You might have to refresh the collection to see the changes. From the Actions menu,
select Refresh.

Graphics and Other Binary Objects in Fields

If you can use graphics or other types of binary objects in a field, commands on the Edit menu are
enabled so you can work with the object.

To view the graphics file or object:
1 Click inside the field.
2 From the Edit menu, select View Binary Data for Current Field.

The system opens the program associated with the file type and displays the object.
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EXAMPLE: If the file is a bitmap (.bmp) image, and you have your system to open bitmap objects
with Microsoft Paint by default, the system opens Paint and displays the bitmap image.
To insert a graphics file or other binary object:

1 Click inside the field.

2 From the Edit menu, select Import Binary Data for Current Field.

3 Inthe dialog box, identify the file you want to use.

The dialog box lists only the types of files appropriate for the field.

To delete a graphics file or other binary object from a field:

1 Click inside the field that contains the object.

2 From the Edit menu, select Delete Binary Data for Current Field.

To export the graphics file or other object to an external file (so you can use it elsewhere):
1 Click inside the field that contains the object.

2 From the Edit menu, select Export Binary Data for Current Field.

3 Inthe dialog box, enter the name to be assigned to the exported file.

The dialog box lists only the file types appropriate for the object you are exporting.
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Some forms include an area that displays important information from the fields on the form as a

chart, to help comprehension. The values in the chart change depending on which record is
selected.
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Adding and Viewing User Tasks

Creating a Task

You can create user tasks, similar to those in Microsoft Outlook, to help you keep track of important
dates, tasks, notes to yourself, and so on. If you set a reminder date, the system reminds you when
the task is due.

In addition, authorized system administrators can also create tasks and assign them to you.
To create a task:

1 To access the Create User Task form, select View > Task.

2 Inthe Task Name field, specify a name for the task.

3 Inthe Remind Date field, specify a reminder date and, optionally, time.
To specify both a date and time, enter the date/time manually, in the format DD/MM/YY
HH:MM:SS AM|PM.

4 (If you are a system administrator creating a task for another user) In the User Name field,
specify the user for whom you are creating the task.

5 If you want the task to be deleted after the reminder date has passed, select Delete After
Reminder.

6 (Optional) Use the Description field to specify any additional information about the task.
7 Click OK.

Setting a Notification Sound and Icon

When a task reminder date and time is reached, the system sends a notification message and
places it in the Inbox form.

In the View > Settings window, you can set prompts that occur when a notification message is
received in your Inbox:

e Play a sound.
o Display an envelope icon in the notification area of the taskbar.
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Viewing the Task List

To see the complete list of tasks that you currently have, open the Task List form. To open this form,
use the standard methods such as Form > Open, or click My Tasks on the Create User Tasks
form.

Authorized system administrators can select the Show All check box on the Task List form to view
all tasks created by all users. After you select Show All, you must reapply the Filter-in-Place.

Viewing Notification Messages

To see and delete notification messages in the Inbox form, select View > Inbox.

Deleting a Task

You can define tasks so that the system automatically deletes them after it sends the reminder. To
do this, select Delete After Reminder on the Create User Tasks form or the Task List form.

You can also manually delete a task from the Task List form.
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Using the User Calendar

This topic tells how to use the User Calendar to manage your appointments. You cannot view or
manage appointments for other users.

Changing Your Month View

Click the arrow buttons at the top of the calendar to display a different month.

Adding an Appointment

To add an appointment, double-click on the day's heading in the User Calendar form to display the
Create User Appointment form. Specify this appointment information and click OK:
e Subject

e Location - As you enter locations, they are stored in the calendar, so you can reuse them later by
selecting locations from a drop-down menu.

e Starting and Ending Time

e Remind Date/Time

o Delete After Reminder (optional)

e Description.

When the reminder date and time is reached, the system sends a message to the Inbox form. It can

also display a message notification icon in the status bar and play a sound when the reminder
message arrives, if you have chosen those options in the Settings dialog.

Viewing Existing Appointments
To view appointment information:

e Hover the cursor over the appointment in the Calendar view to see a brief summary of the time,
subject and location
e Double-click on the appointment

¢ View the appointment in the form grid.

105



Infor Mongoose Basic Concepts User Guide

Deleting an Appointment

If you selected Delete After Reminder, the appointment is automatically deleted after the due date
and time.

To manually delete an appointment, select the row in the grid and click Delete. Then save the form.
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Creating Workflows with the Wizard

Users such as purchasing managers or executives can use the New Workflow Wizard to quickly
create workflows (event handlers and actions) for some basic notification scenarios. For example, a
purchasing manager can build a workflow to "Notify me when a PO line is created for more than

$1000."

As you make simple choices in the wizard, behind the scenes the system is creating event handler
and event actions metadata that can later be viewed or edited in the standard Application Event
System (AES) forms.

Building a Workflow

To build a simple naotification workflow:

1

On the first page of the New Workflow Wizard, specify one of these options:

Notify Me When: Select this option to receive a notification in your Mongoose Inbox when
the change you specify in the following pages is made to the system

Notify You When: Select this option if the person who makes the specified change should
receive a notification in their Mongoose Inbox.

Build from Scratch: Select this option and click Finish to exit the workbench and use the
standard AES forms to build the workflow.

Select Customize Resulting Workflow if you want to open the event handler you created in the
standard AES forms when you finish building the workflow through the wizard. This option is
enabled only if you selected one of the Notify options.

Click Next. On the second page of the wizard, specify these options:

Specify a description of the workflow. You can change the description on later pages.

Specify the IDO and/or form that you want the system to track. You must identify the IDO. In
addition, you can further restrict the triggering condition by specifying the form where the
changes are made. See the Examples below.

Note: If you select a form name and then click in the IDO field, the IDO is automatically filled
in (this can be helpful if you know the form but not the IDO). If you specify an IDO name, and
you want the workflow to apply to all forms that use that IDO, you can either leave the Form
Name field blank or select All Forms. If you want the workflow to apply to all IDOs
associated with the specified form, select All IDOs.

Specify the type of operation on that IDO (Additions, Changes, or Deletions) that will
trigger the notification.

4 Click Next. On the third page of the wizard, specify these options:
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Specify All Rows to trigger the notification on any change to the IDO, or select Where and
specify property and value filter criteria if you only want a notification triggered when the
change is for a row that matches the filter criteria.

To specify multiple filter clauses, specify whether to use And or Or to join the new clause
with the preceding one, and click Add.

For each clause, you can specify one of these options:
= Property, operator, and value
= Property, operator, and another property, with an optional date-time adjustment

=  Property, operator, and the date/time when the workflow runs, with an optional
adjustment.

See the Examples below.

5 Click Finish to complete the workflow. (The Next button on this page is reserved for future use.)
If you selected Customize Resulting Workflow, the Event Handlers form is launched for this
workflow's event handler.

Example 1: PO Line Cost Greater than $1000

To create a workflow that sends a notification to your Inbox when a new purchase order line is
added where the cost is more than $1000:

1 In the first page of the New Workflow Wizard, select Notify Me When.

2 Inthe second page of the wizard, specify the description as Notify me when new PO line cost
is > $1000.

3 For Apply To, select the PurchaseOrderLines form and click in the IDO field to display the
appropriate IDO (SLPoltems) and caption (Purchase Order Items).

4 For What to Track, specify Additions.

5 In the third page, specify the filter criteria:

Select Where. The caption for the IDO you selected on the previous page is displayed
(Purchase Order Items).

Select the appropriate property, DerExtltemCostConv, from the drop-down list. Note that
the field label associated with the property is displayed in the drop-down list where possible,
to help you find the property you want. In this case, DerExtltemCostConv has the field label
Extended Cost, which is what you want to compare to your maximum amount.

Specify the operator, in this case "greater than" ( >).

Specify the value to compare to, in this case 1000. Do not specify separators or currency
symbols.

Click Add This Clause to add your filter to the workflow.

6 Click Finish to complete the workflow.

7 To test the workflow, ask another user to add a new PO line for more than $1000. You should
receive a notification in your Inbox.
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Example 2: PO Line Promise Date Later Than Due Date

To create a workflow that sends a notification to your Inbox when a PO line change occurs and the
Promise Date is later than the Due Date:

1
2
3

Follow steps 1-3 from the first example.
For What to Track, specify Changes.
In the third page, specify the filter criteria:

o Select Where. The caption for the IDO you selected on the previous page is displayed
(Purchase Order Items).

e Select the appropriate property, PromiseDate, from the drop-down list.

e Specify the operator, in this case Is after.

e Specify the other property to compare to, in this case PurchaseOrderltems.DueDate.

e Click Add This Clause to add your filter to the workflow.

Click Finish to complete the workflow.

Test the workflow.

Viewing Your Finished Workflows

After you finish creating your workflow, you can view it in the My Workflows form. If you want to
further customize a workflow, you can use the editors on the Event Handlers form.

Event Handlers cannot be deleted. You can, however, edit the Event Handler and mark it as
Obsolete.
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Using Utilities and Activities

Utility and activity forms process multiple records in one operation. They typically perform tasks such
as purging records, updating values, posting transactions, or changing the status of records. The
Delete Audit Logs form, for example, deletes all audit logs created between specified dates for
specified message types.

To use a utility or activity, you specify criteria to select information to be processed and you select
options to define the processing task. The form then processes information that meets the criteria. In
certain forms, you can preview results of the process before you save them in the database.

For the Change Vendor Contract Price Status Utility, which is used to mass update a range of
vendor contract price records from a status of pending to approved, if there is already an approved
record for one of the records in the results set, this utility overwrites the existing approved contract
break quantities and prices with data from the pending record.

Previewing and Saving Results in Utilities and Activities

Utility and activity forms that display a grid provide an option to preview the results of processing
data without actually changing records in the application database. You can use this feature to
assess your selection criteria and task options. You can adjust them as needed before you save the
changes. You can also use the results as you would use information in a spreadsheet, searching
columns for values, sorting rows, and so forth.

Results display in the grid at the bottom of the form.

Previewing the Results of Running a Utility or Activity
1 Specify your processing criteria on the form.
2 Select Preview.

3 Click Process.

Saving the Results of Running a Utility or Activity
1 Specify your processing criteria on the form.

2 Select Commit.
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3 Click Process. Modified records are stored in the application database.

Specifying Selection Criteria in Utilities and Activities

In many utilities and activities, you select items to process by defining a range of values or several
ranges of values. Range fields are pairs of fields with which you specify a starting value and an
ending value.

Range fields can apply to identification numbers (such as purchase order numbers or line numbers),
dates, names, and most other types of information.

To select:

e Oneitem - enter the same value in both the Starting field and the Ending field.
e All items - leave both the Starting field and the Ending field blank.

e Items between and including two values - enter the lower value in the Starting field and the
higher value in the Ending field.

e |tems from the lowest value through a specified value - leave the Starting field blank and
enter the cutoff value in the Ending field.

e |tems from a specified value through the highest value - enter the specified value in the
Starting field and leave the Ending field blank.

Using Results from Utilities and Activities

Utility and activity forms that contain a grid allow you to use the results of a process as you might
use data in a spreadsheet. The result set displayed in the grid is similar to other collections of
records in the application.

Finding values in results

Sorting rows in results

Copying results to a spreadsheet

Exporting results

Printing results
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Scheduling Background Tasks

Many utilities, reports, and some activities can be scheduled to run daily, weekly, or monthly. Once
scheduled, the process runs automatically in the background at a set time, using your selection
criteria and option settings.

NOTE: Forms that can be scheduled to run in the background have the command Background in
the Actions menu.

Scheduling a Process to Run in the Background

1
2
3

In a utility or activity form, set your selection criteria and task options.
On the Actions menu, select Background. This displays the Background Queue form.

In the Frequency field, select an interval to use as a time unit in scheduling. If you select
Weekly, for example, you can subsequently specify that the process runs every third week. To
run a process once, select Daily.

Set times and dates based on the frequency.
e Daily - To run the process once, select Occurs once at and enter a time and date.

To run the process periodically, select Occurs every and specify an interval (for example,
specify 24 Hours to run a process once a day) and a starting time.

o Weekly - Specify the number of weeks in the interval, the day of the week on which to start
the process, and the time of day.

e Monthly - To run the process on a specified date of the month, select Occurs on day. To
run the process on a specified day of the week, select Occurs on. Enter the number of
months in the interval, the date or the day of the week on which to start the process, and the
time of day.

Click OK.

One Time Only Tasks

To run a task one time only:

1

On the left side of the form, select Daily.

2 On the right side of the form, select Occurs once at.

3 Specify the time and date.
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Recurring Tasks

To schedule a task to run on a daily, weekly, or monthly basis, select that option from the left side.
Then specify the occurrence information on the right side.

Checking whether the Task is Running
You can see which tasks are currently running by opening the Active Background Tasks form.

The task name should be the same as the report or utility's form name. If the task's status is
WAITING, it is waiting for its scheduling requirements to occur. You can delete a WAITING task from
the list.

Viewing Details about the Completed Task

Once the task has run, even if it fails, you can view details about its execution on the Background
Task History form. Details include:

e Task description

e Return status

e User who submitted the task

e Messages triggered by the task
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About Printing Records and Collections

You can print records or collections or records from any form that handles records or collections.
Such printing is handled on your computer (as opposed to the system server).

If you print a single record, fields are listed alphabetically opposite their values.

If you print an entire collection of records, field labels become column headings, and each record
becomes a row in the printed table.
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Reports Overview

Reports can be generated in several formats, which can then be delivered to printers, e-mail
addresses, or fax machines. Most reports also allow you to set various options and preview the
output before actually generating it.

To better understand reports and how to generate them, see the following subtopics:

e Generating Reports
e Previewing Reports
e Printing Reports
e E-mailing Reports

e Faxing Reports
e Setting Report Options
e Setting Ranges

e Printing Notes
o Determining Fonts and Languages

e Assigning Date and Number Formats
o Getting E-mail Notifications

Generating Reports

To generate a report means to output it to a printer, to an e-mail recipient, or to a fax destination.
When you click the Print button on a report form, you generate the report.

When you generate a report, the report is sent to the background task queue, where it is then routed
to the report generator. From there, it is routed either to a printer, to an e-mail recipient, or to a fax
destination, depending on the options for that report as set on the Report Options form.

Previewing Reports

Most reports allow you to preview the output before generating it. Report previews behave the same
as generated reports, with the following exceptions:

e Previews are not sent to a printer.
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e Previews cannot be configured using the Report Options form. Previews use global settings
defined on the Intranets form.

o PDF is the default preview format. If you must use Chrome, Safari, or Firefox as your browser,
you must set the format to PDF.

e Previews are displayed on screen automatically after the preview file is created.
e E-mail notification is not needed or supported.

To preview a report:
1 Open a report form and define the report parameters.

2 Click Preview. When the processing required to create the preview is complete, the preview
displays on the screen.

After you click the Preview button, a preview window displays. Closing the preview window will close
the message window and prevent the preview from opening. However, the preview background task
continues to run and preview files are generated. If you believe there is a problem with a preview,
and you would like to cancel the background task, contact your system administrator.

Printing Reports

When you print a report, the report data is first sent to the report generator and then to the printer.
The system uses printing options as set on the Report Options form or the Intranets form. You
have the option to select a printer other than your default printer. You can also preview the report
before you actually print it.

To print a report:

NOTE: Before reports can be printed, TaskMan must be set up as described in the System

Administration Guide.

1 (Optional) Verify that the Report Options form has been set up for the report you are running.
Make sure the Output Format field for this report is set to Printer.

If no option record exists for your report, the report output defaults to the format as set on the
Intranets form. The default output format on the Intranets form is Acrobat Format (PDF).

NOTE: If you do not select Printer as the output format on either the Report Options form or
the Intranets form, the output does not go to a printer.

2 (Optional) To be notified by e-mail that the report has been printed, verify that:

e On the Report Options form, the E-mail Notification field is set to Yes for your user ID or
for the report you are printing, or both.
e Your e-mail address is on the Users form.

e On the Intranets form, the Send E-mail Notification field is selected.

3 Open the report form and define the report parameters.
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(Optional) To send output to a printer other than your default printer:
a Click Select Printer.

The system opens the Report Options form.

NOTE: If you do this step, the Report Options form opens with limited functionality. This
functionality is restricted to allow you only to select a printer. To make other changes to the
report options for this report, you must perform Step 1.

b Inthe Report Options form, if necessary, scroll to the right to locate the Printer Name
column.
¢ Specify the printer you want from the drop-down list.

d Save and close the Report Options form.

NOTE:

You can select different printers for successive print jobs, but you must be careful: TaskMan
uses whatever printer you have designated at the time it runs the print job.

Suppose, for example, that you queue up one print job to use Printer A and then a second
print job to use Printer B. If TaskMan already had a queue and did not pick up the first job
before you switched printers for the second job, then TaskMan uses Printer B for both print
jobs.

To be safe, it is best to let one print job finish, if possible, before initiating the second print job.

(Optional) Preview the report output.
For more information, see Previewing Reports.

Click Print.

E-Mailing Reports

When you send the report as an e-mail, the system sends it to the e-mail address entered on the
Report Options form, or the Intranets form (if none is used on the Report Options form).

To e-mail a report:

NOTE: Before reports can be printed, TaskMan must be set up as described in the System
Administration Guide.

1

(Optional) Verify that the Report Options form has been set up for the report you are running:
o Make sure the Output Format field for this report is set to anything other than Printer.

NOTE: If no option record exists for your report on the Report Options form, the report
output defaults to the format as set on the Intranets form. The default output format on the
Intranets form is Acrobat Format (PDF).
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o Verify that the E-mail Notification and Attach Report fields are both set to Yes.

If you do not want to attach a copy of the report to your e-mail naotification, you can leave the
Attach Report field set to No. If you later want to view the report, you can find the output file
at: TaskMan path\Report\Output Files\YourUserID

2 Open the report form and define the report parameters.
3 (Optional) Preview the report output. For more information, see Previewing Reports.

4 Click Print.

Changing Fonts in Reports

NOTE: This topic applies only to reports generated with Crystal Reports 2008 or prior versions.
To change the font for a report output:

1 Open the Language IDs form.

2 Inthe row representing the language in which you will print reports, select a font in the Font
Descriptor field.

3 Click Actions > Save.

Remarks

Font names in the Font Descriptor list represent fonts installed on your local client workstation. To
ensure that reports print in the selected font, the font must be installed also on the TaskMan server,
the utility server, and the print server.

NOTE: Barcode type fonts do not need to be installed on the client workstation if they are not going
to be previewed there.

The font setting does not apply to barcodes or currency amounts in checks. To change fonts for
these objects, edit the objects in the report source file.

Faxing Reports

FAX Configurations

The system supports several configurations for faxing reports.
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Windows Fax

By default, the system uses the Fax capability built into the Windows operating system. Windows
Fax runs on the TaskMan machine and uses a standard fax modem. The TaskMan service calls an
executable that initiates faxing of a report through the modem. This configuration is recommended
for light-duty faxing.

See Configuring Windows Fax.

Infor Framework Fax Service

The Infor Framework Fax Service can be installed on a fax server machine rather than the TaskMan
machine (see the Infor Mongoose Installation Guide for instructions). The Infor Framework Fax
Service monitors a directory on the TaskMan machine and initiates faxing through the built-in
Windows Fax capability on the fax server, which is configured with a standard fax modem. This
configuration may be preferable to the Windows Fax configuration where fax loads are higher.

See Configuring Infor Framework Fax Service.

Third-Party Fax Services

The system supports some third-party fax services. A fax service can be installed on a separate fax
server machine with an appropriate modem or fax board. The service monitors a directory on the fax
server, which is shared with the TaskMan machine.

See Configuring a Third-Party Fax Service.

Configurations and Report Options

A fax configuration applies to all reports that can be faxed and to all users. Administrators can
override configuration options for a specific report or user.

Configuring Windows FAX

To configure Windows Fax:

1 Open the Intranets form and select the Reports/TaskMan tab.
2 Leave the Fax Server field blank.

3 Leave the Fax Directory field blank.
4

In the Fax Header field, specify this header template:

-d "BG~OUTPUTFILE~" -n BG~FAXNUM~ -f "BG~ERRFILE~"
5 Clear the Use Fax Control File check box.

6 Inthe Fax Format list, select Acrobat Format or Rich Text Format. These two formats are
recommended starting points.

7 Save the record.
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Configuring Infor Framework FAX Service

For instructions on installing Infor Framework Fax Service, see the Infor Mongoose Installation
Guide.

To configure Infor Framework Fax Service:
1 Open the Intranets form and select the Reports/TaskMan tab.
2 Inthe Fax Server field, type the name of your fax server machine.

3 Inthe Fax Directory field, specify the directory on the Infor Framework TaskMan machine that
was created in the installation of Infor Framework Fax Service:

TaskMan_directory\Report\Fax

In your path, replace TaskMan_directory with the path to Taskman.exe, which is normally
C:\Program Files\Infor\AppName\TaskMan. The directory must exist.

4 Inthe Fax Header field, specify this header template:
SendFax.exe -d "BG~OUTPUTFILE~" -n BG~FAXNUM~ -f "BG~ERRFILE~"
5 Select the Use Fax Control File check box.

6 Inthe Fax Format list, select Acrobat Format or Rich Text Format. These two formats are
recommended starting points.

7 Save the record.

8 On the TaskMan machine, share the fax directory (specified in step 3) with your fax server
(specified in step 2).

Configuring a Third-Party FAX Service
To configure a third-party fax service:

1 Open the Intranets form.

Select the Reports/TaskMan tab.

Select a Fax Format.

Select or clear the Use Fax Control File check box.
Specify a Fax Directory.

Specify a Fax Header.

N O o b~ WODN

Save the record.

Setting FAX Properties for a Specific Report or User

You can override system defaults for faxing, which are set on the Intranets form. You can change
fax properties for a particular user, a particular report, or a combination of the two.
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To set fax properties for a specific report or user:

1
2

Open the Report Options form.
To set fax properties for a specific user, select a user ID in the User field.

o To apply properties to all faxes created by the user, leave the Task Name blank.

o To apply properties to a specific report created by the user, select the report task in the Task
Name field.

To set fax properties for a specific report, select a report task in the Task Name field.

o To apply properties to faxes of this report created by all users, leave the User field blank.
o To apply properties to faxes of this report created by a specific user, select a user ID in the
User field.

Which properties you can override is determined by the type of fax service installed on your
system. You may be able to override the following:

e Use Fax Control File

e Fax Directory

e Fax Output Format

e Fax Header

Save the record.

Setting Report Options

There are two basic ways to set report options:

To set the report options for individual reports, use the Report Options form.

To save, retrieve, and manage commonly-used report settings, you can use the Store Options,
Get Options, and Options Defaults forms (if available).

Setting Report Ranges

When selecting report parameters using the range fields, use the following rules:

To begin the range at the first record in the system, leave the Starting field blank.
To end the range at the last record in the system, leave the Ending field blank.
To include all records in the system, leave both Starting and Ending fields blank.

To include a selected range of records, enter both starting and ending record numbers, or select
the desired start range value and end range value from the drop-down lists.

To set the Starting field value as the default Ending field value, select Set Default Ending
Value to Starting Value on the General Parameters form or the System Parameters form.
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Sending E-Mail Notification

Using the Report Options form, you can send a notification e-mail to yourself when a report that
you initiated is complete. To do this, enter Yes in the E-mail Notification field.

You can also attach a copy of the report to the e-mail message. To do this, enter Yes in the Attach
Report field.

For more information, see E-mailing Reports.
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Working with Notes

You can annotate a record or a collection of records by attaching one or more notes.

The See Also link at the top of this page points to other topics that explain how to create, view, and
attach/detach notes.

Object and Class Notes
The system allows you to create:

e Notes for a single record (Object Notes): These notes are attached to the currently selected
record. Object notes can be internal or external. You can create a note specifically for that
record, or you can attach a reusable note.

¢ Notes for all records in a collection (Class Notes): These notes are attached to every record
in a collection. For example, if you attach a class note to one customer record, it is automatically
attached to all customer records. Class notes can be internal or external. You can only attach
reusable notes as class notes. Also, class notes do not print on reports.

You can attach multiple notes, of either type, to a record. Once you attach a note of any type to a
record, all other users of the system can read the note.

When you attach a note, the status bar displays the word NOTES, and the Actions menu displays a
check mark next to the Notes for Current option (for single-record notes) or next to the Notes for
All option (for notes attached to the whole collection).

Creating and Attaching Notes

On many forms, you can create notes to be attached to records or collections of records. For
information about note types and classifications, see Working with Notes.

Creating a Single-Use Note for a Specific Record

To create a note that applies only to the current record and that will be used only once in the system,
follow the steps below.

1 Open a form and select a record where you want to add a note.
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Select Actions>Notes for Current to open the Object Notes form.

In the Subject field, specify an appropriate subject identifier. This subject line does not print on
reports. It is used only to distinguish this note from other notes.

Specify whether the note should be classified as internal. For more information about external
and internal notes, see "Internal/External Notes" in Working with Notes.

If you want to attach an external file, click Attach File. In the dialog box that opens, browse to
the file you want to attach and click Open. The filename and path displays in the Note field. For
more information, see "More About Attaching External Files," below.

In the Note field (if you did not attach a file), enter the text that constitutes the actual content of
the note. This is the text that can be printed as part of reports.

Save the note record and close the form. This also attaches the note to the current record in the
original form.

Creating Class Notes for a Collection of Records

Class notes, which are attached to all records in a collection, can only be reusable notes. Thus,
follow the steps under "Creating or Selecting Reusable Notes," below.

Creating or Selecting Reusable Notes

To create a note (or select an existing note) that can be reused again for other records:

1
2

Open a form and select a record where you want to add a note.
Select either:

e Actions>Notes for Current to open the Object Notes form, for notes attached to a single
record, or

o Actions>Notes for All to open the Class Notes form, for notes attached to all records in a
collection.

On either the Object Notes or Class Notes form, click Attach/Detach Reusable to display the
System/User Notes form.

Decide which kind of note you want to create or select, and then use the fields under that
heading:

e System note - can be viewed/selected by all system users, printable in some cases
e User note - can be viewed/selected only by the user who created it, never printable

To use an existing note, just select the Attach check box next to that note and click OK to return
to the previous Notes form.

To create a new reusable note:

e Specify an appropriate subject identifier. This does not print on reports. It is used only to
distinguish this note from other notes.
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e If you want to attach an external file, click Attach File. In the dialog box that opens, browse
to the file you want to attach and click Open. The filename and path displays in the Note
field. For more information, see "More About Attaching External Files," below.

¢ In the Note field (if you did not attach a file), type the text that constitutes the actual content
of the note. For system notes, this is the text that may be printable as part of reports.

e Select the Attach check box and click OK to return to the previous form.
7 If you return to the Object Notes form, specify whether the new note is Internal (see the

explanation of "Internal/External Notes" in Working with Notes) and then save the note record.
This also attaches the note to the current record in the original form.

8 If you return to the Class Notes form, click OK to save the note on all records in the collection
and close the form.

More About Attaching External Files

As described in the steps above, you can use notes to attach files created in other applications.
These files can include any type of file that your work environment supports. For example, you can
attach files that represent text documents, spreadsheets, graphics, even multimedia files.

You can attach a file to a new note or an existing note. The file must already exist in a location that is
accessible to any users who might access it from the note.

CAUTION: Attaching a file to an existing note replaces any text content the note may have with the
path and file name for the attached file. If you have note text that you want to preserve, either copy
the text to another note, or attach the file to a new note.

Once a file has been attached to a note, you and others can open the attached file by clicking on the
Open Attachment button.

Notes that have files attached do not print in reports and other printing utilities.

Reading and Modifying Notes

You can read notes that are attached to a record or a collection. In many cases, you can also modify
notes.

Reading/Modifying Notes Attached to a Record or Collection

1 Open a form and select a record that has notes attached. You can tell which records have notes
attached by checking for one of the following:

¢ Inthe toolbar, the Notes button is highlighted when a record has an object note (notes for
current record) attached.

e The status bar for a record with a note attached displays the word NOTES.
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e The Actions menu for records with a note attached displays a check mark before the Notes
for Current and/or Notes for All option.

2 To open the appropriate notes form:

e For single-record notes, use Actions>Notes for Current to open the Object Notes form.
e For class notes (notes for all records in a collection), use Actions>Notes for All to open the
Class Notes form.

3 Inthe notes grid, select the note you want to read or modify. The subject identifier and note text
display. If these fields are inactive, the note is a reusable note - click Attach/Detach Reusable if
you need to modify it. If the note includes an attached file, you can view the attachment by
clicking Open Attachment. If no notes are displayed, but the Actions menu has a check mark
indicating that a note exists for the record, then the note is a private (hon-system) user note
added by another user.

4 (Optional) Modify the subject and note text as required.

5 When you are finished, you can save your changes, if any. To do this, either click OK or save the
notes record.

Reading and Modifying System/User Notes

You can also directly read and modify reusable system or user notes without having to open a form
that the notes attached to records.

To do this, select View>System Notes. This opens the System/User Notes form where you can
read and modify notes as described in the previous section.

Deleting Notes

If you no longer need a note, you can delete it from the system. The way you delete a note is
determined by the type of note it is.

For information about note types and classifications, see Working with Notes.

If the note you want to delete includes an attached external file, you do not need to delete the
attached file. You just remove the connection between the application and the file by detaching it.

Deleting a Single-Record Note

1 Go to the form and record where the note exists.

2 Select from the notes grid the note you want to delete.

3 Use the Delete option on the main toolbar or right-click menu.

NOTE: If you delete a reusable note in the Object Notes form, you only detach the note from the
record; you do not delete the note. To actually delete a reusable note, you must be in the
System/User Notes form - see below.

128



Working with Notes

4 Save the record.

Deleting a Class Note (Notes for All Records in a Collection)
1 Go to the form and record where the note exists.

2 Select from the notes grid the note you want to delete.

3 Use the Delete option on the main toolbar or right-click menu.

NOTE: If you delete a reusable note in the Object Notes form, you only detach the note from the
records in the current collection; you do not delete the note. To actually delete a reusable note,
you must be in the System/User Notes form - see below.

4 Click OK to save the change and exit the form.

Detaching Notes and Files

If you no longer want a note or external file attached to a particular record or collection, but you want
to keep the note for later reuse, you can detach it.

For single-record (object) notes, there is no way to detach a single-record note. You simply delete it.

For information about note types and classifications, see Working with Notes.

Detaching a Reusable Note
1 Go to the form and record where the note exists.
2 Select the option for the appropriate note type:

e Actions>Notes for All to display the Class Notes form, or
e Actions>Notes for Current to display the Object Notes form.

3 Click Attach/Detach Reusable.

4 Onthe System/User Notes form, clear the Attach check box for the note you want to detach
from the record.

5 Click OK to save the change and close the System/User Notes form.
6 Do one of the following:

¢ If you return to the Class Notes form, click OK to save the changes and close the form.
e If you return to the Object Notes form, save the record and then close the form.

Detaching an External File Attached to a Object Note

For more information about external files attached to notes, see Creating and Attaching Notes.
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Go to the form and record where the note exists.
Select the option for the appropriate note type:

e Actions>Notes for All to display the Class Notes form, or

e Actions>Notes for Current to display the Object Notes form; then click Attach/Detach
Reusable to display the System/User Notes form.

Select the note where you want to detach an external file.
Click Delete.

NOTE: Although you click the Delete button, this step does not delete the attached file. It deletes
the note and detaches the attached external file, but the attached file is not deleted from the
system.

Save and close the Notes forms as appropriate:

e From the Object Notes form, save the record and close the form.
o From the System/User Notes form, click OK to save and close the form.

If you attempt to delete a reusable note that is attached to one or more records, when you try
to close the System/User Notes form, the system displays an error and does not delete the
note. You must detach it from all records before deleting it.

e From the Class Notes form, click OK to save and close the form.

Printing Associated Notes

Many reports offer options to print associated notes. These notes are created by you or other people
on your system. The following general principles govern the printing of notes:

You can print notes attached to individual records (also known as object notes), including
reusable system notes but not user notes.

In certain cases, you can choose to print notes tagged as “internal,” "external," or both.
Notes tagged as Class Notes (also known as Notes for All) do not print with reports.
Attachments to notes do not print with reports.

For more information, see Working with Notes and Creating and Attaching Notes.
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Working with Document (File) Attachments

You can augment records for many forms by attaching documents (files) that are related to specific
records. You can also import documents that can then be attached by other users to records.

About Document Types

Before a document can be imported into the system and attached to a record, an authorized system
administrator must first create one or more document types, if they do not already exist. The
Document Types form is used to create document types.

When a document is then imported or attached, the document type is assigned to the document.
Because documents can be filtered based on document type, we recommend that you plan carefully
when you set up your document types. Do not make your types too generic--"Text files," for
example. Rather, cast your types according to the intended use for the document type--"Customer
POs," for example.

When a document type is created, a default file extension is assigned to it. This file extension is
overwritten if the document you import actually has a different file extension.

Importing and Attaching Documents

Only authorized users can import documents and attach them to records. Authorized users can
import, export, view, or delete documents with the Documents form. Within a form that allows
document attachments, they can also click the Display Docs icon on the toolbar, which opens the
Attached Documents form in a linked window. From within this form, they can import a new
document, or they can link to a document that has already been imported into the system. For more
information, see the "How To" related topics.

Availability of Attached Documents for Viewing and Reuse

Once a document has been approved, either by the person who submitted it or by another
authorized approver, it is then available for viewing by other individuals who are authorized to view
these documents. It is also available to other users for reuse or reattachment to other records. This
means that a single document can be attached to multiple records.

To view a list of and access all imported documents, use the Documents form. To view a list of and
access documents attached to specific records within a collection, use the Actions > Documents
for Current menu item to open the Attached Documents form populated for that record.
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Using the Application Event System to Attach and Manipulate Documents

Another option for attaching documents to records is to use an application event and event handler.
There are two ways to do this:

¢ Include documents attached to records when initiating those records for processing using the
application event system.

e Use the application event system to attach, link, or detach documents to records during the
course of processing in the application event system.

For more information and sample scenarios, see Using the Application Event System for Document
(File) Attachments and the Guide to the Application Event System.

Using the Application Event System for Document (File)
Attachments

The application event system provides two basic means to work with document attachments. You
can:

¢ Include documents attached to records when initiating those records for processing using the
application event system.

e Use the application event system to attach, link, or detach documents to records during the
course of processing in the application event system.

Including Documents Attached to Records

If you plan to use application events and event handlers with collections and records that can
already have document attachments, and you want to include those attached documents in
whatever action is taking place through the event handling, you can use the Attach event action
parameter in conjunction with a Notify, Prompt, or Send E-mail event action. This option allows you
to include all documents, only internal documents, all document other than internal documents, or
specified individual documents from the record being processed. You can also exclude all document
attachments from an event handler action.

Using the application event system capabilities, you can update (modify) or detach documents
already attached to records and included in such actions.

For more information and sample scenarios, see the Guide to the Application Event System.

Using the Application Event System to Process Document Attachments

You can use the application event system to attach, link, update, or detach documents during the
processing of an event handler. For these types of actions, use the Attach event action type as part
of the handler sequence.

For more information and sample scenarios, see the Guide to the Application Event System.
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Reference

This section of the Help is designed to provide quick references for many of the common features
and functions of the WinStudio interface. In this section, you can find information about:

o Keyboard Shortcuts - Arranged by functions and by key combinations

e Menus and Menu Options - Also offering equivalent keyboard shortcuts and toolbar options

e Toolbars and Toolbar Options - Also offering equivalent keyboard shortcuts and menu options

Keyboard Shortcuts

Many people prefer to use keyboard shortcuts to accomplish tasks whenever possible, because it is
often faster and easier than using a pointing device, such as a mouse.

The following tables list and describe the keyboard shortcuts available in this system:

¢ Form shortcuts - Shortcuts designed to help you at the form level, such as opening and saving
forms.

e Editing shortcuts - Shortcuts designed to help with editing actions and functions.

o Record/Collection shortcuts - Shortcuts designed to help you work with data in records.

o Navigation shortcuts - Shortcuts designed to help you navigate on and between forms.

There is also a table that presents all keyboard shortcuts grouped according to key combinations.

Form shortcuts

To do this Press Comments
Open a Ctrl+ O Opens the Select Form dialog box, which you can use to locate
form. and select the form you want to open.

For more information, see Finding and Opening Forms Using the
Select Form Dialog Box.

Save a Ctrl+ S Saves any changes, but does not close the form.
form. Any records that have been modified or marked for deletion are
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permanently modified or deleted when this shortcut is used.

Close a Ctrl + F4 Closes the current form window.

form. If you have made changes to any records, or if you have marked
any records for deletion, the system asks whether you want to
save the changes before closing the form window.

Get help F1 Brings up the online help in a separate window.

with the e [fthe focus is on an active field, this opens the help for the

]Eulr(rjent current field.

eld. e [f the focus is not on an active field, this opens the help for the

form.

Toggle Ctrl+ E Available only if you have the required editing permissions.

Design Use this key combination to enter or exit Design Mode for the

Mode active form.

on/off.

Regenerate Ctrl+ G Used in Design Mode only.

the form.

Unload all Ctrl+ U Used in Design Mode only.

global form

objects.

Editing shortcuts

To do this Press Comments

Undo an Ctrl+Z Works only for editing operations (cut/copy/paste). There is no

editing multiple undo, and you can only undo the operation while you are

operation. still in the field where you performed it. Once you move out of the
field, this shortcut no longer works. To undo changes made after
you move out of the field, use Ctrl + F5.

Cut text Ctrl + X As is common in most Windows programs, removes selected text

from a from a field, but keeps a copy of it on the system clipboard. This

field. allows you to paste the deleted text somewhere else.

Copy text Curl+C As is common in most Windows programs, copies any selected text

from a to the system clipboard. This allows you to paste the copied text
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field or somewhere else.

contents NOTE: If you are copying groups of cells within a grid and the last-
of grid selected cell is an editable field, this menu option and keyboard
cells. shortcut do not work. Instead, you must use the Ctrl + Insert key

combination to copy the selected cells to the system clipboard.

Paste text Ctrl+V As is common in most Windows programs, pastes the contents of
into a the system clipboard into the field where the cursor is.
field. You can use this option only in fields that allow you to enter text.

Record/Collection shortcuts

To do this Press Comments

Search for F4 Performs a Filter-in-Place search based on any filter criteria you

records entered into one or more fields. If you left all fields blank, the

using search retrieves all available records up to the cap.

Filter-in- For more information, see Finding Records with Filter-in-Place.

Place.

Clear a F4 If a form is displaying a collection, this option cancels the current

form so a filter-in-place and clears the form so you can perform a new

new search. The only fields that do not get cleared are the ones you last

search can used to perform a query.

be

performed.

Cancel F3 Available only if a form is not displaying a collection.

Filter-in- Cancels the current filter-in-place and returns the collection that

Place. was previously displayed. If no collection has yet been displayed,
this key displays the form in normal mode, but with no records
displayed.

For more information, see Finding Records with Filter-in-Place.

Clear filter F5 Available only when a form is not displaying a collection.

criteria. By default, when you clear the form (using F4), the system displays
the filter criteria used for the previous search. This option allows
you to clear all filter criteria that either you or the system previously
entered.

For more information, see Finding Records with Filter-in-Place.
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Search for Ctrl+Q (Available only from multiview forms.) Opens the query form

records associated with the multiview form.

using Filter For more information, see Finding Records Using a Query Form.

By Query.

Move the Ctrl + F8 In forms that display multiple collections, moves the focus to the

focus to next collection.

the next

collection.

Create a Ctrl + N Works only in collections. Inserts a new, blank record below

record. whichever record is currently selected.

Delete a Cul+D Works only in collections. Marks a record for deletion. (The record

record. is not actually deleted until you do a save operation.)

Refresh a Ctrl + F5 Reverts the selected record to its original value and removes any

single change or deletion indicators.

record. Use this to effectively undo a change or "undelete" a record.

Refresh F5 Available only when a collection is displayed. Refreshes the entire

the collection.

collection. If you have made changes to any records, or if you have marked
any records for deletion, the system asks whether you want to save
the changes before refreshing the collection. If you answer Yes,
the changes are saved and deletions are made permanent. If you
answer No, all values on the form revert to their original values.

Find a Ctrl+ F For more information about finding specific values for fields, see

value for a Finding a Specific Value in a Drop-down List.

drop-down

field.

Repeat the Ctrl + F2 Use this key combination to repeat a Find operation. This locates

Find. the next entry in the field that matches the specified criteria without
having to re-enter the criteria.

Find Ctrl + L For more information about finding details for field values, see

details for Finding Details about a Value in a Drop-down List.

avalue in

a drop-

down field.
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Add a new Ctrl+ A Allows you to create a new value for a drop-down field, and then
value to a have that new value returned to the field.
field. When you use this key combination, the system opens the
associated form. To see an abbreviated summary of the list value,
without having to open the associated form, press F2.
For more information about adding new values to fields, see
Adding a New Field Value.
Delete text DEL With the cursor in a field and text selected, you can use this key to
in a field. delete the selected text. This key works on any field in which you
can enter input.
NOTE: The text is not permanently deleted until you save the form.
So, if you need to undo the deletion before saving the form, you
can return the field to its original value by pressing Ctrl + F5.
Print a Ctrl+ P For more information about printing records and collections of
record or records, see Printing Records or Collections of Records.
collection
of records.
Toggle Ctrl +Shift Works only with multiview forms, query forms, or other forms in
detail-only +1 which there are split views.
view If both views (split view) or only the grid view is displayed, this
on/off. keypress combination displays only the detail view.
If only the detail view is displayed, this keypress combination
displays the split view.
Toggle Ctrl + Shift Works only with multiview forms, query forms, or other forms in
grid-only +2 which there are split views.
view If both views (split view) or only the detail view is displayed, this
on/off. keypress combination displays only the grid view.
If only the grid view is displayed, this keypress combination
displays the split view.
Get help F1 Brings up the online help for the selected field in a separate
with the window.
current
field.
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Navigation shortcuts

To do this Press Comments

Activate Ctrl + F8 In forms that display multiple collections, this keypress combination
the next moves the focus to the next collection.

collection.

Move to F8 or Works only when a record is selected in a collection. Moves the
next Down focus to the next record in the collection.

record. arrow

Move to F7 or Up Works only when a record is selected in a collection. Moves the
the arrow focus to the previous record in the collection.

previous

record.

Move the Home Works whether the field is editable or not.

cursor to

the

beginning

of a field.

Move the Ctrl + Wherever the focus is, this keypress combination moves the focus
cursor to Home to the first editable field for a record. On a multiview form, this

the moves the focus to the first active field (column) in the grid view.
beginning

of a

record.

Shift the F6 Works with multiview forms only.

focus on If the focus is on the grid side, shifts the focus to the detail side. If
the form. the focus is on the detail side, shifts the focus to the grid side.
Switch Ctrl + Tab These key combinations "cycle through” the open forms, moving
between OR the focus from one to the next.

open Ctrl + F6

forms.

Shortcuts Grouped by Key Combinations

e Function (F) keys and key combinations

e Ctrl + key combinations
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Function (F) keys and key combinations

Key

Combination Action Comments

F1 Get help Brings up the online Help in a separate window.
with the « If the focus is on an active field, this opens the Help for the
;:_ulr(;ent current field.
fl)erm or e If the focus is not on an active field, this opens the Help for the

' form.

Ctrl + F2 Repeats a Locates the next entry in the field that matches the specified
Find criteria without having to re-enter the criteria.
operation.

F3 Cancels a Available only if a form is displaying a collection.

Filter-in- Cancels the current filter-in-place and clears the form so you can
Place perform a new search.
search.

F4 Begins or If a form is displaying a collection, cancels the current filter-in-

executes place and clears the form so you can perform a new search.
a Filter-in- If the form has already been cleared, performs a Filter-in-Place
Place search based on any values you entered into one or more fields.
search. If you left all fields blank, the search retrieves all available records
up to the cap.
For more information, see Finding Records with Filter-in-Place.

Ctrl + F4 Closes If changes have been made to any records, or if any records
the have been marked for deletion, the system asks whether you
current want to save the changes before closing the form window.
form
window.

F5 Refreshes If a collection is being displayed and you have made changes to
the entire any records, or if you have marked any records for deletion, the
collection; system asks whether you want to save the changes before
OR refreshing the collection. If you answer Yes, the changes are

saved and deletions are made permanent. If you answer No, all
Clears the S
filter values on the form revert to their original values.
criteria. If no collection is being displayed, clears any filter criteria that

139



Infor Mongoose Basic Concepts User Guide

have been entered into the fields.

Ctrl + F5 Refreshes Reverts the selected record to its original value and removes any
a single change or deletion indicators.
record. Use this to effectively undo a change or "undelete" a record.
F6 Shifts the Works with multiview forms only.
focus on If the focus is on the grid side, shifts the focus to the detail side. If
the form. the focus is on the detail side, shifts the focus to the grid side.
Ctrl + F6 Switches "Cycles through" the open forms, moving the focus from one to
between the next.
open
forms.
F7 Moves to Works only when a record is selected in a collection. Moves the
the focus to the previous record in the collection.
previous
record.
F8 Moves to Works only when a record is selected in a collection. Moves the
next focus to the next record in the collection.
record.
Ctrl + F8 Moves to In forms that display multiple collections, moves the focus to the
the next next collection.
collection.

Ctrl + key combinations

Key
Combination Action Comments
Ctrl+1 Toggles Works only with multiview forms, query forms, or other forms in
detail-only which there are split views.
view on/off. If both views (split view) or only the grid view is displayed, this
keypress combination displays only the detail view.
If only the detail view is displayed, this keypress combination
displays the split view.
Ctrl + 2 Toggles Works only with multiview forms, query forms, or other forms in
grid-only
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view on/off. which there are split views.
If both views (split view) or only the detail view is displayed,
this keypress combination displays only the grid view.
If only the grid view is displayed, this keypress combination
displays the split view.

Ctrl + F2 Repeats a Locates the next entry in the field that matches the specified
Find criteria without having to re-enter the criteria.
operation.

Ctrl + F4 Closes the If changes have been made to any records, or if any records
current form have been marked for deletion, the system asks whether you
window. want to save the changes before closing the form window.

Ctrl + F5 Refreshes a Reverts the selected record to its original value and removes
single any change or deletion indicators.
record. Use this to effectively undo a change or "undelete" a record.

Ctrl + F6 Switches "Cycles through" the open forms, moving the focus from one to
between the next.
open forms.

Ctrl + F8 Moves to the In forms that display multiple collections, moves the focus to
next the next collection.
collection.

Ctrl+ A Adds a new Allows you to create a new value for a drop-down field, and
value to a then have that new value returned to the field.
field. For more information about adding new values to fields, see

Adding a New Field Value.

Ctrl+C Copies text As is common in most Windows programs, copies any

Ctrl + Insert from a field selected text to the system clipboard. This allows you to paste

(Alternative or contents the copied text somewhere else.

for grid cells) of a grid cell. NOTE: If you are copying groups of cells within a grid and the

last-selected cell is an editable field, the Ctrl + C keyboard
shortcut does not work. Instead, you must use the Ctrl + Insert
key combination to copy the selected cells to the system
clipboard.

Ctrl+D Marks a Works only in collections. The record is not actually deleted
record for until you do a save operation.
deletion.

141



Infor Mongoose Basic Concepts User Guide

Ctrl + E

Toggles
Design
Mode on/off.

Available only if you have the correct editing permissions.

Use this key combination to enter or exit Design Mode for the
active form.

Ctrl + F

Initiates a
search for a
specific
value for a
field.

For more information about finding specific values for fields,
see Finding a Specific Value in a Drop-down List.

Ctrl + G

Regenerates
the form.

Used in Design Mode only.

Ctrl + L

Finds details
for a value in
a drop-down
field.

When you
use this key
combination,
the system
opens the
associated
form. To see
an
abbreviated
summary of
the list
value,
without
having to
open the
associated
form, press
F2.

For more information about finding details for field values, see
Finding Details about a Value in a Drop-down List.

Ctrl + N

Creates a
record.

Works only in collections. Inserts a new, blank record below
whichever record is currently selected.

Ctrl + O

Opens a
form.

Opens the Select Form dialog box, which you can use to
locate and select the form you want to open.

For more information, see Finding and Opening Forms Using
the Select Form Dialog Box.
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Ctrl+ P Prints a For more information about printing records and collections of
record or records, see Printing Records or Collections of Records.
collection of
records.

Ctrl + Q Allows you (Available only from multiview forms.) Opens the query form
to search for associated with the multiview form.
records For more information, see Finding Records Using a Query
using Filter Form.

By Query.

Ctrl+ S Saves a Saves any changes, but does not close the form.

form. Any records that have been modified or marked for deletion
are permanently modified or deleted when this shortcut is
used.

Ctrl+ U Unloads all Used in Design Mode only.
global form
objects.

Ctrl+V Pastes text As is common in most Windows programs, pastes the contents
into a field. of the system clipboard into the field where the cursor is.

You can use this option only in fields that allow you to enter
text.

Ctrl + X Cuts text As is common in most Windows programs, removes selected
from a field. text from a field, but keeps a copy of it on the system

clipboard. This allows you to paste the deleted text somewhere
else.

Ctrl+Z Undoes an Works only for editing operations (cut/copy/paste). There is no
editing multiple undo, and you can only undo the operation while you
operation. are still in the field where you performed it. Once you move out

of the field, this shortcut no longer works. To undo changes
made after you move out of the field, use Ctrl + F5.

Ctrl + Home Moves the Wherever the focus is, this keypress combination moves the
cursor to the focus to the first editable field for a record. On a multiview
beginning of form, this moves the focus to the first active field (column) in
a record. the grid view.

Ctrl + Tab Switches "Cycles through" the open forms, moving the focus from one to
between the next.
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open forms.

Miscellaneous other keys

Key

Combination Action Comments

Up Arrow Moves to With focus in a collection and a record selected, moves the
the focus to the previous record in the collection.
previous In a drop-down list, when you tab into the list field, or with the
record. list showing, selects the previous item in the list.

In a date field, with the calendar drop-down showing, regresses
the date by one week.
In a text field, behaves like the Left Arrow key.

Down Arrow Moves to With focus in a collection and a record selected, moves the
next focus to the next record in the collection.
record. In a drop-down list, when you tab into the list field, or with the

list showing, selects the next item in the list.

In a date field, with the calendar drop-down showing, advances
the date by one week.

In a text field, behaves like the Right Arrow key.

Left Arrow Moves to In a grid, moves the focus to the previous field in the record.
previous In a date field, with the calendar drop-down showing, regresses
field or the date by one day.
character. . .

In a text or other input field, moves the cursor to the left one
character position.

Right Arrow Moves to In a grid, moves the focus to the next field in the record.
next field In a date field, with the calendar drop-down showing, advances
or the date by one day.
character. . ' .

In a text or other input field, moves the cursor to the right one
character position.

Delete Marks In fields, deletes the selected text. Works only for fields in
selected which you can make changes and select input.
text ora The text is not permanently deleted until you save the form. So,
record for . . .
deletion. if you need to undo the deletion before saving the form, you

can return the field to its original value by pressing Ctrl + F5.
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¢ In collections, marks the selected record for deletion. The
record is not actually deleted until you do a save operation.

¢ In Design Mode, deletes the selected component.

Home Moves the ¢ In an editable field, moves the cursor to the beginning of a field.
cursor to In a display-only field, moves the cursor to the first column in
the the grid.
beginning e In conjunction with the CTRL key (Ctrl + Home), if in a grid,
of a field moves the cursor to the first active column in the record (in
or record. which you can make a change). In a detail view or other type of

form, moves the cursor (and the focus) to the first active field in
the form.

Page Down Advances Works only in grids.
the If all available records fit in one view, moves to the last record.
records
displayed
by one
set.

Page Up Regresses Works only in grids.
the If all available records fit in one view, moves to the first record.
records
displayed
by one
set.

Menus

Menus

Most of the tasks you need to accomplish can be done by using one or more of the menus. The
placement of these menus depends on what theme you are using (see About Themes).

These topics provide information about each of the standard menus, in table format, to help you
more quickly locate and use the option you need:

e The Form menu includes options for working with forms, including opening, closing, creating,

editing, and saving forms.

e The Actions menu provides options that deal mostly with records and collections of records.
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e The Edit menu provides options for editing content in forms as well as for editing the forms
themselves.

e The View menu includes a number of options for showing or hiding various elements of the user
interface.

e The Window menu includes options for working with windows when you have multiple forms
open.

e The Help menu provides a number of options for accessing the online help, as well as for getting
information about the system software and any form you might have open.

Form Menu

The Form menu includes options for working with forms, including opening, closing, editing, and
saving forms.

Menu option Sl Action Keyboard
option shortcut
Open Opens the Select Form dialog box, which Ctrl+ O

you can use to locate and select the form
you want to open.

For more information, see Finding and
Opening Forms Using the Select Form
Dialog Box.

For an alternate way of opening forms, see
Finding and Opening Forms Using the
Explorer.

Print Opens the Print Options dialog box, from Ctrl+ P
which you can print a record or a collection
of records.

For more information, see Printing Records
or Collections of Records.

Print Preview Opens both the Print Options dialog box
and the Print Preview dialog box. Use
these dialog boxes to generate a preview
before actually printing.

For more information, see Previewing a
Record or Collection Before Printing.

Print Setup Opens the Page Setup dialog box, which
allows you to set printer options before
printing.
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Export to File

Opens the Export Collection to File
dialog box.

Use this option to export data from a
collection to an external file that can be
used in another program, such as a
spreadsheet.

For more information, see Exporting
Collections to External Files.

Close and Save Changes

Saves any changes made and then closes
the form. If any records were marked for

deletion, permanently deletes those

records.

Close and Cancel Changes

Closes the form without saving changes.
Any records that have been changed revert

to their original values. Any records

marked for deletion are not deleted and are

no longer marked for deletion.

Available only in Design mode.

Opens a wizard in which you can create a
new form.

Available only if you have the required
editing permissions.

Use this command to select and open a
form you want to edit.

Available only in Design mode. Ctrl+ S

Save changes to forms and global objects.

Available only in Design mode.

Delete the current form that is open in
Design mode. If a form is not open in
Design mode, the command opens a
dialog box in which you can select the form
you want to delete.

Definition New
Most of
these options
are for Desi
Design mode esign
and can be
used only if
you have
appropriate
Edltlng Save
permissions.
Delete
Copy

Available only in Design mode.

Use this command to make a copy of a
form.
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Edit Template Available only in Design mode.

Use this command to select a form
template to edit.

Copy Template Available only in Design mode.

Use this command to make a copy of a
form template.

Unload All Available only if you have the required Ctrl+ U
Global Form editing permissions. The action can be
Objects performed in either runtime or design

mode.

If you have changed your editing scope,
you can use this command to clear forms
and global form objects from memory.
Otherwise, you might access forms and
global form objects that pertain to your
previous editing scope instead of your new
one.

The command can clear the IDO metadata
cache. Clearing the cache is useful in IDO
development. To enable this option, select
Unload IDO metadata along with global
objects in the Settings window (on the
View menu, click Settings, and then click

Run Time).
Site Developer Available only if you have site developer
Impersonation editing permissions.

Use this command to specify whether you
are creating user versions, group versions,
or site versions of forms and global
objects.

Workspaces Opens the Workspaces dialog box, which
you can use to define, save, change, and
delete workspaces.

For more information, see Using
Workspaces.

New Sign In Opens the Sign In dialog box with the
current user ID and configuration filled in.

You can sign in to a different configuration
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from the current configuration. You may
also sign in with a different user ID.

Exit Exits the system, closing the software and
WinStudio all forms.
Recent Displays a list of most recently opened
forms forms, arranged in reverse chronological

order.

To re-open these forms quickly, without
having to search for them again, click the
form you want to open.

Actions Menu

The Actions menu provides options that deal mostly with records and collections of records. It
includes entries for locating records, navigating through collections, and other features related to
records.

This menu is available only if you have at least one form open.

Menu Submenu Action Keyboard
item item shortcut
Refresh Redisplays the selected collection using the current F5

filtering criteria.

This option reverses any changes made to records in the
collection and restores fields to their original values. Any
records marked for deletion are unmarked and revert to
their original values.

To avoid refreshing the wrong collection or subcollection
when multiple collections are displayed, make sure the
cursor focus is on the collection or subcollection you want
to refresh before selecting this option.

Refresh Current Redisplays the selected record and restores the field to Ctrl + F5
its original value.

To avoid refreshing the wrong record, make sure the
cursor focus is on the record you want to refresh before
selecting this option.
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Filter By Query Opens the query form associated with the current Ctrl+ Q
multiview form, which allows you to perform an advanced
search for forms.

For more information, see Finding Records Using a

Query Form.
Begin in When a collection is being displayed, this option is used F4
Place to clear the form so you can define the criteria for a new

search.

For more information, see Finding Records with Filter-in-

Place.
Execute When no collection is being displayed on the form, this F4
in Place option is used to start a search based on the specified

filter criteria. The system displays the records that match
the specified criteria as the current collection.

For more information, see Finding Records with Filter-in-

Place.
Cancel in When no collection has yet been displayed, this option F3
Place places the form in Filter-in-Place mode, in effect

displaying the active form with no collection displayed.

When a collection has been displayed and then the form
cleared using the Begin in Place (F4) option, this option
returns the previously displayed collection without
requerying the database.

Clear in When setting up for an initial search, you can use this F5
Place option to clear any filter criteria you might have entered
and start over.

When a collection has been previously displayed and
then cleared using the Begin in Place (F4) option, the
system by default displays the filter criteria used for the
previous search. This option clears all filter criteria so you
can initiate a new set of filter criteria.

Apply Opens the Select Filter dialog box, which allows you to
Saved select a saved filter to apply to the current form.
Filter For more information about saving filters and using them,

see Understanding Filters.

Open (Available only with query forms) Opens the Select Filter
dialog box, from which you can select the filter you want
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to open. When the filter "opens" it simply populates the
guery form with the saved search criteria.

Once open, you can change search criteria and resave,
either by saving over the old one (using the same name)
or saving it as a new filter.

Save

(Available only with query forms) Opens the Specify
Filter Name dialog box, in which you assign a name to
the filter you are saving.

Delete

(Available only with query forms) Opens the Select Filter
dialog box, from which you can select the filter you want
to delete.

Next

Moves the focus to the next record in the current
collection.

F8

Previous

Moves the focus to the previous record in the current
collection.

F7

First

Moves the focus to the first record in the current
collection.

Last

Moves the focus to the last record in the current
collection.

Get More Rows

Retrieves the next set, or "bunch," of records in the
collection.

The size of the bunch is determined by the data record
cap settings.

Ctrl + M

New

Creates a new, blank record below the currently selected
record.

For more information, see Adding Records.

Ctrl + N

Copy

Makes a copy of the current record and inserts it
immediately below that record. Marks it as a new record

(n).

Save

Saves any changes to the current collection without
closing the form. Any records marked for deletion are
permanently deleted and removed from the collection.

Ctrl+ S
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Save Current

Saves only changes made to the currently selected
record. If the record is marked for deletion, deletes the
record permanently and removes it from the collection.

Delete Marks the selected record for deletion. Ctrl +D
Note that the record is not actually deleted and removed
from the database until you save the form or save the
current record.
Validate Checks all fields in the currently selected record to make
sure they contain valid values.
If invalid values are found, the system presents a
message that tells you which field contains an error and
displays an (e) in the row label.
Once all values are found to be valid, the (e) indicator no
longer displays in the row label.
Notes for All Opens the Class Notes form, from which you can view,

attach, or detach notes that pertain to the entire collection
of records.

For more information, see Working with Notes.

Notes for Current

Opens the Object Notes form, which allows you to view,
create, attach, and detach notes for the current record.

For more information, see Working with Notes.

Documents for
Current

Opens the Attached Documents form, which allows you
to view, attach, and remove file attachments for the
current record.

For more information, see Working with File Attachments.

Graph

Opens the first page of the Graph Collection wizard,
which you can use to generate a graph based on data
from the current collection.

For more information, see Creating and Formatting
Graphs from a Collection.

To Excel

Opens a Microsoft Excel worksheet (or other application
set to open .csv files) containing data exported from the
current collection.

For more information, see Saving a Collection to

152



Reference

Microsoft Excel.

To Form DataView Sends the current data collection to a DataView,
displayed on the DataView Form Results form.

For more information, see About DataViews.

View Event Status Opens the Event Status form for collections that have the
InWorkflow property set to "1".

The InWorkflow property gets set when an event handler
executes against an update or deletion of an object with
the Suspend option enabled.

Get Options (Available only with some report, activity, and utility
forms) Opens the Get Options dialog box, which allows
you to apply a set of stored criteria for record retrieval to
the form.

For example, suppose you have a particular report that
you run on a daily basis, using the same criteria for
record retrieval. Rather than have to set up the same
criteria every time you want to run the report, you can set
it up once, and then, before running it, store the options
(see next menu item, Store Options).

Then, use this option to apply the same set of search
criteria to the form the next time you want to run the
report.

Store Options (Available only with some report, activity, and utility
forms) Opens the Store Options dialog box, which allows
you to save a set of search or retrieval criteria.

For example, suppose you have a particular report that
you run on a daily basis, using the same criteria for
record retrieval. Rather than have to set up the same
criteria every time you want to run the report, you can set
it up once, and then, before running it, select this option.

Then, to apply it, use the Get Options option (see
previous menu item).

Background (Available only with some report, activity, and utility
forms) Opens the Background Queue dialog box, which
you can use to schedule the report, activity, or utility to
run automatically.

For example, suppose you have a particular report that
you run on a daily basis, using the same criteria for
record retrieval. Rather than have to run the report
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manually every day, you can use this option to schedule
the report to run automatically at the time you designate.

For more information, see Background Queue.

Where Used (Available only with certain grid forms) Opens a linked
Where Used form that shows where a particular value
from the grid form is used elsewhere in the system.

View Amounts (Available only on some utilities) Generates a report
preview that shows the total value of the selected
invoices.

Edit Menu

The Edit menu provides options for editing content in forms as well as for editing the forms
themselves.

NOTES:

¢ Many form editing options are accessible to you only if you have the appropriate editing
permissions.

e Forms cannot be edited from the Web client version.

Menu item _Submenu Action S
item shortcut
Undo Undoes the last editing change you made. Ctrl+Z

Works only for editing operations (cut/copy/paste).
There is no multiple undo, and you can only undo
the operation while you are still in the field where
you performed it. Once you move out of the field,
this option no longer works. To undo changes
made after you move out of the field, use Refresh,
Ctrl + F5.

Cut Cuts text from a field. Ctrl + X

As is common in most Windows programs,
removes selected text from a field, but keeps a
copy of it on the system clipboard. This allows you
to paste the deleted text somewhere else.
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Copy

Copies the contents of the selected field.

As is common in most Windows programs, copies
any selected text to the system clipboard. This
allows you to paste the copied text somewhere
else.

NOTE: If you are copying groups of cells within a
grid and the last-selected cell is an editable field,
this menu option and keyboard shortcut do not
work. Instead, you must use the Ctrl + Insert key
combination to copy the selected cells to the
system clipboard.

Ctrl + C

Paste

Pastes text into a field.

As is common in most Windows programs, pastes
the contents of the system clipboard into the field
where the cursor is.

You can use this option only in fields that allow you
to enter text.

Ctrl + V

Paste Rows Append

Pastes records (rows) from the system clipboard,
inserting them just below the currently selected
record.

For more information about pasting records from
external files, see Copying Data To/From a
Spreadsheet.

n/a

Paste Rows Overwrite

Pastes records (rows) from the system clipboard
into the collection, overwriting existing records
starting with the currently selected record.

For example, if you are pasting in three rows worth
data, and your currently selected row is the fourth
row, this option overwrites the records currently
existing in rows 4, 5, and 6.

For more information about pasting records from
external files, see Copying Data To/From a
Spreadsheet.

n/a

Find Value in Collection

Opens the Find dialog box, which allows you to
search through a collection for a specified value in
a particular field.

For more information, see Finding a Value in a
Collection of Records.

n/a
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Repeat Find

Repeats the search as performed in Find Value in
Collection (see previous menu item).

Ctrl + F2

Replace Value in
Collection

Opens the Replace dialog box, which allows you
to search through a collection for a specified value
in a particular field and then replace the current
value with a new value that you provide.

For more information, see Replacing a Value in a
Record.

n/a

Sort Collection

Opens the Sort dialog box, which allows you to
sort a collection according to criteria you specify in
this dialog box.

For more information, see Sorting Collections.

n/a

Find Value for Current
Field

Allows you to perform a search for a specified
value in a particular field and, optionally, return that
value to the original field.

For more information, see Finding a Specific Value
in a Drop-Down List.

Ctrl + F

Add Value for Current
Field

Allows you to create a new value for a particular
field and, optionally, return that value to the original
field.

For more information, see Adding a New Field
Value.

Ctrl + A

Details for Current Field

Allows you to view details about the value in a
particular field.

For more information, see Finding Details about a
Value in a Drop-down List.

Ctrl + L

Import Binary Data for
Current Field

Active only for fields which can contain graphics or
other binary data objects.

When active, allows you to import a graphics file or
other binary data object into the field.

For more information, see Graphics and Other
Binary Objects in Fields.

Export Binary Data from
Current Field

Active only for fields which can contain graphics or
other binary data objects.

When active, allows you to export a graphics file or

n/a
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other binary data object from the field.

For more information, see Graphics and Other
Binary Objects in Fields.

Delete Binary Data from Active only for fields which can contain graphics or n/a
Current Field other binary data objects.

When active, allows you to delete a graphics file or
other binary data object from the field.

For more information, see Graphics and Other
Binary Objects in Fields.

View Binary Data for Active only for fields which can contain graphics or n/a
Current Field other binary data objects.

When active, allows you to view a graphics file or
other binary data object using the operating system
program designated to view files of that format.

For more information, see Graphics and Other
Binary Objects in Fields.

Design Mode Available only if you have the required editing n/a
permissions.

Enters or exits Design Mode.

What you can do in Design Mode depends on your
editing permissions.

Revert Form Definition Cancels changes to the form and any associated n/a
global form objects and restores another version
according to the following hierarchy:

e A user version reverts to a group version (if one
exists).

e A group version reverts to a site version (if one
exists).

e A sijte version reverts to the default version.

Regenerate Form Active only in Design Mode. Cirl+ G

Saves the form, including any changes made,
closes the form, and then automatically reopens
the form so that the changes are reflected and

displayed.
Create Form Template Creates a form template based on the current n/a
from This Form form. This template can then be used repeatedly to
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create similar new forms.

Form Properties Active only in Design Mode. n/a
Displays the Form properties tab, which allows you
to view and edit form properties.
Component Edit Active only in Design Mode. n/a
Selected Displays the Component properties tab, populated
with the properties of the selected component. This
allows you to view and edit the properties of the
selected component.
Delete Active only in Design Mode. n/a
Selected Deletes the selected component. If the component
contains any objects or other components within it,
these are also deleted.
Set Active only in Design Mode. n/a
Current Makes this form page the current one for this form.
Form
Page
Tab Active only in Design Mode. n/a
Order Toggles on/off the view in which you can set the
order in which fields should receive focus as the
user navigates through the forms using the TAB
key.
Tab Active only in Design Mode. n/a
Order at Resets the tab order beginning with the selected
component. Any components that already have a
tab order ahead of the selected component are not
changes.
Adjust Active only in Design Mode. n/a
Grid Adjusts all grids in the current form so that the
right-most grid column fits within the specified grid
dimensions. This adjustment eliminates extra
space and any unnecessary horizontal scroll bars.
Component Class Active only in Design Mode. n/a

Opens the Component Class dialog box, which
allows you to select, view, add, modify, and delete
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component classes.

Event Handlers

Active only in Design Mode. n/a

Opens the Event Handlers dialog box, which
allows you to select, view, add, modify, and delete
event handlers.

Property Class Extension

Active only in Design Mode. n/a

Opens the Property Class Extension dialog box,
which allows you to select, view, add, modify, and
delete property class extensions.

Script

Active only in Design Mode. n/a

Opens the Scripts dialog box, which allows you to
select, view, add, modify, and delete scripts.

Short-Cut Menu

Active only in Design Mode. n/a

Opens the Short-Cut Menus dialog box, which
allows you to select, view, add, modify, and delete
shortcut menus.

String

Active only in Design Mode. n/a

Opens the Strings dialog box, which allows you to
select, view, add, modify, and delete character
strings.

Validator

Active only in Design Mode. n/a

Opens the Validators dialog box, which allows you
to select, view, add, modify, and delete validators.

Variable

Active only in Design Mode.

Opens the Variables dialog box, which allows you
to select, view, add, modify, and delete variables.

Theme

Active only in Design Mode. n/a

Opens the Themes dialog box, which allows you to
copy, edit, or delete a theme. You can also create
a new theme. You can only delete user-created
themes. The Theme Editor is displayed for some
functions. For more information about the Theme
Editor, see Theme Editor.
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Filter Edit Active only in Design Mode. n/a

Opens the Select Filter dialog box, which allows
you to select a filter to edit.

Edit Active only in Design Mode. n/a
Current

Script Editor Opens the Edit Form Script dialog box, allowing n/a
you to edit the code associated with the current
form or object.

If you have Visual Studio installed on your
computer, and you have the appropriate Visual
Studio option selected in the Settings window,
this option opens the Visual Studio application.
Otherwise, if the WinStudio option is selected in
the Settings window, the WinStudio native script
editor window opens.

View Menu

The View menu includes a number of options for showing or hiding various elements of the user
interface.

Keyboard

Menu item Action shortcut
Diagnostics Opens and closes the Diagnostics window, which is used n/a

for debugging and other analytic tasks.
Explorer Opens and closes the Explorer window, which is used to n/a

access forms.

For more information, see Using the Explorer.
Settings Opens the Settings window. n/a

NOTE: You cannot use this option to close the Settings
display. To close the Settings window, you must use the
Close (x) button in the upper-right corner of the main
workspace.

This is where you can set your own user preferences. This
window also includes options for setting editing and
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diagnostics preferences.
For more information, see Setting Preferences.

Inbox

If the Inbox form is not open, this option opens it. If the
form is open, this option brings it to the top and refreshes
the display.

This menu option generates a standard event,
StdAppLaunchinbox. Developer users can generate or
intercept this event.

n/a

Task

If the Create User Task form is not open, this option opens
it. If the form is open, this option brings it to the top.

This menu option generates a standard event,
StdAppLaunchTask. Developer users can generate or
intercept this event.

n/a

Status Bar

Shows or hides the status bar.

The messages on the status bar display information about
your current actions. For example, if the form you opened
has a note, the status bar displays NOTES.

n/a

System Notes

Opens the System User Notes form, which allows you to
create, read, and maintain reusable notes.

For more information, see Working with Notes.

n/a

Toolbar

Shows or hides the main toolbar.

n/a

Activate Next
Collection

In forms that display multiple collections, this option moves
the focus from one collection to the next.

CTRL+F8

Home Cursor

In a grid, moves the cursor to the first active column in the
record (in which you can make a change). In a detail view
or other type of form, moves the cursor (and the focus) to
the first active field in the form.

CTRL+HOME

Default Size

For forms that you have changed the size (by dragging one
or more borders), this option restores the form to its default
size.

n/a

Hide/Show 1st
Splitter Pane

Toggles the grid view on/off.

This option works only with multiview forms, query forms, or

other forms in which there are both grid views and detail
views.

Ctrl+Shift+1
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Hide/Show Toggles the detail view on/off. Ctrl+Shift+2
2nd Splitter This option works only with multiview forms, query forms, or
Pane other forms in which there are both grid views and detail

views.
Activate Pane This option works only with multiview forms, query forms, or F6
1 other forms in which there are both grid views and detail

views.
Activate Pane This option works only with multiview forms, query forms, or F6
2 other forms in which there are both grid views and detail

views.
Warning Opens the Warning Messages dialog box, which allows n/a
Messages you to view active warning messages for a form and correct

problems before saving and closing the form.

Window Menu

The Window menu includes options for working with windows when you have multiple forms open.
These options affect only form windows, and not the system windows, such as the Explorer,
Settings, and Diagnostics windows.

Menu item Action

Cascade Arranges all open form windows in a typical cascade arrangement.

Tile Arranges all open form windows in a tiled arrangement.
The system attempts to space all windows evenly, first horizontally, then vertically.

Close All Closes all form windows, including those that are minimized.

The system prompts you to save or cancel any changed data. If a form is open to
find, add, or filter records into a parent form, the system gives you the option to
return values to the parent form or not to return them.

Open At the bottom of this menu, the system displays a list of all the forms currently
form list open, in the order in which they were opened. The current active form (that has
the focus) has a check mark in front of it.

You can use this list to quickly select the form you want.
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The Help menu provides a number of options for accessing the online help, as well as for getting
information about the system software and any form you might have open.

NOTE: All help topics display in the current default Web browser for your system.

Menu option

Description/Comments

Contents and Index

Opens the online help in its own browser window, displaying the
Contents in the left pane and the initial help topic in the right pane

This can be especially useful when you want to:
e Browse help topics for general learning purposes

e Use the Index or Search functions to find information about a specific
topic or feature

Current Form

Opens the online help to the topic for the currently active form

Current Field

Opens the online help to the topic for the currently selected field or other
component

About Application

Opens an informational window that presents information for the
application you are using:

e Copyright notice
e Database configurations
e Your user login ID and editing permissions

About This Form

Opens the About This Form information window, which presents this
information:

e The name and original caption of the form

e The version of the form

¢ The name of the parent form, if any

e Which collection is currently selected

e The name of any permanent or user-defined filters in use

163



Infor Mongoose Basic Concepts User Guide

Toolbars

Toolbars

The system interface has two toolbars available:

e The main toolbar includes options (and buttons) for performing many of the most common

actions.

e The alignment toolbar is available only in Design mode and includes options for placing

components on forms.

Main Toolbar

The main toolbar includes tools to help you accomplish the most common tasks.

This toolbar displays just underneath the menu bar. You can choose to display the toolbar or not.

This table lists and describes the main toolbar options.

Menu Keyboard
Icon tooltip Description/Comments equivalent shortcut
Open a form Opens the Select Form dialog box, which Form > Open Ctrl+ O
you can use to locate and select the form
you want to open.
For more information, see Finding and
Opening Forms Using the Select Form
Dialog Box.
For an alternate way of opening forms, see
Finding and Opening Forms Using the
Explorer.
Save Saves the form and any changes you have Form > Ctrl+ S
made to the form, but does not close the Definition >
form. Save
OR
Actions > Save
Save modified Saves any changes made and then closes Form > Close n/a
data and close the form. If any records were marked for and Save
form (OK) deletion, permanently deletes those Changes
records.
Close form, Closes the form without saving changes. Form > Close n/a
canceling Any records that have been modified and Cancel
unsaved revert to their original values. Any records
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changes

marked for deletion are not deleted and
are no longer marked for deletion.

Changes

Create a new Creates a new, blank record below the Actions > New Ctrl + N
object in the currently selected record.
current For more information, see Adding
collection Records.
Delete an Marks the selected record for deletion. Actions > Ctrl+D
object in the Note that the record is not actually deleted ~ Delete
current and removed from the database until you
collection save the form or save the current record.
Refresh the Requeries and displays the selected Actions > F5
current collection using the current filtering criteria.  Refresh
collection This option reverses any changes made to
records in the collection and restores fields
to their original values. Any records
marked for deletion are unmarked and
revert to their original values.
To avoid refreshing the wrong collection or
subcollection when multiple collections are
displayed, make sure the cursor focus is
on the collection or subcollection you want
to refresh before selecting this option.
Discard Reverts the selected record to its original Actions > Ctrl + F5
changes for the  value. Refresh
current object, o avoid refreshing the wrong record, Current
and reload make sure the cursor focus is on the
original values record you want to refresh before selecting
this option.
Filter In Place When on, opens the current form with Actions > F4
Filter-in-Place, which allows you to filter for ~ Filter > Begin
specific forms. This option clears them, so in Place
you can define a new search. OR
For more information, see Finding Records ~ Actions >
with Filter-in-Place. Filter >
After you use Filter-in-Place to identify the E:(:Cceute n

records you want to locate, use this option
to start the search. The system displays
the records that match the specified
criteria as the current collection.

For more information, see Finding Records
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with Filter-in-Place.

View event When enabled, opens the Event Status Action > View n/a
status form, which allows you to check the Event Status

current status of events that are running,

among other things.
Go to the first Moves the focus to the first record in the Actions > First n/a
object in the current collection.
current
collection
Go to the Moves the focus to the previous record in Actions > F7
previous object the collection. Previous
in the current
collection
Go to the next Moves the focus to the next record in the Actions > Next F8
object in the collection.
current
collection
Go to the last Moves the focus to the last record Actions > Last n/a
object in the currently displayed in the collection.
current
collection
Get more rows Retrieves the next set of records in the Actions > Get Ctrl + M
in the current collection. More Rows
collection The size of the set is determined by the

data record cap settings. For example, if

the record cap is set to 200, then a query

returns only the first 200 records in the

collection. Clicking this icon retrieves the

next 200 records, and so on.
Perform find for ~ Allows you to perform a search for a Edit > Find Curl+F
the current specified value in a particular field and, Value for
field's value optionally, return that value to the original Current Field

field.

For more information, see Finding a

Specific Value in a Drop-Down List.
Perform add for  Allows you to create a new value for a Edit > Add Ctrl+ A
the current particular field and, optionally, return that Value for

field's value

value to the original field.
For more information, see Adding a New

Current Field
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Field Value.
Perform details Allows you to view details about the value Edit > Details Ctrl+ L
for the current in a particular field. for Current
field's value For more information, see Finding Details Field

about a Value in a Drop-down List.
Display notes Opens the Object Notes form, which Actions > n/a
for the current allows you to view, create, attach, and Notes for
object detach notes for the current record. Current

For more information, see Working with

Notes.
Display Opens the Attached Documents form, Actions > n/a
documents for which allows you to view, attach, and Documents for
the current remove file attachments for the current Current
object record.

For more information, see Working with

File Attachments.
Exportthe data ~ Opens a Microsoft Excel worksheet (or Actions > To n/a
in the current other application set to open .csv files) Excel
collection to containing selected data exported from the
Excel current collection.

For more information, see Saving a

Collection to Microsoft Excel.
Send the data Opens the DataView Form Results form, Actions > To n/a
in the current with the data from the current collection Form DataView
collection to a displayed.
DataView For more information, see About

DataViews.
Run Opens the DataSearch form, which allows n/a n/a
DataSearch you to search for specific data within all

records in the current collection.

For more information, see Searching the

System with DataSearch.
Enter or exit Toggles back and forth between Design Edit > Design Ctrl+ E
Design Mode Mode and Runtime Mode. You must be in Mode
on this form Design Mode to customize and develop

forms.
Regenerate Active only in Design mode. Edit > Cirl+ G
form: Save Saves the form definition, including any Regenerate
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form definition, changes made, closes the form, and then Form

close form, and  automatically reopens the form so that the

re-open it changes are reflected and displayed.

Gethelponthe  Opens the online help to the topic for the Help > Current F1

current form currently active form Form (with the
focus not in
a field or
other
component)

Alignment Toolbar (Design Mode)

This toolbar is available only in Design Mode. It includes options for aligning form components, both
with respect to other components and to the form itself.

The following table shows and describes the main toolbar options.

Action Description/Comments

Snap to grid Adjusts the size of the current component to the nearest grid dimensions that
match the grid size settings.

The grid size settings are made on the Design Time tab of the Settings
window. For more information, see Design Time Settings.

Align left Aligns all selected components so that their left edges line up.

This option is available only when multiple components are selected. To
select multiple components, CTRL-click the components you want to align.

Components line up with whichever component has solid black squares for
handles. To select the component which the other components should line up
with, after selecting all components to be aligned (by CTRL-clicking them),
click the one you want the others to line up with. The handles of this
component should be solid black, and all others should be black-outlined
handles.

Align center Aligns all selected components so that their horizontal centers line up.

This option is available only when multiple components are selected. To
select multiple components, CTRL-click the components you want to align.

Components line up with whichever component has solid black squares for
handles. To select the component which the other components should line up
with, after selecting all components to be aligned (by CTRL-clicking them),
click the one you want the others to line up with. The handles of this
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component should be solid black, and all others should be black-outlined
handles.

Align right

Aligns all selected components so that their right edges line up.

This option is available only when multiple components are selected. To
select multiple components, CTRL-click the components you want to align.

Components line up with whichever component has solid black squares for
handles. To select the component which the other components should line up
with, after selecting all components to be aligned (by CTRL-clicking them),
click the one you want the others to line up with. The handles of this
component should be solid black, and all others should be black-outlined
handles.

Align top

Aligns all selected components so that their top edges line up.

This option is available only when multiple components are selected. To
select multiple components, CTRL-click the components you want to align.

Components line up with whichever component has solid black squares for
handles. To select the component which the other components should line up
with, after selecting all components to be aligned (by CTRL-clicking them),
click the one you want the others to line up with. The handles of this
component should be solid black, and all others should be black-outlined
handles.

Align middle

Aligns all selected components so that their vertical middles line up.

This option is available only when multiple components are selected. To
select multiple components, CTRL-click the components you want to align.

Components line up with whichever component has solid black squares for
handles. To select the component which the other components should line up
with, after selecting all components to be aligned (by CTRL-clicking them),
click the one you want the others to line up with. The handles of this
component should be solid black, and all others should be black-outlined
handles.

Align bottom

Aligns all selected components so that their bottom edges line up.

This option is available only when multiple components are selected. To
select multiple components, CTRL-click the components you want to align.

Components line up with whichever component has solid black squares for
handles. To select the component which the other components should line up
with, after selecting all components to be aligned (by CTRL-clicking them),
click the one you want the others to line up with. The handles of this
component should be solid black, and all others should be black-outlined
handles.
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Align width

Resizes all selected components so that they are the same width.

This option is available only when multiple components are selected. To
select multiple components, CTRL-click the components you want to align.

Components resize to whichever component has solid black squares for
handles. To select the component which the other components should resize
to, after selecting all components to be resized (by CTRL-clicking them), click
the one you want the others to resize to. The handles of this component
should be solid black, and all others should be black-outlined handles.

Align height

Resizes all selected components so that they are the same height.

This option is available only when multiple components are selected. To
select multiple components, CTRL-click the components you want to align.

Components resize to whichever component has solid black squares for
handles. To select the component which the other components should resize
to, after selecting all components to be resized (by CTRL-clicking them), click
the one you want the others to resize to. The handles of this component
should be solid black, and all others should be black-outlined handles.

Same size

Resizes all selected components so that they are the same size.

This option is available only when multiple components are selected. To
select multiple components, CTRL-click the components you want to align.

Components resize to whichever component has solid black squares for
handles. To select the component which the other components should resize
to, after selecting all components to be resized (by CTRL-clicking them), click
the one you want the others to resize to. The handles of this component
should be solid black, and all others should be black-outlined handles.

Space
horizontally

Moves selected components so that they are evenly spaced within the
horizontal boundaries. This option uses the left edge of the left-most
component and the right edge of the right-most component as the horizontal
boundaries. It moves only the inner components, leaving the outer two
components where they are.

This option works only when three or more components are selected. To
select multiple components, CTRL-click the components you want to align.

Space vertically

Moves selected components so that they are evenly spaced within the
vertical boundaries. This option uses the top edge of the top-most component
and the bottom edge of the bottom-most component as the vertical
boundaries. It moves only the inner components, leaving the outer two
components where they are.

This option works only when three or more components are selected. To
select multiple components, CTRL-click the components you want to align.
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Arrange Arranges all selected components, stacking them vertically.
vertically

Arrange Arranges all selected components horizontally.

horizontally

Bring to front

Brings the selected components to the front, effectively placing them on top of
other, overlapping components. This ensures that the selected components
can be seen.

Send to back

Sends the selected components to the back, effectively placing them
underneath other, overlapping components. This means that all or part of the
selected components might be hidden.

Tab order

Allows you to set the tab order for the components on the form.
This option resets all components selected, starting with order number O.

Tab order at

Allows you to set the tab order for components from a selected component
on.

This option resets only the components starting with the first one you select.
The order of all components to that point does not change.

Undo Undoes the previous design action.
To undo multiple actions, click this button repeatedly.
Redo Repeats a design action that has been undone.

To redo multiple actions, click this button repeatedly.

171






Themes

About Themes

At their most basic level, themes affect the look and feel of SyteLine. You can create your own
themes or use one of the two system themes that are supplied. You can change the look of these
components:

e Button

e CheckBox

e ComboBox

e CriticalNumber

e DataView

e DatePicker

e DroplList
o Edit
e Grid

e GridColumn
e GroupBox
e HyperLinkButton

e ListBox

e Notebook

¢ RadioButton
e Static

e TreeControl
e VerticalGrid
e VerticalGridElement

What can be changed for each component is different, and you can see what can be changed in the
Theme Editor. Attributes that can be changed include but are not limited to text and background
color and font family, size and style.

In the Theme Editor, you can also determine the Explorer style, the group box style, the notebook
style, and whether there is a required field indicator.

System Themes

The application ships with these themes:
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e Infor: This theme is the more current of the two themes. Notable aspects include just three
menu choices in the menu bar and required fields that are identified with a red asterisk. Menus
that used to be in the menu bar in previous versions are now listed under the System menu.

e Classic: This theme provides the look and feel of previous versions. More menu choices are
available in the menu bar, and required fields have a yellow background.

You can edit these themes, but you cannot delete them.

Theme Editor

Use the Theme Editor to create new themes or edit existing ones. You can also copy an existing
theme. For more information, see Theme Editor.
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